After July 2021, the 2.3.x release line will no longer receive quality fixes, or user guide updates. PHP 7.3 reaches end of support in December 2021 and Adobe Commerce 2.3.x reaches end of support in April 2022. We strongly recommend planning your upgrade now to Adobe Commerce 2.4.x and PHP 7.4.x to help maintain PCI compliance.

Developer Client Restrictions

Before using a tool such as Template Path Hints, make sure to add your IP address to the Developer Client Restrictions allow list to avoid disrupting the shopping experience of customers in the store. If you don’t know your IP address, you can search for it online.

Developer Client Restrictions can be set in Developer Mode only.

For technical information, see Custom VCL for allowing requests in the developer documentation.

Add your IP address to the allow list

  1. On the Admin sidebar, go to Stores > Settings > Configuration.

  2. In the left panel, expand Advanced and choose Developer.

  3. Expand Expansion selector the Developer Client Restrictions section.

    Advanced configuration - developer client restrictions Developer Client Restrictions

  4. For Allow IPs, enter your IP address.

    If access is needed from multiple IP addresses, separate each with a comma.

  5. When complete, click Save Config.

  6. When prompted, refresh any invalid caches.