Contents

GETTING STARTED .............................................................................................................. 1

Introduction ......................................................................................................................... 2

CHAPTER 1: Welcome to Magento ...................................................................................... 3

Resources .............................................................................................................................. 4

Join the Conversation! ............................................................................................................ 7

CHAPTER 2: About This Release ......................................................................................... 9

System Requirements ......................................................................................................... 10

Installing Magento ............................................................................................................. 11

Part I: Magento Installation ............................................................................................... 12

Part II: Magento Installation ............................................................................................... 20

Reinstalling Magento ......................................................................................................... 25

Using a Staging Environment ............................................................................................... 25

Prelaunch Checklist ............................................................................................................. 26

CHAPTER 3: Your Magento Account .................................................................................... 29

Sharing Your Account ......................................................................................................... 32

CHAPTER 4: Quick Tour ...................................................................................................... 35

Customer Journey ............................................................................................................... 36

Attract New Customers ........................................................................................................ 38

Engage Your Customers ....................................................................................................... 39

Increase Average Order Value (AOV) .................................................................................. 41

Moment of Purchase ............................................................................................................ 42

Customer Retention ............................................................................................................. 43

Loyalty & Advocacy .............................................................................................................. 44
CHAPTER 9: Industry Compliance ................................................................. 111
   PCI Compliance Guidelines ................................................................. 112
   Privacy Policy ...................................................................................... 113
   Cookie Law Compliance ..................................................................... 114
      Cookie Restriction Mode ................................................................. 115
      Cookie Reference ........................................................................... 119

CHAPTER 10: Navigation ........................................................................ 123
   Top Navigation .................................................................................... 124
   Breadcrumb Trail ............................................................................... 125
   Product Listings .................................................................................. 126
      Pagination Controls ........................................................................ 128
   Layered Navigation ............................................................................ 130
      Filterable Attributes ....................................................................... 132
      Price Navigation ............................................................................ 134

CHAPTER 11: Categories ......................................................................... 137
   Category Levels .................................................................................. 138
   Creating Categories ............................................................................ 139
      Modifying Categories ...................................................................... 142
   Root Categories .................................................................................. 143
   Hidden Categories .............................................................................. 145
   General Information ........................................................................... 146
<table>
<thead>
<tr>
<th>Chapter 12: Attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attribute Input Types</td>
</tr>
<tr>
<td>Date &amp; Time Custom Options</td>
</tr>
<tr>
<td>Creating Attributes</td>
</tr>
<tr>
<td>Deleting Attributes</td>
</tr>
<tr>
<td>Creating an Attribute Set</td>
</tr>
<tr>
<td>Attribute Quick Reference</td>
</tr>
<tr>
<td>Attribute Properties</td>
</tr>
<tr>
<td>Attribute Frontend Properties</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 13: Flat Catalog</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setting Up a Flat Catalog</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 14: Creating Products</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product Types</td>
</tr>
<tr>
<td>Simple Product</td>
</tr>
<tr>
<td>Grouped Product</td>
</tr>
<tr>
<td>Configurable Product</td>
</tr>
<tr>
<td>Virtual Product</td>
</tr>
<tr>
<td>Bundle Product</td>
</tr>
<tr>
<td>Downloadable Product</td>
</tr>
<tr>
<td>Downloadable Product Options</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 15: Product Images</th>
</tr>
</thead>
<tbody>
<tr>
<td>Thumbnail Gallery</td>
</tr>
<tr>
<td>Light Boxes and Sliders</td>
</tr>
<tr>
<td>Image Zoom</td>
</tr>
<tr>
<td>Image Size and Type</td>
</tr>
<tr>
<td>Adding Product Images</td>
</tr>
<tr>
<td>Placeholders</td>
</tr>
</tbody>
</table>
## CHAPTER 19: Product Information

### General

### Product Meta Data

### Recurring Profile

### Design

### Gift Options

### Websites

### Categories

### Related Products

### Up-sells

### Cross-sells

### Custom Options

## MARKETING

## CHAPTER 20: Promotions

### Catalog Price Rules

### Price Rule with Multiple SKUs

### Shopping Cart Price Rules

### Coupon Codes

#### Auto-Generated Coupon Codes

### Coupon Report

### Free Shipping Promotion

### Buy X Get Y Free

### Discount with Minimum Purchase
Contents

Design .................................................................................. 497

CHAPTER 35: Page Layout ....................................................... 499
  Standard Layouts .................................................................. 500
  Storefront Examples .......................................................... 502
  Layout Updates .................................................................. 505
    Placing a Block with a Layout Update .............................. 506
    Controlling Block Order ............................................... 507
    Standard Block Layout .................................................. 508
    Layout Update Syntax ................................................... 510
    Layout Update Examples ............................................... 513
    XML Load Sequence .................................................... 516

CHAPTER 36: Page Setup ......................................................... 517
  HTML Head ...................................................................... 518
  Header ............................................................................. 520
  Footer ............................................................................. 521

CHAPTER 37: Your Store’s Theme ........................................... 523
  Design Packages ............................................................. 524
  Theme Assets .................................................................... 526
    CSS Settings .................................................................. 528
    JavaScript Settings ...................................................... 528
  Responsive Design .......................................................... 529
    Using the Default Theme .............................................. 530
  Installing a New Theme ................................................... 532
  Changing UI Text ............................................................ 535
CUSTOMERS ............................................................................. 539

CHAPTER 38: Customer Accounts .................................................. 541
  Customer Account Login .......................................................... 542
  Account Dashboard .............................................................. 543
  Account Configuration ......................................................... 545
    Customer Account Scope .................................................. 545
    Login Landing Page ......................................................... 546
    Name and Address Options ............................................. 547
      Customer Address Templates ....................................... 549
    Password Options .......................................................... 551

CHAPTER 39: Customer Groups ..................................................... 553
  Creating a Customer Group .................................................. 554

SALES ....................................................................................... 555

CHAPTER 40: Shopping Cart .......................................................... 557
  Cart Configuration .............................................................. 558
  Redirect to Cart ............................................................... 558
  Quote Lifetime ................................................................. 559
  Minimum Order ................................................................ 560
  Shopping Cart Thumbnails ................................................ 562
  My Cart Link ...................................................................... 564
  Mini Cart ........................................................................... 565
  Persistent Shopping Cart ..................................................... 566
    Types of Cookies .......................................................... 566
    Persistent Cart Workflow .............................................. 567
    Persistent Cart Configuration ....................................... 569

CHAPTER 41: Shopping Assistance ................................................ 573
  Online Customers .............................................................. 574
Payments .................................................................635

CHAPTER 47: Basic Payment Methods .................................637
  Merchant Location ......................................................638
  Bank Transfer Payment ..............................................639
  Cash On Delivery .......................................................641
  Check / Money Order ..................................................643
  Purchase Order ..........................................................645
  Zero Subtotal Checkout ................................................647
  Saved Credit Cards .....................................................649

CHAPTER 48: PayPal Payment Solutions ..............................651
  Overview .................................................................652
  PayPal Business Account .............................................654
  PayPal Credit ............................................................655
  PayPal Payments Advanced ..........................................658
    Requirements .........................................................659
    Setting Up PayPal Payments Advanced ...........................659
  PayPal Payments Pro ................................................660
    Requirements ..........................................................661
    Setting Up PayPal Payments Pro ...................................661
  PayPal Payments Standard ...........................................662
    Requirements ..........................................................662
    Setting Up PayPal Payments Standard ............................662
  PayPal Express Checkout ............................................663
    Requirements ..........................................................664
    Setting Up PayPal Express Checkout ...............................664
  Save Customer Billing Address .....................................675
    Billing Address Workflow .........................................675
Updating Currency Rates .................................................................828

CHAPTER 60: Managing Email Templates .............................................831

Supported Email Clients .................................................................832
Email Template Layout and Styles ....................................................834
  Inline and Non-Inline Styles .........................................................834
  Preparing Your Email Logo ........................................................835
  Supported File Formats ..............................................................835
  Image Size ...............................................................................835
Magento Upgrades .........................................................................836
Updating Default Templates ............................................................837
Creating Custom Templates ............................................................841
  Email Header ...........................................................................842
  Email Footer ...........................................................................847
  Email Body ..............................................................................850
  Update the System Configuration ..............................................854
Email Template Configuration ........................................................856
Email Template Reference ..............................................................858

CHAPTER 61: Managing Data Transfer ................................................859

Working with CSV Files .................................................................860
  Product CSV Structure ...............................................................860
  Customer CSV Structure ............................................................861
Importing Data ................................................................................863
  Importing Product Images ..........................................................864
  Import Guidelines .....................................................................866
Exporting Data ...............................................................................868
Dataflow .......................................................................................870

CHAPTER 62: Admin Permissions .......................................................877

Creating New Users .......................................................................878
Creating Custom Roles ..................................................................880
REST Roles ...................................................................................882
Content Permissions .....................................................................883
<table>
<thead>
<tr>
<th>Chapter Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Installing Extensions</td>
<td>927</td>
</tr>
<tr>
<td><strong>CHAPTER 68: Web Services</strong></td>
<td>929</td>
</tr>
<tr>
<td>Magento Core API Settings</td>
<td>930</td>
</tr>
<tr>
<td>Activating Web Services</td>
<td>931</td>
</tr>
<tr>
<td><strong>CHAPTER 69: System Tools</strong></td>
<td>933</td>
</tr>
<tr>
<td>Server Backups &amp; Rollback</td>
<td>934</td>
</tr>
<tr>
<td>Best Practices</td>
<td>934</td>
</tr>
<tr>
<td>Creating a Backup</td>
<td>935</td>
</tr>
<tr>
<td>Rolling Back Changes</td>
<td>937</td>
</tr>
<tr>
<td>Installing Magento Patches</td>
<td>938</td>
</tr>
<tr>
<td>Installing Patches with SSH</td>
<td>942</td>
</tr>
<tr>
<td>Compilation</td>
<td>957</td>
</tr>
<tr>
<td>System Log</td>
<td>958</td>
</tr>
<tr>
<td>System Log Cleaning</td>
<td>958</td>
</tr>
<tr>
<td>Cron (Scheduled Tasks)</td>
<td>960</td>
</tr>
<tr>
<td>Magento Test Framework</td>
<td>962</td>
</tr>
<tr>
<td>Requirements</td>
<td>963</td>
</tr>
<tr>
<td>Installation</td>
<td>964</td>
</tr>
<tr>
<td>Configuration</td>
<td>965</td>
</tr>
<tr>
<td>Non-Firefox Browsers</td>
<td>965</td>
</tr>
<tr>
<td>Magento URLs</td>
<td>965</td>
</tr>
<tr>
<td>Magento URLs</td>
<td>965</td>
</tr>
<tr>
<td>Configuration Reference</td>
<td>966</td>
</tr>
<tr>
<td><strong>CHAPTER 70: Configuration</strong></td>
<td>975</td>
</tr>
</tbody>
</table>
APPENDICES .................................................................................................................. 977

APPENDIX A: Release Notes ......................................................................................... 979
APPENDIX B: Change Log ............................................................................................. 981
APPENDIX C: Documentation Archive ........................................................................... 983
APPENDIX D: Glossary ................................................................................................ 985
APPENDIX E: Configuration Reference ......................................................................... 997

INDEX ................................................................................................................................ 999
About this Guide

This guide answers the “why, where, and how” questions that most merchants have when learning to use Magento. You’ll find lots of step-by-step instructions, screenshots and examples, plus a comprehensive configuration reference that is linked throughout the material. After learning the basics, you can use this guide as a springboard into more advanced topics and resources.

Online User Guide

This online user guide is our primary documentation, and is continually updated with new topics, changes to existing content, and improvements in the way the material is presented. Some changes are in response to feedback we receive from our readers. To ensure that you see the latest content, set your browser to check for updates on each page that you visit. Make sure to check the Change Log often to see what’s new!

PDF User Guide

You’ll find the same great information in both the online (HTML) and offline (PDF) user guides, so you can use the format you prefer. Simply click the link to open the PDF in your browser. You can also right-click the download link to save the file to your computer. The Documentation Archive at the end of this guide has PDF download links for each major version of the product. Updated: 05/26/2016
Introduction

This section of the guide provides an overview of the resources that are available to you as a member of the Magento community. You’ll learn about the current release, and how to log into your Magento account. Finally, you’ll take a guided tour of Magento from two different perspectives, with links you can explore to learn more about each topic.
CHAPTER 1:

Welcome to Magento

Magento Community Edition is a feature-rich eCommerce platform, built on open-source technology that provides online merchants with unparalleled flexibility and control over the look, content, and functionality of their eCommerce store. Magento's intuitive Admin features powerful marketing, search engine optimization, and catalog management tools to give merchants the power to create sites that are tailored to their unique business needs. Designed to be completely scalable, Magento CE offers companies a stable, secure, customizable eCommerce solution.
Resources

Magento provides a wealth of business and technical resources, self-help tools, and services to help you succeed.

**Product Documentation**

Whether you’re a merchant, designer, developer, or all of the above, this is where you’ll gain a deeper insight into how you can leverage the power of Magento to grow your business.

**Magento Resources Library**

Gain access to expert insight and online business resources to help develop and improve the effectiveness of your store.

**Security Center**

Join Magento’s Security Alert Registry to get the latest information on potential vulnerabilities and Security Best Practices.

**Forums**

The Magento forums provide access to a network of dedicated Magento enthusiasts who share tips, tricks and support.
Blog

Check out the Magento blog for the latest information about new features, trends, best practices, upcoming events, and more!

Webinars

Don't worry if you miss a live webinar! You can find the archived version here.

Video Archive

Catch up and review archived sessions from Imagine 2016!

Events

Keep tabs on our calendar of upcoming events. There's always something happening in the Magento ecosystem!
Magento Marketplace

Visit Magento’s next-generation marketplace of digital commerce solutions. Magento Marketplace offers merchants a curated selection of solutions, while providing qualified developers the tools, platform, and prime location for a thriving business.

Training & Certification

Learn how to unleash the power and flexibility of Magento. We provide training for every role in your business, including marketers, designers, developers, and more. Experienced Magento professionals can validate their real-world skills by earning Magento certification.

Partners

Magento partners are committed to your success, and provide custom integrations, best-in-class customer experiences, strategic marketing initiatives, and expert performance and scalability optimization for both on-premise and cloud-based solutions.

Expert Consulting Services

Our Expert Consulting Group (ECG) helps Magento merchants and Solution Partners maximize their success. Our experts offer comprehensive analysis and best practice recommendations, from architecture planning through post-deployment.
Join the Conversation!

Keep up with the latest news from the ecosystem, and connect with other merchants and developers on social media networks.

Magento Forums

This is the place to find solutions, become acquainted with international communities, and join a special interest chat! Share your knowledge and earn kudos from others!

Facebook

Find out what’s happening and join the discussion on our Facebook page!

Twitter

Follow us on Twitter!

LinkedIn

Join a Magento group on LinkedIn.
Google+
Add us to your circle on Google+.

YouTube
Learn while you watch videos on our YouTube channel!

Meetup
Find a Magento Meetup near you!
CHAPTER 2:

About This Release

We are pleased to bring to you Magento Community Edition version 1.9.2.4, which addresses issues reported by our merchants after installing the latest patch SUPEE-7405, or Magento Community Edition Release 1.9.2.3. To learn more, see the Release Notes at the end of this guide.

Important! Use Magento Community 1.9.2.4 or later for all new installations and upgrades to ensure that you get the latest fixes, features, and security updates.
# System Requirements

## STANDARD SYSTEM REQUIREMENTS

<table>
<thead>
<tr>
<th>Environment</th>
<th>LAMP (Linux, Apache, MySQL, and PHP) or LNMP stack</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating System</td>
<td>Linux x86, x86-64</td>
</tr>
<tr>
<td>Web Server</td>
<td>Apache 2.x</td>
</tr>
<tr>
<td></td>
<td>Nginx 1.7.x</td>
</tr>
<tr>
<td>Server Hosting</td>
<td>Ability to run scheduled jobs (crontab) with PHP 5.</td>
</tr>
<tr>
<td></td>
<td>Ability to override options in .htaccess files.</td>
</tr>
<tr>
<td>PHP</td>
<td>PHP 5.4</td>
</tr>
<tr>
<td></td>
<td>PHP 5.5</td>
</tr>
<tr>
<td>Required extensions:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>PDO_MySQL</td>
</tr>
<tr>
<td></td>
<td>simplexml</td>
</tr>
<tr>
<td></td>
<td>mcrypt</td>
</tr>
<tr>
<td></td>
<td>hash</td>
</tr>
<tr>
<td></td>
<td>GD</td>
</tr>
<tr>
<td></td>
<td>DOM</td>
</tr>
<tr>
<td></td>
<td>iconv</td>
</tr>
<tr>
<td></td>
<td>curl</td>
</tr>
<tr>
<td></td>
<td>SOAP (for Webservices API)</td>
</tr>
<tr>
<td>Additional configuration:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>safe_mode off</td>
</tr>
<tr>
<td></td>
<td>memory_limit no less than 256 MB (512 MB recommended)</td>
</tr>
<tr>
<td>Database</td>
<td>MySQL 5.6 (Oracle or Percona)</td>
</tr>
<tr>
<td>SSL</td>
<td>A valid security certificate is required for HTTPS. Self-signed certificates are not supported. We recommend if possible to run both the storefront and Admin on HTTPS.</td>
</tr>
<tr>
<td>Supported Technologies</td>
<td></td>
</tr>
<tr>
<td>Redis</td>
<td>Redis can be used for session or cache storage.</td>
</tr>
<tr>
<td>Memcached</td>
<td>Memcached can be used for session or cache storage.</td>
</tr>
</tbody>
</table>

See also the System Requirements on our site.
Installing Magento

Magento Community Edition is open source software and can be downloaded for free. Developers can modify the core code and add features and functionality by installing extensions from the Magento Connect marketplace.

Because Magento does not provide technical support for this software, you can benefit from the knowledge of experts in the community for help with the installation and configuration. Answers to many technical questions can be found on our user forum.

After you verify that your hosting environment meets the system requirements, you can download Magento Community Edition free of charge from the Magento community site. Although optional, we recommend that you register on our site so you have access to the forums, wiki, groups, screencasts, and other resources the community has to offer.

Magento Community Edition is licensed under the Open Software License (OSL) v3.0, an open source certified license. To learn more, see the License / Trademark FAQ on our site.
Part I: Magento Installation

During the first part of the installation, you will download the scripts and sample data files needed to install Magento. You will also set up permissions on the server, and create a new database.

Process Overview:
Step 1: Download the Magento CE Downloader Script
Step 2: Download the Sample Data
Step 3: Upload the Downloader Script to Your Server
Step 4: Grant File Access Permissions
Step 5: Set Up the Store Database
Step 6: Upload the Sample Data to Your Server
Step 7: Run the Magento CE Downloader
**Step 1: Download the Magento CE Downloader Script**

1. Go to the Magento Community Edition download page.

2. In the Downloader section, select one of the following formats for the archived downloader. The archive file name is: `magento-downloader-x.x.x.zip` (or `.tar.gz`, or `.tar.bz2`). The size of the archive is approximately 46K.
   - `.zip`
   - `.tar.gz`
   - `.tar.bz2`

3. Click the **Download** button. While the file is downloading, take a moment to look over the resources on the Magento Community page.

4. Extract the archive to a directory of your choice on your local computer. The name of the extracted file is: `downloader.php`

**Step 2: Download the Sample Data**

Magento provides sample data with examples of products and basic content pages to help you get started. When you are ready to build your own catalog, you can reinstall Magento without the sample data. This step is recommended, but is not required.

1. In the Sample Data section, **Select your format** for the archived sample data.

2. Click the **Download** button, and **Save** the file anywhere on your local computer. The file name is: `magento-sample-data-x.x.x.zip` (or `.tar.gz`, or `.tar.bz2`). The size of the archive is approximately 10MB.

Magento provides sample data with examples of products and basic content pages to help you get started. When you are ready to build your own catalog, you can reinstall Magento without the sample data. This step is recommended, but is not required.

![Sample Data Download](image)

**Step 3: Upload the Downloader Script to Your Server**

Use an SFTP tool to copy the extracted downloader script to the root `www` directory of the server. (The root `www` directory is usually named `public_html`.) As an alternative, you can copy the file to another subdirectory, such as `/store`. 
Step 4: Grant File Access Permissions

For the Magento Installer to work correctly, the top-level Magento directory on the server, and all directories beneath it must have correct permissions. To learn more, see the Knowledge Base article: Recommended File System Ownership and Privileges.

Step 5: Set Up the Store Database

1. Create a new, empty database using one of the following methods:
   - Use phpMyAdmin or a similar tool provided by your hosting company. For instructions, see the documentation for the specific tool.
   - MySQL command line

2. Create a new user with full permissions to the database. Then, write down the following information:

   - **dbname**: The database name.
   - **dbuser**: The name of the database user.
   - **dbpassword**: The password for the database user.

Step 6: Upload the Sample Data to Your Server

If you want to use the sample data, it must be installed now. If you are ready to add your own products, skip this step. You can use either of the following methods to install the sample data:

**Method 1: FTP or SFTP**

1. Extract the sample data archive that you downloaded in Step 2, to a directory of your choice on your local computer. The file name is similar to: magento_sample_data_for_x.x.x.sql.

   The archive contains an SQL script with a dump of the sample data, and a media/catalog folder with category and product images.

2. Use an FTP or SFTP tool to copy the media folder and its subdirectories from your local computer to the magento installation directory on the server. Depending on your server, the path will look something like this:

   ```
   /var/www.magento/media
   /var/www/html/magento/media
   ```
3. Use an FTP or SFTP tool to copy the magento sample data script to the server. A good place to put it is in the media/catalog folder.

/var/www/magento/media/catalog
/var/www/html/magento/media/catalog

4. Do one of the following:
   - Use phpMyAdmin, or a similar tool to run the sample data script and import the data into the new database.
   - On the command line, enter the following:

     ```
     mysql -u <root user> -p <magento-db-name> < <path-and-filename of db-script>
     ```

**Method 2: Command Line**

If you prefer to install the sample data from the command line, see this Knowledge Base article, under the heading: Installing Optional Sample Data.

You’re ready to install Magento!

**Step 7: Run the Magento CE Downloader**

1. From your browser, navigate to the location of the Magento downloader on your server. The Magento Downloader welcome page appears.

2. To validate your server environment, click the Continue button. If error warnings appear, correct the errors and click the Check Again button.
3. When you pass the validation test, do the following:
   a. Enter the following **Database Connection** information:
      - Host
      - User Name
      - User Password

   ![Database Connection](image)

   **Database Connection**
   b. Click the **Check InnoDB** button to confirm the connection.
   c. When you receive confirmation that the credentials are valid, click the **Continue** button.

4. On the Magento Connect Manager Deployment page, do the following:
Magento Connect Manager Deployment

a. In the Loader Protocol section, set **Magento Connect Channel Protocol** to one of the following:

HTTP  
(Recommended) HTTP is faster than FTP.

FTP  
Choose FTP if outgoing connections are not allowed in your hosting environment.

b. In the Stability section, set **Magento Connect Manager Version Stability** to “Stable.”

c. In the Deployment Type section, select one of the following:
FTP Connection

(Recommended) FTP allows you to upload files to the server without changing read/write/execute permissions. After choosing FTP connection, complete the following with information provided by your FTP server administrator:

- **Host Name**: Enter the host name of the FTP server.

- **Credentials**: Enter the FTP credentials provided by your FTP server administrator.

- **Installation Path**: Enter the path where Magento CE will be installed. The installation path points to the same directory that contains the downloader.php file.

Local Filesystem

Deploying through the local file system requires the Apache account permissions to be changed. When the installation is complete, contact your server administrator to update the file permissions.

If the web server user can't write to the magento directory, do not proceed. It's most likely an ownership issue, rather than a permissions issue.

d. To verify the connection, click the **Check FTP** button. You will not be able to continue if any of the deployment parameters are invalid. After the FTP connection is verified, click the **Continue** button.

5. When the Magento Installation Wizard appears, do the following:
a. Set **Magento Connect Channel Protocol** to the same protocol you selected in the previous step. (Options include: HTTP/FTP)

b. Custom permissions determine how read, write, and execute permissions are applied to the downloaded folders and files. Set **Use Custom Permissions** to one of the following:

   Yes  
   The Magento CE administrator can execute, write, and read files in the downloaded folders. In the Folders and Files fields that appear, specify values in the octal number system to denote the permissions that the Magento administrator has for folders and files on the server.

   No  
   Custom permissions are not specified for downloaded folders and files. In this case the system default values are used:
   0777  
   Folder permissions to read, write, and execute.
   0666  
   File permissions to read and write.

c. Set **Deployment Type** to the type specified in the previous step. (Options include: Local Filesystem/FTP)

d. When you are ready, click the **Start the Download Process** button.

e. When the "Download completed" message appears, click the **Continue to Magento Installation** button.

   If you were unable to complete the download process due to a connection error, try to upload the Full Magento Package from the Community download page.

6. Complete **Part II** of the installation.
Part II: Magento Installation

During the second part of the Magento installation, you will complete the initial configuration, and create an admin account.

Process Overview:
Step 1: Run Setup
Step 2: License Agreement
Step 3: Localization
Step 4: Configuration
Step 5: Create an Admin Account

Step 1: Run Setup

From your browser, enter the path to your Magento installation. Depending on the installation location, it is similar to one of the following:

- http://[your_domain]/magento
- http://www.[your_domain]/magento
- http://www.[your_domain]/[directory]/magento

Step 2: License Agreement

Read the terms of the Magento Community Edition End User License Agreement. If you agree to the terms, click the Continue button.
Step 3: Localization

Select the default localization settings for your Magento CE installation. The values can be changed later for specific stores, store views, and websites.

- Locale
- Time Zone
- Default Currency

![Locale Settings]

Step 4: Configuration

1. In the Database Connection section, do the following:
   a. Set **Database Type** to “MySQL.”
   b. In the **Host** field, enter the server’s fully qualified host name or IP address. If your database server is on the same host as your web server, enter “localhost.”
   c. Refer to the database credentials from Part 1: Step 5, and enter the following:
      - Database Name
      - User Name
      - User Password
   d. (Optional) The Table prefix is used when there are multiple instances of Magento that share a single database.

![Database Connection]
2. In the Web Access Options section, do the following:
   a. Enter the **Base URL** for the Magento store.
   b. In the **Admin Path** filed, enter the base URL for the store’s Admin Panel. (The default value is “admin.”)
   c. To display charts in the Dashboard, select the **Enable Charts** checkbox.
   d. If you are installing Magento to a development or test environment, and the Web server is not verifiable, select the **Skip Base URL Validation Before the Next Step** checkbox. Otherwise, leave the checkbox unselected.
   e. (Recommended) To enable the Apache mod_rewrite module, select the **Use Web Server (Apache) Rewrites** checkbox. To learn more, see the Knowledge Base article: Installing and Configuring Required Prerequisite Software.
   f. (Recommended) If your server has a valid security certificate, select the **Use Secure URLs (SSL)** checkbox. Then, complete the following:
      - **Secure Base URL**: Enter the complete base URL for the SSL connection.
      - **Run the Admin Interface with SSL**: Select the checkbox to run the store admin on the secure channel.

   These initial SSL settings can be modified later.

3. In the Session Storage Options section, set **Save Session Data In** to one of the following:
FileSystem Stores user session data on the filesystem in the magento-install-dir/var/session directory. File-based session storage is the most common configuration.

Database Stores user session data in the database. Choose database storage for a clustered database, or if system access is slow.

4. When the Configuration settings are complete, click the Continue button.

Step 5: Create an Admin Account

1. In the Personal Information section, enter the following:
   - First Name
   - Last Name
   - Email

![Personal Information](image)

2. In the Login Information section, do the following:
   a. Enter the Username you of the owner of the Magento store.
   b. Enter the Password that is associated with your Admin account. To confirm, enter it again in the Confirm Password field.

![Login Information](image)

3. (Optional) If you already have one, enter the Encryption Key. Otherwise, Magento will generate one for you.

The encryption key protects sensitive data such as passwords and personally identifiable customer information. The encryption key is stored on the server at: /app/etc/local.xml

**Important!** When Magento generates your encryption key, write it down and keep it in a safe place. If you ever move your data to another Magento CE site, you will need the encryption key to recover the data.
4. Click the **Continue** button, and you’re all set!
   - To explore your new store, click the **Go to Frontend** button.
   - To explore your store’s admin, click the **Go to Backend** button.
Reinstalling Magento

If you want to repeat the installation of Magento Community Edition on the same server, it is not necessary to download the files again.

To reinstall Magento:

1. On the server, delete the file: app/etc/local.xml
2. Delete any files and directories found in: var/
3. With your browser, navigate to your Magento directory. For example:

   http://www.yourDomain.com/magento-directory

The Magento Installation Wizard launches automatically.

Using a Staging Environment

If you plan to develop your store over a period of time, we recommend that you set up a staging environment where you can test changes before applying them to the live store.

A staging environment is just like any other Magento installation, but is not accessible to the public. You can use a version control tool to keep files synchronized between the staging environment and the live store. We highly recommend that you use a staging environment to test extensions and before updating your live store to a new version of Magento Community Edition.
Pre-launch Checklist

After you complete the design, development, and testing of your store, check the following configuration settings to make sure everything is correct before the store “goes live.” For a comprehensive description of every configuration setting, see the Configuration Reference.

General Settings

☑️ Unsecure URL
   Verify that the Base URL for the storefront is correct for the live environment.

☑️ Secure URL
   Before launching your store, install a 100% Signed and Trusted Security Certificate for the server that is using a Secure Base URL.

☑️ Store Email Addresses
   Complete all the email addresses that are used to send and receive email notifications, such as new orders, invoices, shipments, credit memos, product price alerts, newsletters, and so on. Make sure that each field contains a valid business email address.

Sales Settings

☑️ Sales Document Setup
   Make sure that your invoices and packing slips include the correct business information and reflect your brand.

☑️ Taxes
   Make sure that taxes are properly configured according to your business tax rules and local requirements.

☑️ Shipping Methods
   Enable all carriers and shipping methods to be used by the company.

☑️ Google API
   Magento is integrated with Google API to allow your business to use Google Merchant Center, Google Analytics, Google Sitemap, and Google Shopping. Make sure to set up a Google Merchant Account, and then verify and claim your website URL.

☑️ PayPal
   If you plan to offer your customers the convenience of paying with PayPal, open a PayPal Merchant Account, and set up a payment method. Run some test transactions in Sandbox Mode before the store goes live.

☑️ Payment Methods
   Enable the payment methods that you plan to use, and make sure that they are properly configured. Check the order status settings, accepted currency, allowed countries, and so on.
System Settings

**Cron**
Cron jobs are used to process email, catalog price rules, newsletters, customer alerts, Google sitemaps, update currency rates, the cleaning of database logs, and so on. Make sure that Cron jobs are set to run at the appropriate time interval, in minutes.

**Log Cleaning**
Log cleaning must be enabled to make sure that the database log tables are periodically cleaned. If you do not set this to clear your database log_tables, your database can grow very large when the store has a full traffic load. Set the number of days the log is saved according to your needs and server capacity.

**Transactional Emails**
Update the default email templates to reflect your brand. Make sure to update the configuration if you create new templates.
CHAPTER 3:

Your Magento Account

Your Magento account has a separate login from your store, and can be accessed from either the Magento website or from your store’s Admin. In the dashboard of your Magento account, you can find information that is related to the products and services that you have purchased, as well as your contact and billing information.
To create a Magento account:

1. Visit the Magento site: [http://www.magento.com](http://www.magento.com)
2. In the upper-right corner, click **My Account**.
3. Under New Customers, click **Register**. Then, do the following:

   ![Login or Create an Account](image_url)

   **Log In to Your Account**

   a. Enter your **First Name**, **Last Name**, and **Email Address**.
   
   b. Set **My Company Primarily** to the best description of what your company does. Then, set **My Role** to the best description of what you do for the company.
   
   c. Enter a **Screen Name** to identify you in the Magento forums.

   Your screen name can be from four to fifteen characters long, can include numbers and the underscore, but must start with a letter.

   d. Enter a **Password** for your account. Then, enter it again to confirm.

   Your password can be from eight to sixteen characters long, and must include at least one capital letter, one number, and one special character or one lowercase letter.

   e. When complete, click the **Submit** button. Your account dashboard appears.
To log in to your Magento account:

1. Navigate to the Magento site: http://www.magento.com
2. In the upper-right corner, click My Account.
3. Enter the Email address that is associated with your account. Then, enter your Password.
4. When complete, click the Login button.

To receive a new password:

1. If you forget your password, click Forgot Your Password? Then, enter the Email Address that is associated with your account.
2. Click the Submit button.
   You will receive an email from Magento with a temporary password that you can use to log into your account. Then, reset your password from the dashboard of your account.

To reset your password:

1. Log in to your Magento account.
2. In the panel on the left, select Account Settings. Then, click Change Password
3. Enter your Current Password.
   If you forgot your password, enter the temporary password that was sent to you.
4. Enter your New Password. Then, enter it again to confirm.
5. When complete, click the Submit button.
Sharing Your Account

Your Magento account contains information that can be useful to trusted employees and service providers who help to manage your site. As the primary account holder, you have authority to grant limited access to your account to other Magento account holders. When your account is shared, all sensitive information—such as your billing history or credit card information—remains protected. It is not shared at any time with other users.

All actions taken by users with shared access to your account are your sole responsibility. Magento Inc. is not responsible for any actions taken by users to whom you grant shared account access.

To set up a shared account:

1. Before you begin, get the following information from the new user’s Magento account:
   - Account ID
   - Email address

2. Log in to your Magento account.

3. In the My Account panel on the left, under Shared Access, click Add New User.

4. In the New User Information section, do the following:
   - Enter the Account ID of the new user’s Magento account.
   - Enter the Email address that is associated with the new user’s Magento account.
5. In the Shared Information section, do the following:
   
a. Enter a **Sharename** to identify your shared account. Because the Sharename becomes an option in the Switch Accounts list, it should be something that the other person will recognize as your account.

   b. To share your personal contact information, select the checkbox of each item that you want to make available to the other person:
      
      - Your Email
      - Your Phone

6. In the Grant Account Permissions section, select the checkbox of each item that you want to share.

7. When complete, click the **Create Shared Access** button.

   You are notified when the new role is saved, and the new user record appears in the Manage Users & Permissions section of the Shared Access page. Magento also sends an email invitation with instructions for accessing the shared account to the new user.

---

**Add a New User**

**To access a shared account:**

1. When you receive the invitation to a shared account, the first thing you must do is to log in to your own Magento account.

   Your account dashboard has a new Switch Accounts control in the upper-right corner, with options for “My Account” and the name of the shared account.

2. To gain access to the shared account, set **Switch Accounts** to the name of the shared account.
The shared account displays a welcome message and contact information. The left panel includes only the items that you have permission to use.

3. When you are ready to return to your own account, set **Switch Accounts** to “My Account.”
CHAPTER 4:

Quick Tour

This quick tour follows the customer-decision journey that leads to a purchase on an eCommerce site powered by Magento Community Edition. Each item is linked to a topic in this guide, where you can learn more about the subject. You can also follow along on your computer with the sample data. The journey begins with your storefront.

To access your storefront:

Use your browser to navigate to your store. Your URL might look like one of the following:

- http://www.yourdomain.com
- http://yourdomain.com

Home Page
Customer Journey

Attract New Customers

Magento Community Edition includes SEO functionality out of the box. Improve your search ranking and attract the most visitors to your site.

Engage Your Customers

Design your site with pre-designed templates, or create a custom design with features that invite people to interact with your store.

Increase AOV

Increase average order value with promotions and content that encourage your customers to shop more.
**Moment of Purchase**

Give your customers a faster and easier way to check out. Calculate shipping and taxes automatically, and integrate multiple payment methods on a single page.

**Customer Retention**

Create and manage newsletters and promotions to keep your customers coming back for more.

**Loyalty & Advocacy**

Encourage customers to write product reviews, create wishlists, and send email about products to their friends. This will strengthen your relationship with your customers, who in return, will speak positively of your business to friends and family.
Attract New Customers

Magento Community Edition is packed with features that make it easy to create a “search engine friendly” websites and increase the likelihood of bringing the right customers to your site.

Search Engine Optimization

Magento offers powerful, native capabilities to streamline Search Engine Optimization (SEO) practices for content and site exposure that are integrated with the Admin, and tied directly into the user experience.

Custom URLs

Custom URLs are short, clean, and easy to remember. You can also autogenerate search-friendly URLs to streamline your purchase path.

Meta Data

Improve your search engine rankings by choosing specific criteria that helps search engines to find and index your products more easily. Meta data can be entered for product, category, and content pages.

Sitemap

Link to a sitemap from the footer of your store to give customers an overview of the catalog structure, with links to all categories and products in the store. You can also easily integrate your store with Google Sitemap.

Analytics

In addition to monitoring your site from the Admin dashboard, you can integrate third-party analytics tools such as Google Analytics, for detailed statistics on traffic and sales.
Engage Your Customers

Magento Community Edition makes it easy to create a customized, engaging site experience. Encourage your customers to spend more time exploring your site, and give them the tools to make it easy to find what they want faster.

**Content Management System**

Magento’s CMS makes it easy to store pages, or parts of pages, that you can use in your store. It’s so intuitive that someone without a technology background can create and manage site content.

**Design & Theme**

Control the visual elements of your store with a collection of templates and skin files. You can apply these visual elements to all pages in your store, giving your store a cohesive look and feel.

**Multiple Stores, Sites & Views**

Control the look and feel of multiple sites, introduce new market and languages, and track analytics from a single Admin.

**Multiple Devices**

Magento’s powerful features make it easy to create storefronts optimized for iPhone, Android, and Mobile Opera browsers to help you engage consumers with mobile eCommerce now and into the future.
Shopping Tools

Your store includes a set of shopping tools that create opportunities for your customers to interact with your store, connect on social media, and share with friends.

Sophisticated Search

Filter product by price, manufacturer, or any other criteria to reduce the time to purchase.
Increase Average Order Value (AOV)

Magento Community Edition provides a range of tools to help you tailor the shopping experience, and encourage your customers to put more items in their shopping carts and spend more money.

Promotions

Magento’s catalog and shopping cart price rules let you create promotions that kick into gear when a set of conditions is met.

Coupons

Create limited-time offers and coupons that customers can scan with their phone and apply to a purchase.

Product Suggestions

Another way to increase AOV is to offer suggestions for related products and opportunities to up-sell and cross-sell at strategic points along the path to conversion.

User Permissions & Roles

Restrict access to data in the Admin on a “need to know” basis. Create multiple admin roles for read-only or and editing privileges. Track and review all activity at a granular level to specific stores and websites.
Moment of Purchase

Now that you’ve given your customer an engaging shopping experience, make it easy for them to complete their purchases. Magento is designed to help you streamline your checkout process experience while boosting conversion rates.

Order Processing

Magento supports a complete order processing workflow. It’s easy to customize order statuses and track communications between sales reps and customers.

Shipping Labels

Merchants have complete control over package characteristics such as weight and size. Shipping labels, rate, and barcode information originates directly from the carrier. Labels can be generated for single or multiple orders.

Multiple Shipping Options

Magento supports a variety of shipping methods so you can give your customers a choice at checkout. Customers can see a real-time estimate of shipping charges right from the shopping cart.

Multiple Payment Options

Magento Community Edition supports the payment methods and currencies needed for global commerce. You can choose the ones you want to offer, and at checkout, your customers can choose the ones they prefer.

PayPal Merchant Solutions

It’s easy to integrate a PayPal Payments account to provide your customers faster, more secure checkout options.

Assisted Shopping

Assisted shopping makes it easy for customer service reps to create orders for customers. Customer service reps have access to shopping cart contents, and can move items from a wishlist to a shopping cart, apply coupon codes, and more.

Security

Whether an order is fulfilled online or over the phone, Magento provides sophisticated security, including CAPTCHA and SSL encryption, with best-in-breed encryption and hashing algorithms to protect the security of the system.
Customer Retention

Magento makes it easy for you to get repeat business and build brand loyalty. Magento gives you total control and flexibility over creating and revising goodies like rewards programs, custom coupons and automated emails to keep your customers coming back again and again.

**Custom Coupons**

Create coupons codes for social media, email, or print campaigns. You can incorporate coupon codes into any design you like.

**Newsletters**

Stay in touch with current customers who’ve opted to receive newsletters. You can create as many newsletter templates as you want.
Loyalty & Advocacy

Give customers a direct connection to your brand by allowing them to create customer accounts where they can see their purchase history, wishlist, and newsletter subscriptions. Use product ratings and reviews to give new customers objective product opinions and promote a sense of community. These features turn customer satisfaction into one of the most powerful and cost-efficient marketing tools at your disposal.

Dashboard Snapshots

Knowing what’s of interest on your site is crucial to maximize your marketing budget. Use this information to determine what you should cross- and up-sell to loyal customers, or which products to put on sale.

Customer Accounts

Opening an account provides customers with a personalized shopping experience that they can share with their friends. Customers can save their shopping preferences, and manage their own store billing and shipping information.

Advocacy Tools

Customers who share their wishlists with family and friends make a powerful endorsement of your brand. Customers create these personalized lists from products they choose. When shared by email or RSS feed, these simple lists become powerful advocacy tools.

Reviews & Ratings

Product reviews give your customers a way to engage with your brand while fostering a sense of community. You can curate your reviews with tools to help you edit and approve comments for inappropriate content before they go live.
Success!

Opening your Magento store for business requires the following areas of consideration. While there are virtually any number of customizations you can make to the storefront and Admin, you can use each link in this list as a place to start.

**Implementation**

If you need help setting up your store, you can choose from our vast network of Magento Solutions Partners.

**Design**

You can design your own home page or work with an experienced Magento designer or Solutions Partner to customize your site.

**Product Catalog**

Configure products, create categories, import existing product catalogs, and leverage APIs or third-party data management solutions.

**Payment Methods**

Magento supports a wide variety of payment methods, services, and gateways that you can offer for your customers’ convenience.
Shipping Methods

Magento shipping methods are easy to set up and give you the ability to connect with carriers who can ship your products all over the world.

Taxes

Manage your taxes with our native tools, or add third-party extensions from Magento Connect.

Thanks for your order!

Magento can help you build relationships with your customers, to bring them back to your store, again and again.
Basic Configuration
Basic Configuration

The topics in this section provide an introduction to your store’s Admin, and walk you through the basic configuration settings. Along the way, you will learn the concepts of store hierarchy and configuration scope, and establish some best practices for meeting industry standards and requirements.

Store Admin
- Admin Login
- Message Inbox
- Admin Menu
- Admin Tools

Store Details
- Store Information
- Locale Options
- State Options
- Countries Options
- Currency
- Basic Shipping Settings
- Store Email Addresses
- Contact Us

Storefront Branding
- Uploading Your Logo
- Adding a Favicon
- Welcome Message
- Store Demo Notice
- Copyright Notice

Websites, Stores & Views
- Setting Up Store Hierarchy
- Configuration Scope
- Adding a Language
- Store URLs

Industry Compliance
- PCI Compliance
- Privacy Policy
- Cookie Law Compliance
CHAPTER 5:

Store Admin

Your store Admin is the password-protected back office where you can set up products, promotions, manage orders, and perform other administrative tasks. This chapter of the guide provides a high-level overview of management tasks and tools that you might use on a daily basis.
Admin Login

All of the basic configuration tasks are performed from the Magento Admin Panel, which is referred to in this guide as your store Admin. The initial Admin login credentials were set up during the Magento installation. For additional security, the Admin login can also be configured to require a CAPTCHA.

If you forget your user name or password, a temporary password can be sent to the email address that is associated with the account.

To log in to the Admin:

1. In the address bar of your browser, enter the URL that was specified during the Magento installation, followed by the base URL of your store's Admin. The default Admin URL looks like this:

   http://www.mystore.com/admin

   You can bookmark the Admin Login page for easy access.

2. Enter the **User Name** and **Password** for the Admin account.

3. Click the **Login** button.
To receive new login credentials:

1. If you forget your user name or password, click the **Forgot Your Password?** link.

2. Enter the **Email Address** that is associated with the Admin account.

3. Click the **Retrieve Password** button.

   If there is an account associated with the email address, an email will be sent to reset your password.
My Account

Your account information contains your login credentials and personal information that was initially entered during the Magento Setup. You can edit the account information, and also create additional Admin user accounts with various permission levels.

As a best practice, it’s good to have more than one Admin account with full permissions, so if you ever forget your password, you won’t be locked out of the Admin.

To edit your account information:

1. On the Admin menu, select System > My Account.
2. Make any changes necessary to the following:
   - User Name
   - First Name
   - Last Name
   - Email
3. To change your Admin password, do the following:
   a. Enter your Current Admin Password.
   b. Enter your New Password. To confirm, enter it again in the Password Confirmation field.
4. When complete, click the Save Account button.
5. Make sure to update your records so you don’t forget the new password. You will need it the next time you log in to the Admin.
## Field Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Name</td>
<td>The user name that is entered to log in to the Admin.</td>
</tr>
<tr>
<td>First Name</td>
<td>The first name of the Admin user.</td>
</tr>
<tr>
<td>Last Name</td>
<td>The last name of the Admin user.</td>
</tr>
<tr>
<td>Email</td>
<td>The email address that is associated with the Admin user account.</td>
</tr>
<tr>
<td></td>
<td>Each Admin account must have a different email address.</td>
</tr>
<tr>
<td>Current Admin Password</td>
<td>Your current Admin password.</td>
</tr>
<tr>
<td>New Password</td>
<td>Your new Admin password.</td>
</tr>
<tr>
<td>Password Confirmation</td>
<td>Your new Admin password for confirmation.</td>
</tr>
</tbody>
</table>
Message InBox

Your store has an inbox for the messages received from Magento. The messages are rated by importance, and might refer to updates, patches, new releases, scheduled maintenance, upcoming events, and more. Any message that is considered to be of major importance appears in a pop-up window when you log into your store. You can manage your message inbox much as you would manage your email. Check it often to stay up-to-date on the latest information from Magento!

To manage incoming messages:

1. When the Incoming Messages box appears, do one of the following:
   - Click the Read Details link for more information.
   - Click the Close box to remove the popup and continue.

   A Latest Message notice also appears to the left, just below the header of your store. As with the popup box, you can click the Read Details link for more information.
2. To read your messages, click **Go to messages inbox**.

   The messages in your inbox are marked by severity listed with the most recent at the top.

3. After reading a message, you can apply any of the following actions to the message:

   - For more information, click the **Read Details** link.
   - To keep the message, click the **Mark As Read** link.
   - To delete the message from your inbox, click the **Remove** link.
To apply an action to multiple messages:

1. On the Admin menu, select **System > Notifications**.
2. In your message inbox, do one of the following:
   - Select the checkbox at the beginning of each message you want to manage.
   - Click one of the group selection options above the list to select multiple messages.
3. When the messages that you want to manage are selected, set **Actions** to one of the following:
   - Mark as Read
   - Remove
4. Click the **Submit** button to complete the process.

### Message Importance

<table>
<thead>
<tr>
<th>SEVERITY</th>
<th>COLOR</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Critical</td>
<td>Red</td>
<td>Indicates an important, time-sensitive message.</td>
</tr>
<tr>
<td>Major</td>
<td>Orange</td>
<td>The default message severity level.</td>
</tr>
<tr>
<td>Notice</td>
<td>Green</td>
<td>Indicates that a routine operation has taken place.</td>
</tr>
</tbody>
</table>
Notification Setup

You can specify how often your Message Inbox is updated, from one to twenty-four hours. If your store Admin has a secure URL, you must set the notifications to be delivered over HTTPS.

To configure Admin notifications:

1. On the Admin menu, select System > Configuration.
2. In the panel on the left, under Advanced, select System.
3. Click to expand the Notifications section, and do the following:
   a. If your store Admin is running over a secure URL, set Use HTTPS to Get Feed to “Yes.”
   b. Set Update Frequency to one of the following:
      - 1 Hour
      - 2 Hours
      - 6 Hours
      - 12 Hours
      - 24 Hours
4. When complete, click the Save Config button.
Admin Menu

All of the tools you need to manage the operation and maintenance of your store are available in the Admin menu.

Dashboard

The Dashboard gives you a quick overview of the sales and customer activity in your store. It is usually the first page that appears when you log in to the Admin.

Sales

The Sales menu is where you can find everything related to processing an order, including current and past orders, invoices, shipments, credit memos, terms and conditions, and taxes.

Catalog

The Catalog menu controls everything related to your product catalog, including products, categories, attributes, URL rewrites, search terms and indexing, product reviews, tags, and Google Sitemap.

Customers

The Customers menu is where you can manage customer accounts, and customer groups. You can even see which customers are online at the moment.
Promotions

The Promotions menu is where you set up catalog and shopping cart price rules and coupons. Price rules trigger actions when a set of specific conditions is met.

Newsletter

The Newsletter menu contains the tools you need to publish newsletters and manage your list of subscribers.

CMS

The CMS menu is where you create and manage content for your store. In addition to content pages, you can create static blocks, widgets, and polls.

Reports

The Reports menu provides a broad selection of reports that give you insight into every aspect of your store, including sales, shopping cart, products, customers, tags, reviews, and search terms.

System

The System menu includes tools to configure and maintain every aspect of your store. In addition, you can install extensions and manage Web Services for integration with other applications.
Admin Tools

The Admin includes many lists of data for products, orders, customers, search terms, pages, blocks, and so on. Each list has the same set of tools for finding records, pagination, sorting, filtering, selecting, and applying actions to records.

Global Search

The Global Search box can be used to find any value in the database, including product, customer, and order records.

Sorting

The header of each column can be used to sort the list in ascending or descending order.

Filters

The filters in the header of each column can be used to limit the list to specific values. Some filters have additional options that can be selected from a list box, and for others, you can simply type the value you want to find.

Pagination

The pagination controls are used to view the additional pages of results.

Selection

The Selection controls above the column headers have links to Select All, Unselect All, Select Visible, and Unselect Visible

Actions

The Action control applies an operation to any record with a checkmark in the first column.
Global Record Search

The global search box is located in the Admin header, and can be used to find any record in the database. The results can include customers, products, orders, or any related attribute.

To do a global search:

1. Type the first few letters of what you are looking for into the global search box.
2. In the list of closely matching items, click the one that you want to find.
Grid Controls

Many pages in the Admin include a list of records displayed in a grid, with controls at the top of each column. The controls can be used to sort the list in ascending, or descending order based on the values in the column. In addition, you can filter the list based on a value in each column.

To sort the list:

1. In the upper-left corner, set **Choose the Store View** to define the scope of the data to be retrieved.
2. Click the column name of any header. The arrow indicates the current order as either ascending or descending.
3. Use the pagination controls to view additional pages in the collection.

To set the pagination controls:

1. Set **View** to the number of records that you want to view per page.
2. In the **Page** box, enter the page number you want to view, or click the arrow button to advance to the next or previous page.
**Pagination Controls**

**To filter the list:**

1. In the box below the column header, either enter or select the value you want to find.
2. Click the **Search** button.

**Filter Controls**
Actions Control

When working with lists of data in the grid, you can use the Actions control to apply an operation to a single record, or to multiple records. The Actions control lists the operations that can be applied to the selected records. When working with the Manage Products list, you can use the Actions control to update the attributes of the group of selected products, change their status from “Disabled” to “Enabled,” or delete them from the database. You can make as many changes as necessary, and then update the records in a single step. It’s much more efficient than changing settings individually for each product record.

The selection of available actions varies by list, and additional options may appear, depending on the action selected. For example, when changing the status of a group of records, a Status box appears next to the Actions control with additional options.

Step 1: Select Records

The checkbox in the first column identifies each record that is a target for the action. The search filters can be used to narrow the list to the records you want to target for the action. Do the following:

1. Select the checkbox of each record that is targeted for the action. Or, use the selection links above the list to the left, to select groups of records. Options include:
   - Select All / Unselect All
   - Select Visible / Unselect Visible

2. If needed, set the search filters at the top of the columns to list the records you want to include.

3. In the first column, set the checkbox state to list “Any” record, or only those that match, or do not match the filter settings.
Step 2: Apply an Action to Selected Records

1. Set the **Actions** control to the operation you want to apply.

   **Example: Update Attributes**

   a. In the list, select the checkbox of each record to be updated.

   b. Set the **Actions** control to “Update Attributes,” and click the **Submit** button.

      The Update Attributes page lists all the available attributes, organized by group in the panel on the left.

   c. Select the **Change** checkbox next to each attribute, and make the necessary changes.

   d. Click the **Save** button to update the attributes for the group of selected records.

2. Click the **Submit** button.

**Checkbox States**

<table>
<thead>
<tr>
<th>STATE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Any</td>
<td>Lists all records, regardless of checkbox status.</td>
</tr>
<tr>
<td>Yes</td>
<td>Lists only records with the checkbox selected.</td>
</tr>
<tr>
<td>No</td>
<td>Lists only records without the checkbox selected.</td>
</tr>
</tbody>
</table>
### Actions by List

<table>
<thead>
<tr>
<th>MENU</th>
<th>LIST</th>
<th>ACTIONS</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>SALES</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Orders</td>
<td>Cancel</td>
<td>Hold</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Unhold</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Print Invoices</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Print Packingslips</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Print Credit Memos</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Print All</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Print Shipping Labels</td>
</tr>
<tr>
<td>Invoices</td>
<td>PDF Invoices</td>
<td></td>
</tr>
<tr>
<td>Shipments</td>
<td>PDF Packing Slips</td>
<td>Print Shipping Labels</td>
</tr>
<tr>
<td>Credit Memos</td>
<td>PDF Credit Memos</td>
<td></td>
</tr>
<tr>
<td>Search Terms</td>
<td>Delete</td>
<td></td>
</tr>
<tr>
<td><strong>CATALOG</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Manage Products</td>
<td>Delete</td>
<td>Change Status</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Update Attributes</td>
</tr>
<tr>
<td>Search Terms</td>
<td>Delete</td>
<td></td>
</tr>
<tr>
<td>Manage Tags</td>
<td>Delete</td>
<td>Change Status</td>
</tr>
<tr>
<td>Reviews (All / Pending)</td>
<td>Delete</td>
<td>Update Status</td>
</tr>
<tr>
<td>Tags (All / Pending)</td>
<td>Delete</td>
<td>Change Status</td>
</tr>
</tbody>
</table>
## Actions by List (cont.)

<table>
<thead>
<tr>
<th>MENU</th>
<th>LIST</th>
<th>ACTIONS</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td><strong>CUSTOMERS</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Manage Customers Delete</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Subscribe to Newsletter Unsubscribe from Newsletter</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Assign a Customer Group</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>NEWSLETTER</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Newsletter Subscribers Unsubscribe Delete</td>
</tr>
</tbody>
</table>
CHAPTER 6: Store Details

The basic information for your store includes the store name and address, telephone number and email address, that appear on email messages, invoices, and other communications sent to your customers.

---

**Invoice**

<table>
<thead>
<tr>
<th>Products</th>
<th>SKU</th>
<th>Price</th>
<th>Qty</th>
<th>Tax</th>
<th>Subtotal</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lola Ceremonry Handling</td>
<td>ab801</td>
<td>$340.00</td>
<td>1</td>
<td>$30.60</td>
<td>$340.00</td>
</tr>
<tr>
<td>Religious Art</td>
<td>jdf801</td>
<td>$25.00</td>
<td>3</td>
<td>$6.75</td>
<td>$75.00</td>
</tr>
<tr>
<td>Bathrooms and Sink</td>
<td>gdh801</td>
<td>$30.00</td>
<td>3</td>
<td>$0.00</td>
<td>$35.00</td>
</tr>
<tr>
<td>Virtual and Physical Gift Cards</td>
<td>ayo008</td>
<td>$15.00</td>
<td>3</td>
<td>$4.95</td>
<td>$55.00</td>
</tr>
<tr>
<td>Blue Horizons Brochure</td>
<td>acy008</td>
<td>$35.00</td>
<td>1</td>
<td>$3.15</td>
<td>$35.00</td>
</tr>
<tr>
<td>Madison Embellish</td>
<td>jdm010</td>
<td>$25.00</td>
<td>3</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Subtotal: $330.00
Discount: $5.00
Tax: $15.45
Grand Total: $345.65
Store Information

The Store Information section provides the basic information that appears on sales documents and in other communications.

**To enter the store information:**

1. On the Admin menu, select **System > Configuration**.

2. In the panel on the left, under General, select **Store Information**. Then, do the following:
   
   a. Enter the **Store Name** as you want it to appear in all communications.
   
   b. Enter the **Store Contact Telephone** number, formatted as you want it to appear in all communications.
   
   c. Select the **Country** where your business is located.
   
   d. If applicable, enter the **Value Added Tax** number of your store. To verify the number, click the **Validate VAT Number** button.
   
   e. In the text box, enter your **Store Contact Address** as you want it to appear on sales documents.

3. When complete, click the **Save Config** button.
Locale Options

The locale determines the language, country, tax rate, and other settings used throughout a store. The Locale Options configure the time zone and language of each store, and identify the days of your work week in the area.

![Locale Options](image)

**To set the store locale:**

1. On the Admin menu, select System > Configuration.
2. Click to expand the Locale Options section.
3. Select your Timezone from the list. Then, do the following:
   a. Set Locale to the store language.
   b. Set First Day of the Week to the day that is considered to be the first day of the week in your area.
   c. In the Weekend Days list, select the days which fall on a weekend in your area. (To select multiple options, hold down the Ctrl (PC) or Command (Mac) key.)
4. When complete, click the Save Config button.
States Options

In many countries, the state, province, or region is a required part of a postal address. The information is used for shipping and billing information, to calculate tax rates, and so on. For countries where it is not required, the field can be omitted entirely from the address, or included as an optional field.

Because standard address formats vary from one country to another, you can also edit the address template that determines how the information appears on invoices, packing slips, and shipping labels.

To set up the state options:

1. On the Admin menu, select System > Configuration.
2. Click to expand the States Options section, and do the following:
3. In the State is required for list, select each country where you want State / Province to be a required entry.
   To select multiple options, hold down the Ctrl key (PC) or Command key (Mac), and click each option.
4. Set Display not required State to one of the following:
   Yes In countries where the state field is not required, the field is included in the form as an optional entry.
   No In countries where the state field is not required, the field is omitted from the form.
5. When complete, click the Save Config button.
Countries Options

The Countries Options establish the country where your business is located, and the countries from which you accept payment.

To set the country options for your store:

1. From the Admin menu, select System > Configuration.
2. Click to expand the Countries Options section. Then, do the following:
   a. Set Default Country to the country where your business is located.
   b. In the Allow Countries list, select each country from which you accept orders. By default, all countries in the list are selected. To select multiple countries, hold down the Ctrl (PC) or Command (Mac) key.
   c. In the Postal Code is Optional list, select each country where you conduct business that does not require a ZIP or postal code to be included as part of the street address.
   d. In the European Union Countries list, select each country in the EU where you conduct business. By default, all EU countries are selected.
3. When complete, click the Save Config button.
Currency

Magento Community Edition gives you the ability to accept currencies from more than two hundred countries around the world.

**Setting Up Currency Rates**

The Currency Rate configuration defines the base currency of your store, and the currencies that you accept as payment.

**Currency Symbols**

Currency symbols appear in product prices and sales documents such as orders and invoices.

**Updating Currency Rates**

Currency rates can be updated manually or imported into your store as needed, or according to a predefined schedule.
Basic Shipping Settings

Shipping Settings
The Shipping Settings establish the point of origin for all shipments made from your store or warehouse, and also your preference for managing orders that are shipped to multiple addresses.

Shipping Methods
Magento supports a wide range of built-in shipping methods, including Flat Rate, Free Shipping, Table Rates, and real-time online rates.

Shipping Carriers
If you have a commercial account with a supported carrier, you can offer your customers the convenience of real-time shipping rates, package tracking, and labels.

Shipping Labels
You can easily create shipping labels for new and existing orders from the Admin of your store. Labels can be produced at the time a shipment is created, or at a later time. Shipping labels are stored in PDF format and are downloaded to your computer.
Store Email Addresses

You can have up to five different email addresses to represent distinct functions or departments for each store or view. In addition to the following predefined email identities, there are two custom identities that you can set up according to your needs.

- General Contact
- Sales Representative
- Customer Support

Each identity and its associated email address can be associated with specific automated email messages and appear as the sender of email messages that are sent from your store.

Step 1: Set Up the Email Addresses for Your Domain

Before you can configure email addresses for the store, each must be set up as a valid email address for your domain. Follow the instructions from your server administrator or email hosting provider to create the email address you need.
Step 2: Configure the Email Addresses for Your Store

1. On the Admin menu, select **System > Configuration**.

2. In the Configuration panel on the left, under General, select **Store Email Addresses**. Then, do the following:
   a. Click to expand the **General Contact** section.
   b. If you have multiple stores or views, set the **Current Configuration Scope** in the upper-left corner to identify the store or view where the configuration applies. Then, clear the checkbox after each field so new values can be entered.
   c. In the **Sender Name** field, type the name of the person that you to appear as the sender of all email messages that are associated with the General Contact.
   d. In the **Sender Email** field, type the associated email address.

3. Repeat this process for any other email addresses that you plan to use.

4. When complete, click the **Save Config** button.

Step 3: Update the Sales Email Configuration as Needed

If you use custom email addresses, make sure to update the configuration of any related email messages, so the correct identity appears as the sender.

1. In the panel on the left, under Sales, select **Sales Email**.

2. Click to expand each section, and make sure that the correct store email is selected as the sender of the message.

3. When complete, click the **Save Config** button.
Contact Us

The Contact Us link in the footer of each page is an easy way for customers to keep in touch with you. The form is enabled by default, and can be configured to send inquiries to a specific email address and replies from a specific store identity.
To configure the Contact Us form:

1. On the Admin menu, select System > Configuration.
2. In the panel on the left, under General, click Contacts.
3. Click to expand the Contact Us section, and set Enable Contact Us to “Yes.”

![Contact Us](image)

4. Click to expand the Email Options section. Then, do the following:

   a. In the Send Emails To field, enter the email address of the recipient.
   b. Set Email Sender to the store identity you want to use for the replies sent.
   c. Select the Email Template used to format the data sent from the form.

5. When complete, click the Save Config button.
CHAPTER 7: Storefront Branding

Magento provides a variety of easy-to-use design options that you can use to apply a custom look-and-feel to your store. One of the first things you’ll want to do is change the logo in the header of your store, and also upload a favicon for the browser. In addition, you can update the copyright notice in the footer. While your store is in development, you can turn on the store demo notice, and then remove it when the store is ready to launch.
Uploading Your Logo

The size of the logo in the header is determined by your theme. If your theme has a sample logo, right-click and download the logo to make sure the new logo is the same size.

![Logo In Header](image)

The logo image path points to its location on the server. What is actually a long path is entered as a short path that is relative to the theme. For example:

- **Actual path:** `skin/frontend/base/default/images/logo.gif`
- **Relative path:** `images/logo.gif`

The header image filename is hard-coded into some theme files. If you change the name of the logo file, you will have to make updates to some source files. For non-programmers, the easiest approach is to use the default filename, “logo.gif,” and write over the existing file.
To change the logo:

1. On the server, copy your new logo file to the images folder of your theme. For example: skin/frontend/base/default/images/logo.gif

2. On the Admin menu, select System > Configuration. Then in the panel on the left under General, select Design.

3. If you have multiple stores or views, set the Current Configuration Scope in the upper-left corner to the store or view where the configuration applies. Then, clear the checkbox after each field so new values can be entered.

4. Click to expand the Header section. Then, do the following:

![Header section of the configuration panel]

Header
a. If the path or filename has changed, enter it in the Logo Image Src field.

b. In the Logo Image Alt field, enter the alt text for the image. If the configuration is for a different language view, enter the alt text in the appropriate language.

c. If your store uses a responsive theme, in the Small Logo Image Src field, enter the path to a version of the logo that is optimized for small devices.

5. When complete, click the Save Config button.
Uploading a Favicon

Favicon is short for “favorite icon,” and refers to the little icon on the tab of each browser page. Depending on the browser, the favicon also appears in address bar, just before the URL.

Favicons are generally 16 x 16 pixels or 32 x 32 pixels in size. Although Magento accepts .ico, .png, .jpg, .jpeg, .apng, and .svg file types, not all browsers support these formats. The most widely-supported file format to use for a favicon is .ico. There are many free tools available online that you can use to generate an .ico image or convert an exiting image to the .ico format.

Favicon in Address Bar

Process Overview:
Step 1: Create a Favicon
Step 2: Upload the Favicon to Your Store
Step 3: Refresh the Cache

Step 1: Create a Favicon

1. Create a 16x16 or 32x32 graphic image of your logo, using the image editor of your choice.

2. (Optional) Use one of the available online tools to convert the file to the .ico format. Then, save the file to your computer.
Uploading a Favicon

CHAPTER 7: Storefront Branding

Step 2: Upload the Favicon to Your Store

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left under General, select **Design**.

2. Click to expand the **HTML Head** section. Then, do the following:

   a. Click the **Choose File** button. Then, select the favicon file that you prepared.

   b. If you want to delete the current favicon, select the **Delete Image** checkbox.

3. When complete, click the **Save Config** button.

Step 3: Refresh the Cache

1. As soon as the favicon is uploaded, you are prompted to refresh the cache. Click the **Cache Management** link in the message at the top of the workspace.

2. In the list, select the **Page Cache** checkbox that is marked “Invalidated.”

3. In the upper-right corner, set **Actions** to “Refresh” and click the **Submit** button.

4. To view the new favicon, return to your storefront and press **F5** to refresh the browser.
Changing the Welcome Message

The "Welcome" message in the upper-left corner expands to include the name of customers who are logged in. You can change the text for each store or store view.

**To change the welcome message:**

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left, under General, select **Design**.

2. If you have multiple stores or views, set the **Current Configuration Scope** in the upper-left corner to the store or view where the configuration applies. Then, clear the checkbox after each field so new values can be entered.

3. Click to expand the **Header** section.

4. In the Welcome text box, enter the text that you want to appear in the header,

5. When complete, click the **Save Config** button.

6. When prompted to update the Page Cache, click the **Cache Management** link at the top of the workspace. Then, follow the instructions to refresh the cache.
Store Demo Notice

If you are using a store as a demo, or if it is online but still “under construction,” you can display a store demo notice at the top of the page. When you are ready to “go live” with the store, simply remove the message.

To set the store demo notice:

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under General, select Design.

2. Click to expand the HTML Head section.

3. Scroll down to the bottom, and set the Display Store Demo Notice to your preference.

4. When complete, click the Save Config button.
Copyright Notice

Your Magento store has a copyright notice in the footer of each page in the storefront, as well as the Admin. As a best practice, the copyright notice should include the current year, and identify your company as the legal owner of the site. The &Copy; character code is used to insert the copyright symbol, as shown in the following examples:

Long Format Example

Copyright &Copy; 2015 Magento, Inc. All rights reserved.

Short Format Example

&Copy; 2015 Magento, Inc. All rights reserved.

To change the copyright notice:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under General, select Design.
2. Click to expand the Footer section.
3. In the Copyright box, enter the copyright notice that you want to appear in the footer of each page. Use the &Copy; character code to insert a copyright symbol.
4. When complete, click the Save Config button.
CHAPTER 8:
Websites, Stores & Views

When Magento is installed, a main website, default store, and store view are created. You can create as many additional websites, stores, and store views as you need. Within each website, you can have multiple stores, and within each store, separate views. The term hierarchy\(^1\) refers to the organization of websites, stores, and views in a Magento installation.

---

### Websites

You can set up as many websites as you need, and each can have a different domain.

### Stores

A single website can have multiple stores—all are managed from the same Admin. Each store can have a different main menu, product selection, and appearance.

### Store Views

Store views are usually used to present the store in different languages, although they can be used for other purposes, as well. Customers use the language chooser in the header to change the store view.

---

\(^1\)The organization of websites, stores, and views in a Magento installation.
Setting Up Store Hierarchy

Before you begin, carefully plan your store hierarchy in advance because it is referred to throughout the configuration. Each store can have a separate root category, which makes it possible to have an entirely different set of navigation for each store.

Also consider the prices and product attributes that are needed for each store view. Magento allows for only one standard price with a tiered pricing structure, per SKU\(^1\). If you want to use a different pricing structure for a specific customer group in a store view, you must create a unique SKU for each view.

Manage Stores

To set up a new website:

1. On the Admin menu, select **System > Manage Stores**.
2. From Manage Stores, click the **Create Website** button. Then, do the following:

   a. Enter the **Name** of the website. The name is for internal reference, and can refer to the domain of the site or anything else distinguish it from other sites in the hierarchy.

   b. Enter a **Code** that will be used on the server to point to the domain. The code must begin with a lowercase character, and can include any other combination of letters, numbers, and underscore (_) character.

   c. (Optional) Enter a **Sort Order** number to determine the sequence in which this site is listed with other sites. Enter a zero to make this site appear at the top of the list.

3. When complete, click the **Save Website** button.

---

\(^1\)Stock Keeping Unit: A number or code assigned to a product to identify the product, options, price, and manufacturer.
To set up a new store:

1. Before you begin, set up the root category that will be used for this store.
2. On the Admin menu, select **System > Manage Stores**.
3. From Manage Stores, click the **Create Store** button. Then, do the following:

   ![New Store](image)

   **New Store**

   a. Set **Website** to the site that is the parent of this store.
   b. Enter a **Name** for the store. The name is for internal reference to distinguish it from other stores in the hierarchy. For example: Outlet Sales Store.
   c. Set **Root Category** to the root category that will be used for the main navigation of the store. The root category can be the same as used for other stores, or unique to this store. For example: Outlet Sales Root.
4. When complete, click **Save Store**.
To set up a new store view:

1. On the Admin menu, select **System > Manage Stores**.
2. From Manage Stores, click the **Create Store View** button. Then, do the following:

   - **Store View Information**

     a. Set **Store** to the parent store of this view.

     b. Enter a **Name** for this store view. The name appears in the “language chooser” in the header of the store. For example: French.

     c. Enter a **Code** in lowercase characters to identify the view. For example: french.

     d. To activate the view, set **Status** to “Enabled.”

     e. (Optional) Enter a **Sort Order** number to determine the sequence in which this view is listed with other views.

3. When complete, click the **Save Store View** button.
Configuration Scope

If your Magento installation has multiple websites, stores, or views, you can set the scope of a configuration parameter to apply to a specific part of your installation. The Current Configuration Scope box in the upper-left corner of the Admin workspace determines the scope of the current settings. By default, the configuration scope is set to “Default Config.” For Admin users with restricted access, the list includes only the areas where the user is granted permission to access.

The configuration scope applies to products categories, attributes, customer management setting, and so on. The scope of each item appears in brackets after the field to indicate the range of the setting.

Current Configuration Scope

If your installation includes multiple websites, stores or views, you should always set the scope to identify where you want the settings to apply. The possible settings are: [STORE], [WEBSITE], and [GLOBAL].

Any item with the scope of [STORE] can be set differently for each view. For example, because the scope of a product name and description is [STORE], the fields can have a different value for each language. However, some configuration settings—such as postal code—are [GLOBAL] because the same setting applies throughout the system. The [WEBSITE] scope also applies to the entire site, including all views.
To set the configuration scope:
Before making a configuration setting that applies only to a specific website, store, or view, do the following:

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, select the page with the configuration settings you want to change. If necessary, click to expand the section to be configured. Then, do the following:

   a. In the upper-left corner of a configuration page, set Current Configuration Scope to the website, store, or view where the configuration applies.

      A checkbox appears after each field, and sometimes additional fields become available.

   b. Clear the Use Default checkbox that is after the field that you want to edit. Then, enter the new value.

   c. Repeat this process for every field that needs to be updated on the page.

3. When complete, click the Save Config button.

Scope Settings

<table>
<thead>
<tr>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Store</td>
<td>The setting is limited to the store view, which is often used to display a store in multiple languages.</td>
</tr>
<tr>
<td>Website</td>
<td>The setting is limited to the website.</td>
</tr>
<tr>
<td>Global</td>
<td>The setting applies to the entire installation.</td>
</tr>
</tbody>
</table>
Adding a Language

Most of the text that appears to be hard-coded on pages throughout your store can be instantly changed to a different language by changing the locale of the view. Changing the locale doesn’t actually translate the text word-for-word, but simply references a different translation table that provides the interface text that is used throughout the store. The text that can be changed includes navigational titles, labels, buttons, and links such as “My Cart” and “My Account.”

There is a wide selection of language packs available on Magento Connect. You can also use the Inline Translation tool to touch up any remaining interface text that was not translated for the locale, or to fine-tune the translated text.

After changing the language of the locale, the remaining content that you have created, including product names and descriptions, categories, CMS pages, blocks, and polls must be translated separately for each store view.

---

**Step 1: Install a Language Pack**

1. Log in to your Magento account.

2. Go to Magento Connect, and find the language pack that you want to download. Read the terms of the license, and click the checkbox to proceed.

3. Click the Install Now button. Then, do the following:
   a. Click the Get the Extension Key button.
   b. Click the Select button. Then, copy the license key.

4. Return to the Admin of your store. Then on the Admin menu, select System > Magento Connect > Magento Connect Manager.

5. When prompted, log in to Magento Connect Manager. Then, do the following:
a. In the **Install New Extensions** section, paste your extension key.

b. Click the **Install** button. The language pack you have chosen appears below.

![Install Language Pack](image)

When ready to begin, click the **Proceed** button.

You can follow the progress in the output frame. During the installation, the language pack is uploaded to the following folder on your server:

```
magento/app/locale
```

![Output Frame](image)

6. To return to your store, click the **Return to Admin** link at the top of the page.
Step 2: Create a Store View for the Language

1. On the Admin menu, select **System > Manage Stores**.

2. From Manage Stores, click the **Create Store View** button. Then, do the following:

   a. Select the **Store** that is the parent of the view.
   b. Enter a **Name** for the store view. For example: Spanish.
      This is the name that appears in the “language chooser” in the header.
   c. Enter a **Code** in lowercase characters to identify the view. For example: spanish.
   d. To activate the view, set **Status** to “Enabled.”
   e. (Optional) Enter a **Sort Order** number to determine the sequence in which this view is listed with other views.

3. When complete, click the **Save Store View** button.
Step 3: Change the Locale of the Store View

1. On the Admin menu, select **System > Configuration**.

2. In the upper-left corner, set **Current Configuration Scope** to the store view.

3. Click to expand the **Locale Options** section. Then, do the following:
   
   a. To the right of the Locale field, clear the **Use Website** checkbox.
   
   b. Set **Locale** to the language that you want to assign to the view.

   If there are several variations of the language available, make sure to select the one that matches the language pack that you installed. For example, the Spanish language pack downloaded in this example works only when the locale is set to “Spanish (Spain).” You will need a different language pack to support a specific regional variation. You will need a different language pack to support the regional variations of other countries.

3. When complete, click the **Save Config** button.
Translating Products

If your store has multiple views in different languages, the same products are available in each store view. You can use the same basic product information, such as SKU, price, and inventory level, regardless of language. Then, translate only the product name, description fields, and meta data as needed for each language.

**Step 1: Translate Product Fields**

1. On the Admin menu, select Catalog > Manage Products.
2. In the list, find the product and click Edit to open.
3. In the upper-left corner set Choose Store View to the view where the changes you make will be visible. When prompted to confirm, click OK.

Only fields with a scope of [STORE VIEW] can be edited separately for each view or language.
4. For each field to be edited, do the following:
   a. Clear the Use Default Value checkbox to the right of the field.
   b. Either paste or type the translated text into the field.
5. When complete, click the Save button.
Step 2: Translate Field Labels

1. On the Admin menu, select Catalog > Attributes.
2. In the list, find the attribute and click to open in edit mode.
3. In the panel on the left, select Manage Label / Options.
4. In the Manage Titles section, enter the translated label text for each store view.

5. When complete, click the Save Attribute button.
Translating Pages

If your store has multiple views in different languages, and you have set the locale for each view to a different language, the result is a partially translated site.

The next step is to create a translated version of each page that is available only from the specific store view. The Store View column of the Manage Pages list shows each view that has a translated version of the page. In the following example, the About Us page is available in for the English, French, and German store views, but not Spanish.

To translate a CMS page, you must create a new page that has the same URL Key as the original, but is assigned to the specific store view. Then, update the page with the translated text. The following example shows how to create a translated version of the About Us page for the Spanish store view.
To create a translated page for a view:

1. On the Admin menu, select CMS > Pages.

2. From the Manage Pages list, open the page to be translated and copy the URL Key to the clipboard. Then, press the Back button to return to the Manage Pages list.

3. Click the Add New Page button. Then, do the following:
   a. Enter the translated Page Title.
   b. Paste the URL Key that you copied from the original page.
   c. In the Store View box, select the store view where the page will be available, which in this case is “Spanish.”

4. When complete, click the Save Page button.
5. If prompted to refresh the cache, click the link at the top of the page. Then, refresh any invalid caches.

6. Return to the storefront and select the view from the language choosers.

Notice that there are still some elements on the page that need to be translated, including the company footer links block, which on this page, appears in the left sidebar, the welcome message, and product information.
Store URLs

The URLs that are associated with your store were configured during the initial installation of Magento. The Web access options that were entered at that time specify both unsecure and secure URLs, and whether or not a security certificate is available.

Magento uses variables to define internal links in relation to the base URL, which makes it possible to move an entire store from one URL to another without having to update the internal links.

Web Access Options
Secure and Unsecure Base URLs

Each website in a Magento installation has a base URL that is assigned to the storefront and to the Admin. If you have a security certificate for your domain, you can configure either, or both base URLs to operate over a securely encrypted SSL channel. Unsecure base URLs begin with “http,” and secure base URLs begin with “https.”

Unsecure Base URL  http://www.yourdomain.com/magento/
Secure Base URL  https://www.yourdomain.com/magento/
URL with IP address  http://10.9.220.154/magento/

If Magento was installed before you registered a domain, the base URL might include the IP address of the server. If you don’t yet have security certificate, the store will not be able to switch to secure URLs (https) for transactions that normally take place over the secure socket layer (SSL). These configuration settings can be updated later to reflect the values you need before the store “goes live.”

**Important!** Do not change the Admin URL from the default in the Base URL configuration. To change the Admin URL or path, see: Using a Custom Admin URL.

**To configure the unsecure base URL:**

1. On the Admin menu, select System > Configuration.
2. In the panel on the left, under General, select Web.
3. Click to expand the Unsecure section. Then, do the following:
4. Enter the unsecure (http) Base URL for your store. Make sure to end the URL with a forward slash.

For a typical installation, you do not need to update the paths for the skin, media, and JavaScript files. Be careful not to change the markup tags in the other fields in the section.
5. If you do not plan to use a secure base URL for the Admin, do the following:
   a. Click to expand the Secure section.
   b. Enter your unsecure (http) Base URL. The URL should be the same in both the Secure and Unsecure sections.

6. When complete, click the Save Config button.

**To configure the secure base URL:**

If your domain has a valid security certificate, you can configure the URLs for either the storefront and Admin—or both—to run over a secure (https) channel.

1. Click to expand the Unsecure section. Then, do the following:
   a. To use a secure (https) for the storefront, enter the Base URL, followed by a forward slash. Typically, you will not need to update the paths for the skin, media, and JavaScript files. Be careful not to change the markup tags in the other fields in the section.
   b. If you want to run the entire storefront over a secure (https) channel, set **Use Secure URLs in Frontend** to “Yes.”
   c. If you want to run the entire Admin over a secure (https) channel, set **Use Secure URLs in Admin** to “Yes.”

2. When complete, click the Save Config button.
Using a Custom Admin URL

As a security best practice, Magento recommends that you use a unique, custom Admin URL instead of the default “admin” or the often-used “backend.” Although it will not directly protect your site from a determined attacker, it can reduce exposure to scripts that try to break in to Magento sites.

Check with your hosting provider before implementing a custom Admin URL. Some hosting providers require a standard URL to meet firewall protection rules.

In a typical Magento installation, the Admin URL and path is immediately below the Magento base URL. The path to the store Admin is one directory below the root.

Default Base URL

http://yourdomain.com/magento/

Default Admin URL and Path

http://yourdomain.com/magento/admin

Although it is possible to change the Admin URL and path to another location, any mistake removes access to the Admin, and must be corrected from the server.

As a precaution, do not try to change the Admin URL by yourself unless you know how to edit configuration files on the server.

Method 1: Change from the Magento Admin

1. On the Admin menu, select System > Configure.
2. In the panel on the left, under Advanced, select Admin.
3. Click to expand the Admin Base URL section, and do the following:
   a. Set Use Custom Admin URL to “Yes.” Then, enter the Custom Admin URL in the following format:

   http://yourdomain.com/magento/

   Important! The Admin URL must be in the same Magento installation, and have the same document root as the storefront.
b. Set **Custom Admin Path** to “Yes.” Then, enter the name of the **Custom Admin Path** in the following format:

```
backend
```

4. When complete, click the **Save Config** button.

After the changes are saved, you must log in to the Admin using the new Admin URL and path.

**Method 2: Change from the Server Command Line**

1. Open the `app/etc/local.xml` file in a text editor, and change the name of the `[admin]` path. Make sure to use only lowercase characters. Then, save the file.

   On the server, the admin path is located in the `app/etc/local.xml` file. Look for the `<adminhtml>` argument in the `<admin>` section:

   **Default Admin Path**

   ```xml
   # <frontName><![CDATA[admin]]></frontName>
   ```

   **New Admin Path**

   ```xml
   # <frontName><![CDATA[backend]]></frontName>
   ```

2. Do one of the following methods to clear the Magento cache:

   - On the Admin menu, select **System > Cache Management**. Then, click the **Flush Magento Cache** button.
   - On the server, navigate to the `var/cache` folder, and delete the contents of the `cache` folder.
CHAPTER 9:
Industry Compliance

Magento Community Edition offers a range of security and privacy capabilities that meet legal requirements and industry guidelines for online merchants. Some are mandated by the payment card industry, and others are required by law, depending on your location.

You will learn about PCI compliance, and the importance of establishing procedures to protect payment information. You will also learn how to bring your store into compliance with the Cookie Law, which is a requirement in some countries, and considered a “best practice” in others. In addition, you will learn how to customize and maintain a privacy policy for your store.

Privacy Policy

Privacy Policy

This website ("website") is operated by Madelon Island, which includes Madison Island stones, and Madison Island
Privacy Policy. This privacy policy only covers information collected at this website, and does not cover any information
collected offline by Madison Island. All Madison Island websites are currently covered by this privacy policy.

Security

Personal information provided on the website and online credit and transactions are transmitted through secure servers.
We are committed to handling your personal information in a high standard of information security. We use appropriate
physical, electronic, and administrative steps to maintain the security and accuracy of personally identifiable information
we collect, including limiting the number of people who have physical access to our data servers, or as we deploying
electronic security measures and protocols that limit access to information at risk. Our websites use encryption technology,
like Secure Sockets Layer (SSL), to protect your personal information during data transfers. SSL encrypts any
information such as your name, address, and credit card number. Our Customer Service team and developers operate our
privacy-sensitive secure network. Please note that email and encrypted text is not considered to be secure means of
transmitting credit card information.

Privacy Policy

In order to achieve its goal of providing the highest quality products and services, we use information from our interactions
with you and other customers, as well as from other parties. Because we respect your privacy, we have implemented
procedures to ensure that your personal information is handled in a secure and responsible manner.

We have posted this privacy policy in order to explain our information collection practices. If you have any questions
about our information management and use, please contact us. As we continue to develop our website and take advantage of advances in technology to improve the services we offer, the privacy policy may change. We therefore encourage you to refer to this policy on an ongoing basis so that you understand all of our current privacy policies.

The Information We Collect

Generally, you may browse the website without providing any personally identifiable information. However, we may ask
you to provide personally identifiable information at certain online forms on this website. In some cases, if you choose
to provide us with the requested information, you may not be able to access all parts of this website or participate in all

Privacy Policy
PCI Compliance Guidelines

The Payment Card Industry (PCI) has established a set of requirements for businesses that accept payment by credit card over the Internet. In addition to maintaining a secure hosting environment, merchants must meet additional requirements to ensure the privacy of cardholder data. As your business grows, you might be required to file a compliance report on an annual basis. PCI reporting requirements increase in proportion to merchant level, but are waived for businesses that process fewer than 20,000 credit card transactions per year.

Every merchant who handles customer credit card information is required by the Payment Card Industry to conduct business within the following guidelines:

**PCI Requirements**

- Install and maintain a firewall configuration to protect cardholder data.
- Do not use vendor-supplied defaults for system passwords and security parameters.
- Protect stored cardholder data.
- Encrypt transmission of cardholder data across open, public networks.
- Use and regularly update antivirus software.
- Develop and maintain secure systems and applications.
- Restrict access to cardholder data by business need to know.
- Assign a unique ID to each person with computer access.
- Restrict physical access to cardholder data.
- Track and monitor all access to network resources and cardholder data.
- Regularly test security systems and processes.
- Maintain a policy that addresses information security.
Privacy Policy

Your store includes a sample privacy policy that must be updated with your own information. Your privacy policy should describe the type of information that your company collects, and how it is used. It should also list the filenames of cookies that are placed on the computers of people who visit your store. Any additional cookies that are associated with third-party extensions and add-ons should be included in the list. For a complete list of the cookies used by Magento, see Cookie Restriction Mode.

If you change the URL key of the privacy policy, you must also create a custom URL rewrite to redirect traffic to the new URL key.

To edit your privacy policy:

1. On the Admin menu, select CMS > Pages > Manage Content.
2. Find the privacy policy in the list, and click to open the page.
3. In the panel on the left, click Content.
4. To work in WYSIWYG mode, click the Show/Hide Editor button.
5. Make the necessary changes to the content.
6. When complete, click the Save Page button.
Cookie Law Compliance

Cookies are small files that are saved to the computer of each visitor to your site, and used as temporary holding places for information. Information that is saved in cookies is used to personalize the shopping experience, link visitors to their shopping carts, measure traffic patterns, and improve the effectiveness of promotions. To keep pace with legislation in many countries regarding the use of cookies, Magento offers merchants a choice of methods for obtaining customer consent:

✅ Implied Consent

Implied consent means that visitors to your store have a clear understanding that cookies are a necessary part of operations, and by using your site, have indirectly granted permission to use them. The key to gaining implied consent is to provide enough information for a visitor to make an informed decision. Many stores display a message at the top of all standard pages that provides a brief overview of how cookies are used, with a link to the store's privacy policy. The privacy policy should describe the type of information that your store collects, and how it is used.

✅ Expressed Consent

Operating your store in "cookie restriction mode" requires visitors to express their consent before any cookies can be saved to their computers. Unless consent is granted, many features of your store will be unavailable. For example, if Google Analytics is available for your store, it can be invoked only after the visitor has granted permission to use cookies.
Cookie Restriction Mode

When Cookie Restriction Mode is enabled, visitors to your store are notified that cookies are required for full-featured operations. Depending on your theme, the message might appear above the header, below the footer, or somewhere else on the page. The message links to your privacy policy for more information, and encourages visitors to click the Allow button to grant consent. After consent is granted, the message disappears. The Cookie Restriction Mode message resides in a CMS static block, and can be edited to suit your voice and style.

Your privacy policy should include the name of your store and contact information, and explain the purpose of each cookie that is used by your store. See the end of this topic for a complete list of the cookies used. See the end of this topic for a complete list of the cookies used.

If you change the URL key of the privacy policy, you must also create a custom URL rewrite to redirect traffic to the new URL key. Otherwise, the link in the Cookie Restriction Mode message will return “404 Page Not Found.”
Step 1: Enable Cookie Restriction Mode

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under General, click Web.

2. Click to expand the Session Cookie Management section, and do the following:

   ![Cookie Session Management](image)

   - Enter the **Cookie Lifetime** in seconds.
   - If you want to make cookies available to other folders, enter the **Cookie Path**. To make the cookies available anywhere in the site, enter a forward slash.
   - To make the cookies available to a subdomain, enter the subdomain name in the **Cookie Domain** field. (subdomain.yourdomain.com) To make cookies available to all subdomains, enter the domain name preceded by a period. (.yourdomain.com)
   - To prevent scripting languages such as JavaScript from gaining access to cookies, set **Use HTTP Only** to “Yes.”
   - Set **Cookie Restriction Mode** to “Yes.”
Step 2: Edit the Cookie Restriction Message

1. On the Admin menu, select **CMS > Static Blocks**.

2. Find the **Cookie Restriction Notice**, and click to open the block. Then, do the following:

   a. Select each **Store View** where the notice should appear.
   
   b. Set **Status** to “Enabled.”
   
   c. In the **Content** box, edit the message as needed.

3. When complete, click the **Save Block** button.
Step 3: Update Your Privacy Policy

1. On the Admin menu, select **CMS > Pages > Manage Content**.
2. Find your **Privacy Policy** in the list, and click to open the page.
3. In the panel on the left, click **Content**. If necessary, click the **Show/Hide Editor** button to work in WYSIWYG mode.

   ![Privacy Policy](image)

4. Update your privacy policy to describe the information that your company collects, and how it is used. You can include the information from the tables at the end of this topic.

5. When complete, click the **Save Page** button.
Cookie Reference

Magento Standard Cookies

<table>
<thead>
<tr>
<th>COOKIE NAME</th>
<th>COOKIE DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>USER_ALLOWED_SAVE_COOKIE</td>
<td>Indicates if a customer is allowed to use cookies.</td>
</tr>
<tr>
<td>external_no_cache</td>
<td>A flag that indicates if caching is disabled.</td>
</tr>
<tr>
<td>persistent_shopping_cart</td>
<td>The session key.</td>
</tr>
<tr>
<td>Stf</td>
<td>If product links were sent to friends, stores the timestamps in the format: $timestamp1,$timestamp2,...,$timestampN.</td>
</tr>
<tr>
<td>pollN</td>
<td>A poll ID that indicates if a vote has occurred.</td>
</tr>
<tr>
<td>frontend</td>
<td>Session ID</td>
</tr>
<tr>
<td>guest-view</td>
<td>Allows guests to edit their orders.</td>
</tr>
</tbody>
</table>

Google Analytics Cookies

<table>
<thead>
<tr>
<th>COOKIE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>_utma</td>
<td>Distinguishes users and sessions.</td>
</tr>
<tr>
<td>_utmb</td>
<td>Determines new sessions/visits.</td>
</tr>
<tr>
<td>_utmz</td>
<td>Determines if the user was in a new session/visit.</td>
</tr>
<tr>
<td>_utmz</td>
<td>Stores the traffic source or campaign that explains how the user reached your site.</td>
</tr>
</tbody>
</table>
Products

Customers explore your catalog through the navigation of your store, so that's where this discussion begins. You'll learn about categories and attributes, and how to build your catalog, upload images, and establish pricing. Finally, you'll choose how you want to manage stock, and complete the necessary inventory settings.

Navigation
- Top Navigation
- Breadcrumb Trail
- Product List Configuration
- Layered Navigation

Categories
- Category Levels
- Creating Categories
- General Information
- Display Settings
- Custom Design
- Category Products

Attributes
- Attribute Input Types
- Creating Attributes
- Deleting Attributes
- Creating an Attribute Set
- Attribute Quick Reference

Using a Flat Catalog
- Flat Catalog Setup

Creating Products
- Product Types
- Simple Product
- Grouped Product
- Configurable Product
- Virtual Product
- Bundle Product
- Downloadable Product

Images
- Thumbnail Gallery
- Image Size and Type
- Adding Product Images
- Placeholders
- Watermarks

Swatches
- Swatch Workflow
- Swatch Configuration
- Preparing Swatch Images
- Clearing the Cache

Pricing
- Prices
- Special Price
- Tier Price
- Quantity Increments
- Minimum Advertised Price
- Product Group Price

Inventory
- Inventory Configuration
- Managing Stock

Product Information
- General
- Meta Data
- Recurring Profile
- Design
- Gift Options
- Websites
- Categories
- Related Products
- Up-sells
- Cross-sells
- Custom Options
CHAPTER 10: Navigation

The term, navigation refers to the methods shoppers use to move from page to page throughout your store. The main menu, or top navigation of your store is actually a list of category links. The category structure of your catalog is the main way people find products in your catalog. You will also find categories in the breadcrumb trail that runs across the top of most pages, and in the "layered navigation" that appears on the left side of some two- or three-column pages. These are all examples of how categories can be used to navigate throughout your store.

For a product to be visible in your store, it must be assigned to at least one category. Each category can have a dedicated landing page with an image, static block, a description, and list of products. You can also create special designs for category pages that become active for a specific period of time such as for a holiday season or promotion.
Top Navigation

The main menu of your store displays the selection of categories that are available in your catalog. You can think of the top navigation as different departments in your store. A top-level category serves as landing page for all the subcategories below. The position and presentation of the top navigation might vary by theme, but the way it works is the same.

Top Navigation

The first level of categories below the root typically appear as options in the main menu. Below that, you can have as many additional subcategories as needed. The category structure of your catalog can influence how well your site is indexed by search engines. The deeper a category, the less likely it is to be thoroughly indexed. As a general rule, anywhere between one and three levels is considered to be the best. You can set the maximum number of levels that are available in your top navigation in the system configuration.
Breadcrumb Trail

A breadcrumb trail is a set of links that shows where you are in relation to other pages in the store. You can click any link in the breadcrumb trail to return to a previous page. Here’s an example of a breadcrumb trail from the Magento Demo Store:

HOME/ACCESSORIES/JEWELRY/PEARL STUD EARRINGS

The breadcrumb trail can be configured to appear on CMS content pages, as well as catalog pages. The format and position of the breadcrumb trail varies by theme, but it is usually located in the upper-left, just below the header.

To add breadcrumbs to CMS pages:

1. On the Admin menu, select System > Configuration.
2. In the panel on the left, under General, select Web. Then, do the following:
   a. Click to expand the Default Pages section.
   b. Set Show Breadcrumbs for CMS Pages to “Yes.”
3. When complete, click the Save Config button.
Product Listings

Product listings can be configured to appear by default as either a list or grid. You can also determine how many products appear per page, and which attribute is used to sort the list. Each product list has a set of page controls that can be used to sort the products, change the format of the list, sort by attribute, and advance from one page to the next.

View As Displays the list in either a Grid or List format.
Sort By Changes the sort order of the list.

To configure product listings:

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under Catalog, select Catalog.
2. Click to expand the Frontend section.
3. Set the default List Mode to one of the following:
   - Grid Only
   - List Only
   - Grid (default) / List
   - List (default / Grid
Then, do the following:

a. In the **Products per Page on Grid Allowed Values** field, enter the number of products that you want to appear per page when shown in grid format. To enter a selection of values, separate each number by a comma.

b. In the **Products per Page on Grid Default Value** field, enter the default number of products to appear in the grid per page.

c. In the **Products per Page on List Allowed Values** field, enter the number of products that you want to appear per page when shown in list format. To enter a selection of values, separate each number by a comma.

d. In the **Products per Page on List Default Value** field, enter the default number of products that appear in the list, per page.

4. To give customers the option to list all products, set **Allow All Products on Page** to “Yes.”

5. Set **Product Listing Sorted by** to the default attribute that is initially used to sort the list.

6. If using a flat catalog, do the following:
   
a. To display a flat category listing of products, set **Use Flat Catalog Category** to “Yes.”

b. To display a flat product listing, set **Use Flat Catalog Product** to “Yes.”

7. If you want to allow dynamic references to media assets in category and product URLs, set **Allow Dynamic Media URLs in Products and Categories** to “Yes.”

8. When complete, click the **Save Config** button.
Pagination Controls

The Pagination settings control the format of the pagination links in product listings. You can set the number of links that appear in the control, and configure the Next and Previous links. For the following pagination links to appear, there must be more products in the list than are allowed per page in the catalog configuration.

**Show per Page**  
Determines how many products appear per page.

**Pagination Links**  
Navigation links to other pages.

To configure pagination controls:

1. On the Admin menu, select System > Configuration.
2. In the panel on the left under General, select Design.
3. Click to expand the Pagination section. Then, do the following:
   a. In the Pagination Frame field, enter the number of links that you want to appear in the control.
   b. In the Pagination Frame Skip field, enter the number of links to skip ahead to display the next set of links in the control.

For example, if the pagination frame has five links, and you want to jump to the next five links, how many links do you want to skip ahead? If you set this to four, then the last link from the previous set will be the first link in the next set.
Pagination

c. In the Anchor Text for Previous field, enter the text that you want to appear for the Previous link. Leave blank to use the default arrow.

d. In the Anchor Text for Next field, enter the text that you want to appear for the Next link. Leave blank to use the default arrow.

4. When complete, click the Save Config button.
Layered Navigation

Layered navigation makes it easy to find products based on category, price range, or any other available attribute. Layered navigation usually appears in the left column of search results and category pages and sometimes on the home page. The standard navigation includes a “Shop By” list of categories and price range. You can configure the display of layered navigation, including product count and price range.

The following instructions show how to set up basic layered navigation. For advanced layered navigation with price steps, see Price Navigation.

Layered Navigation by Category and Price
Step 1: Configure Attributes and Anchor Categories

Make sure that the attribute properties and the anchor categories that are required for layered navigation are configured correctly.

Step 2: Set Up Basic Layered Navigation

1. On the Admin menu, select System Configuration. Then in the panel on the left, under Catalog, select Catalog.

2. Click to expand the Layered Navigation section. Then, do the following:

   a. To display the number of products found for each attribute, set Display Product Count to “Yes.”

   b. Set Price Navigation Step Calculation to “Automatic (equalize price ranges).”

3. When complete, click the Save Config button.
Filterable Attributes

Layered navigation can be used to search for products by category or by attribute. For example, when a shopper chooses the Apparel/Shoes category from the top navigation, the initial results include all products in the shoes category. The list can be filtered further by choosing a specific color or size, or by specifying values for both color and size. For an attribute to be included in layered navigation, its property settings must be set to make it filterable.

Anchor categories can be set to appear in an additional section that filters the list by attribute value. The attribute section appears only if a category is set to “Is Anchor.” Each attribute can be configured to display the number of matching records found.

The attribute properties, combined with the product properties, determine which attributes can be used as filters for layered navigation. Only those with the catalog input type of Dropdown, Multiple Select or Price can be used as filterable attributes.
Step 1: Set the Attribute Properties

1. On the Admin menu, select Catalog > Attributes > Manage Attributes.
2. Click to open the attribute in edit mode, and do the following:
   a. Scroll down to the Frontend Properties section, and set Use In Layered Navigation to one of the following:
      - Filterable (with results)
      - Filterable (no results)
   b. Set Use In Search Results Layered Navigation to “Yes.”

Step 2: Make the Category an Anchor

1. On the Admin menu, select Catalog > Manage Categories.
2. In the Categories panel on the left, click to open the category.
3. On the Display Settings tab, set Is Anchor to “Yes.”
4. Click the Save Category button.
5. To test the setting, go to your store and select the category in the top navigation. The selection of filterable attributes for the products in the category appears in the layered navigation.
Price Navigation

Price navigation can be used to distribute products by price range in layered navigation. You can also split each range in intervals. There are ways to calculate price navigation:

- Automatic (Equalize Price Ranges)
- Automatic (Equalize Product Counts)
- Manual

With the first two methods, the navigation steps are calculated automatically. The manual method lets you specify a division limit for price intervals. The following example shows the difference between price navigation steps of 10 and 100.

Iterative splitting provides the best distribution of products among price ranges. With iterative splitting, after a customer chooses to view the $0.00-$99 range, the customer can drill-down through several sub-ranges of prices. Price-range splitting stops when the number of products reaches the threshold set by the Interval Division Limit.

**Example: Price Navigation Steps**

<table>
<thead>
<tr>
<th>PRICE STEP BY 10</th>
<th>PRICE STEP BY 100</th>
</tr>
</thead>
<tbody>
<tr>
<td>$20.00 - $29.99 (1)</td>
<td>$0.00 - $99.99 (4)</td>
</tr>
<tr>
<td>$30.00 - $39.99 (2)</td>
<td>$100 - $199.99 (5)</td>
</tr>
<tr>
<td>$70.00 - $79.99 (1)</td>
<td>$400.00 - $499.99 (2)</td>
</tr>
<tr>
<td>$100.00 - $109.99 (1)</td>
<td>$700.00 and above (1)</td>
</tr>
<tr>
<td>$120.00 - $129.99 (2)</td>
<td></td>
</tr>
<tr>
<td>$150.00 - $159.99 (1)</td>
<td></td>
</tr>
<tr>
<td>$180.00 - $189.99 (1)</td>
<td></td>
</tr>
<tr>
<td>$420.00 - $429.99 (1)</td>
<td></td>
</tr>
<tr>
<td>$440.00 - $449.99 (1)</td>
<td></td>
</tr>
<tr>
<td>$710.00 and above (1)</td>
<td></td>
</tr>
</tbody>
</table>
To configure price layered navigation:

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left, under Catalog, select **Catalog**.

2. In the upper-left corner, set **Current Configuration Scope** to the store view to be configured.

3. Click to expand the **Layered Navigation** section.

4. If you want to display the number of products in parentheses after each filtered item, set **Display Product Count** to “Yes.”

5. Set **Price Navigation Steps Calculation** to one of the following methods:

   **Method 1: Automatic (equalize price ranges)**

   Set **Price Navigation Steps Calculation** to “Automatic (equalize price ranges.)” This setting uses the existing price layered navigation algorithm, and is similar to the Automatic option in earlier versions of Magento.
Method 2: **Automatic (equalize product counts)**

1. Set **Price Navigation Steps Calculation** to “Automatic (equalize product counts).”
2. Set **Display Price Interval as One Price** to “Yes” if you want to display a single price when multiple products with the same price.
3. In the **Interval Division Limit** field, enter the threshold for a number of products within a price range. The range cannot be further split beyond this limit. The default value is 9.

![Automatic (equalize product counts)](image)

**Automatic (equalize product counts)**

Method 3: **Manual**

2. Enter a value to determine the **Default Price Navigation Step**.
3. Enter the **Maximum Number of Price Intervals** allowed, up to 100.

![Manual](image)

**Manual**

6. When complete, click the **Save Config** button.
CHAPTER 11: Categories

Before you add products to your catalog, you must first establish the basic category structure of your catalog. Every product in your catalog must be assigned to at least one category.
Category Levels

The number of subcategory levels that you can have in the top navigation is set in the system configuration. By default, there is no limit to the number of levels of subcategories you can set up. In the following image, the Home & Decor category has a depth of two levels.

To set the depth of the top navigation:

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left, under Catalog, select **Catalog**.

2. Click to expand the **Category Top Navigation** section.

3. To place a limit on the number of subcategories that can be used in the top navigation, enter the number in the **Maximal Depth** field.

   The default Maximal Depth value is 0, which does not limit the number of subcategory levels you can have.

4. When complete, click the **Save Config** button.
Creating Categories

When working in the Admin, the category structure is like an upside-down tree, with the root at the top. Each section of the tree can be expanded and collapsed. Any disabled or hidden categories are grayed out.

![Category Structure Diagram]

Process Overview:
Step 1: Create a Category
Step 2: Complete the General Information
Step 3: Complete the Display Settings

Step 1: Create a Category

1. On the Admin menu, select Catalog > Manage Categories.

2. Before you begin, set Choose Store View to the store or view. By default, the scope of the category configuration is set to “All Store Views.”

3. In the category tree, click the category that is to be the parent of the new category. The parent is the level just above the new category.

   If you’re starting from the beginning without any data, there might be only two categories in the list: “Default Category,” which is the root, and an “Example Category.”

4. Click the Add Subcategory button.
Step 2: Complete the General Information

1. In the General Information section, do the following:
   a. (Required) Type the Name of the category.
   b. (Required) To enable the category, set Is Active to “Yes.”
   c. You can enter a URL Key for the category, or let the system automatically create one that is based on the category name.

2. If supported by your theme, you can display a Thumbnail image in the main menu for each category. Click the Choose File button and select the image to upload.

3. In the Description box, enter a paragraph or two of descriptive text for the category landing page.

4. To display an Image at the top of the category landing page, click the Choose File button and select the image to upload.

5. Complete the category meta data:
   - Page Title
   - Meta Keywords
   - Meta Description

6. (Required) To include the category in the main menu, set Include in Navigation Menu to “Yes.”

7. Click the Save Category button. Then, take note of the following:
- The new category now appears in the tree. If it’s not in the correct position, you can drag it to another location in the tree.

- In addition to the category name, it has an ID number shown in parentheses, just after the name at the top of the page.

- A URL Key that is based on the category name can be automatically generated for the category.

![Category URL Key](image)

**Step 3: Complete the Display Settings**

You can configure the category landing page to display both a static block and product list, or one or the other. A static block can provide additional information, including text, images, and even embedded video.

![Display Settings](image)

1. On the **Display Settings** tab, do the following:
   a. Set **Display Mode** to one of the following:
      - Products Only
      - Static Block Only
      - Static Block and Products
   b. If applicable, set **CMS Block** to the static block that you want to appear on the category page.
   c. If you want this category page to display the “Filter by Attribute” section of layered navigation, set **Is Anchor** to “Yes.”
d. Clear the checkbox under **Default Product Listing Sort By**. Then select one of the available values to sort the list. By default, all available attributes are listed. The default values typically include:

- Best Value
- Name
- Price

2. When complete, click the **Save Category** button.

### Modifying Categories

After a category is established, it can be edited, moved to another position in the category tree, or deleted from the catalog. However, if your catalog is live, you should consider how the change might impact any existing links to products in the category. For example, if your product URLs include the category path, and the category name is changed, any existing links to products in the category will be broken. To avoid this problem, you can configure your catalog to automatically create a permanent redirect if the URL key changes. You can also use the **URL Rewrite** tool to redirect traffic from an old URL to a new one.

**To move a category:**

1. On the Admin menu, select **Catalog > Manage Categories**.
2. To move a category, simply drag-and-drop it to a new location. Category order changes are saved automatically.

**To delete a category:**

1. On the Admin menu, select **Catalog > Manage Categories**.
2. Click to select the category you want to delete.

   A deleted category cannot be restored, so make sure that you have selected the correct category before proceeding.
3. Click the **Delete Category** button to save your changes.
Root Categories

The category structure is like an upside-down tree, with the root on top. All categories in your catalog are nested below the root. Because the root category is the highest level of the catalog, your store can have only one root category active at a time. You can, however, create additional root categories for alternate catalog structures, different stores, and views. The root category is not visible to customers in the store, and does not have a URL key.

Step 1: Create a New Root Category

1. On the Admin menu, select Catalog > Manage Categories.
2. In the upper-left of the Manage Categories page, click the Add Root Category button. Then, complete the following required fields:
   a. Enter a Name for the root category.
   b. Set Is Active to “Yes.”
   c. If you want this root category to be in the main menu, set Include in Navigation Menu to “Yes.”
3. Complete the remaining optional fields as needed:
   a. Click the Choose File to upload a Thumbnail Image for the root category.
   b. Enter a Description of the root category.
   c. Click the Choose File button to upload an Image to the root category.
   d. Complete the following meta data:
4. Click the Display Settings tab. Then, set **Is Anchor** to “Yes.”
5. When complete, click the **Save Category** button.

**Step 2: Add Subcategories to the New Root**

1. On the Categories page, click the **General** tab.
2. In the category tree on the left, click to select the new root category you created in the last step.
3. Click the **Add Subcategory** button.
4. Give the subcategory a **Name**, and set **Is Active** to “Yes.”
5. Click the **Save Category** button.
6. Repeat this process to create as many subcategories as you need.

**Step 3: Apply the New Root Category to Your Store**

1. On the Admin menu, select **System > Manage Stores**.
2. On the Manage Stores page, under Store Name, click the **Main Store** link.
3. Change **Root Category** to the new root category.
4. Click the **Save Store** button.
Hidden Categories

There are many ways to use hidden categories. You might want to create additional category levels for your own internal purposes, but show only the higher-level categories to your customers. Or, you might want to link to a category that is not included in the navigation menu.

**To create hidden categories:**

1. On the Admin menu, select **Catalog > Manage Categories**.
2. In the category tree, select the category you want to hide.
3. On the **General Information** tab, do the following:
   a. Set **Is Active** to “No.”
   b. Set **Include in Navigation Menu** to “No.”
4. On the **Display Settings** tab, set **Is Anchor** to “No.”
5. Although the category is hidden, you can still create additional subcategories beneath it, and make them active. Complete the following settings for each hidden subcategory:
   a. On the **General Information** tab, set **Is Active** to “Yes.”
   b. On the **Display Settings** tab, set **Is Anchor** to “Yes.”

As active categories, you can now link to them from other places in your store, but they will not appear in the navigation menu.

6. When complete, click the **Save Category** button.
General Information

On the General Information tab, complete the basic information about the category you are creating or editing. You can enter keywords to improve the way the category is indexed by search engines, create a URL key for the category, and activate or deactivate the category.
# Field Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Store View</td>
<td><em>(Required)</em> The category name appears in the navigation, and also in the URL key of the category page and associated product pages.</td>
</tr>
<tr>
<td>Is Active</td>
<td>Store View</td>
<td><em>(Required)</em> To make this category available, select “Yes.” Options include: Yes / No</td>
</tr>
<tr>
<td>URL Key</td>
<td>Store View</td>
<td>The URL Key is a relative path to the category, and is automatically generated when the category is saved. The URL Key must be all lower-case characters, with no spaces. As a best practice, each word is separated by a hyphen. If you edit the default URL key, a custom redirect is created automatically. A root category does not have a URL key.</td>
</tr>
<tr>
<td>Thumbnail Image</td>
<td>Store View</td>
<td>If supported by your theme, a thumbnail image can be associated with each category and appear as part of the option in the main menu of the store.</td>
</tr>
<tr>
<td>Description</td>
<td>Store View</td>
<td>The category description, if used, appears below the category image and before the product list.</td>
</tr>
<tr>
<td>Image</td>
<td>Store View</td>
<td>The category image, if used, appears at the top of the category page, before the description and product list. As an alternative, you can display a CMS static block in place of the description and image. <em>(See Category Display Settings.)</em></td>
</tr>
</tbody>
</table>
Field Descriptions (cont.)

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yes</td>
<td>Include this category in the top navigation, select “Yes.”</td>
<td></td>
</tr>
<tr>
<td>No</td>
<td>Hides the category, although it is active. Hidden categories do not appear in the top navigation, but are included in layered navigation.</td>
<td></td>
</tr>
</tbody>
</table>
Display Settings

The Display Settings determine which content elements appear on a category page and the order that products are listed. You can enable CMS blocks, set the anchor status of the category, and manage sorting options from this page.
# Field Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Mode</td>
<td>Store View</td>
<td>Determines the content elements displayed on the category page. Options include: Products Only, Static Block Only, Static Block and Products</td>
</tr>
<tr>
<td>CMS Block</td>
<td>Store View</td>
<td>To display a CMS static block at the top of the category page, select the name of the block from the list.</td>
</tr>
<tr>
<td>Is Anchor</td>
<td>Global</td>
<td>When set to “Yes,” includes the “filter by attribute” section in the layered navigation. Options include: Yes / No</td>
</tr>
<tr>
<td>Available Product Listing</td>
<td>Store View</td>
<td>(Required) The default values are Value, Name, and Price. To customize the sorting option, clear the Use All Available Attributes checkbox and select the attributes you want to use. You can define and add attributes as needed.</td>
</tr>
<tr>
<td>Default Product Listing</td>
<td>Store View</td>
<td>(Required) To define the default “Sort By” option, clear the “Use Config Settings” checkbox and select an attribute.</td>
</tr>
<tr>
<td>Layered Navigation Price</td>
<td>Store View</td>
<td>By default, Magento displays the price range in increments of 10, 100, and 1000, depending on the products in the list. To change the Price Step range, clear the “Use Config Settings” checkbox.</td>
</tr>
</tbody>
</table>
Custom Design

Add a Custom Design to change the look and feel of a category and all assigned product pages, including the content blocks and page layout. You can customize a category page for a promotion or to increase sales by differentiating the category from others. For example, you might develop distinctive design for a brand or special line of products.

To create a custom category design:

1. If the parent category of the selected category has already been customized and you want to use same settings, set Use Parent Category Settings to “Yes.”

2. To apply the custom design to all the products assigned to the category, set Apply to Products to “Yes.” Otherwise, the customization applies to only the category page.

3. To apply a different theme to the category, select the theme you want to use from the Custom Theme list.

4. To apply the category design to a specific range of time, click the calendar to select both the Active From and Active To dates. Otherwise, the design will take effect when you save the changes to the category.

5. Click the Save Category button to save your changes.
### Field Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Parent Category Settings</td>
<td>Store View</td>
<td>Causes the current category to inherit the design settings from the parent category. Options: Yes / No</td>
</tr>
<tr>
<td>Apply to Products</td>
<td>Store View</td>
<td>Applies the custom settings to all products in the category. Options: Yes / No</td>
</tr>
<tr>
<td>Custom Theme</td>
<td>Store View</td>
<td>Applies a custom theme to the category.</td>
</tr>
<tr>
<td>Active From</td>
<td>Store View</td>
<td>The beginning of a date range that specifies the first day the theme is to be used in the store. The date can be entered or selected from the calendar.</td>
</tr>
<tr>
<td>Active To</td>
<td>Store View</td>
<td>The end of a date range that specifies the last day the theme is to be used in the store. The date can be entered or selected from the calendar.</td>
</tr>
<tr>
<td>Page Layout</td>
<td>Store View</td>
<td>Applies a different layout to the category page. Options:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No layout updates: Pre-selected by default, and does not apply layout changes to the category page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Empty: Use to define your own page layout. (Requires an understanding of XML.)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1 column: Applies a one-column layout to the category page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2 columns with left bar: Applies a two-column layout and left sidebar to the category page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2 columns with right bar: Applies a two-column layout and right sidebar to the category page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>3 columns: Applies a three-column layout to the category page.</td>
</tr>
<tr>
<td>Custom Layout Update</td>
<td>Store View</td>
<td>Updates the theme layout with custom XML code.</td>
</tr>
</tbody>
</table>
Category Products

The Category Products tab lists the products that are currently assigned to the category. From the list, you can easily add and remove products from the category.

To assign products to a category:

1. From the category record, click the **Category Products** tab. Then, do the following:
   a. Use the filters and checkbox control to find the products you want to assign:
      - To display all products currently assigned to the category, set the checkbox control to “Yes.”
      - To display all products that are not assigned to the category, set the checkbox control to “No.”
      - To display all products, set the checkbox control to “Any.”
   b. Press the **Search** button.
   c. To list all products again, click the **Reset Filter** button.
2. Select the checkbox of each product you want to assign to the category.
3. When complete, click the **Save Category** button.
CHAPTER 12:

Attributes

Attributes are the building blocks of your product catalog, and describe specific characteristics of a product. Here are a few ways you can use attributes to enhance the shopping experience:

- Input controls for product options
- Provide additional information on product pages
- Search parameters
- In product comparison reports
- As layered navigation “Shop By” parameters
- In catalog and shopping cart price rules

Each attribute contains a value that describes a characteristic of a product, such as “color” or “fabric.” The “color” attribute with the “dropdown” input type might contain many values, although only a few apply to any given product. Because a single attribute can be used with multiple products, your store needs to have only one attribute for color. You can create as many attributes as you need, and assign the most common value as the default, to make it easy for your customers to select the option.

The attributes that make up a product are combined into an attribute set, which is used as template to create new products. The attribute set determines which fields are included in a product, and how they are grouped in the Product Information panel. Magento has a default attribute set with a standard selection of product attributes such as Name, Price, Description, and so on. If you want to keep it simple, you can use the default attribute set for your entire catalog.
Attribute Input Types

When viewed from the Admin, attributes are the fields that you complete when you create a product. The input type that is assigned to an attribute determines the type of data that can be entered, and the format of the field or input control. From the standpoint of the customer, attributes provide information about the product, and are the options and data entry fields that must be completed to purchase a product.

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text Field</td>
<td>A single line input field for text.</td>
</tr>
<tr>
<td>Text Area</td>
<td>A multiple-line input field for entering paragraphs of text such as a product description. You can use the WYSIWYG Editor to format the text with HTML tags, or type the tags directly into the text.</td>
</tr>
<tr>
<td>Date</td>
<td>Date values can be entered by making a selection from a drop-down list, or from a popup calendar. Depending on your system configuration, dates can be typed directly into a field, or selected from the calendar or list. See also: Date &amp; Time Custom Options.</td>
</tr>
<tr>
<td>Yes/No</td>
<td>Displays a drop-down list with pre-defined options of “Yes” and “No.”</td>
</tr>
<tr>
<td>Dropdown</td>
<td>Displays a drop-down list of values. Only one item can be selected at a time. The Dropdown input type is a key component of configurable products.</td>
</tr>
<tr>
<td>Multiple Select</td>
<td>Displays a drop-down list of values. To select more than one option, hold the Ctrl key down and click each item.</td>
</tr>
<tr>
<td>Price</td>
<td>This input type creates price fields that are in addition to the predefined attributes, Price, Special Price, Tier Price and Cost. The currency used is determined by your system configuration.</td>
</tr>
<tr>
<td>Media Image</td>
<td>Associates an additional image with a product, such as a product logo, care instructions, or ingredients from a food label. When you add a media image attribute to the attribute set of a product, it becomes an additional image type, along with Base, Small, and Thumbnail. The media image attribute can be excluded from the thumbnail gallery, but can still be used.</td>
</tr>
<tr>
<td>Fixed Product Tax</td>
<td>Lets you define FPT rates based on the requirements of your locale. See also: General Tax Settings.</td>
</tr>
</tbody>
</table>
Date & Time Custom Options

You can customize the format of date and time fields, and select the input control used for dates. Dates values can be selected from a drop-down list, or from a popup JavaScript calendar. The following page has an example of each type of date input control.

To format date/time fields:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Catalog, select Catalog.

2. Click to expand the Date & Time Custom Options section. Then, do the following:
a. To display the JavaScript calendar as an input control for date fields, set Use JavaScript Calendar to “Yes.”

b. To establish the Date Fields Order, set each to one of the following:

- Month
- Day
- Year

c. Set your preferred Time Format to one of the following:

- 12h AM/PM
- 24h

d. To set the Year Range for the drop-down year values, enter the year in YYYY format to establish the beginning and ending from and to dates.

   If left blank, the field defaults to the current year.

3. When complete, click the Save Config button.
Creating Attributes

The properties of an attribute determine how it can be used in your catalog and how it appears throughout your store. In addition to the basic properties, there are additional properties for drop-down and multiple-select input types, their values, and associated labels. The title, or label, identifies the attribute in the Admin and your storefront. If your store is available in multiple languages, you can enter a different translated label for each language. Attributes can be created with the Manage Attributes tool, and also from inside a product record.

**Process Overview:**

- **Step 1: Assign the Attribute Properties**
- **Step 2: Define the Label and Values**

**Step 1: Assign the Attribute Properties**

1. On the Admin menu, select **Catalog > Attributes > Manage Attributes**. Then, click the **Add New Attribute** button.

2. In the Attribute Properties section, complete the following required (*) properties:
   - **a.** Enter a unique **Attribute Code** to identify the attribute internally. The code should be all lowercase characters without spaces.
   - **b.** In the **Apply To** list, choose each product type that is associated with the attribute.
3. Complete the remaining Attribute Properties as needed.
   a. Set Scope to the indicate where the attribute can be used.
   b. Set Catalog Input Type for Store Owner to the type of input control used by the store administrator during data entry.
   c. If you want to prevent duplicate values from being entered in this field, set Unique Value to “Yes.”
   d. To require that a value must be entered in the field before the record can be saved, set Values Required to “Yes.”
   e. To run a validity test of data entered into the field, set Input Validation for Store Owner to the type of data the attribute should contain.

4. In the Frontend Properties section, complete as many of the settings as needed.
Step 2: Define the Label and Values

1. In the Attribute Information panel on the left, select Manage Label / Options. Then, do the following:
   a. In the Manage Titles section, under Admin, enter a descriptive label to identify the field during data entry.
   b. The next column determines how the label appears in your storefront. You can leave the box blank to use the Admin label as the default.
   c. If your store is available in multiple languages, enter a translated label into each box, as needed.

2. For drop-down or multiple-select input types, do the following:
   a. In the Manage Options section, click the Add Option button.
   b. In the new row, under Admin, type the value you want to use in your store's Admin.
   c. Enter the value you want your customers to see. (Leave blank to use the Admin value as the default.)
   d. If applicable, enter a translated value for each language supported.
   e. Enter a number to determine the Position of this value in relation to other options in the list.
   f. Select Is Default to automatically select this value.
   g. Repeat these steps for each value you want to add to the list.

3. When complete, click the Save Attribute button.

   The attribute appears in the Manage Attributes list, sorted in alphabetical order by Attribute Code. Use the Page controls to view each page of the list.
Deleting Attributes

If you used sample data while setting up your store, you might have attributes that aren’t needed for your catalog. When an attribute is deleted, it is removed from any related products and attribute sets. System attributes are part of the core functionality of your store and cannot be deleted.

To delete an attribute:

1. On the Admin menu, select **Catalog > Attributes > Manage Attributes**.
2. In the list, find the attribute and click to open the record.
3. Click the **Delete Attribute** button.
4. When prompted to confirm, click **OK**.
Creating an Attribute Set

One of the first steps when creating a product is to choose the attribute set that is used as a template for the product record. The attribute set determines the fields that are available during data entry, and the values that appear to the customer.

Manage Attribute Sets

Your store comes with an initial attribute set called “default” which contains a set of commonly-used attributes. If you would like to add only a small number of attributes, you can add them to the default attribute set. However, if you sell products that require specific types of information, such as cameras, it might be better to create a dedicated attribute set that includes the special attributes (fields) needed to describe the product.

A single attribute can be used by as many different attribute sets as is necessary. For example, the attribute “color” can be included in an attribute set for clothing, paint, or for any number of different products.

To create an attribute set:

1. On the Admin menu, select Catalog > Attributes> Manage Attribute Sets.
2. Click the Add New Set button. Then, do the following:

   a. Enter a Name for the attribute set.
   b. In the Based On field, select another attribute set from which this attribute set is to inherit attributes. This option enables you to reuse the attributes already defined in a set to build other attribute sets. The simple option is to leave the Default option that appears in this field.
3. Click the Save Attribute Set button. The next page displays the following:
The top left of the page shows the name of the attribute set defined earlier. You have the option to edit the name because this value is for internal use.

The center of the page shows a hierarchical tree representing Groups for attributes.

The right side of the page shows a list of defined attributes that are not assigned to this attribute set.

4. Select the attribute to be assigned to this Group by dragging them from the Unassigned Attributes area on the right into the relevant Group in the middle of the page.

5. When the attribute set is complete, click the Save Attribute Set button.

To create a new attribute group:

1. In the Groups section of the attribute set, click the Add New button.
2. Enter a Name for the new group, and click OK.
3. Do either of the following:
   - Drag Unassigned Attributes to the new group.
   - Drag attributes from any other group to the new group.

The new group becomes a section in the Product Information panel for any product that is based on this attribute set.
## Attribute Quick Reference

### Product Type Properties

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply To</td>
<td>Identifies the product types that can use the attribute. Visibility must be set to include the catalog.</td>
</tr>
<tr>
<td>Use to Create Configurable Product</td>
<td>Identifies an attribute that is used to create a drop-down list of options for a configurable product.</td>
</tr>
</tbody>
</table>

### Data Entry Properties

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default Value</td>
<td>Displays a common entry as a starting value.</td>
</tr>
<tr>
<td>Unique Value</td>
<td>Prevents duplicate values from being entered.</td>
</tr>
<tr>
<td>Values Required</td>
<td>Requires a value to be entered before the record can be saved.</td>
</tr>
<tr>
<td>Input Validation</td>
<td>Performs a validation check of the data, based on data type, or format.</td>
</tr>
</tbody>
</table>

### Search and Navigation Properties

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use in Quick Search</td>
<td>Lets customers use the Search box to find items based on the value of the attribute.</td>
</tr>
<tr>
<td>Use in Advanced Search</td>
<td>Includes the attribute as a field on the Advanced Search form.</td>
</tr>
<tr>
<td>Use in Layered Navigation</td>
<td>Includes the attribute in the layered navigation that is displayed for category lists.</td>
</tr>
<tr>
<td>Use in Search Results Layered Navigation</td>
<td>Includes the attribute in the layered navigation that is displayed for search results lists.</td>
</tr>
<tr>
<td>Position</td>
<td>Determines the position of the attribute when listed with others in the layered navigation list.</td>
</tr>
<tr>
<td>Use in Product Listing</td>
<td>(Depending on theme) Includes the attribute in the product listing.</td>
</tr>
<tr>
<td>Use for Sorting in Product Listing</td>
<td>(Depending on theme) Includes this attribute as an option in the Sort By list, which can be used to sort a product list.</td>
</tr>
</tbody>
</table>
### Rules and Comparison Properties

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comparable on Front-end</td>
<td>Includes the attribute in the Compare Products report.</td>
</tr>
<tr>
<td>Use for Promo Rule</td>
<td>Allows the attribute to be used as the basis of a condition that triggers a promotional Price Rule or Shopping Cart rule.</td>
</tr>
</tbody>
</table>

### Presentation Properties

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Visible on Product View Page</td>
<td>Includes the attribute on the Additional Information tab of the product view page.</td>
</tr>
<tr>
<td>Allow HTML Tags on Frontend</td>
<td>Permits text fields and areas to be manually tagged with HTML.</td>
</tr>
<tr>
<td>Enable WYSIWYG Editor</td>
<td>Makes the WYSIWYG Editor available for tagging a text field or text area with HTML.</td>
</tr>
</tbody>
</table>
Attribute Properties

The Attribute Properties define the individual characteristics that determine how an attribute can be used in the product catalog.

Property Descriptions

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attribute Code</td>
<td>(Required) A unique identifier for internal use. The Attribute Code must begin with a letter, but can include a combination of lowercase letters (a-z) and numbers (0-9). The code must be less than thirty characters in length and cannot include any special characters or spaces, although an underscore (_) can be used to indicate a space.</td>
</tr>
<tr>
<td>Scope</td>
<td>Limits the use of an attribute to a specific store view or website. Options include: Store View, Website, Global</td>
</tr>
<tr>
<td>Catalog Input Type for Store Owner</td>
<td>Determines the data type and input control that is used to manage the product from the store Admin. Options include: Text Field, Text Area, Date</td>
</tr>
<tr>
<td></td>
<td>A single line input field for text.</td>
</tr>
<tr>
<td></td>
<td>A multiple-line input field that can display paragraphs of text formatted with HTML.</td>
</tr>
<tr>
<td></td>
<td>An input field for date values. The date can be typed directly into the field, or selected from a list or calendar.</td>
</tr>
<tr>
<td>PROPERTY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Yes/No</td>
<td>A drop-down list with pre-defined options of “Yes” and “No.”</td>
</tr>
<tr>
<td>Dropdown</td>
<td>A drop-down list of configurable options, from which only one can be selected.</td>
</tr>
<tr>
<td>Multiple Select</td>
<td>Displays a drop-down list of configurable options. To select more than one option, hold down the Ctrl key and click each item.</td>
</tr>
<tr>
<td>Price</td>
<td>An input type that can be used to create price fields in addition to the predefined attributes: Price, Special Price, Tier Price and Cost.</td>
</tr>
<tr>
<td>Media Image</td>
<td>An additional image that can be included in the attribute set of a product.</td>
</tr>
<tr>
<td>Fixed Product Tax</td>
<td>An input type that gives you the ability to define FPT rates based on the requirements of your locale.</td>
</tr>
</tbody>
</table>

**Default Value**

Assigns a starting value to the attribute to help during data entry. To assign a default value for Multiple Select or Dropdown input types, see: Creating Attributes.

A default value cannot be set for Multiple Select, Dropdown, or Fixed Product Tax input types.

**Unique Value**

To prevent duplicate values in a data entry field, set Unique Value to “Yes.” Options include: Yes / No

**Values Required**

To require that a value to be entered in this field before the record can be saved, set Values Required to “Yes.” Options include: Yes / No

**Input Validation for Store Owner**

Performs a validation check of the data entered in the field, based on the following options:

None
Decimal Number
Integer Number
Email
### Property Descriptions (cont.)

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>URL</td>
<td>Letters (a-z, A-Z) or Numbers (0-9)</td>
</tr>
<tr>
<td>Apply To</td>
<td>(Required) Identifies the product types to which this attribute applies. Options include: All Product Types, Selected Product Types, Simple Product, Grouped Product, Configurable Product, Virtual Product, Bundle Product</td>
</tr>
<tr>
<td>Use to Create</td>
<td>(Dropdown input type only) Select “Yes” if this attribute will be used to create a drop-down list for a configurable product. Options include: Yes / No</td>
</tr>
<tr>
<td>Configurable Product</td>
<td></td>
</tr>
</tbody>
</table>
Attribute Frontend Properties

The Frontend Properties determine how an attribute can be used in your store. You can specify how attributes are used in search, layered navigation, product comparisons, price rules, and sorting. For text attributes, you can enable the WYSIWYG editor and specify if HTML tags can be used to format the value.

Frontend Properties

Property Descriptions

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use in Quick Search</td>
<td>Select “Yes” if you want people to be able to search the catalog based on the value of this attribute. Options include: Yes / No</td>
</tr>
<tr>
<td>Use in Advanced Search</td>
<td>Gives shoppers the ability to enter their search criteria through a form. Options include: Yes / No</td>
</tr>
<tr>
<td></td>
<td>Using too many attributes can slow down search.</td>
</tr>
<tr>
<td>Comparable on Front-end</td>
<td>Select “Yes” to include this attribute as a row in the Compare Products report. Options include: Yes / No</td>
</tr>
<tr>
<td>Use In Layered Navigation</td>
<td>(Dropdown, Multiple Select and Price input types only) Includes the attribute as a filter in the “Shop By” section of layered navigation. Options include:</td>
</tr>
<tr>
<td></td>
<td>No The attribute is not used in layered navigation.</td>
</tr>
<tr>
<td></td>
<td>Filterable (with results) Lists only products that match the filter value.</td>
</tr>
</tbody>
</table>
### Property Descriptions (cont.)

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filterable (no results)</td>
<td>Lists all attribute values, even those that do not apply to any product in the list. Layered navigation appears on a category page only if there are filterable attributes available.</td>
</tr>
</tbody>
</table>

| Use In Search Results Layered Navigation       | To include the attribute in the layered navigation for search results, select “Yes.” Options include: Yes / No                                      |
| Use for Promo Rule Conditions                  | To make the attribute available for use in price rules, select “Yes.” Options include: Yes / No                                               |
| Position                                       | Determines the position of the attribute in layered navigation in relation to other filterable attributes.                                        |
| Enable WYSIWYG                                 | (Text Area input type only) To display the editor when entering or editing the attribute value, select “Yes.” The editor can be used to format field descriptions with HTML tags. Options include: Yes / No |
| Allow HTML Tags on Frontend                   | (Text Field and Text Area input types only) To be able to format the attribute value with HTML tags, select “Yes.” Options include: Yes / No        |
| Visible on Product View Page on Front-end      | (Simple and virtual products only) To include the attribute on the Additional Information tab of the product page, select “Yes.” Options include: Yes / No |
| Used in Product Listing                        | Depends on the theme. To include the attribute in product summaries that appear in catalog listings, select “Yes.”                                 |
| Used for Sorting in Product Listing            | (Depends on theme) To include this attribute as a “Sort By” option for catalog listings, select “Yes.”                                         |
Notes
CHAPTER 13:

Flat Catalog

Magento typically stores catalog data in multiple tables, based on the Entity-Attribute-Value (EAV\(^1\)) model. Because attributes are stored in many tables, SQL queries are sometimes long and complex.

In contrast, a flat catalog creates new tables on the fly, where each row contains all the necessary data about a product or category. The flat catalog is updated automatically—either every minute, or according to your cron job. Flat catalog indexing also applies to catalog and shopping cart price rules. A catalog with as many as 500,000 SKUs can be indexed quickly as a flat catalog. To learn more, see: Setting Up a Flat Catalog.

\(^1\)Entity Attribute Value
Setting Up a Flat Catalog

Before you enable a flat catalog for a live store, make sure to test the configuration in a development environment.

Process Overview:
Step 1: Enable the Flat Catalog
Step 2: Verify the Results

Step 1: Enable the Flat Catalog

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left under **Catalog**, select **Catalog**.

2. Click to expand the **Frontend** section. Then, do the following:

   a. Set **Use Flat Catalog Category** to “Yes.”
   
   b. Set **Use Flat Catalog Product** to “Yes.”

3. When complete, click the **Save Config** button.

4. When prompted to refresh the indexes, click the **Index Management** link in the message at the top of the workspace and follow the instructions to reindex the data.
Step 2: Verify the Results

Method 1: Verify the Results for a Single Product

1. On the Admin menu, select Catalog > Manage Products. Then, do the following:
   a. Choose a product to modify. Then, open the product in edit mode.
   b. In the Name field, add the text “_DEMO” to the product name.
2. Click the Save button.
3. On a new browser tab, navigate to the home page of your store.
4. Search for the product you edited, and browse to its assigned category.
   If necessary, refresh the page to verify the results. The change will appear within the minute or according to your cron job schedule.

Method 2: Verify the Results for Multiple Products

1. On the Admin menu, select Catalog > Categories > Manage Categories.
2. In the upper-left corner, set Current Configuration Scope to one of the following:
   • All Store Views
   • A specific store view
3. In the panel on the left, select an existing category. Click the Add Subcategory button, and do the following:
   a. In the Name field, enter “Test Category.”
   b. Set Is Active to “Yes.”
   c. Click the Save Category button.
New Subcategory

d. Click the **Category Products** tab. Then, click the **Reset Filter** button to display all products.

e. Select the checkbox of several products to add them to the new category. Then, click the **Save Category** button.

Category Products

4. On a new browser tab, navigate to the home page of your store. then, Find the category you created.

If necessary, refresh the page to verify the results. The change will appear within the minute or according to your cron job schedule.
CHAPTER 14:

Creating Products

Choosing a product type is one of the first things you must do to create a new product. In this chapter, you will learn how to create a product of each type. To learn more about all the available options, see Product Information.

If you are just starting out, you can create a few sample products and experiment with each type. Before building your catalog, make sure to read Navigation by Category and Catalog URL Options. This material will give you a good understanding of the relationship between your store’s navigation, the categories in your catalog.
Product Types

Simple Product

A simple product is a physical item with a single SKU. Simple products have a variety of pricing and of input controls which makes it possible to sell variations of the product. Simple products can be used in association with grouped, bundle, and configurable products.

Grouped Product

A grouped product presents multiple, standalone products as a group. You can offer variations of a single product, or group them for a promotion. The products can be purchased separately, or as a group.

Configurable Product

A configurable product appears to be a single product with lists of options for each variation. However, each option represents a separate, simple product with a distinct SKU, which makes it possible to track inventory for each variation.

Virtual Product

Virtual products do not have a physical presence, and are typically used for such things as services, warranties, and subscriptions. Virtual products can be used in association with grouped and bundle products.
Bundle Product

A bundle product let customers “build their own” from an assortment of options. The bundle could be a gift basket, computer, or anything else that can be customized. Each item in the bundle is a separate, standalone product.

Downloadable

A digitally downloadable product that consists of one or more files that are downloaded. The files can reside on your server or be provided as URLs to any other server.
Simple Product

One of the keys to harnessing the power of product types is learning how and when to use a simple, standalone product. Simple products can be sold individually, or as part of a grouped, configurable, or bundle product. A simple product with custom options is sometimes referred to as a composite product\(^1\).

Creating a Simple Product

The following instructions take you through the process of creating a simple product with the basic fields. Each required field is marked in the Admin with a red asterisk (*). After you complete the required settings and save the product, you can add images and complete the remaining product information as needed.

**Process Overview:**

Step 1: Choose the Attribute Set  
Step 2: Complete the Basic Information  
Step 3: Complete the Remaining Product Information

\(^1\)Any product type that offers customers a choice of options.
Step 1: Choose the Attribute Set

The first step is to choose the attribute set, which is used as a template for the product record. The product in this example is based on the Default attribute set, which includes a standard set of fields that can be used for most products.

1. On the Admin menu, go to Catalog > Manage Products.
2. In the upper-right corner of the Manage Products page, click the Add Product button.
3. In the Create Product Settings section, do the following:
   a. Accept the “default” Attribute Set, or select another.
   b. Set Product Type to “Simple,” and click the Continue button.

Step 2: Complete the Basic Information

The basic set of required fields must be completed before the product record can be saved. The Product Information panel groups related fields by topic and the required fields are marked with a red asterisk (*).

1. In the Product Information panel, select General. Then, complete the required fields as follows:
   a. Enter the product Name as you want it to appear in all catalog listings.
   b. In the Description box, enter the main description that will appear on the Product Detail page.
   c. Enter a Short Description of the product.
   d. Assign a unique SKU for the product.
   e. Enter the Weight of the product, which is used to calculate shipping.
   f. Set Status to “Enabled.”
   g. Set Visibility to “Catalog, Search.”
2. In the Product Information panel, select **Prices**. Then, complete the required fields as follows:
   a. Enter the **Price** that you will charge for the product.
   b. Set **Tax Class** to the appropriate tax classification for the product.

3. In the Product Information panel, select **Inventory**. Then, do the following:
   a. If you do not need to keep track of inventory for the product, set **Manage Stock** to “No.”

   Depending on the configuration, you might need to clear the Use Config Settings checkbox.
Inventory with No Stock Management

b. If you want to keep track of inventory, set Manage Stock to “Yes.” Then, do the following:
   
   - In the Qty field, type the quantity of the item that is currently in stock.
   - Set Stock Availability to “In Stock.”

Inventory with Stock Management

4. To be visible in your catalog, the product must be assigned to a category. To assign the product to a category, do the following:
   
a. In the Product Information panel, select Categories.
   
b. In the category tree, click to expand the section where the item belongs.
   
c. Select the checkbox of each category where you want the product to appear.

5. If your Magento installation has multiple websites, the product must be assigned to each one where the product is available for sale. (This option appears only if multiple websites exist in the store hierarchy.) To configure the scope of the product, do the following:
   
a. In the Product Information panel, select Websites.
   
b. On the Websites tab, select the checkbox of each website where the product is available for sale.

6. After completing these steps, click the Save and Continue button.

At this point, the product should be visible on the assigned category page of your catalog. Until the product image is uploaded, a placeholder appears in its place.
Step 3: Complete the Product Information

Although not required, there is still more product information to complete. At the very least, you will want to upload product images and complete the meta data. In addition, you can create additional custom options.

THINGS TO REMEMBER

- A simple product can have custom options with a variety of input controls, which makes it possible to sell many product variations from a single SKU.
- Custom options are not tracked as separate inventory items.
- A simple product that is included in a configurable, or bundle product type cannot have custom options.
A grouped product is made up of multiple, standalone products that are presented as a group. You can offer variations of a single product, or group them by season or theme to create a coordinated set. Each product can be purchased separately, or as part of the group.

Creating a Grouped Product

The following instructions take you through the process of creating a grouped product with the basic fields. Each required field is marked in the Admin with a red asterisk (*). After you complete the required settings and save the product, you can add images and complete the remaining product information, as needed.

**Process Overview:**

Step 1: Create the Grouped Product
Step 2: Add the Associated Products
Step 3: Configure the Shopping Cart Thumbnails
**Step 1: Create the Grouped Product**

The first step is to choose the attribute set, which is used as a template for the product record. The product in this example is based on the Default attribute set, which includes a standard set of fields that can be used for most products.

1. On the Admin menu, select **Catalog > Manage Products**. Then, click the **Add Product** button.

2. In the Create Product Settings section, do the following:
   a. Select the **Attribute Set** you want to use as a template for the product.
   b. Set **Product Type** to “Grouped Product,” and click the **Continue** button.

3. Complete the main configuration settings as you would for a simple product, with the following exceptions:
   - A grouped product does not have price options because the price of each item in the group originates from the associated product.
   - On the Inventory tab, you can set quantity increments and stock availability for the group as a whole, but the inventory of individual items is managed by the individual associated products.

4. Click the **Save and Continue** button.
Step 2: Add the Associated Products

1. In the Product Information panel on the left, select **Associated Products**. Then, do the following:

   a. To display the complete unfiltered list, click the **Reset Filter** button.

   b. If you need help finding the products you want, use the **filter controls** at the top of a column.

   c. Select the **checkbox** of each product that you want to include.

   d. To list only the products you have selected, set the filter control at the top of the checkbox column to “Yes.” Then, click the **Search** button.

2. Click the **Save** button to save your changes.

Step 3: Configure the Shopping Cart Thumbnails

1. On the Admin menu, select **System > Configuration**.

2. In the Configuration panel on the left, under Sales, select **Checkout**.

3. Click to expand the **Shopping Cart** section. Then, set **Grouped Product Image** to one of the following:
   - Product Thumbnail Itself
   - Parent Product Thumbnail
4. Click the **Save Config** button to save the setting.

**THINGS TO REMEMBER**

- A grouped product is essentially a collection of simple associated products.
- Simple and virtual products associated with a grouped product cannot have custom options.
- Each item purchased appears individually in the shopping cart, rather than as part of the group.
- The thumbnail image in the shopping cart can be set to display the image from the grouped product record, or from the associated product.
Configurable Product

A configurable product looks like a single product with drop-down lists of options for each variation. Each option is actually a separate simple product with a unique SKU, which makes it possible to track inventory for each product variation. You could achieve a similar effect by using a simple product with custom options, but without the ability to track inventory for each variation. Products with multiple options are sometimes referred to as composite product.

Although a configurable product uses more SKUs, and may initially take a little longer to set up, it can save you time in the long run. If you plan to grow your business, the configurable product type might be a better choice for a product with multiple options.

Creating a Configurable Product

The following instructions take you through the process of creating a configurable product with the basic fields. Each required field is marked in the Admin with a red asterisk (*). After you complete the required settings and save the product, you can add images and complete the remaining product information, as needed.

1Any product type that offers customers a choice of options.
Process Overview:
Step 1: Create Attributes for Drop-down Options
Step 2: Create the Attribute Set
Step 3: Create the Configurable Product
Step 4: Add the Associated Products
Step 5: Make Any Necessary Price Adjustments
Step 6: Configure the Shopping Cart Thumbnails

Step 1: Create Attributes for Drop-Down Options

Create an attribute for each drop-down list of options that you want to include in the configurable product. If the attribute already exists and has the correct properties, you can add it to the attribute set in the next step. To learn more, see: Creating Attributes.

Required Attribute Properties

<table>
<thead>
<tr>
<th>PROPERTY</th>
<th>SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scope</td>
<td>Global</td>
</tr>
<tr>
<td>Catalog Input Type for Store Owner</td>
<td>Dropdown</td>
</tr>
<tr>
<td>Apply to</td>
<td>Configurable Product or All Product Types</td>
</tr>
<tr>
<td>Use to Create Configurable Product</td>
<td>Yes</td>
</tr>
</tbody>
</table>

Step 2: Create the Attribute Set

1. On the Admin menu, select Catalog > Attributes > Manage Attribute Sets. Then, click the Add New Set button.
2. Assign a Name to the attribute set.
3. In the Based On list, select an existing attribute set, such as “Default,” to use as a template. Then, click the Save Attribute Set button.
4. Starting from the list of Unassigned Attributes, drag and drop each attribute you want to include in the product to the center column. You can arrange them in any order.
5. To group the attributes in their own section of the Product Information panel, do the following:
   a. In the Groups section, click the Add New button.
      
      If prompted by your browser, select “Temporarily Allow Scripted Windows” to continue. Then, click the Add New button again.
   b. When prompted, enter a Name for the new group. Then, click the OK button.
The new group appears at the bottom of the Groups column.

c. Drag and drop each attribute that you created for the drop-down options to group where you want them to appear.

![Attribute Set](image)

6. Click the Save Attribute Set button.

7. When prompted to update your cache, click the link in the message and refresh the invalid cache.

**Step 3: Create the Configurable Product**

1. On the Admin menu, select Catalog > Manage Products. Then, click the Add Product button.

2. In the Create Product Settings section, do the following:
   a. Select the Attribute Set that you created for the product.
   b. Set Product Type to “Configurable Product,” and click the Continue button.

![Create Product Settings](image)

3. In the Select Configurable Attributes section, select the checkbox of each attribute that you want to include in the product. Then, click the Continue button.
4. Complete the Product Information as you would for a simple product, with the exception of the following fields:
   - On the Prices tab, the Price is a required field, but is used as a default price. The price of each individual associated product can be adjusted accordingly.
   - On the Inventory tab, Manage Stock is set to “No” by default, because inventory is managed by each associated product.

5. When complete, click the Save and Continue Edit button.

Step 4: Add the Associated Products

Process Overview:
Method 1: Quick Simple Product Creation
Method 2: Create Empty
Method 3: Copy from Configurable

1. In the panel on the left, select the last option, Associated Products.
2. Then, use one of the following methods to add the associated products.

Method 1: Quick Simple Product Creation

This method automatically creates the associated products and optionally, assigns a Name and SKU to each one.

1. In the Quick Simple Product Creation section, the Name and SKU are set to Autogenerate, which makes it easy to see which products belong to the configurable product. However, if you want to change the default value, you can clear the checkbox and enter a different value.

2. For each associated product that you want to create, do the following:
   a. Enter the Weight.
   b. Set Status to “Enabled.”
   c. To prevent the associated products from being listed individually in the catalog, set Visibility to “Not Visible Individually.”
3. To complete the fields for the drop-down lists, do the following:
   a. For each of the configurable attributes that you set up, select the values that apply to the first product.
   b. Enter the Qty, and set Stock Availability to “In Stock.”
   c. Click the Quick Create button to create the associated product record.

![Quick Simple Product Creation](image)

Quick Simple Product Creation

4. To create additional associated products, do the following:
   a. Select the value for each configurable attribute.
   b. If there is an extra charge for the selection, enter the adjustment in the Price field.
   c. Click the Quick Create button.

Repeat this step to create as many associated product as you need. As each associated products is created, it appears in the list at the bottom of the page.

![List of Associated Products](image)

List of Associated Products
Method 2: Create Simple Associated Product

This method opens a blank Product Information form, which you can complete for each associated product.

1. In the Create Simple Associated Product section, click the Create Empty button. A pop-up window with a blank Product Information form appears.
2. Complete the required fields as you would for any simple product.
3. Click the Save button to add the associated product.

Method 3: Copy from Configurable

This method opens a Product Information form that contains the values already entered for the configurable product. The only fields that need to be completed are the Name, SKU, and values for each drop-down attribute.

1. In the Create Simple Associated Product section, click the Copy From Configurable button. A pop-up window with the basic Product Information from the configurable product appears.
2. Complete the following required fields:
   - SKU
   - Weight
3. Complete the fields with values for each drop-down list.
4. Click the Save button to add the associated product to the configurable product record.

Step 5: Make Any Necessary Price Adjustments

Use the Super Products Attributes Configuration section to make price adjustments to a specific associated product. The adjustment can be entered as a fixed value or percentage, and is made in relation to the price of the configurable product.
Step 6: Configure the Shopping Cart Thumbnails

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under Sales, select Checkout.

2. Click to expand the Shopping Cart section. Then, set Configurable Product Image to one of the following:
   - Product Thumbnail Itself
   - Parent Product Thumbnail

3. Click the Save Config button to save the setting.

THINGS TO REMEMBER

- A configurable product allows the shopper to select options from drop-down lists. Each option is actually a separate, simple product.

- The drop-down list values are based on attributes that must be set up in advance with required settings. The attribute Scope must be set to “Global,” and Use to Create Configurable Product must be “True.” The drop-down attributes must be included in an attribute set, which is then used as a template for the configurable product.

- The simple products associated with a configurable product cannot include custom variants or options, and must be based on the same attribute set that is used to create the configurable product. The associated products can be generated automatically from inside with configurable product record.

- The thumbnail image in the shopping cart can be set to display the image from the configurable product record, or from the associated product.
Virtual Product

Although virtual products are not physical in nature, they do represent something that can be sold, such as a membership, service, warranty, or subscription. Virtual products can be sold individually, or included as part of the following product types:

- **Grouped Product**
- **Bundle Product**

The process of creating a virtual product and a simple product is nearly the same. However, because a virtual product is not shipped, there is no Weight field or option to include a gift card.
Creating a Virtual Product

The following instructions take you through the process of creating a virtual product with the basic fields. Each required field is marked in the Admin panel with a red asterisk (*). After you complete the required settings and save the product, you can complete the remaining product information as needed.

**Process Overview:**

1. **Choose the Attribute Set**
2. **Complete the Required Fields**
3. **Complete the Remaining Product Information**

**Step 1: Choose the Attribute Set**

1. On the Admin menu, select **Catalog > Manage Products**.
2. In the upper-right corner of the Manage Products page, click the **Add Product** button.
3. In the Create Product Settings section, do the following:
   
   a. Accept the “default” **Attribute Set**, or select another.
   
   b. Set **Product Type** to “Virtual Product,” and click the **Continue** button.

**Step 2: Complete the Required Fields**

Complete the required fields as you would for a **simple product**. The only difference is that a virtual product has no weight. All required fields are marked with a red asterisk (*).

1. On the **General** tab, complete the required fields as follows:
   
   a. Type the product **Name** as you want it to appear in all catalog listings.
   
   b. In the **Description** box, enter the main description that will appear on the product view page.
   
   c. Enter a **Short Description** of the product.
   
   d. Assign a unique **SKU** to the product.
   
   e. Set **Status** to “Enabled.”
   
   f. Set **Tax Class** to the appropriate setting for your area.
g. Set Visibility to “Catalog, Search.”

2. On the Prices tab, enter the Price you intend to charge for the product or service.

3. If you’re not going to manage your inventory, you can skip this section. Otherwise, complete the required fields on the Inventory tab as follows:
   a. Under Manage Stock, clear the Use Config Settings checkbox. Then, set Manage Stock to “Yes.”
   b. In the Qty field, enter the quantity of the item currently in stock.
   c. Set Stock Availability to “In Stock.”

4. If applicable, on the Website tab, select the checkbox for the website where the product or service will be available for sale.

5. On the Categories tab, assign the product to the appropriate categories, as follows:
   a. In the Product Category tree, click to expand the section where the item belongs.
   b. Select the checkbox to assign the product to each category where you want the product to be listed in the catalog.

6. When the required fields are complete, click the Save and Continue button.

**Step 3: Complete the Product Information**

You have now completed the required fields. The next step is to complete the rest of the product information as needed for this product. The meta information and product images are a good place to start.

**THINGS TO REMEMBER**

- Virtual products can be used for anything that is not physical in nature, such as services, subscriptions, and warranties.
- Virtual products are much like simple products, but without the Weight and Allow Gift Message fields.
- Shipping Options appear during checkout only if there is also a physical product in the cart.
Bundle Product

A bundle is a “build your own,” customizable product. Each item in a bundle can be based on one of the following product types:

- Simple Product
- Virtual Product

Creating a Bundle Product

The following instructions take you through the process of creating a bundle product with the basic fields. Each required field is marked with a red asterisk (*). After you complete the required settings and save the product, you can complete the remaining Product Information as needed.
Process Overview:
Step 1: Create the Bundle Product
Step 2: Complete the Product Information
Step 3: Add Bundle Items

Step 1: Create the Bundle Product

1. On the Admin menu, select Catalog > Manage Products. Then, click the Add Product button.
2. In the Create Product Settings section, select the Attribute Set for the product.
3. In the Create Product Settings section, do the following:
   a. Accept the “default” Attribute Set, or select another.
   b. Set Product Type to “Bundle Product.” Then, click the Continue button.

Step 2: Complete the Product Information

1. Complete the product information as you would for a simple product, with the exception of the following:
   a. On the General tab, set both the SKU and Weight fields to one of the following:
      • Dynamic
      • Fixed
      If using a fixed SKU or Weight, enter the actual value in the field to the right.
   b. On the Prices tab, set Price to one of the following:
      • Dynamic
      • Fixed
      If using a fixed price, enter the actual value in the field to the right.

Minimum Advertised Price (MAP) is not available for Bundle products with dynamic pricing.
Dynamic Price

c. Then, set **Price View** to one of the following:

- As Low as
- Price Range

2. Click the **Save and Continue Edit** button.

## Step 3: Add Bundle Items

1. In the Product Information panel on the left, select the last option, **Bundle Items**.

2. Then in the Shipment section, set **Ship Bundle** Items to one of the following:

- Together
- Separately

3. In the Bundle Items section, click the **Add New Option** button.

4. In the **Default Title** box, enter a label for the bundle item, as you want it to appear on the Customize Product page. Then, do the following:
a. Set **Input Type** to one of the following:
   - Drop-down
   - Radio Buttons
   - Checkbox
   - Multiple Select

b. Set **Is Required** as needed.

c. In the **Position** field, enter the order that you want this item listed in relation to other items included in the bundle.

5. Click the **Add Selection** button. Then, do the following:

   ![Select Products](image)

Select Products

a. Click the **Reset Filter** button to display the unfiltered list of products.

b. Select the checkbox of each product that you want to include in this item.

c. In the **Qty to Add** column, enter the quantity of each item to be included.

6. Click the **Add Selected Product(s) to Option** button. When the items appear in the Bundle Items list, do the following:

a. Set **User Defined Qty** to one of the following:

   Yes Displays an input box so the customer can change the quantity.

   No Prevents the customer from changing the default quantity.

b. Enter a number in the **Position** column of each item to determine its place in relation to other items.

c. To make an item the default selection, select the **Default** option of the item to be pre-selected in the form.
7. Repeat steps 3-7 for each bundle item you want to include.

8. When complete, click the **Save** button to save the bundle product.

### Field Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>SKU</td>
<td>Determines if each item is assigned a variable, dynamic SKU, or if a fixed SKU is used for the bundle. Options include: Fixed / Dynamic.</td>
</tr>
<tr>
<td>Weight</td>
<td>Specifies the weight is calculated based on the items selected, or is a fixed weight for the entire bundle. Options include: Fixed / Dynamic.</td>
</tr>
<tr>
<td>Price View</td>
<td>Determines if the product price is shown as a range, from the least expensive to the most expensive (Price Range), or with the least expensive shown (As Low As). Options include: Price Range / As Low As.</td>
</tr>
<tr>
<td>Ship Bundle Items</td>
<td>Specifies if individual items can be shipped separately.</td>
</tr>
</tbody>
</table>
THINGS TO REMEMBER

- A bundle is a “build your own” product.
- Bundle items can be simple or virtual products without custom options.
- The Price View can be set to a price range or “As Low As.”
- SKU and Weight can be either “Fixed” or “Dynamic.”
- The Quantity can be set to a pre-set or user-defined value.
- Items can be shipped together or separately.
Downloadable Product

A downloadable product can be anything that you can deliver as a file, such as an eBook, music, video, software application, or an update. You can offer an album for sale, and sell each song individually. You can also use a downloadable product to deliver an electronic version of your product catalog.

Because the actual download doesn’t become available until after the purchase, you can provide samples, such as an excerpt from a book or a clip from an audio file, that the customer can try from the product page.

Downloadable products can be configured to require that the customer log in to an account to receive the link, or can be sent by email and shared with others. The status of the order before the download becomes available, default values, and other delivery options are set in the configuration.

The files for download can be either uploaded to your server, or linked to on a different server on the Internet.

Downloadable product filenames can include letters and numbers. You can to use either a dash or underscore character to represent a space between words. Any invalid characters in the file name are replaced with an underscore.

Creating a Downloadable Product
The following instructions take you through the process of creating a downloadable product with the basic fields. Each required field is marked in the Admin with a red asterisk (*). After you complete the required settings and save the product, you can add images and complete the remaining product information as needed.

### Process Overview:

**Step 1: Choose the Attribute Set**

**Step 2: Complete the Basic Product Information**

**Step 3: Complete the Download Information**

**Step 4: Complete the Samples Information**

**Step 5: Complete the Remaining Product Information**

### Step 1: Choose the Attribute Set

The first step is to choose the attribute set, which is used as a template for the product record. The product in this example is based on the Default attribute set, which includes a standard of set of fields that can be used for most products.

1. On the Admin menu, go to **Catalog > Manage Products.**
2. In the upper-right corner of the Manage Products page, click the **Add Product** button.
3. In the Create Product Settings section, do the following:
   - **Attribute Set** is currently set to “Default.” You can leave it as it is, or select another.
   - **Product Type** to “Downloadable Product,” and click the Continue button.

### Step 2: Complete the Basic Product Information

The basic set of required fields must be completed before the product record can be saved. The Product Information panel groups related fields by topic and the required fields are marked with a red asterisk (*).

1. In the Product Information panel, select **General.** Then, complete the required fields as follows:
   - **Enter the product Name as you want it to appear in all catalog listings.**
   - **In the Description box, enter the main description that will appear on the Product Detail page.**
   - **Enter a Short Description of the product.**
d. Assign a unique SKU for the product.

e. Set Status to “Enabled.”

f. Set Visibility to “Catalog, Search.”

2. In the Product Information panel, select Prices. Then, complete the required fields as follows:

a. Enter the Price that you will charge for the product.

The price entered here becomes the base price of the download and is listed in the catalog before the customers selects items for download. Any additional price that is associated with an individual download is added to the base price.

b. Set Tax Class to the appropriate tax classification for the product.

3. In the Product Information panel, select Inventory. Then, do the following:

a. If you do not need to keep track of inventory for the product, set Manage Stock to “No.”

b. If you do need to keep track of inventory, set Manage Stock to “Yes.” Then, do the following:

   - Set Manage Stock to “Yes.”
   - In the Qty field, type the quantity of the item that is currently in stock.
   - Set Stock Availability to “In Stock.”

4. In the Product Information panel, select Categories. Then, do the following:

a. In the category tree, click to expand the section where the item belongs.

b. Select the checkbox of each additional category where you want the product to appear.

5. To make the product available on multiple websites, it must be assigned to each one. (This option appears only if you have multiple websites.) To configure the scope of the product, do the following:

a. In the Product Information panel, select Websites.

b. Select the checkbox of each website where the product will be available for sale.

6. After completing these steps, click the Save and Continue Edit button.
**Step 3: Complete the Download Information**

1. In the Product Information panel, select **Downloadable Information**.

2. In the Links section, do the following:
   a. Enter a **Title** for the list of downloadable products.
   b. Set **Links can be purchased separately** to one of the following:
      - If you want to offer multiple download links, such as to sell individual songs on an album, select “Yes.”
      - To offer a single download of this item, select “No.”

3. Click the **Add New Row** button, and do the following:
   a. Enter the **Title** and **Price** of the download.
   b. To limit the number of downloads a customer can make, enter the number in the **Max number of downloads** field. To allow unlimited downloads, select the **Unlimited** checkbox.
   c. Set **Sharable** to your preference.
      - To require that customers log in to their accounts to access the download link, select “No.”
      - To send the link by email, which the customer can then share with others, select “Yes.”

4. Under **Sample**, use one of the following methods to deliver a sample of the downloadable product.
   - Select the **File** option. Then, click the **Browse** button, and select the sample file to upload to the server.
   - Select the **URL** option. Then, paste the full **URL** of the sample file.

5. Under **File**, use one of the following methods to deliver the actual downloadable product.
   - Select the **File** option. Then, click the **Browse** button, and select the file to upload.
   - Select the **URL** option. Then, paste the full **URL** of the file that is available for download.

6. In the **Sort Order** field, enter a number to indicate the sequence that this download will be listed with other downloads on the product page.

7. To add another download, click the **Add New Row** button, and repeat the process.
8. When complete, if uploading files to the server, click the **Upload Files** button.

9. Click the **Save and Continue Edit** button.

**Step 4: Complete the Samples Information**

1. Click to expand the **Samples** section.

2. Enter a **Title** for the section of samples on the product page.

3. Click the **Add New Row** button. Then, do one of the following:

   - Select the **File** option. Then, click the **Browse** button, and select the sample file to upload.
   
   - Select the **URL** option. Then, paste the full **URL** of the sample file.

4. To add a new row, click the **Add New Row** button, and repeat the process.

5. When complete, click the **Save** button.

6. When prompted to refresh the index and cache, click the links in the message at the top of the workspace, and follow the instructions.

   At this point, the product should be visible on the assigned category page of your catalog. Until a product image is uploaded, a placeholder appears in its place.
Step 5: **Complete the Product Information**

Although not required, there is other product information to complete. At the very least, you will want to upload product images and complete the meta data.

**THINGS TO REMEMBER**

- Downloadable products can be uploaded to the server, or linked to from another server on the Internet.
- You can determine the number of times a customer can download a product.
- Customers purchasing downloadable products can be required to log in before going through checkout.
- The delivery of a downloadable product can be made when the order is in either a “Pending” or “Invoiced” state.

**Downloadable Product Options**

The configuration settings determine guest checkout, default values, and delivery options for downloadable products.

**To configure downloadable options:**

1. On the Admin menu, select **System > Configure**. Then in the panel on the left, under Catalog, select **Catalog**.
2. Click to expand the **Downloadable Product Options** section. Then do the following:

   ![Downloadable Product Options](image)

   **Downloadable Product Options**

   a. To determine the status an order must have to access available downloads, set **Order Item Status to Enable Downloads** to one of the following:
      - Pending
      - Invoiced
b. Enter the **Default Maximum Number of Downloads** that a customer can purchase in a single order.

c. To determine if customers must log in to their accounts to access the download link, set **Shareable** to one of the following:

   - Yes: Allows the link to be sent by email, which can then be shared with others.
   - No: Prevents guest purchases by requiring customers to log in to their accounts to access the download link.

d. Enter a **Default Sample Title** to be used for all downloadable files.

e. Enter a **Default Link Title** to be used for all download links.

f. If you want download links to open in a new window, set **Open Links in New Window** to “Yes.”

g. To specify how the download link is to be delivered, set **Use Content Disposition** to one of the following:

   - Attachment: Delivers the download link as an email attachment.
   - Inline: Delivers the download link as an inline link on a web page.

h. To require that guests who purchase downloadable products create an account to complete the checkout process, set **Disable Guest Checkout if Cart Contains Downloaded Items** to “Yes.”

3. When complete, click the **Save Config** button.
Notes
CHAPTER 15:

Product Images

Using images of consistent quality, size, and proportion gives your product catalog a professional look with commercial appeal. If you have a large catalog with several images per product, you can easily have hundreds, if not thousands of product images to manage. Before you get started, it’s a good idea to establish a naming convention for your image files, and organize them so you can find the originals if you ever need them.

The Images tab in the Product Information panel is used to upload and manage individual images for the current product. You can upload multiple images for each product, with different images for each website or store view. However, if you have a large quantity of images to manage, it is more efficient to import, rather than upload each one individually. To learn more, see: Importing Product Images.
Thumbnail Gallery

The thumbnail gallery on the product page can be used to display multiple images of the product. Although the position of the gallery varies by theme, it is usually just below the main image on the product page. Click each image to browse through the thumbnail gallery.
Light Boxes and Sliders

Many stores use a third-party light box or slider to display product images in a more elegant fashion. Typically with a light box, whenever a thumbnail image is clicked, it replaces the main image on the page. You can use the left and right arrows in the light box to browse through the images, or click a thumbnail to view a specific image. When zoom is activated, you can click the main image and move the cursor around to magnify different parts of the image. The magnified selection appears to the right of the image. You can find a variety of light box and slider extensions available in Magento Connect.

Image Zoom

Magento displays a magnified portion of the image on mouseover, provided that you have uploaded a larger image that can be used to zoom in for a closer look. When zoom is activated, you can click the main image and move the cursor around to magnify different parts of the image. The magnified selection appears to the right of the image.
Image Size and Type

As a best practice, you should standardize the size of your images so they appear at the highest possible resolution. A single product image can be displayed in several different sizes throughout your catalog. In addition to the main image on the product page, there are smaller images and thumbnails.

Image types are used in different places in your catalog. If you have only one product image, you can use the same image for each type. If you do not assign an image to each type, a placeholder image is used to mark its place in the catalog.

**To configure product images:**

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left under Catalog, select **Catalog**.

2. Click to expand the **Product Image** section, and do the following:

   ![Product Image](image)

   **Product Image**

   a. In the **Base Image Width** field, enter the maximum width that the base image is to be rendered.

   b. In the **Small Image Width** field, enter the maximum width that the small image is to be rendered.

3. When complete, click the **Save Config** button.
## Image Types

<table>
<thead>
<tr>
<th>IMAGE TYPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Thumbnail</td>
<td>Thumbnail images appear in the thumbnail gallery, shopping cart, and in some blocks such as Related Items. Example size: 50 x 50 pixels</td>
</tr>
<tr>
<td>Small Image</td>
<td>The small image is used for the product images in listings on category and search results pages, and to display the product images needed for sections such as for Up-sells, Cross-sells, and the New Products List. Example size: 470 x 470 pixels</td>
</tr>
<tr>
<td>Base Image</td>
<td>The base image is the main image on the product detail page. Image zoom is activated if you upload an image that is larger image than the image container. Example sizes: 470 x 470 pixels (without Zoom) 1100 x 1100 pixels (with Zoom)</td>
</tr>
<tr>
<td>Media Image</td>
<td>(Optional) A media image gives you the ability to associate additional images with a product, that are other than a product image. For example, you might include the product logo, care instructions, or an image of the ingredients from a food label. If you add a media image attribute to the attribute set of a product, it is listed as an additional image type, along with Base, Small, and Thumbnail. You can set it to &quot;Exclude&quot; so it doesn't appear in the gallery.</td>
</tr>
</tbody>
</table>
Adding Product Images

The Images tab is used to upload and manage images for a single product. You can upload multiple images for the product, and maintain different images for each website or store view. However, if you have many images to manage, you might prefer to import them, rather than upload product images individually.

To add product images:

1. If the images are to be used for only a specific store view, set Choose Store View in the upper-left corner to identify the view where the images will be used.

2. In the panel on the left, click Images.

3. Click the Browse Files button, and select the product images files you want to upload to your store.

4. Click the Upload Files button to upload the selected images to your store. Then, for each image, do the following:
   a. Enter a descriptive Label for the image. This text appears on mouseover and can improve indexing by search engines.
   b. If using multiple images, enter a numeric value in the Sort Order field to determine the sequence in which they appear in the thumbnail gallery.
   c. To prevent an image from being included in the thumbnail gallery, click the Exclude checkbox. For example, if the product has only one image, there’s no reason to include it in the gallery.
   d. To delete any image, select the Remove checkbox.

5. When complete, click the Save and Continue Edit button.
To add images to the gallery:
Follow the same process to add a new product image. For best results, gallery image files should be the same size and proportion as the main product image.

Field Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image</td>
<td></td>
<td>On mouseover, a thumbnail of each uploaded image appears.</td>
</tr>
<tr>
<td>Label</td>
<td></td>
<td>The label is the descriptive &quot;Alt&quot; text that appears on mouseover. Including a label for each image improves indexing by search engines, and accessibility for people who use screen readers.</td>
</tr>
<tr>
<td>Sort Order</td>
<td></td>
<td>Determines the order in which images are displayed in the gallery.</td>
</tr>
<tr>
<td>Thumbnail</td>
<td>Store View</td>
<td>The Thumbnail image is used in the shopping cart and in some blocks, such as Related Items.</td>
</tr>
<tr>
<td>Small Image</td>
<td>Store View</td>
<td>The Small Image is used in product listings on the category and search results pages, and to display product images in additional sections such as Upsells, Cross-sells, and the New Products List.</td>
</tr>
<tr>
<td>Base Image</td>
<td>Store View</td>
<td>The Base Image is the main image on the product page, and is also used to produce the magnified area displayed during image zoom.</td>
</tr>
<tr>
<td>Media Image</td>
<td>Store View</td>
<td>(Optional) The Media Image appears only if an attribute of the Media Image type is included in the attribute set.</td>
</tr>
<tr>
<td>Exclude</td>
<td></td>
<td>Select the Exclude checkbox to prevent the image from being listed in the thumbnail gallery.</td>
</tr>
<tr>
<td>Remove</td>
<td></td>
<td>Select the Remove checkbox to delete the image. Selected images are deleted when the product record is saved.</td>
</tr>
</tbody>
</table>
Placeholder images are temporary placeholder images that are used by default until permanent product images are available. The initial placeholder image is the Magento logo, which you can later replace with placeholders images of your own design.

To upload placeholder images:

1. On the Admin menu, select System > Configuration. Then in the Configuration panel on the left under Catalog, select Catalog.

2. Click to expand the Product Image Placeholders section. Then, do the following:

   a. For each image type, click the Choose File button to navigate to, and upload the placeholder image you want to use for the Base Image, Small Image, and Thumbnail images. You can use the same image, or upload a different image for each type.

   b. When complete, click the Save Config button.
Watermarks

If you go to the expense of creating your own original product images, there is not much you can do to prevent unscrupulous competitors from stealing them with the click of a mouse. However, you can place a watermark on each image to identify it as your property and make it a less attractive target. A watermark file can be either a .jpg (jpeg), .gif, or .png image.

Example: Watermark Positions

The watermark used in these examples is a .png file 470 x 470 pixels square, with a black logo and transparent background. The size and opacity were later adjusted to 100 x 100 pixels at 10% using the watermark configuration settings in the Admin panel. You can experiment with different watermark settings until you find the look you want.
To place watermarks on product images:

1. On the Admin menu, select System > Configuration. Then in the Configuration panel on the left under General, select Design.

2. Click to expand the Product Image Watermarks section.

3. Complete the following steps for the Base, Small, and Thumbnail images:
   
   a. Enter the Watermark Default Size, in pixels. For example: 200 x 300
   
   b. Enter the Watermark Opacity, as a percentage. For example: .40
   
   c. Click the Browse button and select the Watermark image file to upload.
   
   d. Set Watermark Position to your preference.

4. When complete, click the Save Config button.
CHAPTER 16: Swatches

Swatches provide an alternate way to display the selection of options for configurable products. Rather than choosing an option from a drop-down list, customers can make their selection by clicking a swatch. Configurable swatches can be used on the product page, product list, and in layered navigation.

In this chapter, you will learn how to use swatches to make the presentation of configurable products more appealing and informative. Topics include:

- How Swatches are Used
- Swatch Configuration
- Adding New Attribute Values
- Preparing Swatch Images
- Uploading Swatch Images
- Swatch Images Cache

Color and Size Swatches on Product Page
Swatch Workflow

On the product page, swatches can be used to indicate the combinations of color and size that are currently available. Any option that is not available is crossed out. In the following example, the pistachio loafer is available only in size 8, so the rest of the sizes are crossed out. You can click each color swatch to see the available sizes, and click each size swatch to see the available colors. When a swatch is selected, the value appears in the input field, and the selected swatch is outlined as the current selection.

Unavailable Size Swatches Crossed Out

Swatches can be set up to display the corresponding product image when the swatch is clicked. For example, from the product list or product page, you can click the swatch to change the color of the main image.

Text-Based Swatches

If there isn’t an image available for a swatch, the attribute value appears as text. A text-based swatch is like a button with a text label, and behaves in the same way as a swatch with an image. In the following example, the color swatches are identified with a text label for the color name, just as the shoe size swatches have a text label for the size. If the size attribute values were “Small,” “Medium,” and “Large,” rather than numbers, then that text would appear in the swatches instead.
Swatches in Layered Navigation

Swatches can also be used in layered navigation, if the Use in Layered Navigation property of the corresponding attribute is set to “Yes.” The following example shows both text-based and color image swatches in layered navigation.
Swatch Configuration

This discussion begins with the understanding that you already have configurable products in your catalog. If you do not have working configurable products, you will need to set them up to continue.

Process Overview:
Step 1: Complete the Configuration
Step 2: Test the Swatches In Your Store

Step 1: Complete the Configuration

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Catalog, select Configurable Swatches.

2. Click to expand the General Settings section. Then, do the following:

   a. Set Enabled to “Yes.”

   b. In the list of Products Attributes to Show as Swatches in Product Detail, select each attribute whose values you want to appear as a swatch.

      The list includes only the attributes that can be used to create configurable products. The attribute must be the Dropdown type, and Use to Create Configurable Product must be set to “Yes.”

   c. Select the Product Attribute to Use for Swatches in Product Listing.

      Because of the limited space in the product listing, only one attribute can chosen to appear as a swatch in the product list.
3. To set the size of the swatches used on the product detail page, do the following:
   a. Click to expand the Swatch Dimensions on Product Detail Page section.
   b. Enter the Width and Height in pixels.
      Just for reference, the swatches in the product page examples in this guide are 35 pixels square.

4. To set the size of the swatches used in the product listing, do the following:
   a. Click to expand the Swatch Dimensions in Product Listing section.
   b. Enter the Width and Height in pixels.

5. To set the size of the swatches used in layered navigation, do the following:
   a. Click to expand the Swatch Dimensions in Layered Navigation section.
   b. Enter the Width and Height in pixels.

6. When complete, click the Save Config button.
7. If prompted that the cache needs to be refreshed, click the Cache Management link in the message at the top of the workspace. Select the checkbox of each invalid cache. Then, with the Actions control set to “Refresh,” click the Submit button.

While you’re in Cache Management, notice the Flush Swatch Images Cache button in the Additional Cache Management section at the bottom of the page. If you ever need to update or replace existing swatches, this is how you can clear all cached swatches.

**Step 2: Test the Swatches In Your Store**

1. Verify that the swatches work correctly from your storefront. Even without any swatch images, the text-based swatches should appear in the store, and work correctly.

2. If any drop-down options from the configurable product are missing from layered navigation, do the following:
   - Verify that the attribute frontend property, Use in Layered Navigation is set to “Yes.”
   - Return to Cache Management and click the Flush Magento Cache button.
Adding Swatch Attribute Values

As you add products to your catalog, you will need to update the attribute values that correspond to each swatch. For example, if you sell clothing, you will need to add new colors to the color attribute to match the products. You can add as many values as you need to any attribute that is represented by a swatch. We use color as an example, but the process is the same for any attribute you might use.

To add new colors:

1. On the Admin menu, select **Catalog > Attributes > Manage Attributes**.
2. In the list, open the color attribute in edit mode.
3. In the panel on the left, click **Manage Label / Options**. Then, do the following:
   a. In the list under Manage Options, click the **Add Option** button.
   b. Under Admin, enter the names of the color as you want it to appear when working from the Admin. Then, enter the name of the color for each language supported, as you want it to appear in the storefront.
   c. To determine the order in which the colors appear, enter a number in the position column.
   d. Repeat this process for as many colors as you need.
4. Click the **Save Attribute** button.
5. When prompted to refresh the cache, click the **Cache Management** link. Then, refresh any cache that is invalid.
Preparing Swatch Images

A swatch image can provide an accurate representation of color, and also illustrate a pattern or texture. There are two different methods you can use to create swatches for your products. You can use either method, or a combination of both.

- The default method is to create global swatches that represent a plain color, and upload them to Media Storage.
- You can also create custom swatches that illustrate a fabric or texture, and upload them to a specific product.

The size of the swatch that is set in the configuration, and the size of the uploaded image determine the level of detail that can be seen in the swatch. To show a pattern clearly, make sure that the image is large enough to capture the essence of the design. To show a fabric weave, texture, or grain of leather, capture the image at as high a resolution as possible, and crop the image as close to the display size of the swatch as possible. Any reduction in size makes the detail harder to see.

Capture Swatch from Product Image

To capture a swatch, you can open the main product image in a photo editor, and crop a section from the image. You can also use the eyedropper tool to pick up the exact color you need, and fill the swatch with the selected color. If you have the product available, you can take a photograph of the fabric with your camera. The swatches below were captured from the side of a shoe in the main product image.
Uploading Swatch Images

The swatches folder in Media Storage is the most common place where uploaded swatch images are stored. Swatch images that are uploaded to Media Storage are globally available and can be used by any product. The name of each uploaded image file must exactly match the attribute value that it represents. In this example, each file name is a color.

Swatches in Media Storage

Swatches can also be associated with a specific product, and uploaded directly to the product’s thumbnail gallery. Swatches that are uploaded directly to a product do not appear in the gallery or in layered navigation. However, in some cases, there are advantages to using this method. It is also the recommended method for languages with a non-Latin character set, such as Arabic, Chinese, Cyrillic, or Japanese.

The system uses a “fall back” method to locate swatches. It looks first to see if there are any swatches associated with the product image. If it doesn’t find a swatch, it then looks in Media Storage.

If you use a language other than English for attribute values, it is recommended that you upload swatch images to each configurable product, rather than to Media Storage. Files uploaded to Media Storage can only include the characters a-z and 0-9. Characters from non-Latin alphabets, such as Arabic, Chinese, Cyrillic, and Japanese are not recognized by the system. To learn more, see the developer documentation.
Method 1: Upload Swatches to Media Storage

Before uploading swatch images, make sure that the file names exactly match the corresponding attribute values. For example, if you upload a file named “gray.png,” it will match the attribute value “Gray,” but not “Grey.”

All file names are converted to lowercase. In addition, any characters other than a-z and 0-9 are replaced with a hyphen. Therefore, the swatch name “Royal Blue” becomes “royal-blue.”

If you have access to the server, swatch files can be uploaded to the following location:

```
[Magento install directory]/media/wysiwyg/swatches
```

1. On the Admin menu, select CMS > Pages > Manage Content.
2. In the list, click to open any page in edit mode.
   
   The purpose of this step is to launch the editor. Media Storage can be accessed from any place the editor is used.

3. In the panel on the left, select Content.
4. From the editor, click the Insert Image button. In the directory tree on the left, click the **swatches** folder, and do the following:

   a. Click the **Browse** button, and locate the swatch image files that you want to upload.

   You can upload individual images, or multiple images at the same time.

   b. Click the **Upload Files** button to copy the file to Media Storage.

   Newly uploaded images appear at the bottom of the list.

   ![Uploading Multiple Swatches](image)
5. When you are done, click the Close button in the upper-left corner of the Media Storage window. Then, click the Back button to exit the editor.

6. If prompted to refresh the cache, click the Cache Management link in the message at the top of the workspace, and refresh any cache that is invalid.

7. Go to your storefront to verify that the swatches work correctly. The text-based swatches should now be replaced with the swatch images that you uploaded.

8. If any drop-down options from the configurable product are missing from layered navigation, return to Cache Management and click the Flush Magento Cache button.

**Method 2: Upload Swatches as Product Images**

Use this method to associate swatch images with a specific product. Swatches uploaded with this method take precedence over those uploaded to Media Storage.

1. On the Admin menu, select Catalog > Manage Products.

2. Find the product the configurable product in the list, and open the record in edit mode.

3. If the image is intended for a specific store view, set Choose Store View to the store view where the images will be used.

4. In the panel on the left, click Images. Then, do the following:
   a. Click the Browse Files button, and select the images files to upload to your store.
   b. Click the Upload Files button to upload the selected images to your store.
   c. Enter a Label for each swatch image uploaded, in the following format: color name, followed by a hyphen, and the word “swatch.” This label identifies the image as a swatch that is associated with this specific variation of the product.
Do not select any of the remaining options. It is not necessary to select the Exclude checkbox, because by default, Swatch images do not appear in the thumbnail gallery.

5. When complete, click the Save button.

6. When prompted to clear the cache, click the Cache Management link in the message at the top of the workspace, and refresh any cache that is invalid.

Setting Up Dynamic Images

Dynamic images change when the corresponding swatch is clicked, and can be used on the product and product listing pages. The easiest way to understand this is to see how the products are set up.

With this technique, each associated product must have an image that depicts the variation, even if the products are different sizes of the same color. These are the images that appear dynamically when the swatch is clicked. As with all swatch images, the dynamic image does not appear in the thumbnail gallery.
Method 1: Upload Images to Configurable Product

When you view this product in the store and click a swatch, the corresponding product appears as the main product image. You can click any swatch to change the image. Also, notice in the example below that the fourth swatch is a miniature version of the Royal Blue product image. Because there isn’t a Royal Blue swatch available, the fall-back method used the product image with the “Royal Blue” label.

![Dynamic Product Image](image)

1. Each associated simple product has a single product image that depicts the variation. Because these images are not swatches, they do not need the “-swatch” suffix. The product variations used in this example are labeled “Royal Blue,” “Pink,” and “Red.”

![Image Uploaded to Associated Simple Product](image)

2. The Color attribute for each variation is set to the correct color.
3. In addition to the standard product images, images for each product variation are also uploaded to the configurable product, and given labels that exactly match the corresponding color attribute values. No options are selected for the product variations. Although these images are not swatches, they will be used if no other swatch is available.

Method 2: Upload Swatches to Configurable Product

This method features custom swatches that are uploaded to the configurable product. Each associated product has a product image that depicts the variation. When you click each swatch, the corresponding product image appears.
1. An image is uploaded to each associated product that shows the product variation.

2. The Color attribute of the product variation is set to the correct color.

3. In addition to the standard product images, a complete set of the swatch images is uploaded to the configurable product, and labeled as a swatch for each variation. In this example, the swatches are named:
- Royal Blue-swatch
- Charcoal-swatch
- Red-swatch
- Khaki-swatch

*Images Uploaded to Configurable Product*
Swatch Localization

If you use a language other than English for attribute values, it is recommended that you upload swatch images to each configurable product record, rather than upload the images to Media Storage. Swatch image file names that are uploaded to Media Storage are also used as CSS classes, and can only include the characters a-z, A-Z, and 0-9. Characters from non-Latin alphabets, such as Arabic, Chinese, Cyrillic, and Japanese are not recognized by the system.

**English as Primary Language**

By default, the same swatch image can be used for all languages. The easiest way to localize a swatch is to simply translate the attribute label that appears in the store. However, if the translated labels include accented characters, see the next section.

The system uses a simple fallback strategy to locate a suitable swatch. The system looks first for a swatch image that is based on the current language. If no image is found, the system looks next for an attribute label that is associated with the configurable product option.

Using Manage Attribute / Labels, you can enter a translated label for each language supported. For example, the label for the color value "Red" would be entered as "Rot" for German. The following table shows the relationship between the attribute label, the product image label, and the image file name:

<table>
<thead>
<tr>
<th>ATTRIBUTE LABEL</th>
<th>IMAGE LABEL</th>
<th>IMAGE FILE NAME</th>
</tr>
</thead>
<tbody>
<tr>
<td>Red</td>
<td>Red-swatch</td>
<td>media/wysiwyg/swatches/red.png</td>
</tr>
<tr>
<td>Rot</td>
<td>Rot-swatch</td>
<td>media/wysiwyg/swatches/rot.png</td>
</tr>
</tbody>
</table>

**Label Translation**

**Other Primary Languages**

If possible, we recommend that you upload swatch images from the Magento Admin, which allows you to use any character in the image file name. However, if either of the following is true, you must upload swatches directly to the server:

- If you use a language other than English and the translated labels have Latin characters with diacritics (that is, accented characters)
- Your localized images have names that do not transliterate from UTF-8 to ASCII using PHP.

Swatch images are located on the server in the following directory: `media/wysiwyg/swatches/`. If you choose to upload images directly to the server, you must understand how attribute labels are converted to image names.

1. The label is transliterated from UTF-8 to ASCII.
   a. If the label contains Latin characters with diacritics, many of the characters are transliterated to ASCII. For example, Ô is converted to ^O.
   b. If the label cannot be transliterated into ASCII, no swatch images can be uploaded from `media/wysiwyg/swatches/`. Languages with characters that cannot be transliterated include Cyrillic, Chinese, Japanese, and Arabic.
c. If the language contains characters that cannot be transliterated to ASCII, do one of the following:

- Upload all swatch images to each configurable product
- In the Admin, change the attribute values to English as the primary language, and set up the swatch files in English.

2. The label is converted to lowercase.

3. Any characters other than 0-9 and a-z are replaced with the dash character (-).

Conversion Examples

<table>
<thead>
<tr>
<th>LABEL</th>
<th>CONVERTS TO</th>
</tr>
</thead>
<tbody>
<tr>
<td>Königsblau</td>
<td>media/wysiwyg/swatches/k-onigsblau.png</td>
</tr>
<tr>
<td>Weiß</td>
<td>media/wysiwyg/swatches/weiss.png</td>
</tr>
<tr>
<td>красный</td>
<td>(No transliteration is possible, and no image is uploaded.)</td>
</tr>
</tbody>
</table>

Common Transliteration Values

<table>
<thead>
<tr>
<th>CHARACTER</th>
<th>TRANSLITERATION</th>
<th>REPLACEMENT</th>
</tr>
</thead>
<tbody>
<tr>
<td>French</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Å</td>
<td>`A</td>
<td>-a</td>
</tr>
<tr>
<td>Å</td>
<td>^A</td>
<td>-a</td>
</tr>
<tr>
<td>Æ</td>
<td>AE</td>
<td>ae</td>
</tr>
<tr>
<td>Ä</td>
<td>&quot;A</td>
<td>-a</td>
</tr>
<tr>
<td>Æ</td>
<td>&quot;A</td>
<td>-a</td>
</tr>
<tr>
<td>Ç</td>
<td>C</td>
<td>c</td>
</tr>
<tr>
<td>É</td>
<td>`E</td>
<td>-e</td>
</tr>
<tr>
<td>È</td>
<td>`E</td>
<td>-e</td>
</tr>
<tr>
<td>Ê</td>
<td>`E</td>
<td>-e</td>
</tr>
<tr>
<td>Ò</td>
<td>&quot;E</td>
<td>-e</td>
</tr>
<tr>
<td>Õ</td>
<td>^O</td>
<td>-o</td>
</tr>
<tr>
<td>œ</td>
<td>OE</td>
<td>oe</td>
</tr>
</tbody>
</table>
### Common Transliteration Values (cont.)

<table>
<thead>
<tr>
<th>CHARACTER</th>
<th>TRANSLITERATION</th>
<th>REPLACEMENT</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ö</td>
<td>&quot;O</td>
<td>-o</td>
</tr>
<tr>
<td>Ú</td>
<td>'U</td>
<td>-u</td>
</tr>
<tr>
<td>Ù</td>
<td>^U</td>
<td>-u</td>
</tr>
<tr>
<td>Õ</td>
<td>&quot;U</td>
<td>-u</td>
</tr>
<tr>
<td>Ý</td>
<td>&quot;Y</td>
<td>-y</td>
</tr>
</tbody>
</table>

**German**

| Ä         | "A              | -a          |
| Ö         | "O              | -o          |
| Ú         | "U              | -u          |
| ß         | ss              | ss          |

**Spanish**

| Ñ         | ~N              | -n          |
| Á         | 'A              | -a          |
| É         | 'E              | -e          |
| í         | 'I              | -i          |
| Ò         | 'O              | -o          |
| Ú         | 'U              | -u          |
Clearing the Swatch Cache

Swatch images are resized and cached before they are used. Swatch images are stored on the server in the Magento installation directory, at the following location:

```
/[Magento install directory]/media/catalog/swatches/
```

Whenever changes are made to existing swatch images, the swatch cache must be flushed before the changes can be seen in the store.

To flush the swatch cache:

1. On the Admin menu, select **System > Cache Management**.
2. In the Additional Cache Management Section, click the **Flush Swatch Images Cache** button.
CHAPTER 17:

Product Pricing

Magento Community Edition supports a number of pricing options that you can use for promotions, and to meet minimum advertised price requirements.
**Prices**

The Prices tab is used to establish the pricing structure of the product. Options include special and tier pricing, and manufacturer's suggested retail price.

![Prices Tab Image]

**Field Descriptions**

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Price</td>
<td>Global</td>
<td>The retail price of the product.</td>
</tr>
<tr>
<td>Group Price</td>
<td>Global</td>
<td>Sets up promotional prices for specific customer groups within the selected website.</td>
</tr>
<tr>
<td>Special Price</td>
<td>Website</td>
<td>To offer a Special Price, enter a discounted price and complete the date range fields to establish when the promotion goes into effect. When available, the retail price is crossed out and the special price appears below in a large, bold font.</td>
</tr>
<tr>
<td>Special Price From Date</td>
<td>Website</td>
<td>Sets the beginning date for the range of time the Special Price is offered.</td>
</tr>
<tr>
<td>Special Price To Date</td>
<td>Website</td>
<td>Sets the ending date for the range of time the Special Price is offered.</td>
</tr>
<tr>
<td>Tier Price</td>
<td>Website</td>
<td>Tier pricing is used to offer a quantity discount. The discount can be applied to specific customer groups within the selected website.</td>
</tr>
<tr>
<td>Apply MAP</td>
<td>Website</td>
<td>When applied, hides the actual product price from the customer. Options include: Yes / No / Use Config</td>
</tr>
</tbody>
</table>
### Field Descriptions (cont.)

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Actual Price</td>
<td>Website</td>
<td>Determines when the customer can see the actual product price. Options include:</td>
</tr>
<tr>
<td>In Cart</td>
<td></td>
<td>Displays the actual product price in the shopping cart.</td>
</tr>
<tr>
<td>Before Order Confirmation</td>
<td></td>
<td>Displays the actual product price only at the end of the checkout process, just before the order is confirmed.</td>
</tr>
<tr>
<td>On Gesture</td>
<td></td>
<td>Displays the actual product price</td>
</tr>
<tr>
<td>Use Config</td>
<td></td>
<td>Displays the actual price according to the configuration setting.</td>
</tr>
<tr>
<td>Manufacturer’s Suggested Retail Price</td>
<td>Global (MSRP)</td>
<td>The retail price as suggested by the manufacturer.</td>
</tr>
<tr>
<td>Tax Class</td>
<td></td>
<td>The tax class associated with the product.</td>
</tr>
</tbody>
</table>
Special Price

To offer a Special Price, enter a discounted price and complete the date range fields to establish when the promotion goes into effect. On both the catalog list and product pages, the regular price is crossed out, and the Special Price appears in bold red.

To display a special price:

1. In the Product Information panel on the left, select Prices.
2. Enter the amount of the Special Price.
3. Complete the Special Price From Date and Special Price To Date to define the period of time that the special price is in effect. You can pick the dates from the Calendar to the right of each field.
4. Click the Save button to save your changes.
5. When prompted to update the cache and indexes, follow the instructions at the top of the page.
Tier Price

Tier pricing lets you offer a quantity discount from the catalog list and product detail pages. The discount can be applied to a specific store view or customer group.

"As Low as"

- On the catalog page, the product price includes the words, “As Low As,” followed by the lowest tier price.
- On the product page, the calculated quantity discount has the message:

  Buy 2 for $__. __ each and save __ %

The prices in the storefront take precedence from the highest to the lowest quantity. Therefore, if you have a tier for the quantity 5 and one for the quantity 10 and a customer adds 5, 6, 7, 8 or 9 items to the shopping cart, then the customer gets the discounted price that you specified for the quantity 5 tier. As soon as the customer adds the 10th item, the discounted price specified for the quantity 10 tier supersedes the quantity 5 tier and that discounted price (of 10) applies instead.
To display a tier price:

1. In the Product Information panel on the left, select Prices.
2. In the Tier Price section, click the Add Tier button. Then, do the following:
a. Select the **Website** to which the tier pricing applies.

b. Select the **Customer Group** for whom the tier pricing is available.

   To apply a tier to multiple groups, but not all groups, create multiple tiers, each with the same Qty and Price information and select a different customer group for each.

c. In the **Qty** field, enter the quantity that must be ordered to receive the discount.

d. In the **Price** field, enter the adjusted price of the item.

3. When complete, click the **Save** button.

4. When you are prompted to update the cache and indexes, follow the instructions in the message at the top of the workspace.
Quantity Increments

Unlike a unit price, the quantity price refers to multiple items of the same product that are packaged together and sold as a single unit. A six-pack of soft drinks is an example of product that is sold in quantity increments.

**How to set up quantity increments:**

1. On the Admin menu, select **Catalog > Manage Products**.
2. In the list, click to select the product you want to sell as a package.
3. In the Product Information panel on the left, select **Inventory**. Then, do the following:
   a. Set **Qty for Item’s Status to Become Out of Stock** to the lowest inventory threshold for this item. (If necessary, clear the **Use Config Settings** checkbox.)

      The number should be a multiple of the number of items in the package. For example, for a six-pack, the threshold might be 6, 12, 18, and so on.

   b. Set **Enable Qty Increments** to “Yes.”

   c. Set **Qty Increments** to the number of units included in the package. For example, 6.

4. When complete, click the **Save Config** button.
Minimum Advertised Price

Merchants are sometimes prohibited from displaying a price that is lower than the manufacturer's suggested retail price (MSRP). Magento's Minimum Advertised Price (MAP) gives you the ability to remain in compliance with the manufacturer's requirements while offering your customers a better price. Because requirements differ from one manufacturer to another, you can configure your store to prevent the display of your actual price on pages where it is not allowed to appear according to the terms of the manufacturer.
MAP Logic

For products that allow configuration from the storefront, with prices that depend on a selected option, (such as custom options, or simple products with their own SKUs and stock management), the following logic is implemented:

- MAP is applied to the main price. The prices of options, bundle items, and associated products (which add or subtract from the main price) appear normally.
- If a product does not have a main price, and its price is derived from the associated product prices (such as in a grouped product), the MAP settings of the associated products are applied.
- If a product in the cart has the Manufacturer's Suggested Retail Price (MSRP) specified, the price is not crossed-out.

For other price settings, the following MAP logic is used:

- If tier pricing is set, the tier price appears according to the Display Actual Price setting.
- If a special price is set, it is considered to be the actual price for MAP.

In the order management and customer management tools, as well as in the reports sections of the Admin, only the actual price appears.

Using MAP with Product Types

<table>
<thead>
<tr>
<th>PRODUCT TYPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Simple, Virtual</td>
<td>The actual price does not automatically appear on catalog list and product pages, but is included only according to the Display Actual Price setting. Custom option prices appear normally.</td>
</tr>
<tr>
<td>Grouped</td>
<td>The prices of associated simple products do not automatically appear on catalog list and product pages, but are included only according to the Display Actual Price setting.</td>
</tr>
<tr>
<td>Configurable</td>
<td>The actual price does not automatically appear on catalog list and product pages, but is included only according to the Display Actual Price setting. Option prices appear normally.</td>
</tr>
<tr>
<td>Bundle with fixed price</td>
<td>The actual price does not automatically appear on catalog pages, but is included only according to the Display Actual Price setting. The prices of bundle items appear normally. MAP is not available for bundle products with dynamic pricing.</td>
</tr>
<tr>
<td>Downloadable</td>
<td>The actual price does not automatically appear on catalog list and product pages, but is included only according to the Display Actual Price setting. The price associated with each download link appears normally.</td>
</tr>
</tbody>
</table>
Using MAP with Price Settings

<table>
<thead>
<tr>
<th>PRICE SETTING</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tier Price</td>
<td>If tier pricing is set, the tier pricing message is not displayed in the catalog. On the product page a notification is displayed that indicates that the price can be lower when ordering more than a certain quantity, but the discount is displayed in percentages only. For associated products of a grouped product, the discounts are not displayed on the product page. The tier price is shown according to the Display Actual Price setting.</td>
</tr>
<tr>
<td>Special Price</td>
<td>If the Special price is specified, the special price is displayed according to the Display Actual Price setting.</td>
</tr>
</tbody>
</table>
MAP Configuration

MAP can be configured at both the global and product levels. There are a variety of configuration options that you can use to remain in compliance with the terms of your agreement with the manufacturer, while still offering your customers a better price. Your store’s MAP settings can be applied to all products in your catalog or configured for only specific products.

On the global level, you can enable or disable MAP, apply it to all products, define how the actual price is displayed, and edit the text of the related messages and information tips that appear in the store. When MAP is enabled globally, product-level MAP settings become available. For a product you can choose to apply MAP, specify the MSRP, and define how the actual price is displayed. Product-level MAP settings override the global MAP settings.
To configure MAP globally:

1. On the Admin menu, select System > Configuration.

2. If applicable, in the upper-right corner, set Current Configuration Scope to the website where the configuration applies.

3. In the panel on the left, under Sales, select Sales. Then, click to expand the Minimum Advertised Price section.

4. To activate MAP, set Enable MAP to “Yes.”
   a. Set Apply MAP (Default Value) to one of the following:
      - To apply MAP to certain products, select “No.”
      - To apply MAP by default to all products and hide all prices throughout the site, select “Yes.”
   b. To determine when and where you want your actual price to be visible to the customer, set Display Actual Price to one of the following:
      - In Cart
      - Before Order Confirmation
      - On Gesture (on click)

5. When complete, click the Save Config button.

To configure MAP for a specific product:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, click to expand the Minimum Advertised Price section. Then, do the following:
a. Set **Enable MAP** to “Yes.”

b. Set **Apply MAP (Default Value)** to “No.”

c. Complete the remaining settings as needed. Then, click the **Save Config** button.

3. Select **Catalog > Manage Products**, and open the product record.

4. In the Product Information panel on the left, select **Prices**. Then, do the following:

   a. Enter your **Price** that is lower than the manufacturer’s minimum advertised price.

   b. Set **Apply MAP** to “Yes.”

   c. Set **Display Actual Price** according to your preference.

   d. Enter the **Manufacturer’s Suggested Retail Price**.

5. When complete, click the **Save** button.

---

**Product Group Price**

Product Group Price enables you to set promotional prices for different customer groups at the product level. Group price can be used with the following product types:

- Simple
- Configurable
- Virtual
- Bundle
- Downloadable

For Bundle products, the group price is specified as a discount percentage. If bundle items have their own group prices set for the same customer group, then the discount specified for the entire Bundle applies to the group prices.

For Grouped products, the Group Price is not applied, even if the product type is selected in the Apply To field of the group_price attribute. In this case, the Group Price field does not appear in the Prices section of Product Information.
Product Group Price Setup

The display of group prices in the store follows the general logic used for Magento pricing. If, in addition to the regular price, a product has promotional price(s), the lowest price appears in the storefront. If a product custom option has price set as a percentage, then the lowest promotional price is used as base for the calculation. The same logic applies when the associated products (the options) of a configurable product have prices set as a percentage.

Examples: Promotional Prices in Storefront

The following table illustrates how the minimum promotional price logic is implemented. The table provides several examples, but it is not an exhaustive list of possible combinations.

**Promotional Pricing**

<table>
<thead>
<tr>
<th>ADMIN PRICE</th>
<th>STOREFRONT PRICE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Price = $4</td>
<td>For customers from the tier price group(s): $ 4</td>
</tr>
<tr>
<td>Special Price = $5</td>
<td>As low as: $3</td>
</tr>
<tr>
<td>Tier Price = $3</td>
<td>For customers from other groups: $4</td>
</tr>
<tr>
<td>Price = $5</td>
<td>For all customers:</td>
</tr>
<tr>
<td>Special Price = $3</td>
<td>Regular Price: $5</td>
</tr>
<tr>
<td>Tier Price = $4</td>
<td>Special Price: $3</td>
</tr>
<tr>
<td>Price = $5</td>
<td>For customers from the catalog price rule group:</td>
</tr>
<tr>
<td>Special Price = $3</td>
<td>Regular Price: $5</td>
</tr>
<tr>
<td>Tier Price = $4</td>
<td>Special Price: $2</td>
</tr>
<tr>
<td>Price after a catalog price rule applied = $2</td>
<td>For customers from other groups:</td>
</tr>
<tr>
<td>Special Price = $3</td>
<td>Regular Price: $5</td>
</tr>
<tr>
<td>Tier Price = $4</td>
<td>Special Price: $3</td>
</tr>
<tr>
<td>Price = $5</td>
<td>For customers from the price group:</td>
</tr>
<tr>
<td>Special Price = $4</td>
<td>Regular Price: $5</td>
</tr>
<tr>
<td>Group Price = $3</td>
<td>Special Price: $3</td>
</tr>
<tr>
<td></td>
<td>For customers from other groups:</td>
</tr>
<tr>
<td>Special Price = $3</td>
<td>Regular Price: $5</td>
</tr>
<tr>
<td></td>
<td>Special Price: $4</td>
</tr>
</tbody>
</table>

**Important!** When a group price is set for a product, the catalog price rules for the corresponding customer groups are applied to the group price, not to the regular price.
To set up a group price for a product:

1. On the Admin menu, select Catalog > Manage Products. Then in the list, click to open the product in edit mode.

2. In the panel on the left, click Prices. Then, do the following:

   a. In the Group Price field, click the Add Group Price button.

   b. Select the target Customer Group and enter the product Price for the group. The Website column defines the scope of the Group Price field.

3. When complete, click the Save button.

Group Price Attribute

The group_price attribute gives you the ability to offer a different price to members of a customer group for any product type that is specified in the attribute’s Apply To property.

To set up a group price:

1. On the Admin menu, select Catalog > Manage Products. Then, open the product in edit mode.

2. In the panel on the left, select Prices. Then, do the following:
Group Price

a. Under Group Price, click the Add Group Price button.

b. Select the Website to determine the scope of the setting.

c. Choose the Customer Group that is eligible for the group price.

d. Enter the Price of the product for members of the selected group.

3. When complete, click the Save button.
CHAPTER 18:

Inventory

Managing stock creates opportunities for customer engagement by displaying stock availability messages in your store, and giving your customers the opportunity to receive product alerts. Even if your store doesn’t have a large inventory of products, your customers can benefit from the way you manage your inventory.

Inventory settings can be made for the catalog as a whole, and fine tuned for each individual product. In addition to controlling stock levels, the inventory settings determine how backorders and returned items are managed. If your needs are simple, you might choose not to manage inventory at all. However, inventory management is more than just keeping track of how many products you have on hand.
Inventory Configuration

The Product Stock Items configuration determines the default product inventory settings. The configuration applies to individual products, rather than to the contents of the cart as a whole.

To configure the default inventory settings:

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left, under Catalog, select **Inventory**.

2. Click to expand the **Product Stock Options** section, and do the following:

   ![Product Stock Options](image)

   **Product Stock Options**

   a. Set **Manage Stock** to one of the following:

      Yes               Activates full inventory control to keep track of the number of items currently in stock.

      No                Does not keep track of the number of items currently in stock.

   b. Set **Backorders** to one of the following:

      No Backorders    Does not accept backorders when product is out of stock.

      Allow Qty Below 0 Accepts backorders when the quantity falls below zero.

      Allow Qty Below 0 and Notify customer Accepts backorders when the quantity falls below zero, but notifies customers that orders can still be placed.

   c. In the **Maximum Qty Allowed in Shopping Cart** field, enter the default maximum quantity of any product that a customer can place into the shopping cart.

   d. In the **Qty for Item’s Status to Become Out of Stock** field, enter the stock level that indicates a product to be out of stock.

3. At the **Minimum Qty Allowed in Shopping Cart** field, click the **Add Minimum Qty** button. Then, do the following:
a. Select the **Customer Group**.

b. Enter the default **Minimum Quantity** for members of the group.

Repeat these steps as needed.

4. In the **Notify for Quantity Below** field, enter the stock level that triggers a notification to be sent that a product has fallen below the threshold.

5. If you want to sell product packaged as multiples—such as a six-pack—set **Enable Qty Increments** to “Yes.” Then, enter the number of **Qty Increments** to be sold together as a package.

6. If you want to return any item that appears on a credit memo back to inventory, set **Automatically Return Credit Memo Item to Stock** to “Yes.”

7. When complete, click the **Save Config** button.

**Managing Stock**

Each product in your catalog has both a short and long version of the Inventory options, depending on whether you need to manage inventory for the product. To take full advantage of Magento’s advanced inventory management capabilities, Manage Stock must be enabled.

To set up a simple catalog without stock management, complete the Inventory short form. For full inventory management, complete the long form. The initial values reflect the default Product Stock Options set in the configuration.
To set up a product without stock management:

1. On the Admin menu, select Catalog > Manage Products. Then, open the product in edit mode.
2. In the panel on the left, under Catalog, select Inventory. Click to expand the Product Stock Options section.
3. To change the default setting of any field, first clear the Use Config Settings checkbox. Then, do the following:
   a. Set Manage Stock to “No.”
   b. In the Minimum Qty Allowed in Shopping Cart field, enter the minimum quantity of the product that a customer can place into the shopping cart.
   c. In the Maximum Qty Allowed in Shopping Cart field, enter the maximum quantity of the product that a customer can place into the shopping cart.
   d. If you want to sell this product packaged in multiples, such as a six-pack, set Enable Qty Increments to “Yes.”
4. When complete, click the Save Config button.

To set up a product with full inventory control:

1. On the Admin menu, select Catalog > Manage Products. Then, open the product in edit mode.
2. In the panel on the left, under Catalog, select Inventory. Click to expand the Product Stock Options section.
3. If necessary, clear the checkbox below the Manage Stock field. Then, set Manage Stock to “Yes.”
To change the default setting of any field, first clear the **Use Config Settings** checkbox. Then, do the following:

- **a.** In the **Qty** field, type the number of units you currently have in stock.

- **b.** In the **Qty For Item’s Status to become Out of Stock** field, enter the stock level that indicates the item is considered to be out of stock.

- **c.** In the **Minimum Qty Allowed in Shopping Cart** field, enter the default maximum quantity of any product that a customer can place into the shopping cart.

- **d.** In the **Maximum Qty Allowed in Shopping Cart** field, enter the default maximum quantity of any product that a customer can place into the shopping cart.

- **e.** If the quantity of the product is indicated with decimal precision, set **Qty Uses Decimals** to “Yes.”
  - If the product can be shipped in separate boxes, set **Can be divided into Multiple Boxes for Shipping** to “Yes.”

- **f.** Set **Backorders** to one of the following:
  - **No Backorders** Does not accept backorders when product is out of stock.
  - **Allow Qty Below 0** Accepts backorders when the quantity falls below zero.
  - **Allow Qty Below 0 and Notify Customer** Accepts backorders when the quantity falls below zero, but notifies customers that orders can still be placed.

- **g.** In the **Notify for Quantity Below** field, enter the stock level that triggers a notification to be sent that a product has fallen below the threshold.
If you want to sell product packaged as multiples—such as a six-pack—set **Enable Qty Increments** to “Yes.” Then in the **Qty Increments** field, enter the number of products that are packaged together.

Set **Stock Availability** to one of the following:

- **In Stock**: Makes the product available for purchase.
- **Out of Stock**: Unless Backorders are activated, prevents the product from being available for purchase and removes the listing from the catalog.

5. When complete, click the **Save** button.

### Field Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manage Stock</td>
<td>Global</td>
<td>Determines if you use full inventory control to manage the items in your catalog. Options include:</td>
</tr>
<tr>
<td>Qty</td>
<td>Global</td>
<td>(Required) The quantity of the item in stock.</td>
</tr>
<tr>
<td>Qty For Item’s Status to become Out of Stock</td>
<td>Global</td>
<td>Determines the stock level at which a product is considered to be out of stock.</td>
</tr>
<tr>
<td>Minimum Qty Allowed in ShoppingCart</td>
<td>Global</td>
<td>Determines the minimum amount of this item that is available for purchase. By default, the minimum quantity is set to 1.</td>
</tr>
<tr>
<td>Maximum Qty Allowed in ShoppingCart</td>
<td>Global</td>
<td>Determines the maximum number of this item that can be purchased in a single order. By default, the maximum quantity is set to 10,000.</td>
</tr>
<tr>
<td>Qty Uses Decimals</td>
<td>Global</td>
<td>Determines if customers can use a decimal value rather than a whole number when entering the quantity ordered. Options include:</td>
</tr>
</tbody>
</table>
### Field Descriptions (cont.)

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yes Permits values to be entered as decimals, rather than whole numbers, which is suitable for products sold by weight, volume or length.</td>
<td>Yes</td>
<td>Permits values to be entered as decimals, rather than whole numbers, which is suitable for products sold by weight, volume or length.</td>
</tr>
<tr>
<td>No Quantity values must be entered as whole numbers.</td>
<td>No</td>
<td>Quantity values must be entered as whole numbers.</td>
</tr>
<tr>
<td>Can be divided into Multiple Boxes for Shipping</td>
<td>Global</td>
<td>Determines if parts of the product can shipped separately. Options include: Yes / No</td>
</tr>
<tr>
<td>Backorders</td>
<td>Global</td>
<td>Determines how your store manages backorders. A backorder does not change the processing status of the order. Funds are still authorized or captured immediately when the order is placed, regardless of whether the product is in stock. When the product becomes available, it will be shipped. Options include:</td>
</tr>
<tr>
<td>No Backorders</td>
<td>Global</td>
<td>Does not accept backorders when product is out of stock</td>
</tr>
<tr>
<td>Allow Qty Below 0</td>
<td>Global</td>
<td>Accepts backorders when the quantity falls below zero.</td>
</tr>
<tr>
<td>Allow Qty Below 0 and Notify Customer</td>
<td>Global</td>
<td>Accepts backorders when the quantity falls below zero, but notifies customers that orders can still be placed.</td>
</tr>
<tr>
<td>Notify for Quantity Below</td>
<td>Global</td>
<td>Determines the stock level at which notification is sent that the inventory has fallen below the threshold.</td>
</tr>
<tr>
<td>Enable Qty Increments</td>
<td>Global</td>
<td>Determines if the product can be sold in quantity increments. Options include: Yes / No</td>
</tr>
<tr>
<td>Qty Increments</td>
<td>Global</td>
<td>Establishes the number of products that make up a quantity increment.</td>
</tr>
<tr>
<td>Stock Availability</td>
<td>Global</td>
<td>Determines the current availability of the product. Options include:</td>
</tr>
</tbody>
</table>
Field Descriptions (cont.)

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>In Stock</td>
<td>Makes the product available for purchase.</td>
<td></td>
</tr>
<tr>
<td>Out of Stock</td>
<td>Unless Backorders are activated, prevents the product from being available for purchase and removes the listing from the catalog.</td>
<td></td>
</tr>
</tbody>
</table>
Stock Options

The Stock Options settings determine if items are removed from stock when an order is placed, and returned to stock if an order is canceled. The Stock Options determine if out-of-stock products are included in the catalog, and control the display of the “In Stock,” “Out of Stock,” and “Only x left” messages.
To configure stock options:

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under Catalog, select Inventory.

2. Click to expand the Stock Options section. Then, do the following:

   ![Stock Options](image)

   - **Stock Options**

   **a.** To return items to stock if an order is cancelled, Set Items Status to be in Stock When Order in Cancelled to “Yes.”

   **b.** To adjust the quantity on hand when an order is placed, set Decrease Stock When Order is Placed to “Yes.”

   **c.** Set Display Out of Stock Products to “Yes” to continue to display products in the catalog that are no longer in stock.

   If price alerts are enabled, customers can sign up to be notified when the product is back in stock.

   **d.** To display the message, “Only x left,” enter the number in the Display X left Threshold field.

   The message begins to appear when the quantity in stock reaches the threshold. For example, if set to 3, the message “Only 3 left” appears when the quantity in stock reaches 3. The message adjusts to reflect the quantity in stock, until the quantity reaches zero.

   **e.** To display an “In Stock” or “Out of Stock” message on the product page, set Display products availability in stock in the frontend to “Yes.”

3. When complete, click the Save Config button.
Stock Availability

You can define an inventory level that becomes the threshold to determine when an item needs to be reordered. The out of stock threshold can be set to any number greater than zero.

Another way you can use the stock availability threshold is to manage products that are in high demand. If you want to capture new customers, rather than sell to high-quantity buyers, you can set a maximum quantity to prevent a single buyer from taking out your entire inventory.

Your catalog can be configured to display the availability of each item as “In Stock” or “Out of Stock” on the product page. The configuration setting applies to the catalog as a whole, and the message changes according to the stock status of the product. There are several display variations possible, including how “out of stock” products are managed in the catalog and search results lists.

“In Stock” Message on Product Page

Process Overview:
Step 1: Configure the Inventory Stock Options
Step 2: Set the Product to Manage Stock
Step 3: Set the “Out of Stock” Threshold
Step 1: Configure the Inventory Stock Options

1. On the Admin menu, select **System > Configuration**. Then in the Configuration panel on the left, under Catalog, select **Inventory**.

2. Click to expand the **Stock Options** section. Then, do the following:

   ![Stock Options](image)

   **Stock Options**

   a. To configure how “out of stock” products are handled in the category and search results lists, set **Display Out of Stock Products** to one of the following:

      Yes          Includes “out of stock” products on catalog pages.

      No           Omits “out of stock” products from catalog pages.

   b. To configure the stock availability message on the product page, set **Display products availability in stock in the frontend** to one of the following:

      Yes          Displays an availability message indicating the product stock status.

      No           Does not display an availability message.

3. Click the **Save Config** button to save the setting.

Step 2: Set the Product to Manage Stock

1. On the Admin menu, select **Catalog > Manage Products**.

2. In the list, click to open the product. Then in the Product Information panel on the left, select **Inventory**.

3. If necessary, clear the **Use Config Settings** checkbox, and set **Manage Stock** to “Yes.” Then, complete the inventory settings as needed.

4. Make sure that **Stock Availability** is set to “In Stock.”

5. Click the **Save** button to save the product settings.
Step 3: Set the "Out of Stock" Threshold

1. On the Inventory tab, set the Qty for Item's Status to Become Out of Stock to a value above zero.

2. To set the quantity of the product that is allowed in the cart, set the following fields to the appropriate values for your product, store, and strategy:
   - Minimum Quantity Allowed in Shopping Cart
   - Maximum Quantity Allowed in Shopping Cart

3. To be notified when stock drops below the threshold, clear the Use Config Settings checkbox. Then, set Notify for Quantity Below to a number to establish the threshold. The default the value is 1.

If you need time to restock your inventory, you can use this value to indicate when it is time to replenish.
Message Scenarios

You can use a combination of configuration settings to control stock availability messages on product pages and in listings of products on catalog pages.
Product Page

There are several variations of messaging available for the product page, depending on the combination of Manage Stock and Stock Availability settings.

“Out of Stock” Message

Example 1: Show Availability Message

Scenario 1: This combination of settings causes the availability message to appear on the product page, according to the stock availability of each product.

<table>
<thead>
<tr>
<th>STOCK OPTIONS</th>
<th>MESSAGE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display product availability in stock in the frontend: Yes</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Product Inventory</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manage Stock Yes</td>
</tr>
<tr>
<td>Stock Availability In Stock Out of Stock “Availability: In Stock” “Availability: Out of Stock”</td>
</tr>
</tbody>
</table>

Scenario 2: When stock is not managed for a product, this combination of settings can be used to display the availability message on the product page.

<table>
<thead>
<tr>
<th>STOCK OPTIONS</th>
<th>MESSAGE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display product availability in stock in the frontend: Yes</td>
<td></td>
</tr>
</tbody>
</table>

| Product Inventory |
### Example 2: Hide Availability Message

**Scenario 1:** This combination of configuration and product settings prevents the availability message from appearing on the product page.

<table>
<thead>
<tr>
<th>STOCK OPTIONS</th>
<th>MESSAGE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manage Stock</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>“Availability: In Stock”</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Product Inventory</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Manage Stock</td>
<td>Yes</td>
</tr>
<tr>
<td>Stock Availability</td>
<td>In Stock</td>
</tr>
<tr>
<td>Stock Availability</td>
<td>Out of Stock</td>
</tr>
<tr>
<td></td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>None</td>
</tr>
</tbody>
</table>

**Scenario 2:** When stock is not managed for a product, this combination of configuration and product settings prevents the availability message from appearing on the product page.

<table>
<thead>
<tr>
<th>STOCK OPTIONS</th>
<th>MESSAGE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display product availability in stock in the frontend:</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Product Inventory</td>
<td></td>
</tr>
<tr>
<td>Manage Stock</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>None</td>
</tr>
</tbody>
</table>
Catalog Page

The following display options are possible for the category and search results lists, depending on the product availability and configuration settings.

Example 1: Show Product with “Out of Stock Message”

This combination of configuration settings includes out of stock products in the category and search results lists, and displays an “out of stock” message.

<table>
<thead>
<tr>
<th>STOCK OPTIONS</th>
<th>MESSAGE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Out of Stock Products</td>
<td>Yes</td>
</tr>
<tr>
<td>Display product availability in stock in the frontend</td>
<td>Yes</td>
</tr>
<tr>
<td>Display Out of Stock Products</td>
<td>Yes</td>
</tr>
<tr>
<td>Display product availability in stock in the frontend</td>
<td>No</td>
</tr>
</tbody>
</table>
Example 2: Show Product without “Out of Stock Message”

This combination of configuration settings includes out of stock products in the category and search results lists, but does not display a message.

<table>
<thead>
<tr>
<th>STOCK OPTIONS</th>
<th>MESSAGE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Out of Stock Products</td>
<td>Yes</td>
</tr>
<tr>
<td>Display product availability in stock in the frontend</td>
<td>No</td>
</tr>
</tbody>
</table>

Example 3: Hide Product Until Back in Stock

This configuration setting omits out of stock products entirely from the category and search results lists, until they are back in stock.

<table>
<thead>
<tr>
<th>STOCK OPTIONS</th>
<th>MESSAGE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Out of Stock Products</td>
<td>No</td>
</tr>
</tbody>
</table>

Out of Stock Threshold

You can define an inventory level that becomes the threshold to determine when an item needs to be reordered. The out of stock threshold is set to a number above zero.

To set the out of stock threshold:

1. In the Product Information panel, select Inventory.
2. Set the Qty for Item's Status to Become Out of Stock to a value above zero.

To change the quantity allowed in cart:

This option is helpful for products in high demand. If you want to capture a larger number of new customers rather than selling high volumes to high-quantity buyers, you can set a maximum quantity to prevent a high-quantity buyer from taking out your entire inventory.

1. In the Product Information panel, select Inventory.
2. Change the Minimum and Maximum Quantity Allowed in Shopping Cart fields to appropriate values for your product, store, and strategy.

To be notified when stock drops below threshold:

1. In the Product Information panel, select Inventory.
2. Clear the Use Config Settings checkbox, and set Notify for Quantity Below to indicate the level when you want to be notified. By default, the value is set to 1.
Product Alerts

You can enable your customers to subscribe to two types of customer alerts by email: price change alerts and in-stock alerts. For each alert type, choose whether to enable users to subscribe to it, and select the email template to use. Also, select a sender display name, which applies to both alert types.

Sign Up for Price Alert

When price change alerts are enabled, a “Sign up for price alert” link appears on every product page. Customers can click the link to subscribe to alerts related to the product. Guests are prompted to open an account with your store. Whenever the price changes, or the product goes on special, everyone who has signed up to be notified receives an email alert.

The in-stock alert creates a link called “Sign up to get notified when this product is back in stock” for every product that is out of stock. Customers can click the link to subscribe to the alert. When the product is back in stock, customers receive email notification that the product is available. Products with alerts have a Product Alerts tab in the Product Information panel that lists the customers who have subscribed to an alert.
List of Price Alert Subscriptions

To set up product alerts:

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left, under Catalog, select **Catalog**.

2. Click to expand the **Product Alerts** section, and do the following:

   a. To offer price change alerts to your customers, set **Allow Alert When Product Price Changes** to “Yes.”

   b. Set **Price Alert Email Template** to the template that you want to use for the price alert notifications.

   c. To offer alerts when out-of-stock products become available again, set **Allow Alert When Product Comes Back in Stock** to “Yes.”

   The “Sign up to get notified when this product is back in stock” message appears only when Inventory Stock Options - Display Out of Stock Products is set to “Yes.”
d. Set **Stock Alert Email Template** to the template that you want to use for product stock alerts.

e. Set **Alert Email Sender** to the store contact that you want to appear as the sender of the email alert.

3. When complete, click the **Save Config** button.

### Field Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allow Alerts When Product Price Changes</td>
<td>Store View</td>
<td>Determines if email alerts are available for product price changes. Options include: Yes / No</td>
</tr>
<tr>
<td>Price Alert Email Template</td>
<td>Store View</td>
<td>Identifies the template that is used for product price change email alerts. Default template: Product price alert</td>
</tr>
<tr>
<td>Allow Alert When Product Comes Back in Stock</td>
<td>Website</td>
<td>Determines if customers can choose to receive an alert when the product comes back in stock. Options include: Yes / No</td>
</tr>
<tr>
<td>Stock Alert Email Template</td>
<td>Store View</td>
<td>Identifies the template that is used for stock alert email notifications. Default template: Product stock alert</td>
</tr>
<tr>
<td>Alert Email Sender</td>
<td>Store View</td>
<td>Determines the store contact that appears as the sender of the product alert email message.</td>
</tr>
</tbody>
</table>
Scheduling Product Alerts

These settings enable you to select how often Magento checks for changes that require alerts to be sent. Additionally, you can select the recipient, sender, and template for emails that are sent if the sending of alerts fails.

To set up product alerts:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Catalog, select Catalog.

2. Click to expand the Product Alerts Run Settings section. Then, do the following:

   ![Product Alert Run Settings](image)

   - To determine how often product alerts are sent, set Frequency to one of the following:
     - Day
     - Week
     - Month
   - To determine the time of day product alerts are sent, set Start Time to the hour, minute, and second.
   - In the Error Email Recipient field, enter the email of the person to be contacted if an error occurs.
   - In the Error Email Sender field, select the store identity that appears as the sender of the error notification.
   - Set Error Email Template to the transactional email template to be used for the error notification.

3. When complete, click the Save Config button.
Managing Configurable Product Stock

By default, Manage Stock is turned off for a configurable product, because the inventory is managed through each associated product. However, at times it may be necessary to apply inventory settings to a configurable product as a whole, such as to set quantity increments and change the stock availability.

To enable quantity increments:

1. On the Inventory tab of the configurable product, clear the Use Config Settings checkbox, and set Manage Stock to “Yes.” The Enable Qty Increments field appears.
2. To sell the product in quantity increments, do the following:
   a. Below the Enable Qty Increments field, clear the Use Config Settings checkbox. Then, set Enable Qty Increments to “Yes.”
   b. In the Qty Increments field, enter the number of products that you want to sell together as a single batch.

To set product as “Out of Stock:”

1. On the Inventory tab of the configurable product, clear the Use Config Settings checkbox, and set Manage Stock to “Yes.” The Stock Availability field appears.
2. To temporarily remove the product from sale, set Stock Availability to “Out of Stock.”
3. When you are ready to offer the product for sale, set Stock Availability to “In Stock.”
CHAPTER 19:

Product Information

The Product Information panel provides access to the full range of settings that make up a product record. The information in this section can be used for reference when creating a product of any type. The selection of Product Information tabs, and the organization of the fields on each page is determined by the attribute set that was used to create the product.
General

Use the General tab to enter information about the product. In addition to providing basic information about the product, this section determines the product’s visibility in the catalog and search.

The selection, order, and grouping of the fields is determined by the attribute set that was used to create the product. As a result, the product attributes might differ from what is shown in the example.

General Information

Button Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create New Attribute</td>
<td>Gives you the ability to create a new attribute while working in product edit mode. Although you can save the new attribute, it is not automatically included in the attribute set that is associated with the current product.</td>
</tr>
<tr>
<td>WYSIWYG Editor</td>
<td>Opens the editor so you can format the description fields with HTML. The frontend properties of the description attributes must set to allow HTML.</td>
</tr>
</tbody>
</table>
## Field Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Store View</td>
<td>(Required) The name of the product you want to appear in catalog. The name is also used to auto-generate the URL Key.</td>
</tr>
<tr>
<td>Description</td>
<td>Store View</td>
<td>(Required) The main product description that appears on the product page. The text should be plain ASCII text. HTML tags can be used to format the description if permitted by the attribute properties. Do not paste text directly from a word processor, because the text might include print control codes that will not render correctly. To strip out any control codes, save the file as a .txt file before copying and pasting the text into the product description.</td>
</tr>
<tr>
<td>Short Description</td>
<td>Store View</td>
<td>(Required) Depending on the theme, the Short Description might appear on catalog pages. Because of its length, it is often used for RSS feeds.</td>
</tr>
<tr>
<td>SKU</td>
<td>Global</td>
<td>(Required) The Stock Keeping Unit is a unique identifier for each individual product or service provided.</td>
</tr>
<tr>
<td>Weight</td>
<td>Global</td>
<td>(Required) The weight of the product is a decimal value used for shipping calculations, and refers to the standard measurement system used by shipping carriers in your locale. In the United States, weight is measured in pounds and ounces, whereas countries on the metric system measure weight in grams and kilograms.</td>
</tr>
<tr>
<td>Set Product as New from Date</td>
<td>Website</td>
<td>Sets the beginning date for the range of time the product is featured in the &quot;New Product&quot; block on the Home page. The date can be typed directly into the box, or selected from the calendar.</td>
</tr>
<tr>
<td>Set Product as New to Date</td>
<td>Website</td>
<td>Sets the ending date for the range of time the product is featured in the &quot;New Product&quot; block on the Home page.</td>
</tr>
<tr>
<td>Status</td>
<td>Website</td>
<td>(Required) The Status indicates when the product is ready to be offered for sale in your store. Options include: Enabled / Disabled.</td>
</tr>
</tbody>
</table>
### Field Descriptions (cont.)

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>URL Key</td>
<td>Store View</td>
<td>Determines the online address of the product. It is added to the base URL of the store, and appears in the address bar of a browser. The URL Key should be all lowercase characters, with hyphens instead of spaces. Magento initially creates a default, “search engine friendly” URL, based on the product name. Do not type the suffix .html in the URL Key, because use of the suffix is controlled by your store configuration. To learn more, see, SEO URL Options.</td>
</tr>
<tr>
<td>Visibility</td>
<td>Store View</td>
<td>(Required) Determines the level of visibility the product has throughout the store. Options include:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Not Visible</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Individually</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The product may be associated with a one-to-many product, but is not listed in the catalog.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Catalog</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The product appears in the catalog listing, but is not included in Search results.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Search</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The product appears in search results, but is not listed in the catalog.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Catalog, Search</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The product is listed in the catalog and search results.</td>
</tr>
<tr>
<td>Country of Manufacture</td>
<td>Website</td>
<td>Select the manufacturer of the product. To add new options to the list, see Manage Label / Options.</td>
</tr>
</tbody>
</table>
Product Meta Data

Meta data is your first level of contact with potential customers who are searching for a product. Your title and description are selling tools that will either help to motivate a visitor to click your link or not. It is wise to use a descriptive title and a description that includes relevant words that a potential customer might search.

The information is read by search engines that index your site. Although Google no longer places a value on meta keywords, other search engines continue to use the information. It’s a good practice to incorporate high-value keywords in your product titles and related content.

Field Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Meta Title</td>
<td>Store View</td>
<td>The title appears in the title bar and tab of your browser, and on search engine results pages (SERP(^1)).</td>
</tr>
<tr>
<td>Meta Keywords</td>
<td>Store View</td>
<td>Relevant keywords that customers might use to find the product.</td>
</tr>
<tr>
<td>Meta Description</td>
<td>Store View</td>
<td>A few sentences that describe the product. Although not visible to the customer, some search engines include the meta description in search results.</td>
</tr>
</tbody>
</table>

\(^1\)Search Engine Results Page
Recurring Profile

Recurring Profiles are most often used for subscriptions or products with installment payment plans. When such a product is purchased from your store, the customer is redirected to a third-party payment system. The customer enters into a recurring payment agreement to authorize the payment system to charge the customer account according to the recurring profile settings.

When a customer purchases a product with recurring payments, the profile parameters specified from Magento are transferred to the payment system. Magento supports recurring profiles for items paid with PayPal Express Checkout.

For example, to set up a product with monthly subscription payments, the following parameters are specified in the recurring profile of the product. The customer is charged by the payment system once a month, for a year.

- Billing Period Unit: Month
- Billing Frequency: 1
- Maximum Billing Cycles: 12

You can also set up a trial period where the customer pays a special, introductory price for a period of time. When the trial ends, the customer is charged the regular amount.

Creating a recurring profile for a product does not create additional sales orders.

In the third-party payment system, a recurring profile is an accounting record that captures payments on a regular basis and according to the payment schedule defined in the recurring profile. A recurring profile submits the information about the frequency of a payment being initiated to the payment system.

The Recurring Profile tab appears by default for simple and virtual products. However, you can configure it to become available for other product types by changing the Apply To property of the recurring_profile attribute. To learn more about recurring profiles, see: Working with Recurring Profiles in the knowledge base.
To set up a recurring profile:

1. On the Admin menu, select **Catalog > Manage Products**. Find the product in the list, and click to open it in edit mode.

2. In the panel on the left, select **Recurring Profile**.

3. Set **Enable Recurring Profile** to “Yes.” The section expands to include additional options.

   ![Recurring Profile](image)

4. In the Schedule section, do the following:

   ![Schedule](image)

   a. To let the customer determine the starting date for the payments, set **Customer Can Define Start Date** to “Yes.”

   b. In the **Schedule Description** field, enter a brief description of the recurring payment. The description is used as the name of the recurring payment on the Review Information page.

   c. In the **Maximum Payment Failures** field, enter the number of times payment can fail before the recurring profile is suspended.

   d. To automatically initiate a payment transaction at the end of the next billing cycle, set **Auto Bill on Next Cycle** to “Yes.”

5. In the Billing section, do the following:

   ![Billing](image)
a. Set **Billing Period Unit** to the period of time that defines the billing cycle.

b. Set **Billing Frequency** to how often a payment transaction is initiated during the billing cycle.

c. In the **Maximum Billing Cycles** field, enter the maximum number of payments allowed for the recurring profile. If left blank, the customer will continue to be charged until the recurring profile is canceled.

6. In the Trial Period section, do the following:

```
<table>
<thead>
<tr>
<th>Trial Period</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trial Billing Period Unit</td>
</tr>
<tr>
<td>Trial Billing Frequency</td>
</tr>
<tr>
<td>Maximum Trial Billing Cycles</td>
</tr>
<tr>
<td>Trial Billing Amount</td>
</tr>
</tbody>
</table>
```

**Trial Period**

a. Set **Trial Billing Period Unit** to the period of time that defines the billing cycle during the trial period.

b. Set **Trial Billing Period Frequency** to how often a payment transaction is initiated during the trial billing cycle.

c. In the **Trial Billing Period Cycles** field, enter the maximum number of payments allowed during the trial period.

d. In the **Trial Billing Amount** field, enter the product price during the trial period.

The trial billing period parameters are optional, but if specified, make sure that all fields are complete. Otherwise, the payment system will not authorize the payment.

7. In the Initial Fees section, do the following:

```
<table>
<thead>
<tr>
<th>Initial Fees</th>
</tr>
</thead>
<tbody>
<tr>
<td>Initial Fee</td>
</tr>
<tr>
<td>Allow Initial Fee Failure</td>
</tr>
</tbody>
</table>
```

**Initial Fees**
a. In the **Initial Fees** field, enter the amount that the customer is charged at the time of purchase. The initial fee is paid only once during the life of a subscription.

b. If you want to cancel the recurring if the initial payment fails, set **Allow Initial Fee Failure** to “Yes.” If set to “No,” the initial fee is added to the customer’s outstanding amount and is charged by the payment system as soon as the customer account has a sufficient amount.

8. When complete, click the **Save** button.

### Field Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>SCHEDULE</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Customer Can Define Start</td>
<td>Global</td>
<td>Determines if the customer can set the starting date for the payments. Options include:</td>
</tr>
<tr>
<td>Date</td>
<td></td>
<td>Yes Displays the Recurring Profile Start Date as an option on the product page.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No The customer cannot set the start date.</td>
</tr>
<tr>
<td>Schedule Description</td>
<td>Global</td>
<td>A brief description of the recurring payment. The description appears as the name of the recurring payment on the review information page of the payment system. If left empty, the name of the selected product appears as the name of the recurring profile.</td>
</tr>
<tr>
<td>Maximum Payment Failures</td>
<td>Global</td>
<td>Determines the number of failed scheduled payments before the recurring profile is automatically be suspended.</td>
</tr>
<tr>
<td>Auto Bill on Next Cycle</td>
<td>Global</td>
<td>Determines if the payment system automatically initiates a payment transaction after the regular billing cycle. In the event of a number of payment failures and the customer has an outstanding amount, the customer is charged in the next billing cycle. Options: Yes / No</td>
</tr>
<tr>
<td><strong>BILLING</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Billing Period Unit</td>
<td>Global</td>
<td>Determines the period of time included in a subscription billing cycle, and how frequently a payment transaction is initiated. Options include:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Day</td>
</tr>
</tbody>
</table>
### Field Descriptions (cont.)

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Week</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Two Weeks</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Month</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Year</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Billing Frequency</td>
<td>Global</td>
<td>Determines how often within the billing period a payment transaction is initiated for the recurring profile.</td>
</tr>
<tr>
<td>Maximum Billing Cycles</td>
<td>Global</td>
<td>Limits the number of payments that can be made during a billing cycle. If you do not specify the maximum of billing cycles, the recurring profile remains permanently active and the customer is charged by the payment system until the recurring profile is suspended or canceled.</td>
</tr>
</tbody>
</table>

### TRIAL PERIOD

<table>
<thead>
<tr>
<th>Trial Billing Period Unit</th>
<th>Global</th>
<th>Determines the period of time included in a trial subscription billing cycle, and how frequently a payment transaction is initiated. Options include: Day Week Two Weeks Month Year</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trial Billing Frequency</td>
<td>Global</td>
<td>Determines how often during the billing period a payment transaction is initiated for the recurring profile.</td>
</tr>
<tr>
<td>Maximum Trial Billing Cycles</td>
<td>Global</td>
<td>Limits the number of recurring payments that can be made during a trial billing cycle.</td>
</tr>
<tr>
<td>Trial Billing Amount</td>
<td>Global</td>
<td>The price of the product during the trial period.</td>
</tr>
<tr>
<td>Initial Fees</td>
<td>Global</td>
<td>The amount the customer is charged at the time of purchase. The initial fee is paid only once during the life of a subscription.</td>
</tr>
</tbody>
</table>
### Field Descriptions (cont.)

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allow Initial Fee Failure</td>
<td>Global</td>
<td>Determines if the payment profile is suspended if the initial fee payment fails. In case the field is set to No, Options include:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Yes</td>
<td></td>
<td>The payment profile is suspended if the initial fee fails.</td>
</tr>
<tr>
<td>No</td>
<td></td>
<td>The initial fee is added to the customer’s outstanding amount and is charged by the payment system as soon as the customer account has the sufficient amount.</td>
</tr>
</tbody>
</table>
Design

The Design page gives you the ability to apply a different theme to the product page, and make updates to the XML code that controls the page layout.

**Product Design**

### Field Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Custom Design</td>
<td>Store View</td>
<td>To apply a custom theme, select the one you want from the list of available themes.</td>
</tr>
<tr>
<td>Active From</td>
<td>Store View</td>
<td>If applying a custom theme for a period of time, enter the beginning date, or select the date from the Calendar.</td>
</tr>
<tr>
<td>Active To</td>
<td>Store View</td>
<td>If applying a custom theme for a period of time, enter the ending date, or select the date from the Calendar.</td>
</tr>
<tr>
<td>Custom Layout Update</td>
<td>Store View</td>
<td>You can further customize the theme with XML coding.</td>
</tr>
<tr>
<td>Page Layout</td>
<td>Store View</td>
<td>To apply a different layout to the product page, select one of the following:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No layout updates This option is preselected by default and does not apply layout changes.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Empty This option lets you define your own layout, such as a 4-column page. Requires an understanding of XML.</td>
</tr>
</tbody>
</table>
### Field Descriptions (cont.)

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 column</td>
<td>Applies the 1-column layout.</td>
<td></td>
</tr>
<tr>
<td>2 columns with left bar</td>
<td>Applies the 2 column layout.</td>
<td></td>
</tr>
<tr>
<td>2 columns with right bar</td>
<td>Applies the 2-columns with right bar layout.</td>
<td></td>
</tr>
<tr>
<td>3 columns</td>
<td>Applies the 3 column layout.</td>
<td></td>
</tr>
</tbody>
</table>

- **Display product options in Store View**
  - Options include: Product Info Column / Block after Info Column
Gift Options

Gift Options determine if customers have the option to add a gift message and to gift wrap the product during checkout. To configure gift options for the store, see: Gift Options Configuration.

To set up gift options for a product:

1. On the Admin menu, select Catalog > Manage Products. Then, click to open the product in edit mode.

2. In the panel on the left, select Gift Options. Then, do the following:

   a. The Allow Gift Message reflects the default configuration. To override the setting, clear the Use Config Settings checkbox. Then, change the value as needed.

   b. To charge for gift wrapping, enter the amount in the Price for Gift Wrapping field, as a decimal, without the currency symbol.

3. When complete, click the Save button.
Websites

If your Magento installation has multiple websites, stores, or views, you can set the scope of a configuration setting, product, category, or attribute to apply to a specific website, store, or store view. To learn more, see: Websites, Stores & Views.

To assign a product to a store view:

1. In the Product Information panel on the left, select Websites.
2. Select the checkbox for each store view where the product is offered for sale.
3. When complete, click the Save button.
Categories

Every product in your catalog must be assigned to at least one category. Before you can add products to your catalog, you must first establish its basic category structure. A product cannot be saved until after it has been assigned to at least one category.

To set up the product categories:

1. In the Product Information panel on the left, select **Categories**.

2. In the category tree, select the checkbox of each category to which you want to associate the product. Click the plus [+ ] icon to show any available subcategories.

   A single product can be assigned to more than one category.

3. When complete, click the **Save** button.
Related Products

Related products are meant to be purchased in addition to the item the customer is viewing. Simply click the checkbox of a product to place it in the shopping cart. The placement of the Related Products block varies according to theme and page layout. In the example below, it appears at the bottom of the Product View page. With a 2 column layout, the Related Product block often appears in the right column.

To set up related products:

1. In the Product Information panel on the left, click Related Products.

2. Click the Reset Filter button in the upper-right to list all the available products, or use the search filters at the top of each column to find specific products.

3. In the list, select the checkbox in the first column of any product you want to feature as a related product.

4. When complete, click the Save button.
Up-sells

Up-sell products are items that your customer might prefer instead of the product currently viewed. An item offered as an up-sell might be of a higher quality, more popular, or have better profit margin. Up-sell products appear on the product page, under a heading such as, “You may also be interested in the following product(s).”

To select up-sell products:

1. In the Product Information panel, select **Up-sells**.
2. Click the **Reset Filter** button in the upper-right to list all the available products, or use the search filters at the top of each column to find specific products.
3. In the list, select the checkbox in the first column of any product you want to feature as an up-sell.
4. When complete, click the **Save** button.
Cross-sells

Cross-sells are similar to impulse purchases in the checkout line of a grocery store. Cross-sell products appear on the shopping cart page, just before the customer begins checkout.

To set up cross-sell products:

1. In the Product Information panel on the left, click Cross-sells.
2. Click the Reset Filter button to list all the available products, or use the filters at the top of each column to find specific products.
3. Select the checkbox in the first column of any product you want to feature as a cross-sell.
4. When complete, click the Save button.
Custom Options

Custom options are an easy way to offer a selection of product variations that do not rely on attributes. The limitations are that you cannot track inventory based on any variation, and that a product with custom options cannot be used with a configurable, grouped, or bundle product. Custom options are a good solution if your inventory needs are simple.

To create custom options:

1. On the Admin menu, select Catalog > Manage Products.
2. In the list, open the product record in edit mode.
3. In the panel on the left, select Custom Options.
4. In the upper-right corner, click the Add New Option button. Then, do the following:
   a. In the Title field, enter a name for the property.
   b. Set the Input Type you want to use for data entry.
   c. Set Is Required to “Yes” if the option must be selected before the product can be purchased.
   d. In the Sort Order field, enter a number to indicate the order of this item in the list of options. Enter the number 1 to display this option first.
5. Click the **Add New Row** button. Then, complete the following:

![Add New Row](image)

**Add New Row**

a. In the **Title** field, enter a name for this option.

b. In the **Price** field, enter any markup or markdown from the base product price that applies to this option.

c. Set **Price Type** to one of the following:

   - **Fixed**: The price of the variation differs from the price of the base product by a fixed monetary amount, such as $1.
   - **Percentage**: The price of the variation differs from the price of the base product by a percentage, such as 10%.

d. Enter a **SKU** for the option. The option SKU is a suffix to the product SKU.

e. In the **Sort Order** field, enter a number to indicate the order of this item in the list of options. Enter the number 1 to display this option first.

6. When complete, click the **Save** button.
Marketing

Learn how to increase average order value with targeted promotions, and use your store's built-in shopping tools to create opportunities for customer engagement. Opportunities abound for you to leverage multiple sales channels, including social media, shopping sites, and marketplaces. Then, use Google tools to analyze traffic, optimize your content, plan your next campaign.

Promotions
- Catalog Price Rules
- Multiple SKUs
- Shopping Cart Price Rules
- Coupon Codes
  - Auto-Generated Coupon Codes
  - Coupon Report
- Free Shipping Promotion
- Buy X, Get Y Free
- Discount with Minimum Purchase

Shopping Tools
- Opportunities to Engage
  - Email a Friend
  - Polls
  - Tags
    - Products Tagged by Admin
    - Moderating Tags
- Wishlists
  - Wishlist Reports
- Gift Options
- Product Relationships
- Compare Products
- Recently Viewed/Compared Products
- Product Reviews
  - Custom Ratings

Newsletters
- Newsletter Configuration
- Newsletter Templates

Sales Channels
- RSS Feeds

Social Marketing
- Adding Facebook Plugins

Google Tools
- Google Merchant Center
- Google Sitemap
- Google Universal Analytics

SEO & Search
- Storefront Search Tools
  - Quick Search
  - Advanced Search
  - Search Results
  - Popular Search Terms
  - Search Configuration
- Managing Search Terms
  - Adding Search Terms

SEO Best Practices
- Meta Data
- Sitemap
- Catalog URLs
  - URL Configuration
- Dynamic Media URLs
- Canonical Meta Tag
- Managing URL Rewrites
  - Configuring URL Rewrites
  - Automatic Product Redirects
  - Creating URL Rewrites
    - Product Rewrite
    - Category Rewrite
    - Custom Rewrite
CHAPTER 20:  

Promotions

In this section of the guide, you will learn how to set up product relationships, and use price rules to trigger discounts based on a variety of conditions. Here are a few ways you can use price rules to offer incentives to your customers:

- Send your best customers a coupon for a discount on a specific product
- Offer free shipping for purchases over a certain amount
- Schedule a promotion for a period of time

With price rules, you can set up your promotions in advance, so they spring into action whenever the required conditions are met.
Catalog Price Rules

Catalog price rules can be used to selectively put products on sale under certain conditions. Catalog price rules do not use coupon codes, because they are triggered before a product is placed into the shopping cart.

### Process Overview:

**Step 1: Add a New Rule**

**Step 2: Define the Conditions**

**Step 3: Define the Actions**

**Step 4: Apply the Rule**

---

**Step 1: Add a New Rule**

1. On the Admin menu, select **Promotions > Catalog Price Rules**.

2. In the upper-right corner, click the **Add New Rule** button.

   The options in the panel on the left include Rule Information, Conditions, and Actions.
Rule Information

3. On the Rule Information page, do the following:
   
   a. Complete the **Rule Name** and **Description** fields. These fields are for your internal reference only.
   
   b. Set **Status** to “Active.”
   
   c. Select the **Websites** where the rule will be available.
   
   d. Select the **Customer Groups** to which this rule applies.

   To select multiple options, hold down the Ctrl key (PC) or Command key (Mac), and click each option.

   e. Set **From Date** and **To Date** to define the range of dates when the rule will be in effect. If you leave the dates blank, the rule is enabled as soon as the price rule is saved.

   f. Enter a number to establish the **Priority** of this rule in relation to other rules.

Step 2: Define the Conditions

Most of the available conditions are based upon existing attribute values. If you want to apply the rule to all products, leave the conditions blank.

1. In the panel on the left, select **Conditions**. The first rule begins:
The statement has two underlined links, which when clicked, display the options for that part of the statement. If you save the condition without making additional selections, the rule will apply to all products.

- Click the **ALL** link, and select “ALL” or “ANY.”
- Click the **TRUE** link and select “TRUE” or “FALSE.”
- Leave the condition unchanged to apply the rule to all products.

You can create different conditions by changing the combination of these values.

If **ALL** of these conditions are **TRUE**:

2. Click the **Add** button at the beginning of the next line.
   
   a. In the list under **Product Attribute**, select the attribute that you want to use as the basis of the condition. For this example, the selected condition is “Attribute Set.”

![Condition Line 2, Part 1](image)

For an attribute to appear in the list, it must be configured to be used in promo rule conditions. To learn more, see: Attribute Frontend Properties.

The selected condition appears in the statement, followed by two more underlined links. The statement now says:

If **ALL** of these conditions are **TRUE**:

Attribute Set **is** ...

b. Click the **is** link, and select the comparison operator that is needed to describe the condition to be met. In this example, the options are “IS” or “IS NOT.”

c. Then, click the **more** link, and choose the attribute set upon which the condition is based.
Condition Line 2, Part 3

The selected item appears in the statement to complete the condition.

If ALL of these conditions are TRUE:

Attribute Set is Eyewear

3. To add another line to the statement, click the Add button, and choose one of the following:

- Conditions Combination
- Product Attribute

Then, repeat the process until the condition is complete.

If at any time you want to delete part of the statement, click the Delete button at the end of the line.

Step 3: Define the Actions

1. In the panel on the left, select Actions.

2. In the Update Prices Using the Following Conditions section, set Apply to one of the following options:

   - By Percentage of the Original Price
     Discounts item by subtracting a percentage from the original price. For example:
     Enter 10 in Discount Amount for an updated price that is 10% less than the original price.
By Fixed Amount  Discounts item by subtracting a fixed amount from original price. For example:
Enter 10 in Discount Amount for an updated price that is $10 less than the original price.

To Percentage of the Original Price  Discounts item by defining the final price based on percentage. For example:
Enter 10 in Discount Amount for an updated price that is 10% of the original price.

To Fixed Amount  Sets the price to a fixed amount.

3.  Do one of the following:
   - Enter the Discount Amount.
   - To apply the discount amount to associated products, set Enable Discount to Subproducts to “Yes.” Then, enter the Discount Amount to apply.

4.  If you want to stop the processing of other rules after this rule has been applied, set Stop Further Rules Processing to “Yes.” This safeguard prevents customers from receiving multiple discounts for the same product.

5.  Click the Save and Continue Edit button to save your changes.

Step 4: Apply the Rule

As new rules are added, the prices and the priorities are recalculated accordingly.

1.  To apply a new rule immediately, do one of the following:
   - Click the Save and Apply button.
   - From the Catalog Price Rules list, click the Apply Rules button.

2.  When you create a new price rule, it might take an hour or so for it to become available. Allow enough time for it to get into the system. Then, test the rule to make sure that it works correctly. Unless otherwise specified, price rules are automatically processed with other system rules each night.
Price Rule with Multiple SKUs

A single price rule can be applied to multiple SKUs, which makes it possible to create a variety of promotions based on a product, brand, or category. In the following illustration, multiple products are selected for a catalog price rule.

Selecting Multiple SKUs for a Price Rule Condition

To apply a price rule to multiple SKUs:

1. On the Admin menu, select **Promotions > Catalog Price Rules**.
2. Do one of the following:
   - Follow the instructions to create a catalog price rule.
   - In the list, click to open the catalog price rule that you want to change.
3. In the panel on the left, select **Conditions**. Then, do the following:
   a. In the first line, set the first parameter to “ANY.”
   b. If the price rule doesn’t have a line for SKU, Click the Add button at the beginning of the next line. Then, in the list under Product Attribute, select SKU.
Choose the Condition

c. Click the … “more” link to display more options. Then, click the **Chooser** button to display the list of available products.

**SKU IS**

d. In the list, select the checkbox of each product that you want to include. Then, click the **Select** button to add the SKUs to the condition.

---

4. Complete the rule, including any **Actions** to be taken when the conditions are met.

5. To apply the rule, click the **Save Rule** button.

6. When you create a new price rule, it might take an hour or so for it to become available. Allow enough time for it to get into the system. Then, test the rule to make sure that it works correctly. Unless otherwise specified, price rules are automatically processed with other system rules each night.
Shopping Cart Price Rules

Shopping cart price rules create discounts for orders at the checkout level, based on a set of conditions. The discount can be applied automatically when the conditions are met, or be applied when the customer enters a valid coupon code. When applied, the discount appears on the shopping cart page under the subtotal.

Once established, the price rule can be used as needed for a season or promotion by changing its status and date range.

Process Overview:
Step 1: Add a New Rule
Step 2: Define the Conditions
Step 3: Define the Actions
Step 4: Complete the Labels
Step 6: Apply the Rule
Step 1: Add a New Rule

1. On the Admin menu, select Promotions > Shopping Cart Price Rules. Then, click the Add New Rule button.

   ![Shopping Cart Price Rules](image1)

   **Shopping Cart Price Rules**

   The options in the panel on the left include Rule Information, Conditions, Actions, and Labels.

   ![Shopping Cart Price Rule General Information](image2)

   **Shopping Cart Price Rule General Information**

2. Under General Information, complete the Rule Name and Description. These fields are for internal reference only.

3. If you want the rule to go into effect immediately, set Status to “Active.”

4. To establish the scope of the rule, do the following:
   a. Select the Websites where the promotion is to be available.
b. Select the **Customer Groups** to which the promotion applies.

- To make the promotion available only to registered customers, do not select the “NOT LOGGED IN” option.
- To select multiple options, hold down the Ctrl key (PC) or Command key (Mac), and click each option.

5. To associate a **coupon** with the price rule, set **Coupon** to “Specific Coupon.” Then, do the following:

a. Enter a numeric **Coupon Code** that the customer must enter to receive the discount.

b. To set a limit on the number of times the coupon can be used, complete the following:

- **Uses per Coupon**
  - Determines how many times the coupon code can be used. If there is no limit, leave the field blank.

- **Uses per Customer**
  - Determines how many times the coupon code can be used by the same registered customer who belongs to any of the selected customer groups. The setting does not apply to guest shoppers who are members of the NOT LOGGED IN customer group, or to customers who shop without logging in to their accounts. If there is no limit, leave the field blank.

6. To define the “good through” date range for the promotion, do the following:

a. Click the **Calendar** button next to the **From Date** field, and choose the first date. The promotion will start at the beginning of that day.

b. Click the **Calendar** button next to the **To Date** field, and choose the last date. The promotion will stop at the end of that day.

7. Enter a number to determine the **Priority** of this price rule in relation to the Action settings of other price rules that might be active at the same time. (Number 1 has the highest priority.)

8. To apply the rule to published listings in **RSS feeds**, set **Public In RSS Feed** to “Yes.”
Step 2: Define the Conditions

In this step, the conditions are described that must be met for an order to qualify for the promotion. The rule goes into action whenever the set of conditions is met.

1. In the panel on the left, select **Conditions**. The first rule appears by default, and states:

   **If ALL of these conditions are TRUE:**

   The statement has two underlined links which when clicked, display the selection of options for that part of the statement. You can create different conditions by changing the combination of these values. Do any of the following:

   - Click the **ALL** link, and select “ALL” or “ANY.”
   - Click the **TRUE** link and select “TRUE” or “FALSE.”
   - Leave the condition unchanged to apply the rule to all products.

2. Click the **Add** button at the beginning of the next line. Then, choose one of the following options from the list to describe the condition that you want to set for the rule.

   - Product attribute combination
   - Products subselection
   - Conditions combination
   - Cart Attribute
Example 1: Regional Price Rule

To create a regional price rule, select one of the following cart attributes:

- Shipping Postcode
- Shipping Region
- Shipping State/Province
- Shipping Country

Example 2: Shopping Cart Totals

To base the condition on shopping cart totals, select one of the following cart attributes:

- Subtotal
- Total Items Quantity
- Total Weight

When you make a selection, the basic structure of the statement appears in the box with additional links to mark where you can select information. Each underlined word is a building block that describes a different aspect of the condition.

3. In the list under **Product Attribute**, select the attribute upon which the condition is based. For this example, the selected condition is “Attribute Set.”

![Condition - Line 2, Part 1](image)

For an attribute to appear in the list, its **Use for Promo Rules Conditions** property must be set to “Yes.”

The condition appears in the statement, followed by two more underlined links. The statement now says:
If **ALL** of these conditions are **TRUE**:

If an item is **FOUND** in the cart with **ALL** of these conditions true

Attribute Set is ... 

4. Click the **is** link, and select the comparison operator that is needed to describe the condition to be met. In this example, the options are “IS” and “IS NOT.”

5. Click the ... “more” link, and choose the attribute set upon which the condition is based. The selected item appears in the statement to complete the condition.

Completed Condition

If **ALL** of these conditions are **TRUE**:

Attribute Set is **Electronics**

6. To add more conditions, click the **Add** button and again, choose one of the following:

- Conditions Combination
- Product Attribute

Then, repeat the process until the condition is complete.

If at any time you want to delete part of the statement, click the **Delete** button at the end of the line.
Step 3: Define the Actions

The shopping cart price rule actions describe how prices are updated when the conditions of the rule are met.

1. In the panel on the left, select **Actions**.

2. Set **Apply** to one of the following discount options:

   - **Percent of product price discount**
     Discounts item by subtracting a percentage from the original price. The discount applies to each qualifying item in the cart. For example:
     Enter 10 in Discount Amount for an updated price that is 10% less than the original price.

   - **Fixed amount discount**
     Discounts item by subtracting a fixed amount from original price. The discount applies to each qualifying item in the cart. For example:
     Enter 10 in Discount Amount for an updated price that is $10 less than the original price.

   - **Fixed amount discount for whole cart**
     Discounts the entire cart by subtracting a percentage from the cart total. For example:
     Enter 10 in Discount Amount to subtract 10% from the cart total.

   - **Buy X get Y free**
     Defines a quantity that the customer must purchase to receive a quantity for free. (The Discount Amount is Y.)

3. Enter the **Discount Amount** as a number, without symbols. For example, depending on the discount option selected, the number 10 might indicate a percentage, a fixed amount, or a quantity of items.

4. In the **Maximum Qty Discount is Applied To** field, enter the largest number of the same product that can qualify for the discount.
5. To determine how **free shipping** is applied, set **Free Shipping** to one of the following:
   - **No**: Free shipping is not available for the promotion.
   - **For matching items only**: Free shipping is available only for specific items in the cart that match the rule.
   - **For shipment with matching items**: Free shipping is available for the entire cart when a coupon that is based on the rule is used.

6. **Set Stop Further Rules Processing** to “Yes” to stop processing other rules as soon as this one is applied. This safeguard prevents customers from receiving multiple discounts for the same purchase.

7. To define an additional action that applies to specific items in the cart, only when a specific set of conditions is met, click the **Add** button. Then, choose an item from the following sections in the list:
   - Cart item attribute
   - Price in cart
   - Quantity in cart
   - Row total in cart
   - Product attribute (from all available in your catalog)

   Add as many levels as you need to describe the conditions to be met.

8. When complete, click the **Save Rule** button.

**Step 4: Complete the Labels**

The label appears on the order below the subtotal to identify the discount. You can enter a default label for all store views, or enter a different label for each view.

1. In the panel on the left, select **Labels**.

2. In the Default Label section, enter the text for the **Default Rule Label for All Store Views**.

```
<table>
<thead>
<tr>
<th>Default Label</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default Rule Label for All Store Views</td>
</tr>
</tbody>
</table>
```

3. In the Store View Specific Labels section, enter the label text for each store view. For example, if each store view is in a different language, enter the label translation for each view.
Step 5: Apply the Rule

1. When complete, click the **Save Rule** button.

2. When you create a new price rule, it might take an hour or so for it to become available. Allow enough time for it to get into the system. Then, test the rule to make sure that it works correctly. Unless otherwise specified, price rules are automatically processed with other system rules each night. As new rules are added, Magento recalculates the prices and the priorities accordingly.
## Field Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>RULE INFORMATION</strong></td>
<td></td>
</tr>
<tr>
<td>Rule Name</td>
<td>(Required) The name of the rule is for internal reference.</td>
</tr>
<tr>
<td>Description</td>
<td>A description of the rule should include the purpose of the rule, and explain how it is used.</td>
</tr>
<tr>
<td>Status</td>
<td>(Required) Determines if the rule is currently active in the store. Options: Active / Inactive</td>
</tr>
<tr>
<td>Websites</td>
<td>(Required) Identifies the websites where the rule can be used.</td>
</tr>
<tr>
<td>Customer Groups</td>
<td>(Required) Identifies the customer groups to which the rule applies.</td>
</tr>
<tr>
<td>Coupon</td>
<td>(Required) Indicates if a coupon is associated with the rule. Options: No Coupon No coupon is associated with the rule. Specific Coupon A specific coupon is associated with the rule. Coupon Code When prompted, enter the Coupon Code that the customer must enter to take advantage of the promotion. Use Auto Generation Select the checkbox to automatically generate multiple coupon codes which can be used with the promotion.</td>
</tr>
<tr>
<td>Uses per Coupon</td>
<td>The number of times the coupon code can be used.</td>
</tr>
<tr>
<td>Uses per Customer</td>
<td>Determines how many times the coupon code can be used by the same registered customer who belongs to any selected customer group. Does not apply to guest shoppers who are members of the NOT LOGGED IN customer group, or to customers who shop without logging in to their accounts. For no limit, leave blank.</td>
</tr>
<tr>
<td>From Date</td>
<td>The first date the coupon can be used.</td>
</tr>
<tr>
<td>To Date</td>
<td>The last date the coupon can be used.</td>
</tr>
<tr>
<td>Priority</td>
<td>A number that indicates the priority of this rule in relation to others. The highest priority is number 1.</td>
</tr>
</tbody>
</table>
### Field Descriptions (cont.)

<table>
<thead>
<tr>
<th>FIELD</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Public in RSS Feed</td>
<td>Determines if the promotion is included in your store’s public RSS feed. Options: Yes / No.</td>
</tr>
</tbody>
</table>

### ACTIONS

<table>
<thead>
<tr>
<th>ACTION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply</td>
<td>Determines the type of calculation that is applied to the purchase. Options:</td>
</tr>
<tr>
<td></td>
<td>Percent of product price discount</td>
</tr>
<tr>
<td></td>
<td>Fixed amount discount</td>
</tr>
<tr>
<td></td>
<td>Fixed amount discount for whole cart</td>
</tr>
<tr>
<td></td>
<td>Buy X Get Y Free (discount amount is Y)</td>
</tr>
</tbody>
</table>

- **Discount Amount** (Required) The amount of discount that is offered.
- **Maximum Qty Discount is Applied To** Sets the maximum number of products that the discount can be applied to in the same purchase.
- **Discount Qty Step (Buy X)** Sets the number of products represented by “X” in a “Buy X Get Y Free” promotion.
- **Apply to Shipping Amount** Determines if the discount can be applied to the cost of shipping. Options: Yes / No.
- **Free Shipping** Determines if free shipping is included in the promotion, and if so, for which items. Options:
### Field Descriptions (cont.)

<table>
<thead>
<tr>
<th>FIELD</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>No</td>
<td>Free shipping is not available when a coupon that is based on the rule is used.</td>
</tr>
<tr>
<td>For matching items only</td>
<td>Free shipping is available only for specific items in the cart that match the rule.</td>
</tr>
<tr>
<td>For shipment with matching items</td>
<td>Free shipping is available for the entire cart when a coupon that is based on the rule is used.</td>
</tr>
</tbody>
</table>

**Stop Further Rules Processing**

Determines if additional rules can be applied to this purchase. To prevent multiple discounts from being applied to the same purchase, select “Yes.” Options: Yes / No

### DEFAULT LABEL

**Default Rule Label for All Store Views**

A default label that identifies the discount and can be used for all store views.

**Store View Specific Labels**

If applicable, a different label that identifies the discount for each store view.
Coupon Codes

Coupons codes can be associated with shopping cart price rules to apply a discount when a set of conditions is met. For example, a coupon code can be created for a specific customer group, or for anyone who makes a purchase over a certain amount. To apply the coupon to a purchase, the customer can enter the coupon code from the shopping cart page, or possibly at the cash register of your “brick and mortar” store.

Here are a few ways that you can use coupons in your store:

- Email coupons to customers
- Produce printed coupons
- Create in-store coupons for mobile users

Coupon codes can be sent by email, or included in newsletters, catalogs, and advertisements. You can even create in-store coupons with a quick response code that shoppers can scan with their smart phones. The QR code links to a page on your site with more information about the promotion.
To set up a coupon code:

1. Follow the instructions to create a shopping cart price rule.

2. On the General Information page, do the following:
   a. Set Coupon to “Specific Coupon.”
   b. Do one of the following:
      - Enter a numeric Coupon Code to be used with the promotion.
      - Select the Use Auto Generation checkbox.
   c. To limit the number of times the coupon can be used, complete the following:
      - Uses per Coupon
      - Uses per Customer
      For unlimited use, leave these fields blank.
   d. To make the coupon valid for a limited period of time, complete the From Date and To Date fields. To select the date, click the Calendar button next to each field. If you leave the date range empty, the rule will never expire.

   ![Price Rule Coupon Code Settings]

3. Follow the standard instructions to complete the shopping cart price rule.

Auto-Generated Coupon Codes

Batches of discount coupon codes can be formatted and generated automatically. Coupon codes can also be exported, and incorporated into other applications. For example, you might use a series of auto-generated coupon codes to produce printed coupons with unique codes.
To configure auto-generated codes:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Customers, select Promotions.

2. Click to expand the Auto Generated Specific Coupon Codes section.

3. To create a specific format for your codes, enter the following:
   - Code Length
   - Code Format
   - Code Prefix
   - Code Suffix
   - Dash Every X Characters

4. When complete, click the Save Config button.

These settings can be overridden from the Shopping Cart Price Rule page.
To generate a batch of coupon codes:

1. On the Admin menu, select **Promotions > Shopping Cart Price Rules**.
2. Select an existing rule, or create a new one.
3. Set **Coupon** to “Specific Coupon.” Then, do the following:
   a. Select the **Use Auto Generation** checkbox.
   b. Complete the other rule settings as needed.
4. Click the **Save and Continue Editing** button.
5. In the panel on the left, select **Manage Coupon Codes**. Then, do the following:
   a. In the **Coupon Qty** field, enter the number of codes to be generated.
   b. Adjust the code format settings, as needed.
   c. Click the **Generate** button.

The generated coupon codes appear below. The list shows how many times each coupon code has been used.

To delete coupon codes:

1. In the list, select the checkbox of each code that you want to delete.
2. Set the **Actions** control to “Delete.”
3. Click the **Submit** button. When prompted, click **OK** to confirm.

To export coupon codes:

1. In the list of generated codes, use the filter controls at the top of each column to display the codes that you want to export.
2. Set **Export to** to the file format that you want to use for the data file.
3. Click the **Export** button.

Field Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Code Length</td>
<td>Global</td>
<td>Defines the length of the coupon code, excluding the prefix, suffix and separators.</td>
</tr>
<tr>
<td>Code Format</td>
<td>Global</td>
<td>Defines the coupon code format. Options:</td>
</tr>
</tbody>
</table>
**Field Descriptions (Cont.)**

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alphanumeric</td>
<td></td>
<td>Any combination of letters and numbers.</td>
</tr>
<tr>
<td>Alphabetical</td>
<td></td>
<td>Letters only.</td>
</tr>
<tr>
<td>Numeric</td>
<td></td>
<td>Numbers only.</td>
</tr>
<tr>
<td>Code Prefix</td>
<td>Global</td>
<td>A value appended to the beginning of all coupon codes. Leave blank to omit the prefix.</td>
</tr>
<tr>
<td>Code Suffix</td>
<td>Global</td>
<td>A value appended to the end of all codes. Leave blank to omit the suffix.</td>
</tr>
<tr>
<td>Dash Every X Characters</td>
<td>Global</td>
<td>An interval where a dash (-) can be inserted into all coupon codes. If you do not want to use a dash, leave the field blank.</td>
</tr>
</tbody>
</table>

*Coupon codes that differ by only a dash are considered to be different codes.*
Coupon Report

To learn how your coupons are used, you can run a detailed coupon usage report for each website, store, or view.

To generate a coupon report:

1. On the Admin menu, select Reports > Sales > Coupons.
2. In the upper-right corner, set Show Report For to define the scope of the report.
3. Set the filters as needed. Then, do one of the following:
   - To include coupon codes from all price rules in the report, set Shopping Cart Price Rule to “Any.”
   - To include coupon codes related to specific rules, set Shopping Cart Price Rule to “Specified.” Then, select the rules that you want to include in the report.
4. When complete, click the Show Report button.
Free Shipping Promotion

Free shipping can be offered as a promotion, either with, or without a coupon. A free shipping coupon, or voucher, can also be applied to customer pick-up orders, so the order can be invoiced and “shipped” to complete the workflow.

Some shipping carrier configurations give you the ability of offer free shipping based on a minimum order. To expand upon this basic capability, you can use shopping cart price rules to create complex conditions based on multiple product attributes, cart contents, and customer groups.

Process Overview:

Step 1: Enable Free Shipping
1. Enable the Free Shipping method in the configuration of your store.
2. Complete the free shipping settings for any carrier service that you want to use for free shipping.

Step 2: Create the Shopping Cart Price Rule
1. On the Admin menu, select Promotions > Shopping Cart Price Rules.
2. Follow the steps below to set up the type of free shipping promotion that you want to offer.
3. When complete, click the Save Rule button.

When you create a new price rule, it might take an hour or so for it to become available. Allow enough time for it to get into the system. Then, test the rule to make sure that it works correctly. Unless otherwise specified, price rules are automatically processed with other system rules each night.

Example 1: Free Shipping for Any Order
1. Complete the General Information settings as follows:
   a. Enter a Rule Name for internal reference.
   b. Set Status to “Active.”
   c. Set Website to “Main Website.” (Click to make sure the entry is selected.)
   d. Select the Customer Groups to which the rule applies.
e. Do one of the following:

- To offer a free shipping promotion without a coupon, accept the default, “No Coupon” setting.
- To use a coupon with the price rule, set **Coupon** to “Specific Coupon.” If necessary, complete the instructions to set up a **coupon**.

2. In the panel on the left, select **Actions**. Then, do the following:

a. Set **Apply** to “Percent of product price discount.”

b. Set **Apply to Shipping Amount** to “Yes.”

c. Set **Free Shipping** to “For shipment with matching items.”

![Price Rule Action](image)

3. In the panel on the left, select **Labels**. Then, do one of the following:

- Enter a **Default Rule Label for All Store Views**. This label is visible to the customer.
- If your store is available in multiple stores, enter a label for each view, as needed.

4. When complete, click the **Save Rule** button.

**Example 2: Free Shipping for Orders Over $Amount**

1. Complete the **General Information** settings as follows:

a. Enter a **Rule Name** for internal reference.

b. Set **Status** to “Active.”

c. Set **Website** to “Main Website.” (Click to make sure the entry is selected.)

d. Select the **Customer Groups** to which the rule applies.

e. Do one of the following:

- To offer a free shipping promotion without a coupon, accept the default, “No Coupon” setting.
- To use a coupon with the price rule, set **Coupon** to “Specific Coupon.” If necessary, follow the instructions to set up a **coupon**.

2. In the panel on the left, select **Conditions**.
3. Click the Add button to insert a condition. Then, do the following:
   a. In the list under Cart Attribute, click Subtotal.
   b. Click the underlined is link, and select “equals or greater than.”
   c. Click the … “more” link, and enter a threshold value for the Subtotal, such as 100, to complete the condition.
4. In the panel on the left, select Actions. Then, do the following:
   a. Set Apply to “Percent of product price discount.”
   b. Set Apply to Shipping Amount to “Yes.”
   c. Set Free Shipping to “For shipment with matching items.”
5. In the panel on the left, select Labels. Then, do one of the following:
   - Enter a Default Rule Label for All Store Views. The label is visible to the customer during checkout.
   - If your store is available in multiple views, enter a label for each view, as needed.
6. When complete, click the Save Rule button.

**Step 3: Test the Rule**

When you create a new price rule, it might take an hour or so for it to become available. Allow enough time for it to get into the system. Then, test the rule to make sure that it works correctly. Unless otherwise specified, price rules are automatically processed with other system rules each night.
Buy X Get Y Free

This example shows how to set up a shopping cart price rule for a “Buy X, Get Y Free” promotion. The format of the discount is as follows:

Buy X quantity of product, get Y quantity for free.

Process Overview:
Step 1: Create a Shopping Cart Price Rule
Step 2: Define the Conditions
Step 3: Define the Actions
Step 4: Complete the Label
Step 5: Apply the Rule

Step 1: Create a Shopping Cart Price Rule

Complete Step 1 of the shopping cart price rule instructions to create a shopping cart rule with the general information.

Step 2: Define the Conditions

Complete Step 2 of the shopping cart instructions to define the conditions for the price rule. The conditions can be triggered by purchasing a specific product, making a purchase of a certain amount, or any other scenario.

Step 3: Define the Actions

1. In the panel on the left, select Actions. Then, do the following:
   a. Set Apply to “Buy X get Y free (discount amount is Y).”
   b. Set Discount Amount to 1. This is the quantity the customer will receive for free.
   c. To limit the number of discounts that can be applied when the condition is met, enter the number in the Maximum Qty Discount is Applied To field. For example, enter “1” to discount only one item.
   d. In the Discount Qty Step (Buy X) field, enter the quantity that the customer must purchase to qualify for the discount.
2. Click the **Save and Continue Edit** button. Then, complete the rest of the rule as needed.

**Step 4: Complete the Label**

Complete **Step 4** of the shopping cart price rule instructions to enter the label that appears during checkout.

**Step 5: Apply the Rule**

1. When complete, click the **Save Rule** button.

2. When you create a new price rule, it might take an hour or so for it to become available. Allow enough time for it to get into the system. Then, test the rule to make sure that it works correctly. Unless otherwise specified, price rules are automatically processed with other system rules each night.
Discount with Minimum Purchase

Shopping cart price rules can be used to offer a percentage discount based on a minimum purchase. In the following example, a 25% discount is applied to all purchases over $200.00 in a specific category. The format of the discount is as follows:

\[ X\% \text{ off all } Y \text{ (category) over } Z \text{ dollars} \]

**Process Overview:**

Step 1: Create a Shopping Cart Rule
Step 2: Define the Conditions
Step 3: Define the Actions

**Step 1: Create a Shopping Cart Rule**

Follow the basic instructions to create a shopping cart rule.

**Step 2: Define the Conditions**

1. In the panel on the left, select **Conditions**.

2. Click the **Add** button at the beginning of the next line, and select **Product Attribute Combination**.

3. Click the **Add** button at the beginning of the next line.

**Product Attribute Combination**

**If an Item is FOUND**
4. In the list under Product Attribute, click **Category**.

   Choose Condition to Add

   a. Click the … “more” link to display additional options.

   Category IS

   b. Click the **Chooser** button to display the available categories. Then in the category tree, select the checkbox of each category that you want to include.

   Category Tree

   c. Click the **Select** button at the end of the line to add the categories to the condition.
5. Click the Add button at the beginning of the next line, and do the following:
   a. In the list under Product Attribute, select Price.
   b. Click the first underlined parameter, IS. Then in the list, select “equals or greater than.”
   c. Click the … “more” link to display the price field. Then, enter the amount that the price must be to meet the condition. For example, enter 200.00.

6. Click the Save and Continue Edit button.
Step 3: Define the Actions

1. In the panel on the left, select **Actions**. Then, do the following:

   ![Actions Panel](image)

   **Actions**

   - a. Set **Apply** to “Percent of product price discount.”
   - b. Enter the **Discount Amount**. For example, enter 25 for a twenty-five percent discount.
   - c. If you want to prevent the purchase from qualifying for additional promotions, set **Stop Further Rules Processing** to “Yes.”

2. Click the **Save and Continue Edit** button. Then, complete the rule as needed.
CHAPTER 21:

Shopping Tools

Your store includes a set of shopping tools that create opportunities for your customers to interact with your store, and to share the experience with friends.

Magento eBook

Learn five simple and inexpensive strategies to increase your average order value (AOV), and optimize and personalize the shopping experience. Get the eBook now!

Topics in this chapter include:

- Email a Friend
- Polls
- Tags
- Wishlists
- Gift Options
- Up-sells, Cross-sells & Related Products
- Compare Products
- Recently Viewed/Compared Products
- Product Reviews
Customer Engagement

Wishlist

The Wishlist block displays the items from the customer’s wishlist.

Compare Products

The Compare Products block lets your customers quickly compare the features of one product with another.

Product Reviews

Product reviews help build a sense of community, and are considered to be more credible than any advertising money can buy.
Tags

Tags help customers organize and remember the products that they have seen, offer quick navigation, and help search engines index your store.

Polls

The Poll block displays a series of polls or surveys that you can use to learn more about your customers.

Email a Friend

The Email a Friend link makes it easy for your customers to share links to products with their friends.
Email a Friend

The Email a Friend link makes it easy for your customers to share links to products with their friends. In the Magento demo store, the Email a Friend link appears as an envelope icon. The automated message that is sent from your store is referred to as **transactional email**\(^1\). The message template can be customized for your voice and brand. To prevent spamming, you can limit the number of recipients for each email, and the number of products that can be shared over a one-hour period.

\(^1\)An automated email message that is sent in response to a specific event or transaction.
To configure email to a friend:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Catalog, select Email to a Friend.

2. Click to expand the Email Templates section. Then, do the following:

   a. Set Enabled to “Yes.”
   b. Set Select Email Template to the template you want to use as the basis of the messages.
   c. If you want to require that only registered customers can send email to friends, set Allow for Guests to “No.”
   d. In the Max Recipients field, enter the maximum number of friends who can be on the distribution list for a single message.
   e. In the Max Products Sent in One Hour field, enter the maximum number of products that can be shared by a single user with friends over a one-hour time period.
   f. Set Limit Sending By to one of the following methods to identify the sender of emails:

      - IP Address (Recommended) Identifies the sender by the IP address of the computer that is used to send the emails.
      - Cookie (unsafe) Identifies the sender by browser cookie. This method is less effective because the sender can delete the cookie to bypass the limit.

3. When complete, click the Save Config button.
To send email to a friend:

1. On a catalog page, click the **Email a Friend** link. When prompted, either log into your customer account or register to open an account.

2. Complete the **Message** and enter the recipient **Name** and **Email Address**.

   To send the message to more than one person, click the **Add Another Recipient** link and complete the information for each person.

3. When ready to send the message, click the **Send Email** button.
Polls

Polls make it easy to learn about your customers’ opinions and preferences. The poll occupies a small amount of space and is usually placed in the right sidebar of a catalog page. Poll results appear immediately after a response is submitted. If you create multiple polls, a new poll appears each time the page is refreshed.

To create a poll:

1. On the Admin menu, select CMS > Polls.
2. In the upper-right corner of the Poll Manager, click the Add New Poll button.
3. In the Poll Information section, do the following:
   a. Enter the Poll Question.
   b. By default, Status is set to “Open.” If you later want to remove the poll from your store, set Status to “Closed.”
   c. Set Visible In to the store view where you want the poll to appear.
4. In the panel on the left, select Poll Answers. Then, for each answer, do the following:
a. Click the **Add New Answer** button. Then, do the following:

   ![Assigned Answers]

   **Assigned Answers**

   a. In the **Answer Title** field, enter the answer as you want it to appear in the poll.

   b. To weight an answer, enter a number in the **Votes Count** field. The number will increment each time a customer chooses the answer.

5. Click the **Save Poll** button to save your poll.

**To prevent multiple voting:**

You can protect the poll results by preventing people from voting multiple times from the same computer.

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left under General, select **Web**.

2. Click to expand the **Polls** section.

   ![Polls]

   **Polls**

3. Set **Disallow Voting in a Poll Multiple Times from Same IP Address** to “Yes.”

4. When complete, click the **Save Config** button.
To edit a poll:

1. From the Poll Manager list, click to open the poll in edit mode. Then, make the necessary changes.
   - To close the poll so that it no longer appears in the store, set **Status** to “Closed.”
   - To see the vote count for each answer, click **Poll Answers** in the panel on the left.

2. When complete, click the **Save Poll** button.

![Poll Answer Count](image-url)
Tags

Tags are one-word descriptors that are used as keywords for your catalog. Tags can be assigned to products by registered customers who are logged in, and also by guests. Tags help customers organize and remember the products that they have seen, offer quick navigation, and help search engines index your store. The tags that customers assign to a product appear on the Customers Tagged Product tab of the product record. The detail includes the tag, the customer name, and email address.

A tag cloud typically appears in the Popular tags block in the right sidebar of catalog pages. The size of the text indicates the popularity of the tag. Each product page has an “Tag this Product” section at the bottom of the page, where shoppers can enter their own tags. As an incentive, customers can earn reward points for tagging a product.
To add a tag from the store:

1. From any product page, scroll down to the Tag this Product section.

2. In the Add a Tag text box, type the tag you want to associate with the product.
   - To enter multiple tags, separate each with a blank space.
   - To enter a phrase, enclose the text in single quotes.

3. Click the Add Tags button.

   The tag will be submitted for review and published on the site when approved.
Products Tagged by Administrators

There’s no reason to wait for customers to tag products. The store administrator can apply new tags to products, and reuse existing tags.

To add a new tag:

1. On the Admin menu, select Catalog > Tags > All Tags.
2. In the upper-right corner, click the Add New Tag button. Then, do the following:
   a. Enter the Tag Name.
   b. Set Status to “Approved.”
   c. In the Base Popularity field, enter a numeric value to assign a weight to the tag. The number assigns a base value to the tag and increases its size in the tag cloud.
3. When complete, click the Save Tag button.

To apply an existing tag to specific products:

1. In the Manage Tags list, click to open the tag.
2. Click to expand the Products Tagged by Administrators section. Then, do the following:
   a. Click the Reset Filter button to display all product records.
   b. Select the checkbox of each product that you want to tag.
3. When complete, click the Save Tag button.

The products now appear in the list of Products Tagged by Administrators.
Moderating Tags

After a customer submits a product tag, an administrator must approve the tag before it becomes visible in the store. After a tag has been approved, it can be used for other products without further approval.

Changing the Status of Pending Tags

The remaining sections give you a snapshot of the tag activity, including which customers have used the tag, and products tagged by the store administrator and customers.

Customers Submitted this Tag

You can jump to a specific customer or product by clicking its row in the list.

Products Tagged by Customers

To approve multiple tags:

1. On the Admin menu, select Catalog > Tags > Pending Tags. Then in the list, click to open a pending tag.
2. In the list, select the checkbox of each tag that you want to approve.
3. Set the Actions control to “Change Status.” Then, set the Status control to “Approved.”
4. When complete, click the Submit button.
To manage a single tag:

1. On the Admin menu, select Catalog > Tags > Pending Tags. Then in the list, click to open a pending tag.

   ![Editing a Tag](image)

   *Editing a Tag*

2. If necessary, you can edit the text as needed. Then, do one of the following:
   
   * To approve and publish the pending tag, set **Status** to “Approved.”
   * To reject the tag, set **Status** to “Disapproved.”

3. When complete, click the **Save Tag** button.
Wishlists

A wishlist is a list of products that registered customers can share with friends or transfer to their shopping carts at a later date. When wishlists are enabled, the Add to Wishlist link appears on the category and product pages of your store. Depending on the theme, it might be a text link or a graphic image.

Add to Wishlist Links on Category Page
Wishlist Workflow

Shared wishlists are sent from a store email address, but the body of the message contains a personalized note from the customer. You can customize the email template that is used for the notification message when wishlists are shared, and choose the store contact that appears as the sender.

Each wishlist can be maintained in the customer’s account dashboard, where it can be updated, and used to add products to the shopping cart. Wishlists can be set to public or private, and shared with friends. Items can be transferred between the wishlist and shopping cart by the customer or from the Admin. When a product with multiple options is added to a wishlist, any options that have been selected by the customer are included in the wishlist item description. For example, if the customer adds the same pair of shoes, but in three different colors, each pair appears as a separate wishlist item. On the other hand, if the customer adds the same product to the wishlist multiple times, the product appears in the wishlist only once, but with an updated quantity that reflects the number of times the product was added. Customers can update their wishlists from their account dashboard. Merchants can also update a customer’s wishlist from the Admin.

Wishlist Reports

A customer Wishlist report includes the following information for each wishlist the customer has created:

- The date when a product was added
- The customer name
- The wishlist name and status (public or private)
- The product name and SKU
- Customer comments
- Quantity of the product in the Wishlist, quantity currently available in the store, and the difference between these two values.

You can choose to see a report for the entire website or for an individual store view. The scope is selected in the Show Report For field. The report can be exported to .csv or Excel .xml format.

To generate a wishlist report:

On the Admin menu, select Reports > Customers > Customers Wishlist.
**Gift Options**

At checkout, customers are presented with the available gift options during the Shipping Method step of the process. If the customer chooses to add gift options, two groups of checkboxes appear: Gift Options for Entire Order and Gift Options for Individual Items.

The Gift Options configuration determines if customers have the option to add a gift message for the complete order, and for individual items. The gift options must be configured first for the website, and can then be overridden at the product level.

---

**Gift Options During Checkout**

**To enable gift options:**

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left, under Sales, select **Sales**.

2. Click to expand the **Gift Options** section.

3. Set the following options according to your preference:
   - Allow Gift Messages on Order Level
   - Allow Gift Messages for Order Items

4. When complete, click the **Save Config** button.
Product Relationships

An easy way to promote products throughout your catalog is to establish relationships between products. The options available are: Up-sell products, Related products, and Cross-sell products.

Related Products

Related products are meant to be purchased in addition to the item the customer is viewing. They compliment, enhance, or add optional features to the product.

Up-sells

Up-sell products are items that are similar, but are perhaps of a higher-quality, more popular, or have a better profit margin than the item the customer is considering.

Cross-sells

Cross-sell products are offered on the shopping cart page as last-minute purchases before the checkout process begins.
Compare Products

The Compare Products block usually appears in the far right column, or sidebar of the category page, and can be used to generate a detailed, side-by-side comparison of two or more products. You can customize the report to include additional attributes or remove ones that you don’t want to include. Depending on the theme, the Add to Compare link can be represented by an icon or a link.
**To compare products:**

1. From your storefront, find the products that you want to compare, and click the **Add to Compare** link for each.

2. In the Compare Products block in the right sidebar, click the **Compare** button. The Compare Products report opens in a new window.

3. To print the report, click **Print This Page**.

4. To clear the Compare Products list, click the **Clear All** link.
Recently Viewed/Compared Products

The Recently Viewed and Recently Compared blocks usually appear in the right sidebar of a catalog page. The number of products listed in each block can be configured for each website, store, or store view.
To configure Recently Viewed/Compared Products:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Catalog, select Catalog.

2. Click to expand the Recently Viewed/Compared Products section. Then, do the following:

   ![Recently Viewed/Compared Products](image)

   **Recently Viewed/Compared Products**

   a. Set **Show for Current** to the website, store, or store view where the configuration applies.

   b. In the **Default Recently Viewed Products Count** field, enter the number of recently viewed products to appear in the list.

   c. In the **Default Recently Compared Products Count**, enter the number of recently compared products to appear in the list.

3. When complete, click the **Save Config** button.
Product Reviews

Product reviews help to build a sense of community, and are considered more credible than any advertising money can buy. In fact, some search engines give sites with product reviews a higher ranking than those without. For those who find your site by searching for a specific product, a product review is essentially the landing page of your store. Product reviews help people find your store, keep them engaged, and often lead to sales.

The configuration determines whether customers must open an account with your store to be write a product review, or can submit a review as a guest. Requiring reviewers to open an account with your store can improve the quality of reviews by preventing anonymous submissions.

Customers can write reviews for any product in your catalog. Reviews can be written from the product page by clicking the “Add Your Review” link. For products that haven't been reviewed, the link says, “Be the first to review this product.”

The number of stars indicates the satisfaction rating. Visitors can click the link to read the reviews and write their own. As an incentive, customers can receive reward points for submitting a review.

When a review is submitted, it is sent to the Admin for moderation. When approved, the review is published in your store.
To configure product reviews:

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under Catalog, select Catalog.

2. Click to expand the Product Reviews section.

3. Set Allow Guests to Write Reviews according to your preference.

4. When complete, click the Save Config button.
To moderate reviews:

1. On the Admin menu, select Catalog > Reviews and Ratings > Customer Reviews > Pending Reviews.

2. In the list, click a pending review to view the details, and edit if necessary.

3. To approve a pending review, change the Status from “Pending” to “Approved.” To reject a review, select “Not Approved.”

4. When complete, click the Save Review button.
Custom Ratings

By default, customers can rate the quality, price, and value of a product. In addition, you can add your own custom ratings that relate to your products and customers. The average rating for each product appears in catalog lists and on the product page.

To create your own ratings:

1. On the Admin menu, select **Catalog > Reviews and Ratings > Manage Ratings**.
2. In the upper-right corner, click the **Add New Rating** button.
3. In the Rating Title section, enter the **Default Value** for the new rating. Then, enter the translation for each language supported by your store.
4. In the Rating Visibility section, set **Visibility In** to the store view where the rating will be used. (Hold down the Ctrl key to select multiple options.)
5. In the **Sort Order** field, enter a number to determine the sequence that this rating appears in the list of ratings.
6. When complete, click the **Save Rating** button.
CHAPTER 22:

Newsletters

Publishing a regular newsletter is considered to be one of the most powerful and affordable marketing tools available. Magento Community Edition gives store administrators the ability to publish and distribute newsletters to customers who have registered to receive them, plus all the tools necessary to promote your newsletter, build and manage your list of subscribers, develop content, maintain an archive of back issues, and drive traffic to your store. Topics include:

- Newsletter Configuration
- Newsletter Templates
- Newsletter Queue
- Newsletter Reports
Newsletter Configuration

The first step in creating newsletters is to configure the newsletter settings for your site. You can require customers to confirm the registration by clicking a confirmation link sent by email. This technique is called double opt-in\(^1\), because customers must confirm twice that they want to receive a newsletter. This method reduces the number of customers that might otherwise consider your newsletter as spam.

To configure subscription options:

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left under Customers, select **Newsletter**.
2. Click to expand the **Subscription Options** section. Then, do the following:

   
   ![Subscription Options]

   **Subscription Options**

   a. Confirm the email templates and senders of the following email messages sent to subscribers:
   
      - Success email
      - Confirmation email
      - Unsubscription email
   
   b. To require people to double-opt in to confirm their subscription, set **Need to Confirm** to “Yes.”
   
   c. To allow people who do not have an account with your store to subscribe to the newsletter, set **Allow Guest Subscriptions** to “Yes.”
   
   d. When complete, click the **Save Config** button.

---

\(^1\)The process for subscribing email recipients by requiring them to take a secondary step to confirm that they want to receive emails.
Newsletter Templates

Before sending a newsletter, create a newsletter template. You can create and save as many of these as required for any situation, from an annual holiday newsletter to a weekly product update.

To create a newsletter template:

1. On the Admin menu, select Newsletter > Newsletter Templates. The page lists the available newsletter templates. You can edit an existing template or create a new one.

2. To add a new template, click the Add New Template button. Then, do the following:
   
   a. In the Template Name field, specify a unique and indicative name for this template. This value is not visible for customers.
   
   b. In the Template Subject field, specify the subject of the email to be sent to your customers.
   
   c. In the Sender Name and Sender Email fields, specify the name and email of the sender of the email to be sent to your customers.
   
   d. In the Template Content field, use the WYSIWYG editor to compose the body of the email. Note that this field is pre-filled with tags showing an unsubscribe link in the email. We recommend that you do not remove this link so that all emails that are sent enable your customers to unsubscribe from the newsletter.
   
   e. Click Preview Template, to display the content with the formatting as it will be viewed by your subscribers.

3. When complete, click the Save Template button.

   After you have saved a template, a Save As button appears when you edit this template. You can use the Save As button, so you can make changes and save it as a new template, without affecting the original. This can save you time because you will not need to re-enter all the
template information in order to create a new template. If you already have an existing template that is similar to the new template, simply edit the fields that you require, and then use the Save As button to create a new template.

**Newsletter Queue**

A newsletter that has many recipients must be sent in stages. The process of sending the newsletter is managed by a queue. After you start the queue, Magento sends the emails in packs. To ensure delivery of your newsletters, it is recommended that you integrate your Magento installation with a third-party newsletter provider. These services are “white listed” by email service providers. Look for newsletter providers in Magento Connect.

**To send your newsletter using a queue:**

1. On the Admin menu, select **Newsletter > Newsletter Templates**.
2. Set the **Actions** control to the relevant template. Then, select **Queue Newsletter**.
3. In the **Queue Date Start** field, specify when the newsletter will start being sent.
4. In the **Subscribers From** field, select one or more store views whose customers this newsletter will be sent to.
5. Review the template and parameters and then click the **Save Newsletter** button to schedule sending the newsletter.
Newsletter Reports

The following newsletter reports are available for your store. To learn more, see Reports.

Newsletter Queue

Shows the newsletter queues that have been defined and indicates their progress in sending emails.

Newsletter Subscribers

Shows a list of customers that have subscribed to your newsletter. It also enables you to unsubscribe these customers manually.

Newsletter Problem Reports

Shows a list of errors that have occurred while sending the email. This Report enables you to remove the incorrect emails from the subscribers list.
CHAPTER 23:

Sales Channels

Publishing your catalog through multiple channels is an effective way to widen your distribution without much effort. You can start by syndicating your content with RSS feeds, and then expand by sending your catalog data to shopping aggregators and marketplaces. Topics include:

- Setting Up RSS Feeds
- Social Marketing
- Adding Facebook Plugins
Setting Up RSS Feeds

RSS (Really Simple Syndication) is an XML-based data format that is used to distribute information online. Your customers can subscribe to your RSS feeds and be notified of new products and promotions. RSS Feeds can also be used to publish your product information to shopping aggregation sites, and can also be included in newsletters.

When RSS feeds are enabled, any additions to products, specials, categories, and coupons in your store are automatically sent to the subscribers of each feed. A link to all the RSS feeds that you publish is in the footer of your store.

The software that is used to read an RSS feed is called a **feed reader**\(^1\), and allows people to subscribe to headlines, blogs, podcasts, and much more. Google Reader is one of the many feed readers which are available online for free.

**To set up RSS feeds for your store:**

1. From the Admin menu, select **System > Configuration**.
2. In the upper-right corner, set **Current Configuration Scope** to the store view where you want the feeds to be available.
3. In the panel on the left, under Catalog, select **RSS Feeds**.
4. In the Rss Config section, set **Enable RSS** to “Enable.” Then, in each section below, set the feeds that you want to activate to “Enable.”
   a. In the Wishlist section, set **Enable RSS** to “Enable.”
   b. In the Catalog section, set any, or all, of the following feeds to “Enable.”

---

\(^1\)Software that is used to read syndicated content from RSS feeds.
CHAPTER 23: Sales Channels

Setting Up RSS Feeds

- New Products
- Special Products
- Coupons/Discounts
- Tags Products
- Top Level Category
- Top Level Category

![Catalog](image)

**c.** In the Order section, set **Customer Order Status Notification** to “Enable.”

5. When complete, click the **Save Config** button.

### Types of RSS Feeds

<table>
<thead>
<tr>
<th>RSS FEED</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wishlist</td>
<td>When enabled, an RSS feed link appears at the top of customer wishlist pages. Additionally, the wishlist sharing page includes a checkbox that lets you include a link to the feed from shared wishlists.</td>
</tr>
<tr>
<td>New Products</td>
<td>Publishes notification of new products added to the catalog.</td>
</tr>
<tr>
<td>Special Products</td>
<td>Publishes notification of any products with special pricing.</td>
</tr>
<tr>
<td>Coupons / Discounts</td>
<td>Publishes notification of any special coupons or discounts that are available in the store.</td>
</tr>
<tr>
<td>Tags Products</td>
<td>Publishes notification of new product tags.</td>
</tr>
<tr>
<td>Top Level Category</td>
<td>Publishes notification of any change to the top-level category structure of your catalog, which is reflected in the main menu.</td>
</tr>
<tr>
<td>Customer Order Status</td>
<td>Gives customers the ability to track their order status by RSS feed. When enabled, an RSS feed link appears on the order.</td>
</tr>
</tbody>
</table>
Social Marketing

There are many social marketing extensions that can be added to your store. To learn more, see: Magento Connect.
Adding Facebook Plugins

Facebook has a number of social plugins that can easily be added to your store. The following example shows how to add a Like Button to your store.

Step 1: Get the Button Code

1. On the Facebook site, go to the button setup page.

2. In the URL to Like field, enter the URL of the page in your store that you want people to Like. For example, enter the URL of your store’s home page. Then, do the following:
   a. Choose the Layout for the button.
   b. Enter the Width in pixels that is available on your site for the button and any associated text message.
   c. Set Action Type to one of the following:
      - Like
      - Recommend

3. Click the Get Code button to copy the generated code to the clipboard.
Step 2: Create a Static Block

1. Return to your store. On the Admin menu, select CMS > Static Blocks.

2. In the upper-right corner, click the Add New Block button. Then, do the following:
   a. Enter a descriptive Block Title. For example: Facebook Like Button.
   b. Assign a unique Identifier to the block, using all lowercase characters, with underscores instead of spaces. For example: facebook_like_button.
   c. Select the Store View(s) where you want the block to appear.
   d. Set Status to “Enabled.”
   e. Paste the snippet of code that you copied from Facebook into the Content box.

3. When complete, click the Save Block button.

Step 3: Place the Block

1. On the Admin menu, select CMS > Widgets.

2. In the upper-right corner, click the Add New Widget Instance button.

3. In the Settings box, do the following:
a. Set Type to “CMS Static Block.”

b. Set Design Package/Theme to your current theme.

c. Click the Continue button.

4. In the Frontend Properties box, do the following:

a. Enter the Widget Instance Title to appear in the list of widgets that are available in your store. For example: Facebook Like Button.

b. If you want the button to appear in all views of your store, set Assign to Store Views to “All Store Views.”

c. You can leave Sort Order blank for now.

![Frontend Properties](image1)

5. In the Layout Updates section, click the Add Layout Update button. Then, do the following:

![Layout Updates](image2)

a. Set Display On to “All Pages.”

b. Set Block Reference to the place on the page where you want the button to appear. For a diagram of block references, see: Standard Block Layout.

In general, either the header or footer are good places for a Like button because it will appear in the same place on every page of the store. Depending on your store, you might need to update the Sort Order field to position the button in relation to other content that is assigned to the same place on the page. You can try several settings to see what works best.

c. Click Save and Continue Edit.
6. In the panel on the left, select **Widget Options**. Then, do the following:
   a. Click the **Select Block** button.
   
   ![Select Block](image)

   **Select Block**

   b. In the list, find the block that you created for the Facebook Like button, and select the block.

   c. When complete, click **Save**.

7. When prompted, follow the instructions in the message at the top of the workspace to update the index and page cache.

**Step 4: Verify the Location in Your Store**

Return to your storefront to make sure that the Facebook Like button is in the right location. If you want to try a different place, reopen the widget and change the block reference.
CHAPTER 24: Google Tools

Your store includes a number of tools to help optimize your content, analyze your traffic, and connect your catalog to shopping aggregators and marketplaces.

- Google Merchant Center
- Google Sitemap
- Google Universal Analytics

*Google Merchant Center Login*
Google Merchant Center

Google Merchant Center helps you manage Google’s shopping tools and services from a single dashboard. In addition to the following services, you can also link Google Analytics to your Merchant Center account.

Google Shopping

Google Shopping is a commercial service that helps shoppers find products on Google, compare products, and connect with merchants.

Product Listing Ads

Your product listings can include rich information, such as product image, price, and merchant name. Whenever a user enters a search query on Google.com that is relevant to an item you are trying to sell, Google will automatically show the most relevant products along with the associated image, price, and product name.

Process Overview:
Step 1: Open a Google Merchant Account
Step 2: Verify Your Website URL
Step 3: Claim Your Website URL

Step 1: Open a Google Merchant Account

1. Visit the Google Merchant Center, and do one of the following:
   - If you have a Google account, enter your **Email address** and **password**, and click the **Sign In** button.
   - Click the **Sign Up** button, and follow the instructions to create an account.
2. In the panel on the left, click to expand **Settings**, and select **General**.

3. Enter your **Store name** and **Description**.

4. Enter the full **Website URL** for your store. Depending on your domain, the URL might be formatted as one of the following:

   - http://mystore.com
   - http://www.mystore.com

   At this time, your Website URL is unclaimed and unverified.

5. Complete the remaining General settings information, and **Save Changes**.
Step 2: Verify Your Website URL

In this step, you will use Google Webmaster Tools to verify that you have the right to upload product listings from your store.

1. On a new browser tab, go to Google Webmaster Tools. Then, do the following:
   a. Click the Add a Site button. When prompted, enter the URL of your store, and click Continue.
   b. When prompted to verify that you are the owner of the site, click the Alternate methods tab.
   c. Select the HTML tag method, and press Ctrl + C to copy the meta tag code to the clipboard.

2. Return to your store's Admin, and select System > Configuration. Then in the panel on the left under General, select Design.

3. Click to expand the HTML Head section. Then, do the following:
a. Scroll down to the **Miscellaneous Scripts** box and press **Ctrl + V** to paste the verification code from the clipboard.

![HTML Head](image)

**HTML Head**

b. When complete, click the **Save Config** button.

4. Return to **Google Webmaster Tools**, and click the **Verify** button. When prompted, click **Continue**. Your site is now verified.

![Google Webmaster Tools - Site Verified](image)
Step 3: Claim Your Website URL

In this final step, you will establish the connection between your site and your Google Merchant account.

1. Return to the Google Merchant Center. The General Settings now show that your site is verified, but not claimed.

![Google Merchant Center- Claim this URL](image)

2. Click the Claim this URL link. Your Website URL is now both verified and claimed.

![Website URL Verified and Claimed](image)

Now that your site is verified, you can submit a sitemap to Google. You can also set up a Google Analytics account, and link it to your Merchant Center Dashboard.
Google Sitemap

Google Sitemap improves the way your store is indexed by their search engine, and is specifically designed to find pages which might otherwise be overlooked. As with the standard Magento sitemap, Google Sitemap is an index of all the pages on your site. However, unlike the Magento sitemap, the Google Sitemap is not visible to customers.

Process Overview:
Step 1: Remove any “robots.txt” Restrictions
Step 2: Generate the Sitemap
Step 3: Submit Your Sitemap to Google
Step 4: Restore Previous “robots.txt” Restrictions

Step 1: Remove any "robots.txt" Restrictions

When first setting up your Google Sitemap, you must provide full access for Google to index your site. If you have a robots.txt file, make sure that it includes the following instruction:

```
User-agent:*  
Disallow:  
```

After your sitemap has been successfully submitted to Google, you can restore any instructions to exclude certain locations of your site. If you have not yet set up a robots.txt file, you can do so after you finish the sitemap.

Step 2: Generate the Sitemap

1. On the Admin menu, select **Catalog > Google Sitemap**.
2. In the upper-right corner, click the **Add Sitemap** button. Then, do the following:
   a. In the **Filename** field, enter: “sitemap.xml”
   b. Enter the path to a writable location on your server for the sitemap.
      - To put the sitemap in a folder, enter the path to the folder: `/sitemaps`
      - To put the sitemap at the base path of your store, enter a forward slash: `/`
   c. Set **Store View** to the view where the sitemap will be used.
3. Click the **Save & Generate** button to create the sitemap.

The sitemap appears in the list, with a link to sitemap.xml file. From here, you can do the following:

- To view the sitemap, click the hyperlink in the **Link for Google** column. This is the link that you will later submit to Google.
- To update the sitemap, click the **Generate** link.

**Step 3: Submit Your Sitemap to Google**

1. Go to **Google Webmaster Tools** and do one of the following:
   - Log in to your existing account.
   - Create a new account, and log in.
2. Click the **Add a Site** button.

3. When prompted to enter your store address, enter the full URL of your store, such as: http://www.mystore.com

   Then, click the **Continue** button.
4. To verify that you are the owner of the site, click the Alternate Methods tab. Then, choose one of the following methods:
   - Add a DNS record to your domain’s configuration
   - Add a meta tag to your site’s home page

To verify your site with a meta tag, do the following:

a. Open two tabs on your browser; one for Google Webmaster Central, and the other that is logged in to the Admin of your store.

b. Follow the instructions on Webmaster Central to copy the full text of the Google site verification meta tag.

c. On the Admin menu, select System > Configuration. In the Configuration panel on the left, under General, click Design.

d. In the HTML Head section, scroll down to Miscellaneous Scripts and paste the site verification meta tag. Then, click the Save Config button.

e. Return to Google Webmaster Central, and click Verify.

5. After your site is verified and appears in your Google dashboard, do the following:

a. Click the name of your store. Then, click the Sitemaps button.

b. In the upper-right corner, click the Add/Test Sitemap button.

6. Return to your store Admin, and copy the path to your Google sitemap. If necessary, log back in and do the following:
a. Go to Catalog > Google Sitemap.

b. In the Link for Google column, right-click the link to your sitemap. Then on the context menu, click Copy Shortcut.

c. Open a text editor and paste the link. Then, copy the part of the link that comes after the “dot com.” It looks like this:

/media/s4d71280645299/sitemaps/sitemap.xml

7. Return to Google Webmaster Tools and paste the text into the box to complete the address of your sitemap. Then, click the Submit Sitemap button.

8. Make sure that the link to your sitemap is working correctly, and that your Google dashboard shows the number of pages indexed.

Step 4: Restore Previous "robots.txt" Restrictions

If you changed your robots.txt file to make it fully accessible, you can now restore the previous instructions to disallow access to certain areas of your site.
Google Sitemap Configuration

Your Google sitemap should be updated as frequently as the content on your site changes, which could be daily, weekly, or monthly. The configuration lets you set the frequency and priority for each type of content separately.

**Step 1: Complete the Generation Settings**

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left under Catalog, select **Google Sitemap**.

2. Click to expand the **Generation Settings** section.

3. To activate Google Sitemap, set **Enabled** to “Yes.” Then, do the following:
   a. Set **Start Time** to the hour, minute and second that you want the sitemap to be updated.
   b. Set **Frequency** to one of the following:
      - Daily
      - Weekly
      - Monthly
   c. In the **Error Email Recipient** field, enter the email address of the person who is to receive notification if an error occurs during a sitemap update.
   d. Set **Error Email Sender** to the store contact who appears as the sender of the error notification.
   e. Set **Error Email Template** to the template used for the error notification.
Step 2: Set the Frequency and Priority of Content Updates

1. Click to expand the Categories Options section. Then, do the following:
   a. Set Frequency to one of the following:
      - Always
      - Hourly
      - Daily
      - Weekly
      - Monthly
      - Yearly
      - Never
   b. In the Priority field, enter a value between 0.0 and 1.0. Zero has the lowest priority.

2. Click to expand the Products Options section. Then, complete the Frequency and Priority settings as needed.

3. Click to expand the CMS Pages Options section. Then, complete the Frequency and Priority settings as needed.

4. When complete, click the Save Config button.
Google Universal Analytics

Google Universal Analytics gives you the ability to define additional custom dimensions and metrics for tracking. Universal Analytics supports offline and mobile app interactions, and includes access to ongoing updates.

Process Overview:
Step 1: Sign Up or Upgrade to Google Universal Analytics
Step 2: Complete the Magento Configuration

Step 1: Sign Up or Upgrade to Google Universal Analytics

Do one of the following:

- Sign up for a new Google Universal Analytics account.
- Upgrade your classic Google Analytics account to Universal Analytics.

During the first part of the upgrade process, your existing account properties and tracking code are converted to the Universal Analytics format, but your data and settings are preserved. In the second part of the process, your tracking code is converted to the Universal Analytics format.

Before beginning the upgrade, visit the Universal Analytics Upgrade Center, and read the Upgrade Guide. Take note of the Important Considerations section at the bottom of the page.
Step 2: Complete the Magento Configuration

1. Return to your store, and log in to the Admin. Then on the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Google API.

3. Click to expand the Google Analytics section, and do the following:
   a. Set Enable to “Yes.”
   b. Set Account type to “Universal Analytics.” Then, enter your Universal Analytics Account Number.
   c. To anonymize part of your visitor's IP address before it is sent to Google, set Enable IP Anonymization to “Yes.”

According to Google, anonymizing IP addresses can reduce the accuracy of geographic data in the Analytics report.

4. When complete, click the Save Config button.
Search & SEO
Search & SEO

The focus of this section is how to attract new shoppers, and help them find what they want. We’ll take a look at the specific search capabilities of your store, what you can learn from customer searches, and how to make your products easy to find. Finally, you’ll learn best practices and techniques that you can use to bring more traffic to your store.

Storefront Search Tools
- Quick Search
- Advanced Search
- Search Results
- Popular Search Terms
- Search Configuration

Managing Search Terms
- Adding Search Terms

SEO Best Practices
- Meta Data
- Sitemap
- Catalog URLs
  - URL Configuration
- Dynamic Media URLs
- Canonical Meta Tag

Managing URL Rewrites
- Configuring URL Rewrites
- Automatic Product Redirects
- Creating URL Rewrites
  - Product Rewrite
  - Category Rewrite
  - Custom Rewrite
CHAPTER 25:

Storefront Search Tools

Research shows that people who use search are more likely to make a purchase than those who rely on navigation alone. In fact, according to some studies, people who use search are nearly twice as likely to make a purchase.

Magento Community Edition has a powerful search engine that you can use as is, or enhance to make even more effective. In this chapter, we will examine the search tools that are available to your customers while shopping in your store. In addition, Magento’s layered navigation gives your customers the ability to filter product options by price, manufacturer, or any other criteria to reduce the time it takes to make a purchase. Topics include:

- Quick Search
- Advanced Search
- Search Results
- Popular Search Terms
- Search Configuration
Quick Search

The Quick Search box in the upper-right corner helps visitors find products in your catalog. The search text can be the full or partial product name, or any other word or phrase that describes the product.

To do a quick search:

1. Type the first few letters of what you are looking for into the search box.
2. Press either the Enter key or the button to the right of the search box to retrieve a list of matching products from the catalog.
Advanced Search

Advanced Search lets shoppers search through your catalog by entering values into a form. Because the form contains multiple fields, a single search can include several parameters. The result of the search is a list of the products that match the search criteria. A link to Advanced Search is in the footer of your store.

Each field in the form corresponds to an attribute from your product catalog. You can determine which fields to include by setting the attribute frontend properties to “Include in Advanced Search.” As a best practice, you should include only the fields that your customers are most likely to use to find a product, because too many can slow down the search.

To use advanced search:

1. In the footer of the store, click the Advanced Search link.
2. In the Search Settings form, enter any value you want to match in as many fields as necessary. You can find records based on a full or partial match.
3. Click the Search button at the bottom to display the results.
4. If you don’t see what you are looking for in the search results, click **Modify your search** and try another combination of values.
Search Results

The Search Results list includes all products that match the search parameters entered through the Quick Search box or the Advanced Search form. Any page in the catalog that lists products has essentially the same controls. The only difference is that one is the result of a search query, and the other is the result of navigation.

Search Results with Pagination Controls

The results can be formatted as either a grid or list, and the records can be sorted by a selection of attributes. Controls can be used to sort the list and change the format from a list to a grid. Page links appear when there are more products than can fit on the page, and allow you to move from one page to the next. Depending on the layout, the left column of the page might also include layered navigation under the “Shop By” heading, with products listed by category and attribute.
Popular Search Terms

The Search Terms link in the footer of your store displays the search terms that have been used by visitors to your store, and ranks them by popularity. Search terms appear in a “tag cloud” format, where the size of the text indicates the popularity of the term.

By default, Popular Search Terms is enabled as a search engine optimization tool, but has no direct connection to the catalog search process. Because the Search Terms page is indexed by search engines, any terms included on the page will help improve your search engine ranking and the visibility of your store.
To configure Popular Search Terms:

1. On the Admin menu, select **System > Configuration**. Then in the Configuration panel on the left under Catalog, select **Catalog**.

2. Click to expand the **Search Engine Optimizations** section.

3. Set **Popular Search Terms** to “Enable.”

4. When complete, click the **Save Config** button.
Search Configuration

By adjusting the Catalog Search configuration, you can control the behavior of the search operations and determine the size of valid query text, and the display of search recommendations.

To configure catalog search:

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Catalog, select Catalog. Then, click to expand the Catalog Search section.

3. To limit the length and word count of search query text, do the following:
   a. Set Minimal Query Length to the minimum number of characters that can be submitted in a query.
   b. Set Maximum Query Length to the maximum number of characters that can be submitted in a query.
   c. Set Maximum Query Words Count to the maximum number of words that can be submitted in a query.

4. Set Search Type to one of the following:
   - Like: Performs a search based on individual keywords.
   - Fulltext: Performs a search based on the full text of each attribute and ranks each by relevance.
   - Combine (Like and Fulltext): This combination of Like and Fulltext matches by keyword, but takes into consideration its relevance.

5. To limit the number of records that can be used with layered navigation, enter the maximum number allowed in the Apply Layered Navigation if Search Results are Less Than field. To allow any number of records, enter zero (0).

6. When complete, click the Save Config button.
CHAPTER 26:

Managing Search Terms

You can learn what your customers are looking for by examining the search terms they use to find products in your store. If enough people are looking for a product that you don’t carry, perhaps it’s time to add it to your catalog. Meanwhile, rather than have them leave them empty handed, why not redirect them to another product in your catalog? Here are a few ways you can leverage customer search terms:

Landing Page

The landing page for a search term can be a content page, a category page, a product detail page, or even a page on a different site.

Synonyms

One way to improve the effectiveness of catalog search is to include different terms that people may use to describe the same item. You don’t want to lose a sale just because someone is looking for a “sofa,” and your product is listed as a “couch.” You can capture a broader range of search terms by entering the words, “sofa,” “davenport,” and “loveseat” as synonyms for “couch,” and direct them to the same landing page.

Misspelled Words

Use search terms to capture common misspellings and redirect them to the appropriate page. For example, if you sell wrought iron patio furniture, you know that many people misspell the term as “rod iron,” or even “rot iron.” You can enter each misspelled word as a search term, and make them synonyms for “wrought iron.” Even though the word is misspelled, the search will be directed to the page for “wrought iron.”
Adding Search Terms

As you learn new words that people use to search for products in your catalog, you can add them to your search terms list to direct people to the closely matching products in your catalog.

To add a new search term:

1. On the Admin menu, select Catalog > Search Terms.
2. Click the Add New Search Term button. Then, do the following:
   a. In the General Information section, in the Search Query box, type the word or phrase that you want to add as a new search term.
   b. Select the Store where the search term will be used. If your store is available in multiple languages, select the applicable store view.
   c. If this term is a synonym for another search term, enter the other term in the Synonym For field. Any search for the synonym will be automatically redirected to the page for the other term.
To edit a search term:

1. On the Admin menu, select Catalog > Search Terms.
2. Click the row of any record to open the search term in edit mode.
3. Make the necessary changes.
4. When complete, click the Save Search button.

To delete a search term:

1. In the list, select the checkbox of the term to be deleted.
2. In the upper-right corner of the list, set the Actions control to “Delete.”
3. When complete, click the Submit button.
CHAPTER 27:

SEO Best Practices

Search engine optimization is the practice of fine-tuning the content and presentation of a site to improve the way the pages are indexed by search engines. Magento Community Edition includes a number of features that support your ongoing effort to improve the indexing of your site.

Commerce Resources

See the latest Magento eBooks to gain access to expert insight and online business resources to help develop and improve your store.
Meta Data

Your store is loaded with places where you can enter keyword-rich meta data to improve the way search engines index your site. While setting up your store, you might enter preliminary meta data, with the intention of finishing it later. Over time, you can fine-tune the meta data to target the buying patterns and preferences of your customers.

**Meta Title**

The meta title appears in the title bar and tab of your browser, and search results listings. The meta title should be unique to the page, and less than 70 characters in length.

**Meta Keywords**

Although some search engines ignore meta keywords, others continue to use them. The current best practice is to incorporate high-value keywords in the meta title and meta description.

**Meta Description**

Meta descriptions provide a brief overview of the page for search results listings. Ideally, a meta description should be between 150-160 characters in length, although the field will accept up to 255 characters.
Sitemap

The default Magento sitemap has links to every product and category in your store, and can help improve the way your products are indexed by some search engines. Like a table of contents, the sitemap also gives visitors a quick overview of the organization of your catalog. To switch between the category and product lists, click the link on the right. By default, the footer of your store includes a link to the sitemap.

Sitemap

The sitemap can be formatted as a nested, tree-like structure, or as a simple list. The number of lines included per page, and the use of indentation is set in your system configuration.

Because the Magento sitemap does not include CMS pages, it is not a complete index to the content on your site. In addition to the default sitemap, it is recommended that you also generate a Google sitemap that can be used for reference when your site is indexed by Google.
To set up the sitemap:

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left under Catalog, select **Catalog**.

2. Click to expand the **Sitemap** section. Then, set the following options according to your preference:
   - Use Tree Like Category Sitemap
   - Minimum Lines per Page

3. Scroll down the page and click to expand the **Search Engine Optimizations** section. Then, set **Autogenerated Site Map** to “Enable.”

4. When complete, click the **Save Config** button.
Catalog URLs

The URLs you assign to products and categories play a major role in determining how well your site is indexed by search engines. Before you start building your catalog is an ideal time to consider the available options.

Dynamic URL

A dynamic URL is created “on the fly,” and might include a query string with variables for the product ID, sort order, and the page where the request was made. When a customer searches for a product in your store, the resulting URL might look something like this:

http://mystore.com/catalogsearch/result/?q=tee+shirt

Static URL

A static URL is a fixed address for a specific page. A static URL can be displayed in a search-engine friendly format, or one that references products and categories by ID. Search-engine friendly URLs include words that people might use to look for a product, and are created by enabling Web Server Rewrites.

http://mystore.com/accessories/eyewear.html

URL Key

The URL key is the part of a static URL that describes the product or category. When you create a product or category, an initial URL key is automatically generated based on the name. The URL key should consist of lowercase characters with hyphens to separate words. A well-designed, “search engine friendly” URL key might include the product name and key words to improve the way it is indexed by search engines. The URL key can be configured to create an automatic redirect if the URL key is changed.

Store Code

The store code can be included in the URL. However, it might cause problems if third-party services, such as PayPal, are configured to work with a URL that does not include the code. By default, the store code is not included in URLs.
HTML Suffix

Your catalog can be configured to either include or exclude the .html suffix as part of category and product URLs. There are various reasons why people might choose to use or to omit the suffix. Some believe that the suffix no longer serves any useful purpose, and that pages without a suffix are indexed more effectively by search engines. However, your company might have a standardized format for URLs, that requires a suffix.

The most important thing to understand is that the suffix is controlled by your system configuration. Never type the suffix directly into the URL key of a category or product. (Doing so will result in a double suffix at the end of the URL.) Whether you decide to use the suffix or not, be consistent and use the same setting for all your product and category pages. Here are examples of a category URL with, and without, the suffix.

http://mystore.com/accessories/eyewear.html
http://mystore.com/accessories/eyewear/retro-chic-eyeglasses

Category Path

You can configure the URL to either include or exclude the category path. By default, the category path is included in all category and product pages. The following examples show the same product URL with, and without, the category path.

http://mystore.com/accessories/eyewear/retro-chic-eyeglasses
http://mystore.com/retro-chic-eyeglasses

To prevent search engines from indexing multiple URLs that lead to the same content, you can exclude the category path from the URL. Another method is to use a canonical meta tag to let search engines know which URLs to index and which to ignore.
Catalog URL Configuration

Catalog URLs play a major role in how well your store is indexed by search engines. All of the following options use web server rewrites to change the format of the URL.

**URL Suffix**
Determines if a suffix, such as “html” or “htm,” is used for category URLs. Do not enter a period before the suffix, because it is applied automatically.

**Store Code**
Inserts the Store Code of the current view in the URL immediately after the magento root.

**Category Path**
Determines if category paths are included in product URLs. However, doing so can impact SEO by creating multiple URLs that give the appearance of duplicate content.

To configure the URL suffix:

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left under Catalog, select **Catalog**.
2. Click to expand the **Search Engine Optimizations** section. Then, do the following:
   - **Set Product URL Suffix** to “html” or “htm.” Do not include a period before the suffix.
   - **Set Category URL Suffix** to “html” or “htm.” Do not include a period before the suffix.
   - Set the category path to your preference. To omit the category path from product URLs, set **Use Categories Path for Product URLs** to “No.”
3. When complete, click the **Save Config** button.
4. After the setting is saved, you will be prompted to refresh the cache. Click the **Cache Management** link in the message at the top of the workspace. Then, follow the instructions to refresh the cache.
To include the store code in URLs:

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left under General, select **Web**.

2. Click to expand the **URL Options** section.

3. Set **Add Store Code** to your preference.

   **URL with Store Code**
   

   **URL without Store Code**
   

4. When complete, click the **Save Config** button.

5. After the setting is saved, you will be prompted to refresh the cache. Click the **Cache Management** link in the message at the top of the workspace. Then, follow the instructions to refresh the cache.

To include the category path in URLs:

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left under Catalog, select **Catalog**.

2. Click to expand the **Search Engine Optimizations** section.
3. Set **Use Categories Path for Product URLs** to “Yes.”

**URL with Category Path**

[http://mystore.com/furniture/living-room/microfiber-sofa-sleeper](http://mystore.com/furniture/living-room/microfiber-sofa-sleeper)

4. When complete, click the **Save Config** button.

5. After the setting is saved, you will be prompted to refresh the cache. Click the **Cache Management** link in the message at the top of the workspace. Then, follow the instructions to refresh the cache.
Dynamic Media URLs

A dynamic media URL is a relative reference to an image or other media asset. When enabled, dynamic media URLs can be used to link directly to assets on your server, or even on a CDN. As with all markup tags, the code is enclosed in double curly braces. The format of a dynamic media URL looks like this:

```{{media url="path/to/image.jpg"}}```

If you prefer to use a static URL, you can change the configuration setting. If dynamic media URLs are included in your catalog, but later the setting is disabled, each reference in your catalog will appear as a broken link. However, the links can be restored by again enabling dynamic media URLs. Using dynamic media URLs can enhance your catalog, but can also impact the performance of catalog search.

**To configure dynamic media URLs:**

1. On the Admin menu, select **System > Configuration**. Then in the Configuration panel on the left under Catalog, select **Catalog**.
2. Click to expand the **Frontend** section.
3. Then, set **Allow Dynamic Media URLs in Products and Categories** to either “Yes” or “No.”
4. Click the **Save Config** button to save the setting.
To use static URLs by default for media files:

By default, images inserted into the catalog from media storage have relative, dynamic URLs. If you prefer to use a static URL, you can change the configuration setting.

1. On the Admin menu, select System > Configuration. Then in the Configuration panel on the left under General, select Content Management.

2. Click to expand the WYSIWYG Options section.

3. Set Use Static URLs for Media Content in WYSIWYG for Catalog to “Yes.”

4. When complete, click the Save Config button.
Canonical Meta Tag

Some search engines penalize websites that have multiple URLs that point to the same content. The canonical meta tag tells search engines which page to index when multiple URLs have identical or very similar content. Using the canonical meta tag can improve your site ranking and aggregate pageviews. The canonical meta tag is placed in the `<head>` block of a product or category page. It provides a link to your preferred URL, so search engines will give it greater weight.

**Example 1: Category Path Creates Duplicate URLs**

For example, if your catalog is configured to include the category path in product URLs, your store will generate multiple URLs that point to the same product page.

```
http://mystore.com/furniture/living-room/microfiber-sofa-sleeper
http://mystore.com/microfiber-sofa-sleeper
```

**Example 2: Category Page Full URL**

When canonical meta tags for categories are enabled, the category page of your store includes a canonical URL to the full category URL:

```
http://mystore.com/furniture/living-room/microfiber-sofa-sleeper
```

**Example 3: Product Page Full URL**

When canonical meta tags for products are enabled, the product page includes a canonical URL to the domain-name/product-url-key because product URL keys are globally unique.

```
http://mystore.com/microfiber-sofa-sleeper
```

If you also include the category path in product URLs, the canonical URL remains domain-name/product-url-key. However, the product can also be accessed using its full URL, which includes the category. For example, if the product URL key is microfiber-sofa-sleeper and is assigned to the Furniture > Living-Room category, the product can be accessed using either URL.

You can avoid being penalized by search engines by omitting the category from the URL, or by using the canonical meta tag to direct search engines to index either by product or category. As a best practice, it is recommended that you enable canonical meta tags for both categories and products.
To enable the canonical meta tag:

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left under Catalog, select **Catalog**.

2. Click to expand the **Search Engine Optimizations** section.

3. If want search engines to index only pages that have a full category path, do the following:
   a. Set **Use Canonical Link Meta Tag for Categories** to “Yes.”
   b. Set **Use Canonical Link Meta Tag for Products** to “No.”

4. If you want search engines to index only product pages, do the following:
   a. Set **Use Canonical Link Meta Tag for Products** to “Yes.”
   b. Set **Use Canonical Link Meta Tag for Categories** to “No.”

5. When complete, click the **Save Config** button.
CHAPTER 28:  
Managing URL Rewrites

The URL Rewrite tool lets you change any URL that is associated with a product, category, or CMS page. When the rewrite goes into effect, any links that point to the previous URL are redirected to the new address.

The terms rewrite and redirect are often used interchangeably, but refer to slightly different processes. A URL rewrite changes the way a URL appears in the browser. A URL redirect, on the other hand, updates the URL that is stored on the server. A URL redirect can be either temporary or permanent. Your store uses URL rewrites and redirects to make it easy for you to create search engine friendly URLs and to preserve existing links.

Create Permanent Redirect for Old URL
Configuring URL Rewrites

URL rewrites make it possible to make “search engine friendly” URLs by adjusting the format and content. Initially, all Magento URLs include a file called “index.php” that resides in the root folder. By default, the file name appears in the URL just after the name of the root folder. When Web Server Rewrites are enabled, the system rewrites the URL to omit “index.php.” The rewrite has no impact on performance or site rank, and is more of a usability issue than anything else.

URL without Web Server Rewrite


URL with Web Server Rewrite

http://www.yourdomain.com/magento/storeview/url-identifier

To enable URL rewrites:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under General, select Web.
2. Click to expand the Search Engine Optimization section.

   ![Search Engine Optimization]

   Search Engine Optimization

3. Set Use Web Server Rewrites to “Yes.”
4. When complete, click the Save Config button.
Automatic Product Redirects

Your store can be configured to automatically generate a permanent redirect whenever the URL key of a product changes. In the product record, the checkbox below the URL key indicates if permanent redirects are enabled for your catalog. If your store is already configured to automatically redirect catalog URLs, making a redirect is as easy as updating the URL key.

**To set up automatic redirects:**

1. On the Admin menu, select **System > Configuration.** Then in the panel on the left under Catalog, select **Catalog.**
2. Click to expand the **Search Engine Optimizations** section.
3. Set **Create Permanent Redirect for URLs if URL Key Changed** to “Yes.”
4. When complete, click the **Save Config** button.
To automatically redirect catalog URLs:

1. On the Admin menu, select Catalog > Manage Products.

2. Find the product in the list, and click to open the record.

3. In the URL Key field, do the following:
   a. Make sure that the Create Permanent Redirect for old URL checkbox is selected. If not, complete the instructions to enable automatic redirects.
   b. Update the URL Key as needed, using all lowercase characters and hyphens instead of spaces.

4. When complete, click the Save button.

5. When prompted to refresh the cache and index, click the links in the messages that appear at the top of the workspace. Follow the instructions.
   The permanent redirect is now in effect for the product and any associated category URLs.

6. To view the redirect records, select Catalog > URL Rewrite Management. The most recent permanent redirects are at the top of the list.
Creating URL Rewrites

The URL Rewrite tool can be used to create product and category rewrites, and custom rewrites for any page in your store. When the rewrite goes into effect, any existing links that point to the previous URL are seamlessly redirected to the new address. The following instructions show how to use the URL Rewrite tool to create three different kinds of rewrites:

- **Product Rewrite**
- **Category Rewrite**
- **Custom Rewrite**

All rewrites reference a “Target Path” and “Request Path,” as shown in the following examples. The “Request Path” is the old URL, and the “Target Path” is where you want the URL to go from now on.

**Example: Permanent 301**

<table>
<thead>
<tr>
<th>Target Path:</th>
<th>category-1.html</th>
</tr>
</thead>
<tbody>
<tr>
<td>Request Path:</td>
<td>catalog/category/id/6</td>
</tr>
<tr>
<td>Redirect Type:</td>
<td>Permanent 301</td>
</tr>
</tbody>
</table>

**Example: Temporary 302**

<table>
<thead>
<tr>
<th>Target Path:</th>
<th>catalog/category/id/6</th>
</tr>
</thead>
<tbody>
<tr>
<td>Request Path:</td>
<td>product.html</td>
</tr>
<tr>
<td></td>
<td><a href="http://magentocommerce.com">http://magentocommerce.com</a></td>
</tr>
<tr>
<td>Redirect Type:</td>
<td>Temporary 302</td>
</tr>
</tbody>
</table>
You can use rewrites to create additional URLs for items, as a temporary seasonal change, or as a permanent change. Rewrites can be created for any valid path, including CMS content pages. Internally, the system references products and category by ID. No matter how often the URL changes, the ID remains the same. Here are some ways you can use URL rewrites:

**Original URL**

http://www.example.com/peripherals/ergonomic-keyboard.html

**Additional Product URL**

http://www.example.com/best-keyboard.html

**Additional Category URL**

http://www.example.com/all-on-sale.html
http://www.example.com/save-now/spring-sale
Product Rewrite

Before you begin, you should know exactly what you want the redirect to accomplish. Just remember—the “Request Path” is the old URL, and the “Target Path” is where you want the URL to go from now on. To manage multiple paths that lead to the same product, see: Canonical Meta Tag.

**New Product Rewrite**

**Process Overview:**

Step 1: Get the Product ID of the Target URL
Step 2: Create the Product Rewrite
Step 3: Refresh the Index
Step 4: Test the Rewrite

**Step 1: Get the Product ID of the Target URL**

1. On the Admin menu, select **Catalog > Manage Products**.
2. Find the product in the list that is the destination of the rewrite and take note of its product ID.

**Step 2: Create the Product Rewrite**

1. On the Admin menu, select **Catalog > URL Rewrite Management**.
2. In the upper-right corner, click the **Add URL Rewrite** button.
3. Set **Create URL Rewrite** to “For product.”
Create URL Rewrite for Product

4. In the list, find the product that you want to redirect, and click the record.

5. Scroll down to the bottom of the Select Category tree, and click the **Skip Category Selection** button.

6. In the URL Rewrite Information section, do the following:

   ![URL Rewrite Information](image)

   **URL Rewrite Information**

   a. If you have multiple stores, set **Store** to the specific view where the rewrite applies.

   b. In the **Request Path** field, enter the URL key of the page to be redirected.

   c. Set **Redirect** to one of the following:

      - Temporary (302)
      - Permanent (301)

   d. For your own reference, enter a brief description of the rewrite.

7. When complete, click the **Save** button.

   Your new product rewrite now appears at the top of the list.

**Step 3: Refresh the Index**

1. On the Admin menu, select **System > Index Management**.

2. Select the **Catalog URL Rewrites** checkbox.

3. Set the **Actions** control to “Reindex Data,” and click the **Submit** button.
Refresh Catalog URL Rewrite Index

### Step 4: Test the Rewrite

Test the rewrite from your store, to make sure that it works correctly.

### Field Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create URL Rewrite</td>
<td>Indicates the type of rewrite to be made. The type cannot be changed after the rewrite is created. Options include:</td>
</tr>
<tr>
<td></td>
<td>For Category</td>
</tr>
<tr>
<td></td>
<td>For Product</td>
</tr>
<tr>
<td></td>
<td>Custom</td>
</tr>
<tr>
<td>ID Path</td>
<td>The ID of the target page. The ID Path and Target Path refer to the same page.</td>
</tr>
<tr>
<td>Request Path</td>
<td>The URL of the page that is to be redirected. Depending on your configuration, the Request Path might include the .html suffix and category. For example:</td>
</tr>
<tr>
<td></td>
<td>brandname</td>
</tr>
<tr>
<td></td>
<td>brand/brandname</td>
</tr>
<tr>
<td></td>
<td>catalog/category/view/id/56</td>
</tr>
<tr>
<td></td>
<td>private-sale-shoes/prima-pump.html</td>
</tr>
<tr>
<td></td>
<td>brand/brandname.html</td>
</tr>
<tr>
<td></td>
<td>A Request Path must be unique, and must not have been used previously. If you have made several attempts to redirect the same page, delete any unsuccessful redirects and refresh the cache.</td>
</tr>
<tr>
<td>Target Path</td>
<td>The URL that points to the destination page. The Target Path can be a different CMS page, or the result of a search.</td>
</tr>
<tr>
<td></td>
<td>To avoid getting a 404 &quot;Page Not Found&quot; error, the path must exactly match what the system expects to find. The following examples are valid target paths:</td>
</tr>
<tr>
<td></td>
<td>brandname</td>
</tr>
</tbody>
</table>
### Field Descriptions (cont.)

<table>
<thead>
<tr>
<th>FIELD</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>brand/brandname</td>
<td></td>
</tr>
<tr>
<td>catalog/category/view/id/52</td>
<td></td>
</tr>
<tr>
<td>catalogsearch/advanced/result/?brand=brandname</td>
<td></td>
</tr>
<tr>
<td><a href="http://magentocommerce.com">http://magentocommerce.com</a></td>
<td></td>
</tr>
</tbody>
</table>

#### Redirect

Indicates whether the rewrite is temporary or permanent. Options include:

- **No**
  - No redirect is specified.
- **Temporary (302)**
  - Indicates to search engines that the rewrite is for a limited duration. Search engines do not preserve page rank information for temporary rewrites.
  - In the URL Rewrite Management list, temporary redirects have the letter “R” in the Options column.
- **Permanent (301)**
  - Indicates to search engines that the rewrite is permanent. Search engines generally preserve page rank information for permanent rewrites.
  - In the URL Rewrite Management list, permanent redirects have the letters “RP” in the Options column.

#### Description

Describes the purpose of the rewrite. This field is for reference and is not visible to customers.
Category Rewrite

If a category changes, or no longer exists, you can use a category rewrite to redirect links that point to the previous category to another URL. It is possible to have multiple URLs that point to the same product, if your store is configured to include categories in the URL key. To manage multiple paths that lead to the same product, see: Canonical Meta Tag.

Process Overview:
Step 1: Get the Category ID of the Target URL
Step 2: Create the Category Rewrite
Step 3: Refresh the Index
Step 4: Test the Rewrite

Step 1: Get the Category ID of the Target URL

1. On the Admin menu, select Catalog > Categories > Manage Categories.
2. In the category in the tree, find the target category and click to open the record.
3. Take note of its category ID at the top of the page.

Step 2: Create the Category Rewrite

1. On the Admin menu, select Catalog > URL Rewrite Management.
2. In the upper-right corner, click the Add URL Rewrite button.
3. By default, **Create URL Rewrite** is set to “For category.” In the category tree, click to select the category to be redirected.

4. In the URL Rewrite section, do the following:
   a. If you have multiple stores, select the **Store** where the rewrite applies.
   b. In the **Request Path** field, enter the URL key of the category to be redirected.
   c. Set **Redirect** to one of the following:
      - Temporary (302)
      - Permanent (301)
   d. For your own reference, enter a brief description of the rewrite.

5. When complete, click the **Save** button.

---

**Category URL Rewrite Information**

Your new category rewrite now appears at the top of the list of rewrites.

---

**New Category Rewrite**

6. Test the rewrite from your store, to make sure that it works correctly.
Step 3: Refresh the Index

1. On the Admin menu, select **System > Index Management**.
2. Select the **Catalog URL Rewrites** checkbox.
3. Set the **Actions** control to “Reindex Data,” and click the **Submit** button.

Step 4: Test the Rewrite

Test the redirect from your store, to make sure that it works correctly. Make sure that the URL you test goes directly to the category, rather than to a subcategory. For example:

```
http://yourstore.com/catalog/category/view/id/56
```
Custom Rewrite

You can use a custom rewrite to redirect CMS pages, or any other type of page. For example, if you change the URL key of the privacy policy from `privacy-policy-cookie-restriction-mode` to `privacy-policy`, the link in the cookie restriction mode will return “404 - Page Not Found.” To redirect traffic to the new URL key, create a custom rewrite with the following settings:

- **ID Path:** `privacy-policy`
- **Request Path:** `privacy-policy-cookie-restriction-mode`
- **Target Path:** `privacy-policy`
- **Redirect:** Permanent (301)

Before you begin, figure out the URL keys that you need for the ID Path, Request Path, and Target Path. Just remember— the “Request Path” is the old URL, and the “ID Path” and “Target Path” are the new URL.

**Process Overview:**

1. **Step 1:** Establish the Request and Target Paths
2. **Step 2:** Create the Custom Rewrite
3. **Step 3:** Refresh the Index
4. **Step 4:** Test the Rewrite
Step 1: Establish the Request and Target Paths

Before you begin, write down the URL key of the page to be redirected (Request Path), and the target page where it will be redirected (Target Path).

Step 2: Create the Custom Rewrite

1. On the Admin menu, select Catalog > URL Rewrite Management.
2. In the upper-right corner, click the Add URL Rewrite button.
3. Set Create URL Rewrite to “Custom.”

4. In the URL Rewrite Information section, do the following:
   a. If you have multiple stores, select the Store where the rewrite applies.
   b. In the ID Path field, enter the relative path of the destination page.
      - To redirect to another CMS page in your store, enter the relative path to the page, without a leading forward slash.
      - To redirect to a page on a different site, enter the fully qualified URL of the new destination.

   c. In the Request Path field, enter the relative path of the page to be redirected.
   d. In the Target Path field, enter the valid URL of an existing page that will be the new destination. This refers to the same page as the ID Path.
   e. Set Redirect to one of the following:
      - Temporary (302)
      - Permanent (301)
   f. For your own reference, enter a brief Description of the rewrite.

In the following illustration, the CMS page “about-magento-demo-store” is temporarily redirected to the target, “my-page.”
5. When complete, click the **Save** button.

Your new rewrite now appears at the top of the list.

**Step 3: Refresh the Index**

1. On the Admin menu, select **System > Index Management**.
2. Select the **Catalog URL Rewrites** checkbox.
3. Set the **Actions** control to “Reindex Data,” and click the **Submit** button.

**Step 4: Test the Rewrite**

Test the rewrite from your store, to make sure that it works correctly.
Content

Quality content can transform your site into a destination. In this section, you will learn to use your store’s content management system to create custom pages and modular blocks of content that can be placed most anywhere in your store. Add images and video to tell a story that educates, inspires, and entertains.

Magento CMS
CMS Tools

Content Pages
Core Content
Creating a Page
Using the Editor
Media Storage

Blocks
Creating a Static Block
Positioning Blocks

Widgets
Widget Types
Creating a Widget
Static Block
New Products List
Mini Shopping Cart

Variables
Predefined Variables
Custom Variables

Markup Tags
Markup Tag Syntax
Using Markup Tags in Links
Category List on Home Page

Design
Page Layout
Page Setup
Your Store’s Theme
CHAPTER 29:

Magento CMS

The term, content marketing\(^1\) refers to the art of promoting your products or services by providing valuable information to your customers at no charge. The quality of your content helps distinguish your store from others, increases your visibility to search engines, and provides support to your customers. This soft-sell approach is often more effective than advertising, builds credibility and trust, and can turn your store into a destination. Content is still king!

Your content should reflect the branding of your store, and be delivered with your distinctive visual presentation and voice to convey your message. Use pictures to tell a story. Educate, inspire, and entertain. With quality content, sometimes less is more.

Magento Community Edition includes a powerful content management system (CMS) that you can use to create rich content for your store. In this chapter, you will learn how to create new content, and incorporate existing content to create a compelling experience that will bring your customers back to your store for more.

---

\(^1\)The art of promoting products or services by providing valuable information at no charge.
**CMS Tools**

**Pages**

Create pages with text, images, blocks, variables, and widgets, that can be incorporated into the navigation of your store, and linked to other pages.

**Static Blocks**

The CMS makes it easy to create blocks of content without writing any code. Blocks can contain text, images, and even video, and can be assigned to any part of the page layout.

**Widgets**

Use the Widget tool to display dynamic data and add blocks, links, and interactive elements most anywhere in your store.

**Polls**

Create polls to learn about your customers’ opinions and preferences. They’re fun to take and see the results!
CHAPTER 30:

Content Pages

All content can be viewed in terms of its shelf life, just as any product in a store. Did you know that the shelf life of social media content is less than twenty-four hours? The potential shelf life of the content you create can help you decide where to invest your resources.

Content with a long shelf life is sometimes referred to as evergreen content. Examples of evergreen content include customer success stories, "how to" instructions, and Frequently Asked Questions (FAQ.) Other content is perishable by nature, such as events, industry news, and press releases. Make sure that your site has quality content of both types, so it becomes a resource to your customers. Topics in this chapter include:

- Core Content
- Default Pages
- Creating a Page
- Using the Editor
- Inserting Links
- Inserting Images
- Adding a Widget
- Media Storage

\(^1\)Content with a long shelf life.
Core Content

The Magento demo store has examples of core content pages that can help you get started. Take a look at the following pages in your store, to make sure that they convey your message and brand.

Home

The demo “Home” page includes a banner, an image carousel, several static blocks with links, and a list of new products.

About Us

The “About Us” page is linked from the footer of your store. You can include images, video, links to press releases and announcements. The sample page has an image on the right, and one of a decorative sort to indicate the end of the page.

Customer Service

The “Customer Service” page is another node in the page hierarchy. The two headers on the page have content that only becomes visible when the header is clicked.

Privacy Policy

Your store’s “Privacy Policy” page should be updated with your own information. As a best practice, your privacy policy should explain to your customers the type of information that your company collects and how it is used.
"404" Page Not Found

The "404 Page Not Found" response code is returned when a page cannot be found. URL redirects reduce the number of times that this page appears. However, for those times when it is necessary, you might as well take advantage of the opportunity to offer some links to products that the customer might find interesting.

Enable Cookies

The "Enable Cookies" page appears when visitors to your site do not have cookies enabled in their browsers. The page provides step-by-step, illustrated instructions to enable cookies for the most popular browsers.

"503" Service Unavailable

The "503 Service Unavailable" page is named for the response code that is returned when the server is unavailable.
Default Pages

The Default Pages configuration determines the landing page that is associated with the base URL, and the corresponding CMS home page. It also determines which CMS page appears when a “404 Page Not Found” error occurs, and if a breadcrumb trail appears at the top of CMS pages.

To configure the default pages:

1. On the Admin menu, select System > Configuration.
2. If necessary, set Current Configuration Scope in the upper-left corner to the store view where the setting applies.
3. In the panel on the left under General, select Web.
4. Click to expand the Default Pages section. Then, do the following:

   a. In the Default Web URL field, enter the relative path to the folder in the Magento installation that contains the landing page. The default value is “cms.”

      For a specific store view, clear the Use Default checkbox next to the Default Web URL field, and any other default fields to be changed.

   b. Set CMS Home Page to the CMS page to be used as the home page.

   c. In the Default No-route URL field, enter the relative path to the folder in the Magento installation where the page is redirected when a “404 Page Not Found” error occurs. The default value is “cms/index/noRoute.”

   d. Set CMS No Route Page to the CMS page that appears when a “404 Page Not Found” error occurs.

   e. Set CMS No Cookies Page to the CMS page that appears when cookies are disabled in the browser.

   f. If you want a breadcrumb trail to appear at the top of all CMS pages, set Show Breadcrumbs for CMS Pages to “Yes.”

5. When complete, click the Save Config button.
Creating a Page

Most pages are designed to be read by search engines first, and by people second. Keep in mind the needs of each of these two very different audiences when choosing the page title, URL key, and meta data, as well as when writing the content. The process of adding a new page to your store is essentially the same for adding a new home page, or any other type of page. You can include text, images, blocks of content, variables, and widgets.

**Process Overview:**

Step 1: Add a New Page  
Step 2: Choose the Page Layout  
Step 3: Complete the Content  
Step 4: Complete the Meta Data  
Step 5: Publish the Page  
Step 6: Make a New Home Page (Optional)

**Step 1: Add a New Page**

1. On the Admin menu, select **CMS > Pages > Manage Content**.
2. Click the **Add New Page** button.
3. In the Page Information section, do the following:
   
   a. Enter a **Title** for the new page.
   b. Enter a **URL Key** for the page that is based on the Title. Use all lowercase characters, with hyphens instead of spaces.
      
      The URL Key is added to the base URL to create the online address for the page.
   c. In the **Store View** list, select each view where this page will be available.
   d. Set **Status** to “Disabled.” (This will be changed when the page is ready to publish.)
4. With the required fields complete, click the **Save and Continue Edit** button.
Step 2: Choose the Page Layout

1. In the Page Information panel on the left, select Design.

2. In the Page Layout section, set Layout to one of the following to determine the column layout of the page.
   - 1 column
   - 2 columns with left bar
   - 2 columns with right bar
   - 3 columns

   ![Page Layout Image]

Step 3: Complete the Content

1. In the Page Information panel on the left, select Content.

2. In the Content Heading box, type the text you want to appear as the main heading at the top of the page.

   Complete the remaining content, as you want it to appear in the main content column, according to the page layout selected. The content can include text, images, variables, and widgets with dynamic data.

3. Click the Show / Hide Editor button to display the WYSIWYG editor. You can format the text from the toolbar.
4. Click the **Show / Hide Editor** button again to return to the HTML mode. You can work in either mode that you prefer.

5. Click the **Save and Continue Edit** button.

**Step 4: Complete the Meta Data**

1. In the panel on the left, select **Meta Data**.

2. Complete the **Keywords** and **Description** for the page. This information is used by search engines to index the page.

**Step 5: Publish the Page**

1. In the panel on the left, select **Page Information**.

2. Set **Status** to “Published.”

3. Click the **Save Page** button.

When the page is complete, it can be added to the navigation of your store, linked to other pages, or added as a link in the footer.
Step 6: Make a New Home Page (Optional)

1. Complete the steps to create a new page.
2. On the Admin menu, select System > Configuration.
3. In the panel on the left under General, select Web. Then, click to expand the Default Pages section.

4. Set CMS Home Page to the new page.
5. Click the Save Config button.
6. In the message at the top of the workspace, click the Cache Management link.
7. Select the checkbox for the invalid Layout cache. Then, click the Submit button to refresh the cache.
Using the Editor

The WYSIWYG editor gives you the ability to enter and format while working in a “What You See Is What You Get” view of the content. If you prefer to work directly with the underlying HTML code, you can easily change modes. The editor can be used to create content for pages, blocks, and product descriptions. When working in the product catalog, the editor is accessed by clicking the WYSIWYG Editor button.

For a complete list of toolbar buttons, see the Editor Toolbar in the appendix of this guide.

Editor Toolbar
Inserting a Link

The easiest way to insert a link is to use the Link button in the editor toolbar. It doesn’t require any knowledge of HTML and the result is the same.

To insert a link:

1. Highlight the text where you want to create the link. Then, in the editor toolbar, click the Link button.

2. In the Link URL field, enter one of the following:
   - The URL Key of a page in your store.
   - The full URL of an external page to be linked.

3. Set Target to one of the following:
   - Open link in the same window
   - Open in a new window

4. In the Title field, enter the tooltip text that appears when someone hovers over the link.

5. Click the Insert button to create the link.
Inserting Images

From the editor, you can insert an online image that resides on another server, or display an image that has been uploaded to Media Storage.

![Media Storage]

Method 1: Insert an Image from Media Storage

1. If necessary, click the **Show / Hide Editor** button to display the code.
2. Position the cursor where you want the code to be inserted. Then, click the **Insert Image** button.
3. Select the image that you want to use, and click the **Insert File** button.
4. To view the image in WYSIWYG mode, click the **Show / Hide Editor** button.
Method 2: Insert an Image from Another Server

Use this method to insert an image that is available online, but resides on another server. You must have the full URL of the image to complete the process.

1. Click the Show / Hide Editor button to work in WYSIWYG mode.
2. Position your cursor where you want the image to appear.
3. On the Editor toolbar, click the Insert Image button. Then, do the following:

   ![Insert Image Button]

   Insert Image Button

   a. In the Image URL field, paste the full Web address to the image.
   b. In the Image Description field, write a brief description of the image.
   c. In the Title field, write a relevant title for the image.

4. Click the Insert button to complete the process.
Adding a Widget

The Widget tool can be used to add a variety of content elements to the page, including links to any content page or node, product, or category. Links can be positioned on the page by block reference or incorporated directly into CMS content and email templates. You can create links to the following four types of content:

- CMS Pages
- Catalog Categories
- Catalog Products

Links can be displayed as a block, or used inline and incorporated into existing text. By default, a link inherits its style from the location (block reference) according to the style sheet (styles.css) of the theme.

**To add a widget to a page:**

1. Open the CMS page to be edited.
2. In the panel on the left, select **Content**. Then, use either of the following methods:

   **Method 1: WYSIWYG Mode**
   
   1. Click the **Show / Hide Editor** button to display the page in WYSIWYG mode.
   2. Position the cursor in the text where you want the widget to appear.
   3. On the editor toolbar, click the **Insert Widget** button.

   **Method 2: HTML Mode**
   
   From the HTML editor, click the **Insert Widget** button.

3. When prompted, select the **Widget Type**. This example shows how to insert a link to a product.
4. You can leave the **Anchor Custom Text** field empty to use the product name.
5. Enter a **Anchor Custom Title** for best SEO practice. (The title isn't visible on the page.)
6. Set **Template** to one of the following:
   
   - To incorporate the link into text, select “Product Link Inline Template.”
   - To place the link on a separate line, select “Product Link Block Template.”
Select the Template

7. Click the **Select Product** button, and do the following:
   
   a. In the tree, navigate to the category you want.
   b. In the list, click the product that you want to include in the link.

Select the Product

   c. Click the **Insert Widget** button to place the link on the page. In the HTML, the link **markup tag** appears at the top of the page, enclosed in double curly braces.

   d. If needed, use Cut (Ctrl + x) and Paste (Ctrl + v) to position the markup tag in the code where you want the link to appear.

Widget Link Code
8. Click the **Show / Hide Editor** button to see the link in WYSIWYG mode.

Now you can continue editing the page, and incorporate the links into the rest of the content.
Media Storage

Media storage is a tool you can use to organize and access miscellaneous media files on the server. The path to the physical location of the files is determined by the Base URL configuration. Files in media storage can be accessed from the editor while working on pages and static blocks. Media storage is usually located in the file system on the same server as the Magento program files. Alternatively, the files can be managed in a database, or located on a separate server or content delivery network.

To upload an image to media storage:

1. From the editor, do the following:
   a. Click the **Browse Files** button. Find the file on your computer, and click to select it. Then, click the **Open** button to copy the file to Media Storage.
   b. Click the **Upload File** button to add the image to Media Storage.

2. To link the image to a file, click to select the image. Then, click the **Insert File** button.

3. To complete the **Alt** tag, place the cursor between the double-quotes, and enter the alt text.

4. To see the image in WYSIWYG mode, click the **Show / Hide Editor** button.
CHAPTER 31:

Blocks

A block is a modular unit of content that can be positioned most anywhere on the page. Blocks can be used to display static information such as text, images, and embedded video, as well as dynamic information.

You can use Magento Community Edition’s content management system to create custom blocks of content without writing any code. Blocks can contain text, images, and even video, and can be assigned to any part of the page layout.

In addition, your store includes a selection of built-in blocks that make it easy to add features and functionality to your store. Some built-in blocks are required components of your store, while others are shopping tools that can be enabled or disabled according to your preference. Many of the built-in blocks can be added to your store with the Widget tool. Blocks can also be defined and positioned by entering XML code in the Layout Update box on the target page. Topics include:

- Creating a Static Block
- Positioning Blocks
Creating a Static Block

Custom, static blocks of content can be added to any page, group of pages, or even to another block. The carousel image slider on the home page of the demo store is generated by code that is placed in a static block. The three smaller blocks below are also static blocks that link to other pages. Although they look like graphic images, they are actually defined using HTML and CSS.
To create a block:

1. On the Admin menu, select CMS > Static Blocks.

2. In the upper-right corner, click the Add New Block button. Then, do the following:
   a. Assign a descriptive Block Title.
   b. Assign a unique Identifier to the block. Use all lowercase characters, with underscores instead of spaces. The identifier is used for internal reference.
   c. Select the Store View(s) where this content block will be visible.
   d. Set Status to “Enabled” to make the block visible in the store.
   e. Complete the Content for the block. You can use the Editor to format text, create links and tables, add images, video, and audio.

3. When complete, click the Save Block button.
Positioning Blocks

The code that controls the page layout and placement of blocks is written in XML. You might have noticed references to XML Page Layout Updates throughout the Admin of your store. Every product, category, and piece of content—whether it’s a page, block, or widget—has a section where you can update the XML code that controls the positioning of the item. The selection of available block references that is available varies by page type, and whether the customer is logged in, or is visiting the as a guest.

Widgets make it easy to position a block at a specific place on the page, and even for a specific product or category. You can select each option from a list, rather than trying to remember all of the possible combinations.

Category and CMS Pages

<table>
<thead>
<tr>
<th>BLOCK REFERENCE</th>
<th>POSITION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Breadcrumbs</td>
<td>The navigation aid at the top of many pages that shows your current location as a link. Any additional content placed in the Breadcrumbs reference floats to the right of the breadcrumbs, if displayed.</td>
</tr>
<tr>
<td>Left Column</td>
<td>Content is added to the left column.</td>
</tr>
<tr>
<td>Main Content Area</td>
<td>Content is added to the main content area.</td>
</tr>
<tr>
<td>My Cart Extra Actions</td>
<td>Content appears below the Cart Subtotal in the My Cart popup located within the top link.</td>
</tr>
<tr>
<td>Navigation Bar</td>
<td>Content appears below the main navigation bar.</td>
</tr>
<tr>
<td>Page Bottom</td>
<td>Content appears at the bottom of the page.</td>
</tr>
<tr>
<td>Page Footer</td>
<td>Content appears above the footer of the page.</td>
</tr>
<tr>
<td>Page Header</td>
<td>Content appears below the header of the page.</td>
</tr>
<tr>
<td>Page Top</td>
<td>Content appears at the top of the page.</td>
</tr>
<tr>
<td>Right Column</td>
<td>Content appears in the right column.</td>
</tr>
<tr>
<td>Store Language</td>
<td>Content appears in the upper-left corner of the header.</td>
</tr>
<tr>
<td>BLOCK REFERENCE</td>
<td>POSITION</td>
</tr>
<tr>
<td>-------------------------------------</td>
<td>-----------------------------------------------------------------</td>
</tr>
<tr>
<td>Alert URLs</td>
<td>Content appears below the title of the product on the product detail page.</td>
</tr>
<tr>
<td>Bottom Block Options Wrapper</td>
<td>If custom options are added, content appears below the Add to Cart button.</td>
</tr>
<tr>
<td>Breadcrumbs</td>
<td>Content appears to the right of breadcrumbs—the navigation aid that provides links as a path—that's showcased below the navigation bar.</td>
</tr>
<tr>
<td>Info Column Options Wrapper</td>
<td>If a custom options are added, content appears to the right. The same location applies to configurable options.</td>
</tr>
<tr>
<td>Left Column</td>
<td>Content appears below the left column blocks.</td>
</tr>
<tr>
<td>Main Content Area</td>
<td>Content appears below the main content area.</td>
</tr>
<tr>
<td>My Cart Extra Actions</td>
<td>Content appears below the Cart Subtotal in the My Cart popup located within the top link.</td>
</tr>
<tr>
<td>Navigation Bar</td>
<td>Content appears below the main navigation bar.</td>
</tr>
<tr>
<td>Page Bottom</td>
<td>Content appears at the bottom of the page.</td>
</tr>
<tr>
<td>Page Footer</td>
<td>Content appears above the footer of the page.</td>
</tr>
<tr>
<td>Page Header</td>
<td>Content appears below the header of the page.</td>
</tr>
<tr>
<td>Page Top</td>
<td>Content appears at the top of the page.</td>
</tr>
<tr>
<td>PayPal Express Checkout (Payflow Edition) Shortcut Wrapper</td>
<td>If the PayPal payment method is enabled, content appears below the PayPal buy button.</td>
</tr>
<tr>
<td>PayPal Express Checkout Shortcut Wrapper</td>
<td>If the PayPal payment method is enabled, content appears below the PayPal buy button.</td>
</tr>
<tr>
<td>Product Tags List</td>
<td>Content appears below the products tag bar.</td>
</tr>
<tr>
<td>Product View Extra Hint</td>
<td>Content appears below the main top price of the product.</td>
</tr>
<tr>
<td>Right Column</td>
<td>Content appears below the right column blocks.</td>
</tr>
<tr>
<td>Store Language</td>
<td>Content appears to the right of the language chooser.</td>
</tr>
<tr>
<td>Tags List Before</td>
<td>Content appears above the Add Your Tags field.</td>
</tr>
</tbody>
</table>
CHAPTER 32:

Widgets

A widget is a snippet of code that makes it possible to display a wide range of content and place it at specific block references in your store. Many widgets display real-time, dynamic data and create opportunities for your customers to interact with your store. The Widget tool makes it easy to place existing content such as static blocks with images and text, and interactive elements most anywhere in your store.

You can use widgets to create landing pages for marketing campaigns, display promotional content at specific locations throughout the store. Widgets can also be used to add interactive elements and action blocks for external review systems, video chats, voting, and subscription forms, or to provide navigation elements for tag clouds and image sliders. Topics in this chapter include:

- Widget Types
- Creating a Widget
- CMS Static Block
- New Products List
- Mini Shopping Cart
Widget Types

CMS Page Link
Displays a link to a selected page. Allows you to specify custom text and title. When the link is complete, it can be used in content pages and blocks.

CMS Static Block
Displays a block of content at a specific location on a page.

Catalog Category Link
Displays either an inline or block-style link to a selected catalog category. When the link is complete, it can be used in content pages and blocks.

Catalog New Products List
Displays a block of products which have been designated as new, for the duration of time specified in the product record.

Catalog Product Link
Displays either an inline or block-style link to a selected catalog product. When the link is complete, it can be used in content pages and blocks.

Recently Compared Products
Displays the built-in block of recently compared products. You can specify the number of products included, and format them as a list or product grid.

Recently Viewed Products
Displays the built-in block of recently viewed products. You can specify the number of products included, and format them as a list or product grid.

Mini Shopping Cart
If the store has a responsive theme, the Mini Shopping Cart widget can be used to display additional information, such as a banner or contact information, in the mini shopping cart.
Creating a Widget

The process of creating a widget is nearly the same for each type. You can follow the first part of the instructions, which is the same for all types, and then complete the last part that is specific to the type of widget you want to create.

Process Overview:
Step 1: Choose the Widget Type
Step 2: Specify Where It Goes
Step 3: Complete the Widget Options
Step 4: Check It Out!

Step 1: Choose the Widget Type

1. On the Admin menu, select CMS > Widgets.
2. Click the Add New Widget Instance button. Then, do the following:
   a. In the Settings section, select the Type of widget you want to create.
   b. Select the Design Package/Theme that will be used with the widget.
3. Click the Continue button.

Widget Settings

4. In the Frontend Properties section, do the following:
a. In the **Widget Instance Title** field, enter a descriptive title for the widget. This title is for internal use only, and won’t be visible to your customers.

b. Set **Assign to Store Views** to “All Store Views,” or to the view where the widget to be available. To select more than one, hold the Ctrl key down, and select each option.

c. Enter a number in the **Sort Order** field to determine the order of the block when listed with others in the column. The top position is zero.

**Step 2: Specify Where It Goes**

1. In the Layout Updates section, click the **Add Layout Update** button.

2. Set **Display On** to the type of category or product page where you want the widget to appear.

3. In the **Block Reference** list, select the block or section of your page layout where you want the widget to appear.

```
<table>
<thead>
<tr>
<th>Display On</th>
<th>Specified Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product</td>
<td></td>
</tr>
</tbody>
</table>
```

**Layout Updates**

4. If the widget is a link, set **Template** to one of the following:

   - **Block Template**
     Formats the content so it can be placed as standalone unit on the page.

   - **Inline Template**
     Formats the content so it can be placed inside other content. For example, a link that goes inside a paragraph of text.

5. Click **Save and Continue Edit** to save your changes and continue editing.
Step 3: Complete the Widget Options

The options for each type vary slightly, but the process is essentially the same. The following instructions show how to place a CMS Static Block.

1. In the panel on the left, select **Widget Options**.
2. Click the **Select Block** button.
3. In the list, click to select the block you want to place.
4. When complete, click the **Save** button.

The widget appears in the Manage Widget Instances list.
5. When prompted, follow the instructions at the top of the workspace to update the cache, as needed.

Step 4: Check It Out!

Return to your storefront to verify that the block is in the correct location. To move the block to a different location, you can reopen the widget and try a different page or block reference.
CMS Static Block Widget

The CMS Static Block widget gives you the ability to place an existing CMS block most anywhere in your store.

<table>
<thead>
<tr>
<th>Process Overview:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1: Choose the Widget Type</td>
</tr>
<tr>
<td>Step 2: Complete the Layout Updates</td>
</tr>
<tr>
<td>Step 3: Place the Block</td>
</tr>
</tbody>
</table>

**Step 1: Choose the Widget Type**

1. On the Admin menu, select CMS > Widgets.
2. Click the Add New Widget Instance button.
3. In the Settings section, set Type to “CMS Static Block.” Then, click the Continue button.
4. In the Frontend Properties section, do the following:
   a. In the Widget Instance Title field, enter a descriptive title for the widget. This title is for internal use only, and is not visible to your customers.
   b. Enter a number in the Sort Order field to determine the order of the block when listed with others in the column. The top position is zero.
   c. Set Assign to Store Views to “All Store Views,” or to the view where the app will be available. To select more than one, hold the Ctrl key down, and select each option.

**Step 2: Complete the Layout Updates**

1. In the Layout Updates section, set Display On to the category, product, or page where you want the block to appear.
2. To complete the Layout Updates, do the following:
   a. Select the Page where you want the block to appear.
   b. Select the Block Reference to identify the place on the page where the block will appear
   c. Accept the default setting for Template, which is set to "CMS Static Block Default Template."
   d. Click Save and Continue Edit.
Step 3: Place the Block

1. In the panel on the left, select **Widget Options**.

2. Click the **Select Block** button.

   Then in the list, click to select the block you want to place.

3. When complete, click the **Save** button.

   The app appears in the Manage Widget Instances list.

4. When prompted, follow the instructions at the top of the workspace to update the index and page cache.

5. Return to your storefront to verify that the block is in the correct location. To move the block, you can reopen the widget and try a different page or block reference.
New Products List Widget

The list of new products is an example of dynamic content, and consists of live data that is pulled from your product catalog. By default, the “New Products” list includes the first eight of the most recently added products. However, it can also be configured to include only products within a specified date range.

![New Products List on Home Page](image)

**Process Overview:**
- **Step 1:** Set the Date Range for Each Product
- **Step 2:** Create a Working Copy of the Widget
- **Step 3:** Select the Location for the List
- **Step 4:** Configure the List
- **Step 5:** Preview Your Work

**Step 1: Set the Date Range for Each Product**

To make a product appear in the list by date range, the dates must be specified in the product record. The product then appears in the New Products list during the date range specified.

1. On the Admin menu, select **Catalog > Manage Products**.
2. Find the product you want to feature, and open the record. Then, do the following:
   a. In the **Set Product as New From Date** field, click the calendar button and select the first date that you want the product to be featured.
   b. In the **Set Product as New To Date** field, click the calendar button and select the last date that you want the product to be featured.
3. When complete, click the **Save** button.

4. When you are prompted to reindex and refresh the page cache, click the links at the top of the workspace, and follow the instructions.

The product will now appear in the New Products list during this date range. Repeat this step for each product that you want to feature.
Step 2: Create a Working Copy of the Widget

The code that determines the content of the list and its placement in your store is generated by the Widget tool. To create your own working copy of the New Products list, simply save a copy of the existing widget. Your working copy is a new “instance” of the widget, and any changes you make will not affect the original.

1. On the Admin menu, select CMS > Widgets.
2. In the upper-right corner, click the Add New Widget Instance button.
3. In the Settings section, do the following:
   a. Set Type to “Catalog New Products List.”
   b. Select the Design Package/Theme that is used by the store.
4. Then, click the Continue button.

5. In the Frontend Properties section, complete the following fields:
   - Widget Instance Title: Enter a descriptive title for your widget. This title is visible only from the Admin.
   - Assign to Store Views: Select the store views where the widget will be visible. You can select a specific store view, or "All Store Views."
   - Sort Order: (Optional) Enter a number to determine the order this items appears with others in the same part of the page. (0 = first, 1 = second, 3= third, and so on.)
Step 3: Select the Location for the List

1. In the Layout Updates section, click the **Add Layout Update** button. Then, do the following:
   a. Set **Display On** to “Specified Page.”
   b. Set **Page** to “CMS Home Page.”
   c. Set **Block Reference** to “Main Content Area.”
   d. Set **Template** to one of the following:
      - New Product Lists Templates
      - New Products Grid Template

2. Click the **Save and Continue Edit** button to save your changes.

Step 4: Configure the List

1. In the panel on the left, select **Widget Options**. Then, do the following:
2. Set **Display Products** to one of the following:
   - All Products: Lists products in sequence, starting with those most recently added.
   - New Products: Lists only the products which are identified as “New.” A product is considered to be new during the date range specified in the “Set Product As New From” date and “Set Product As New To” date. fields of the product. The list will be blank if the date range expires and no additional products have been set as “New.”

3. Complete the remaining information as follows:
   a. To provide navigation control for lists with multiple pages, set **Display Page Control** to “Yes.” Then, in the **Number of Products per Page** field, enter the number of products you want to appear on each page.
   b. Set **Number of Products to Display** to the number of new products you want to include in the list. The default setting is 10.
c. In the **Cache Lifetime (Seconds)** field, select how often you want to refresh the list of new products. By default, the cache is set to 86400 seconds, or 24 hours.

![Widget Options]

4. When complete, click the **Save** button.

5. When prompted to refresh the cache, click the link in the message at the top of the workspace, and follow the instructions.

**Step 5: Preview Your Work**

1. On the Admin menu, select **CMS > Pages > Manage Content**.

2. Find the published page in the list, where you placed the New Products list. Then, in the **Action** column, click the **Preview** link.
Mini Shopping Cart Widget

You can use a widget to show relevant information to your customers when the mini cart appears in your store. For example, you might want to display a promotional message, or you could provide a phone number or other contact information.

The mini shopping cart widget can be used only with responsive web design themes.

### Process Overview:

1. **Choose the Widget Type**
2. **Complete the Layout Updates**
3. **Place the Block**

### Step 1: Choose the Widget Type

1. On the Admin menu, select CMS > Widgets.
2. Click the Add New Widget Instance button.
3. In the Settings section, do the following:
   a. Set Type to “CMS Static Block.”
   b. Set Design Package/Theme to any responsive web design (RWD) theme. You must select a responsive package/theme to use the mini cart widget.
   c. Click the Continue button.
4. In the Frontend Properties section, do the following:
   a. In the **Widget Instance Title** field, enter a descriptive title for the widget. This title is for internal use only, and is not visible to your customers.
   b. Enter a number in the **Sort Order** field to determine the order of the block when listed with others in the column. The top position is zero.
   c. Set **Assign to Store Views** to “All Store Views,” or to the view where the block will be available. To select more than one, hold the Ctrl key down and select each option.

Step 2: Complete the Layout Updates

1. In the Layout Updates section, set **Display On** to the category, product, or page where you want the block to appear.

2. To complete the Layout Updates, do the following:
   a. Select the **Page** where you want the block to appear.
   b. Set **Block Reference** to “Mini-cart promotion block.”
   c. Accept the default **Template** setting, “CMS Static Block Default Template.”
   d. Click **Save and Continue Edit**.
Step 3: Place the Block

1. In the panel on the left, select Widget Options.

2. Click the Select Block button. Then in the list, click to select the block you want to place.

3. When complete, click the Save button. The block appears in the Manage Widget Instances list.

4. When prompted, follow the instructions at the top of the workspace to update the index and page cache.

5. Return to your storefront to verify that the block is in the correct location.
CHAPTER 33: Variables

Variables are reusable pieces of information that can be created once and used in multiple places, such as email templates, blocks, and content pages. Your Magento store includes a large number of predefined attributes, and also gives you the ability to create your own custom variables. Topics include:

- Predefined Variables
- Custom Variables
Predefined Variables

Predefined variables are easy to add to content pages, blocks, and email templates.

**To add a variable to a page:**

1. On the Admin menu, select **CMS > Pages > Manage Content**. Then, click to open the page.
2. In the Page Information panel on the left, select **Content**. Then from the editor, do one of the following:
   - Click the **Insert Variable** button.
   - If you prefer to work with the code, click the **Show / Hide Editor** button.
3. Position the insertion point in the text where you want the variable to appear. Then, click the **Insert Variable** button.
4. In the list of available store contact variables, click the one you want to use.
5. When complete, click the **Save** button.

**To add a variable to a block:**

1. On the Admin menu, select **CMS > Static Block**. Then, click to and open the block.
2. From the editor, do one of the following:
   - Click the **Insert Variable** button.
   - If you prefer to work with the code, click the **Show / Hide Editor** button.
3. Position the insertion point in the text where you want the variable to appear. Then, click the **Insert Variable** button.

4. In the list of available variables, click to select the one you want to use.

5. When complete, click the **Save Block** button.

**To add a variable to an email template:**

1. On the Admin menu, select **System > Transactional Emails**.

2. Do one of the following:
   - Click to edit a predefined template.
   - Click the **Add New Template** button to create a new one.

3. In the **Template Content** box, position the insertion point where you want the variable to appear. Then, click the **Insert Variable** button.

4. In the list of available variables, click to select the one you want to use.

5. When complete, click the **Save Template** button.

**Predefined Variables**

<table>
<thead>
<tr>
<th>STORE CONTACT VARIABLES</th>
</tr>
</thead>
<tbody>
<tr>
<td>Store Contact Information</td>
</tr>
<tr>
<td>Base Unsecure URL</td>
</tr>
<tr>
<td>Base Secure URL</td>
</tr>
<tr>
<td>General Contact Name</td>
</tr>
<tr>
<td>General Contact Email</td>
</tr>
<tr>
<td>Sales Representative Contact Name</td>
</tr>
<tr>
<td>Sale Representative Contact Email</td>
</tr>
<tr>
<td>Custom 1 Contact Name</td>
</tr>
<tr>
<td>Custom 1 Contact Email</td>
</tr>
<tr>
<td>Custom 2 Contact Name</td>
</tr>
<tr>
<td>Custom 2 Contact Email</td>
</tr>
<tr>
<td>Store Name</td>
</tr>
<tr>
<td>Store Contact Telephone</td>
</tr>
<tr>
<td>Store Contact Address</td>
</tr>
</tbody>
</table>
Custom Variables

If you know a little basic HTML, you can create custom variables and incorporate them into pages, blocks, banners, and email templates. When a variable is inserted into HTML, it is formatted as a markup tag, and enclosed in double curly braces.

```
{{CustomVar code= "store_hours"}}
```

To create a custom variable:

1. On the Admin menu, select System > Custom Variable.
2. Click the Add New Variable button.
3. Enter an identifier in the Variable Code field. Use all lowercase characters, without spaces.
4. Enter a Variable Name, which is used for internal reference. Then, do one of the following:
   - In the Variable HTML Value text field, enter any content you want to include, using basic HTML tags. This option allows you to format the value.
   - In the Variable Plain Value field, enter the variable value as plain text.
5. When complete, click the Save button.
CHAPTER 34:

Markup Tags

A markup tag is a snippet of code that contains a relative reference to an object in your store, such as a page, block, or image. Markup tags can be incorporated into the HTML content of CMS pages, blocks, images, and email templates. Topics include:

- Markup Tag Syntax
- Using Markup Tags in Links
- Listing Categories On Home Page
Markup Tag Syntax

Markup tags are enclosed in double, curly braces, and can be generated by the Widget tool, or typed directly into HTML content. For example, rather than hard-coding the full path to a page, you can use a markup tag to represent the store URL. The markup tags featured in the following examples include:

- Store URL
- Media URL
- Block ID
- Template Tag
- Non-Inline CSS Tag
- Widget Code
Store URL

The Store URL markup tag represents the base URL of your website, and is used as a substitute for the first part of a full URL, including the domain name. There are two versions of this markup tag: One that goes directly to your store, and the other with a forward slash at the end that is used when a path is added.

```{{store url='apparel/shoes/womens'}}```

Media URL

The dynamic media URL markup tag represents the location and file name of an image that is stored on a content delivery network (CDN). The tag can be used to place an image on a page, block, banner, or email template.

```{{media url='shoe-sale.jpg'}}```

Block ID

The Block ID markup tag is one of the easiest to use, and can be used to place a block directly on a CMS page, or even nested inside another block. You can use this technique to modify a block for different promotions or languages. The Block ID markup tag references a block by its identifier.

```{{block id='block-id'}}```

Template Tag

A template tag references a PHTML template file, and can be used to display the block on a CMS page or static block. The code in the following example can be added to a page or block to display the Contact Us form.

“Contact Us” Template Tag

```{{block type="core/template" name="contactForm"
template="contacts/form.phtml"}}```

The code in the next example can be added to a page or block to display the a list of products in a specific category, by category ID.

“Category Product List” Template Tag

```{{block type="catalog/product_list" category_id="22"
template="catalog/product/list.phtml"}}```
Non-Inline CSS Tag

Because many email clients do not support CSS, this markup tag provides a way to convert the CSS styles that are used in email and newsletter templates to inline styles. The tag references the non_inline_styles variable to point to a CSS file on the server for the styles to be converted. The styles that are non-inline are copied to the <styles> tag of each message or newsletter that is sent. This tag can be used only with templates for transactional email and newsletters. To learn more, see the developer documentation.

{{var non_inline_styles.css}}

Widget Code

The Widget tool can be used to display lists of products, or to insert complex links, such as one that goes to a specific product page, based on product ID. The code that is generated includes the block reference, location of the code module, and corresponding PHTML template. After the code is generated, you can copy and paste it from one place to another.

The code in the following example can be added to a page or block to display the list of new products.

“New Products Grid” Code

{{widget type="catalog/product_widget_new" display_type="new_products" products_count="10" template="catalog/product/widget/new/content/new_grid.phtml"}}

The code in the next example can be added to a page or block to display a link to a specific product, by product ID.

“Link to Product” Code

{{widget type="catalog/product_widget_link" anchor_text="My Product Link" title="My Product Link" template="catalog/product/widget/link/link_block.phtml" id_path="product/31"}}
Using Markup Tags in Links

You can use markup tags with HTML anchor tags, and link directly to any page in your store. The link can be incorporated into CMS content, such as a page, static block, banner, or email template. You can also use this technique to link an image to a specific page.

Process Overview:
Step 1: Identify the Destination URL
Step 2: Add the Markup to the URL
Step 3: Complete the Anchor Tag

Step 1: Identify the Destination URL

If possible, navigate to the page that you want to link to, and copy the full URL from the address bar of your browser. The part of the URL that you need comes after the “dot com forward slash.” Otherwise, copy the URL Key from the CMS page that you want to use as the link destination.

Full URL to Category Page

http://mystore.com/apparel/shoes/womens
http://mystore.com/apparel/shoes/womens.html

Full URL to Product Page

http://mystore.com/apparel/shoes/womens/nine-west-pump
http://mystore.com/apparel/shoes/womens/nine-west-pump.html

Full URL to CMS Page

http://mystore.com/about-us

Step 2: Add the Markup to the URL

The Store URL tag represents the base URL of your website, and is used as a substitute for the “http address” part of the store URL, including the domain name and “dot com.” There are two versions of the tag, which you can use, depending on the results you want to achieve.

store direct_url  Links directly to a page.
store url  Places a forward slash at the end, so additional references can be appended as a path.
In the following examples, the URL Key is enclosed in single quotes, and the entire markup tag is enclosed in double curly braces. When used with an anchor tag, the markup tag is placed inside the double quotes of the anchor. To avoid confusion, you can alternate using single-and double quotes for each nested set of quotes.

1. If you are starting with a full URL, delete the “http address” part of the URL, up through and including the “dot.com forward slash.” In its place, type the Store URL markup tag, up through the opening single quote.

```
http://mystore.com/apparel/shoes/womens
{{store url='apparel/shoes/womens'}}
```

Store URL Markup Tag

Otherwise, type the first part of the Store URL markup tag, and paste the URL key or path that you copied earlier.

```
{{store url=' 
{{store url='apparel/shoes/womens'}}
```

Store URL Markup Tag with URL Key

2. To complete the markup tag, type the closing double quotes and double braces.

**Step 3: Complete the Anchor Tag**

1. Wrap the completed markup tag inside an anchor tag, using the markup tag instead of the target URL. Then, add the link text, and closing anchor tag.

```
<a href="{{markup tag goes here}}>Link Text</a>
```

Markup in Anchor Tag

2. Paste the completed anchor tag into the code of any CMS page, block, banner, or email template, where you want the link to appear.

```
<a href="{{store url='apparel/shoes'}}">Shoe Sale</a>
```

Complete Link with Markup
Listing Categories On Home Page

By default, Magento uses a CMS page for the home page. You can add a markup tag to the content of your home page to display a product list from a specific category.

To list a category on the home page:

1. On the Admin menu, select Catalog > Manage Categories.

2. In the category tree, select the category that you want to use. Take note of the category ID that appears in parentheses after the category title. For example: (ID:4)

3. On the Admin menu, select CMS > Pages. Then, open your homepage and do the following:
   a. In the panel on the left, select Content.
   b. In the editor, “comment out” the current code by enclosing it in beginning and ending comment tags.

   ```
   <!--
   (your current home page code)
   -->
   ```
   c. Paste the following markup tag into the editor, substituting the ID of the category that you want to appear:

   ```
   {{block type="catalog/product_list" name="home.catalog.product.list"
   ```
If you ever want to restore your previous home page, simply remove the comment tags from the original code, and comment out the markup tag. If you don’t plan to ever use the original code, it can be deleted from the page.

4. Click the **Save Page** button.
5. In the message at the top of the workspace, click the **Cache Management** link.
6. Select the checkbox for the invalid **Layout** cache. Then, click the **Submit** button to refresh the cache.
Design
Design

Your store’s theme is like a window dressing, and can be changed for a season or promotion. In this section, you will learn about page layouts, and how to apply a new theme to your store.

Page Layout
- Standard Layouts
- Storefront Examples
- Layout Updates
  - Placing a Block
  - Controlling Block Order
  - Standard Block Layout
- Layout Update Syntax
- Layout Update Examples
- XML Load Sequence

Page Setup
- HTML Head
- Page Header
- Page Footer

Your Store’s Theme
- Design Packages
- Theme Assets
  - CSS Settings
  - JavaScript Settings
- Responsive Design
  - Using the Default Theme
  - Installing a New Theme
- Changing UI Text
CHAPTER 35: Page Layout

Magento is an object-oriented environment with pages that are assembled from separate components. For some, this approach requires a slightly different way of thinking, because there isn’t a single HTML page that corresponds to any given page. After you understand the basics, you’ll appreciate working in such a flexible and fluid environment!

The layout of each page in your store consists of distinct sections, or containers, that define the header, footer, and content areas of the page. Depending on the layout, each page might have one, two, three columns, or more. You can think of the layout as the “floor plan” of the page.

Content blocks float to fill the available space, according to the section of the page layout where they are assigned to appear. You will discover that if you change the layout from a three-column to a two-column layout, the content of the main area expands to fill the available space, and any blocks that are associated with the unused sidebar seem to disappear. However, if you restore the three-column layout, the blocks reappear. This fluid approach, or liquid layout, makes it possible to change the page layout without having to rework the content. If you are used to working with individual HTML pages, you will discover that this modular, “building block” approach requires a different way of thinking.
Standard Layouts

1 Column

The “1 Column” layout can be used to create a dramatic home page with a large image or focal point. It’s also a good choice for a landing page, or any other page that has a combination of text, images, and video.

2 Columns with Left Bar

The “2 Columns with Left Bar” layout is often used for pages with navigation on the left, such as a catalog or search results pages with layered navigation. It is also an excellent choice for home pages that need additional navigation or blocks of supporting content on the left.

2 Columns with Right Bar

With a “2 Columns with Right Bar” layout, the main content area is large enough for an eye-catching image or banner. This layout is also often used for Product pages that have blocks of supporting content on the right.
3 Columns

The “3 Column” layout has a center column that is wide enough for the main text of the page, with room on each side for additional navigation and blocks of supporting content.

Empty

The “Empty” layout can be used to define custom page layouts. To learn more, see the Magento Design Guide.
Storefront Examples

The column dimensions are determined by style sheet of the theme. Some themes apply a fixed pixel width to the page layout, while others use percentages to make the page respond to the width of the window or device.

Most desktop themes have a fixed width for the main column, and all activity takes place within this enclosed area. Depending on your screen resolution, there is empty space on each side of the main column.

1 Column Layout

The content area of a “1 Column” layout spans the full-width of the main column. This layout is often used for a home page with a large banner or slider, or pages that require no navigation, such as a login page, splash page, video, or full-page advertisement.
2 Columns with Left Bar

The content area of this layout is divided into two columns. The main content column floats to the right, and the sidebar floats to the left.

![2 Columns Left Bar]

2 Columns with Right Bar

This layout is a mirror image of the other two-column layout. This time, the sidebar floats to the right, and the main content column floats to the left.

![2 Columns Right Bar]
3 Columns

A 3-column layout has a main content area with two side columns. The left side bar and main content column are wrapped together, and float as a unit to the left. The other side bar floats to the right.
Layout Updates

Before you begin working with custom layout updates, it is important to understand how the pages of your store are constructed, and the difference between the terms layout and layout update. The term layout refers to the visual and structural composition of the page. However, the term layout update refers to a specific set of XML instructions that determines how the page is constructed.

The XML layout of your Magento Community Edition store is a hierarchical tree of blocks. Some elements appear on every page, and others appear only on specific pages. You can see how these structural blocks are referenced by examining the layout update code for your home page. To do so, simply open your CMS home page in edit mode, and select the Design tab to view the Page Layout section. Depending on the theme, it might contain instructions to remove blocks, unset blocks, and add blocks by referencing specific areas of the page layout.

In many cases, the same result can be achieved with a widget. To place a CMS static block of content with a widget, you must identify the page, and location on the page, where you want the block to appear. You can use the Widget tool to place a block on any generic page of your store, including the home page and all CMS pages. However, to place a block in the sidebar of a specific CMS page, you must make a layout update.

---

1 The visual and structural composition of a page.
2 A specific set of XML instructions that determines how the page is constructed.
Placing a Block with a Layout Update

Blocks can be placed in the left or right column of a specific page by making a layout update to the XML code. With a few simple changes to the code, you can position the block in either column, and control its position in relation to other blocks.

As you work with the underlying code, you will encounter slightly different terminology. For example, the term callout\(^1\) is sometimes used to refer to a block that is defined as a layout update with XML code. The term sidebar\(^2\) refers to the left or right columns of the page layout. For our general discussion, we use the terms block and column. However, when entering layout update code, make sure to follow the syntax exactly as shown in the example.

**To place a block in a side column:**

1. On the Admin menu, select **CMS > Pages > Manage Content**.
2. Click to open the CMS page. Then, in the panel on the left, select **Design**.
3. In the Layout Update XML box, enter the code for the right or left sidebar, as shown in example. Then, do the following:
   a. Change the reference name to identify either the “right” or “left” column.
   b. Change the block_id to the identifier of the block to be placed.

   **Code for CMS Block in Side Column**

   ```xml
   <reference name="right">
   <block type="cms/block" name="right.permanent.callout">
   <action method="setBlockId"><block_id>your-block-id</block_id></action>
   </block>
   </reference>
   ```

4. When complete, click the **Save Page** button.

---

\(^1\) Sometimes used to describe an XML block of page layout code.

\(^2\) The right or left column of a two-column page layout.
Controlling Block Order

To control the order of blocks in an XML layout update, include a “before” or “after” positioning property in the code. To place a block—either before, or after a specific block—replace the hyphen with the block identifier, as shown in the following examples:

before="-"  Places the block at the top of the sidebar, before other blocks.

after="-"  Places the block at the bottom of the sidebar, after other blocks.

Code to Position CMS Blocks

```
<block type="cms/block" before="-" name="left.permanent.callout">
<block type="cms/block" before="some-other-block"
name="left.permanent.callout">
<block type="cms/block" after="-" name="left.permanent.callout">
<block type="cms/block" after="some-other-block"
name="left.permanent.callout">
```
Standard Block Layout

In the following diagram, the block names that can be used to refer to a block in the layout are black, and the block types, or block class paths, are blue.
## Block Descriptions

<table>
<thead>
<tr>
<th>BLOCK TYPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>page/html</td>
<td>There can be only one block of this type per page. The block name is &quot;root,&quot; and, it is one of the few root blocks in the layout. You can also create your own block and name it &quot;root,&quot; which is the standard name for blocks of this type.</td>
</tr>
<tr>
<td>page/html_head</td>
<td>There can be only one block of this type per page. The block name is &quot;head,&quot; and it is a child of the root block. This block must not be removed from layout.</td>
</tr>
<tr>
<td>page/html_notices</td>
<td>There can be only one block of this type per page. The block name is &quot;global_notices,&quot; and it is a child of the root block. If this block is removed from the layout, the global notices will not appear on the page.</td>
</tr>
<tr>
<td>page/html_header</td>
<td>There can be only one block of that type per page. The block name is &quot;header,&quot; and it is a child of the root block. This block corresponds to the visual header at the top of the page, and contains several standard blocks. This block must not be removed.</td>
</tr>
<tr>
<td>page/html_wrapper</td>
<td>Although included in the default layout, this block is deprecated, and only is included to ensure backward compatibility. Do not use blocks of this type.</td>
</tr>
<tr>
<td>page/html_breadcrumbs</td>
<td>There can be only one block of this type per page. The name of this block is &quot;breadcrumbs,&quot; and it is a child of the header block. This block displays breadcrumbs for the current page.</td>
</tr>
<tr>
<td>page/html_footer</td>
<td>There can be only one block of this type per page. The block name is &quot;footer,&quot; and it is a child of the root block. The footer block corresponds to the visual footer at the bottom of the page, and contains several standard blocks. This block must not be removed.</td>
</tr>
<tr>
<td>page/template_links</td>
<td>There are two blocks of this type in the standard layout. The &quot;top_links&quot; block is a child of the header block, and corresponds to the top navigation menu. The &quot;footer_links&quot; block is a child of the footer block, and corresponds to the bottom navigation menu. It is possible to manipulate the template links, as shown in the examples.</td>
</tr>
<tr>
<td>page/switch</td>
<td>There are two blocks of this type in a standard layout. The &quot;store_language&quot; block is a child of the header block, and corresponds to the top language switcher. The &quot;store_switcher&quot; block is a child of the footer block, and corresponds to the bottom store switcher.</td>
</tr>
</tbody>
</table>
Block Descriptions (cont.)

<table>
<thead>
<tr>
<th>BLOCK TYPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>core/messages</td>
<td>There are two blocks of this type in a standard layout. The &quot;global_messages&quot; block displays global messages. The &quot;messages&quot; block is used to display all other messages. If you remove these blocks, the customer won't be able to see any messages.</td>
</tr>
<tr>
<td>core/text_list</td>
<td>This type of block is widely used throughout Magento, and is used as a placeholder for rendering children blocks.</td>
</tr>
<tr>
<td>core/profiler</td>
<td>There is only one instance of this type of block per page. It is used for the internal Magento profiler, and should not be used for other purposes.</td>
</tr>
</tbody>
</table>

Layout Update Syntax

Custom layout updates can be applied to product category pages, product pages, and CMS page to achieve a variety of results, such as:

- `<block>` Create new block.
- `<reference>` Update existing content.
- `<action>` Assign actions to blocks.
- `<remove>` Remove blocks.

Any change made to the layout is applied when the associated entity—which can be either a product, category, or CMS page—becomes active in the frontend of the store.

Custom layout update instructions consist of well-formed XML tags, without the `<?xml ...?>` declaration and root tag. As with normal XML, every tag must either be empty or properly closed, as shown in the following examples:

```
<tag attribute="value" />
<tag attribute="value"> ... </tag>
```
<block>
Creates a new block within the current context. Layout block nesting defines the ordering of block initialization location of the blocks on the page.

Syntax

<table>
<thead>
<tr>
<th>NAME</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>type</td>
<td>* block class path</td>
</tr>
<tr>
<td>name</td>
<td>* block name identifier</td>
</tr>
<tr>
<td>before</td>
<td>block name</td>
</tr>
<tr>
<td>after</td>
<td>block name</td>
</tr>
<tr>
<td>template</td>
<td>template filename</td>
</tr>
<tr>
<td>as</td>
<td>block alias</td>
</tr>
</tbody>
</table>

An identifier of the block class path that corresponds to the class of the block. See the list of the available block types below.

A name that can be used to address the block in which this attribute is assigned. If you create a new block with the name that is the same as one of the existing blocks, your newly created block substitutes the previously existing block. See the list of names of existing blocks below.

Is used to position the block before a block with the name specified in the value. If "-" value used the block is positioned before all other sibling blocks.

Is used to position the block after a block with the name specified in the value. If "-" value used the block is positioned after all other sibling blocks.

A template filename used for the specific block type. As you have no way to see the list of template files, use whatever template value is demanded for every block type listed below.

An alias name by which a template calls the block in which this attribute is assigned. Sometimes it’s necessary to specify the alias for a specific block type.
<reference>
Changes the context for all included instructions to a previously defined block. An empty
<reference> tag if of no use, because it affects only the instructions which are children.

Syntax

<table>
<thead>
<tr>
<th>NAME</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>block name</td>
</tr>
</tbody>
</table>

A name of a block to reference.

<action>
Used to access block API, in other words, call block's public methods. It is used to set up the
execution of a certain method of the block during the block generation. Action child tags are
translated into block method arguments. The list of all available methods depends on the block
implementation (e.g. public method of the block class).

Syntax

<table>
<thead>
<tr>
<th>NAME</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>method</td>
<td>block method name</td>
</tr>
</tbody>
</table>

A name of the public method of the block class this instruction is
located in that is called during the block generation.

<remove>
Removes an existing block from the layout.

Syntax

<table>
<thead>
<tr>
<th>NAME</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>block name</td>
</tr>
</tbody>
</table>

The name of the block to be removed.

<extend>
This instruction performs final modifications to blocks which are already part of the layout.
Every attribute in the <block> instruction—except for the block name—is subject for change. In
addition, the special attribute parent can be used to change the parent of the block. Simply put
the name of the new parent block into the <extend> instruction, and the parent of the block
that is referenced will be changed in the layout.

Syntax

<table>
<thead>
<tr>
<th>NAME</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>block name</td>
</tr>
</tbody>
</table>

The name of any block to be extended.
Syntax (cont.)

<table>
<thead>
<tr>
<th>NAME</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>*</td>
<td>any other</td>
</tr>
<tr>
<td></td>
<td>Any other attribute specific for the &lt;block&gt; instruction.</td>
</tr>
<tr>
<td>parent</td>
<td>block name</td>
</tr>
<tr>
<td></td>
<td>The name of the block that should become a new parent for the</td>
</tr>
<tr>
<td></td>
<td>referenced block.</td>
</tr>
</tbody>
</table>

* Indicates a required value

Layout Update Examples

The following blocks types can be manipulated with custom layout instructions. Each action must be specified using the full syntax of the instruction. In the following examples, a simplified notation is used to refer to each action, which corresponds to the full syntax of the instruction.

Full Syntax

```xml
<!-- Action can be specified inside either a <block> or <reference> instruction. -->

<action method="someActionName">
    <arg1>Value 1</arg1>
    <arg2>Value 2</arg2>
    <!-- -->
    <argN>Value N</argN>
</action>

<!-- -->
```

Simplified Syntax

```php
someActionName($arg1, $arg2, ..., $argN)
```
**page/template_links**

**Syntax**

<table>
<thead>
<tr>
<th>ACTION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>addLink($label, $url, $title, $prepare)</td>
<td>Adds another link to the end of the list of existing links. Just specify the $label (link caption), $url (link URL) and $title (link tooltip), and you'll see a new link in the corresponding place. The $prepare parameter must be &quot;true&quot; if you want the URL to be prepared, or converted to the full URL from the shortened URL. For example, the new page becomes BASE_URL/newpage if prepared.</td>
</tr>
</tbody>
</table>

| removeLinkByUrl($url) | Removes a link from the block by its URL. Note that the URL must be properly specified and exactly match corresponding URL of the link you want to remove. |

**cms/block**

**Syntax**

<table>
<thead>
<tr>
<th>ACTION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>setBlockId($blockId)</td>
<td>Specifies the ID of a CMS block, so its content can be fetched and displayed when the page is rendered.</td>
</tr>
</tbody>
</table>

```xml
?<reference name="content">
   <block type="cms/block" name="additional.info" as="additionalInfo">
      <action method="setBlockId"><id>additional_info</id></action>
   </block>
</reference>```

```xml`
**core/text**

A *core/text* block can be used to enter free form text directly into the template.

**Syntax**

<table>
<thead>
<tr>
<th>ACTION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>addText($textContent)</td>
<td>Specifies text to be rendered as the block's content. After the text is specified, the layout update instructions must continue to be a valid XML statement. If you use HTML tags as part of the text, it is recommended to use: ![CDATA[...]]&gt;</td>
</tr>
</tbody>
</table>

```xml
<reference name="content">
    <block type="core/text" name="test.block">
        <action method="addText">
            <txt><![CDATA[<h2>ATTENTION!</h2><p>Check your options carefully before you submit.</p>]]></txt>
        </action>
    </block>
</reference>
```

**page/html_welcome**

This block can be used to duplicate the “Welcome, `<USERNAME>`!” message that appears in the header block. When the user is not logged in, the *welcome message* specified in the configuration appears.
XML Load Sequence

For developers, it is important to understand that blocks and layout updates must be loaded in the correct order, in keeping with the rules of precedence and **load sequence** which determine how the page is rendered. Magento supports the following page layout scenarios:

- **Default Layout**
  The default layout consists of the visual elements that are visible from every page of the store. Whether it is a menu item, or a shopping cart block, each item has a **handle** in the default section of the layout definition.

- **Changes to Specific Pages**
  The second case allows you to create a different layout for a specific page. The XML layout for specific pages is constructed in the same sequence that Magento loads modules, and is determined by the system configuration.

  In addition to the instructions in the layout update files which are specific to each module, you can make a custom layout update that applies to a special case in the backend, and is merged each time the special case occurs.

---

1. The order scripts are loaded into memory. To work correctly, some scripts must be loaded before others.

2. In programming, a name used to reference an object.
CHAPTER 36:  

Page Setup

The main sections of the page are controlled, in part, by a set of standard HTML tags. Some of these tags control the selection of fonts, color, size, and background colors and images that appear in each section of the page. Other settings control page elements such as the logo that appears in the header, and the copyright notice in the footer. The basic page properties of an HTML page can be set from the Admin. Topics include:

- HTML Head
- Header
- Footer
HTML Head

The settings in the HTML Head section correspond to the <head> tag of an HTML page and can be configured for each store view. In addition to meta data for the page title, description, and keywords, the section includes a link to the favicon, and miscellaneous scripts. Instructions for search engine robots and the display of the store demo notice are also configured in this section.

To configure the HTML Head:

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under General, select Design.

2. If you have multiple stores or views, set the Current Configuration Scope in the upper-left corner to the store or view where the configuration applies. Then, clear the checkbox after each field so new values can be entered.

3. Update the fields as needed.

4. When complete, click the Save Config button.
### Field Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Favicon Icon</td>
<td>Store View</td>
<td>Uploads the small graphic image that appears in the address bar and tab of the browser.</td>
</tr>
<tr>
<td>Default Title</td>
<td>Store View</td>
<td>The title that appears at the title bar of each page when viewed in a browser. The default title is used for all pages, unless another title is specified for individual pages.</td>
</tr>
<tr>
<td>Title Prefix</td>
<td>Store View</td>
<td>A prefix can be added before the title to create a two- or three-part title. A vertical bar or colon can be used as a separator at the end of the prefix to differentiate it from the text of the main title.</td>
</tr>
<tr>
<td>Title Suffix</td>
<td>Store View</td>
<td>A suffix can be added after the title to create a two- or three-part title. A vertical bar or colon can be used as a separator at the end of the prefix to differentiate it from the text of the main title.</td>
</tr>
<tr>
<td>Default Description</td>
<td>Store View</td>
<td>The description provides a summary of your site for search engine listings and should not be more than 160 characters in length.</td>
</tr>
<tr>
<td>Default Keywords</td>
<td>Store View</td>
<td>A series of keywords that describe your store, each separated by a comma.</td>
</tr>
<tr>
<td>Default Robots</td>
<td>Store View</td>
<td>Instructions that tell search engines how to index your site. Options include: INDEX, FOLLOW NOINDEX, FOLLOW INDEX, NOFOLLOW NOINDEX, NOFOLLOW</td>
</tr>
<tr>
<td>Miscellaneous Scripts</td>
<td>Store View</td>
<td>An input box that where you can upload miscellaneous scripts to the server. For example, any third-party JavaScript that must be placed before the &lt;body&gt; tag, can be entered here.</td>
</tr>
<tr>
<td>Display Demo Store Notice</td>
<td>Store View</td>
<td>Controls the display of the demo store notice at the top of the page. Options include: Yes / No</td>
</tr>
</tbody>
</table>
Header

The Header section identifies the path to the logo file, and specifies the logo alt text and welcome message.

To configure the header:

1. On the Admin menu, select **System > Configuration**.
2. In the panel on the left, under General, select **Design**.
3. Click to expand the **Header** section. Then, make any changes necessary.
4. When complete, click the **Save Config** button.

### Field Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Logo Image Src</td>
<td>Store View</td>
<td>Identifies the path to the logo that appears in the header.</td>
</tr>
<tr>
<td>Logo Image Alt</td>
<td>Store View</td>
<td>The Alt text that is associated with the logo.</td>
</tr>
<tr>
<td>Small Logo Image Src</td>
<td>Store View</td>
<td>Identifies the path to a smaller version of the logo that is used with responsive themes and optimized for a small screen.</td>
</tr>
<tr>
<td>Welcome Text</td>
<td>Store View</td>
<td>The welcome message appears in the header of the page and includes the name of customers who are logged in.</td>
</tr>
</tbody>
</table>
Footer

The Footer configuration section is where you can update the copyright statement that appears at the bottom of the page, and enter miscellaneous scripts.

### Field Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copyright</td>
<td>Store View</td>
<td>The copyright statement that appears at the bottom of each page. To include the copyright symbol, use the HTML character entity: ©</td>
</tr>
<tr>
<td>Miscellaneous HTML</td>
<td>Store View</td>
<td>An input box where you can upload miscellaneous scripts to the server. For example, third-party JavaScript—such as an analytics tracking code—that must be placed after the &lt;body&gt; tag, can be entered here.</td>
</tr>
</tbody>
</table>
CHAPTER 37:

Your Store’s Theme

A theme is a collection of files that determines the visual presentation of your store. You might think of a theme as the “window dressing” of your store. When you first install Magento Community Edition, the design elements of the store are based on the “Default” Theme. In addition to the initial default theme that comes with your Magento installation, there is a wide variety of themes that are available “off the shelf” on Magento Connect.

Magento themes include layout files, template files, translation files, and skins. A skin is a collection of supporting CSS, images, and JavaScript files that together, create the visual presentation and interactions that your customers experience when they visit your store. Themes and skins can be modified and customized by a developer or designer who has knowledge of Magento theme design and access to your server. Topics in this chapter include:

- Design Packages
- Theme Assets
- CSS Settings
- JavaScript Settings
- Responsive Design
- Using the Default Theme
- Installing a New Theme
- Changing UI Text

To learn advanced techniques such as how to use themes, skins, layouts, and blocks, see the Magento Design Guide.
Design Packages

A design package is simply a collection of related themes. There can be any number of design packages installed, but there must always be one that serves as the base package for the installation. The base package is named “default.”

Each package contains a default theme. In addition, the package might contain any number of variations of the default theme. Themes contain the files that determine the visual presentation of each page, and how the elements on the page interact with the user. Magento themes contain templating information (layout files, template files, theme-specific translation files) and skinning information (CSS files, images, and theme-specific JavaScript files). Each theme can belong to only one design package.

Packaging Variations

You can also set up exceptions to dynamically change the package when a specific user agent, such as a mobile device, tablet, or desktop browser, is detected. Exceptions can also be applied at the theme level. The names that are used to identify user agents are constantly evolving, along with the technology. You can search on the Internet for a list of user agent strings.

For an installation with multiple stores, each store in the hierarchy can have a separate theme, share the same theme, or a combination of both. The design package and theme can be assigned at either the website and/or store view level. If you assign a package at the website level, all stores in the website inherit the package. To override the default package, you can assign a different package at the store, or store view level. If no additional packages are available, the system falls back to the default package.

Before a design package can be assigned, it must be copied to the server. If you purchase and install a design package or theme from Magento Connect, the necessary files are copied to your server automatically. However, it might need to update the configuration with the name of the package, theme, or both. The developer of any design package or theme typically provides specific configuration instructions.
To assign a design package:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under General, select Design.

2. Click to expand the Package section, and do the following:

   ![Package section]

   a. To assign the package to a specific store view, set the Current Configuration Scope in the upper-left corner to the store view where the configuration applies. Then, clear the Use Default checkbox next to the Current Package Name field.

   b. Enter the Current Package Name in lower-case characters.

3. To add an exception for a specific user agent, click the Add Exception button. Then, do the following:

   a. In the Matched Expression field, enter the standard name for the user agent to be matched. For multiple entries, separate each with a vertical bar.

   b. In the Value field, enter the name of the package to be used as the exception.

   c. Repeat these steps to add as many exceptions as necessary.

   ![Add Exception section]

4. When complete, click the Save Config button.

5. When prompted to update the cache, click the Cache Management link and follow the instructions.
Theme Assets

The assets associated with a theme are organized in the skin folder. JavaScript libraries which are shared across themes, are placed in the js/ directory at the Magento root.
### Theme Assets

<table>
<thead>
<tr>
<th>FILE TYPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>CSS</td>
<td>Contains the CSS files that control the visual styling associated with the skin. Path on server: <code>[magento]/skin/frontend/[designPackage]/[theme]/css</code></td>
</tr>
<tr>
<td>Images</td>
<td>Contains all images used by the theme, including buttons, background textures, and so on. Path on server: <code>[magento]/skin/frontend/[designPackage]/[theme]/images</code></td>
</tr>
<tr>
<td>JS</td>
<td>Contains theme-specific JavaScript routines and callable functions. Path on server: <code>[magento]/skin/frontend/[designPackage]/[theme]/js</code></td>
</tr>
</tbody>
</table>
CSS Settings

As part of an effort to optimize your site and reduce page load time, you can reduce the number of separate CSS files by merging them into a single condensed file. If you open a merged CSS file, you’ll find one continuous stream of text, with line breaks removed. Because you can’t edit the merged file, it’s best to wait until you are out of the development mode, and no longer making frequent changes to the CSS.

To merge CSS files:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Advanced, select Developer.
2. Click to expand the CSS Settings section.
3. Set Merge CSS Files to “Yes.”
4. When complete, click the Save Config button.

JavaScript Settings

Multiple JavaScript files can be merged into a single, condensed file to reduce page load time. If you open a merged JavaScript file, you’ll find one continuous stream of text, with line breaks removed. If you are finished with the development process, and the code contains no errors, you might consider merging the files.

To merge JavaScript files:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Advanced, select Developer.
2. Click to expand the JavaScript Settings section.
3. Set Merge JavaScript Files to “Yes.”
4. When complete, click the Save Config button.
Responsive Design

Responsive design is an approach to web page creation that flows the page layout to fit the visitor’s screen size and orientation, and changes the layout accordingly. The Magento default responsive theme features style sheets that support flexibility for layouts and images, and helps provide a pleasing experience for site visitors using mobile devices. By comparison, non-responsive sites or sites not optimized for smaller screens or mobile devices are often slow or difficult to read, and offer a clunky experience on mobile devices.

Responsive Theme on Tablet and Smartphone

Benefits of using the Magento default responsive theme include:

- You can get a tablet and smart phone friendly responsive site in about half the time as before, speeding time to market and freeing up resources for other projects.
- Your responsive site makes you better able to participate in the fast growing mobile commerce space, and gives you the ability to create a website that is more easily adapted to new opportunities and less expensive to maintain. A responsive site also offers potential search engine optimization (SEO) benefits from using Google’s preferred approach to mobile-optimizing sites.
- You no longer need to develop separate content per device. The default theme is easy to customize for simple sites, and provides a powerful starting point for developing themes for more complex sites.

To learn more about creating custom responsive themes, see the Responsive Theme Developer’s Guide.
Using the Default Theme

The default Magento Community Edition theme is based on a responsive design that renders the display of your storefront for different devices. The theme incorporates best practices for mobile sites and experiences.

Technologies used in Magento’s default responsive theme include Sass/Compass\(^1\) and jQuery\(^2\) in noConflict() mode. Additional JavaScript libraries are discussed in more detail in the Responsive Theme Developer’s Guide. The responsive theme code is located on the server in the following directories, relative to your Magento installation:

**Code Location**

```
app/design/frontend/rwd
skin/frontend/rwd
```

---

\(^1\)A CSS pre-compiler that provides organizable, reusable CSS.

\(^2\)A popular JavaScript library that is often used to create dynamic and responsive effects.
To view the default theme:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under General, select Design.

2. Click to expand the Package section. The new responsive theme is enabled by default, and the default package name is “rwd.”

3. Click to expand the Themes section. The Default theme name is “default” (although the field appears blank).

4. When complete, click the Save Config button.
Installing a New Theme

When you first install Magento, the design elements of the store are based on the “Default” Theme. You can modify the theme, add themes created by others, or create new ones. To learn more, see the Designer’s Guide to Magento.

Magento Connect contains hundreds of extensions, which are add-ons to Magento that can extend the functionality or enhance the appearance of your store. The following example shows how to add a mobile theme from Magento Connect.

To install a new theme:

1. Go to Magento Connect.
2. In the upper-right corner, click to extend the All Platforms list, and choose Enterprise.
3. You can browse through the available themes based on price or popularity, or do a keyword search. For more information, click the thumbnail of any theme.
4. To get the registration key, you must be a registered Magento Community Edition owner and be logged into your account. Then, click the Install Now button to get the license key.
5. To complete the process, follow the instructions to install an extension from Magento Connect.

To activate the theme for your store:

1. On the Admin menu, select **System > Configuration**. In the panel on the left under General, select **Design**.

2. Click to expand the **Themes** section. Then, do the following:

3. In the **Default** field, enter the name of the theme. The name of the Magento demo store theme is “mds.”
4. If you want to use an alternate theme for different browsers or devices, do the following:

a. Click the **Add Exception** button.

   The Add Exception button is used to use a different theme for specific browsers. For example, a theme that is optimized for mobile can be used whenever a mobile device is detected.

![Add Exception](image)

   **Add Exception**

b. In the **Matched Expression** field, enter the name of the browser or device that triggers the use of the alternate theme. If there are multiple browsers, separate the name of each with a vertical bar. For example, because the mobile theme can be used with multiple devices, you can enter them all in the Match Expression field, as follows:

   Android|Blackberry|Googlebot-Mobile|iPhone|iPod|mobi|Palm|Opera Mini|Windows Mobile

   c. In the **Value** field, enter the name of the theme. In this example, the value is “Mobile.”

5. Click the **Save Config** button on the top right of the page.

6. Test the new theme from your store. If you installed an exception for different browsers, view the store with each browser or device.

   If the new theme uses a different page layout than your current home page, you might need to change its **page layout setting** to match the theme.
Changing UI Text

You can use the Translate Inline tool to touch up the text in the interface to reflect your voice and brand. When the Translate Inline mode is activated, all text on the page that can be edited is outlined in red. It’s easy to edit field labels, messages, and other text that appears throughout the storefront and Admin. For example, many themes use terminology such as “My Account,” “My Wishlist,” and “My Dashboard,” to help customers find their way around. However, you might prefer to simply use the words “Account,” “Wishlist,” and “Dashboard.”

If your store is available in multiple languages, you can make fine adjustments to the translated text for the locale. On the server, interface text is maintained in a separate CSV file for each output block, and is organized by locale. As an alternate approach, rather than use the Translate Inline tool, you can also edit the CSV files directly on the server.

To use the Translate Inline tool, your browser must allow pop-ups.

Step 1: Add Your IP Address to the Developer Mode Whitelist

To use the Inline Translator without disrupting the shopping experience of customers in the store, add your IP address to the Developer Client Restrictions whitelist. If you don’t know your IP address, you can search for it online.

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Advanced, select Developer.

2. Click to expand the Developer Client Restrictions section.

3. In the Allow IPs field, enter your IP address. If access is needed from multiple IP addresses, separate each with a comma.

4. When complete, click the Save Config button.

Step 2: Disable Output Caches

1. On the Admin menu, select System > Cache Management.

2. Select the following checkboxes:
   - Blocks HTML output
   - Translations

3. Set the Actions control to “Disable.” Then, click the Submit button.
Step 3: Activate the Translate Inline Tool

1. On the Admin menu, select **System > Configuration**.

2. To work with a specific store view, set **Current Configuration Scope** to the store view to be updated.

3. In the panel on the left under Advanced, select **Developer**.

4. Click to expand the **Translate Inline** section. Then, do the following:

   a. Set **Enabled for Frontend** to “Yes.”
   
      For a specific store view, you must first clear the **Use Website** checkbox. The Enabled for Admin option is not available when editing a store view.

5. When complete, click the **Save Config** button.

Step 4: Update the Text

1. Open your storefront in a browser, and go to the page that you want to edit. If necessary, select the store view from the language switcher in the upper-left corner.

   Each string of text that can be translated is outlined in red. When you hover over any text box, a book icon 📘 appears.
2. Click the book icon 📖 to open the Translation window. Then, do the following:
   a. If the change is for a specific store view, select the **Store View Specific** checkbox.
   b. Enter the **Custom** text.
   c. Click the **Submit** button.

3. To see your changes in the store, press the **F5** key to refresh the browser.

4. Repeat this process for any elements in the store to be changed.
Step 5: Restore Original Settings

1. On the Admin menu, select System > Developer.
   a. In the panel on the left under Advanced, select Developer.
   b. Click to expand the Translate Inline section.

   ![Translate Inline]

   a. Set Enabled for Frontend to “No.”
   b. Click the Save Config button.

2. On the Admin menu, select System > Cache Management. Then, do the following:
   a. Select the following checkboxes:
      - Blocks HTML output
      - Translation
   b. Set the Actions control to “Enable.” Then, click the Submit button.

   ![Enable Output Caches]
Customers

Learn why customers should be encouraged to register for an account with your store, and how to create customer groups that can be referenced in promotional price rules and tax classes.

Customer Accounts
- Customer Account Login
- Account Dashboard
- Account Configuration
  - Account Scope
  - Login Landing Page
  - Name and Address Options
  - Address Templates
  - Password Options

Customer Groups
- Creating a Customer Group
CHAPTER 38: 

Customer Accounts

The header of every page in your store extends an invitation for shoppers to “Log in or register” for an account with your store. Customers who open an account with your store enjoy a range of benefits, including:

- Faster Checkout
  Registered customers move through checkout faster because much of the information is already in their accounts.

- Ability to Self-Serve
  Registered customers can update their information, check the status of orders, and even reorder from their account dashboard.
Customer Account Login

Customer have easy access to their accounts from every page in your store. Depending on the configuration, customers can be redirected to their account dashboard, or continue shopping after they log in to their accounts. When customers forget their passwords, a reset link is sent to the email address that is associated with the account.

To log in to your customer account:

1. From the header of your store, click the Log in link.
2. When prompted, enter the Email Address that is associated with your account, and your Password. Then, click the Log In button.

To reset your password:

1. From the Login page, click the Forgot Your Password? link.
2. When prompted, enter the Email Address that is associated with your account, and click the Submit button.

   If the email address you entered matches the one that is associated with the account, you will receive a "Password Reset Confirmation" email with a link to reset your password.

3. Click the link in the email, and when prompted, enter your New Password. Enter it again to confirm, and click the Reset a Password button.

   Your new password must be six or more characters in length, without spaces.

After you are notified that the password has been updated, you can use the new password to log in to your account.
Account Dashboard

Customers can access their account dashboard by clicking the “My Account” link in the header of the store. They can use their account dashboard to view and modify their information, including past and current addresses, billing and shipping preferences, newsletter subscriptions, wishlist, and more.

<table>
<thead>
<tr>
<th>SECTION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account Information</td>
<td>Customers can update their account information and change their password, as needed.</td>
</tr>
<tr>
<td>Address Book</td>
<td>The customer address book includes the default billing and shipping address, and additional address entries.</td>
</tr>
<tr>
<td>My Orders</td>
<td>Displays a list of all customer orders, with a link to each. If enabled in the configuration, any order can be reordered by simply clicking the Reorder link.</td>
</tr>
<tr>
<td>Billing Agreements</td>
<td>Displays a list of any customer billing agreements.</td>
</tr>
<tr>
<td>Recurring Profiles</td>
<td>Displays a list of any products that are purchased on a recurring basis, as a subscription.</td>
</tr>
<tr>
<td>My Product Reviews</td>
<td>Displays a list of all product reviews submitted by the customer, with a link to each.</td>
</tr>
</tbody>
</table>
### Dashboard Sections

<table>
<thead>
<tr>
<th>SECTION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>My Wishlist</td>
<td>Displays the customer's wishlist. Products from the wishlist can be added to the cart.</td>
</tr>
<tr>
<td>My Applications</td>
<td>This section is a placeholder for API applications that link the customer account to other applications or extensions.</td>
</tr>
<tr>
<td>Newsletter Subscriptions</td>
<td>Lists all available newsletters. Those to which the customer is currently subscribed have a checkmark.</td>
</tr>
<tr>
<td>My Downloadable Products</td>
<td>Lists all downloadable products the customer has purchased, with a link to each.</td>
</tr>
</tbody>
</table>
Account Configuration

The customer account configuration settings determine the information that you collect during customer registration, and the experience customers have during the process.

Customer Account Scope

The scope of customer accounts can be limited to the website where the account was created, or shared with all websites and stores in the store hierarchy.

To set the scope of customer accounts:

1. On the Admin menu, select System > Configuration.
2. In the panel on the left, under Customers, select Customer Configuration.
3. Click to expand the Account Sharing Options section.
4. Set Share Customer Accounts to one of the following:
   - Global: To share customer account information with every website and store in the Magento installation.
   - Per Website: To limit customer account information to the website where the account was created.
5. When complete, click the Save Config button.
Login Landing Page

Depending on the configuration, customers can be redirected to their account dashboard, or continue shopping after they log in to their accounts.

To set the login landing page:

1. On the Admin menu, select System > Configuration.
2. In the panel on the left, under Customers, select Customer Configuration.
3. Click to expand the Login Options section.
4. Set Redirect Customer to Account Dashboard after Logging in to one of the following:
   
   Yes  
   The account dashboard appears when customers log in to their accounts.

   No  
   Customers can continue shopping after logging in to their accounts.

5. When complete, click the Save Config button.
Name and Address Options

The fields that are included in the customer registration form, and the format of the street address are set in the Customer Configuration. When all fields are used, the registration form includes the full name, including the middle initial, with drop-down lists for the prefix and suffix. The registration form can also include the date of birth, gender, and Tax ID or VAT number.

To configure the customer name and address:

1. On the Admin menu, select **System > Configuration**.
2. In the panel on the left, under Customer, select **Customer Configuration**.
3. Click to expand the **Name and Address Options** section.
4. Enter the **Number of Lines in a Street Address**. If left blank, the street address defaults to 2.

5. To include a prefix before the name, do the following:
   a. Set **Show Prefix** to one of the following:
      - Optional
      - Required
   b. In the **Prefix Dropdown Options** field, enter each prefix that you want to appear in the list, separated by a semicolon. Place a semicolon before the first value to display an empty value at the top of the list.

6. To include a suffix after the name, do the following:
   a. Set **Show Suffix** to one of the following:
      - Optional
      - Required
   b. In the **Suffix Dropdown Options** field, enter each prefix that you want to appear in the list, separated by a semicolon. Place a semicolon before the first value to display an empty value at the top of the list.

7. To include additional fields, do the following:
   a. Set **Show Date of Birth** to “Yes.”
   b. Set **Show Tax/VAT Number** to “Yes.”
   c. Set **Show Gender** to “Yes.”

8. When complete, click the **Save Config** button.
Customer Address Templates

The store administrator can modify the address templates that control the format of the customer billing and shipping addresses that appear in the following locations:

- General customer billing and shipping address format
- Shipping and billing addresses in customer’s address book (available during the shopping cart checkout)
- Address format for PDF sales documents, such as invoices, shipments, and refunds

Example 1: Text Templates

For Text, Text One Line, HTML and PDF Address Templates

```
{{depend address attribute code}} a space, a character, or UI label
{{/depend}};

{{if address attribute code}}{{var address attribute code}} a space, a character, or UI label
{{/if}}
```

Example 2: JavaScript Template

For JavaScript Address Template

```
#{address attribute code} or User Interface label #{address attribute code}
```
Address Templates

To change the order of address fields:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Customers, select Customer Configuration.

2. Click to expand the Address Templates section. The section includes a separate set of formatting instructions for each of the following:
   - Text
   - Text One Line
   - HTML
   - PDF
   - JavaScript Template

3. Edit each template as needed, using the examples below for reference.

4. When complete, click the Save Config button.
Password Options

The customer password options determine the email templates that are used when customers forget their passwords, and the lifetime of the password recovery link. You can allow customers to change their own passwords, or require that only store administrators can do so.

**To configure customer password options:**

1. On the Admin menu, select **System > Configuration**.
2. In the panel on the left under Customers, select **Customer Configuration**.
3. Click to expand the **Password Options** section. Then, do the following.

   ![Password Options](image)

   **Password Options**

   a. Set **Forgot Email Template** to the template that is used for the email sent to customers who have forgotten their passwords.

   b. Set **Remind Email Template** to the template that is used when a password hint is sent to customers.

   c. Set **Forgot and Remind Email Sender** to the **store contact** that appears as the sender of the Forgot Email and Remind Email notifications.

   d. In the **Recovery Link Expiration Period** field, enter the number of days before the password recovery link expires.

   e. To require that only the store administrator can change customer passwords, set **Require admin user to change user password** to “Yes.”

4. When complete, click the **Save Config** button.
CHAPTER 39:

Customer Groups

The customer group determines which discounts are given to a customer, as defined by price rules, and the tax class that is associated with the group. The default customer groups are:

- General
- Not Logged In
- Wholesale
Creating a Customer Group

Customer groups can be referenced in promotional price rules and associated with specific tax classes. Follow these steps to create customer groups you can use to increase sales.

To create a customer group:

1. On the Admin menu, select Customers > Customer Groups.

![Customer Groups](image)

2. To create a new group, click the Add New Customer Group button. Then, do the following:
   a. Enter a unique Group Name to identify the group from the Admin. The name must be less than 32 characters.
   b. Select the Tax Class that applies to the group.

![Group Information](image)

3. When complete, click the Save Customer Group button.

To edit a customer group:

1. On the Admin menu, select Customers > Customer Groups.
2. In the list, click to open the record.
3. Make the necessary changes.
4. When complete, click the Save Customer Group button.
Sales

The focus of this section is what happens after a customer places an order. You will learn how to offer shopping cart assistance, fulfill orders, print invoices, collect payment, process credit memos, manage returns, and more.

Shopping Cart
  Cart Configuration
  Redirect to Cart
  Quote Lifetime
  Minimum Order
  Shopping Cart Thumbnails
  My Cart Link
  Mini Cart
  Persistent Cart

Shopping Assistance
  View Online Customers
  Update a Shopping Cart
  Create an Order
  Create a Customer Account

Checkout
  Checkout Process
  Checkout Method
    One Page Checkout
  Order Review
  Terms and Conditions
  Order Confirmation

Sales Communications
  Setting Up Sales Email
  PDF Logo Requirements
  Adding Reference IDs

Managing Orders
  Process Overview
  Order Stages
  Order Status
    Custom Order Status
  Order Workflow

Order Fulfillment
  Invoice an Order
  Print Invoices
  Ship an Order
    Print Packing Slips
  Transactions

Credit Memos & Refunds
  Product Return Workflow
  Create Credit Memo
    Print Credit Memo

Payments
  Basic Payment Methods
  PayPal Payment Solutions
  Payment Gateways
  Payment Services

Shipping
  Basic Shipping Methods
  Shipping Carriers
  Shipping Labels

Taxes
  Managing Taxes
  Value Added Tax (VAT)
  Quick Reference
CHAPTER 40:

Shopping Cart

The shopping cart is positioned at the end of the path to purchase, at the intersection of “Buy” and “Abandon.” It is perhaps, the most important page in the store. The cart is where the order total is calculated, along with discount coupons and estimated shipping and tax. It’s a great place to show your trust badges and seals, and an ideal opportunity to offer one last item. You can choose the items to be offered as a cross-sell impulse purchase whenever a specific item appears in the cart.

![Shopping Cart](image-url)
Cart Configuration

The shopping cart configuration determines when the customer is directed to the cart page, and which images are used for product thumbnails. You can require an order to reach a minimum amount before the checkout process begins, specify the number of days a quoted prices remain valid, and control the order of items in the Totals section.

Redirect to Cart

The shopping cart page can be configured to appear whenever an item is added to the cart, or only when customers choose to go to the page. The basic information about the items currently in the cart is always available in the mini cart. The decision is a matter of balancing the benefits letting customers continue shopping, with the benefit of encouraging customers to proceed to checkout. If might be simply a matter of personal preference. However, if you want back it up with numbers, you can run an A/B test to see which approach produces a higher conversion rate.

To configure when the cart appears:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Sales, choose Checkout.
2. Expand the Shopping Cart section.
3. Set After Adding a Product Redirect to Shopping Cart to your preference.
4. Click the Save Config button.
Quote Lifetime

You can determine how long a price is valid by setting the shopping cart quote lifetime. For example, if a shopper leaves a cart unattended for several days, the price of some items might change. By default, the quote lifetime is set to thirty days.

To configure the quote lifetime:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Sales, choose Checkout.
2. Click to expand the Shopping Cart section.
3. In the Quote Lifetime (days) field, enter the number of days that a quoted price remains valid.
4. When complete, click the Save Config button.
Minimum Order

Order subtotals can be required to meet a minimum amount, after any discounts have been applied. Orders shipped to multiple address can be required to meet the minimum order amount per address. The Proceed to Checkout button becomes available only when the minimum order amount is reached.

To configure the minimum order amount:

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under Sales, choose Sales.

2. Click to expand the Minimum Order Amount section. Then, do the following:

   a. To require a minimum order amount, set Enable to “Yes.”

   b. Enter the Minimum Amount required for the subtotal, after discounts are applied.

   c. To display a message at the top of the shopping cart that differs from the default, enter the text in the Description Message box. Leave blank to use the default message.

   d. To display an error message that differs from the default, enter the text in the Error to Show in Shopping Cart box.

   e. To require that each address in a multi-address order meet the minimum order amount, set Validate Each Address Separately in Multi-address Checkout to “Yes.”

   f. To display a message at the top of the shopping cart that differs from the default for orders shipped to multiple addresses that do not meet the minimum order requirement, enter the text in the Multi-address Description Message box.
g. To display an error message that differs from the default for orders shipped to multiple addresses that do not meet the minimum order amount, enter the text in the **Multi-address Error to Show in Shopping Cart** box.

3. When complete, click the **Save Config** button.
Shopping Cart Thumbnails

The thumbnail images in the shopping cart give customers a quick overview of the items they are about to purchase. However, for products with multiple options, the standard product image may not match the actual item being purchased. If the customer purchased a pair of red shoes, ideally, the thumbnail in the shopping cart should show the product in the same color.

The thumbnail image for both grouped and configurable products can be set to display the image from either the “parent” product record or associated product. The setting applies to all grouped or configurable products in the current store view.

![Shopping Cart Thumbnails](image)
To configure shopping cart thumbnails:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Sales, choose Checkout.

2. Click to expand the Shopping Cart section, do the following:

   ![Shopping Cart](image)

   a. Set Grouped Product Image to one of the following:
      - Product Thumbnail Itself
      - Parent Product Thumbnail

   b. Set Configurable Product Image to one of the following:
      - Product Thumbnail Itself
      - Parent Product Thumbnail

3. When complete, click the Save Config button.
My Cart Link

The My Cart Link setting determines if the number in parentheses represents the number of line items in the cart, or the total quantity of items in the cart.

To configure the My Cart link:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Sales, choose Checkout.
2. Click to expand the My Cart Link section.
3. Set Display Cart Summary to one of the following:
   - Display number of items in cart
   - Display items quantities
4. When complete, click the Save Config button.
Mini Cart

The mini cart is a widget that appears in the upper-right corner of the page. The mini cart allows customers to examine an item in detail, edit the quantity, delete items, view the full-size cart, or go to checkout. The number indicates how many items are currently in the cart. To learn more, see: Mini Shopping Cart Widget.

To display the mini cart:

In the upper-right corner of the storefront, click the shopping cart icon. Then, do any of the following:

- To see more information about an item, click Details.
- To go to the product page, click the product name.
- To change the quantity or variations of the product, click Edit Item. Then, make the changes and click the Update Cart button.
- To view the full shopping cart, click View Shopping Cart.
- To delete an item from the cart, click Remove Item.
- To begin the checkout process, click the Checkout button.
Persistent Shopping Cart

A persistent shopping cart keeps track of unpurchased items which are left in the cart, and saves the information for the customer's next visit. Customers who are “remembered” can have the contents of their shopping carts restored the next time they visit your store.

Using a persistent shopping cart can help reduce the number of abandoned shopping carts and increase sales. It is important to understand that the persistent shopping cart does not expose sensitive account information at any time. While the persistent shopping cart is use, both registered customers and guest shoppers are required to either log in to an existing account, or create a new account before going through checkout. For guest shoppers, a persistent shopping cart is the only way to retrieve information from a previous session.

Types of Cookies

To use the persistent shopping cart, the customer’s browser must be set to allow cookies. During operation, the following cookies are used:

- **Session Cookie**
  
  A short-term session cookie exists for the duration of a single visit to your site, and expires when the customer leaves, or after a set period of time.

- **Persistent Cookie**
  
  A long-term persistent cookie continues in existence after the end of the session, and saves a record of the customers’ shopping contents for future reference.
Persistent Cart Workflow

When Persistent Shopping Cart is enabled, the workflow depends on the values of the “Enable Remember Me” and “Clear Persistence on Log Out” settings, the customer’s decision to select or clear the “Remember Me” checkbox, and when the persistent cookie is cleared.

When a persistent cookie is applied, a Not %Jane Smith%? link appears in the page header, to give the customer the ability to terminate the persistent session and start working as a guest, or log in as a different customer. The system retains a record of the shopping cart contents, even if the customer later uses different devices to shop in your store. For example, a customer can add an item to the shopping cart from a laptop, edit the cart contents from a desktop computer, add more items from a mobile device, and complete the checkout process from a tablet.

There is a separate independent persistent cookie for each browser. If the customer uses multiple browsers while visiting your store during a single, persistent session, any changes made in one browser will be reflected in any other browser when the page is refreshed. While the persistent shopping cart is enabled, your store creates and maintains a separate persistent cookie for each browser that is used by a customer to log in or create an account.

Leaving an Open Session on a Shared Computer

Jane is finishing up her holiday shopping with a persistent session, and adds a present for John to her cart, as well as something for her mother. Then she goes to the kitchen for some milk and cookies.

John sits down at the computer to do some quick shopping while Jane’s in the kitchen. Without noticing the “Not %Jane%” link at the top of the page, he finds a nice present for Jane and adds it to the cart. When he goes to checkout and logs in as himself, both the items in Jane’s cart are added to his cart. John’s in such a hurry that he doesn’t notice the additional item during Order Review, and submits the order. Jane’s cart is now empty, and John bought presents for both Jane and her mother.

Jane brings John some milk and cookies, and asks, “What’s up?” He says, “Oh, nothing.”
Remember Me
Customers can click the “Remember Me” checkbox on the Login page to save the contents of their shopping carts.

- **Yes**  A persistent cookie is created, and the contents of the shopping cart is saved for the customer's next logged-in session.
- **No**  If “Remember Me” is not selected or is cleared, a persistent cookie is not created, and the cart information is not saved for the customer's next logged-in session.

Continue Persistence After Logout (No)

- **No**  When the customer logs in, the persistent cookie is invoked, in addition to the session cookie which is already in use.
- **Yes**  When the customer logs out, the session cookie is deleted, but the persistent cookie remains in effect. The next time the customer logs in, the cart items are restored, or added to any new items that have been placed in the cart.
- **Yes**  If the customer does not log out, but the session cookie expires, the persistent cookie remains in effect.

Clear Persistence on Logout (Yes)

- **Yes**  When the customer logs in, the persistent cookie is invoked, in addition to the session cookie which is already in use.
- **Yes**  When the customer logs out, both cookies are deleted.
- **Yes**  If the customer does not log out, but the session cookie expires, the persistent cookie remains in effect.

Persistent Cart Settings and Effects

<table>
<thead>
<tr>
<th>SETTING</th>
<th>EFFECT</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable Remember Me = “No”</td>
<td>The Remember Me checkbox is not available on the login and registration page. The persistent cookie is not used.</td>
</tr>
<tr>
<td>Clear Persistence on Log Out</td>
<td></td>
</tr>
</tbody>
</table>
### Persistent Cart Configuration

During the setup of a persistent shopping cart, you can specify the lifetime of the cookies, and which options you want to make available for various customer activities.

If the session cookie expires while the customer is logged in, the persistent cookie remains active.

**To set up a persistent shopping cart:**

1. **On the Admin menu, select System > Configuration.** Then in the panel on the left, under Customers, select **Persistent Shopping Cart.**
2. **Click to expand the General Options section.**

![General Options](image)

3. **To enable the persistent shopping cart and to display additional configuration options, set Enable Persistence to “Yes.”**
4. Do the following:
a. Set **Persistence Lifetime (seconds)** to the length of time that you want the persistent cookie to last. The default value 31,536,000 seconds is equal to one year, and is the maximum time allowed.

b. Set **Enable “Remember Me”** to one of the following:

   - Yes Displays the “Remember Me” checkbox on the Login page of your store, so customers can choose to save their shopping cart information.
   - No Persistence can still be enabled, but customers are not given the option to choose if they want to save their information.

c. To preselect the “Remember Me” checkbox, set **Remember Me Default Value** to “Yes.”

d. Set **Clear Persistence on Log Out** to one of the following:

   - Yes The shopping cart is cleared when a registered customer logs out.
   - No The shopping cart is saved when a registered customer logs out.

   If the session cookie expires while the customer is still logged in, the persistent cookie remains in use.

e. Set **Persist Shopping Cart** to one of the following:

   - Yes If the session cookie expires, the persistent cookie is preserved. If a guest shopper later logs in or creates a new account, the shopping cart is restored.
   - No The shopping cart is not preserved for guests after the session cookie expires.

5. When complete, click the **Save Config** button.
## Field Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>SCOPE</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable Persistence</td>
<td>Website</td>
<td>Determines if the persistence is enabled.</td>
</tr>
<tr>
<td>Persistence Lifetime</td>
<td>Website</td>
<td>Defines the lifetime of the persistent cookie in seconds. Maximum allowed</td>
</tr>
<tr>
<td>(seconds)</td>
<td></td>
<td>value is 3153600000 seconds (100 years).</td>
</tr>
<tr>
<td>Enable “Remember Me”</td>
<td>Website</td>
<td>Defines whether the “Remember Me” checkbox appears on the login and</td>
</tr>
<tr>
<td></td>
<td></td>
<td>registration pages of the store. Options include:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Yes Displays the “Remember Me” checkbox.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No Does not display the “Remember Me” checkbox, and the persistent cookie</td>
</tr>
<tr>
<td></td>
<td></td>
<td>is used only for customers who already have it.</td>
</tr>
<tr>
<td>“Remember Me” Default</td>
<td>Website</td>
<td>Defines the default state for the “Remember Me” checkbox.</td>
</tr>
<tr>
<td>Value</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Clear Persistence on Log Out</td>
<td>Website</td>
<td>Defines whether the persistent cookie is deleted when a store customer logs out.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No matter how Clear Persistence on Log Out is configured, if a customer does not log out, but the session cookie expires, the persistent cookie is still used.</td>
</tr>
<tr>
<td>Persist Shopping Cart</td>
<td>Website</td>
<td>Defines whether using the persistent cookie gives access to the shopping cart data of the correspondent account. Options include:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Yes The shopping cart contents are saved after the session ends.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No The shopping cart contents are not saved after the session ends.</td>
</tr>
</tbody>
</table>
CHAPTER 41: Shopping Assistance

Customers sometimes need assistance to complete a purchase. Some customers like to shop online, but would rather the order by phone. While you’re on the phone, the customer might decide to take advantage of a coupon. To complete the sale, you must know how to edit the contents of the shopping cart, apply the discount from the coupon, and complete the order from the Admin—all while the customer is on the phone. No problem!

You can offer immediate shopping cart assistance to any customer who has registered for an account with your store. The Manage Shopping Cart tool gives you the ability to edit the contents of the customer’s shopping cart in real time, from the Admin of your store. Customer Service reps can see the contents of a customer’s shopping cart while the customer is on the phone, and the changes can be seen by the customer immediately after the page is refreshed.

Topics in this chapter include:

- Online Customers
- Update a Shopping Cart
- Create an Order
- Update an Order
- Create a Customer Account
Online Customers

You can see who's online in your store at any given time, and examine the contents of the customer's shopping cart, past purchases, and recent activity.

The length of the online session is set in the configuration, and determines how long the customer is visible from the Admin. By default, the online session is set to fifteen minutes.

To configure the session length:

1. On the Admin menu, select System > Configuration.
2. In the panel on the left, under Customers, select Customer Configuration.
3. Click to expand the Online Customers Options section.
4. In the Online Minutes Interval field, enter the number of minutes before the online session expires. You can leave the field empty to accept the default of fifteen minutes.
5. When complete, click the Save Config button.
To see customers online:

1. On the Admin menu, select **Customers > Online Customers**.

2. Take note of the customer account. Then on the Admin menu, select **Customers > Manage Customers**, and open the customer record in edit mode.

3. To see the contents of the customer’s shopping cart, expand the **Shopping Cart** section.

*Customer’s Shopping Cart*
Update a Shopping Cart

To begin an assisted shopping session, the customer must be logged into the account dashboard, so that the information is available. If the customer doesn’t have an account, you can create one. What service!

To offer assisted shopping:

1. On the Admin menu, select Customers > Online Customers.

2. In the list, click to open the customer record in edit mode.

   When the customer record opens, the first thing you’ll notice is that the Last Logged In value is “(Online).”

3. In the panel on the left, select Shopping Cart. Then, click the Manage Shopping Cart button to enter assisted shopping mode.

To apply a coupon code:

1. In the Apply Coupon Code section, enter the Code.

2. Click the Apply button.
To adjust the quantity ordered:

1. In the Qty column of the product to be adjusted, enter the correct amount.
2. Click the Update Items and Qty's button.

To add products to the shopping cart:

1. Click to expand the Products section. In the Qty to Add column, enter the quantity of the product the customer wants to order.
2. If the product is configurable, click the Configure link. Then, select the options the customer wants, and click the OK button.

To transfer products from a wishlist:

1. Click to expand the Wishlist section.
2. By default, it is set to transfer all items in the wishlist. If there are multiple items, select the checkbox of the items that you do not want to transfer, and set Qty to Add to 0.

Customer service reps can remove items from a cart by setting the quantity to 0 and updating the cart. However, only the customer can move items from the cart to the wishlist or to the product compare list.
3. Follow the same procedure to add items from the remaining sections:
   - Products in Comparison List
   - Recently Compared Products
   - Recently Viewed Products
   - Last ordered items

4. When complete, click the **Add Selected Products to the Shopping Cart** button.

5. Ask the customer to press F5 to refresh the page, so the products appear in the cart.
   At this point, the customer can continue shopping and checkout unassisted, or have the customer service representative create the order.

6. To create an order, click the **Create Order** button, and follow the normal process to complete the order for the customer.

**Create an Order**

For registered customers who need assistance, you can create an entire order directly from the Admin. The Create New Order form includes all the information that is needed to complete the normal checkout process, with activity summaries from the customer’s account dashboard.

For existing customers, new orders can be created both from the Manage Customer page and from the Sales Order page. The Sales Order page can also be used to open accounts for new customers.

![Create Order](image)

**Process Overview:**

**Step 1:** Initiate the Order

**Step 2:** Add Products to the Order
Step 1: Initiate the Order

Method 1: Create New Order from Existing Account

1. On the Admin menu, select Customers > Manage Customers.
2. Find the customer in the list and click to open the record.
3. Click the Create Order button.

4. To complete the order, do the following:
   a. To add products from the Current Activities section, find the product in the list and select the Add to Order checkbox. Then, click the Update Changes button.
   b. To add products from the catalog, click the Add Products link. Then, select the checkbox of each product to be added to the cart, and the Qty to be purchased.
Add Products

c. If the product has multiple options, click the **Configure** button. Complete the options as needed, and click the **OK** button. Then, click the **Add Selected Product(s) to Order** link to update the cart.

Configure
d. To override the price of an item, select the **Custom Price** checkbox. Then, enter the new price in the box below. Click the **Update Items and Qty's** button to update the cart totals.

Custom Price
e. Complete the following sections, as needed for the order:
   - Apply Coupon Codes
   - Payment Method
   - Shipping Method

f. In the Order Comments section, enter any comments that you want to accompany the order. To include the comments in the email notification that is sent to the customer, click the **Order Comments** button.
The **Email Order Confirmation** checkbox is selected by default. If you don’t want to send an email confirmation to the customer, clear the checkbox.

5. When complete, click the **Submit Order** button.

**Method 2: Create New Order from Sales**

1. On the Admin menu, select **Sales > Orders**.

2. Click the **Create New Order** button.

3. Do one of the following:
   - For registered customers, find the customer in the list and click to open the record.
   - For unregistered customers, click the **Create New Customer** button.

4. Complete the order information as you would if going through the checkout process. For a new customer account, complete the following sections:
   - **Account Information**
   - **Billing Address**
   - **Shipping Address**
Step 2: Add Products to the Order

Products can be added to the order by selecting each item from the catalog, or by transferring the information from a previous order, the customer's wishlist, recently viewed products, or other activities.

1. To add products to the order, do the following:
   a. Click to the **Add Products** button.
   b. Click the **Reset Filter** button to list all products. Then, use the filter controls as needed to find the products to be added. Then, click the **Search** button.
   c. Select the checkbox of each product to be added to the cart and if applicable, enter the **Qty** to be purchased.
      
      If the product has multiple options, click the **Configure** link. Complete the options as needed and click the **OK** button.

2. Click the **Add Selected Product(s) to Shopping Cart** button to update the cart. The current content of the cart appear in the Items Ordered section.

3. To override the price of an item, select the **Custom Price** checkbox. Then, enter the new price in the box below. Click the **Update Items and Qty's** button to update the cart totals.

4. Complete the following sections, as applicable to the order:
   - Apply Coupon Codes
   - Payment Method
   - Shipping Method

5. When complete, click the **Submit Order** button.
Update an Order

After a customer has placed an order, it is sometimes necessary to edit the order, place it on hold, or cancel the order entirely. When you make changes to an order, the original order is canceled and a new order is generated. You can, however, make changes to the billing or shipping address without generating a new order.

To edit an order:

1. On the Admin menu, select Sales > Orders.
2. Select the pending order that you want to edit.
3. Click the Edit button at the top of the screen. When prompted to confirm, click OK to continue.
4. Make the necessary changes to the order.
5. When complete, do one of the following:
   - Click Save to save changes made to the billing or shipping address.
   - Click Submit Order to save changes made to line items, and reprocess the order.
To place an order on hold:

If the customer’s preferred method of payment is not available, or if the item is temporarily out of stock, you can put the order on hold.

1. On the Admin menu, select **Sales > Orders**.
2. In the list, find the pending order that you want to place on hold. Then, click to open the order.
3. Click **Hold** to place the order on hold.

4. When you are ready to return the order to an active state, repeat the process and click **Unhold**.

To cancel an order:

Canceling an order removes it from the list of pending orders.

1. On the Admin menu, select **Sales > Orders**.
2. Find the pending order that you want to cancel, and click to open the order.
3. In the upper-right corner, click the **Cancel** button to remove this order.
4. The status of the order is now “Canceled.”

Create a Customer Account

Customers usually create their own accounts from your store. However, you can also create customer accounts directly from the Admin, which is useful when customers order by phone.

To create a new customer account:

1. On the Admin menu, select Customers > Manage Customers.
2. Click the Add New button.
3. In the Associate to Website list, select one of the following:
   - Admin
   - Main Website

You can associate a customer with the Admin website to require that orders are placed only from the store Admin. Customers associated with the Admin website cannot log in to their accounts from the store.

4. Assign the customer to a Customer Group.
5. Complete the remaining customer information.
6. In the **Password Management** section, do one of the following
   - Manually assign a password.
   - Select the **Send auto-generated password** checkbox. The new password is generated after the customer information is saved.

7. When complete, click the **Save Customer** button.

**To add a new address to a customer account:**

1. On the Admin menu, select **Customers > Manage Customers**. Then, click to open the customer record.

2. In the panel on the left, select **Addresses**. Then, do the following:
   a. To add a new address, click the **Add New Address** and complete the information.
   b. To assign a **Default Address** check either the **Default Billing Address** or **Default Shipping Address** as needed.
3. When complete, click the **Save Customer** button.

**Field Descriptions**

<table>
<thead>
<tr>
<th>FIELD</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Associate to Website</td>
<td>Identifies the website associated with the customer account.</td>
</tr>
<tr>
<td>Group</td>
<td>Identifies the customer group to which the customer belongs. Select the checkbox to disable automatic group change based on VAT.</td>
</tr>
<tr>
<td>Prefix</td>
<td>If used, the prefix that is associated with the customer's name. For example: Mr., Mrs., or Dr.</td>
</tr>
<tr>
<td>First Name</td>
<td>The customer's first name.</td>
</tr>
<tr>
<td>Middle Name / Initial</td>
<td>The customer's middle name or middle initial.</td>
</tr>
<tr>
<td>Last Name</td>
<td>The customer's last name.</td>
</tr>
<tr>
<td>Suffix</td>
<td>If used, the suffix that is associated with the customer's name. For example: Jr., Sr., or III.</td>
</tr>
<tr>
<td>Email</td>
<td>The customer's email address.</td>
</tr>
<tr>
<td>Date of Birth</td>
<td>The customer's date of birth.</td>
</tr>
<tr>
<td>Tax / VAT Number</td>
<td>The customer's Tax or Value Added Tax number, if applicable.</td>
</tr>
<tr>
<td>Gender</td>
<td>Identifies the customer's gender as Male or Female.</td>
</tr>
<tr>
<td>Send Welcome Email</td>
<td>Select the checkbox if you want the system to send the customer a welcome email message.</td>
</tr>
</tbody>
</table>
Field Descriptions (cont.)

<table>
<thead>
<tr>
<th>FIELD</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Send From</td>
<td>If you have multiple stores, select the store from which the welcome message will be sent.</td>
</tr>
</tbody>
</table>

New Account Options

In the customer configuration, the basic account options are combined with advanced options related to VAT ID Validation. The following instructions show how to complete only the basic customer account options, which are highlighted in the following screenshot. To learn about the advanced options, see: VAT ID Validation.

![Create New Account Options](image-url)
To set up the basic customer account options:

1. On the Admin menu, select **System > Configuration**.

2. In the panel on the left, under Customers, select **Customer Configuration**.

3. Click to expand the **Create New Account Options** section. Then, do the following:
   
   a. Set **Default Group** to the customer group that is assigned to new customers when an account is created.
   
   b. Enter the **Default Email Domain** for the store. For example: mystore.com
   
   c. Set **Default Welcome Email** to the template that is used for the Welcome email sent to new customers.
   
   d. Set **Email Sender** to the store contact that appears as the sender of the Welcome email.
   
   e. To require that customers must confirm their request to open an account with your store, set **Require Emails Confirmation** to “Yes.” Then, set **Confirmation Link Email** to the template that is used for the confirmation email.
   
   f. Set **Welcome Email** to the template that is used for the Welcome message that is sent after the account is confirmed.

4. When complete, click the **Save Config** button.
Update a Customer Account

The panel on the left of the Customer Information page includes information about customer activity, such as when the customer last logged in and out, addresses, order statistics, recent orders, shopping cart contents, product reviews, newsletter subscriptions, and so on.

To view customer information:

1. On the Admin menu, select Customers > Manage Customers.
2. Click to open a customer record.
3. In the panel on the left, select the type of information you need to edit. Then, make the necessary changes.
4. When complete, click the Save Customer button.
CHAPTER 42:

Checkout

When shoppers “proceed to checkout” from the shopping cart, the transaction shifts to a secure, encrypted channel. A padlock symbol appears in the address bar of the browser, and the URL changes from “http” to “https.”

From this point on, the goal is to gather the information necessary to complete the transaction. The Checkout page leads the customer through each step of the process. Customers who are logged into their accounts can complete checkout quickly, because much of the information is already in their accounts.
Checkout Process

1. **Enter or confirm billing address.** Guests going through checkout are prompted to enter their billing address. For registered customers, the information is already in their account, and the customer confirms the information.

2. **Enter or choose shipping address.** Guests going through checkout are prompted to enter the shipping address. Registered customers have the option to choose the shipping address from the address book of their customer account.

3. **Choose shipping method.** The customer is prompted to choose how the order is to be shipped from the selection of shipping methods supported by your store.

4. **Choose payment method.** The customer is prompted to choose a payment method, and if applicable, enter a credit card number. Depending on the payment method, the customer might be redirected to another site to complete this part of the transaction.

5. **Review and submit order.** During order review, the customer reviews the order items and totals. Depending on the configuration, the customer might be required to acknowledge reading the terms and conditions of the sale before the order can be submitted.

6. **Receive confirmation.** The order confirmation page appears after the order is placed, and an order confirmation email is sent to the customer. For registered customers, the order confirmation page includes a link to their account.
Checkout Method

Your store can be configured to require that customers open an account before making a purchase, or to allow unregistered guests to go through the checkout process.

To allow guest checkout:

1. On the Admin menu, select System > Configuration.
2. In the panel on the left under Sales, select Checkout.
3. Click to expand theCheckout Optionssection.
4. Set Allow Guest Checkout to “Yes.”
5. Click the Save Config button.
One Page Checkout

The purpose of OnePage Checkout is to gather the information that is needed, and complete the sale as quickly as possible. When Onepage Checkout is enabled, the entire checkout process takes place on a single page. Each section of the checkout information is expanded as needed.

Magento’s Onepage Checkout is enabled by default. If you are implementing a custom integration or checkout extension, it might be necessary to disable Onepage Checkout.

**To disable Onepage Checkout:**

1. On the Admin menu, select **System > Configuration**.
2. In the panel on the left under Sales, select **Checkout**.

3. Click to expand the **Checkout Options** section.
4. Set **Enable Onepage Checkout** to “No.”
5. When complete, click the **Save Config** button.
Order Review

During Order Review, the total appears at the bottom of the order, with any adjustments for discounts, gift cards, shipping charges, store credit, and tax. The order of each item determines the sequence of the calculations, and is set by a number that is assigned to each item. For example, the Subtotal is the first item in the section, and is assigned a value of 10. The Grand Total appears last, and is assigned a value of 100. All of the other items in the totals section are assigned a value between the first and the last.

To configure the checkout totals:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Sales, choose Sales.
2. Click to expand the Checkout Totals Sort Order section.
3. Change the number assigned to each item to determine its order in the Totals section.

4. When complete, click the **Save Config** button.

## Terms and Conditions

When Terms and Conditions are enabled, customers must select a checkbox to verify that they agree to the terms and conditions of the sale. The Terms and Conditions message and checkbox appear during Order Review between the Totals section and the Place Order button. The transaction cannot be finalized until the customer selects the checkbox to agree to the terms and conditions of the sale.

![Terms and Conditions at Checkout](image)

**Terms and Conditions at Checkout**

**Process Overview:**

- Step 1: Enable Terms and Conditions
- Step 2: Describe Your Terms and Conditions
- Step 3: Format the Content
Step 1: Enable Terms and Conditions

1. On the Admin menu, select **System > Configuration**.

2. In the panel on the left, under Sales, select **Checkout**. Then, click to expand the **Checkout Options** section.

3. Make sure that **Enable OnePage Checkout** is set to “Yes.” Otherwise, the Terms and Conditions checkbox will not appear during checkout.

4. To display the terms and conditions checkbox during checkout, set **Enable Terms and Conditions** to “Yes.”

5. When complete, click the **Save Config** button.

Step 2: Describe Your Terms and Conditions

1. On the Admin menu, select **Sales > Terms and conditions**.

2. In the upper-right corner, click the **Add New Condition** button.

3. In the Terms and Conditions Information section, complete the following:
   a. Enter the **Condition Name**. The name is for internal reference only.
   b. Set **Status** to “Enabled.”
Step 3: Format the Content

1. **Set Show Content as** to one of the following:
   - **Text** Displays the terms and conditions content as unformatted text.
   - **HTML** Displays the terms and conditions content as HTML, which can be tagged and formatted.

2. Identify the **Store View** where the Terms and Conditions will appear.

3. Enter the **Checkbox Text** that you want to appear as a label with the checkbox. For example, you could use “I understand and accept these terms and conditions of the sale.”

4. In the **Content** field, either type or paste enter the full text of the terms and conditions of the sale.

5. (Optional) Enter the **Content Height (css)**, in pixels, to determine the height of the text box in which the terms and conditions statement appears during checkout. For example, if you want the text box to be one inch high, enter 96, which is the equivalent value in pixels.

6. When complete, click the **Save Condition** button.
Order Confirmation

The order confirmation appears after the order is placed. For registered customers, the page includes the order number with a link to the customer’s account, and a link to generate a receipt. Registered customers are told that they will receive order confirmation and tracking info by email. Guests are encouraged to create an account to track the order. Registered customers can generate a receipt by clicking a link. The order confirmation page is also called the “Success” page, and is used by analytics programs to track conversions.

Checkout Success
CHAPTER 43:

Sales Communications

Your store generates invoices, packing slips, and credit memos in both HTML and PDF formats. Before your store goes live, make sure to update these documents with your logo and store address. You can customize the address format, and also include the Order ID for reference. The following print-ready invoice has a high-resolution, 300 DPI logo that reproduces well with the text on the page.
Setting Up Sales Email

A number of transactional email messages are triggered by events related to an order, and the configuration is similar for each. You must identify the store contact that appears as the sender of the message, the email template to be used, and who else is to receive a copy of the message.

Step 1: Update the Email Templates

Make sure that you have updated each email template configuration with your store logo, and have made any other changes necessary to the content of each template to reflect your store and brand. For a complete list of templates, see: Email Template Reference.

Step 2: Configure the Sales Emails

1. On the Admin menu, select System > Configuration.
2. In the panel on the left under Sales, select Sales Emails. Then, do the following:
3. Click to expand the Order section. Then, do the following:
a. Verify that Enabled is set to “Yes.”

b. Set New Order Confirmation Email to the store contact that appears as the sender of the message.

c. Set New Order Confirmation Template to the template that is used for the email that is sent to registered customers.

d. Set New Order Confirmation Template for Guest to the template that is used for the email that is sent to guests who do not have an account with your store.

e. In the Send Order Email Copy To field, enter the email address of anyone who is to receive a copy of the new order email. If sending a copy to multiple recipients, separate each address with a comma.

f. Set Send Order Email Copy Method to one of the following:

- Bcc Sends a “blind courtesy copy” by including the recipient in the header of the same email that is sent to the customer. The BCC recipient is not visible to the customer.
- Separate Email Sends the copy as a separate email.

4. Click to expand the Order Comments section, and repeat these steps.

5. Complete the configuration in a similar manner for the remaining sales emails:
   - Invoice
   - Shipment
   - Credit Memo

6. When complete, click the Save Config button.
PDF Logo Requirements

The logo that is used for PDF print-outs can be a high-resolution, 300 dpi image, but must be a specific size. However, the size of the logo that appears in the HTML print view version of sales documents is determined by your theme.

One way to resize your logo to fit the required size is to create a new, blank image with the correct dimensions. Then, paste your logo image and resize it to fit the height. With most image editing programs, you can preserve the aspect ratio by holding down the shift key as you resize the image. The following image is a 200px by 50px .png file with a transparent background, (which is represented by the checkerboard pattern). The same image is used for the high-resolution image on the PDF invoice, but saved as a 300 dpi jpg.

To set up your sales documents:

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left, under Sales, select **Sales**.

2. Click to expand the **Invoice and Packing Slip Design** section, and do the following:

   a. To upload the **Logo for PDF Print-outs**, click the **Browse** button. Then, select the logo that you have prepared and click **Open**. The path to the file appears in the text box.

   b. To upload the **Logo for HTML Print View**, click the **Browse** button. Then, select the logo that you have prepared and click **Open**. The path to the file appears in the text box.

3. Enter your address as you want it to appear on invoices and packing slips.
4. When complete, click the Save Config button.

For reference, a thumbnail of the uploaded image appears before each field. Unless the uploaded image is square, the thumbnail appears distorted. The proportion of the logo will be correct on the invoice.

**To replace an image:**

1. Click the **Browse** button and select the new logo.
2. Select the **Delete Image** checkbox for the image you want to replace.
3. Click the **Save Config** button.

**Image Formats**

<table>
<thead>
<tr>
<th>FORMAT</th>
<th>REQUIREMENTS</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>PDF</strong></td>
<td></td>
</tr>
<tr>
<td>File Format</td>
<td>jpg (jpeg), png, tif (tiff)</td>
</tr>
<tr>
<td>Image Size</td>
<td>200 pixels wide x 50 pixels high</td>
</tr>
<tr>
<td>Resolution</td>
<td>300 dpi recommended</td>
</tr>
<tr>
<td><strong>HTML</strong></td>
<td></td>
</tr>
<tr>
<td>File Format</td>
<td>jpg (jpeg), png, gif</td>
</tr>
<tr>
<td>Image Size</td>
<td>Determined by theme.</td>
</tr>
<tr>
<td>Resolution</td>
<td>72 or 96 dpi</td>
</tr>
</tbody>
</table>
Add Reference IDs to Header

The order ID and customer IP address can be included in the header of sales documents that accompany an order. Follow the instructions below to include either, or both of these identifiers for reference in the header of invoices, shipment packing slips, and credit memos.

PDF Print-outs

To show the Order ID:

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left under Sales, select **PDF Print-outs**.
2. Click to expand the **Invoice** section.
3. To include the Order ID in the header, Set **Display Order ID in Header** to “Yes.”
4. Repeat these steps for the **Shipment** and **Credit Memo** sections.
5. When complete, click the **Save Config** button.
To show the customer IP address:

1. On the Admin menu, select System > Configuration.
2. In the panel on the left, under Sales, select Sales.
3. Click to expand the General section.

4. To show the IP address of the computer that was used to place the order, set Hide Customer IP to “No.”
5. When complete, click the Save Config button.
Notes
CHAPTER 44:  
Managing Orders

In this chapter, we explore what happens after a customer places an order, and the time the order is delivered. You will learn how to fulfill orders, print invoices, collect payment, process credit memos, manage returns, and more.

Magento eBook

Learn top ten tips you can use to increase your conversion rates by evaluating and optimizing your site's entire shopping experience. Get the eBook now!
Order Process Overview

Order submitted. During checkout, the customer reviews the order, agrees to the Terms and Conditions, and clicks the Place Order button. Customers receive a confirmation of their orders, with a link to their customer account.

Order “Pending.” Before payment is processed the status of a sales order is “Pending.” At this point, the order can still be canceled.

Payment received. Depending on the payment method, you, may be notified when the transaction is authorized and in some cases, processed. The status of the invoice is now “Processing.”

Order invoiced. Sometimes an order is invoiced before payment is received. In this example, the invoice is generated and submitted after the credit card payment has been authorized and processed. After the invoice is generated and submitted, a copy is sent by email to the customer.

Order “Processing.” When the customer logs into his account to check on the order, the status is still "Processing."

Order shipped. The shipment is submitted, and packing slips printed. You ship the package, and the customer is notified by email. Congratulations! You’re in business.

Order Stages

The Sales menu lists transactions according to where they are in the order workflow. You might think of each of these as a possible stage in the life of an order.
Orders

When an order is created, either from the storefront or in the Admin, a sales order is created as a temporary record of the transaction. Sales orders can be seen from the Admin by selecting the Orders option from the Sales menu. Payment has not yet been processed and the order can still be canceled.

Invoices

An invoice is a record of the receipt of payment for an order. Multiple invoices can be created for a single order, each containing as much or as few of the purchased products that you specify. Depending on the payment action, payment can be automatically captured when the invoice is generated.

Shipments

A shipment is a record of the products in an order that have been shipped. As with invoices, multiple shipments can be associated with a single order, until all of the products in the order are shipped.

Credit Memos

A credit memo is a record of a refund. A product cannot be refunded until it has been paid (which means that it has been invoiced). This means that you are not able to create a credit memo before an invoice has been created. The credit memo serves as a record of a refund, but it is not a record of the actual return of funds to the customer.

Transactions

The Transactions page lists all payment activity that has taken place between your store and a payment system, and provides access to more detailed information.
Order Status

All orders have an order status that is associated with a stage in the order processing workflow. You can see the status of an order by clicking the control at the top of the Status column.

Order Status

Your store has a set of predefined order status and order state settings. The state describes the position of an order in the workflow.

Order Status and State

<table>
<thead>
<tr>
<th>ORDER STATUS</th>
<th>ORDER STATE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Canceled</td>
<td>New</td>
</tr>
<tr>
<td>Canceled Ogone</td>
<td>Pending Payment</td>
</tr>
<tr>
<td>Closed</td>
<td>Processing</td>
</tr>
<tr>
<td>Complete</td>
<td>Complete</td>
</tr>
<tr>
<td>Declined Ogone</td>
<td>Closed</td>
</tr>
<tr>
<td>Suspected Fraud</td>
<td>Canceled</td>
</tr>
<tr>
<td>On Hold</td>
<td>On Hold</td>
</tr>
<tr>
<td>Payment Review</td>
<td>Payment Review</td>
</tr>
<tr>
<td>PayPal Canceled Reversal</td>
<td></td>
</tr>
<tr>
<td>PayPal Reversed</td>
<td></td>
</tr>
<tr>
<td>Pending</td>
<td></td>
</tr>
<tr>
<td>Pending Ogone</td>
<td></td>
</tr>
<tr>
<td>Pending Payment</td>
<td></td>
</tr>
<tr>
<td>Pending PayPal</td>
<td></td>
</tr>
<tr>
<td>Processed Ogone Payment</td>
<td></td>
</tr>
<tr>
<td>Processing</td>
<td></td>
</tr>
<tr>
<td>Processing Ogone Payment</td>
<td></td>
</tr>
<tr>
<td>Waiting Authorization</td>
<td></td>
</tr>
</tbody>
</table>
Custom Order Status

In addition to the preset order status values, you can create custom order status values of your own, assign order statuses to order states, and set a default order status for order states. For example, you might need a custom order status for orders, such as “packaging” or “backordered,” or for a status that is specific to your needs. You can create a descriptive name for the custom status, and then assign it to the associated order state in the order processing workflow.

Only the default custom order status values are applied in the order management workflow. The custom status values that are not set as default are available only in the comments section in the order view in the Admin.

To create a custom order status:

1. On the Admin menu, select **System > Order Statuses**.
2. In the upper-right corner, click the **Create New Status** button.
3. In the Order Status Information section, do the following:
   a. Enter a **Status Code**. This value is for internal use only. The first character must be a letter (a-z), and the rest can be any combination of letters and numbers (0-9). You can use the underscore character instead of a space.
   b. Enter a **Status Label** to identify the status setting in both the Admin and store.
4. In the Store View Specific Labels section, enter any labels that you need for different store views and languages.

5. When complete, click the **Save Status** button.

The new order status now appears in the Order Statuses list.

**To assign an order status to a state:**

1. From the Order Statuses list, click the **Assign Status to State** button.

2. In the Assignment Information section, do the following:
   a. Select the **Order Status** that you want to assign. They are listed by status label.
   b. Select the **Order State** that represents where the order status belongs in the workflow.
   c. To make this status the default for the order state, select the **Use Order Status as Default** checkbox.

3. When complete, click the **Save Status Assignment** button.

**To edit an existing order status:**

1. On the Order Statuses page, click to open the status record in edit mode.

2. Update the status labels as needed.

3. When complete, click the **Save Status** button.

**To remove an order status from an assigned state:**

1. On the Order Statuses page, find the order status record that you want to unassign.

2. In the Action column on the far right of the row, click the **Unassign** link.

   A message appears at the top of the workspace that the order status has been unassigned. Although the order status label still appears in the list, it is no longer assigned to a state. Order statuses cannot be deleted.
Order Workflow
CHAPTER 45:
Order Fulfillment

When the order is placed, a sales order is created as a temporary record of the transaction. In the Orders list, sales orders are shown with a status of "Pending," and can be canceled at any time until the payment is processed. After payment confirmed, the order can be invoiced and shipped.
Invoice an Order

An invoice is a record of the receipt of payment for an order. Creating an invoice for an order converts the temporary sales order into a permanent record of the order, which cannot be canceled. A new invoice page looks similar to a completed order page, with some additional fields that can be edited. Every activity that is related to an order is noted in the Comments section of the invoice.

Multiple invoices can be created for a single order, and each can include as many or as few of the purchased products that you specify. Invoices can be generated for a single order, or for a batch of orders. The payment method determines which invoicing options can be used for the order. For payment methods with Payment Action set to “Authorize and Capture,” the Invoice button does not appear.

Before an invoice can be printed, the invoice must first be generated for the order. To view or print the PDF, you must have a PDF reader. You can download Adobe Reader at no charge.
Invoice

To invoice an order:

1. On the Admin menu, select Sales > Orders.
2. In the list, find the “Pending” order, and click to open the record.
3. If the items are ready to ship, you can create a packing slip for the shipment with the invoice. To create a packing slip, do the following:
   a. In the Shipping Information section, select the Create Shipment checkbox.
   b. To include a tracking number, click the Add Tracking Number button and enter the Carrier, Title, and Number.
4. To make a partial invoice scroll down to the Items to Invoice section, and enter the **Qty to Invoice** for each item.

5. Under the Invoice History menu, in the **Invoice Comments** section, complete the comments as needed. Then, in the Invoice Totals section, select the **Append Comments** checkbox to add the comments to the invoice.

6. Select the **Email Copy of Invoice** checkbox to send a copy of the invoice to your customer.

7. Do one of the following:
   - Click the **Submit Invoice** button to process the invoice and capture the sale.
   - If your store requires that you ship before invoicing, click the **Ship** button, complete the shipping information and submit the shipment. When that is complete, you can finish the invoicing steps.

### Payment Actions

<table>
<thead>
<tr>
<th>PAYMENT ACTION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Capture Online</td>
<td>When the invoice is submitted, the system captures the payment from the third-party payment gateway. You have the ability to create a credit memo and void the invoice.</td>
</tr>
<tr>
<td>Capture Offline</td>
<td>When the invoice is submitted, the system does not capture the payment. It is assumed that the payment is captured directly through the gateway, and you no longer have the option to capture this payment through Magento. You have the ability to create a credit memo, but you do not have the option to void the invoice. (Even though the order used an online payment, the invoice is essentially an offline invoice.)</td>
</tr>
<tr>
<td>Not Capture</td>
<td>When the invoice is submitted, the system does not capture the payment. It is assumed that you will capture the payment through Magento at a later date. There is a Capture button in the completed invoice. Before capturing, you are able to cancel the invoice. After capturing you are able to create a credit memo and void the invoice.</td>
</tr>
</tbody>
</table>

**Do not select Not Capture unless you are certain that you are going to capture the payment through Magento at a later date. You will not be able to create a credit memo until the payment has been captured using the Capture button.**
Print Invoices

You can print an invoice for a single order, or for multiple invoices as a batch, or group. However, before an invoice can be printed, the invoice must first be generated for the order.

To view or print the PDF, you must have a PDF reader. You can download Adobe Reader at no charge.

To print invoices:

1. On the Admin menu, select Sales > Invoices.
2. In the Invoices list, select the checkbox of each invoice that you want to print.
3. Set the Actions control to “Print Invoices.”
4. Click the Submit button to generate the PDF and display the document in a new window.
5. After the file has been downloaded and saved to your computer, you can open and print the document with Adobe Reader.
Ship an Order

An order that has been paid, but is awaiting shipment has the “Processing” status. The shipment record contains a detailed history of the fulfillment process associated with the order. Partial shipments can be made until the order is fulfilled.

To ship an order:

1. On the Admin menu, select **Sales > Orders**.
2. In the Orders list, click to open the order to be shipped.
3. In the upper-right corner, click the **Ship** button.
4. If you need to update the billing or shipping address, click the **Edit** link in the upper-right corner of the section. Make the necessary changes, and click the **Save Order Address** button.
5. To have the carrier generate a shipping label, select the **Create Shipping Label** checkbox. Then, do the following:
   a. To add a tracking number, scroll down to the Shipping Information section, and click the **Add Tracking Number** button.
   b. Do one of the following:
      * Select the **Carrier**, and enter the tracking **Number**.
      * Set **Carrier** to “Custom Value.” Enter a **Title** for the custom carrier, and enter the tracking **Number**.
6. To make a partial shipment, scroll down to the Items to Ship section, and enter the Qty to Ship for each item.

7. To notify customers by email of the shipment, do the following:
   a. Enter any comments you would like to include in the Shipment Comments box.
   b. To include the comments in the notification email that is sent to the customer, select the Append Comments checkbox.
   c. To send a copy of the shipment email to yourself, select the Email Copy of Shipment checkbox. The status of an invoice email appears next to the invoice number of the completed invoice as either sent or not sent.

8. When complete, click the Submit Shipment button. The status of the order changes from “Processing” to “Complete.”

**To view the shipment detail:**

1. On the Admin menu, select Sales > Shipments.
2. Find the shipment in the list, and click to open the record.
3. If you want to add a comment to the order, scroll down to the Comments History section, and enter the comment in the box.
   * To send the comment to the customer by email, select the Notify Customer by Email checkbox.
   * To post the comment in the customer’s account, select the Visible on Frontend checkbox.
4. Click the Submit Comment button.
Print Packing Slips

A packing slip is a sales document that accompanies shipments sent from your store, and lists each item included in the package. You can print a packing slip for a single order, or print multiple packing slips as a batch, or group. However, before a packing slip can be printed, it must first be created for the order.

To view or print the PDF, you must have a PDF reader. You can download Adobe Reader at no charge.

To print packing slips:

1. On the Admin menu, select Sales > Shipments.

Method 1: Print Single Packing Slip from Shipment

1. In the Shipments list, open the record that needs a packing slip.
2. In the upper-right corner of the shipment page, click the Print button. Look for the download indicator in the lower-left corner of your browser window.

Packing Slip
Method 2: Print Multiple Packing Slips

1. In the Shipments list, select the checkbox of each shipment record that needs a packing slip.

2. In the upper-right corner, set the Actions control to “PDFpackingslips” and click the Submit button.

Printing Multiple Packing Slips

2. Do one of the following:

   - To save the document, click the Save button. Then, follow the prompts to save the file to your computer. When the download is complete, open the PDF in Adobe Reader, and print the document.

   - To view the document in Adobe Reader, click the Open button. From here, you can either print the packing slip or save it to your computer.
Transactions

The Transactions page lists all payment activity that has taken place between your store and external payment systems, and provides access to detailed information about each transaction.

To view transactions:
On the Admin menu, select **Sales > Transactions.**
CHAPTER 46:

Credit Memos & Refunds

After an order has been paid for and invoiced, all of the order, or a portion of it, can be refunded by issuing a credit memo. A credit memo differs from a refund because the amount of the credit is restored to the customer's account where it can be applied to future purchases, rather than returned to the customer as cash. In some cases, a refund can be given at the same time that a credit memo is issued, just as payment can be made at the time of invoicing. Topics include:

- Product Return Workflow
- Create a Credit Memo
- Print a Credit Memo
Product Return Workflow

1. Customer returns item
2. Create credit memo
3. Select "Return Items to Inventory"
4. Add note to explain refund
5. Select "Online Refund"
   - Submit to send credit memo
   - Refund applied to credit card
   - Credit
6. Select "Refund to Store Credit"
   - Submit to send credit memo
   - Refund applied to customer account
   - Refund
Create a Credit Memo

A credit memo is a document that lists the amount that is owed to the customer. The amount can be applied toward a purchase, or refunded to the customer. You can print a credit memo for a single order, or for multiple orders as a batch, or group. Before a credit memo can be printed, it must first be generated for the order.

To create a credit memo:

1. On the Admin menu, select **Sales > Orders**.
2. Find the order in the list, click to open the order.
3. In the upper right corner, click the **Credit Memo** button. (The button appears only if an invoice has been generated for the order.)

The New Credit Memo page looks similar to the completed order page, with an Items to Refund section that lists each item from the invoice.
If an online payment method was used, you will not be able to edit these fields.

4. Do one of the following:
   - If the product is to be returned to inventory, check the **Return to Stock** checkbox.
   - If the product will not be returned to inventory, leave the checkbox blank.

   The Return to Stock checkbox appears only if you have set the inventory **Stock Options** to “Decrease Stock When Order Is Placed.”

5. Complete the following:
   a. In the **Qty to Refund** box, type the number of items to be returned and press the **Enter** key to record the change. The Update Qty’s button appears.
   b. Set the **Qty to Refund** of any items not to be refunded to 0.
   c. Click the **Update Qty’s** button to recalculate the total. (The amount to be credited cannot exceed the maximum quantity that is available for refund.)
6. In the **Refund Totals** section, do the following, as applicable:

   a. In the **Refund Shipping** field, enter the amount that is to be refunded from the shipping fee. This field initially displays the total shipping amount from the order that is available for refund. It is equal to the full shipping amount from the order, less any shipping amount that has already been refunded. Like the quantity, the amount can be reduced, but not increased.

   b. In the **Adjustment Refund** field, enter a value to be added to the total amount refunded as an additional refund that does not apply to any particular part of the order (shipping, items, or tax). The amount entered cannot raise the total refund higher than the paid amount.

   c. In the **Adjustment Fee** field, enter a value to be subtracted from the total amount refunded. This amount is not subtracted from a specific section of the order such as shipping, items, or tax.

   d. To credit the amount back to the customer’s account balance, select the **Refund to Store Credit** checkbox.

   e. To add a comment, type the text in the **Credit Memo Comments** box.

   f. To send an email notification to the customer, select the **Email Copy of Credit Memo** checkbox.

   g. If you want to include the comments you have entered, check the **Append Comments** checkbox.

The status of a credit memo notification appears in the completed credit memo next to the credit memo number.
7. To complete the process and generate the credit memo, select one of the following refund option buttons, depending on the payment type:
   - Refund Offline
   - Refund Online

8. To add a comment to the completed credit memo, scroll down to the Comments History section, and enter the comment in the box.
   - To send the comment to the customer by email, select the **Notify Customer by Email** checkbox.
   - To post the comment in the customer’s account, select the **Visible on Frontend** checkbox.

Below the credit memo is a complete list of all activity related to the order.

9. Click the **Submit Comment** button.
Print a Credit Memo

To print or view the completed credit memo, you must have a PDF reader installed on your computer. You can download Adobe Reader at no charge.

To print a credit memo:

1. On the Admin menu, select Sales > Credit Memos.

2. Use one of the following methods to print the credit memo:

   Method 1: Open the Credit Memo
   1. In the list, click to open the credit memo.
   2. Click the Print button to print the PDF document.

   Method 2: Use the Action Control
   1. In the list, select the checkbox of each credit memo that you want to print.
   2. Set the Actions control to “PDF Credit Memos,” and click the Submit button.
   3. When prompted, do one of the following:
To save the document, click **Save**. Then, follow the prompts to save the file to your computer. When the download is complete, open the PDF in Adobe Reader, and print the document.

To view the document, click **Open**. The printed-ready PDF credit memo opens in Adobe Reader. From here, you can either print the credit memo or save it to your hard disk.
Payments
Payments

Magento Community Edition gives you the ability to offer your customers a wide range of payment methods, services, and gateways. In this section, you'll learn how to enable and configure the payment methods and services that you want to make available to your customers during checkout.

Basic Payment Methods
- Merchant Location
- Bank Transfer Payment
- Cash on Delivery
- Check / Money Order
- Purchase Order
- Zero Subtotal Checkout
- Saved Credit Cards

PayPal Payment Solutions
- PayPal Business Account
- PayPal Credit
- PayPal Payments Advanced
- PayPal Payments Pro
- PayPal Payments Standard
- PayPal Express Checkout
  - Save Customer Billing Address
  - Managing Order Transactions
  - Billing Agreements
  - Settlement Reports
- PayPal Payflow Pro
- PayPal Payflow Link
- PayPal Fraud Management Filter
- PayPal Solutions by Country

Payment Gateways
- Payment Solutions by Region
- Testing Credentials
- Authorize.Net

Payment Services
- 3D Secure Credit Card Validation
CHAPTER 47:

Basic Payment Methods

Magento Community Edition supports a wide variety of payment methods, services, and gateways that you can offer for your customers’ convenience. In addition to the payment methods in this guide, other solutions can be downloaded from Magento Connect. Topics in this chapter include:

- Merchant Location
- Bank Transfer Payment
- Cash On Delivery
- Check / Money Order
- Purchase Order
- Zero Subtotal Checkout
- Saved Credit Cards
Merchant Location

Setting the merchant location is the first step for configuring any payment method.

**To set the merchant location country:**

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left, under Sales, select **Payment Methods**.

2. In the upper-right corner, set **Current Configuration Scope** to either your website or leave it set to “Default Config.”

3. If necessary, click to expand the **Merchant Location** section.

4. Set **Merchant Country** to your country.

5. When complete, click the **Save Config** button.
Bank Transfer Payment

Magento Community Edition lets you accept payments transferred directly from customers' bank accounts to your merchant bank account.

![Bank Transfer Payment](image)

**To set up bank transfer payments:**

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left, under Sales, select **Payment Methods**.

2. Click to expand the **Bank Transfer Payment** section. Then, do the following:
   a. To activate Bank Transfer Payment, set **Enabled** to “Yes.”
   b. Enter a **Title** to identify Bank Transfer Payment during checkout.
   c. Set **New Order Status** to “Pending” until payment is authorized.
   d. Set **Payment from Applicable Countries** to one of the following:
      - All Allowed Countries: Customers from all countries specified in your store configuration can use this payment method.
      - Specific Countries: After choosing this option, the Payment from Specific Countries list appears. Select each country in the list where customers can make purchases from your store.
e. Enter the **Instructions** your customers must follow to set up a bank transfer. Depending on the country where your bank is located and your bank’s requirements, you might need to include the following information:

- Bank account name
- Bank account number
- Bank routing code
- Bank name
- Bank address

f. Set **Minimum Order Total** and **Maximum Order Total** to the amounts required to qualify to use this payment method.

3. Enter a **Sort Order** number to determine the position of Bank Transfer Payment in the list of payment methods during checkout. (0 = first, 1 = second, 2 = third, and so on.)

4. When complete, click the **Save Config** button.
Cash On Delivery

Magento Community Edition allows you to accept COD payments from your customers. With a cash on delivery payment, the customer pays at the time of delivery. The customer pays the order amount to the shipping carrier, who sends a check to you. Shipping carriers typically charge an extra fee for COD service. You can account for this fee in your shipping and handling charges.

To set up cash on delivery payments:

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left under Sales, select **Payment Methods**.

2. Click to expand the **Cash on Delivery Payments** section. Then, do the following:
   
a. To activate Cash on Delivery Payments, set **Enabled** to “Yes.”

   b. Enter a **Title** to identify the COD method during checkout.

   c. Set **New Order Status** to “Pending” until receipt of payment is confirmed.

   d. Set **Payment from Applicable Countries** to one of the following:

      All Allowed Countries  Customers from all **countries** specified in your store configuration can use this payment method.

      Specific Countries  Select each country in the list where customers can make purchases from your store.
e. Enter **Instructions** for making a COD payment.

f. Set **Minimum Order Total** and **Maximum Order Total** to the order amounts which are required to qualify for COD payment.

An order qualifies if the total is between, or matches, the minimum or maximum order total.

**g.** Enter a **Sort Order** number to determine the sequence in which COD is listed with other payment methods during checkout. (0 = first, 1 = second, 2 = third, and so on.)

3. When complete, click the **Save Config** button.
Check / Money Order

Magento Community Edition allows you to accept payments by either check or money order. The Check / Money Order payment method is enabled for your store by default.
To set up payment by check or money order:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Sales, select Payment Methods.

2. Click to expand Check / Money Order, and do the following:
   a. To activate the Check / Money Order payment method, set Enabled to “Yes.”
   b. Enter a Title to identify Check / Money Order during checkout.
   c. Set New Order Status to "Pending” until receipt of payment is confirmed.
   d. Set Payment from Applicable Countries to one of the following:
      - All Allowed Countries: Customers from all countries specified in your store configuration can use this payment method.
      - Specific Countries: After choosing this option, the Payment from Specific Countries list appears. Select each country in the list where customers can make purchases from your store.
   e. In the Make Check Payable To field, enter the name of the party to whom the check must be payable.
   f. In the Send Check To field, enter the street address or PO Box where the checks are mailed.
   g. Set Minimum Order Total and Maximum Order Total to the order amounts required to qualify for this payment method.

   An order qualifies if the total falls between, or exactly matches, the minimum or maximum total values.

   h. Enter a Sort Order number to determine the position of Check / Money Order in the list of payment methods that appears during checkout. (0 = first, 1 = second, 2 = third, and so on.)

3. When complete, click the Save Config button.
Purchase Order

A purchase order (PO) allows commercial customers to pay for purchases with prior authorization by referencing the PO number. During checkout, the customer is prompted to enter the purchase order number as the method of payment.

Always establish the credit worthiness of a customer before accepting payment by purchase order.

For example, your customer represents the company that sells computers and needs to buy some monitors from your store. In their accounting system, the customer creates a purchase order that is assigned a unique PO number. The customer places an order in your store using the Purchase Order payment method and references the PO number from their accounting system. All order-related documents, including the order confirmation email, invoice, shipment, and credit memo, will have the PO number on them. The company’s accounting department can reference the PO number on the Magento sales order to track the order. When the customer receives your invoice, the payment is processed in their accounts payable system.

To set up payment by purchase order:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Sales, select Payment Methods.

2. Click to expand the Purchase Order section. Then, do the following:
   a. To activate the Purchase Order payment method, set Enabled to “Yes.”
   b. Enter a Title to identify Purchase Order during checkout.
   c. Set New Order Status to “Pending” until payment is authorized.
   d. Set Payment from Applicable Countries to one of the following:
All Allowed Countries  Customers from all countries specified in your store configuration can use this payment method.

Specific Countries  After choosing this option, the Payment from Specific Countries list appears. Select each country in the list where customers can make purchases from your store.

e. Set Minimum Order Total and Maximum Order Total to the amounts required to qualify for this payment method.

An order qualifies if the total falls between, or exactly matches, the minimum or maximum total values.

f. Enter a Sort Order number to determine the position of Purchase Order in the list of payment methods during checkout. (0 = first, 1 = second, 2 = third, and so on.)

3. When complete, click the Save Config button.
Zero Subtotal Checkout

Zero Subtotal Checkout is available only for orders created from the Admin. It can be used for orders with a subtotal of zero that are taxed after any discount has been applied. This situation might occur when a discount covers the entire price of the purchase, and there is no additional charge for shipping. To save time, these orders can be set to invoice automatically.

Unlike other payment methods for which you can set order amount filters, this method contains an intrinsic order amount filter, so that the method appears only when the subtotal equals zero. Zero Subtotal Checkout can be used when:

- The product that the customer adds to the shopping cart is of the Downloadable or the Virtual product type and the price equals zero.
- The price of a Simple product is zero and the Free Shipping method is available.
- A coupon code that covers the full price of products and shipping is applied in the shopping cart.

To set up Zero Subtotal Checkout:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Sales, select Payment Methods.
2. Click to expand the Zero Subtotal Checkout section. Then, do the following:

   a. Enter a Title to identify the Zero Subtotal Checkout payment method during checkout from the Admin.
   b. Set Enabled to “Yes” to activate Zero Subtotal Checkout.
   c. Set New Order Status to “Pending” until payment is authorized.

      - Pending: The order is waiting for authorization.
      - Processing: Payment has been authorized, and the transaction is being processed.
d. Set **Automatically Invoice All Items** to “Yes” if you want to automatically invoice all items with a zero balance.

e. Set **Payment from Applicable Countries** to one of the following:

   - **All Allowed Countries**: Customers from all countries specified in your store configuration can use this payment method.
   - **Specific Countries**: After choosing this option, the Payment from Specific Countries list appears. Select each country in the list where customers can make purchases from your store.

f. Enter a **Sort Order** number to determine the position of Zero Subtotal Checkout in the list of payment methods during checkout from the Admin. (0 = first, 1 = second, 2 = third, and so on.)

3. When complete, click the **Save Config** button.
Saved Credit Cards

This option gives you the ability store credit card numbers to process offline. This method is useful when you have a card terminal in a “brick and mortar” store, or have access to a virtual terminal. As with all online payment methods, it is highly recommended that you configure an SSL certificate for your store.

Important! Saving customer card data is discouraged unless absolutely necessary. Even though the data is encrypted, being in possession of the data increases your security risk. If you save customer credit card numbers online, your store will be out of compliance with Payment Card Industry (PCI) requirements.
To set up the Saved Credit Cards:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Sales, select Payment Methods.

2. Click to expand the Saved CC section. Then, do the following:
   a. To activate the Saved CC payment method, set Enabled to “Yes.”
   b. Enter a Title to identify Saved CC as a payment method during checkout.
   c. Select the New Order Status to be assigned to all purchases made with Saved CC. The default value is “Pending.”

3. In the Credit Card Types list, select each credit card that you accept for payment by Saved CC.

4. To require customers to enter the three-digit code from the back of the card, set Request Card Security Code to "Yes."

5. If you subscribe to 3D Secure Card Validation, do the following:
   a. To activate the service, set 3D Secure Card Validation to "Yes."
   b. To be protected from chargeback liability, set Severe 3D Secure Card Validation to "Yes."
   c. In the Centinel API URL field, enter the URL provided by CardinalCommerce that is associated with your 3D Secure Card Validation account.

6. Set Payment from Applicable Countries to one of the following:
   - All Allowed Countries: Customers from all countries specified in your store configuration can use this payment method.
   - Specific Countries: After choosing this option, the Payment from Specific Countries list appears. Select each country in the list where customers can make purchases from your store.
   
   d. Enter the Minimum Order Total and Maximum Order Total to be applied to all transactions. To qualify, the order total must exactly match the minimum or maximum threshold, or fall somewhere in between.
   
   e. Enter a Sort Order number to determine the position of Saved Credit Card in the list of payment methods during checkout. (0 = first, 1 = second, 2 = third, and so on.)

7. When complete, click the Save Config button.
CHAPTER 48:

PayPal Payment Solutions

PayPal is a global leader in online payments and a fast and secure way for your customers to pay online. With PayPal and Magento Community Edition, you can accept payments from all major debit and credit cards, and PayPal account holders. Since customers don’t even need a PayPal account to pay with PayPal, both you and your customers can get extra convenience without extra effort.

The PayPal payment methods that are available in Magento, and the method names, are different depending on merchant location. For country-specific PayPal methods, see the list at the end of this chapter. The two PayPal payment methods that can be used all over the world are Express Checkout and PayPal Payments Standard. Topics in this chapter:

- PayPal Business Account
- PayPal Credit
- PayPal Payments Advanced
- PayPal Payments Pro
- PayPal Payments Standard
- PayPal Express Checkout
- Billing Agreements
- Settlement Reports
- PayPal Payflow Pro
- PayPal Payflow Link
- PayPal Fraud Management Filters
- PayPal Solutions by Country

PayPal payment methods are mutually exclusive, with the exception of PayPal Express Checkout. You cannot have more than one method enabled at a time. PayPal Express Checkout can be used with other PayPal payment methods except PayPal Payments Standard. PayPal Payments Standard cannot be enabled simultaneously with any other method, including Express Checkout.
Overview

PayPal Express Checkout

With PayPal Express Checkout enabled, customers can click the “Checkout with PayPal” button to make a secure payment from the PayPal site. You can use Express Checkout as a standalone solution, or in combination with one of the other solutions.

PayPal Credit

For US merchants, PayPal Credit is now a payment option during checkout. PayPal Credit, (formerly Bill Me Later) offers your customers access to financing, so they can buy now and pay later, at no additional cost to you. You are not charged when customers choose PayPal Credit, and only pay your normal PayPal transaction fee. You can also use free, ready-made banner ads and a prominent PayPal Credit button in checkout, to tell your customers while they shop that financing is available.

All-In-One Solutions

PayPal offers a variety of PCI-compliant solutions to meet the needs of your growing business.

PayPal Payments Advanced

(Includes Express Checkout) PayPal Payments Advanced offers your customers a secure checkout experience without leaving your site. Flexible templates and a low monthly fee make this an ideal choice for merchants who want to create a more customized checkout experience.

PayPal Payments Pro

PayPal Payments Pro brings you all the benefits of a merchant account and payment gateway in one, plus the ability to create your own, fully customized checkout experience.

- PayPal Payments Pro Hosted Solution (Includes Express Checkout)
- PayPal Payments Pro Payflow Edition (Includes Express Checkout) (UK only)

PayPal Payments Standard

PayPal Payments Standard is the easiest way to accept payments online. You can offer your customers the convenience of payment by credit card and PayPal by simply adding a checkout button to your site. During checkout, customers are redirected to PayPal to complete the payment part of the checkout process. There are no lengthy applications to complete, or monthly charges to set up in advance. When you make your first sale, PayPal will guide you through the process of setting up your account.
Payment Gateways

PayPal offers a choice of two payment gateway solutions for your business. You can let PayPal host your checkout on its secure payment site, or you can take control of the entire payment experience with a completely customizable solution.

PayPal Payflow Pro

PayPal Payflow Pro is a fully customizable payment gateway that can be used with any Internet merchant account to process credit card transactions online. Payflow Pro can also be used to process PayPal Express Checkout transactions.

PayPal Payflow Link

PayPal Payflow Link is a hosted payment gateway with an embedded checkout that keeps customers on your site. It’s the fast and easy way to add transaction processing to your site.

PayPal Access

The PayPal Access Card is like a debit card that can be used to spend or withdraw money from the PayPal balance of the cardholder. It can be used to make purchases online, or anywhere else that MasterCard is accepted. It’s like having your PayPal account in your wallet.

PayPal Access streamlines the process of opening an account with your store. When customers with PayPal Access register with your store, their address and contact information is read directly from their PayPal account.
PayPal Business Account

PayPal payment methods that are integrated with Magento require the merchant to have a PayPal business account and/or a PayPal Payflow account. The type of PayPal account that is required is specified in the description of each method.

Customers who make purchases using Express Checkout and the Express Checkout for Payflow Pro must have buyer accounts with PayPal to pay for their purchases. PayPal Payments Standard (and Website Payments Standard) can work either directly or through a buyer account, if the PayPal Account Optional parameter is enabled in the Premier or Business account of the merchant. By default, this parameter is enabled and customers can choose to enter their credit card information and the billing and shipping addresses and pay the order amount, or to create a buyer account with PayPal and then pay the order amount. When the parameter is disabled, the customer must create a buyer account with PayPal before paying for the order.

Website Payments Pro, Website Payments Pro Payflow Edition, Payflow Pro Gateway, and Payflow Link require the customer to enter credit card information during checkout.

Fraud filters can be managed from your PayPal merchant account.
PayPal Credit

For US merchants, PayPal Credit is now a payment option during checkout. PayPal Credit offers your customers access to financing, so they can buy now and pay later, at no additional cost to you. You are not charged when customers choose PayPal Credit, and only pay your normal PayPal transaction fee. You can also use free, ready-made banner ads and a prominent PayPal Credit button in checkout, to tell your customers while they shop that financing is available.

According to an August 2013 Forrester Consulting study commissioned by PayPal, PayPal Credit (Bill Me Later) can increase sales up to 18%, with about one-third resulting from the six months’ same-as-cash payment option. To learn more, visit the PayPal site.

Before you configure PayPal Credit in your store, make sure it is enabled in your PayPal account.

To enable PayPal Credit:

1. On the Admin menu, select System > Configuration.
2. In the panel on the left, under Sales, select Payment Methods.
3. Under PayPal Express Checkout, or one of the All-In-One solutions that includes PayPal Express Checkout, click the Configure link. Then, do the following:
   a. Click to expand Required PayPal Settings.
   b. Set Enable PayPal Credit to “Yes.”
4. Click the Save Config button.
Learn More about PayPal Credit

To enable PayPal Credit banners:

1. On the Admin menu, select **System > Configuration**.
2. In the panel on the left, under Sales, select **Payment Methods**.
3. Under PayPal Express Checkout, click the **Configure** link.
4. Click to expand **Required PayPal Settings** section. Then, click to expand **Advertise PayPal Credit** section.
5. Click the **Get Publisher ID from PayPal** button and follow the directions to get your account information. Then, enter your **Publisher ID**.

6. Click to expand the **Home Page** section. Then, do the following:
   
   a. To place a banner on the page, set **Display** to “Yes.”
   
   b. Set **Position** to one of the following:
      
      - Header (center)
      - Sidebar (right)
   
   c. Set **Size** to one of the following:
      
      - 190 x 100
      - 234 x 60
      - 300 x 50
      - 468 x 60
      - 728 x 90
      - 800 x 66

7. Repeat the previous step for each of the following sections:
   
   - Catalog Category Page
   - Catalog Product Page
   - Checkout Cart Page

8. When complete, click the **Save Config** button.

These examples do not represent the actual size of the banners, but show their relative shape and proportion.
PayPal Payments Advanced

PayPal Payments Advanced is a PCI-compliant solution that lets your customers pay by debit or credit card without leaving your site. It includes an embedded checkout page that can be customized to create a seamless and secure checkout experience.

Even customers without a PayPal account can make purchases through PayPal’s secure payment gateway. Accepted cards include Visa, MasterCard, Switch/Maestro, and Solo credit cards in the United States and United Kingdom. For additional convenience, PayPal Express Checkout is included with PayPal Payments Advanced.

You can have two PayPal solutions active at the same time: Express Checkout, plus any All-In-One or Payment Gateway solution. If you change payment solutions, the one used previously is disabled.

Checkout Workflow

With PayPal Payments Advanced, your customer stays on your site during the checkout process. The customer selects the PayPal Payments Advanced payment method on the Payment Information checkout step and clicks Continue.

The Order Review step appears, with the Pay Now button, instead of the Place Order button. After the customer clicks the Pay Now button, a PayPal-hosted form opens in the customer’s browser. The customer specifies the card information and clicks Verify Card. If the transaction is successful, the customer is redirected to the order confirmation page. The form also includes the Pay with PayPal button, which redirects the customer to the PayPal site, where payment can be made with PayPal Express Checkout.

If the transaction fails for any reason, an error message appears on the checkout page and the customer is directed to repeat the checkout process. These issue are managed by PayPal.

Order Processing Workflow

Processing orders with PayPal Payments Advanced is the same as processing any regular order with PayPal. An invoice, shipment, and credit memo (online/offline refund) can be created. Multiple online refunds are not available for the PayPal Payments Advanced payment method.

With PayPal Payments Advanced, an order is created in the Admin when a customer clicks the Place Order button. The order status can be any of the following, depending on the response from PayPal.

<table>
<thead>
<tr>
<th>Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Processing</td>
<td>The transaction was successful.</td>
</tr>
<tr>
<td>Pending Payment</td>
<td>The system did not receive any response from PayPal.</td>
</tr>
<tr>
<td>Canceled</td>
<td>The transaction was not successful for some reason.</td>
</tr>
<tr>
<td>Suspected Fraud</td>
<td>The transaction did not pass some of the PayPal fraud filters; the system receives the response from PayPal that the transaction is under review by Fraud Service.</td>
</tr>
</tbody>
</table>
PayPal Payments Advanced cannot be used for orders created from the Admin of your store.

Requirements

- PayPal Business Account

- If you manage multiple Magento websites, you must have a separate PayPal merchant account for each.

Setting Up PayPal Payments Advanced

For step-by-step configuration instructions, see PayPal Payments Advanced in the Magento Community Edition online user guide.
PayPal Payments Pro

PayPal Payments Pro brings you all the benefits of a merchant account and payment gateway in one, plus the ability to create your own, fully customized checkout experience. PayPal Express Checkout is automatically enabled with PayPal Payments Pro, so you can tap into more than 110 million active PayPal users.

For merchants outside the US, this method is called “PayPal Website Payments Pro.”

You can have two PayPal solutions active at the same time: PayPal Express Checkout, plus any one of the All-In-One solutions. If you change payment solutions, the one used previously is automatically disabled.

Checkout Workflow

After customers add products to their shopping carts, they can go to checkout by clicking the Proceed to Checkout button. In the Payment Information checkout section, they select the PayPal Direct Payment option, and enter the credit card information.

- PayPal Payments Pro lets your customer stay on your site during the checkout process.
- PayPal Express Checkout redirects your customer to the PayPal site to complete the transaction

Order Processing Workflow

If Payment Action is set to “Authorize,” Magento creates a sales order with the “Processing” status. In this case, the amount of money to be authorized is pending approval. With PayPal Payments Pro, you can process the payment online from either the Admin of your store, or from your PayPal merchant account. If Payment Action is set to “Sale,” Magento creates both a sales order and invoice.

When checking out products from the shopping cart to multiple addresses simultaneously, customers can choose to pay with PayPal Payments Pro. At the customer’s request, the store administrator can also create an order from the Admin, and process the transaction with PayPal Payments Pro.

An order can be voided online at any time until the order amount is fully invoiced. If required, the order can be online partially invoiced for a specified quantity of products. For each partial invoice submitted through the PayPal payment system, a separate transaction record with a unique ID and of the Capture transaction type will become available on the Transaction tab, and a separate invoice document will be created on the Invoices tab. The payment transaction of the type “Authorization” is closed only after the full order amount is captured.

When capturing the payment transaction, PayPal transfers the order amount from the buyer’s balance, bank account or credit card to the merchant’s account. If for any reason the customer returns the purchased products and claims a refund, as with order amount capturing and invoice creation, you can create an online refund either from the Admin or from your PayPal merchant account.
Make sure that instant payment notifications are enabled in your PayPal merchant account. An invoice is created in Magento only after an instant payment notification message is delivered to Magento from PayPal. Based on these notifications, you can receive detailed payment information on each transaction from PayPal after you click the Fetch button on the Transaction page of an order.

Requirements

☑ PayPal Business Account (with Direct Payments Activated)

Setting Up PayPal Payments Pro

For step-by-step configuration instructions, see PayPal Payments Pro in the Magento Community Edition online user guide.
PayPal Payments Standard

PayPal Payments Standard is the easiest way to accept payments online. You can offer your customers the convenience of payment both by credit card and PayPal by simply adding a checkout button to your store.

For merchants outside the US, this method is called “PayPal Website Payments Standard.”

With PayPal Payments Standard, you can swipe credit cards on mobile devices. There is no monthly fee, and you can get paid on eBay. Supported credit cards include Visa, MasterCard, Discover, and American Express. In addition, customers can pay directly from their personal PayPal accounts. PayPal Payments Standard is available in all countries on the PayPal worldwide reference list.

Checkout Workflow

During checkout, the customer is redirected to the PayPal site to complete the transaction. PayPal Payments Standard is a one-step process for customers whose credit card information is up-to-date in their personal PayPal accounts. All the customer needs to do is click the “Pay Now” button to complete the purchase.

Requirements

PayPal Business Account

Setting Up PayPal Payments Standard

PayPal Payments Standard cannot be enabled simultaneously with any other PayPal method, including Express Checkout. If you change payment solutions, the one you used previously is disabled.

For step-by-step configuration instructions, see PayPal Payments Standard in the online user guide.
PayPal Express Checkout

PayPal Express Checkout helps boost sales by giving your customers the ability to pay by credit card or from the security of their personal PayPal accounts. During checkout, the customer is redirected to the secure PayPal site to complete the payment information. The customer is then returned to your store to complete the remainder of the checkout process. Choosing Express Checkout adds the familiar PayPal button to your store, which has been reported to increase sales.

Customers with current PayPal accounts can make a purchase in a single step, by clicking the “Checkout with PayPal” button. Express Checkout can be added as a standalone, or added to an existing PayPal solution. If you already accept credit cards online, you can offer Express Checkout as an additional option to attract new customers who prefer to pay with PayPal. PayPal Express Checkout can be used as a standalone, or in combination with one of PayPal’s All-In-One solutions.

Checkout Workflow

With Express Checkout, the customer is redirected to the PayPal site to complete the transaction. Unlike other payment methods, PayPal Express Checkout allows the customer to check out at the beginning of the usual checkout flow. With the PayPal Express Checkout enabled, the “Checkout with PayPal” button is available on the product page, in the shopping cart, and mini shopping cart. Clicking the button redirects the customer to the PayPal website to review the purchase information. Customers must log in to their PayPal accounts to complete the transaction. The payment system uses the customer’s billing and shipping information from the customer’s PayPal account. The customer is then redirected back to the Magento Review Order page. After the customer places the order in Magento, the payment information is submitted to PayPal and the payment transaction is settled.

If the customer uses the one-page checkout and selects the Express Checkout payment method, the customer is redirected to PayPal during the Payment Review process, just before the sales order is submitted.

Express Checkout method of payment is unavailable if the customer chooses to check out the products from the shopping cart to multiple addresses. The store administrator cannot place an order using the Express Checkout method of payment, because it is also unavailable from the Admin.
Requirements

☑ Merchant: Personal PayPal Account

☑ Customer: Personal PayPal Account

Setting Up PayPal Express Checkout

You can have two PayPal solutions active at the same time: Express Checkout, plus an All-In-One solution. If you enable a different solution, the one used previously is automatically deactivated.

Process Overview:
Step 1: Configure Your PayPal Account
Step 2: Complete the Required Settings
Step 3: Complete the Basic Settings
Step 4: Complete the Advanced Settings
Step 1: Configure Your PayPal Account

1. Before you begin, you must configure your PayPal merchant account on the PayPal website.
   b. Go to Service Settings > Hosted Checkout Pages > Set Up, and make the following settings:
      
      AVS No
      CSC No
      Enable Secure Token Yes
   c. Save the settings.

2. PayPal recommends that you set up an additional user on your account. To set up an additional user, do the following:
   a. Go to manager.paypal.com and log in to your account.
   b. Follow the instructions to set up an additional user.
   c. Save the changes.

Step 2: Complete the Required Settings

1. On the Admin menu, select System > Configuration.

2. In the Configuration panel on the left, under Sales, select Payment Methods.

3. If your Magento installation has multiple websites, stores or views, set the Current Configuration Scope box in the upper-left corner to the target configuration.

4. In the Merchant Location section, select the Merchant Country where your business is located.

5. If necessary, click to expand the PayPal Express Checkout section. Then, click the Configure button.
6. Under Required PayPal Settings, in the Express Checkout section, complete the following:
   a. Enter the **Email Address** that is associated with your PayPal merchant account.

   **Important!** Email addresses are case sensitive. To receive payment, the email address you enter must match the email address specified in your PayPal merchant account.

   b. Set **API Authentication Methods** to one of the following:
      - API Signature
      - API Certificate

   c. If necessary, click the **Get Credentials from PayPal** button. Then, complete the following:
      - API Username
      - API Password
      - API Signature

   d. If you are using credentials from your sandbox account, set **Sandbox Mode** to “Yes.”
      If necessary, click the **Sandbox Credentials** button and follow the instructions to set up your testing environment.

   e. If your system uses a proxy server to establish the connection between Magento and the PayPal payment system, set **API Uses Proxy** to “Yes.” Then, complete the following:
      - Proxy Host
      - Proxy Port

7. When these sections are complete, set **Enable this Solution** to “Yes.”

8. To offer financing through PayPal to your customers, see **PayPal Credit** to learn more.

   You have now completed the Required PayPal Settings. At this point, you can either continue with the Basic and Advanced Settings, or click the **Save Config** button. You can return later fine-tune the configuration.
Step 3: Complete the Basic Settings

1. If your store has multiple views, make sure to set the **Current Configuration Scope** box in the upper-left corner to the view where these settings apply.

2. In the Basic Settings - PayPal Express Checkout section, complete the following:
   
   a. Enter a **Title** to identify this payment method during checkout. It is recommended to set the title to “PayPal” for each store view.

   b. If you offer multiple payment methods, enter a number in the **Sort Order** field to determine the sequence in which PayPal Payments Standard is listed with the other methods. Payment methods appear in ascending order based on the Sort Order value.

   c. Set **Payment Action** to one of the following:

      | Payment Action | Description |
      |----------------|-------------|
      | Authorization  | Approves the purchase, but puts a hold on the funds. The amount is not withdrawn until it is “captured” by the merchant. |
      | Sale           | The amount of the purchase is authorized and immediately withdrawn from the customer’s account. |
Order

The amount of the order is neither captured nor authorized in the customer’s balance, bank account, or credit card at PayPal. The Order payment action represents an agreement between the PayPal payment system and the merchant, which enables the merchant to capture one or more amounts up to the “ordered” total from the customer’s buyer account, over a maximum of 29 days. After the funds are “ordered,” the merchant can capture them at any time during the following 29 days. Capturing of the order amount can be done only from the Magento backend, by creating one or more invoices.

d. If Payment Action is set to “Order,” complete the following fields:

Authorization Honor Period (days) Defines how long the primary authorization stays valid. The value should be equal to the corresponding value in your PayPal merchant account. The default value in your PayPal merchant account is 3. To increase this number you need to contact PayPal. The authorization becomes invalid at 11:49 p.m., U.S. Pacific Time, of the last day.

Order Valid Period (days) Defines how long the order remains valid. When the order becomes invalid, you can no longer create invoices for it. Specify the value equal to the Order Valid Period value in your PayPal merchant account. The default value in your PayPal merchant account is 29. To change this number, you need to contact PayPal.

Number of Child Authorizations Defines the maximum number of authorizations for one order; that is, the maximum number of the online partial invoices you can create for one order. The number in this field should be equal to the corresponding setting in your PayPal merchant account. The default number of child authorizations in your PayPal account is 1. To increase this number, you need to contact PayPal.

e. To display the “Checkout with PayPal” button on the product page, set Display on Product Details Page to “Yes.”
Step 4: Complete the Advanced Settings

1. At the bottom of the Basic Settings section, click to expand Advanced Settings. Then, complete the following:

   a. Set Payment Applicable From to one of the following:

      - All Allowed Countries: Accepts payment from the countries already specified in your configuration.
      - Specific Countries: Accepts payments from only the countries you specify. Hold the Ctrl key down and in the Payment Applicable From list, click each country where you accept payment.

   b. Set Debug Mode to “Yes” to write communications with the payment system into the log file. The log file for PayPal Payments Advanced is payments_payflow_advanced.log.

      In accordance with PCI Data Security Standards, credit card information is not recorded in the log file.

   c. To enable host authenticity verification, set Enable SSL Verification to “Yes.”

   d. To display a full summary of the customer’s order by line item from the PayPal site, set Transfer Cart Line Items to “Yes.”

      To include up to ten shipping options in the summary, set Transfer Shipping Options to “Yes.” (This option appears only if line items are set to transfer.)

   e. To determine the type of image used for the PayPal acceptance button, set Shortcut Button Flavor to one of the following:

      - Dynamic: Displays an image that can be dynamically changed from the PayPal server.
      - Static: Displays a specific image that cannot be dynamically changed.

   f. To allow customers without PayPal accounts to make purchases with this method, set Enable PayPal Guest Checkout to “Yes.”

   g. Set Require Customer’s Billing Address to one of the following:

      - Yes: Requires the customer’s billing address for all purchases.
      - No: Does not require the customer’s billing address for any purchases.
      - For Virtual Quotes Only: Requires the customer’s billing address for virtual quotes only.
h. To specify whether the customer can sign a billing agreement with your store in the PayPal payment system when there are no active billing agreements available in the customer account, set **Billing Agreement Signup** to one of the following:

- **Auto**
  The customer can either sign a billing agreement during the Express Checkout flow or use another method of payment.

- **Ask Customer**
  The customer can decide whether to sign a billing agreement during the Express Checkout flow.

- **Never**
  The customer cannot sign a billing agreement during the Express Checkout flow.

The store owner needs to apply to PayPal Merchant Technical Support to enable billing agreements. The Billing Agreement Signup parameter must be enabled only after PayPal confirms that billing agreements are enabled for your merchant account.

i. To allow the customer to complete the transaction from the PayPal site without returning to your Magento store for Order Review, set **Skip Order Review Step** to “Yes.”

PayPal Express Checkout Advanced Settings

2. Complete the following sections as needed for your store:

**PayPal Billing Agreement Settings**

A billing agreement is a sales agreement between the merchant and customer that has been authorized by PayPal for use with multiple orders. During the checkout process, the Billing Agreement payment option appears only for customers who have already entered into a billing agreement with your company. After PayPal authorizes the agreement, the payment system
issues a unique reference ID to identify each order that is associated with the agreement. Similar to a purchase order, there is no limit to the number of billing agreements a customer can set up with your company.

1. To make billing agreements available to your customers, click to expand the PayPal Billing Agreement Settings section.

2. Set Enabled to “Yes.” Then, do the following:
   a. Enter a Title to identify the PayPal Billing Agreement method during checkout.
   b. If you offer multiple payment methods, enter a number in the Sort Order field to determine the sequence in which Billing Agreement appears when listed with other payment methods during checkout.
   c. Set Payment Action to one of the following:

<table>
<thead>
<tr>
<th>Authorization</th>
<th>Approval of purchase, but puts a hold on the funds. The amount is not withdrawn until it is “captured” by the merchant.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sale</td>
<td>The amount of the purchase is authorized and immediately withdrawn from the customer’s account.</td>
</tr>
</tbody>
</table>

d. Set Payment Applicable From to one of the following:

<table>
<thead>
<tr>
<th>All Allowed Countries</th>
<th>Accepts payment from the countries already specified in your configuration.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specific Countries</td>
<td>Accepts payments from only the countries you specify. Hold the Ctrl key down and in the Payment Applicable From list, click each country where you accept payment.</td>
</tr>
</tbody>
</table>

e. To record communications with the payment system in the log file, set Debug Mode to “Yes.”

   The log file is stored on the server and is accessible only to developers. In accordance with PCI Data Security Standards, credit card information is not recorded in the log file.

f. To enable SSL verification, set Enable SSL verification to “Yes.”

g. To display a summary of each line item in the customer’s order on your PayPal payments page, set Transfer Cart Line Items to “Yes.”

h. To allow customers to initiate a billing agreement from the dashboard of their customer account, set Allow in Billing Agreement Wizard to “Yes.”
Settlement Report Settings

1. Click to expand the Settlement Report Settings section.

2. If you have signed up for PayPal’s Secure FTP Server, enter the following SFTP login credentials:
   
   - Login
   - Password

3. To run test reports before “going live” with Express Checkout on your site, set Sandbox Mode to “Yes.”

4. Enter the Custom Endpoint Hostname or IP Address. By default, the value is: reports.paypal.com

5. Enter the Custom Path where reports are saved. By default, the value is: /ppreports/outgoing

6. To generate reports according to a schedule, under Scheduled Fetching, make the following settings:
   
   a. Set Enable Automatic Fetching to “Yes.”

   b. Set Schedule to one of the following:
       
       - Daily
       - Every 3 Days
       - Every 7 Days
       - Every 10 Days
       - Every 14 Days
       - Every 30 Days
       - Every 40 Days

   PayPal retains each report for forty-five days.
c. Set **Time of Day** to the hour, minute, and second when you want the reports to be generated.

![PayPal Settlement Report Settings](image)

**PayPal Settlement Report Settings**

### Frontend Experience Settings

The frontend experience settings give you the opportunity to choose which PayPal logos appear on your site, and to customize the appearance of your PayPal merchant pages.

1. Click to expand the **Frontend Experience Settings** section.

2. Select the **PayPal Product Logo** that you want to appear in the PayPal block in your store. The PayPal logos are available in four styles and two sizes. Options include:
   
   - No Logo
   - We Prefer PayPal (150 x 60 or 150 x 40)
   - Now Accepting PayPal (150 x 60 or 150 x 40)
   - Payments by PayPal (150 x 60 or 150 x 40)
   - Shop Now Using PayPal (150 x 60 or 150 x 40)

3. To customize the appearance of your PayPal merchant pages, do the following:
   
   a. Enter the name of the **Page Style** that you want to apply to your PayPal merchant pages. Options include:

      | Style              | Description                               |
      |--------------------|-------------------------------------------|
      | *paypal*           | Uses the PayPal page style.               |
      | *primary*          | Uses the page style that you identified as the “primary” style in your account profile. |
      | *your_custom_value*| Uses a custom payment page style, which is specified in your account profile. |
b. In the **Header Image URL** field, enter the URL of the image that you want to appear in the upper-left corner of the payment page. The maximum file size is 750 pixels wide by 90 pixels high.

PayPal recommends that the image be located on a secure (https) server. Otherwise, the customer’s browser may warn that “the page contains both secure and nonsecure items.”

c. Enter the six-character hexadecimal code, without the “#” symbol, for each of the following:

- **Header Background Color**  
  Background color for the checkout page header
- **Header Border Color**  
  2-pixel border around the header.
- **Page Background Color**  
  Background color for the checkout page and around the header and payment form.

![PayPal Frontend Experience Settings](image)

---

3. When complete, click the **Save Config** button.
Save Customer Billing Address

The complete billing address of the customer can be saved when the customer pays with PayPal Express Checkout. The billing address can be received from PayPal, and can be edited by the customer. Make sure that your PayPal merchant account is configured to save the customer billing address. Contact PayPal technical support for more information.

Billing Address Workflow

When customers choose to pay using PayPal Express Checkout, they are redirected to PayPal. After logging in to PayPal and reviewing the payment information, they are redirected back to the Order Review page of your store, where they can complete the checkout process and place the order.

If you have set up your PayPal Express Checkout Advanced settings to skip the order review step, the customer can pay for the order on the PayPal site by clicking the Pay Now button.

If a billing address cannot be received from PayPal because of your configuration or due to any other reasons, the billing address fields on the Order Review page are prepopulated with the shipping address values. A customer can edit them if necessary.

If a customer leaves the billing and shipping addresses unchanged, the Place Order button is enabled when the customer chooses the shipping method in the Shipping Method field.

If the customer edits the billing or shipping address, the Place Order button is disabled. When the customer clicks the Update Order Data button, the system updates the information, including the available shipping methods, and the Place Order button appears.

After the customer clicks Place Order, the order is created in Magento, and PayPal performs the related transaction(s). The complete billing and shipping addresses are saved in the order record in Magento.
To save the customer billing address:

1. On the Admin menu, select **System > Configuration**.
2. In the panel on the left, under Sales, select **Payment Methods**.
3. Under PayPal Express Checkout, click the **Configure** link, and do the following:
   a. Set **Require Customer’s Billing Address** to “Yes.”
   b. To request the customer’s billing address only for orders with downloadable and/or virtual products, set **Require Customer’s Billing Address** to “For Virtual Quotes Only.”
4. Click the **Save Config** button.

Managing Order Transactions

Magento includes the option to use the Order payment action for the PayPal Express Checkout payment method. When a store customer submits an order, having paid using the PayPal Express Checkout payment method, for which the Order payment action is set, the funds on the customer’s card are authorized. If the authorization times out before you capture all payment, the authorization is voided, and a new authorization and capture are conducted when you create an invoice. Only the amount equal to the invoice total is authorized and captured. The maximum number of these authorizations for one order, and the periods for which the first authorization and the order in general stay valid, depend on your PayPal merchant account settings. These parameters need to be specified in the Magento Admin Panel as well. Capturing can be done only from the Magento Admin Panel, by creating one or more invoices.

Situations in which using the Order transaction may be appropriate include the following:

- Back orders, in which available items are sent immediately, and the remaining part of the order is sent when available; this may include more than two shipments
- Split orders, in which ordered items are sent in more than one shipment, perhaps to different addresses, and you want to collect a payment for each shipment
- Drop shipments, which are shipments from other vendors for which you accept the payment

Using the Order payment action does not influence the checkout process for store customers.

Payment Action Set to “Order”

When the store customer submits the order, having paid using the PayPal Express Checkout payment method, for which the Order payment action is set, the order (with Processing status) is created in the Admin. Two transactions are created for this order: one with type Order and one with type Authorization.
The funds on the customer's account are put on hold, and you can capture the payment only from the Admin. To capture, you need to create an online invoice. When you choose to create an online invoice, Magento determines whether the number of days passed from the first authorization exceeds the Order Valid Period value. If more days have passed, you cannot create an online invoice for this order.

If the order is valid, Magento determines whether the first authorization is valid, comparing the number of days passed with the Authorization Honor Period value. If the authorization is valid, the necessary sum is captured; the rest is left on hold, and the number of captures is not limited. If the authorization is not valid anymore, it is voided. A new authorization and capture are created, but for the invoice total (not the order total). From this moment, each time you create an online invoice for this order, a new authorization and capture will be conducted only for invoice totals.

Also, Magento will determine whether the number of the conducted captures is equal to the Number of Child Authorizations value each time. If the number specified there is already reached, creating online invoices for the order will not be possible.
Billing Agreements

The Billing Agreement functionality enables customers to sign an agreement with the payment system and eases the process of checkout because customers do not need to specify payment information again and again. During the shopping cart checkout, the customer can simply choose a billing agreement as a payment method and based on its number; the payment system will charge the customer's account. The store administrator can manage customer's billing agreements from both the Customer and Sales sections of the Admin menu.

Sales Management

The list of all billing agreements for all customers is available under Sales > Billing Agreements. The store administrator can filter the records by the customer or billing agreement information including billing agreement reference ID, status, and creation date. A specific record provides general information about the selected billing agreement and about all sales orders that relate to it. The store administrator can view, cancel, or delete a customer's billing agreements in the Sales Management area. Billing agreements can be canceled or deleted by clicking the corresponding buttons located in the upper right part of the Billing Agreement page. An already canceled billing agreement can only be deleted by the store administrator.

Customer Management

Billing agreements created by a single customer can be seen on the Billing Agreements tab of the customer account page in the Admin (Customers > Manage Customers). From here, the store administrator can open a required billing agreement to view its general information and sales orders relating to it, cancel a billing agreement, or delete it.

Customer Account Workflow

Customers can create billing agreements by signing in to their customer accounts, selecting the billing agreement payment method, and initiating the Billing Agreement process. When a billing agreement is created, it is submitted to the PayPal payment system and recorded in the customer account, along with reference information. There is no limit to the number of billing agreements a customer can create. The customer can also cancel some, or all of the billing agreements on the Billing Agreement page of the customer account. The status of each billing agreement is shown as either “Active” or “Canceled.” When a billing agreement is canceled, it cannot be reactivated.

When checking out products from the shopping cart, a customer who has already entered into a billing agreement with PayPal can choose the PayPal Billing Agreement payment method in the Payment Information section of the checkout page, and select the billing agreement reference ID from the list. When the customer places the order, the billing agreement reference ID and sales order payment details are transferred to the PayPal payment system. After the payment system confirms the payment, a sales order is created in Magento.

Sales Order Workflow

Customers who do not yet have a billing agreement with PayPal can choose PayPal Express
Checkout, and select “Sign a billing agreement” to streamline the process. They are then redirected to the PayPal payment system where the billing agreement can be signed. After the billing agreement is signed, the customer returns to the checkout page, where the order is placed. A corresponding record appears in the billing agreements list.

Customers can also sign a billing agreement from the mini shopping cart or product page by clicking the “Checkout with PayPal” button. When making a purchase with PayPal Express Checkout, the customer can choose to enter into a billing agreement PayPal. If the customer cancels creating a billing agreement, the order is created through the normal PayPal payment process.

Customers with one or more billing agreements can still create a new billing agreement from their customer account, but cannot enter into a new billing agreement through PayPal Express Checkout.

When the customer signs a billing agreement during checkout, PayPal creates a payment transaction through PayPal Express Checkout, and a billing agreement reference ID is sent to the customer and to the store. The current order is not related to the billing agreement that is signed. Related billing agreement order records are created the next time the customer chooses to use the billing agreement as a payment method to place an order.
To enable billing agreements:

1. On the Admin menu, select **System > Configuration**.
2. In the panel on the left, under Sales, select **Payment Methods**.
3. Click the **Configure** button for one of the following PayPal solutions:
   - PayPal Express Checkout
   - PayPal Payments Advanced (includes Express Checkout)
   - PayPal Payments Pro (includes Express Checkout)
4. Scroll down to the PayPal Billing Agreement Settings section, and do the following:

   ![PayPal Billing Agreement Settings](image)

   **PayPal Billing Agreement Settings**

   a. Set **Enabled** to “Yes.”

   a. Enter a **Title** to identify the PayPal Billing Agreement method during checkout.

   b. If you offer multiple payment methods, enter a number in the **Sort Order** field to determine the sequence in which Billing Agreement appears when listed with other payment methods during checkout.

   c. Set **Payment Action** to one of the following:

      - **Authorization**: Approves the purchase, but puts a hold on the funds. The amount is not withdrawn until it is “captured” by the merchant.
      - **Sale**: The amount of the purchase is authorized and immediately withdrawn from the customer’s account.
d. Set **Payment Applicable From** to one of the following:

- **All Allowed Countries** accepts payment from the countries already specified in your configuration.
- **Specific Countries** accepts payments from only the countries you specify. Hold the Ctrl key down and in the Payment Applicable From list, click each country where you accept payment.

e. To record communications with the payment system in the log file, set **Debug Mode** to “Yes.”

   > The log file is stored on the server and is accessible only to developers. In accordance with PCI Data Security Standards, credit card information is not recorded in the log file.

f. To enable SSL verification, set **Enable SSL verification** to “Yes.”

g. To display a summary of each line item in the customer’s order on your PayPal payments page, set **Transfer Cart Line Items** to “Yes.”

h. To allow customers to initiate a billing agreement from the dashboard of their customer account, set **Allow in Billing Agreement Wizard** to “Yes.”

5. When complete, click the **Save Config** button.
Settlement Reports

The PayPal Settlement report provides the store administrator with the information about each transaction that affects the settlement of funds.

Before generating settlement reports, the store administrator must contact PayPal Merchant Technical Services to create an SFTP user account, and enable settlement reports and SFTP for the PayPal business account.

After configuring and enabling settlement reports in the PayPal merchant account, Magento will start generating reports within twenty-four hours.

The store administrator can fetch the most recent settlement reports by clicking the Fetch Updates button located in the upper right part of the page. After clicking it, a dialog box appears, stating that the system will connect to the PayPal SFTP server to fetch the reports. When all recent reports are added to the list, the Infolog message appears, stating the number of reports fetched. The report includes the following additional information for each transaction:

**To enable settlement reports:**

1. On the Admin menu, select **System > Configuration.** Then in the panel on the left under Sales, select **Payment Methods.**

2. Click the **Configure** button for one of the following PayPal solutions:
   - PayPal Express Checkout
   - PayPal Payments Advanced (includes Express Checkout)
   - PayPal Payments Pro (includes Express Checkout)

3. Scroll down to the Settlement Report Settings section, and do the following:

   ![Settlement Report Settings](image)
a. Enter your SFTP Credentials.

b. Complete the remaining information according to your business requirements.

   For detailed configuration instructions, see the topic for your PayPal solution.

c. When complete, click the Save Config button.

To view the settlement reports:

On the Admin menu, select Reports > Sales > PayPal Settlement Reports.

Field Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>PayPal Reference ID Type</td>
<td>One of the following reference codes:</td>
</tr>
<tr>
<td>Order ID</td>
<td></td>
</tr>
<tr>
<td>Transaction ID</td>
<td></td>
</tr>
<tr>
<td>Subscription ID</td>
<td></td>
</tr>
<tr>
<td>Preapproved Payment ID Options</td>
<td></td>
</tr>
<tr>
<td>Custom</td>
<td>The text entered by the merchant on the transaction in PayPal.</td>
</tr>
<tr>
<td>Transaction Debit or Credit</td>
<td>The direction of money movement of gross amount.</td>
</tr>
<tr>
<td>Fee Debit or Credit</td>
<td>The direction of money movement for fee.</td>
</tr>
</tbody>
</table>

Settlement Report

<table>
<thead>
<tr>
<th>FIELD</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report Date</td>
<td>The date when the settlement report was generated.</td>
</tr>
<tr>
<td>Merchant Account</td>
<td>The encrypted merchant account number generated by PayPal.</td>
</tr>
<tr>
<td>Transaction ID</td>
<td>The identification of a transaction of the money moving event. Transaction ID is generated by PayPal and cannot be changed by the merchant.</td>
</tr>
<tr>
<td>Invoice ID</td>
<td>The identification of an invoice generated within Magento. The field can be populated with either an invoice ID sent with the capture request or with the value of the invoice ID (if any) from the authorizing transaction.</td>
</tr>
<tr>
<td>PayPal Reference ID</td>
<td>The identification of a related, pre-existing transaction or event.</td>
</tr>
</tbody>
</table>
### Settlement Report (cont.)

<table>
<thead>
<tr>
<th>FIELD</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Event Code</td>
<td>The code assigned to the transaction according to the event that has initiated it. Among these can be website payments standard payment, express or direct checkout API, pre-approved payment, subscription payment, and so on.</td>
</tr>
<tr>
<td>Initiation Date</td>
<td>The date and time the transaction was initiated.</td>
</tr>
<tr>
<td>Completion Date</td>
<td>The date and time the transaction was completed.</td>
</tr>
<tr>
<td>Gross Amount</td>
<td>The amount of the payment between the two parties and before fees.</td>
</tr>
<tr>
<td>Fee Amount</td>
<td>The amount of fee associated with the settlement. All transaction fees are included in this amount. Fees are never amortized across several transactions.</td>
</tr>
</tbody>
</table>
PayPal Payflow Pro

PayPal Payflow Pro gateway, formerly known as Verisign, is a payment method available for customers of the USA, Canada, Australia, and New Zealand. Similar to other PayPal payment methods that are provided in Magento, PayPal Payflow Pro Gateway requires that the store owner have a merchant account at PayPal. The PayPal Payflow Pro gateway links the merchant account at PayPal and the merchant’s website, and acts both as a gateway and a merchant account. With PayPal Payflow Pro Gateway, payments are processed directly on the merchant websites and customers are not redirected to PayPal. Unlike other PayPal payment methods, the pricing for using the Payflow Pro Gateway method of payment is fixed no matter how many transactions are submitted. That is, merchants pay a fixed monthly fee plus a fixed fee for each transaction regardless of their number.

PayPal Payflow Pro allows customers to enter their credit card information during checkout, without leaving the store checkout page and without using PayPal hosted forms. Additionally, payments are accepted through PayPal Payflow Pro at the time an order is placed. PayPal Payflow Pro does not require customers to have buyer accounts at PayPal; but depending on the merchant country, customers may use their PayPal buyer accounts for paying through the gateway. You can view all Payflow Pro Gateway transactions in your PayPal business account.

Customer Workflow

After customers add products to their shopping carts and proceed to the checkout, they specify their billing and/or shipping addresses and the shipping method. Then, in the Payment Information section of the Checkout page, they can select the Payflow Pro payment method, enter the type of credit card, its number, expiration date, and the card verification number. Customers are not redirected to the PayPal website when they choose to pay with Payflow Pro Gateway. Depending on the payment action selected in the configuration of the payment method, either a sales order or a sales order and an invoice is created.

Order Processing Workflow

Orders paid with Payflow Pro Gateway can be processed online only from Magento. Here, you can submit an online invoice and as a result a corresponding transaction and an invoice will be created. Regarding order amount refunds, you can also submit them online from the created invoice.

Partial invoices are not available when using PayPal Payflow Pro. The Qty to Invoice field is unavailable for editing. The partial refund is unavailable as well.
PayPal Payflow Link

PayPal PayFlow Link is available for merchants in the United States and Canada only; this method requires a Payflow merchant account. PayFlow Link cannot be used for orders created from the Admin.

In general, order processing with PayPal PayFlow Link is the same as processing orders with PayPal. An invoice, shipment, and credit memo (online/offline refund) can be created. PayPal Payflow Link passes the card information directly to PayPal. It is never stored in Magento system. The customer is not required to have a PayPal account to use this method. Multiple online refunds are not available with PayPal PayFlow Link.

Customer Workflow

The customer selects the PayFlow Link payment method on the Payment Information checkout step and clicks Continue. The Order Review step appears, where the Pay Now button is available instead of the usual Place Order button. After the customer clicks Pay Now, the PayPal-hosted form, where the credit card information can be entered, loads in the checkout page. The customer specifies the card information and clicks Pay Now. If the transaction is successful, the customer is redirected to the order confirmation page.

The Cancel Payment link redirects the customer to the Payment Information step of the checkout, with the payment method selected. If the transaction fails on any reason, an error message appears on the checkout page and the customer is directed to repeat the checkout process. These situations are managed by PayPal.

Order Workflow

When a customer clicks the Pay Now button on the last checkout step, the order is created with a “Pending Payment” status. After the customer enters the card information and clicks the Pay Now button on the PayPal site, the status of the order changes, depending on the response the system receives from PayPal. If the customer clicks the Cancel Payment link, the order status changes to Canceled. The new order is created when a customer proceeds with the checkout.

<table>
<thead>
<tr>
<th>Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Processing</td>
<td>The transaction was successful.</td>
</tr>
<tr>
<td>Pending Payment</td>
<td>The system did not receive any response from PayPal.</td>
</tr>
<tr>
<td>Canceled</td>
<td>The transaction was not successful for some reason.</td>
</tr>
<tr>
<td>Suspected Fraud</td>
<td>The transaction did not pass some of the PayPal fraud filters. The system receives the response from PayPal that the transaction is under review by Fraud Service.</td>
</tr>
</tbody>
</table>
PayPal Fraud Management Filters

Magento Community Edition supports PayPal fraud management filters for owners of Website Payments Pro PayPal accounts. The filters can be used for orders that are paid by PayPal Express Checkout or PayPal Website Payments Pro. Fraud management filters are managed through your PayPal merchant account.

PayPal fraud management filters make it easier to detect and respond to fraudulent transactions, and can be configured to flag, hold for review, or deny riskier payments. Magento order status values changed according to the fraud filter settings.

Filter Actions

<table>
<thead>
<tr>
<th>ACTION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Review</td>
<td>If you set the filter action to “Review,” the suspected order receives the status “Payment Review” when the order is placed. You can review the order and approve, or cancel the payment in the Admin, or on the PayPal side. When you click the Accept Payment or the Deny Payment buttons, no new transactions for the order are created. If you change the status of the transaction on the PayPal site, you must click the Get Payment Update button in the upper-right corner of the Order page in the Admin to apply the changes. If you click Accept Payment or Deny Payment, the changes made at the PayPal site are applied.</td>
</tr>
<tr>
<td>Deny</td>
<td>If you set the filter action to “Deny,” the suspected order cannot be placed by the customer, because the corresponding transaction is rejected by PayPal. To deny the payment from the Admin, click the Deny Payment button in the upper-right corner of the page. The order status changes to “Canceled,” the transaction is reverted, and funds are released on the customer’s account. The corresponding information is added in the Comments History section of the order view.</td>
</tr>
<tr>
<td>Flag</td>
<td>If you set the filter action to “Flag”, the suspected order gets the status ”Processing” when it is placed. The corresponding transaction is marked with a “flag” in the list of the merchant account transactions.</td>
</tr>
</tbody>
</table>
## PayPal Solutions by Country

### PayPal Solutions

<table>
<thead>
<tr>
<th>COUNTRY</th>
<th>PAYPAL PAYMENT SOLUTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>United States</td>
<td>PayPal Payments Advanced (Includes Express Checkout)</td>
</tr>
<tr>
<td></td>
<td>PayPal Payments Pro (Includes Express Checkout)</td>
</tr>
<tr>
<td></td>
<td>PayPal Payments Standard+</td>
</tr>
<tr>
<td></td>
<td>PayPal Payflow Pro (Includes Express Checkout)</td>
</tr>
<tr>
<td></td>
<td>PayPal Payflow Link (Includes Express Checkout)</td>
</tr>
<tr>
<td></td>
<td>PayPal Express Checkout</td>
</tr>
<tr>
<td>Canada</td>
<td>PayPal Payments Pro (Includes Express Checkout)</td>
</tr>
<tr>
<td></td>
<td>PayPal Payments Standard</td>
</tr>
<tr>
<td></td>
<td>PayPal Payflow Pro</td>
</tr>
<tr>
<td></td>
<td>PayPal Payflow Link (Includes Express Checkout)</td>
</tr>
<tr>
<td></td>
<td>PayPal Express Checkout</td>
</tr>
<tr>
<td>Australia</td>
<td>PayPal Payments Standard</td>
</tr>
<tr>
<td></td>
<td>PayPal Payflow Pro</td>
</tr>
<tr>
<td></td>
<td>PayPal Payments Pro Hosted Solution</td>
</tr>
<tr>
<td></td>
<td>PayPal Express Checkout</td>
</tr>
<tr>
<td>United Kingdom</td>
<td>PayPal Express Checkout</td>
</tr>
<tr>
<td></td>
<td>PayPal Payments Standard</td>
</tr>
<tr>
<td></td>
<td>PayPal Payments Pro Payflow Edition (Includes Express Checkout)</td>
</tr>
<tr>
<td></td>
<td>PayPal Payments Pro Hosted Solution</td>
</tr>
<tr>
<td>Japan</td>
<td>PayPal Express Checkout</td>
</tr>
<tr>
<td></td>
<td>PayPal Payments Standard</td>
</tr>
<tr>
<td></td>
<td>PayPal Website Payments Plus (PayPal Payments Pro Hosted Solution)</td>
</tr>
<tr>
<td>France</td>
<td>PayPal Express Checkout</td>
</tr>
<tr>
<td></td>
<td>PayPal Payments Standard</td>
</tr>
<tr>
<td></td>
<td>PayPal Integral Evolution (PayPal Payments Pro Hosted Solution)</td>
</tr>
<tr>
<td>Italy</td>
<td>PayPal Express Checkout</td>
</tr>
<tr>
<td></td>
<td>PayPal Payments Standard</td>
</tr>
<tr>
<td></td>
<td>PayPal Pro (PayPal Payments Pro Hosted Solution)</td>
</tr>
<tr>
<td>Spain</td>
<td>PayPal Express Checkout</td>
</tr>
<tr>
<td></td>
<td>PayPal Payments Standard</td>
</tr>
</tbody>
</table>
### PayPal Solutions (cont.)

<table>
<thead>
<tr>
<th>COUNTRY</th>
<th>PAYPAL PAYMENT SOLUTION</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>PayPal Pasarela integral (PayPal Payments Pro Hosted Solution)</td>
</tr>
<tr>
<td>Hong Kong</td>
<td>PayPal Express Checkout</td>
</tr>
<tr>
<td></td>
<td>PayPal Payments Standard</td>
</tr>
<tr>
<td></td>
<td>PayPal Payments Pro Hosted Solution</td>
</tr>
<tr>
<td>New Zealand</td>
<td>PayPal Express Checkout</td>
</tr>
<tr>
<td></td>
<td>PayPal Payments Standard</td>
</tr>
<tr>
<td></td>
<td>PayPal Payflow Pro</td>
</tr>
<tr>
<td>Others</td>
<td>PayPal Express Checkout</td>
</tr>
<tr>
<td></td>
<td>PayPal Payments Standard</td>
</tr>
</tbody>
</table>
CHAPTER 49:
Payment Solutions & Gateways

Magento Community Edition supports a wide range of payment solutions and gateways that offer merchant services in all parts of the world. Unlike some payment solutions that transfer control to complete the transaction on another site, a payment gateway makes it possible for you to accept credit card payments directly from your store.

![Checkout Payment Information](image-url)
Payment Solutions by Region

Worldwide

Amazon Simple Pay

Amazon offers easy payment and checkout solutions for physical goods retailers that allow customers to use their Amazon.com accounts as a payment method. Magento Community Edition supports the following payment solutions from Amazon:

- Amazon Simple Pay
- Checkout by Amazon

Authorize.Net

Authorize.Net includes free fraud tools, free customer support, a free website seal, and the ability to accept multi-channel payments: online, mail order/telephone order, retail and mobile. Trusted by 300,000 customers.

ChronoPay

Established in Amsterdam in 2003, ChronoPay offers payment solutions for the global market. The company has a large presence in the Russian market. Magento Community Edition supports the following ChronoPay payment solutions:

- ChronoPay Standard
- ChronoPay Gateway

CyberSource

CyberSource, a wholly-owned subsidiary of Visa Inc., is a payment management company. Over 330,000 businesses worldwide use CyberSource to process online payments, streamline fraud management, and simplify payment security.

First Data

Fast, convenient, and secure. With over forty years of industry leading experience Express Merchant Processing Solutions (EMPS) powered by First Data helps millions of businesses like yours bring safe, easy, cost-effective payments to their customers with affordable support, regardless of size.
PayPal

With PayPal’s deep integration with Magento, you can easily accept credit cards and PayPal payments using PayPal, all while keeping customers on your site. Already have a merchant account? Add PayPal Express checkout to increase conversion.

Europe

CyberMut Payment

CyberMut is a secure payment service operated by the French Bank, Crédit Mutuel. To use CyberMut, you must open a business account with the bank.

iDEAL

iDEAL is a collection of technical agreements between banks and transaction processors (a protocol) and not a centralized electronic payment system. The iDEAL protocol provides an immediate online transfer from the buyer’s bank account to the bank account of the online store. Magento Community Edition support the following iDEAL payment solutions:

- iDEAL Basic
- iDEAL Advanced

Ogone

Ogone Payment Services delivers non-face-to-face businesses the payment solutions platform, added value opportunities and technology advancements that become essential for the way payments are performed, managed and secured today.

Paybox

Paybox Services provides merchant accounts and eCommerce payment services for merchants in Europe. Magento Community Edition supports the following Paybox payment methods:

- Paybox Direct
- Paybox System

Protx Standard (Sage Pay)

Protx is one of the largest payment processors in the United Kingdom. In 2006, Protx was acquired by Sage Pay.
Oceania

**eWAY Direct**

Focusing on high-level standards in technology, innovations and customer care, eWay has become Australia’s award-winning payment gateway. eWAY specializes in delivering successful eCommerce payment gateway services to thousands of merchants. Magento Community Edition supports the following eWAY payment methods:

- eWAY Direct
- eWAY Shared
- eWAY 3D Secure

**Flo2Cash Payment Web Service**

New Zealand-based Flo2Cash provides and approves Credit Card and Direct Debit facilities and is a leading provider of payment processing services and solutions, which enables businesses of all sizes to streamline their payment processes; this in turn improves cash flow and reduces operating expense.
## Testing Credentials

When testing the configuration of a payment gateway, use the following credentials for test transactions.

<table>
<thead>
<tr>
<th>Card Type</th>
<th>Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>Visa</td>
<td>4111111111111111</td>
</tr>
<tr>
<td>MasterCard:</td>
<td>5555555555554444</td>
</tr>
<tr>
<td>American Express:</td>
<td>378282246310005</td>
</tr>
<tr>
<td>Expiration Date:</td>
<td>Any future date</td>
</tr>
<tr>
<td>CVV/CVC:</td>
<td>123 or 000</td>
</tr>
</tbody>
</table>
Authorize.Net

Authorize.Net gives merchants the ability to accept credit card and payments through the Authorize.Net payment gateway. It processes the credit card information entered during checkout, and creates a transaction either for the payment authorization or for the payment authorization and a capture of the funds, depending on the configuration.

Authorize.Net can be used to pay for purchases made from the storefront or for orders placed from the Admin. Orders that use the Authorize.Net payment method can be processed from your store's Admin and also from the Authorize.Net merchant account. Based on the response that Magento receives from Authorize.Net, an order is created in Magento with an assigned Authorize.Net transaction number.

Capture Workflow

Authorize.Net does not allow partial invoices to be created from Magento. The Qty to Invoice field cannot be edited on the New Invoice for Order page. When an invoice is captured online, a corresponding document with status of “Paid” is created and appears in the list of Invoices. In addition, a Capture transaction is added to the list of Transactions.

You can partially capture the order amount from the Authorize.Net merchant account. However, Authorize.Net does not allow for the remaining amount to be captured. In the case of a partial capture from Authorize.Net, no invoice or transaction is created in Magento for the order.

To find an order:

1. On the Admin menu, select Sales > Orders.
2. In the list, click to open the order.
3. On the order detail page, click the Invoice button.

   The order Amount field has the following payment actions:
## Payment Actions

<table>
<thead>
<tr>
<th>PAYMENT ACTION</th>
<th>DESCRIPTION</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Capture Online</td>
<td>When an invoice is submitted, the system captures the payment amount through the external payment gateway. In this case, an invoice and a transaction of the “Capture” type are added to the order detail page. If a payment is captured online, you can later create an online credit memo from the invoice, if required.</td>
<td>A payment capture transaction can be voided only from your Authorize.Net merchant account.</td>
</tr>
<tr>
<td>Capture Offline</td>
<td>When an invoice is submitted using this option, the system does not capture the payment, and only an offline invoice is created in Magento. It is assumed that the payment will be captured directly through the payment gateway. You do not have the option to capture the payment online through Magento.</td>
<td>If the invoice is captured offline, you cannot create an online refund from Magento.</td>
</tr>
<tr>
<td>Not Capture</td>
<td>When an invoice is submitted using this option, Magento does not capture the payment, and no corresponding transaction is created in the Authorize.Net merchant account. However, it is assumed that you will capture the payment online through Magento at a later date. Therefore, the Capture button is available in the completed invoice, which has a status temporarily set to “Pending.”</td>
<td>The order can be canceled at any time before the payment is captured. After the payment has been captured, a credit memo must be generated to cancel the order.</td>
</tr>
</tbody>
</table>
Authorize.Net Configuration

The Authorize.Net payment gateway gives you the ability to accept credit card and electronic check payments in USD, quickly and inexpensively.

To configure Authorize.Net:
See the step-by-step instructions in the online user guide. For field descriptions, click the link below the screenshot.
Partial Authorization with Authorize.Net

Authorize.Net gives you the ability to accept multiple credit cards as payment for a single order. If there isn’t enough remaining balance on a single card to cover the purchase, the amount can be distributed across multiple cards. Up to five credit cards can be used to pay for a single order. Partial authorization can be activated in the Authorize.Net configuration at either the global, or website level.

Customer Workflow

During the checkout process, the customer selects Authorize.Net, enters the card information, and proceeds to Order Review. When the customer clicks the Place Order button, the request is sent to Authorize.Net. If the amount available on the card is not enough to cover the order total, the following message appears:

```
The amount on your credit card is insufficient to complete your purchase. The available amount has been put on hold. To complete your purchase, click Continue and specify additional credit card number. To cancel the purchase and release the amount on hold, click Cancel.
```

If the customer chooses to continue, the Payment Information checkout step reappears, and the customer is prompted to enter another credit card. The information about the previously used credit cards appears as well.
If the customer clicks the Cancel button, all authorizations are reversed. The customer can then choose another payment method to complete the purchase. If the customer closes the browser window, the authorizations remain active until they expire. The term of each authorization depends on the bank that issued the credit card. An order is created only after the total amount of the order is captured.

If the customer reaches the limit of five cards that can be used for one order, the following message appears during Order Review:

You have reached the maximum number of credit cards that can be used for the payment.

When the customer clicks the OK button, the Payment Information checkout step reappears, with the following message:

You have reached the maximum number of credit cards that can be used for one payment. The available amounts on all used cards were insufficient to complete payment. The payment has been canceled and amounts on hold have been released.

The system sends a request to Authorize.Net to void all authorizations of this payment. The customer can now choose another payment method, or try a different credit card.

During partial authorization, the bank might reject the transaction, For example, the daily limit for the card might be exceeded. In this case, Authorize.Net sends the appropriate response to Magento and the following message appears:

Your credit card has been declined. Click Continue to specify another credit card to complete your purchase. Click Cancel to release the amount on hold and select another payment method.

If the customer decides to reverse the payment and clicks Cancel, the payment is reversed, and a request is sent to Authorize.Net to release the amounts on hold from the previously entered cards. The customer can then select another payment method. If the customer chooses to continue, the Payment Information checkout step reappears, and the customer is prompted to enter another credit card.

Before the order is placed, the customer can click the Cancel button from the Payment Information step to reverse all authorizations and release all amounts.

If the customer changes any order information after having started the partial authorization process, an error will occur when the order is submitted. In such a case, all authorizations are released, and the customer is redirected to the Payment Information checkout step.
Admin Workflow

Partial authorization can be applied to new orders and recorders from the Admin. After you choose the Authorize.Net payment method, enter the card information, and click the Submit Order button, the request is sent to Authorize.Net. If the amount on the card is not enough to cover the order, the available funds are put on hold, and the partial authorization is triggered. A message appears on the Create New Order page, asking if you want to continue. If you choose to continue, the system displays the information about the previously used credit cards, and prompts you to enter another credit card. If you click the Cancel button, all authorizations are reversed.

If you close the browser window during the partial authorization process, the authorizations remain active until they expire. The term of authorization depends on the bank that issued the credit card.

If payment is not complete, you can click the Cancel button in the upper-right corner. Magento then sends a request to Authorize.Net to void the authorization for all cards that were entered during the process, and the amounts on hold are released. If the payment gateway is not able to void authorization for some transactions, the order is canceled by the system only.

Do not change any order information after the partial authorization process begins. Otherwise, an error occur when you submit the order, and all authorizations are released automatically.
Refund Workflow

When processing a refund for an order that was paid with partial authorizations, Magento refunds the correct captured amount to each card. The process is managed by the system, and requires no action on your part.

When initiating an online invoice or refund, and some authorizations fail, the system proceeds with the remaining authorizations, but does not generate the invoice or refund. After all authorizations have been processed, information about the successful authorizations, as well as any that failed, appears in the header of the order. The same information is added to the order comments section of the order. The administrator is then prompted to process the failed authorizations manually, by creating an offline invoice or offline refund in Magento.

For a partial refund, the amounts are refunded to the cards from which they originated, in the order of authorization. The amount captured from the first card is the first to be refunded. In this order, it is possible for the amount reversed on the last card to be less than what was captured during the partial authorization process. In this case the transaction for the card remains open, and can be closed in the next partial refund.

Magento stores only the last four digits of the credit card number. For a period of 120 days after the payment, Authorize.Net allows merchant systems to submit a refund using the last four digits of the credit card. After 120 days have passed, you cannot process an online refund for an order that was paid with Authorize.Net.

Because American Express does not support authorization reversals, it is not possible to create an online refund for any purchases paid for with this method. In such a case, you can create an offline refund, and settle the situation by releasing the customer’s funds through the appropriate merchant account, outside of the Magento system.

To enable partial authorization:

1. On the Admin menu, select **System > Configuration**.

2. In the panel on the left under Sales, select **Payment Methods**. Then, click to expand the **Authorize.Net** section.

3. Set **Allow Partial Authorization** to “Yes.”

4. When complete, click the **Save Config** button.
Direct Post

Magento Community Edition incorporates the Direct Post method for payments made through Authorize.Net. When payments are made with Direct Post, Authorize.Net handles all steps in the transaction process—such as payment data collection, data submission, and response to the customer—while the customer remains in your store.

Admin Workflow

Authorize.Net Direct Post can be used with orders created from the Admin as well as from the store. When creating an order, you can select it in the Payment Method section. After selecting the option, the credit card data entry fields appear. If the transaction fails, an error message appears, and you can select another payment method or try again with another card. The order process is similar to the standard order workflow. As with other orders, and invoice, shipment, and credit memo can be created.

Customer Workflow

When Direct Post is enabled, the customer can select it in the Payment Information section of the checkout process. After the customer clicks the corresponding option button and clicks Continue, the Order Review section of the checkout appears, with fields to enter the credit card information. The customer then specifies the card information and clicks the Place Order button.
If the transaction is successful, the customer is redirected to the order confirmation page. If the transaction fails on some reason, an error message is displayed in a dialog box and the customer may then select another payment method or try Authorize.Net Direct Post with another card.

**To configure Authorize.net Direct Post:**

See the [step-by-step instructions](#) in the online user guide. For field descriptions, click the link below the screenshot.
CHAPTER 50: Payment Services

Your Magento Community Edition includes support for the following service to provide an additional layer of protection against fraudulent charges and chargebacks for sales.

3D Secure Credit Card Validation

3D Secure Credit Card Validation provides an additional layer of protection against fraudulent charges and chargebacks for sales. The service is available only for eligible payment gateways, and must be enabled in the gateway configuration.

PayPal Fraud Management Filters

Magento Community Edition includes support for PayPal fraud management filters available for Website Payments Pro PayPal accounts, and orders that are paid with either PayPal Express Checkout or Website Payments Pro.
3D Secure Credit Card Validation

Magento Community Edition includes the option to use 3D Secure authentication for payment transactions made with Authorize.Net. Cardinal Centinel® is the company that provides the 3D Secure Credit Card Validation service.

During checkout, the customer is prompted to enter a secret code that is assigned to the card, which is then used to confirm the identity of the cardholder. The bank also provides additional data elements to confirm the cardholder's identity. The service provider arranges the communication between the banks and payment systems. 3D Secure authentication can be used for orders placed from the store, or from the Admin.

Customer Workflow

During the checkout process, the customer selects the Authorize.Net payment method, enters the credit card information, and clicks the Continue button. During Order Review, the bank that issued the credit card displays a form to verify the customer's identity. Depending on the bank's requirements, the customer might be required to enter a secret code, log in to an account, or complete another activity.

After submitting the form, the customer is returned to Order Review. The customer clicks the Place Order button. If the authentication succeeds, the customer proceeds to the order confirmation page. If the authentication fails for any reason, an error message appears and the customer can select another payment method or try again with Authorize.Net.
Admin Workflow

When creating an order from the Admin that uses 3D Secure with Authorize.Net, a form appears with the fields to enter the credit card information, and a Start/Reset Validation button. After you complete the credit card information, and click the Start/Reset Validation button, the bank that issued the credit card displays a form to verify the customer's identity. Depending on the bank’s requirements, you might be required to enter a secret code, log in to an account, or complete another activity on behalf of the customer. If successful, a message indicates that the transaction has been validated, and you can proceed with the order.

3D Secure Authentication from the Admin

To configure 3D Secure Credit Card Validation:
See the step-by-step instructions in the online user guide. For field descriptions, click the link below the screenshot.
Shipping
Shipping

Studies have shown that stores that offer a choice of several shipping methods have higher conversion rates than those that use a single method for all shipments. In this section, you will learn how to set up a variety of shipping methods and carriers, and print shipping labels.

Basic Shipping Methods
Shipping Settings
Flat Rate
Free Shipping
Table Rates
Online Rates
Dimensional Weight

Shipping Carriers
UPS
USPS
FedEx
DHL

Package Type by Carrier

Shipping Labels
Shipping Label Workflow
Shipping Label Setup
Creating Shipping Labels
Creating a Package
CHAPTER 51:

Basic Shipping Methods

Magento Community Edition supports a wide range of shipping methods and carriers. This section shows how to configure the following basic shipping methods.

Before you proceed, make sure that you have completed the Shipping Settings to establish the point of origin for your store, and your preference for handling orders shipped to multiple addresses. Topics in this chapter include:

- Shipping Settings
- Flat Rate
- Free Shipping
- Table Rates
- Online Rates
- Dimensional Weight
Shipping Settings

The Shipping Settings establish the point of origin for all shipments made from your store or warehouse, and determine if you support shipments to multiple addresses. The point of origin also determines the store tax rate for products sold.

To establish the point of origin:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Sales, click Shipping Settings.

2. Click to expand the Origin section, and complete the following:
   - Country
   - Region / State
   - ZIP / Postal Code
   - City
   - Street Address (and line 2, if needed)

3. When complete, click the Save Config button.
To support shipments to multiple addresses:

1. Continuing in the Shipping Settings section, click to expand the Options section, and complete the following:

2. Set Allow Shipping to Multiple Addresses to “Yes.”

3. To limit the number of address you accept per shipment, enter the number in the Maximum Qty Allowed for Shipping to Multiple Addresses field.

4. When complete, click the Save Config button.
Flat Rate

Flat rate is a fixed, predefined charge that can be applied per item, or per shipment. Flat rate is a simple solution, especially when used with the flat-rate packaging that is available from some carriers.

To set up flat rate shipping:

1. On the Admin menu, select System > Configuration. In the panel on the left under Sales, select Shipping Methods.

2. Click to expand the Flat Rate section. Then, do the following:
   a. Set Enabled to “Yes.”
      
      Flat Rate appears as an option in the Estimate Shipping and Tax section of the shopping cart, and also in the Shipping section during checkout.
   b. Enter a descriptive Title for this shipping method. The default is “Flat Rate.”
   c. Enter a Method Name that appears next to the calculated rate in the shopping cart. The default method name is “Fixed.” If you charge a handling fee, you can change the Method Name to “Plus Handling” or something else that is suitable.
   d. To describe how flat rate shipping can be used, set Type to one of the following:
None

None disables the payment type. The Flat Rate option is listed in the cart, but with a rate of zero—which is the same as free shipping.

Per Order

Per Order charges a single flat rate for the entire order.

Per Item

Per Item charges a single flat rate for each item. The rate is multiplied by the number of items in the cart, regardless of whether there are multiple quantities of the same, or of different items.

e. Enter the Price to be charged for the flat rate fee.

f. If charging a handling fee, set **Calculate Handling Fee** to one of the following:

- Fixed
- Percent

Then, enter the **Handling Fee** rate according to the method used to calculate the fee. For example, if the fee is calculating based on a percentage, enter 0.06 for 6 percent. If using a fixed amount calculation, enter the fee as a decimal.

g. In the **Displayed Error Message** box, type the message that appears if this method becomes unavailable.

h. Set **Ship to Applicable Countries** to one of the following:

- All Allowed Countries
  
  Customers from all countries specified in your store configuration can use this shipping method.

- Specific Countries
  
  After choosing this option, the Ship to Specific Countries list appears. Select each country in the list where this shipping method can be used.

i. Enter a **Sort Order** number to determine the position of Flat Rate in the list of shipping methods during checkout. (0 = first, 1 = second, 2 = third, and so on.)

3. When complete, click the **Save Config** button.
Free Shipping

Free shipping is one of the most effective promotions you can offer. It can be based on a minimum purchase, or set up as a shopping cart price rule that applies when a set of conditions is met. If both apply to the same order, the configuration setting will take precedence over the shopping cart rule.

Check your shipping carrier configuration for any additional settings that may be required for free shipping.

To set up free shipping:

1. On the Admin menu, select System > Configuration. In the panel on the left, under Sales, select Shipping Methods.

2. Click to expand the Free Shipping section. Then, do the following:
   a. Set Enabled to “Yes.”
   b. Enter a Title for this shipping method that will be displayed during checkout.
   c. Enter a descriptive Method Name to identify the Free Shipping method.
   d. Enter the Minimum Order Amount to qualify for free shipping.

To use Free Shipping with Table Rates, you must enter a Minimum Order Amount so high that it is never met. This prevents Free Shipping from going into effect, unless triggered by a price rule.
e. In the **Displayed Error Message** box, type the message to appear if this method becomes unavailable.

f. Set **Ship to Applicable Countries** to one of the following:

- **All Allowed Countries**: Customers from all *countries* specified in your store configuration can use this shipping method.
- **Specific Countries**: After choosing this option, the Ship to Specific Countries list appears. Select each country in the list where this shipping method can be used.

> g. Set **Show Method if Not Applicable** to one of the following:

- **Yes**: Always shows the Free Shipping method, even when not applicable.
- **No**: Shows the Free Shipping method only when applicable.

> h. Enter a **Sort Order** number to determine the position of Free Shipping in the list of shipping methods during checkout. (0 = first, 1 = second, 2 = third, and so on.)

3. When complete, click the **Save Config** button.

4. Make sure that you complete any configuration that is required for each carrier that you plan to use for free shipping. For example, assuming that your UPS configuration is complete, make the following settings to enable and configure free shipping:

a. From the Shipping Methods configuration, click to expand the **UPS** section.

b. In the UPS section, set **Free Method** to “Ground.”

c. To require a minimum order for free shipping, set **Free Shipping with Minimum Order Amount** to “Enable.”

d. Enter the required amount in the **Minimum Order Amount for Free Shipping** field.

5. When complete, click the **Save Config** button.
Table Rates

The table rate shipping method lets you set up a table to calculate shipping rates for a combination of conditions. The shipping rate can be based on the following:

- Weight v. Destination
- Price v. Destination
- # of Items v. Destination

If your warehouse is located in Los Angeles, it costs less to ship to San Diego than to Vermont. You can use table rate shipping to pass the savings on to your customer.

Example 1: Price v. Destination

This example uses the Price v. Destination condition to create a set of three different shipping rates based on the amount of the order subtotal for the continental United States, Alaska, and Hawaii. The asterisk (*) is a wildcard that represents all values.

<table>
<thead>
<tr>
<th>COUNTRY</th>
<th>REGION / STATE</th>
<th>ZIP / POSTAL CODE</th>
<th>ORDER SUBTOTAL (and above)</th>
<th>SHIPPING PRICE</th>
</tr>
</thead>
<tbody>
<tr>
<td>USA</td>
<td>*</td>
<td>*</td>
<td>0</td>
<td>15</td>
</tr>
<tr>
<td>USA</td>
<td>*</td>
<td>*</td>
<td>50</td>
<td>10</td>
</tr>
<tr>
<td>USA</td>
<td>*</td>
<td>*</td>
<td>100</td>
<td>5</td>
</tr>
<tr>
<td>USA</td>
<td>AK</td>
<td>*</td>
<td>0</td>
<td>20</td>
</tr>
<tr>
<td>USA</td>
<td>AK</td>
<td>*</td>
<td>50</td>
<td>15</td>
</tr>
<tr>
<td>USA</td>
<td>AK</td>
<td>*</td>
<td>100</td>
<td>10</td>
</tr>
<tr>
<td>USA</td>
<td>HI</td>
<td>*</td>
<td>0</td>
<td>20</td>
</tr>
<tr>
<td>USA</td>
<td>HI</td>
<td>*</td>
<td>50</td>
<td>15</td>
</tr>
<tr>
<td>USA</td>
<td>HI</td>
<td>*</td>
<td>100</td>
<td>10</td>
</tr>
</tbody>
</table>

Example 2: Restrict Free Shipping to the Continental United States

You can use table rates to limit free shipping to only the continental United States, while excluding Alaska and Hawaii.

1. Create a tablerates.csv file that includes all the state destinations to which you are willing to provide free shipping.

2. Complete the table rate configuration with the following settings:
<table>
<thead>
<tr>
<th>SETTING</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Condition</td>
<td>Price v. Destination</td>
</tr>
<tr>
<td>Method Name</td>
<td>Free Shipping</td>
</tr>
<tr>
<td>Ship to Applicable Countries</td>
<td>Specific Countries</td>
</tr>
<tr>
<td>Ship to Specific Countries</td>
<td>Select only United States</td>
</tr>
<tr>
<td>Show method if not applicable</td>
<td>No</td>
</tr>
</tbody>
</table>

3. Set **Current Configuration Scope** to the main website. Then, click the **Import** button to import the tablesrates.csv file.

![Table Rate in Shopping Cart](image)

### Setting Up Table Rates

The data that is used to calculate the rate is prepared in a spreadsheet and imported into your store. When the customer requests a quote, the results appear in the shipping estimate section of the shopping cart.

Only one set of table rate data can be active at a time.

**Process Overview:**

- Step 1: Complete the Default Settings
- Step 2: Prepare the Table Rate Data
- Step 3: Import the Table Rate Data
Step 1: Complete the Default Settings

The first step is to complete the default settings for table rates. You can complete this step without changing the scope of the configuration.

1. On the Admin menu, select System > Configuration.
2. In the Configuration panel on the left, under Sales, select Shipping Methods.
3. Click to expand the Table Rates section. Then, do the following:
   a. Set Enabled to “Yes.”
   b. Enter a Title for the section of table rates that appears during checkout. (The default title is “Best Way.”)
   c. Enter the Method Name that appears next to the calculated rate in the shopping cart.
   d. Set Condition to one of the following calculation methods:
      - Weight v. Destination
      - Price v. Destination
      - # of Items v. Destination
   e. For orders that include virtual products, set Include Virtual Products in Price Calculation to “Yes” if you want to be able to include the virtual product(s) in the calculation.

Because virtual products—such as services—have no weight, they cannot change the result of a calculation that is based on the Weight v. Destination condition. However, virtual products can change the result of a calculation that is based on either the Price v. Destination or # of Items vs Destination condition.

   f. If charging a handling fee, set Calculate Handling Fee to one of the following:
      - Fixed
      - Percent
      Then, enter the Handling Fee rate according to the method used to calculate the fee.

   If the handling fee is based on a percent, enter the whole number without the percent sign.

   g. In the Displayed Error Message box, type the message that appears when this method is not available.
h. Set **Ship to Applicable Countries** to one of the following:

- **All Allowed Countries**: Customers from any country specified in your store configuration can use table rate shipping.
- **Specific Countries**: After choosing this option, the “Ship to Specific Countries” list appears. Select each country where customers can use table rate shipping.

i. Enter a **Sort Order** number to determine where table rates appear in the list of shipping methods during checkout. (0 = first, 1 = second, 2 = third, and so on.)

4. When complete, click the **Save Config** button.
Step 2: Prepare the Table Rate Data

1. In the upper-left corner, set **Current Configuration Scope** to the “Main Website,” or any other website where you want the configuration to apply.

   Export and Import options appear in the Table Rates section, with “Use Default” checkboxes to the right of each option.

   To change any of the current settings, you must first clear the “Use Default” checkbox next to the field.

2. If you want to change the **Condition**, clear the **Use Default** checkbox. Then, select another option.

3. Click the **Export CSV** button. Then, save the **tablerates.csv** file to your computer.

4. Open the file in Excel, or any other spreadsheet program.

5. Complete the table with appropriate values for the shipping calculation condition being used.
   - You can use an asterisk (*) as a wildcard to represent all possible values in any category.
   - The Country column must contain a valid three-character code for each row.
6. When complete, save the `tablerates.csv` file.

**Step 3: Import the Table Rate Data**

1. Return to the **Table Rates** section of the Shipping Methods configuration.

2. In the upper-left corner, set **Current Configuration Scope** to the website where this method will be used.

3. Next to the **Import** field, click the **Choose File** button. Select your completed `tablerates.csv` file, and import the rates.

4. When complete, click the **Save Config** button. Then, go through the payment process with different addresses to make sure the shipping and handling rates are correct.
Online Rates

Magento offers dynamic retrieval of rates from various shipping providers. To enable and configure online rates, see the configuration for the following carriers:

- UPS
- USPS
- FedEx
- DHL

Setting up online rates is similar to setting up Flat Rates. Because the online rate options differ for each service, contact the carrier for more information.

Most shipping providers require that you open an account with them. Consult your shipping provider for details on how to obtain API credentials.
Dimensional Weight

Dimensional weight, sometimes called volumetric weight, is a common industry practice that bases the transportation price on a combination of weight and package volume. In simple terms, dimensional weight is used to determine the shipping rate based on the amount of space a package occupies in the cargo area of the carrier. Dimensional weight is typically used when a package is relatively light compared to its volume.

All major carriers now apply dimensional weight to some shipments. However, the manner in which dimensional weight pricing is applied varies from one carrier to another.

- DHL
- FedEx
- UPS
- USPS

We recommend that you become familiar with the method used by each carrier to determine and apply dimensional weight. If your company has a high volume of shipments, even a slight difference in shipping price can translate to thousands of dollars over the course of a year.

Magento’s native shipping configuration does not include support for dimensional weight. However, WebShopApps has developed a Dimensional Shipping extension that manages rates for FedEx, UPS, and USPS. WebShopApps is a Magento Technology Partner.
CHAPTER 52:

Shipping Carriers

If you have a commercial account with a supported carrier, you can offer your customers the convenience of choosing that carrier during checkout. The rates are automatically downloaded, so you do not need to look up the information.

Before you can offer your customers a selection of shipping carriers, you must first complete the shipping settings to establish the point of origin for your store. Then, complete the configuration for each carrier service that you want to offer. The configuration options vary for each carrier. However, all require that you first open a shipping account with the carrier, and enter your account number or userID, and the gateway URL to their system into the configuration of your store. See Magento Connect for additional shipping services for your Magento Community Edition installation.

UPS

United Parcel Service offers domestic and international shipping services by land and air to more than 220 countries.

USPS

The United States Postal Service is the independent postal service of United States government. USPS offers domestic and international shipping services by land and air.

FedEx

Offers domestic and international shipping services by land and air to more than 220 countries.

DHL

Offers integrated international services and tailored, customer-focused solutions for managing and transporting letters, goods and information.
Package Type by Carrier

The following tables provide an overview of the shipping methods and supported package types for U.S. and international shipments by carrier. Because package types are subject to change, see the website of each carrier for the most up-to-date information.

- **Custom Packaging**
  Custom packaging has been added to each shipping method of each shipping carrier.

- **Shipping Methods**
  Shipping methods are divided into U.S. and International. Those that are marked as “U.S.” are for US domestic shipments only. Those that are marked as "International" can be those shipped from the U.S. to other countries, from other countries to the U.S. and within countries other than the U.S. FedEx does not offer domestic shipments for countries other than the U.S. at this time. USPS offers shipments from the U.S. only for both domestic and international.

- **International Shipping**
  For international shipping, available package types sometimes depend on the country of origin (U.S. or other). If a shipment originates outside of the U.S., the available package types are filtered according to the types that are acceptable. For shipments that originate in countries other than the U.S., the full list of package types available for the selected shipping carrier is provided.

### FedEx (U.S.)

#### Package Types: FedEx (U.S.)

<table>
<thead>
<tr>
<th>SHIPPING METHOD</th>
<th>PACKAGE TYPE</th>
</tr>
</thead>
<tbody>
<tr>
<td>FedEx First Overnight</td>
<td>FedEx Envelope</td>
</tr>
<tr>
<td></td>
<td>FedEx Pak</td>
</tr>
<tr>
<td></td>
<td>FedEx Box</td>
</tr>
<tr>
<td></td>
<td>FedEx Tube</td>
</tr>
<tr>
<td></td>
<td>Your Packaging</td>
</tr>
<tr>
<td>FedEx Priority Overnight</td>
<td>(same as above)</td>
</tr>
<tr>
<td>FedEx Standard Overnight</td>
<td>(same as above)</td>
</tr>
<tr>
<td>FedEx 2Day</td>
<td>(same as above)</td>
</tr>
<tr>
<td>FedEx Express Saver</td>
<td>FedEx Envelope</td>
</tr>
<tr>
<td></td>
<td>FedEx Pak</td>
</tr>
<tr>
<td></td>
<td>Your Packaging</td>
</tr>
</tbody>
</table>
### Package Types: FedEx (U.S.) (cont.)

<table>
<thead>
<tr>
<th>SHIPPING METHOD</th>
<th>PACKAGE TYPE</th>
</tr>
</thead>
<tbody>
<tr>
<td>FedEx Ground</td>
<td>Your Packaging</td>
</tr>
<tr>
<td>FedEx Home Delivery</td>
<td></td>
</tr>
<tr>
<td>FedEx SmartPost</td>
<td></td>
</tr>
</tbody>
</table>

### FedEx (International)

#### Package Types: FedEx (Int'l)

<table>
<thead>
<tr>
<th>SHIPPING METHOD</th>
<th>PACKAGE TYPE</th>
</tr>
</thead>
<tbody>
<tr>
<td>FedEx International First</td>
<td>FedEx Envelope</td>
</tr>
<tr>
<td></td>
<td>FedEx Pak</td>
</tr>
<tr>
<td></td>
<td>FedEx Box</td>
</tr>
<tr>
<td></td>
<td>FedEx Tube</td>
</tr>
<tr>
<td></td>
<td>Your Packaging</td>
</tr>
<tr>
<td>FedEx International Priority</td>
<td>FedEx Envelope</td>
</tr>
<tr>
<td></td>
<td>FedEx Pak</td>
</tr>
<tr>
<td></td>
<td>FedEx Box</td>
</tr>
<tr>
<td></td>
<td>FedEx 10 kg Box</td>
</tr>
<tr>
<td></td>
<td>FedEx 25 kg Box</td>
</tr>
<tr>
<td></td>
<td>FedEx Tube</td>
</tr>
<tr>
<td></td>
<td>Your Packaging</td>
</tr>
<tr>
<td>FedEx International Ground</td>
<td>Your Packaging</td>
</tr>
<tr>
<td>FedEx Europe First Priority</td>
<td>FedEx Envelope</td>
</tr>
<tr>
<td></td>
<td>FedEx Pak</td>
</tr>
<tr>
<td></td>
<td>FedEx 10 kg Box</td>
</tr>
<tr>
<td></td>
<td>FedEx 25 kg Box</td>
</tr>
<tr>
<td></td>
<td>Your Packaging</td>
</tr>
</tbody>
</table>

### UPS (U.S.)

#### Package Types: UPS (U.S.)

<table>
<thead>
<tr>
<th>SHIPPING METHOD</th>
<th>PACKAGE TYPE</th>
</tr>
</thead>
<tbody>
<tr>
<td>UPS Next Day Air Early AM</td>
<td>Small Express Box</td>
</tr>
<tr>
<td></td>
<td>Medium Express Box</td>
</tr>
<tr>
<td></td>
<td>Large Express Box</td>
</tr>
</tbody>
</table>
### Package Types: UPS (U.S.) (cont.)

<table>
<thead>
<tr>
<th>SHIPPING METHOD</th>
<th>PACKAGE TYPE</th>
</tr>
</thead>
<tbody>
<tr>
<td>UPS Express Tube</td>
<td></td>
</tr>
<tr>
<td>UPS Pak</td>
<td></td>
</tr>
<tr>
<td>UPS Letter</td>
<td></td>
</tr>
<tr>
<td>Your Packaging</td>
<td></td>
</tr>
<tr>
<td>UPS 2nd Day Air</td>
<td>(same as above)</td>
</tr>
<tr>
<td>UPS Next Day Air</td>
<td>(same as above)</td>
</tr>
<tr>
<td>UPS 2nd Day Air AM</td>
<td>(same as above)</td>
</tr>
<tr>
<td>UPS 3 Day Select</td>
<td>Your Packaging</td>
</tr>
<tr>
<td>UPS Ground</td>
<td>Your Packaging</td>
</tr>
</tbody>
</table>

### UPS (International)

### Package Types: UPS (Int'l)

<table>
<thead>
<tr>
<th>SHIPPING METHOD</th>
<th>PACKAGE TYPE</th>
</tr>
</thead>
<tbody>
<tr>
<td>UPS Worldwide Express</td>
<td>Large Express Tube</td>
</tr>
<tr>
<td></td>
<td>UPS Express Tube</td>
</tr>
<tr>
<td></td>
<td>UPS 10 kg Box</td>
</tr>
<tr>
<td></td>
<td>UPS 25 kg Box</td>
</tr>
<tr>
<td></td>
<td>UPS Pak</td>
</tr>
<tr>
<td></td>
<td>UPS Letter</td>
</tr>
<tr>
<td></td>
<td>Customer Packaging</td>
</tr>
<tr>
<td>UPS Worldwide Express Plus</td>
<td>(same as above)</td>
</tr>
<tr>
<td>UPS Worldwide Saver</td>
<td>(same as above)</td>
</tr>
<tr>
<td>UPS Worldwide Expedited</td>
<td>(same as above)</td>
</tr>
<tr>
<td>UPS Worldwide Expedited</td>
<td>Large Express Tube</td>
</tr>
<tr>
<td></td>
<td>UPS Express Tube</td>
</tr>
<tr>
<td></td>
<td>UPS 10 kg Box</td>
</tr>
<tr>
<td></td>
<td>UPS 25 kg Box</td>
</tr>
<tr>
<td></td>
<td>UPS Pak</td>
</tr>
<tr>
<td></td>
<td>Customer Packaging</td>
</tr>
</tbody>
</table>
### USPS (International)

**Package Types: USPS (Int’l)**

<table>
<thead>
<tr>
<th>SHIPPING METHOD</th>
<th>PACKAGE TYPE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Express Mail® International Flat Rate Envelope</td>
<td>Express Mail International Flat Rate Envelope</td>
</tr>
<tr>
<td>Express Mail Flat Rate Envelop Hold for Pickup</td>
<td>Express Mail International Flat Rate Envelope</td>
</tr>
<tr>
<td>Priority Mail International Flat Rate Envelope</td>
<td>Priority Mail International Flat Rate Envelope</td>
</tr>
<tr>
<td>Global Express Guaranteed (GXG)</td>
<td>Large Package/Non-Rectangular (Regular and Medium) Variable</td>
</tr>
<tr>
<td>USPS GXG Envelopes</td>
<td>Large Package/Rectangular (Regular and Medium) Variable</td>
</tr>
<tr>
<td></td>
<td>Large Package/Non-Rectangular (Regular and Medium) Variable</td>
</tr>
<tr>
<td>Express Mail International</td>
<td>(same as above)</td>
</tr>
<tr>
<td>Priority Mail International</td>
<td>(same as above)</td>
</tr>
<tr>
<td>First-Class Mail International Package</td>
<td>(same as above)</td>
</tr>
</tbody>
</table>

### DHL (International)

**Package Types: DHL (Int’l)**

<table>
<thead>
<tr>
<th>SHIPPING METHOD</th>
<th>PACKAGE TYPE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Express</td>
<td>Package</td>
</tr>
<tr>
<td>Express International</td>
<td>Letter</td>
</tr>
</tbody>
</table>
CHAPTER 53:

Shipping Labels

Magento Community Edition has a high level of integration with major shipping carriers that gives you access to carrier shipping systems to track orders, create shipping labels, and more.

USPS Priority Shipping Label
Shipping Label Workflow

Shipping labels can be produced at the time a shipment is created, or later. Shipping labels are stored in PDF format and downloaded to your computer. Depending on your browser settings, you can open the file at once and print the labels. Each shipping label appears on a separate page in the PDF file.

Shipment Workflow

When you create a shipping label, Magento prompts you for information about packaging you want to use (type, size, etc.) and which products go with which package. When you finish, Magento connects to the shipping carrier web-services, creates an order in its system, and receives the shipping label for the shipment. The tracking number(s) are also received and added in the Admin.

After the shipping label is generated, the new shipment is saved and the label can be printed. If the shipping label cannot be created due to problems with connection or any other reason, the shipment is not created.

Tracking Number Workflow

Magento receives the tracking numbers related to the shipment when labels are generated. and inserts the numbers into the Shipping and Tracking Information section of the order. If you generate the same shipping labels multiple times, the original tracking numbers are preserved.
Shipping Label Setup

Shipping label settings must be made at the product level, as well as in the configuration of each carrier. Complete the setup for each carrier that you intend to use to produce shipping labels.

To set up shipping labels:

1. On the Admin menu, select Catalog > Manage Products.

2. The Country of Manufacture field is required for each product that is shipped internationally by USPS and FedEx, Update the field for each product record, as needed.

3. When complete, click the Save button.

   If you have many products that need to be updated with the same information, do the following:
   a. In the Manage Products list, select the checkbox of each product that needs to be updated. For example, all products that are manufactured in China.
   b. Set the Actions control to “Update Attributes,” and click the Submit button.
   c. In the Update Attributes form, find the Country of Manufacture field and select the Change checkbox. Then, select the country from the list and click the Save button.

4. On the Admin menu, select System > Configuration. Then, do the following:
   a. In the panel on the left, under Sales, select Shipping Settings. Click to expand the Origin section, and verify that the following fields are complete:

      Street Address The street address of the place from which shipments are sent. For example, the location of your company or warehouse. This field is required for shipping labels.

      Street Address Line 2 Any additional address information, such as the floor, entrance and so on. We strongly recommend that you use this field.
b. In the Configuration panel under Sales, select **Shipping Methods**. Click to expand the **USPS** section, and verify that the following fields are complete:

- **Secure Gateway URL**: This field is pre-populated by Magento.
- **Password**: The password is provided by USPS, and gives you access to their system through Web Services.
- **Length, Width, Height, Girth**: The default dimensions of the package. To make these fields appear, set Size to "Large."

c. Click to expand the **FedEx** section, and verify that the following fields are complete:

- **Meter Number**
- **Key**
- **Password**

This information is provided by the carrier, and is required to gain access to their system through Web Services.

d. In the Configuration panel under General, select **Store Information**. Verify that the fields in this section are complete. If you have multiple stores, and the contact information differs from the default, set **Current Configuration Scope** to the store view and verify that the information is complete. If any of this information is missing, an error message will appear when you try to print shipping labels.

- **Store Name**: The name of the store or store view.
- **Store Contact Telephone**: The telephone number of the primary contact for the store or store view.
- **Country**: The country where your store is based.
- **VAT Number**: If applicable the Value Added Tax number of your store. (Not required for stores based in the U.S.)
- **Store Contact Address**: The street address of the primary contact for the store or store view.
e. When complete, click the **Save Config** button.

### Carrier Requirements

<table>
<thead>
<tr>
<th>CARRIER</th>
<th>REQUIREMENTS</th>
</tr>
</thead>
<tbody>
<tr>
<td>USPS</td>
<td>Requires a USPS account.</td>
</tr>
<tr>
<td>UPS</td>
<td>Requires a UPS account. Shipping labels are available only for shipments that originate in the U.S. Specific credentials are required for stores outside the US.</td>
</tr>
<tr>
<td>FedEx</td>
<td>Requires a FedEx account. For stores outside of the U.S., shipping labels are supported for international shipments only. FedEx does not allow domestic shipments that originate outside of the U.S.</td>
</tr>
<tr>
<td>DHL</td>
<td>Requires a DHL account. Shipping labels are supported only for shipments that originate in the U.S.</td>
</tr>
</tbody>
</table>
Create Shipping Labels

You can easily create shipping labels for new and existing orders from the Admin of your store. To create shipping labels, you must first set up your shipping carrier account to support labels. Then, follow the prompts to enter a description of the package and its contents. Magento contacts the shipping carrier, creates an order in the carrier's system, and receives a shipping label and tracking number for the shipment. An individual order is created for each package shipped. A single shipment with multiple packages receives multiple shipping labels.

Process Overview:
- Step 1: Contact Your Shipping Carriers
- Step 2: Update the Configuration for Each Carrier
- Step 3: Create Shipping Labels
- Step 4: Print Shipping Labels

Step 1: Contact Your Shipping Carriers

Before you begin, make sure that your shipping accounts are set up to process labels. Some carriers might charge an additional fee to add shipping labels to your account.

1. Contact each carrier that you use to activate shipping labels for your store.
2. Follow the instructions provided by each carrier to add shipping label support to your account.

FedEx Contact FedEx Web Services regarding their label evaluation process.

USPS Contact uspstechnicalsupport@esecurecare.net to request that API Signature Confirmation V3 be enabled for your live USPS API Access account.

UPS Contact UPS to confirm your account type supports shipping labels. To generate shipping labels, you must use the UPS XML option.

DHL Contact the DHL Resource Center to learn more about their services or send an inquiry through their Contact Center.

Step 2: Update the Configuration for Each Carrier

1. Make sure that your Store Information is complete.
2. Follow the instructions below for each carrier account that has been activated for label printing.
**UPS**

United Parcel Service ships both domestically and internationally. However, shipping labels can be generated only for shipments that originate within the United States.

1. On the Admin menu, select **System > Configuration**.
2. In the Configuration panel on the left, under Sales, select **Shipping Methods**.
3. Click to expand the **UPS** section. Then, verify that your UPS **Shipper Number** is correct. Your Shipper Number appears only when United Parcel Service XML is enabled.
4. When complete, click the **Save Config** button.

**USPS**

The United States Postal Service ships both domestically and internationally.

1. On the Admin menu, select **System > Configuration**.
2. In the Configuration panel on the left, under Sales, select **Shipping Methods**.
3. Click to expand the **USPS** section. Then, do the following:
   a. Verify that the **Secure Gateway URL** is entered. The correct URL should be entered automatically.
   b. Enter the **Password** provided to you by USPS.
   c. Set **Size** to “Large.” Then, enter the following dimensions:
      - Length
      - Width
      - Height
      - Girth
4. When complete, click the **Save Config** button.

**FedEx**

FedEx ships domestically and internationally. Stores located outside the United States can create FedEx labels for international shipments only.

1. On the Admin menu, select **System > Configuration**.
2. In the Configuration panel on the left, under sales, select **Shipping Methods**.
3. Click to expand the **FedEx** section. Then, make sure that the following FedEx credentials are correct:
   - Meter Number
   - Key
   - Password
4. When complete, click the **Save Config** button.

### DHL

DHL provides international shipping services.

1. On the Admin menu, select **System > Configuration**.
2. In the Configuration panel on the left, under sales, select **Shipping Methods**.
3. Click to expand the **DHL** section. Then, do the following:
   a. Verify that the **Gateway URL** is entered. The correct URL should be entered automatically.
   b. Make sure that the following credentials are complete:
      - Access ID
      - Password
      - Account Number
4. When complete, click the **Save Config** button.

### Step 3: Create Shipping Labels

**Process Overview:**
- Method 1: Create Label for New Shipment
- Method 2: Create Label for Existing Shipment

### Method 1: Create Label for New Shipment

1. On the Admin menu, select **Sales > Orders**.
2. Find the order in the list, and click to open the record. The status of the order must be either “Pending” or “Processing.”
3. In the upper-right corner, click the **Ship** button. Then, confirm the shipping information according to carrier requirements.
4. In the lower-right corner, select the **Create Shipping Label** checkbox. Click the **Submit Shipment** button, and do the following:
   a. To add products from the order to the package, click the **Add Products** button. The Quantity column shows the maximum number of products that are available for the package.
   b. Select the check box of each product to be added to the package and enter the **Quantity** of each. Then, click the **Add Selected Product(s) to Package** button.
To add a new package, click the **Add Package** button.

To delete a package, click the **Delete Package** button.

If you use a package type other than the default, or require a signature, the cost of shipping might differ from what you have charged the customer. Any difference is not reflected in your store.

5. When complete, click **OK**.
   - If you need to cancel an order, click the **Cancel** button. A shipping label will not be created, and the Create Shipping Label checkbox is cleared.

6. Magento now connects to the shipping carrier system, submits the order, and receives a shipping label and tracking number for each package.
   - If the label is successfully created, the shipment is submitted, the tracking number appears in the form, and the label is ready to print.
   - If the carrier cannot create the label due to the problems with connection, or for any other reason, the shipment is not processed.

### Method 2: Create Label for Existing Shipment

1. On the Admin menu, select **Sales > Orders**.
2. Find the order in the list and click to open the Shipping form. Then, do the following:
   a. In the Shipping and Tracking Information section, click the **Create Shipping Label** button.
   b. Distribute the ordered product(s) to the appropriate package(s), and click **OK**.
   c. To review the package information, click the **Show Packages** button.

   Magento connects to the shipping carrier system, submits an order, and receives a shipping label and a tracking number.

   If a shipping label for this shipment already exists in the system, it is replaced with a new one. However, existing tracking numbers are not replaced. Any new tracking number is added to the existing one.

### Step 4: Print Shipping Labels

Shipping labels are generated in PDF format, and can be printed from the Admin panel. Each label includes the order number and package number.

**Process Overview:**

Method 1: **Print Label from Shipment Form**
Method 2: Print Labels for Multiple Orders
Method 1: Print Label from Shipment Form

1. On the Admin menu, do one of the following:
   - Select Sales > Orders. Find the order in the list, and click to open the record. In the panel on the left, select Shipments. Then, click to open the shipment record.
   - Select Sales > Shipments. Find the order in the list, and click to open the record.

2. To download the PDF file, go to the Shipping and Tracking section of the form and click the Print Shipping Label button. Depending on your browser settings, the shipping labels can be viewed and printed directly from the PDF file.

   The Print Shipping Label button appears only after the carrier has generated labels for the shipment. If the button is missing, click the Create Shipping Label button. The button will appear after Magento receives the label from the carrier.

Method 2: Print Labels for Multiple Orders

1. On the Admin menu, do one of the following:
   - Select Sales > Orders.
   - Select Sales > Shipments.

2. In the list, select the checkbox of each order that has shipping labels to be printed.

3. In the upper-right corner, set the Actions control to "Print Shipping Labels."

4. Click the Submit button.

   A complete set of labels is printed for each shipment that is related to the selected orders.
# Required Carrier Settings

<table>
<thead>
<tr>
<th>FIELD</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Package types differ by carrier and method. The default package type for each carrier is initially selected. USPS does not require the package type for domestic shipments.</td>
</tr>
<tr>
<td>Customs Value</td>
<td>(International shipments only) The declared value or sales price of the contents of an international shipment.</td>
</tr>
<tr>
<td>Total Weight</td>
<td>The total weight of all products added to the package is calculated automatically. The value can also be changed manually, and entered as pounds or kilograms.</td>
</tr>
<tr>
<td>Length, Width, Height</td>
<td>(Optional) The package dimensions are used for custom packages only. You can specify the measurements units as inches or centimeters.</td>
</tr>
<tr>
<td>Signature Confirmation</td>
<td>Indicates if a signature is required to confirm receipt of the package. Although the options vary by carrier and shipping method. Options include:</td>
</tr>
<tr>
<td></td>
<td>Not Required No confirmation of delivery is sent to the store by the shipping carrier.</td>
</tr>
<tr>
<td></td>
<td>No Signature A delivery confirmation without the signature of the recipient is sent to the store by the shipping carrier.</td>
</tr>
<tr>
<td></td>
<td>Signature Required The shipping carrier obtains the signature of the recipient and provides the store with a printed copy.</td>
</tr>
<tr>
<td></td>
<td>Direct (FedEx Only) FedEx obtains a signature from someone at the delivery address. If no one is available to sign for the package, the carrier tries to deliver the package at another time.</td>
</tr>
<tr>
<td></td>
<td>Indirect (FedEx Residential Deliveries Only) FedEx obtains the signature of someone, possibly a neighbor or building manager, at the delivery address. The recipient can leave a signed FedEx door tag to authorize the package to be left without anyone present to sign for it.</td>
</tr>
<tr>
<td>Contents</td>
<td>(USPS Only) Select one of the following descriptions of the package: Gift</td>
</tr>
</tbody>
</table>
### Required Carrier Settings (cont.)

<table>
<thead>
<tr>
<th>FIELD</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Documents</td>
<td></td>
</tr>
<tr>
<td>Commercial Sample</td>
<td></td>
</tr>
<tr>
<td>Returned Goods</td>
<td></td>
</tr>
<tr>
<td>Merchandise</td>
<td></td>
</tr>
<tr>
<td>Other</td>
<td></td>
</tr>
<tr>
<td>Explanation</td>
<td>(USPS Only) A detailed description of the package contents.</td>
</tr>
<tr>
<td>Adult Required</td>
<td>The shipping carrier obtains the signature of an adult recipient and provides the store with a printed copy.</td>
</tr>
</tbody>
</table>
Creating a Package

The Create Packages pop-up window appears if you choose to create a shipping label. You can start configuring the first package at once.

To configure a package(s):

1. When the Create Packages window appears, do the following to complete the description of Package 1:
   a. Select the **Type** of packaging. (Not required for UPS domestic shipments.)
   b. Enter the **Total Weight** and verify that the unit of measurement is correct.
   c. Enter the **Length**, **Width**, and **Height** of the package, and verify that the unit of measurement is correct.
   d. Set **Signature Confirmation** as needed.

   If you select the non-default value in the Type field or require a signature confirmation, the price of a shipment may differ from the rate you quoted the customer.

   e. To view a list of shipped products and add them to the package, click the **Add Products** button.

      The Qty column is pre-populated with the maximum available quantity to add (for the Package 1 this number is equal to the total shipped quantity of the product).

   f. Specify the products and quantities. To add the products to the package, click the **Add Selected Product(s) to Package** button in the header of the grid. The products are added to the package.

2. To view a list of shipped products and add them to the package, click the **Add Products** button.

   The Qty column is pre-populated with the maximum available quantity to add (for the Package 1 this number is equal to the total shipped quantity of the product).

3. Specify the products and quantities. To add the products to the package, click the Add Selected Product(s) to Package button in the header of the grid. The products are added to the package.
To add a new package, click the **Add Package** button in the window header. You can add several packages, and edit them simultaneously.

To delete a package, click the **Delete Package** button.

After products have been added to the package, the quantity cannot be edited directly.

**To increase the quantity:**

1. Click the **Add Selection** button.
2. Enter the additional quantity.

The number is added to the previous quantity of the product in the package.

**To decrease the quantity:**

1. Delete the product from the package.
2. Click the **Add Selection** button.
3. Enter the new, smaller value.

After you distribute all products, the total number of the packages you are going to use equals the number of the last package in the list. The **OK** button is disabled until all shipped items are distributed between packages and all necessary information is specified.

4. When complete, click the **OK** button to generate the labels.

If you need to stop the process, click the **Cancel** button. The packages are not saved, and the shipping label creation is canceled.
Field Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>(Non-domestic only) Identifies the type of a package. Available package types are different for each shipping carrier, and depend on the shipping method selected when the order is created. When the Create Packages pop-up window opens, the default package for the shipping carrier set in system configuration is selected in the Type field. For shipping labels created for DHL, FedEx, and UPS shipments, the “Type of Goods” field is set to “Merchandise.” If you select a package, that is not designed by a shipping carrier, you must enter the package dimensions.</td>
</tr>
<tr>
<td>Total Weight</td>
<td>The total weight of a package. The field is pre-populated with the total weight of products in a package, after you add them, but can be edited manually. The measurement units can be specified using the drop-down menu next to the field; select between pounds and kilograms.</td>
</tr>
<tr>
<td>Length</td>
<td>The length of a package, integer and floating point numbers. The field is enabled if the custom package type is used. The measurement units can be specified using the drop-down menu next to the Height field; select between inches and centimeters.</td>
</tr>
<tr>
<td>Width</td>
<td>The width of a package, integer and floating point numbers. The field is enabled if the custom package type is used. The measurement units can be specified using the drop-down menu next to the Height field; select between inches and centimeters.</td>
</tr>
<tr>
<td>Height</td>
<td>The height of a package, integer and floating point numbers. The field is enabled if the custom package type is used. The measurement units can be specified using the drop-down menu next to the Height field; select between inches and centimeters.</td>
</tr>
<tr>
<td>Signature Confirmation</td>
<td>Establishes how delivery is confirmation. Options include:</td>
</tr>
<tr>
<td>Not Required</td>
<td>No delivery confirmation letter is sent.</td>
</tr>
<tr>
<td>No Signature</td>
<td>A delivery confirmation letter without a recipient’s signature is sent to you.</td>
</tr>
<tr>
<td>Signature Required</td>
<td>The shipping carrier obtains the recipient’s signature and provides you with its printed copy.</td>
</tr>
</tbody>
</table>
Field Descriptions (cont.)

<table>
<thead>
<tr>
<th>FIELD</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adult Required</td>
<td>The shipping carrier obtains the adult recipient’s signature and provides you with its printed copy.</td>
</tr>
<tr>
<td>Direct</td>
<td>(FedEx only) FedEx obtains a signature from someone at the delivery address and reattempts delivery if no one is available to sign for the package.</td>
</tr>
<tr>
<td>Indirect</td>
<td>(FedEx only) FedEx obtains a signature in one of three ways: (1) from someone at the delivery address; (2) from a neighbor, building manager or other person at a neighboring address; or (3) the recipient can leave a signed FedEx Door Tag authorizing release of the package without anyone present. Available for residential deliveries only. The field availability and options may vary slightly for different shipping methods. For the most up to date information please refer to shipping carrier’s resources.</td>
</tr>
</tbody>
</table>

Contents  
(USPS only) Description of the package contents. Options include:  
- Gift  
- Documents  
- Commercial Sample  
- Returned Goods  
- MerchandiseOther

Explanation  
(USPS only) Detailed description of the package content.
Taxes
Taxes

In this section of the guide, you’ll learn how to set up taxes according to the requirements of your locale. You can create tax classes for products and customer groups, and tax rules that combine product and customer classes, tax zones, and rates. In addition, you’ll learn more advanced topics such as setting up fixed product taxes, compound taxes, and how to display consistent prices across international borders. If you’re required to collect a value-added tax, you can set up your store to automatically calculate the appropriate amount with validation.

Managing Taxes
- General Tax Settings
- Tax Classes
  - Product Tax Classes
  - Shipping Tax Class
  - Customer Tax Classes
- Tax Zones & Rates
  - Import / Export Tax Rates
- Tax Rules
  - EU Place of Supply
  - Cross-Border Price Consistency
- Fixed Product Tax
  - FPT Setup
- Compound Taxes

Value Added Tax (VAT)
- VAT ID Validation
- VAT ID Validation Setup

Quick Reference
- International Configurations
- US Recommendations
- Canada: Example Configuration
- EU: Example Configuration
- Tax Warning Messages
CHAPTER 54: Managing Taxes

Magento provides a variety of options to help you meet the tax requirements for your locale. Magento also supports the calculation of Value-Added Tax (VAT) for business-to-business transactions in the European Union. Admin permissions can be set to restrict access to tax resources, based on the business “need to know.”

Tax classes are used to define “tax rules.” Tax rules incorporate a combination of product class, customer class and tax zone, and rate. Each type of customer can be assigned a customer class when you define them, and each product is assigned a tax class. Magento analyzes the shopping cart of each customer and calculates the appropriate tax according to the class of the customer, the class of the products in the shopping cart, and the region (as determined by the customer’s shipping address, billing address or shipping origin).

**Important!** No guarantee is made regarding any information in this guide. Please contact an expert before making decisions about tax matters.
General Tax Settings

The following instructions take you through the basic tax setup for your store. Before setting up your taxes, make sure that you are familiar with the tax requirements of your locale. Then, you can complete the tax configuration as needed for your store.

Admin permissions can be set to restrict access to tax resources, based on the business “need to know.” To create an Admin role with access to tax settings, select both the Sales/Tax and System/Tax resources. If setting up a website for a region that differs from your default shipping point of origin, you must also allow access to the System/Shipping resources for the role, because the shipping settings determine the store tax rate used for catalog prices.

Process Overview:
Step 1: Set Up Tax Classes
Step 2: Complete the Calculation Settings
Step 3: Set Up the Default Tax Destination
Step 4: Complete the Display Settings

Step 1: Set Up Tax Classes

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Sales, select Tax.
2. If you have multiple websites, set Current Configuration Scope to the website where the tax configuration applies.
3. Click to expand the Tax Classes section.

   ![Tax Classes]

4. Set Tax Class for Shipping to the appropriate class. The default classes are:
   - Taxable Goods
   - Shipping
   - Tax Exempt
Step 2: **Complete the Calculation Settings**

1. Click to expand the **Calculation Settings** section. Then, do the following:

   ![Calculation Settings](image)

   **Calculation Settings**

   a. In the **Tax Calculation Method Based On** field, select whether the tax is based on the price of each unit, or on the “row total” (that is, the total for a line item in the order, accounting for any discounts).

   b. In the **Tax Calculation Based On** field, select whether the tax is calculated based on the customer’s shipping address, billing address, or your store’s shipping origin.

2. To determine which prices include tax, do the following:

   a. Set **Catalog Prices** to include or exclude tax.

   b. Set **Shipping Prices** to include or exclude tax.

3. In the **Apply Customer Tax** field, select whether tax is applied to the original or discounted price.

4. In the **Apply Discount on Prices** field, select whether any discounts applied include the tax or exclude it.

5. In the **Apply Tax On** field, select whether tax is applied to custom prices or to original prices.

6. In the **Enable Cross Border Trade** field, select “Yes” to use consistent pricing across different tax rates, or select “No” to vary the price by tax rate.

   **Important!** If cross-border trade is enabled, the profit margin changes by tax rate. Profit is determined by the formula (Revenue - CustomerVAT - CostOfGoodsSold). To enable cross-border trade, set prices to include tax.
Step 3: Set Up the Default Tax Destination Calculation

1. Click to expand the Default Tax Destination Calculation section.
2. Select the Default Country to be used for tax calculations.
3. Select the Default State to be used for tax calculations.
4. Select the Default Post Code to be used for tax calculations.

An asterisk can be used as a wildcard to represent all State and Post Code values.

![Default Tax Calculation](image)

Step 4: Complete the Price Display Settings

**Important!** Some combinations of settings related to a price display that both includes and excludes tax can be confusing to the customer. To avoid triggering a warning message, see the recommended settings.

1. Click to expand the Price Display Settings section. Then, do the following:

   ![Price Display Settings](image)

   a. Set Display Product Prices in Catalog to one of the following:

      - Excluding Tax
      - Including Tax
      - Including and Excluding Tax

      If you set the Display Product Prices field to “Including Tax,” the tax appears only if there is a tax rule that matches the tax origin, or if Magento detects that the customer address matches the tax rule. This can happen after a customer creates an account, logs in, or uses the Tax and Shipping estimation tool in the cart.
b. Set **Display Shipping Prices** to one of the following:
   - Excluding Tax
   - Including Tax
   - Including and Excluding Tax

2. Click to expand the **Shopping Cart Display Settings** section.

For each section listed, choose how you want taxes and prices to be shown for products in a shopping cart, according to the requirements of your store and locale.

![Shopping Cart Display Settings](image)

3. Click to expand the **Orders, Invoices, Credit Memos Display Settings** section. Then, select how prices and taxes are displayed in orders, invoices, and credit memos.

![Orders, Invoices, Credit Memos Display Settings](image)

4. When complete, click the **Save Config** button.
**Tax Classes**

Every product and customer is assigned to a tax class. Tax classes, in turn, are used to define tax rules. Tax rules are a combination of a customer tax class, product tax class, and tax rates. The basic types of tax classes are:

- Product Tax Classes
- Shipping Tax Classes
- Customer Tax Classes

**Product Tax Classes**

Product tax classes can be created and assigned according to the tax requirements of the product. For example, food might not be taxed (or might be taxed at a different rate). If your store charges an additional tax on shipping, you should designate a separate product tax class for shipping.

**To define a product tax class:**

1. On the Admin menu, select **Sales > Tax > Product Tax Class**.
2. In the upper-right corner, click the **Add New** button.
3. Enter a **Class Name** for this tax class.
   The new tax class now appears as a Tax Class option for product prices.
4. When complete, click the **Save Class** button.
Shipping Tax Class

A separate product class can be set up for shipping. Then, you must identify it in the configuration as the tax class used for shipping.

Step 1: Set Up a Product Tax Class for Shipping

1. On the Admin menu, select Sales > Tax > Product Tax Class.
2. In the upper-right corner, click the Add New button.
3. Enter a Class Name for the new tax class. For example, “Shipping.”
4. When complete, click the Save Class button.

Step 2: Configure the Shipping Tax Class

1. On the Admin menu, select System > Configuration.
2. In the panel on the left, under Sales, select Tax.
3. Click to expand the Tax Classes section.
4. Set Tax Class for Shipping to the class you created for shipping.
5. When complete, click the Save Config button.
Customer Tax Classes

Customer tax classes are created and assigned by customer type. For example, in some jurisdictions, wholesale transactions are not taxed, although retail transactions are.

To define a customer tax class:

1. On the Admin menu, select Sales > Tax > Customer Tax Classes.
2. In the upper-right corner, click the Add New button.
3. Enter a Class Name for this tax class.

To link a customer tax class to a customer group, edit the customer group. You can then assign the customer group when creating or editing a customer.

4. When complete, click the Save Class button.
Tax Zones & Rates

Tax rates generally apply to transactions that take place within a specific geographical area. The Tax Zones and Rates tool enables you to specify the tax rate for each geographical area for which you collect and remit taxes. Because you give each tax zone and rate specification a unique identifier, you can have multiple tax rates for a given geographic area (for example, for places that do not tax food or medicine but tax other products).

Store tax is calculated based on the store's address. The actual customer tax for an order is calculated after the customer completes the order information. Magento then calculates the actual tax based upon the tax configuration of the store.

To define tax zones and rates:

1. On the Admin menu, select Sales > Tax > Manage Tax Zones & Rates.
2. In the upper-right corner, click the Add New Tax Rate button.
3. In the Tax Rate Information section, do the following:
a. In the **Tax Identifier** field, enter a unique name for this tax. Do not use spaces. This identifier is not shown in the store if the Tax Titles section is completed, as described below.

b. Select the location of the **Country** and **State**. (Starting in EE 1.13.1, you can use the wildcard character * for State.)

c. Do one of the following:

   - If you want the ZIP or postal code represented as an individual code, set **Zip/Post is Range**, to “No.” Then, enter the **Zip/Post Code**.
   - If you want the ZIP or postal code represented as a range, set **Zip/Post is Range** to “Yes.” Then, enter the **Range From** and **Range To** values.

The wildcard character * can be used to represent all values. For example, 90* means all ZIP codes from 90000 through 90999.

d. In the **Rate Percent** field, enter the percentage of tax.

4. In the **Tax Titles** section, enter a name of this tax for each store view.

5. When complete, click the **Save Rate** button.
Import / Export Tax Rates

If you have nexus in several states and ship a large volume of product, you might consider downloading a tax rate by ZIP code data set. The rates can then be imported into Magento. In the following example, we import a set of California tax rates that was downloaded from the Avalara website. Avalara provides tax rate tables that can be downloaded at no charge for every ZIP code in the United States. Avalara is a Magento Technology Partner.

### Process Overview:

**Step 1: Export the Magento Tax Rate Data**

1. On the Admin menu, select **Sales > Tax > Import / Export Tax Rates**.
2. Click the **Export Tax Rates** button. When prompted, click **Save**. Then, open the exported file in OpenOffice Calc.

**Step 2: Prepare the Import Data**

**Step 3: Import the Tax Rates**
3. In a second instance of OpenOffice Calc, open the new tax rate data, so you can see both, side by side. The basic Magento tax rate data includes the following columns:

- Code
- Country
- State
- Zip/Post Code
- Rate

![Exported Tax Rate Data](image)

4. In the new tax rate data, take note of any additional tax rate data that you might need to set up in your store before the data is imported. For example, the tax rate data for California also includes:

- TaxRegionName
- CombinedRate
- StateRate
- CountyRate
- CityRate
- SpecialRate

If you need to import additional tax zones and rates, you must first define them from the Admin of your store, and update the tax rules as needed. Then, export the data, and open the file in OpenOffice Calc, so it can be used for reference. However, to keep this example simple, we will import only the standard tax rate columns.

**Step 2: Prepare the Import Data**

You now have two spreadsheets open, side by side. One with the Magento export file structure, and the other with the new tax rate data that you want to import.
1. To create a place to work in the spreadsheet with the new data, insert as many blank columns at the far left as needed. Then, use cut and paste to rearrange the columns so they match the order of the Magento export data.

2. Rename the column headers to match the Magento export data.

3. Delete any columns that have no data. Otherwise, the structure of the import file should match the original Magento export data.

4. Before saving the file, scroll down and make sure that the tax rate columns contain only numeric data. Any text found in a tax rate column will prevent the data from being imported.

5. Save the prepared data as a .CSV file. When prompted, verify that a comma is used as a Field delimiter, and double quotes as the Text delimiter. Then, click OK.

Magento requires all text strings to be enclosed in double quotes. Because Microsoft Excel removes the double quotes, we recommend that you use OpenOffice Calc instead.

**Step 3: Import the Tax Rates**

1. On the Admin menu, select Sales > Tax > Import / Export Tax Rates.

2. Click the Browse button, and select the .CSV tax rate file that you prepared to import. Then, click the Import Tax Rates button.

   It might take several minutes to import the data. When the process is complete, the message, "The tax rate has been imported" appears. If you receive an error message, correct the problem in the data and try again.

3. On the Admin menu, select Sales > Tax > Manage Tax Zones & Rates. The new data appears in the list. Use the page controls to view the new tax rates.
**Imported Tax Rates**

4. Run some text transactions in your store with customers from different ZIP codes to make sure that the new tax rates work correctly.
Tax Rules

Tax rules put all the taxation elements together: product tax classes, customer tax classes, and tax zones and rates. Each tax rule consists of a customer tax class, a product tax class, and a tax rate.

When numerous taxes must be defined, you can simplify the process by importing them from a spreadsheet. Select Sales > Tax > Import/Export Tax Rates.

Manage Tax Rules

To define tax rules:

1. On the Admin menu, select Sales > Tax > Manage Tax Rules.
2. In the upper-right corner, click the Add New Tax Rule button. Then, do the following:
a. Enter a Name for the rule.

b. Select a Customer Tax Class. To select multiple options, hold the Ctrl key down and click each item.

c. Select a Product Tax Class.

d. Select the Tax Rate.

This rule applies the tax rate to customers in the selected customer tax class and to products in the selected product tax class.

e. In the Priority field, enter a number to indicate the priority of this tax, when more than one tax applies. If two tax rules with the same priority apply, then the taxes are added together. If two taxes with different priority settings apply, then the taxes are compounded.

3. In the Sort Order field, enter a number to indicate the order in which tax rules are displayed on the Manage Tax Rules page.

4. If you want taxes to be based on the order subtotal, select the Calculate off Subtotal Only checkbox.

5. When complete, click the Save Rule button.
## Field Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Enter a name for this tax rule to make it easy to identify.</td>
</tr>
<tr>
<td>Customer Tax Class</td>
<td>Select the customer tax class associated with this rule.</td>
</tr>
<tr>
<td>Product Tax Class</td>
<td>Select the product tax class associated with this rule.</td>
</tr>
<tr>
<td>Tax Rate</td>
<td>Select the tax rate that applies to this rule.</td>
</tr>
<tr>
<td>Priority</td>
<td>Enter a number to indicate the priority of this tax, when more than one tax applies. Lower numbers have higher priority. If two tax rules with the same priority apply then the taxes are added together. If two taxes with a different priority apply then the taxes are compounded. When taxes are compounded, the first priority tax is calculated on the subtotal amount, and then the second priority tax is calculated on the subtotal plus the first priority tax amount.</td>
</tr>
<tr>
<td>Calculate off Subtotal Only</td>
<td>Select this checkbox for taxes to be calculated based on the subtotal of the order. This means that for this tax rule, tax applies only to the subtotal of the order.</td>
</tr>
<tr>
<td>Sort Order</td>
<td>Specify the order in which tax rules are displayed on the Manage Tax Rules page. Lower numbers have higher sort order in the list.</td>
</tr>
</tbody>
</table>
EU Place of Supply

European Union (EU) merchants must report their digital goods sold by quarter to each member country. Digital goods are taxed based on the customer's billing address. The law requires merchants to run a tax report and identify the relevant tax amounts for digital goods, as opposed to physical goods.

Merchants must report all digital goods sold by EU member countries on a quarterly basis to a central tax administration, along with payment due for tax collected during the period. Merchants who have not yet reached the threshold (50k/100k Euro of annual business) must continue to report physical goods sold to the EU states where they have registered VAT numbers.

Merchants who are audited for taxes paid for digital goods, must provide two pieces of supporting information to establish the customer place of residence.

- The customer's billing address and a record of a successful payment transaction can be used to establish the customer place of residence. (Payment is accepted only if the billing address matches payment provider information.)
- The information can also be captured directly from the data store in the Magento database tables.

To collect digital goods tax information:

1. Load the tax rates for all EU member countries.
2. Create a digital goods product tax class.
3. Assign all your digital goods to the digital goods product tax class.
4. Create tax rules for your physical goods, using physical product tax classes, and associate them with the appropriate tax rates.
5. Create tax rules for your digital goods, using use the product tax class for digital goods, and associate them with the appropriate tax rates for EU member countries.
6. Run the tax report for the appropriate period, and collect the required digital goods information.
7. Export the tax amounts that are related to the tax rates for the digital goods product tax class.

See also:

European Commission Taxation and Customs Union

EU 1015 Place of Supply Changes
Cross-Border Price Consistency

Cross-border trade (also referred to as price consistency) supports European Union (EU) and other merchants who want to maintain consistent prices for customers whose tax rates are different than the store tax rate.

Merchants operating across regions and geographies can show their customers a single price. Pricing is clean and uncluttered regardless of tax structures and rates that vary from country to country.

To use cross-border price consistency, your store must include tax in product prices.

To enable cross-border price consistency:

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under Sales, select Tax.
2. Click to expand the Calculation Settings section.
3. To enable cross-border price consistency, set Enable Cross Border Trade to “Yes.”

   **Important!** If you enable cross-border trade your profit margin changes by tax rate. Profit is determined by the formula: (Revenue - Customer VAT - Cost Of Goods Sold)

4. When complete, click the Save Config button.
Fixed Product Tax

Some tax jurisdictions have a fixed tax that must be added to certain types of products. You can set up a fixed product tax (FPT) for your store’s tax calculations. For example, in some countries FPT can be used to set up a Waste Electrical and Electronic Equipment Directive (WEEE) tax, also known as "ecological tax" or "eco tax," that is collected on certain types of electronics to offset the cost of recycling. This tax is a fixed amount, rather than a percentage of the product price.

Fixed product taxes apply at the item level, based on the product. In some jurisdictions this tax is subject to an additional % tax calculation. Your tax jurisdiction might also have rules about how the product price appears to customers, either with or without tax. Be sure that you understand the rules, and set your FPT display options accordingly.

We recommend that you exercise caution when quoting FPT prices in email, because the difference in price can affect customer confidence in their orders. For example, if you display Order Review prices without showing FPT, customers who buy items with associated FPT will see a total that includes the FPT tax amount, but without an itemized breakdown. The difference in price might lead some customers to abandon their carts because the total differs from the amount expected.

FPT Display Prices

<table>
<thead>
<tr>
<th>FPT</th>
<th>DISPLAY SETTING AND CALCULATION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Not Taxed</td>
<td></td>
</tr>
<tr>
<td>Excluding FPT</td>
<td>FPT appears as a separate row in the cart, and the value is used in appropriate tax calculations.</td>
</tr>
<tr>
<td>Including FPT</td>
<td>FPT is added to the base price of an item but is not included in tax-rule-based calculations.</td>
</tr>
<tr>
<td>Excluding FPT, FPT Description, Final Price</td>
<td>Item prices are shown without FPT, FPT amount, and with FPT included. FPT is not included in tax-rule-based calculations.</td>
</tr>
<tr>
<td>Taxed</td>
<td></td>
</tr>
<tr>
<td>Excluding FPT</td>
<td>FPT appears as a separate row in the cart, and the value is used in appropriate tax calculations.</td>
</tr>
<tr>
<td>Including FPT</td>
<td>FPT is included in the price of an item, and no change to tax calculations is required.</td>
</tr>
<tr>
<td>Excluding FPT, FPT Description, Final Price</td>
<td>Item prices are shown without FPT, FPT amount, and with FPT included. FPT is included in tax-rule-based calculations.</td>
</tr>
</tbody>
</table>
Fixed Product Tax Setup

The following instructions show how to set up a fixed product tax for your store. An “eco tax” is an example of how you might use FPT. After setting the scope for the tax and the countries and states where the tax applies, and depending on the options you choose, the input fields can change to accommodate the local requirements.

Process Overview:
Step 1: Enable the FPT Tax
Step 2: Create an FPT Attribute
Step 3: Add the FPT to an Attribute Set
Step 4: Apply the FPT to Products

Step 1: Enable the FPT Tax

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Sales, select Tax.
2. Click to expand the Fixed Product Taxes section. Then, complete the fields as needed, using the Field Description section at the end of this section for reference.

3. When complete, click the Save Config button.

Step 2: Create an FPT Attribute

1. On the Admin menu, select Catalog > Attributes > Manage Attributes.
2. In the upper-right corner, click the Add New Attribute button. Then, do the following:
Fixed Product Tax

a. In the **Attribute Code** field, specify a unique identifier for this attribute. Do not use spaces or special characters. However, you can use hyphens or underscores. The maximum length is 30 characters.

b. Set **Scope** to indicate where in your Magento installation the attribute will be available.

c. Set **Catalog Input Type for Store Owner** to “Fixed Product Tax.”

d. Set **Apply To** to one of the following:

   - **All Product Types**  
     Makes the FPT attribute available for all product types.

   - **Selected Product Types**  
     If you select this option, select each product type in the list that will use the attribute.

3. In the panel on the left, select **Manage Label / Options**. Then, enter a label to identify the field. If you enter one label for the Admin, it will be used for the other views.

4. When complete, click the **Save Attribute** button.

   To learn more, see: Creating Attributes.
Step 3: Add the FPT Attribute to an Attribute Set

1. On the Admin menu, select **Catalog > Attributes > Manage Attribute Sets.**
2. Open the attribute set that needs the FPT attribute.
3. Drag the FPT attribute from the list of Unassigned Attributes on the right to the Groups list. The group folders correspond to sections in the Product Information panel. You can place the attribute wherever you want it to appear.

4. When complete, click the **Save Attribute Set** button.

To learn more, see: Creating Attribute Sets.

Step 4: Apply the FPT to Products

1. On the Admin menu, select **Catalog > Manage Products.**
2. Find the product that needs the FPT and open it in edit mode.
3. In the product information, find the FPT field that you added to the attribute set. Then, do the following:
4. Click the **Add Tax** button. Then, do the following:
   a. Select the **Country/State** where the FPT applies.
   b. Enter the amount in the **Tax** field.
   c. To add more FPT taxes, click the **Add Tax** button and repeat the process.

5. When complete, click the **Save** button.
## Compound Taxes

For compound taxes, the total cost of a product or service is taxed at one rate, and then the total of that amount, including the first tax amount, is taxed a second time. Compound tax is also known as stacked tax.

Compound taxes use different tax rule priorities. If two tax rules with the same priority apply then the taxes are added together. If two taxes with a different priority apply then the taxes are compounded. When taxes are compounded, the first priority tax is calculated on the subtotal amount, and then the second priority tax is calculated on the subtotal plus the first priority tax amount. Lower numbers have higher priority.

### Important!
In order for compound taxes to work correctly do not select the Calculate off subtotal only check box when you set up your tax rules that apply to compound taxes. This check box overrides the compounding calculation and cannot be used in conjunction with compound taxes.

### Example 1: Regular Two-Tax Calculation

For example, in a regular tax calculation involving two tax rules, each rule is applied separately to the product subtotal, and the taxes are added together to calculate the total tax, which is then added to the product subtotal to calculate the grand total:

**Regular Two-Tax Calculation**

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>$50.00</td>
<td>Product Price</td>
<td></td>
</tr>
<tr>
<td>+ $50.00</td>
<td>Product Price</td>
<td></td>
</tr>
<tr>
<td>$100.00</td>
<td>Subtotal</td>
<td></td>
</tr>
<tr>
<td>$5.00</td>
<td>Subtotal x 1st tax rate 5%</td>
<td></td>
</tr>
<tr>
<td>+ $10.00</td>
<td>Subtotal x 2nd tax rate 20%</td>
<td></td>
</tr>
<tr>
<td>$15.00</td>
<td>Total Taxes</td>
<td></td>
</tr>
<tr>
<td>$100.00</td>
<td>Subtotal</td>
<td></td>
</tr>
<tr>
<td>+ $15.00</td>
<td>Total Taxes</td>
<td></td>
</tr>
<tr>
<td>$115.00</td>
<td>Grand Total</td>
<td></td>
</tr>
</tbody>
</table>
Example 2: Compound Tax Calculation

With compound taxes, the first tax is added to the product subtotal, and the second tax is applied to that total:

**Compound Tax Calculation**

<table>
<thead>
<tr>
<th>$50.00</th>
<th>Product Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>+ $50.00</td>
<td>Product Price</td>
</tr>
<tr>
<td>$100.00</td>
<td>Subtotal</td>
</tr>
<tr>
<td>$5.00</td>
<td>Subtotal x 1st tax rate 5%</td>
</tr>
<tr>
<td>+ $10.50</td>
<td>[Subtotal + (Subtotal x 1st rate)] x 2nd tax rate: $105 x 10%</td>
</tr>
<tr>
<td>$15.50</td>
<td>Total Taxes</td>
</tr>
<tr>
<td>$100.00</td>
<td>Subtotal</td>
</tr>
<tr>
<td>+ $15.50</td>
<td>Total Taxes</td>
</tr>
<tr>
<td>$115.50</td>
<td>Grand Total</td>
</tr>
</tbody>
</table>

**To set up compound taxes:**

1. Set up all the tax rates that will be used in your compound tax rule. See: Tax Zones & Rates.

2. Set up the first tax rule for compounding. For the first tax rule, be sure that you set a higher priority than you will set for the next tax rule, which will be compounded on top of this first tax rule. Lower numbers are used for higher priority. Use 0 for the highest priority. See: Tax Rules.

3. Set up the second tax rule for compounding. For the second rule, be sure that you set a lower priority (use a higher number) than you set for the first tax rule.
CHAPTER 55: Value Added Tax (VAT)

Some countries charge a value added tax, or VAT, on goods and services. There can be different VAT rates depending on which stage you as a merchant are at in the manufacture or distribution of the products, materials, or services that you sell to your customers. In this case you may need to use more than one VAT rate in your store for tax calculation purposes.

This section provides a sample procedure for setting up a 20% VAT in the U.K. for sales to retail customers. For other tax rates and countries, follow the general procedure but enter specific information that corresponds to your country, VAT rate, customer types, and so on.

Before proceeding, find out which rules and regulations apply to VAT in your area.

In certain business-to-business transactions, VAT is not assessed. Magento can validate a customer's VAT ID to ensure that VAT is assessed (or not assessed) properly. To learn more, see: VAT Validation.
Process Overview:
Step 1: Set Up Customer Tax Classes
Step 2: Set Up Product Tax Classes
Step 3: Set Up Tax Zones and Rates
Step 4: Set Up Tax Rules
Step 5: Apply Tax Classes to Products

Step 1: Set Up Customer Tax Classes

1. On the Admin menu, select Sales > Tax > Customer Tax Classes.
2. Ensure that there is a customer tax class that is appropriate to use with the VAT. For this example, ensure that there is a customer tax class named Retail Customer. If Retail Customer does not exist, click the Add New button and add it.

Step 2: Set Up Product Tax Classes

1. On the Admin menu, select Sales > Tax > Product Tax Classes.
2. Click the Add New button and create three new classes:
   - VAT Standard
   - VAT Reduced
   - VAT Zero
3. Click the Save Class button for each new class that you add.

Step 3: Set Up Tax Zones and Rates

1. On the Admin menu, select Sales > Tax > Manage Tax Zones & Rates.
   For this example you can remove the U.S. tax rates, or leave them as they are.
2. Click the Add New Tax Rate button. Add new rates as follows:

<table>
<thead>
<tr>
<th>VAT STANDARD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tax Identifier:</td>
</tr>
<tr>
<td>Country and State:</td>
</tr>
<tr>
<td>Rate Percent:</td>
</tr>
</tbody>
</table>
Step 4: Set Up Tax Rules

A tax rule is a combination of a customer tax class, a product tax class, and a tax rate.

1. On the Admin menu, select Sales > Tax > Manage Tax Rules.
2. Add new tax rules as follows:

<table>
<thead>
<tr>
<th>VAT STANDARD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name: VAT Standard</td>
</tr>
<tr>
<td>Customer Tax Class: Retail Customer</td>
</tr>
<tr>
<td>Product Tax Class: VAT Standard</td>
</tr>
<tr>
<td>Tax Rate: VAT Standard Rate</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>VAT REDUCED</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name: VAT Reduced</td>
</tr>
<tr>
<td>Customer Tax Class: Retail Customer</td>
</tr>
<tr>
<td>Product Tax Class: VAT Reduced</td>
</tr>
<tr>
<td>Tax Rate: VAT Reduced Rate</td>
</tr>
</tbody>
</table>

3. Click the Save Rule button for each rate.

Step 5: Apply Tax Classes to Products

1. On the Admin menu, select Catalog > Manage Products.
2. Open a product from your catalog in edit mode.
3. On the General page, find the Tax Class field. Then, select the VAT Class that applies to the product.
4. When complete, click the Save button.
VAT ID Validation

VAT ID Validation automatically calculates the required tax for B2B transactions that take place within the European Union (EU), based on the merchant and customer locale. Magento performs VAT ID validation using the web services of the European Commission server.

VAT-related tax rules do not influence other tax rules, and do not prevent the application of other tax rules. Only one tax rule can be applied at a given time.

- VAT is charged if the merchant and customer are located in the same EU country.
- VAT is not charged if the merchant and customer are located in different EU countries, and both parties are EU-registered business entities.

The store administrator creates more than one default customer group that can be automatically assigned to the customer during account creation, address creation or update, and checkout. The result is that different tax rules are used for intra-country (domestic) and intra-EU sales.

Important: If you sell virtual or downloadable products, which by their nature do not require shipping, the VAT rate of a customer’s location country should be used for both intra-union and domestic sales. You must create additional individual tax rules for product tax classes that correspond to the virtual products.

Customer Registration Workflow

If VAT ID Validation is enabled, after registration each customer is prompted to enter the VAT ID number. However only those who are registered VAT customers are expected to complete the field.

After a customer specifies the VAT number and other address fields, and chooses to save, the system saves the address and sends the VAT ID validation request to the European Commission server. According to the results of the validation, one of the default groups is assigned to a customer. This group can be changed if a customer or an administrator changes the VAT ID of the default address, or changes the entire default address. In some cases, the group is temporarily changed during checkout by emulating a group change.

Checkout Workflow

If a customer’s VAT validation is performed during checkout, the VAT request identifier and VAT request date are saved in the Comments History section of the order.

The system behavior of the VAT ID validation and the customer group change during the checkout depends on how the Validate on Each Transaction and the Disable Automatic Group Change settings are configured. If a customer uses PayPal Express Checkout, Google Express Checkout, or another external checkout method that uses an external payment gateway, the Validate on Each Transaction setting cannot be applied. Thus the customer group cannot be changed during checkout.
“One-Page” Checkout with VAT ID Validation
Setting Up VAT ID Validation

Use the following tax rule examples when setting up VAT ID Validation for your store.

**Example: Minimal Tax Rules Required for VAT ID Validation**

<table>
<thead>
<tr>
<th>TAX RULE #1</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Customer Tax Class</strong></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td><strong>Product Tax Class</strong></td>
</tr>
<tr>
<td><strong>Tax Rate</strong></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>TAX RULE #2</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Customer Tax Class</strong></td>
</tr>
<tr>
<td><strong>Product Tax Class</strong></td>
</tr>
<tr>
<td><strong>Tax Rate</strong></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>TAX RULE #3 (REQUIRED FOR VIRTUAL AND DOWNLOADABLE PRODUCTS)</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Customer Tax Class</strong></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td><strong>Product Tax Class</strong></td>
</tr>
<tr>
<td><strong>Tax Rate</strong></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>TAX RULE #4 (REQUIRED FOR VIRTUAL AND DOWNLOADABLE PRODUCTS)</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Customer Tax Class</strong></td>
</tr>
<tr>
<td><strong>Product Tax Class</strong></td>
</tr>
<tr>
<td><strong>Tax Rate</strong></td>
</tr>
</tbody>
</table>
Process Overview:
Step 1: Create VAT-Related Customer Groups
Step 2: Create VAT-Related Classes, Rates and Rules
Step 3: Enable and Configure VAT ID Validation
Step 4: Set your VAT ID and Location Country
Step 5: Verify the List of EU Member Countries

Step 1: Create VAT-Related Customer Groups

VAT ID Validation automatically assigns one of the four default customer groups to customers according to VAT ID validation results:

- Domestic
- Intra-EU
- Invalid VAT ID
- Validation error

You can create new customer groups for VAT ID Validation or use existing groups, if they comply with your business logic. When configuring VAT ID Validation, you must assign each of the created customer groups as a default for customers with appropriate VAT ID validation results.

Step 2: Create VAT-Related Classes, Rates, and Rules

Each tax rule is defined by three entities:

- Customer Tax Classes
- Product Tax Classes
- Tax Rates

Create the tax rules that you need to use VAT ID Validation effectively.

- Tax rules include tax rates and tax classes.
- Tax classes are assigned to customer groups.

Step 3: Enable and Configure VAT ID Validation

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Customers, select Customer Configuration.
2. Set Current Configuration Scope to “Default Config,” or the applicable store view.
3. Click to expand the Create New Account Options section.
4. Set **Enable Automatic Assignment to Customer Group** to “Yes.”

5. To complete the fields, refer to the descriptions for **Create New Account Options** in the Configuration reference.

6. When complete, click the **Save Config** button.
Step 4: Set Your VAT ID and Location Country

1. On the Admin menu, select **System > Configuration**.
2. In the panel on the left, under General, select **General**.
3. Set **Current Configuration Scope** to the applicable store view.
4. Click to expand the **Store Information** section. Then, do the following:

   ![Store Information](image)

   **Store Information**

   a. Select your **Country**.

   b. Enter your **VAT Number**. Then, click the **Validate VAT Number** button.

5. When complete, click the **Save Config** button.
Step 5: Verify the List of EU Member Countries

1. Continuing in the General configuration section,

2. Verify that the **Current Configuration Scope** is set to the correct store view.

3. Click to expand the **Countries Options** section.

4. In the **European Union Countries** list, verify that each member country of the EU is selected.

5. When complete, click the **Save Config** button.
CHAPTER 56:

Tax Quick Reference

Configuration Options

Some tax settings have a choice of options that determines the way the tax is calculated and presented to the customer. Topics in this chapter include:

- Tax Calculation Methods
- International Tax Configurations
- US Tax Configuration Recommendations
- Canada: Example Tax Configuration
- EU: Example Tax Configuration
## Tax Calculation Methods

Tax calculation method options include Unit Price, Row Total, and Total. The following table explains how rounding (to two digits) is handled for different settings.

### Tax Configuration Options

<table>
<thead>
<tr>
<th>SETTING</th>
<th>CALCULATION AND DISPLAY</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unit Price</td>
<td>Magento calculates the tax for each item and displays prices tax-inclusive. To calculate the tax total, Magento rounds the tax for each item, and then adds them together.</td>
</tr>
<tr>
<td>Row Total</td>
<td>Magento calculates the tax for each line. To calculate the tax total, Magento rounds the tax for each line item and then adds them together.</td>
</tr>
<tr>
<td>Total</td>
<td>Magento calculates the tax for each item and adds those tax values to calculate the total unrounded tax amount for the order. Magento then applies the specified rounding mode to the total tax to determine the total tax for the order.</td>
</tr>
</tbody>
</table>

## Catalog Prices With or Without Tax

The possible display fields vary depending on the calculation method and whether the catalog prices include or exclude taxes. Display fields have two-decimal precision in normal computations. Some combinations of price settings display prices that both include and exclude tax. When both appear on the same line item, it can be confusing to customers, and triggers a warning.

### Tax Configuration Options

<table>
<thead>
<tr>
<th>SETTING</th>
<th>CALCULATION AND DISPLAY</th>
</tr>
</thead>
<tbody>
<tr>
<td>Excluding Tax</td>
<td>Using this setting, the base item price is used as it is entered and the tax calculation methods are applied.</td>
</tr>
<tr>
<td>Including Tax</td>
<td>Using this setting, the base item price excluding tax is calculated first. This value is used as the base price, and the tax calculation methods are applied.</td>
</tr>
</tbody>
</table>

**Important!** Changes have been made from earlier versions for EU merchants or other VAT merchants who display prices including tax and operate in several countries with multiple store views. If you load prices with more than two digits of precision, Magento automatically rounds all prices to two digits to ensure that a consistent price is presented to buyers.
Shipping Prices With or Without Tax

**Tax Configuration Options**

<table>
<thead>
<tr>
<th>SETTING</th>
<th>DISPLAY</th>
<th>CALCULATION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Excluding Tax</td>
<td>Appears without tax.</td>
<td>Normal calculation. Shipping is added to cart total, typically displayed as a separate item.</td>
</tr>
<tr>
<td>Including Tax</td>
<td>Can be tax inclusive, or tax can be displayed separately.</td>
<td>Shipping is treated as another item in cart with taxes, using the same calculations.</td>
</tr>
</tbody>
</table>

**Tax Amounts as Line Items**

To display two different tax amounts as separate line items, such as GST and PST for Canadian stores, you must set different priorities for the related tax rules. However, in previous tax calculations, taxes with different priorities would automatically be compounded. To correctly display separate tax amounts without an incorrect compounding of the tax amounts, you can set different priorities, and also select the Calculate off subtotal only checkbox. This produces correctly calculated tax amounts that appear as separate line items.
## International Tax Configurations

### U.S. Tax Configuration

<table>
<thead>
<tr>
<th>TAX OPTION</th>
<th>RECOMMENDED SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Load catalog prices</td>
<td>Excluding tax</td>
</tr>
<tr>
<td>FPT</td>
<td>No, because FPT is not taxed.</td>
</tr>
<tr>
<td>Tax based on</td>
<td>Shipping origin</td>
</tr>
<tr>
<td>Tax Calculation</td>
<td>On total</td>
</tr>
<tr>
<td>Tax shipping?</td>
<td>No</td>
</tr>
<tr>
<td>Apply Discount</td>
<td>Before tax</td>
</tr>
<tr>
<td>Comment</td>
<td>All tax zones are the same priority; ideally, a zone for state and one or more zones for zip code lookup.</td>
</tr>
</tbody>
</table>

### U.K. B2C Tax Configuration

<table>
<thead>
<tr>
<th>TAX OPTION</th>
<th>RECOMMENDED SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Load catalog prices</td>
<td>Excluding tax</td>
</tr>
<tr>
<td>FPT</td>
<td>Yes, including FPT and description</td>
</tr>
<tr>
<td>Tax based on</td>
<td>Shipping address</td>
</tr>
<tr>
<td>Tax Calculation</td>
<td>On total</td>
</tr>
<tr>
<td>Tax shipping?</td>
<td>Yes</td>
</tr>
<tr>
<td>Apply Discount</td>
<td>Before tax, discount on prices, including tax.</td>
</tr>
<tr>
<td>Comment</td>
<td>For merchants marking up supplier invoices (including VAT).</td>
</tr>
</tbody>
</table>

### U.K. B2B Tax Configuration

<table>
<thead>
<tr>
<th>TAX OPTION</th>
<th>RECOMMENDED SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Load catalog prices</td>
<td>Excluding tax</td>
</tr>
<tr>
<td>FPT</td>
<td>Yes, including FPT and description</td>
</tr>
<tr>
<td>Tax based on</td>
<td>Shipping address</td>
</tr>
<tr>
<td>Tax Calculation</td>
<td>On item</td>
</tr>
<tr>
<td>Tax shipping?</td>
<td>Yes</td>
</tr>
</tbody>
</table>
U.K. B2B Tax Configuration (cont.)

<table>
<thead>
<tr>
<th>TAX OPTION</th>
<th>RECOMMENDED SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply Discount</td>
<td>Before tax, discount on prices, including tax.</td>
</tr>
<tr>
<td>Comment</td>
<td>For B2B merchants to provide simpler VAT supply chain considerations. Tax calculation on row is also valid; however, check with your taxing jurisdiction. Setup assumes a merchant is in the supply chain and that goods sold are used by other vendors for VAT rebates and so on. This makes it easy to discern tax by item for faster rebate generation. Note that some jurisdictions require different rounding strategies not currently supported by Magento, and that not all jurisdictions allow item or row level tax.</td>
</tr>
</tbody>
</table>

Canada Tax Configuration

<table>
<thead>
<tr>
<th>TAX OPTION</th>
<th>RECOMMENDED SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Load catalog prices</td>
<td>Excluding tax</td>
</tr>
<tr>
<td>FPT</td>
<td>Yes, including FPT, description, and apply tax to FPT.</td>
</tr>
<tr>
<td>Tax based on</td>
<td>Shipping origin</td>
</tr>
<tr>
<td>Tax Calculation</td>
<td>On total</td>
</tr>
<tr>
<td>Tax shipping?</td>
<td>Yes</td>
</tr>
<tr>
<td>Apply Discount</td>
<td>Before tax</td>
</tr>
<tr>
<td>Comment</td>
<td>Merchants located in a GST/PST province (Montreal) should create one tax rule and show a combined tax amount. Be sure to consult a qualified tax authority if you have any questions. For information about the tax requirements of specific provinces, see the following: Revenue Québec Government of Saskatchewan Manitoba Information for Vendors</td>
</tr>
</tbody>
</table>
U.S. Tax Configuration Recommendations

**Tax Classes**

<table>
<thead>
<tr>
<th>TAX CLASS</th>
<th>RECOMMENDED SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tax Class for Shipping</td>
<td>None</td>
</tr>
</tbody>
</table>

**Calculation Settings**

<table>
<thead>
<tr>
<th>CALCULATION</th>
<th>RECOMMENDED SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tax Calculation Method Based On</td>
<td>Total</td>
</tr>
<tr>
<td>Tax Calculation Based On</td>
<td>Shipping Origin</td>
</tr>
<tr>
<td>Catalog Prices</td>
<td>Excluding Tax</td>
</tr>
<tr>
<td>Shipping Prices</td>
<td>Excluding Tax</td>
</tr>
<tr>
<td>Apply Customer Tax</td>
<td>After Discount</td>
</tr>
<tr>
<td>Apply Discount on Prices</td>
<td>Excluding Tax</td>
</tr>
</tbody>
</table>

**Default Tax Destination Calculation**

<table>
<thead>
<tr>
<th>SETTING</th>
<th>RECOMMENDED SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default Country</td>
<td>United States</td>
</tr>
<tr>
<td>Default State</td>
<td>State where business is located.</td>
</tr>
<tr>
<td>Default Post Code</td>
<td>The postal code that is used in your tax zones.</td>
</tr>
</tbody>
</table>

**Price Display Settings**

<table>
<thead>
<tr>
<th>SETTING</th>
<th>RECOMMENDED SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Product Prices in Catalog</td>
<td>Excluding Tax</td>
</tr>
<tr>
<td>Display Shipping Prices</td>
<td>Excluding Tax</td>
</tr>
</tbody>
</table>

**Shopping Cart Display Settings**

<table>
<thead>
<tr>
<th>SETTING</th>
<th>RECOMMENDED SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Prices</td>
<td>Excluding Tax</td>
</tr>
<tr>
<td>Display Subtotal</td>
<td>Excluding Tax</td>
</tr>
<tr>
<td>Display Shipping Amount</td>
<td>Excluding Tax</td>
</tr>
</tbody>
</table>
### Setting

<table>
<thead>
<tr>
<th>Setting</th>
<th>Recommended Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Gift Wrapping Prices</td>
<td>Excluding Tax</td>
</tr>
<tr>
<td>Display Printed Card Prices</td>
<td>Excluding Tax</td>
</tr>
<tr>
<td>Include Tax in Grand Total</td>
<td>Yes</td>
</tr>
<tr>
<td>Display Full Tax Summary</td>
<td>Yes</td>
</tr>
<tr>
<td>Display Zero Tax Subtotal</td>
<td>Yes</td>
</tr>
</tbody>
</table>

### Orders, Invoices, Credit Memos, Display Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Recommended Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Prices</td>
<td>Excluding Tax</td>
</tr>
<tr>
<td>Display Subtotal</td>
<td>Excluding Tax</td>
</tr>
<tr>
<td>Display Shipping Amount</td>
<td>Excluding Tax</td>
</tr>
<tr>
<td>Include Tax in Grand Total</td>
<td>Yes</td>
</tr>
<tr>
<td>Display Full Tax Summary</td>
<td>Yes</td>
</tr>
<tr>
<td>Display Zero Tax Subtotal</td>
<td>Yes</td>
</tr>
</tbody>
</table>

### Fixed Product Taxes

<table>
<thead>
<tr>
<th>Setting</th>
<th>Recommended Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable FPT</td>
<td>No, except in California.</td>
</tr>
</tbody>
</table>
Canada: Example Tax Configuration

The following example shows how to set up GST tax rates for Canada and PST tax rates for Saskatchewan, with tax rules that calculate and display the two tax rates. Because this is an example configuration, be sure to verify the correct tax rates and rules for your tax jurisdictions. When setting up taxes, set the store scope to apply the configuration to all applicable stores and websites.

- Fixed product tax is included for relevant goods as a product attribute.
- In Quebec, PST is referred to as TVQ. If you need to set up a rate for Quebec, make sure to use TVQ as the identifier.

Process Overview:
Step 1: Complete the Tax Calculation Settings
Step 2: Set Up Canadian Goods & Services Tax (GST)
Step 3: Set Up Canadian Provincial Sales Tax (PST)
Step 4: Create a GST Tax Rule
Step 5: Create a PST Tax Rule for Saskatchewan
Step 6: Save and Test the Results

Step 1: Complete Tax Calculation Settings

1. On the Admin menu, select System > Configuration. Then in the panel on the left, under Sales, select Tax.
2. Click to expand each section, and complete the following settings:

Tax Calculation Settings

<table>
<thead>
<tr>
<th>FIELD</th>
<th>RECOMMENDED SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tax Calculation Method Based On</td>
<td>Total</td>
</tr>
<tr>
<td>Tax Calculation Based On</td>
<td>Shipping Address</td>
</tr>
<tr>
<td>Catalog Prices</td>
<td>Excluding Tax</td>
</tr>
<tr>
<td>Shipping Prices</td>
<td>Excluding Tax</td>
</tr>
<tr>
<td>Apply Customer Tax</td>
<td>After Discount</td>
</tr>
<tr>
<td>Apply Discount on Prices</td>
<td>Excluding Tax</td>
</tr>
<tr>
<td>Apply Tax On</td>
<td>Custom Price (if available)</td>
</tr>
</tbody>
</table>
Tax Classes

<table>
<thead>
<tr>
<th>FIELD</th>
<th>RECOMMENDED SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tax Class for Shipping</td>
<td>Shipping (shipping is taxed)</td>
</tr>
</tbody>
</table>

Default Tax Destination Calculation

<table>
<thead>
<tr>
<th>FIELD</th>
<th>RECOMMENDED SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default Country</td>
<td>Canada</td>
</tr>
<tr>
<td>Default State</td>
<td>(as appropriate)</td>
</tr>
<tr>
<td>Default Postal Code</td>
<td>* (asterisk)</td>
</tr>
</tbody>
</table>

Shopping Cart Display Settings

<table>
<thead>
<tr>
<th>FIELD</th>
<th>RECOMMENDED SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Include Tax in Grand Total</td>
<td>Yes</td>
</tr>
<tr>
<td>Display Full Tax Summary</td>
<td>Yes</td>
</tr>
<tr>
<td>Display Zero in Tax Subtotal</td>
<td>Yes</td>
</tr>
</tbody>
</table>

Fixed Product Taxes

<table>
<thead>
<tr>
<th>FIELD</th>
<th>RECOMMENDED SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable FPT</td>
<td>Yes</td>
</tr>
<tr>
<td>All FPT Display Settings</td>
<td>Including FPT and FPT description</td>
</tr>
<tr>
<td>Apply Discounts to FPT</td>
<td>No</td>
</tr>
<tr>
<td>Apply Tax to FPT</td>
<td>Yes</td>
</tr>
<tr>
<td>Include FPT in Subtotal</td>
<td>No</td>
</tr>
</tbody>
</table>

Step 2: Set Up Canadian Goods & Services Tax (GST)

To print the GST number on invoices and other sales documents, include it in the name of the applicable tax rates. The GST will appear as part of the GST amount on any order summary.

Manage Tax Zones & Rates

<table>
<thead>
<tr>
<th>FIELD</th>
<th>RECOMMENDED SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tax Identifier</td>
<td>Canada-GST</td>
</tr>
<tr>
<td>Country</td>
<td>Canada</td>
</tr>
</tbody>
</table>
Manage Tax Zones & Rates (cont.)

<table>
<thead>
<tr>
<th>FIELD</th>
<th>RECOMMENDED SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>State</td>
<td>*(asterisk)</td>
</tr>
<tr>
<td>Zip/Post is Range</td>
<td>No</td>
</tr>
<tr>
<td>Zip/Post Code</td>
<td>*(asterisk)</td>
</tr>
<tr>
<td>Rate Percent</td>
<td>5.0000</td>
</tr>
</tbody>
</table>

Step 3: **Set Up Canadian Provincial Sales Tax (PST)**

Set up another tax rate for the applicable province.

**Tax Rate Information**

<table>
<thead>
<tr>
<th>FIELD</th>
<th>RECOMMENDED SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tax Identifier</td>
<td>Canada-SK-PST</td>
</tr>
<tr>
<td>Country</td>
<td>Canada</td>
</tr>
<tr>
<td>State</td>
<td>Saskatchewan</td>
</tr>
<tr>
<td>Zip/Post is Range</td>
<td>No</td>
</tr>
<tr>
<td>Zip/Post Code</td>
<td>*(asterisk)</td>
</tr>
<tr>
<td>Rate Percent</td>
<td>5.0000</td>
</tr>
</tbody>
</table>
Step 4: Create a GST Tax Rule

To avoid compounding the tax and to correctly display the calculated tax as separate line items for GST and PST, you must set different priorities for each rule, and select the “Calculate off subtotal only” checkbox. Each tax appears as a separate line item, but the tax amounts are not compounded.

**Tax Rule Information**

<table>
<thead>
<tr>
<th>FIELD</th>
<th>RECOMMENDED SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Retail-Canada-GST</td>
</tr>
<tr>
<td>Customer Tax Class</td>
<td>Retail Customer</td>
</tr>
<tr>
<td>Product Tax Class</td>
<td>Taxable Goods</td>
</tr>
<tr>
<td></td>
<td>Shipping</td>
</tr>
<tr>
<td>Tax Rate</td>
<td>Canada-GST</td>
</tr>
<tr>
<td>Priority</td>
<td>0</td>
</tr>
<tr>
<td>Calculate off subtotal only</td>
<td>Select this checkbox.</td>
</tr>
<tr>
<td>Sort Order</td>
<td>0</td>
</tr>
</tbody>
</table>

Step 5: Create a PST Tax Rule for Saskatchewan

For this tax rule, make sure to set the priority to 0 and select the "Calculate off subtotal only" checkbox. Each tax appears as a separate line item, but the tax amounts are not compounded.

**Tax Rule Information**

<table>
<thead>
<tr>
<th>FIELD</th>
<th>RECOMMENDED SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Retail-Canada-PST</td>
</tr>
<tr>
<td>Customer Tax Class</td>
<td>Retail Customer</td>
</tr>
<tr>
<td>Product Tax Class</td>
<td>Taxable Goods</td>
</tr>
<tr>
<td></td>
<td>Shipping</td>
</tr>
<tr>
<td>Tax Rate</td>
<td>Canada-SK-PT</td>
</tr>
<tr>
<td>Priority</td>
<td>1</td>
</tr>
<tr>
<td>Calculate off subtotal only</td>
<td>Select this checkbox.</td>
</tr>
<tr>
<td>Sort Order</td>
<td>0</td>
</tr>
</tbody>
</table>
Step 6: Save and Test the Results

1. When complete, click the **Save Config** button.
2. Return to your storefront, and create a sample order to test the results.
EU Example Tax Configuration

The following example depicts a store based in France that sells > 100k Euros in France and > 100k Euros in Germany.

- Tax calculations are managed at the website level.
- Currency conversion and tax display options are controlled individually at the store view level, (Click the Use Website checkbox to override the default).
- By setting the default tax country you can dynamically show the correct tax for the jurisdiction.
- Fixed product tax is included for relevant goods as a product attribute.
- It might be necessary to edit the catalog to ensure that it shows up in the correct category/website/store view.

<table>
<thead>
<tr>
<th>Process Overview:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1: Create Three Product Tax Classes</td>
</tr>
<tr>
<td>Step 2: Create Tax Rates for France and Germany</td>
</tr>
<tr>
<td>Step 3: Set Up the Tax Rules</td>
</tr>
<tr>
<td>Step 4: Set Up a Store View for Germany</td>
</tr>
<tr>
<td>Step 5: Configure Tax Settings for France</td>
</tr>
<tr>
<td>Step 6: Configure Tax Settings for Germany</td>
</tr>
</tbody>
</table>

**Step 1: Create Three Product Tax Classes**

For this example, it is assumed that multiple VAT-Reduced product tax classes are not needed.

1. Create a VAT-Standard product tax class.
2. Create a VAT-Reduced product tax class.
3. Create a VAT-Free product tax class.
**Step 2: Create Tax Rates for France and Germany**

Create the following tax rates:

<table>
<thead>
<tr>
<th>TAX RATE</th>
<th>SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>France-StandardVAT</td>
<td>Country: France</td>
</tr>
<tr>
<td></td>
<td>State/Region: *</td>
</tr>
<tr>
<td></td>
<td>ZIP/Postal Code: *</td>
</tr>
<tr>
<td></td>
<td>Rate: 20%</td>
</tr>
<tr>
<td>France-ReducedVAT</td>
<td>Country: France</td>
</tr>
<tr>
<td></td>
<td>State/Region: *</td>
</tr>
<tr>
<td></td>
<td>ZIP/Postal Code: *</td>
</tr>
<tr>
<td></td>
<td>Rate: 5%</td>
</tr>
<tr>
<td>Germany-StandardVAT</td>
<td>Country: Germany</td>
</tr>
<tr>
<td></td>
<td>State/Region: *</td>
</tr>
<tr>
<td></td>
<td>ZIP/Postal Code: *</td>
</tr>
<tr>
<td></td>
<td>Rate: 19%</td>
</tr>
<tr>
<td>Germany-ReducedVAT</td>
<td>Country: Germany</td>
</tr>
<tr>
<td></td>
<td>State/Region: *</td>
</tr>
<tr>
<td></td>
<td>ZIP/Postal Code: *</td>
</tr>
<tr>
<td></td>
<td>Rate: 7%</td>
</tr>
</tbody>
</table>
Step 3: **Set Up the Tax Rules**

Create the following tax rules:

### Tax Rules

<table>
<thead>
<tr>
<th>TAX RULE</th>
<th>SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Retail-France-StandardVAT</td>
<td>Customer Class: Retail Customer</td>
</tr>
<tr>
<td></td>
<td>Tax Class: VAT-Standard</td>
</tr>
<tr>
<td></td>
<td>Tax Rate: France-StandardVAT</td>
</tr>
<tr>
<td></td>
<td>Priority: 0</td>
</tr>
<tr>
<td></td>
<td>Sort Order: 0</td>
</tr>
<tr>
<td>Retail-France-ReducedVAT</td>
<td>Customer Class: Retail Customer</td>
</tr>
<tr>
<td></td>
<td>Tax Class: VAT-Reduced</td>
</tr>
<tr>
<td></td>
<td>Tax Rate: France-ReducedVAT</td>
</tr>
<tr>
<td></td>
<td>Priority: 0</td>
</tr>
<tr>
<td></td>
<td>Sort Order: 0</td>
</tr>
<tr>
<td>Retail-Germany-StandardVAT</td>
<td>Customer Class: Retail Customer</td>
</tr>
<tr>
<td></td>
<td>Tax Class: VAT-Standard</td>
</tr>
<tr>
<td></td>
<td>Tax Rate: Germany-StandardVAT</td>
</tr>
<tr>
<td></td>
<td>Priority: 0</td>
</tr>
<tr>
<td></td>
<td>Sort Order: 0</td>
</tr>
<tr>
<td>Retail-Germany-ReducedVAT</td>
<td>Customer Class: Retail Customer</td>
</tr>
<tr>
<td></td>
<td>Tax Class: VAT-Reduced</td>
</tr>
<tr>
<td></td>
<td>Tax Rate: Germany-ReducedVAT</td>
</tr>
<tr>
<td></td>
<td>Priority: 0</td>
</tr>
<tr>
<td></td>
<td>Sort Order: 0</td>
</tr>
</tbody>
</table>
Step 4: Set Up a Store View for Germany

1. In the upper-left corner of the Admin, click the Manage Stores link.

2. Under the default website, create a store view for Germany. Then, do the following:
   a. On the Admin menu, select System > Configuration. In the upper-left corner, set Default Config to the French store.
   b. On the General page, click to expand the Countries Options section, and set the default country to “France.”
   c. Complete the locale options as needed.

3. In the upper-left corner, set Current Configuration Scope to the German website. Then, do the following:
   a. On the General page, click to expand Countries Options, and set the default country to “Germany.”
   b. Complete the locale options as needed.

Step 5: Configure Tax Settings for France

Complete the following General tax settings:

**General Settings**

<table>
<thead>
<tr>
<th>FIELD</th>
<th>RECOMMENDED SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tax Class for Shipping</td>
<td>Shipping (shipping is taxed)</td>
</tr>
<tr>
<td>Tax Calculation Method Based On</td>
<td>Total</td>
</tr>
<tr>
<td>Tax Calculation Based On Shipping Address</td>
<td></td>
</tr>
<tr>
<td>Catalog Prices</td>
<td>Including Tax</td>
</tr>
<tr>
<td>Shipping Prices</td>
<td>Including Tax</td>
</tr>
<tr>
<td>Apply Customer Tax</td>
<td>After Discount</td>
</tr>
<tr>
<td>Apply Discount on Prices</td>
<td>Including Tax</td>
</tr>
<tr>
<td>Apply Tax On</td>
<td>Custom Price (if available)</td>
</tr>
<tr>
<td>Default Country</td>
<td>France</td>
</tr>
<tr>
<td>Default State</td>
<td></td>
</tr>
</tbody>
</table>
### General Settings (cont.)

<table>
<thead>
<tr>
<th>FIELD</th>
<th>RECOMMENDED SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default Postal Code</td>
<td><em>(asterisk)</em></td>
</tr>
<tr>
<td>Include Tax in Grand Total</td>
<td>Yes</td>
</tr>
<tr>
<td>Enable FPT</td>
<td>Yes</td>
</tr>
<tr>
<td>All FPT Display Settings</td>
<td>Including FPT and FPT description</td>
</tr>
<tr>
<td>Apply Discounts to FPT</td>
<td>No</td>
</tr>
<tr>
<td>Apply Tax to FPT</td>
<td>Yes</td>
</tr>
<tr>
<td>Include FPT in Subtotal</td>
<td>Yes</td>
</tr>
</tbody>
</table>

### Step 6: Configure Tax Settings for Germany

1. On the Admin menu, select **System > Configuration**.
2. In the panel on the left, under Sales, select **Tax**.
3. Click to expand the **Default Tax Destination Calculation** section, and do the following:
   
   ![Default Tax Destination Calculation](image)

   - **Default Tax Destination Calculation**
   
   a. In the upper-right corner, set **Current Configuration Scope** to the German store.
   
   b. To the right of the Default Country field, clear the **Use Website** checkbox. Then, set **Default Country** to “Germany.”
   
   c. To the right of the Default State field, clear the **Use Website** checkbox. Then, set **Default State** to “*.”
   
   d. To the right of the Default Post Code field, select the **Use Website** checkbox. Then, set **Default Post Code** to “*.”

4. When complete, click the **Save Config** button to save the settings.
Tax Warning Messages

Some combinations of tax-related options might cause customers to lose confidence in the purchase, and abandon their carts. In general, these conditions occur when the tax calculation method is set to “Row” or “Total,” and the customer is presented with prices that both exclude and include tax, or tax on an item basis in the cart. Because the tax calculation is rounded, the amount that appears in the cart might differ from the amount that a customer expects to pay.

Shopping Cart Line Item that Includes and Excludes Tax

If your tax calculation is based on a problematic configuration, the following warnings appear:
Calculation Settings

Some combinations of price settings display prices which both include and exclude tax. This mixed message can be confusing to customers, and trigger a warning. Use the following tables for reference when configuring tax calculation settings:

### Tax Calculation Method: Excluding Tax

<table>
<thead>
<tr>
<th>PRICE DISPLAY</th>
<th>UNIT PRICE</th>
<th>ROW TOTAL</th>
<th>TOTAL</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tax Class for Shipping</td>
<td>Shipping (is taxed)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Excluding tax</td>
<td>OK</td>
<td>OK</td>
<td>OK</td>
</tr>
<tr>
<td>Including tax</td>
<td>OK</td>
<td>OK</td>
<td>OK</td>
</tr>
<tr>
<td>Including and Excluding tax</td>
<td>OK</td>
<td>OK</td>
<td><strong>Warning</strong></td>
</tr>
</tbody>
</table>

### Catalog Prices: Including Tax

<table>
<thead>
<tr>
<th>PRICE DISPLAY</th>
<th>UNIT PRICE</th>
<th>ROW TOTAL</th>
<th>TOTAL</th>
</tr>
</thead>
<tbody>
<tr>
<td>Excluding tax</td>
<td>OK</td>
<td>OK</td>
<td>OK</td>
</tr>
<tr>
<td>Including tax</td>
<td>OK</td>
<td>OK</td>
<td>OK</td>
</tr>
<tr>
<td>Including and Excluding tax</td>
<td>OK</td>
<td></td>
<td><strong>Warning</strong> <strong>Warning</strong></td>
</tr>
</tbody>
</table>

![Calculation Settings](image_url)
Discount Settings

We strongly recommend that you use the following settings to avoid issues when configuring taxes in relation to discounts.

## Discount Settings

<table>
<thead>
<tr>
<th>FIELD</th>
<th>RECOMMENDED SETTING</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply Customer Tax</td>
<td>After Discount</td>
</tr>
<tr>
<td>Apply Discount on Prices</td>
<td>US and Canada Excluding Tax EU Including Tax</td>
</tr>
</tbody>
</table>
Reports

Magento Community Edition provides a wide selection of reports to keep you current on everything from the contents of your customers’ shopping carts to the tags they use. Report data can be viewed online or downloaded as a CSV or XML data file.

Dashboard
- Snapshot Reports
- Dashboard Setup

Running Reports
- Refreshing Report Statistics
- Available Reports
  - Sales
  - Shopping Cart
  - Products
  - Customers
  - Tags
  - Wishlists
  - Reviews
  - Newsletters
  - Search Terms
CHAPTER 57:

Dashboard

The dashboard is usually the first page that appears when you log in to the Admin, and gives an overview of sales and customer activity. The blocks on the left provide a snapshot of lifetime sales, average order amount, the last five orders, and search terms. The graph depicts the orders and amounts for the selected date range. You can use the tabs above the graph to toggle between the two views.

Although by default, the dashboard is the startup page for the Admin, you can change the configuration to show a different page when you log in. You can also set the starting dates used in dashboard reports, and disable the display of the charts section. To learn more, see: Dashboard Setup.

Snapshot Reports

The dashboard provides quick reports about your sales, search terms entered by customers, best-selling and most viewed products, new customers, and those who have purchased the most during the specified date range.
Snapshot Reports

Bestsellers
Lists your best-selling products, showing the price and quantity ordered.

Most Viewed Products
Lists the most recently viewed products and the number of times viewed.

New Customers
Lists recently registered customers.

Customers
Lists customers who have ordered the most during the specified range of time.
Dashboard Setup

By default, the dashboard is the startup page for the Admin. However, if you prefer, you can change the configuration to display a different page when you log in. You can also set the starting dates used in dashboard reports, and disable the display of the charts section.

**To set the date range:**

Set **Select Range** to one of the following:

- Last 24 Hours
- Last 7 Days
- Current Month
- YTD
- 2YTD

**To set the starting dates:**

1. On the Admin menu, select **System > Configuration**.
2. In the Configuration panel on the left, under General, select **Reports**.
3. Click to expand the **Dashboard** section, do the following:
   a. Set **Year-To-Date Starts** to the month and year that the current year began.
   b. Set **Current Month Starts** to the current month.

**To change the Admin startup page:**

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left, under Advanced, select **Admin**.
2. In the Admin UI section, set **Startup Page** to the page you want to first appear when you log in to the Admin.
3. Click the **Save Config** button to save the setting.
To turn off real-time data:

If you have a lot of data to process, the performance of the Dashboard can be improved by turning off the display of real time data.

1. On the Admin menu, select **System > Configuration**. Then in the Configuration panel on the left, under Sales, select **Sales**.

2. Click to expand the **Dashboard** section. Then, set **Use Aggregated Data (beta)** to “Yes.”

To disable charts:

1. On the Admin menu, select **System > Configuration**. Then in the Configuration panel on the left, under Advanced, select **Admin**.

2. In the Dashboard section, set **Enable Charts** to “No.”

3. When complete, click the **Save Config** button.

   A message on the Dashboard indicates that the chart is now disabled.
CHAPTER 58:

Running Reports

Magento provides a variety of reports that you can access at any time. To see the reports that you can generate in Magento, from the Reports menu, select a type of report and then select a specific report of that type. Some report pages have filter controls that enable you to narrow the scope of the report. When you are finished making filter selections, click Show Report (or Refresh, in some reports) to generate the report.

![Reports Menu](image-url)
To run the Orders report:

The Orders report includes real-time data, and can include orders of any status during a specific period of time.

1. On the Admin menu, select **Reports > Sales > Orders**. Then, do the following:
   a. A message indicates the last time the report statistics were refreshed. If necessary, click the link to refresh the statistics.
   b. Set **Show Report for** to the website, store, or store view that you want to include in the report.
   c. Set **Match Period To** to one of the following:
      - Order Created Date
      - Order Updated Date
   d. To determine how the report data is aggregated by row, set **Period** to one of the following:
      - Day
      - Month
      - Year
   e. To include activity during a specific period, click the calendar icon and select the **From** and **To** dates.
   f. To choose the orders that are included in the report, do one of the following:
To include all orders, set Order Status to “Any.”
To include only orders with a specific status, set Order Status to “Specified.” Then, select each order status that you want to include in the report.

g. To omit any empty rows from the report, set Empty Rows to “No.”
h. To show actual, rather than projected values, set Show Actual Values to “Yes.”

2. When ready to run the report, click the Show Report button.

To export report data:

1. Set the Export to control to one of the following:
   - CSV
   - Excel XML

2. Click the Export button. Then, look for the download file in the lower-left corner of your browser window.
# Field Descriptions

<table>
<thead>
<tr>
<th>FILTER CONTROL</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Report For</td>
<td>Determines the store view or website (or all websites) that are included in the report.</td>
</tr>
<tr>
<td>Match Period To</td>
<td>Determines how the records are selected to be included, based on either the order creation date or the order modified date. Options include: Order Created Date Order Updated Date</td>
</tr>
<tr>
<td>Period</td>
<td>Determines how report data is aggregated. Options include: Day Month Year</td>
</tr>
<tr>
<td>From and To</td>
<td>Determines the start and end dates that are covered by the report.</td>
</tr>
<tr>
<td>Order Status</td>
<td>Determines the status of orders that are included in the report. Options include: Any / Specified.</td>
</tr>
<tr>
<td>Empty Rows</td>
<td>Determines if rows without data are included in the report. Options include: Yes / No.</td>
</tr>
<tr>
<td>Show Actual Values</td>
<td>Determines if report values reflect actual or projected values based on an estimate. Options include: Yes / No.</td>
</tr>
</tbody>
</table>
Refreshing Report Statistics

To reduce the performance impact of generating sales reports, Magento calculates and stores the required statistics for each report. When you generate a report, the report uses the stored statistics, rather than recalculating the statistics each time you generate a report. To include the most recent data, the sales report statistics must be refreshed. Refreshing the sales report statistics is a manual process.

To refresh sales report statistics:

1. On the Admin menu, select Reports > Refresh Statistics.
2. In the list, select the checkbox of each report that needs to be refreshed.
3. Set the Actions control to one of the following:
   - Refresh Lifetime Statistics
   - Refresh Statistics for the Last Day
4. When complete, click the Submit button.
Available Reports

Report Descriptions

<table>
<thead>
<tr>
<th>REPORT</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sales Reports</td>
<td></td>
</tr>
<tr>
<td>Total Ordered</td>
<td>Reports &gt; Sales &gt; Orders</td>
</tr>
<tr>
<td></td>
<td>Shows orders for the specified time period.</td>
</tr>
<tr>
<td>Order Taxes</td>
<td>Reports &gt; Sales &gt; Tax</td>
</tr>
<tr>
<td></td>
<td>Shows taxes charged for orders in the specified time period; grouped by tax rate.</td>
</tr>
<tr>
<td>Total Invoiced vs. Paid</td>
<td>Reports &gt; Sales &gt; Invoiced</td>
</tr>
<tr>
<td></td>
<td>Shows amounts paid and unpaid for invoiced orders in the specified time period.</td>
</tr>
<tr>
<td>Total Shipped</td>
<td>Reports &gt; Sales &gt; Shipping</td>
</tr>
<tr>
<td></td>
<td>Shows orders shipped in the specified time period, grouped by carrier/method; includes shipping charge amounts.</td>
</tr>
<tr>
<td>Total Refunded</td>
<td>Reports &gt; Sales &gt; Refunds</td>
</tr>
<tr>
<td></td>
<td>Shows refunds applied to orders in the specified time period.</td>
</tr>
<tr>
<td>Coupons Usage</td>
<td>Reports &gt; Sales &gt; Coupons</td>
</tr>
<tr>
<td></td>
<td>Shows coupons used for orders in the specified time period, grouped by coupon code.</td>
</tr>
<tr>
<td>PayPal Settlement</td>
<td>Reports &gt; Sales &gt; PayPal Settlement Reports</td>
</tr>
<tr>
<td></td>
<td>Shows PayPal settlements for the specified time period. Click Fetch Updates to retrieve data from PayPal.</td>
</tr>
<tr>
<td>ShoppingCart Reports</td>
<td></td>
</tr>
<tr>
<td>Products in Carts</td>
<td>Reports &gt; Shopping Cart &gt; Products in carts</td>
</tr>
<tr>
<td></td>
<td>Shows products that are currently in shopping carts.</td>
</tr>
<tr>
<td>Abandoned Carts</td>
<td>Reports &gt; Shopping Cart &gt; Abandoned Carts</td>
</tr>
<tr>
<td></td>
<td>Shows shopping carts that were started but then abandoned. Enables you to contact customers to offer incentives to turn an abandoned cart into a conversion.</td>
</tr>
<tr>
<td>Product Reports</td>
<td></td>
</tr>
</tbody>
</table>
# Report Descriptions (cont.)

<table>
<thead>
<tr>
<th>REPORT</th>
<th>DESCRIPTION</th>
</tr>
</thead>
</table>
| Products Bestsellers          | Reports > Products > Bestsellers  
Shows the products that were sold in the highest quantity in the specified time period. |
| Products Ordered              | Reports > Products > Products Ordered  
Shows all products that were ordered in the specified time period. |
| Most Viewed                   | Reports > Products > Most Viewed  
Shows the products that were viewed the most times in the specified time period. |
| Low Stock                     | Reports > Products > Low Stock  
Shows the products whose stock levels are low. |
| Downloads                     | Reports > Products > Downloads  
Shows the number of purchases and downloads for each downloadable product. |

## Customer Reports

<table>
<thead>
<tr>
<th>REPORT</th>
<th>DESCRIPTION</th>
</tr>
</thead>
</table>
| New Accounts                    | Reports > Customers > New Accounts  
Shows the new accounts that were created during the specified time period. |
| Customers by Orders Total       | Reports > Customers > Customers by orders total  
Shows the customers listed in descending order of total order amount. |
| Customers by Number of Orders   | Reports > Customers > Customers by number of orders  
Shows the customers listed in descending order of number of orders placed. |

## Tag Reports

<table>
<thead>
<tr>
<th>REPORT</th>
<th>DESCRIPTION</th>
</tr>
</thead>
</table>
| Customers Tags                  | Reports > Tags > Customers  
Shows the customers listed with the number of tags each one has created. |
| Products Tags                   | Reports > Tags > Products  
Shows the number of unique tags and total number of tags created for each product. |
| Popular Tags                    | Reports > Tags > Popular  
Shows the number of times each tag has been applied. |
### Report Descriptions (cont.)

<table>
<thead>
<tr>
<th>REPORT</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Review Reports</strong></td>
<td></td>
</tr>
<tr>
<td>Customers Reviews</td>
<td>Reports &gt; Reviews &gt; Customers Reviews</td>
</tr>
<tr>
<td></td>
<td>Shows the customers listed in descending order of number of reviews contributed.</td>
</tr>
<tr>
<td>Products Reviews</td>
<td>Reports &gt; Reviews &gt; Products Reviews</td>
</tr>
<tr>
<td></td>
<td>Shows the products listed in descending order of number of reviews.</td>
</tr>
<tr>
<td><strong>Search Term Report</strong></td>
<td></td>
</tr>
<tr>
<td>Search Terms</td>
<td>Reports &gt; Search Terms</td>
</tr>
<tr>
<td></td>
<td>Shows terms submitted with the search tool. If Hits are high, but the Results are low, you should review product names and descriptions so you can promote products related to the term.</td>
</tr>
</tbody>
</table>
Store Operations

The topics in this section focus on the back office details of running your business. You will learn how to customize email templates to reflect your voice and brand, import and export data, establish permissions for multiple admin users, configure secure logins, and run reports.

Stores
- Currency Rates
- Currency Configuration
- Currency Symbols
- Updating Currency Rates

Email Templates
- Supported Email Clients
- Template Layout and Styles
- Preparing Your Email Logo
- Magento Upgrades
- Updating Default Templates
- Creating Custom Templates
  - Email Header
  - Email Footer
  - Email Body
- Email Template Configuration
- Email Template Reference

Data Transfer
- Working with CSV Files
- Import
  - Importing Product Images
  - Import Guidelines
- Export
- Dataflow

Permissions
- New Users
- Custom Roles
- Content

Security
CHAPTER 59:

Currency Rates

Magento Community Edition gives you the ability to accept currencies from more than two hundred countries around the world. When a store supports multiple currencies, a Currency Chooser appears in the header of every page after the rates are updated.

![Currency Chooser](Image)

If you accept payment in multiple currencies, make sure to monitor the currency rate settings, because any fluctuation can affect your profit margin.

Currency symbols appear in product prices and sales documents such as orders and invoices. You can customize the currency symbols as needed, and also set the display of the price separately for each store or view.
Currency Configuration

Before setting up individual currency rates, you must first specify which currencies you accept, and the currency used to display prices in your store.

Step 1: Choose the Currencies You Accept

1. On the Admin menu, select System > Configuration. Then in the panel on the left under General, select Currency Setup.

2. Click to expand the Currency Options section. Then, do the following:
   a. Set Base Currency to the primary currency that you use for online transactions.
   b. Set Default Display Currency to the currency that you use to display pricing in your store.
   c. In the Allowed Currencies list, select all currencies that you accept as payment in your store. Make sure that you also select your primary currency. (To select multiple currencies, hold down the Ctrl key and click each option.)

3. To define the scope of the base currency configuration, do the following:
   a. In the panel on the left, under Catalog, select Catalog. Then, click to expand the Price section.
   b. Set Catalog Price Scope to define the scope of the base currency configuration as either global, or limited to the website.

4. When complete, click the Save Config button.
Step 2: Configure the Import Connection

1. In the panel on the left under General, select **Currency Setup**.
2. Click to expand the **WebserviceX** section.
3. In the **Connection Timeout in Seconds** field, enter the number of seconds of inactivity to allow before the connection times out.

![WebserviceX](image)

Step 3: Configure the Scheduled Import Settings

1. Continuing with Currency Setup, click to expand the **Scheduled Import Settings** section.

![Scheduled Import Settings](image)

2. To automatically update currency rates, set **Enabled** to "Yes." Then, do the following:
   a. Set **Service** to the rate provider. The default value is “Webservicex.”
   b. Set **Start Time** to the hour, minute, and second of the scheduled update.
   c. To determine how often the rates are updated, set **Frequency** to one of the following:
      - Daily
      - Weekly
      - Monthly
   d. In the **Error Email Recipient** field, enter the email address of the person who is to receive email notification if an error occurs during the import process. Separate multiple email addresses with a comma.
   e. Set **Error Email Sender** to the store contact that appears as the sender of the error notification.
   f. Set **Error Email Template** to the email template used for the error notification.
3. When complete, click the **Save Config** button.

### Currency Symbols

Manage Currency Symbols gives you the ability to customize the symbol associated with each currency that is accepted as payment in your store.

#### Manage Currency Symbols

**To customize currency symbols:**

1. On the Admin menu, select **System > Manage Currency > Symbols**.

   Each enabled currency for your store appears in the Currency list.

2. Enter a custom symbol for each currency you want to use, or select the **Use Standard** checkbox to the right of each currency.

3. If you want to override the default symbol, clear the **Use Standard** checkbox. Then, enter the symbol you want to use.

   *It is not possible to change the alignment of the currency symbol from left to right.*

4. When complete, click the **Save Currency Symbols** button.

### Updating Currency Rates

Currency rates can be set manually, or be imported into the store. To ensure that your store has the most current rates, you can configure the currency rates to be updated automatically on schedule.

Before importing currency rates, complete the **Currency Setup** to specify the currencies that you accept, and to set up the import connection and schedule.
To manually update a currency rate:

1. On the Admin menu, select **System > Manage Currency Rates**.
2. Click the rate you want to change, and type the new value.
3. When complete, click the **Save Currency Rates** button.

To import currency rates:

1. On the Admin menu, select **System > Manage Currency Rates**.
2. Set **Import Service** to the currency rate provider. WebserviceX is the default provider.
3. Click the **Import** button.

   The updated rates appear in the Manage Currency Rates list. If the rates have changed since the last update, the old rate appears below for reference.
4. When complete, click the **Save Currency Rates** button.

   A message appears when the updated rates have been saved.

To import currency rates on schedule:

1. Make sure that **Cron** is enabled for your store.
2. Complete the **Currency Setup** to specify the currencies that you accept, and to set up the import connection and schedule.
3. To verify that the rates are imported on schedule, check the Manage Currency Rates list. Then, wait for the duration of the frequency setting established for the schedule, and check the rates again.
CHAPTER 60: Managing Email Templates

Email templates define the layout, content, and formatting of automated messages sent from your store. They are called transactional emails\(^1\) because each one is associated with a specific type of transaction, or event.

Magento includes a set of responsive email templates that are triggered by a variety of events that take place during the operation of your store. Each template is optimized for any screen size, and can be viewed from the desktop, as well as on tablets and smartphones. You will find a variety of prepared email templates related to customer activities, sales, product alerts, admin actions, and system messages that you can customize to reflect your brand. Topics in this chapter include:

- Supported Email Clients
- Template Layout and Styles
- Preparing Your Email Logo
- Magento Upgrades
- Updating Default Templates
- Creating Custom Templates
- Email Header
- Email Footer
- Email Body
- Email Template Configuration
- Email Template Reference

\(^1\) An automated email message that is sent in response to a specific event or transaction.
Supported Email Clients

A wide range of technologies is supported by the various email clients and services available today. Although they do not all follow the same standards, and there is some variation in the way email messages are rendered, we have found the following services to be compatible with Magento Community Edition.

### Desktop Clients

<table>
<thead>
<tr>
<th>OPERATING SYSTEM</th>
<th>CLIENTS SUPPORTED</th>
</tr>
</thead>
<tbody>
<tr>
<td>OS X 10.8</td>
<td>Apple Mail 6</td>
</tr>
<tr>
<td>OS X 10.7</td>
<td>Outlook 2011</td>
</tr>
<tr>
<td></td>
<td>Outlook 2013</td>
</tr>
<tr>
<td>Windows 8</td>
<td>Outlook 2010</td>
</tr>
<tr>
<td>Windows 7</td>
<td>Outlook 2007</td>
</tr>
<tr>
<td></td>
<td>Outlook 2003</td>
</tr>
</tbody>
</table>

### Mobile Clients

<table>
<thead>
<tr>
<th>OPERATING SYSTEM</th>
<th>CLIENTS SUPPORTED</th>
</tr>
</thead>
<tbody>
<tr>
<td>Android 4.2, “Jelly Bean”</td>
<td>Native email app</td>
</tr>
<tr>
<td>Android 2.3, “Gingerbread”</td>
<td>Native email app</td>
</tr>
<tr>
<td>Gmail App (Android 4.2)</td>
<td>Native email app</td>
</tr>
<tr>
<td>Blackberry 5 OS</td>
<td>Native email app</td>
</tr>
<tr>
<td>IOS 8</td>
<td>iPhone 6</td>
</tr>
<tr>
<td></td>
<td>iPhone 6 Plus</td>
</tr>
<tr>
<td>IOS 7</td>
<td>iPad (Retina)</td>
</tr>
<tr>
<td></td>
<td>iPad Mini</td>
</tr>
<tr>
<td></td>
<td>iPhone 5s</td>
</tr>
<tr>
<td>Mail on these devices:</td>
<td></td>
</tr>
<tr>
<td>IOS 6</td>
<td>iPhone 5</td>
</tr>
<tr>
<td></td>
<td>iPhone 4s</td>
</tr>
</tbody>
</table>
### Web Clients

<table>
<thead>
<tr>
<th>EMAIL APPLICATION</th>
<th>BROWSERS SUPPORTED*</th>
</tr>
</thead>
<tbody>
<tr>
<td>AOL Mail</td>
<td>Chrome</td>
</tr>
<tr>
<td></td>
<td>Internet Explorer</td>
</tr>
<tr>
<td></td>
<td>Firefox</td>
</tr>
<tr>
<td>Gmail</td>
<td>Chrome</td>
</tr>
<tr>
<td></td>
<td>Internet Explorer</td>
</tr>
<tr>
<td></td>
<td>Firefox</td>
</tr>
<tr>
<td>Yahoo! Mail</td>
<td>Chrome</td>
</tr>
<tr>
<td></td>
<td>Internet Explorer</td>
</tr>
<tr>
<td></td>
<td>Firefox</td>
</tr>
<tr>
<td>Outlook.com</td>
<td>Chrome</td>
</tr>
<tr>
<td></td>
<td>Internet Explorer</td>
</tr>
</tbody>
</table>

* The latest version of each browser was used for testing.
Email Template Layout and Styles

Magento Community Edition has a set of responsive templates that define the header, body, and footer of all automated email messages that are sent from your store. The content, or body section, is combined with the header and footer to create each message. You can set up the header and footer one time, and then use them for every message.

Inline and Non-Inline Styles

Email templates are written in HTML, and are associated with the locale. The CSS files that provide the formatting instructions are stored separately, and reside on the server.

Many email clients do not support CSS formatting instructions that are stored separately from the email message. For this reason, the non_inline_styles variable has been added to the header of each message, to convert the external CSS styles to local, inline styles. The variable points to the CSS file on the server that provides the styles that are needed to format the template. The styles are then converted to inline styles, and copied to the <styles> tag of each message.

When you examine the header template code, you will find the markup tag with the non_inline_styles variable just after the <body> tag.

```html
<body>
{var non_inline_styles}
<!-- Begin wrapper table -->
```

When customizing transactional email templates from the Admin, you can enter any additional CSS styles that you need directly into the Template Styles box. They will be included when the non_inline_styles are converted.
Preparing Your Email Logo

To ensure that your logo renders well on high-resolution devices, the uploaded image should be at least twice the size of the dimensions that are specified in the header template. Be careful to preserve the aspect ratio\(^1\) of the logo, so the height and width resize proportionally.

![Logo with Transparent Background](image)

Supported File Formats

Logos can be saved as any of the following file types. Logos with transparent backgrounds can be saved as either .GIF or .PNG files.

- JPG / JPEG
- GIF
- PNG

Image Size

To make the most of the limited vertical space in the header, the logo should be cropped to eliminate any wasted space above or below the image. As a general rule, you can make an image smaller than the original, but not larger without losing resolution. If possible, the original artwork should be at least as large as the uploaded file. Taking a small image and doubling its size in a photo editor does not improve the resolution.

For example, in the default header template, the display dimensions of the logo are 168 pixels wide by 48 pixels high. To increase the resolution of the image, the image that is uploaded must be at least twice the size.

<table>
<thead>
<tr>
<th>LOGO DIMENSIONS</th>
<th>1 X (DISPLAY SIZE)</th>
<th>2 X (IMAGE SIZE)</th>
<th>2.5 X (IMAGE SIZE)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width:</td>
<td>168 px</td>
<td>336 px</td>
<td>420 px</td>
</tr>
<tr>
<td>Height:</td>
<td>48 px</td>
<td>96 px</td>
<td>120 px</td>
</tr>
</tbody>
</table>

\(^1\)The proportional relationship between the width and height of an image.
If the original artwork was created as a vector, rather than a bitmap, it can be scaled up or down to the dimensions needed without losing resolution. The image can then be saved in one of the supported bitmap image formats. If the original logo artwork is a bitmap, the original should be at least twice the display size.

**Magento Upgrades**

If you have upgraded from an earlier version of Magento Community Edition, you can use an email client to view each transactional email template that is generated by your store. Verify that the logo, fonts, and styles render correctly. Email templates that were created with earlier versions of Magento do not have the `non_inline_styles` variable, and are not responsive. However, most can be used as they are.

To take advantage of the high-resolution display that is available on many devices, email logos are now uploaded at twice their display size. If you intend to use the responsive email templates, you should upload a higher resolution logo.

It is not necessary to reconfigure your email logo for use with custom templates that were created with earlier versions of Magento.
Updating Default Templates

Email templates are formatted with HTML and CSS, and can be easily edited. In addition, you can further customize the template by adding variables and widgets.

Many of the default email templates contain placeholder information that must be changed before any transactional email messages are sent to customers. When the template is ready to be used, make sure to update your system configuration, so the updated template will be used instead of the sample template.

**Step 1: Choose a Default Template**

1. On the Admin menu, select **System > Transactional Emails**.
2. Click the **Add New Template** button.
3. In the **Template** list, select a default template from the list of predefined templates.

4. If necessary, set the **Locale** to the store language.
5. Click the **Load Template** button.

The path to the configuration settings for each default template appears at the top of the Template Information section. Make note of this "Used as Default for" path, because you will later need to update the configuration with the name of the new template.
Step 2: Customize the Content

1. In the Template Information section, do the following:
   a. Enter a **Template Name** for the new email template.
   b. In the **Template Subject** field, type the text to appear in the Subject header of the message.
   c. Complete the **Template Content** as needed.

2. (Optional) To insert a variable, do the following:
   a. Position the cursor in the text where you want the variable to appear.
   b. Click the **Insert Variable** button.
   c. In the list of available **predefined variables**, click the variable you want to insert into the template.

3. When complete, click the **Save Template** button.

4. Make sure to **Preview** the template before associating it with a transactional email message that is sent to customers.
Step 3: Update Your Configuration

Before the template can be used, the configuration must be updated with the name of the new template. Refer to the path that you recorded in Step 1 when updating your configuration with the name of the new template. To learn more, see: Configuring Email Templates.

1. On the Admin menu, select System > Configuration.
2. In the panel on the left, under Sales, select Sales Emails.
3. Update the templates as needed.
4. When complete, click the Save Config button.
Email Template Variables

**PREDEFINED VARIABLES**

**STORE CONTACT INFORMATION**
- Base Unsecure URL
- Base Secure URL
- General Contact Name
- General Contact Email
- Sales Representative Contact Name
- Sale Representative Contact Email
- Custom 1 Contact Name
- Custom 1 Contact Email
- Custom 2 Contact Name
- Custom 2 Contact Email
- Store Name
- Store Contact Telephone
- Store Contact Address

**TEMPLATE VARIABLES**
- Store Url
- Email Logo Image Url
- Customer Name
- Customer Account Url
- Customer Email
- Customer Password
Creating Custom Templates

Magento includes a default email template for the body section of each message that is sent by the system. Each template with the body content is combined with the header and footer templates to create the complete message. The content is formatted with HTML and CSS, and can be easily edited, and customized by adding variables and widgets.

The default templates already include your logo and store information and can be used as they are, without further customization. As a best practice, you should view each default email template and verify any changes you make before sending them to customers.

When a custom template is ready to be used, make sure to update your system configuration, so the custom template will be used instead of the default template. Email templates can be customized for each website, store, or store view. For detailed instructions, see the following topics:

- Header Template
- Footer Template
- Content Templates
Email Header

The default header includes your email logo that is linked to your store. You can easily insert variables to add store contact information to the header. To make more extensive changes requires a working knowledge of both HTML and CSS. On the server, the header template is located at:

```
```

Process Overview:
Step 1: Load the Template
Step 2: Customize the Template
Step 3: Update the Configuration

Step 1: Load the Template

1. On the Admin menu, select System > Transactional Emails.
2. Click the Add New Template button. Then, do the following:
   a. Set Template to “Email - Header.”
   b. Set Locale to the language of the email recipients.
3. Click the Load Template button.
Step 2: Customize the Template

When working in the template code, be careful not to overwrite anything that is enclosed in double braces.

1. In the **Template Name** field, enter a name for your custom header.

2. In the **Template Content** box, modify the HTML as needed.

3. To insert a variable, position the cursor in the code where you want the variable to appear, and click the **Insert Variable** button. Then, do the following:
   
a. In the list of Store Contact Information variables, click the variable that you want to insert. You are not limited to the variables in this list, although they are the ones most often included in the header. You can actually type the code for any system variable directly into the template.

   b. Click the **Preview Template** button. Then, make any adjustments to the template that are needed.
4. When complete, click the Save Template button. Your custom header now appears in the list of Transactional Email templates.
4. When complete, click the **Save Config** button.

### Field Descriptions

<table>
<thead>
<tr>
<th>FIELD</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>LOAD DEFAULT TEMPLATE</td>
<td></td>
</tr>
<tr>
<td>Template</td>
<td>Lists the selection of available templates, and identifies the template to</td>
</tr>
<tr>
<td></td>
<td>be customized.</td>
</tr>
<tr>
<td>Locale</td>
<td>Identifies the locale where the template is to be used.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>TEMPLATE INFORMATION</td>
<td></td>
</tr>
<tr>
<td>Template Name</td>
<td>The name of your custom template.</td>
</tr>
<tr>
<td>Template Subject</td>
<td>(N/A) This field isn’t used for header templates.</td>
</tr>
<tr>
<td>Template Content</td>
<td>The content of the template, in HTML.</td>
</tr>
<tr>
<td>Template Styles</td>
<td>(N/A) This field is not used for header templates.</td>
</tr>
</tbody>
</table>
## Store Contact Information Variables

<table>
<thead>
<tr>
<th>VARIABLE</th>
<th>MARKUP TAG</th>
</tr>
</thead>
<tbody>
<tr>
<td>Base Unsecure URL</td>
<td><code>{{config path=&quot;web/unsecure/base_url&quot;}}</code></td>
</tr>
<tr>
<td>Base Secure URL</td>
<td><code>{{config path=&quot;web/secure/base_url&quot;}}</code></td>
</tr>
<tr>
<td>General Contact Name</td>
<td><code>{{config path=&quot;trans_email/ident_general/name&quot;}}</code></td>
</tr>
<tr>
<td>General Contact Email</td>
<td><code>{{config path=&quot;trans_email/ident_general/email&quot;}}</code></td>
</tr>
<tr>
<td>Sales Representative Contact Name</td>
<td><code>{{config path=&quot;trans_email/ident_sales/name&quot;}}</code></td>
</tr>
<tr>
<td>Sales Representative Contact Email</td>
<td><code>{{config path=&quot;trans_email/ident_sales/email&quot;}}</code></td>
</tr>
<tr>
<td>Custom1 Contact Name</td>
<td><code>{{config path=&quot;trans_email/ident_custom1/name&quot;}}</code></td>
</tr>
<tr>
<td>Custom1 Contact Email</td>
<td><code>{{config path=&quot;trans_email/ident_custom1/email&quot;}}</code></td>
</tr>
<tr>
<td>Custom2 Contact Name</td>
<td><code>{{config path=&quot;trans_email/ident_custom2/name&quot;}}</code></td>
</tr>
<tr>
<td>Custom2 Contact Email</td>
<td><code>{{config path=&quot;trans_email/ident_custom2/email&quot;}}</code></td>
</tr>
<tr>
<td>Store Name</td>
<td><code>{{config path=&quot;general/store_information/name&quot;}}</code></td>
</tr>
<tr>
<td>Store Contact Telephone</td>
<td><code>{{config path=&quot;general/store_information/phone&quot;}}</code></td>
</tr>
<tr>
<td>Store Contact Address</td>
<td><code>{{config path=&quot;general/store_information/address&quot;}}</code></td>
</tr>
</tbody>
</table>
Email Footer

The footer contains the closing and signature line of the email message. You can change the closing to fit your style, and add additional information, such as the company name and address below your name. To make more extensive changes requires a working knowledge of both HTML and CSS. On the server, you will find the footer template in the following location:


Process Overview:
Step 1: Load the Template
Step 2: Customize the Template
Step 3: Update the Configuration

Step 1: Load the Template

1. On the Admin menu, select System > Transactional Emails.
2. Click the Add New Template button. Then, do the following:
   a. Set Template to “Email - Footer.”
   b. Set Locale to the language of the email recipients.
3. Click the Load Template button.

Choosing the Email - Footer Template
Step 2: Customize the Template

When working in the template code, be careful not to overwrite anything that is enclosed in double braces.

1. In the **Template Name** field, enter a name for your custom footer.

2. In the **Template Content** box, modify the HTML as needed.

3. To insert a variable, position the cursor in the code where you want the variable to appear, and click the **Insert Variable** button. Then, do the following:

   a. In the list of Store Contact Information variables, click the variable that you want to insert.

   b. When you’re done, click the **Preview Template** button to verify the code. Then, make any adjustments to the template that are needed.

4. When the template is finalized, click the **Save Template** button.

   Your custom footer now appears in the list of Transactional Email templates.
Step 3: Update the Configuration

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left under General, select **Design**.

2. If necessary, set the **Current Configuration Scope** to the website, store, or store view where the header will be used.

3. Click to expand the **Transactional Emails** section, and do the following:

   a. If the header is for a specific view, clear the **Use Website** checkbox that is next to the Email Footer Template field.

   b. Set **Email Footer Template** to the name of the custom header that you just created.

4. When complete, click the **Save Config** button.
Email Body

The process of customizing the main body of each message is the same as the customizing the header or footer. The only difference is that there are many templates, listed in alphabetical order. You can use the templates as they are, or customize the most important messages first, such as messages related to customer accounts, and customer activities. For a complete list, see the Email Template Reference at the end of this section.

**Process Overview:**
- **Step 1: Choose a Default Template**
- **Step 2: Customize the Content**
- **Step 3: Update the Configuration**

**Step 1: Choose a Default Template**

1. On the Admin menu, select **System > Transactional Emails**.
2. Click the **Add New Template** button.
3. In the **Template** list, select a default template from the list of predefined templates.

![Load Default Template](image)

4. If necessary, set the **Locale** to the store language.
5. Click the **Load Template** button.

The path to the configuration settings for each default template appears at the top of the Template Information section. You can click this link later when you are ready to update the configuration with the name of the new template.
Step 2: Customize the Content

1. In the Template Information section, do the following:
   a. Enter a Template Name for the new email template.
   b. In the Template Subject field, type the text that you want to appear in the Subject line of the message.
   c. For a better view of the content and variables in the message, click the Convert to Plain Text button. When prompted to confirm, click OK.
   d. To restore the HTML, click the Return HTML Version button.
   e. Edit the Template Content as needed.

2. (Optional) To insert a variable, do the following:
   a. Position the cursor in the text where you want the variable to appear.
   b. Click the Insert Variable button.
      The list includes the standard Store Contact Information variables, and an additional list of variables that are specific to the template.
   c. In the list of available variables, click the variable you want to insert into the template.
When a variable is selected, the markup tag that is associated with the variable is inserted at the cursor position in the code.

3. When complete, click the Save Template button.

4. Make sure to Preview the template code, and verify that the template is customer-ready.
Step 3: Update the Configuration

Before the template can be used, the configuration must be updated with the name of the new template. Do one of the following:

- Click the link at the top of the Template Information section to jump to the configuration settings for the template.
- On the Admin menu, select **System > Configuration**. Then in the panel on the left, under Sales, select **Sales Emails**.

5. Update the email template information as needed.

6. When complete, click the **Save Config** button.
Update the System Configuration

After creating a customized version of a template, remember to update your system configuration so the correct template is used for each message. You can access the template configuration from the System Configuration menu, or by clicking the link at the top of the template when open in edit mode.

Method 1: Link to Configuration

This method is convenient to use when you finish customizing a template. With the template open in edit mode, simply click the link at the top of the Template Information section to jump to the configuration settings for the template.

Method 2: Navigate to the Configuration

Use this method if you have many customized templates that need to be added to the configuration.
Sales Email Templates

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Sales, select Sales Emails. Then, select the appropriate templates for each of the following sections:
   - Order and Order Comments
   - Invoice and Invoice Comments
   - Shipment and Shipment Comments
   - Credit Memo and Credit Memo Comments

3. When complete, click the Save Config button.

Customer Email Templates

1. On the Admin menu, select System > Configuration.

2. In the panel on the left, under Customer, select Customer Configuration. Then, select the appropriate templates for each of the following sections:
   - Create New Account Options
   - Password Options

3. When complete, click the Save Config button.
Email Template Configuration

The configuration for transactional email templates is designed to support multiple devices. The email logo that is uploaded is designed to render well on high-resolution displays. The configuration specifies the header and footer templates that are used for all transactional email messages sent within the scope of the configuration. To support the requirements of many email clients, a variable has been added that is used to convert external CSS styles to inline styles. The name of the external CSS file that it references is specified in the configuration.

Process Overview:

1. **Step 1: Upload Your Logo**
   - On the Admin menu, select **System > Configuration**.
   - In the panel on the left, under General, select **Design**.
   - If needed, set **Current Configuration Scope** in the upper-left corner to the website, store, or store view where the configuration applies.

2. **Step 2: Select the Header and Footer Templates**
   - Click to expand the **Transactional Emails** section. Then, do the following:
     - **a.** To upload your prepared **Logo Image**, click the **Browse** button. Find the file on your computer, and click to copy the path to the field.
     - **b.** In the **Logo Image Alt** field, enter the alternate text to identify the image.
If you uploaded a logo image, enter the **Logo Width** and **Logo Height** in pixels. Enter each value as a number, without the “px” abbreviation. These values refer to the display dimensions of the logo in the header, and not to the actual size of the image.

**Step 2: Select the Header and Footer Templates**

If you have custom header and footer templates for your store, or for different stores, you can specify which templates should be used for each, according to the scope of the configuration.

1. Select the **Email Header Template** to be used for all transactional email messages.
2. Select the Email Footer Template to be used for all transactional email messages.

**Step 3: Choose the CSS File(s)**

1. In the **Non-inline CSS File(s)** field, enter the name of each CSS file that is needed to format the content of your transactional email messages. Separate the names of multiple files with a comma. On the server, the CSS files reside in the following location:

   ```
   [magento install dir]/skin/frontend/[package]/[theme]/css/
   ```

2. When complete, click the **Save Config** button.
# Email Template Reference

## Customer Account
- New Account
- New Account Confirmation Key
- New Account Confirmed
- Forgot Password
- Remind Password

## Customer Activity
- Contact Form
- Send Product to a Friend
- Share Wishlist

## Newsletters
- Newsletter Subscription Confirmation
- Newsletter Subscription Success
- Newsletter Unsubscription Success

## Admin Activity
- Forgot Admin Password
- Currency Update Warnings
- Email - Footer
- Email - Header

## System Notifications
- Log Cleanup Warnings
- Token Status Change
- Sitemap Generate Warnings

## Product Alerts
- Product Alerts Cron Error
- Product Price Alert
- Product Stock Alert

## Sales
- New Order
- New Order for Guest
- Order Update
- Order Update for Guest
- Payment Failed
- New Invoice
- New Invoice for Guest
- Invoice Update
- Invoice Update for Guest
- New Shipment
- New Shipment for Guest
- Shipment Update
- Shipment Update for Guest
- New Credit Memo
- New Credit Memo for Guest
- Credit Memo Update
- Credit Memo Update for Guest
- Moneybookers Activate Email
CHAPTER 61:

Managing Data Transfer

The Import/Export tool gives you the ability to manage multiple customer and product records in a single operation. If you have a large catalog of products, you will find it much easier to export the data, edit the data in a spreadsheet, and then import the data back into your store.

The **CSV**\(^1\) file format separates each data element by a comma, and is used as the standard for data exchange operations. All spreadsheet and database applications support the CSV file format. If you are working with a Mac, you should save the data in the CSV (Windows) format.

Topics include:

- Working with CSV Files
- Import
- Importing Product Images
- Import Guidelines
- Export
- Dataflow

---

\(^1\)Comma Separated Values: A type of file used to store data values which are separated from each other by commas.
Working with CSV Files

CSV files have a specific structure that must match the database. Each column heading must exactly match the Attribute Code of the attribute that is represented by the column. To ensure that the column headings can be read by Magento, first export the data from your store as a CSV file. You can then edit the data and re-import it into Magento.

**Important!** We recommend that you use a program that supports UTF-8 encoding to edit CSV files, such as Notepad++ or OpenOffice Calc. Microsoft Excel inserts additional characters into the column header of the CSV file, which can prevent the data from being imported back into Magento.

Product CSV Structure

The catalog products CSV file contains information about products and the relationships between them. The table has the following structure:

The first row of the table contains the names of the columns, there are two types of the names, as shown in the following table. Other rows contain attributes values, service data, and complex data. If a row contains the value in the SKU column, then this row the rows below it describe the product. Each new SKU value begins the description of the next product.

Each category is entered as a path, with a forward slash (/) between each level. For example: Furniture/Living Room. Do not include the Root Category in the path.

During import, if a row that contains the SKU value is found to be invalid, then the row, and all other rows with data for that product cannot be imported.

The minimal table that can be imported contains only the SKU column, which can be used to delete records from the database. There is no limit to the number of the columns he table can have. Columns without data are ignored during the import process.
CSV Product Structure

<table>
<thead>
<tr>
<th>COLUMN NAME</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;name&gt;</td>
<td>The names of the service columns and complex data columns. Service columns contain entity properties, which are not attributes. For example, columns with website or product type information are service columns. The underscore as first character is used to distinguish these columns from the attribute column names.</td>
</tr>
<tr>
<td>&lt;attribute name&gt;</td>
<td>The names of the columns with values of both system-created attributes and attributes created by the store administrator.</td>
</tr>
</tbody>
</table>

Customer CSV Structure

The customers CSV file contains customer information from the database, and has the following structure:

The first row of the table contains the names of the attribute columns (which are the same as attribute codes). There are two types of column names, as shown in the following table. Other rows contain attribute values, service data, and complex data. Each row with non-empty values in the "email" and "_website" columns starts the description of the subsequent customer. Each row can represent customer data with or without address data, or the address data only. In case a row contains only the address data, values in the columns, related to the customer profile, will be ignored and may be empty.
To add or replace more than one address for a customer, in the import file add a row for each new address with empty customer data and the new or updated address data below the customer data row.

---

**Exported Customer CSV in Notepad++**

**CSV Customer Structure**

<table>
<thead>
<tr>
<th>COLUMN NAME</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>&lt;name&gt;</em></td>
<td>The names of the service columns, and complex data columns. Service columns contain entity properties, which are not attributes. For example, columns with website or store information are service columns. The underscore as first character is used to distinguish these columns from the other attributes names. The &quot;_address_default_billing&quot; and the &quot;_address_default_shipping&quot; columns are the default billing and shipping addresses flags. If the address in the row is the default billing and/or shipping address of the client, the &quot;_address_default_billing&quot; and/or &quot;_address_default_shipping&quot; columns in this row will have the &quot;1&quot; value.</td>
</tr>
<tr>
<td>&lt;attribute name&gt;</td>
<td>The names of the columns with values of both system-created attributes, and attributes created by the store administrator.</td>
</tr>
</tbody>
</table>
Importing Data

Data for all product types can be imported into the store, with the exception of bundle and downloadable products. In addition, you can import customer data, and product images. During the validation process, all items are verified, including:

- **Attribute Values**
  Attribute values according to data type (decimal, integer, varchar, text, datetime).

- **Complex Data**
  Complex data, service data and attributes with values that originate from a defined set (such as a drop-down or multiple select input type), are checked to ensure the values exist in the defined sets.

- **New Entities**
  For new entities, the presence of required attribute values in the file is checked. For existing entities, the presence of required attributes values is not checked, but if a required value is specified, it is validated according to the attribute type.

To import customer or product data:

1. On the Admin menu, select **System > Import/Export > Import**. Then, do the following:

   ![Import Settings](image)

   **Import Settings**

   a. Set **Entity Type** to one of the following:
      - Products
      - Customers

   b. Set **Import Behavior** to the way you want complex data to be managed if imported records already exist in the database.
      - Complex data for products includes categories, websites, custom options, tier prices, related products, up-sells, cross-sells, and associated products data.
      - Complex data for customers includes addresses.
c. Choose one of the following options:

- **Append Complex Data**: The new complex data will be added to the existing complex data for the existing entries in the database.
- **Replace Existing Complex Data**: The existing complex data for the existing entities will be replaced.
- **Delete Entities**: If entities that are imported already exist in the database, they will be deleted from the database.

d. At the **Select File to Import** field, click the **Choose File** button. Then, select the CSV file that you have prepared for import.

2. Click the **Check Data** button in the upper-right corner of the page. The system validates the file. If the file is valid, the corresponding message and the **Import** button appear. If some of the rows in the imported file are not valid and cannot be imported, the corresponding information is included to the message, but you can proceed with importing. The invalid rows will be skipped.

3. If needed, make corrections to the CSV file.

4. Click the **Import button** to import the data into the database.

## Importing Product Images

Multiple product images of each type can be imported into Magento, and associated with a specific product. The path and file name of each product image is entered in the CSV file, and the image files to be imported are uploaded to the corresponding path on the Magento server or external server, or uploaded to Media Storage.

Magento creates its own directory structure for product images that is organized alphabetically. When you export product data to a CSV file, you can see the alphabetized path before the file name of each image. However, when you import images, you typically don’t need to specify a path, because Magento manages the directory structure automatically. All you need to do is enter a forward slash before the file name of each image to be imported, and let Magento take care of the rest.

Review the steps in the import method that you want to use, and run through the process with a few products. After you understand how it works, you’ll feel confident importing large quantities of images.

### Important!
We recommend that you use a program that supports UTF-8 encoding to edit CSV files, such as Notepad++ or OpenOffice Calc. Microsoft Excel inserts additional characters into the column header of the CSV file, which can prevent the data from being imported back into Magento.

## Method 1: Import Images to Default Path

The easiest way to import product images is to use Dataflow, and let Magento manage the
directory structure. For complete instructions, see Dataflow.

**Method 2: Import Images to Specific Path**

1. To import image files into a specific path, you must first create the required directory structure in the media/import folder. The import folder is located on the server in the following location:

   
   ![Image Directory Structure](magento installation folder)/media/import

2. Create the directory structure as follows:
   a. Create the parent folder, named for the first character of the image file name.
   b. Create a subfolder, named for the second character of the image file name. For example, the import path for `filename.jpg` would be as follows:

   
   ![Import Path](magento installation folder)/media/import/f/i/filename.jpg

   c. Set the following permissions for all image folders and files:

      | Image Folders | 0777 |
      | Image Files   | 0666 (or greater) |

      On the server, change directories to the media/import folder, and enter the following from the command line:

      ```
      find . -type d -exec chmod 777 {} \;
      find . -type f -exec chmod 666 {} \;
      ```

3. In the CSV file, the image path and file name must be entered in the image, small_image, and media_image columns for the correct SKU, according to image type. If you want, you can use the same image for each type.
   a. In the appropriate column, enter the relative path to each image in the following format:

      
      `/f/i/filename.jpg`

      **Important!** Use only lowercase characters in the image path and filename of any image to be imported.

   b. Make sure that the correct SKU is entered on each row that has an image file.

4. Complete the standard process to import product data.
Import Guidelines

**New Entities**

- Entities are added with the attribute values specified in the CSV file.
- If there is no value, or there is a non-valid value, for a required attribute with no default value set, then the entity (the corresponding row or rows) cannot be imported.
- If there is no value, or there is a non-valid value, for a required attribute with the default value set, then the entity (the corresponding row or rows) is imported, and the default value is set for the attribute.
- If the complex data is not valid, then the entity (the corresponding row or rows) cannot be imported.

**Existing Entities**

- For attributes that are not complex data, the values from the import file, including the empty values for the non-required attributes, replace the existing values.
- If there is no value, or there is a non-valid value, for a required attribute, then the existing value is not replaced.
- If the complex data for the entity is invalid, the entity (the corresponding row or rows) cannot be imported, except the case, when Delete Entities was selected in the Import Behavior drop-down menu.
Complex Data

If an attribute that is specified in the import file already exists, and its value is derived from a defined set of values, the following applies:

☑️ If the value is not already included in the defined set of values, the row can be imported and a default value, if defined, is set for the attribute.

☑️ If the value is already included in the defined set, the corresponding row cannot be imported.

If an attribute name is specified in the import file but is not yet defined in the system, it is not created, and its values are not imported.

Invalid Files

☑️ A file cannot be imported if all rows are invalid.

☑️ A non-existing service data or complex data name is specified in the import file, such as a column with a "_<non-existing name>" heading.
Exporting Data

The best way to become familiar with the structure of your database is to export the data and open it in a spreadsheet. Once you become familiar with the process, you’ll find that it is an efficient way to manage large amounts of information.

To export customer or product data:

1. On the Admin menu, select System > Import/Export > Export.
2. In the Export Settings section, do the following:

   a. Set Entity Type to one of the following:
      - Products
      - Customers Main File
      - Customer Addresses

   b. Accept the default Export File Format of “CSV.”

3. In the Entity Attributes section, you can include or exclude data to be exported according to the entity attribute values.

   a. To include records with specific attribute values, set the required values of the attributes in the Filter column.
   b. To omit an attribute from the export, select the Skip checkbox at the beginning of the row.
Export Customers Based on Attribute Value

4. Scroll down and click the **Continue** button in the lower-right corner of the page. Look for the download prompt in the lower-right corner of your browser.

The CSV file that is generated can be edited and imported back into your store. Or, it can be used for mailing or other application.
Dataflow

Magento Dataflow is a data exchange framework that can be used by both merchants and developers. The basic Dataflow tool includes preconfigured profiles that make it easy to import and export product and customer data. The profiles can be used as they are, or be modified to meet your needs. You can create additional profiles for operations that are performed on a regular basis. For more sophisticated applications, Advanced Profiles can be defined in XML to perform custom data exchange operations.

The following instructions show how to use Dataflow profiles to export all product data, and import new product images.

**Dataflow Profiles**

Process Overview:
- Step 1: Export All Products
- Step 2: Copy the Product Images to the Server
- Step 3: Edit the CSV File
- Step 4: Import the Products
- Step 5: Update the Index

**Step 1: Export All Products**

1. Before you begin, make sure that all changes to the product data have been saved.
2. On the Admin menu, select **System > Import/Export > Dataflow - Profiles**.
3. In the list of profiles, select **Export All Products**.
4. In the panel on the left, click **Run Profile**.
5. To begin the process, click the **Run Profile in Popup** button.

6. Wait a few moments for the profile to begin execution. The length of time it takes to complete the process depends on the size of the database. Do not close the window.

7. When the process is complete, you can find the exported CSV file in the following location on the server:

   ```
   [magento-install-dir]
   /var/export/export_all_products.csv
   ```

   Here’s how the exported data file looks from the command line of the server:
8. Use an SFTP utility to download the `export_all_products.csv` file from the server to your desktop.

9. Then, open the file in any editor that supports UTF-8 encoding, such as Notepad++ or OpenOffice Calc. To open the CSV file in OpenOffice Calc, specify a comma as the separator, and double quotes as the text delimiter.

The CSV data appears in the spreadsheet as rows of product records organized into columns of attributes, with the Attribute Code in the header of each column.
Step 2: Copy the Product Images to the Server

The CSV file contains a path to each product image, but the actual image files must be uploaded to the server. To make the images available to import, place them in the media/import directory.

```
[Magento-install-dir]
/mmedia/import
```

Use your SFTP utility to copy the product images that you want to import to the media/import folder.

Step 3: Edit the CSV File

1. Edit the data as needed.
2. Save your changes to the CSV file.
For this example, we will add three new images to SKU #hdb005. Because this is the only product record that we’re going to update, the others can be deleted from the CSV file.

Currently, this product has only one image that is used for the base image, small image, and thumbnail. Because we’re going to now offer this product in three colors, we need to upload an image for each color, and replace the image that’s currently assigned to the product. Because this is a simple product, we can later use Custom Options to add an option for each color.

Magento creates a directory structure of product image files that is organized alphabetically. You can see that path before each image file name in the CSV data. However, when you import images, you must never include that path before the file name. The only thing you have to do is to enter a forward slash before the file name of each image that you want to import. Magento takes care of the rest. For this example, we need to add the three image files that were uploaded to the media/import folder.

```
/hdb005_HOTP_600.jpg
/hdb005_MARM
/hdb005_SALM_600.jpg
```

In the data, we will replace the original image file name, and add the other two image file references on separate blank lines. just below the original row. You must also enter the SKU on each additional line, to associate the images with the product.

\[\text{Update the CSV File with the Import Data}\]

**Step 4: Import the Products**

1. On the Admin menu, select **System > Import/Export > Dataflow - Profiles**.
2. In the list of profiles, select **Import All Products**.

   This general-purpose profile that can be used to import or update any number or product records.
3. In the panel on the left, select **Upload File**.

4. Because we’re uploading only one file, click the **Browse** button for File 1. Then, find the file on your computer and click to select it. The path to the file appears in the input box.

5. Click the **Save and Continue Edit** button.
6. In the panel on the left, select **Run Profile**.

7. Select the CSV file that you edited. If there are several files in the list, make sure to select the right one. Then, click the **Run Profile in Popup** button.

8. Wait a few moments for the profile to begin the import process. Do not close the window or interrupt the process. Look for the “Finished Profile Execution” message at the bottom of the list when the import process is complete. If you receive an error message, correct the problem in the CSV file, and try again.

**Step 5: Update the Index**

Usually the index needs to be updated after changes are made to product data. If you receive a message that the indexes are out of date, click the link and update the index.
CHAPTER 62:

Admin Permissions

Magento uses roles and permissions to create different levels of access to the Admin. When your store is first set up, you receive a set of login credentials for the Administrator role, with full permissions. However, you can restrict the level of permissions on a “need to know” basis for other people who work on your site. For example, a designer can be given access to only the Design tools, but not to areas with customer and order information. Topics in this chapter include:

- Creating New Users
- Creating Custom Roles
- Content Permissions
Creating New Users

When your store is first installed, your login credentials have full administrative access. As a best practice, one of the first things you should do is to create another user account with full Administrator permissions. That way, you can use one account for your everyday Administrative activities, and reserve the other as a “Super Admin” account in case you forget your regular credentials or they somehow become otherwise unusable.

If there are others on your team, or service providers who need access, you can create a separate user account for each, and assign a restricted role. They cannot change any global settings or data.

### Process Overview:
- **Step 1: Create a New User**
- **Step 2: Assign the Role**

### Step 1: Create a New User

1. On the Admin menu, select **System > Permissions > Users**.
2. Click the **Add New User** button.
3. In the Account Information section, do the following:

![Account Information](image)
a. Enter the **User Name** for account.

   The User Name should be easy to remember. It is not case-sensitive. For example, if your user name is “John,” you can also log in as “john.”

b. Complete the following information:
   
   - First Name
   - Last Name
   - Email address

   This email address must be different from the one that is associated with your original Admin account.

c. Assign a **Password** to the account.

   The password should be seven or more characters long, and include both letters and numbers.

d. In the **Password Confirmation** box, repeat the password to make sure it was entered correctly.

4. Set **This Account is** to “Active.”

**Step 2: Assign the Role**

1. In the User Information panel on the left, click **User Role**. Then, in the list of Roles, select **Administrators**. (Initially, it will be the only role available.)

2. When complete, click the **Save User** button.

   You now have two accounts with Administrator access.
Creating Custom Roles

To give someone restricted access, the first step is to create a role with the appropriate level of permissions. After the role is created, you will add the new user, set up the login credentials, and assign the role to the user account. After the role is established, you can create new Administrator users at any time, and assign the restricted role to grant limited access to the user.

For example, Admin permissions can be set to restrict access to tax resources, based on the business “need to know.” To create an Admin role with access to tax settings, select both the Sales/Tax and System/Tax resources. If setting up a website for a region that differs from your default shipping point of origin, you must also allow access to the System/Shipping resources for the role, because the shipping settings determine the store tax rate used for catalog prices.

---

**Creating Custom Roles**

To give someone restricted access, the first step is to create a role with the appropriate level of permissions. After the role is created, you will add the new user, set up the login credentials, and assign the role to the user account. After the role is established, you can create new Administrator users at any time, and assign the restricted role to grant limited access to the user.

For example, Admin permissions can be set to restrict access to tax resources, based on the business “need to know.” To create an Admin role with access to tax settings, select both the Sales/Tax and System/Tax resources. If setting up a website for a region that differs from your default shipping point of origin, you must also allow access to the System/Shipping resources for the role, because the shipping settings determine the store tax rate used for catalog prices.

---

**Process Overview:**

- **Step 1: Define the Role**
  - On the Admin menu, select System > Permissions > Roles. Then in the upper-left corner, click the Add New Role button.
  - In the Role Information section, enter a descriptive Role Name.

---
3. In the panel on the left, select **Role Resources**.

4. In the Roles Resources section, select the checkbox of each Admin **Resource** that you want to grant those with the role permission to access.

   **Important!** Be sure to disable access to the Permissions tool if you are limiting access for a given role. Otherwise, users with this role will be able to modify their own restrictions.

5. (Optional) In the panel on the left, select **Role Users**. Then, assign additional Administrator user accounts to the new role.

6. When complete, click the **Save Role** button. The role now appears in the list of available roles.

**Step 2: Add the New User**

1. On the Admin menu, select **System > Permissions > Users**.

2. Click the **Add New User** button.

3. In the Account Information section, do the following:
a. Assign a **User Name** to the account.

The User Name should be easy to remember. It is not case-sensitive. For example, if your user name is “john,” you can also log in as “John.”

b. Complete the following information:

- First Name
- Last Name
- Email address

c. Assign a **Password** to the account.

The password should be at least seven characters long, and include letters and numbers.

d. In the **Password Confirmation** field, type the password again to make sure it was entered correctly.

e. Set **This Account is** to “Active.”

4. In the User Information panel on the left, click **User Role**. Then, in the list of Roles, select the option for the role you want to assign to the new user.

5. When complete, click the **Save User** button.

**REST Roles**

The REST API defines a set of functions that developers can use to perform requests and receive responses. To learn more about REST permissions, see: [Web Services](#).
Content Permissions

As a security measure, Magento includes a whitelist of content that can be referenced by custom modules and extensions. Some implementations such as blog extensions, reference content that can be accessed only if the directive is in the whitelist. For example, a module or extension might include the following markup tags on CMS pages or in email templates.

Commonly Used Directives

```text
{{config path="web/unsecure/base_url"}}
{{block type=rss/order_new}}
```

You can add the most commonly used variable and block references to the whitelist from the Admin. If not included in the list of allowed directives, it must be added to the database installation script on the server. Some configuration variables or blocks can be added to the whitelist only by running a data update script that lists each additional directive.

Variable and Block Names in Script

```text
permission_variable
permission_block
```

Allowed Variables
To add a variable to the whitelist:

1. On the Admin menu, select System > Permissions. Then, choose Variables.
2. Click the Add New Variable button.
3. Enter the Variable Name.
4. Set Is Allowed to “Yes.”
5. When complete, click Save Variable.

To add a block to the whitelist:

1. On the Admin menu, select System > Permissions. Then, choose Blocks.
2. Click the Add New Block button.
3. Enter the Block Name.
4. Set Is Allowed to “Yes.”
5. When complete, click Save Block
Allowed Directives

CONTENT REFERENCES

VARIABLES

web/unsecure/base_url

web/secure/base_url

trans_email/ident_support/name

trans_email/ident_support/email

trans_email/ident_general/name

trans_email/ident_sales/name

trans_email/ident_sales/email

trans_email/ident_custom1/name

trans_email/ident_custom1/email

trans_email/ident_custom2/name

trans_email/ident_custom2/email

general/store_information/name

general/store_information/phone

general/store_information/address

BLOCKS

core/template

catalog/product_new
CHAPTER 63: Security

In this section of the guide, you will learn how to manage Admin sessions and credentials, implement CAPTCHA, and manage website restrictions.

Magento Security Best Practices

All eCommerce sites are attractive targets to hackers because of the personal and payment information that is required to complete a sale. Even if the system does not directly process credit card transactions, a compromised site might reroute customers to a false page, or alter an order before it is transmitted to the payment processor.

A compromised site can have long-term consequences for both customers and merchants. Customers might suffer financial loss and identify theft, while merchants can face damage to their reputations, loss of merchandise, higher processing fees, revoked privileges with financial institutions, and the threat of lawsuits.

This guide outlines a multifaceted approach to improve the security of your Magento installation. Although there is no single way to eliminate all security risks, there are many things that you can do to make your site a less attractive target. It is crucial for hosting providers, system integrators, and merchants to work together to establish and maintain a secure environment, implement methods for early detection, and determine a plan of action in the event of a breach. To learn more, see Best Practices in the Magento Security Center.

Make sure to stop by our Magento Security Center, and sign up for the Security Alert Registry to receive notification from our security team of any emerging issues and solutions.
Start Right

Work with reliable hosting providers and solution integrators. When evaluating their qualifications, ask about their approach to security. Verify that they have a secure software development life cycle in accord with industry standards such as The Open Web Application Security Project (OWASP), and that they test their code for security issues.

If you are starting a new site, consider launching the entire site over HTTPs. Taking the lead on this issue, Google now uses HTTPs as a ranking factor.

For an existing installation, plan to upgrade the entire site to run over a securely encrypted, HTTPs channel. Although you will need to create redirects from HTTP to HTTPs, the effort will future-proof your site. We recommend that you plan to make this change sooner, rather than later.

Protect the Environment

Protecting the environment is the most critical aspect of ensuring the security of your store. Keep all software on the server up to date, and apply security patches as recommended. This applies not only to Magento, but to any other software that is installed on the server, including database software and other websites that use the same server. Any system is only as secure as the weakest link.

Server Environment

☑ Make sure that the server operating system is secure. Work with your hosting provider to ensure that there is no unnecessary software running on the server.

☑ Use only secure communications protocol (SSH/SFTP/HTTPS) to manage files, and disable FTP.

☑ Magento includes .htaccess files to protect system files when using the Apache web server. If you use a different web server such as Nginx, make sure that all system files and directories are protected. For an sample Nginx configuration, see: magento-nginx.conf on GitHub.

For .htaccess protection to work correctly, your web server must read .htaccess through the AllowOverride All directive in its configuration. To verify, try the following request:

http://www.yoursite.com/app/etc/local.xml

If you get the contents of the local.xml file, you must change the web server settings.

☑ Use only the minimum required permissions for a given task. As an example, do not use the root or administrator account to send mail from Magento. Use only limited privileges for database account.

☑ Use strong, long, and unique passwords, and change them periodically.
Server Environment (cont.)

- Keep the system up to date, and immediately install patches when new security issues are discovered.
- Closely monitor any issues that are reported for software components used by your Magento installation, including the operating system, MySQL database, PHP, Redis (if used), Apache or Nginx, Memcached, Solr, and any other components in your specific configuration.
- Limit access to `cron.php` file to only required users. For example, restrict access by IP address. If possible, block access completely and execute the command using the system cron scheduler.

Advanced Techniques

- Automate the deployment process, if possible, and use private keys for data transfer.
- Limit access to the Magento Admin by updating the whitelist with the IP address of each computer that is authorized to use the Admin and Magento Connect downloader. For examples of how to whitelist IP addresses, see: Secure Your Magento Admin.
- Do not install extensions directly on a production server.
  To disable the Magento Connect downloader on the production site, either remove or block access to the `/downloader` directory. You can also use the same whitelisting methods.
- Use two-factor authorization for Admin logins. There are several extensions available that provide additional security by requiring an additional passcode that is generated on your phone, or a token from a special device.
- Review your server for “development leftovers.” Make sure there are no accessible log files, publicly visible .git directories, tunnels to execute SQL helper scripts, database dumps, `phpinfo` files, or any other unprotected files that are not required, and that might be used in an attack.
- Limit outgoing connections to only those that are required, such as for a payment integration.
- Use a Web Application Firewall to analyze traffic and discover suspicious patterns, such as credit card information being sent to an attacker.
Server Applications

☑ Make sure that all applications running on the server are secure.

☑ Avoid running other software on the same server as Magento, especially if it is accessible from the Internet. Vulnerabilities in blog applications such as Wordpress can expose private information from Magento. Install such software on a separate server or virtual machine.

☑ Keep all software up to date, and apply patches as recommended.

Admin Desktop Environment

☑ Make sure that the computer that is used to access the Magento Admin is secure.

☑ Keep your antivirus software up to date, and use a malware scanner. Do not install any unknown programs, or click suspicious links.

☑ Use a strong password to log in to the computer, and change it periodically. Use a password manager such as LastPass, 1Password, or Dashlane to create and manage secure, unique passwords.

☑ Do not save FTP passwords in FTP programs, because they are often harvested by malware and used to infect servers.

☑ Delete user accounts for employees or contractors who no longer work with you. A large number of intrusions can be attributed to insider knowledge.

Protect Magento

Your effort to protect your Magento installation starts with the initial setup, and continues with the security-related configuration settings, password management, and ongoing maintenance.
Your Magento Installation

- Use the latest version of Magento to ensure that your installation includes the most recent security enhancements.
  
  If for any reason you cannot upgrade to the latest version, make sure to install all security patches as recommended by Magento. Although Magento issues security patches to fix major issues, new product releases include additional improvements to help secure the site.

- Use a unique, custom Admin URL instead of the default “admin” or the often-used “backend.” Although it will not directly protect your site from a determined attacker, it can reduce exposure to scripts that try to break into every Magento site. (Never leave your valuables in plain sight.)

  Check with your hosting provider before implementing a custom Admin URL. Some hosting providers require a standard URL to meet firewall protection rules.

- Block access to any development, staging, or testing systems. Use IP whitelisting and .htaccess password protection. When compromised, such systems can produce a data leak or be used to attack the production system.

- Use the correct file permissions. Core Magento and directory files should be set to read only, including app/etc/local.xml files.

- Use a strong password for the Magento Admin. To learn more, see: Creating a strong password.

- Take advantage of Magento’s security-related configuration settings for Admin Security, Password Options, and CAPTCHA.

Don’t Be Taken for a Ride

- Install extensions only from trusted sources. Never use paid extensions that are published on torrent or other sites. If possible, review extensions for security issues before installing them.

- Do not click suspicious links, or open suspicious email.

- Do not disclose the password to your server or to the Magento Admin, unless you are required to do so.
Be Prepared!

- Develop a disaster recovery/business continuity plan. Even a basic plan will help you get back on track in the event of a problem.

- Ensure that your server and database are automatically backed up to external location. A typical setup requires daily incremental backups, with a full backup on a weekly basis. Make sure to test the backup regularly to verify that it can be restored.

- For a large site, simple text file dumps of the database take an unacceptable amount of time to restore. Work with your hosting provider to deploy a professional database backup solution.

Monitor for Signs of Attack

If your system is not immediately patched after a major security breach, there is a high probability that your site is already compromised. Complete a security review periodically to check for signs of attack, and also when contacted by customers with security-related concerns.

Security Review

- Check periodically for unauthorized Admin users.

- (Magento Enterprise only) Check the Admin Actions Log for suspicious activity.

- Use automated log review tools such as Apache Scalp.

- Work with your hosting provider to review server logs for suspicious activity, and to implement an Intrusion Detection System (IDS) on your network.

- Use a file and data integrity checking tool such as TripWire to receive notification of any potential malware installation.

- Monitor all system logins (FTP, SSH) for unexpected activity, uploads, or commands.
Follow Your Disaster Recovery Plan

In the event of a compromise, work with your internal IT security team if available, or hosting provider, and system integrator to determine the scope of the attack. Taking into consideration the type of compromise and the size of the store. Then, adjust the following recommendations to your business needs.

1. Block access to the site, so the attacker cannot remove evidence or steal more information.

2. Backup the current site, which will include evidence of the installed malware or compromised files.

3. Try to determine the scope of the attack. Was credit card information accessed? What information was stolen? How much time has elapsed since the compromise? Was the information encrypted? Typically you can expect the following types of attack:

   Defacing of Site  
   Site access is compromised, but often the payments information is not. User accounts might be compromised.

   Botnetting  
   Your site becomes part of a botnet that sends spam email. Although data is probably not compromised, your server is blacklisted by spam filters which prevents email that you send to customers from being delivered.

   Direct Attack on Server  
   Data is compromised, backdoors and malware are installed, and the site no longer works. Payment information—provided that it is not stored on the server—is probably safe.

   Silent Card Capture  
   In this most disastrous attack, intruders install hidden malware or card capture software, or possibly modify the checkout process to collect and send out credit card data. Such attacks can go unnoticed for extended periods of time, and result in major compromise of customer accounts and financial information.

4. Try to find the attack vector to determine how the site was compromised, and when. Review server log files and file changes. Note that sometimes there are multiple different attacks on the same system.

5. If possible, wipe and reinstall everything. In case of virtual hosting, create a new instance. Malware might be hidden in an unsuspected location, just waiting to restore itself. Remove all unnecessary files. Then, reinstall all required files from a known, clean source such as files from your own version control system, or the original distribution files from magento.com.

6. Apply all the latest security patches necessary.

7. Reset all credentials, including the database, file access, payment and shipping integrations, web services, and Admin login.

8. If payment information was compromised, it might be necessary to inform your payment processor.
9. Inform your customers about the attack and the type of information affected. If payment information was compromised, they should look for unauthorized transactions. If personal information, including email addresses was compromised, they might be targeted with phishing attacks or spam.

Acknowledgments

Parts of this article were inspired by real-world solutions that were shared by community members. The resulting article incorporates content from the community, with input from our team. We’d like to thank the following people for contributing to this article:

- Bryan (BJ) Hoffpauir for sharing his insight on the Magento forum, and for contributing recommendations in the Attack Response Plan section of this article. See the original post by beejhuff for more information.
- Anna Völkl (@rescueann), Magento developer at LimeSoda.
- Robert Mangiafico (@robfico) CTO at LexiConn.
- @dracony_gimp for his security presentation, Being Hacked is Not Fun.
- Willem de Groot for providing a sample Nginx configuration.
Security Configuration

The security settings give you the ability to control the lifetime of user sessions, and whether to allow your Magento store to run in a frame. (This setting can prevent clickjacking.) In addition you can add a secret key to URLs, and determine the case sensitivity of login credentials.

For security reasons Magento strongly recommends against running your store in a frame.

To configure Admin security:

1. On the Admin menu, select System > Configuration.
2. In the panel on the left, under Advanced, select Admin.
3. Click to expand the Security section, and complete the settings as needed.
4. When complete, click the Save Config button.
CAPTCHA

CAPTCHA is an acronym for “Completely Automated Public Turing Test to Tell Computers and Humans Apart.” A CAPTCHA is a visual device that ensures that a human being, rather than a computer, is interacting with the site. CAPTCHA can be used for both the Admin and customers.

Users can reload the CAPTCHA as many times as is necessary by clicking the Reload icon in the upper right corner of the image. The Magento CAPTCHA was implemented using a Zend Framework module, and is fully configurable.

CAPTCHA in Customer Login
Admin CAPTCHA

For an extra level of security, you can add a CAPTCHA to the Admin Login page. Administrator users can reload the displayed CAPTCHA by clicking the Reload icon in the upper-right corner of the image. The number of reloads is not limited.

To configure CAPTCHA for the Admin:

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left under Advanced, select **Admin**.
2. In the upper-right corner, set **Current Configuration Scope** to “Default.”
3. Click to expand the **CAPTCHA** section, and complete the settings as described below.
4. When complete, click the **Save Config** button.
Customer CAPTCHA

CAPTCHA can be required to log in to a customer account, or be configured to appear after several unsuccessful attempts. It can also be used for other forms in the storefront.

To configure CAPTCHA for customers:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Customers, select Customer Configuration.
2. Set Current Configuration Scope to the website where you want the configuration to apply.
3. Click to expand the CAPTCHA section, and complete the fields as described below.
4. When complete, click the Save Config button.
Session Validation

Magento Community allows you to validate session variables as a protective measure against possible session fixation attacks, or attempts to poison or hijack user sessions. The Session Validation Settings determine how session variables are validated during each store visit, and if the session ID is included in the URL of the store.

The validation checks to see that visitors are who they say they are by comparing the value in the validation variables against the session data that is already stored in $_SESSION data for the user. Validation fails if the information is not transmitted as expected, and the corresponding variable is empty. Depending on the session validation settings, if a session variable fails the validation process, the client session immediately terminates.

Enabling all of the validation variables can help prevent attacks, but might also impact the performance of the server. By default, all session variable validation is disabled. We recommend that you experiment with the settings to find the best combination for your Magento installation. Activating all of the validation variables might prove to be unduly restrictive, and prevent access to customers who have Internet connections that pass through a proxy server, or that originate from behind a firewall. To learn more about session variables and their use, see the system administration documentation for your Linux system.

To configure the Session Validation Settings:

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left under General, select **Web**.

2. Click to expand the **Session Validation Settings** section. Then, do the following:
a. To verify that the IP address of a request matches what is stored in the $_SESSION variable, set Validate REMOTE_ADDR to “Yes.”

b. To verify that the proxy address of an incoming request matches what is stored in the $_SESSION variable, set Validate HTTP_VIA to “Yes.”

c. To verify that the forwarded-for address of a request matches what is stored in the $_SESSION variable, set Validate HTTP_X_FORWARDED_FOR to “Yes.”

d. To verify that the browser or device that is used to access the store during a session matches what is stored in the $_SESSION variable, set Validate HTTP_USER_AGENT to “Yes.”

e. If you want a user to stay logged in while switching between stores, set Use SID on Frontend to “Yes.”

If including SID with analytics, you must configure your analytics software to filter the SID from URLs, so the page visit counts are correct.

3. When complete, click the Save Config button.
Browser Capabilities Detection

As is true of most websites and applications on the Internet, Magento requires that the visitor’s browser allow both cookies and JavaScript for full operations. However, occasionally a user’s browser might be set to the highest privacy setting which disallows both cookies and JavaScript. Your store can be configured to test the browser capabilities of each visitor, and to display a notice if the settings need to be changed.

- If the browser’s privacy settings disallow cookies, you can configure the system to automatically redirect them to the “CMS No Cookies Page,” which explains how to make the recommended settings with most browsers.
- If the browser’s privacy settings disallow JavaScript, you can configure the system to display the following message above the header of every page:

  ![JavaScript Disabled Notice]

To configure browser capabilities detection:

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left under General, select **Web**.

2. Click to expand the **Browser Capabilities Detection** section. Then, do the following:

   ![Browser Capabilities Detection]

   a. If you want to display instructions that explain how to configure the browser to allow cookies, set **Redirect to CMS-page if Cookies are Disabled** to “Yes.”

   b. If you want to display a banner above the header when JavaScript is disabled in the user’s browser, set **Show Notice if JavaScript is Disabled** to “Yes.”

3. When complete, click the **Save Config** button.
System Operations
System

This section of the guide focuses on aspects of the server environment that can be managed from the Admin. You will learn to perform routine index and cache management operations, and system administration tasks such as updating Magento, installing extensions, and backing up the server. You will learn some performance-improvement techniques, such as running the compiler, and setting up alternate media storage using an external database or content delivery network. Topics of interest only to developers include configuring API settings and activating Web Services.

System

Index Management
  Manual Indexing
  Automatic Indexing
Cache Storage
  Clearing Caches
  External Full-Page Cache
Alternate Media Storage
  Database Configuration
  CDN Configuration
Magento Connect
  Upgrading Magento
  Installing Extensions
Web Services
  Magento Core API Settings
  Activating Web Services
  REST Roles
System Tools
  Backups
    Creating a Backup
    Rolling Back Changes
  Patches
    Installing Patches with SSH
Compilation
System Log
  System Log Cleaning
Cron
Magento Test Framework
Database Repair
Configuration
CHAPTER 64: Index Management

Indexing is how Magento transforms data such as products, categories, and so on, to improve the performance of your web store. As data changes, the transformed data must be updated—or reindexed. Magento has very sophisticated architecture that stores merchant data (including catalog data, prices, users, stores, and so on) in many database tables. To optimize storefront performance, Magento accumulates data into special tables using indexers.

For example, suppose you change the price of an item from $4.99 to $3.99. Magento must reindex the price change to display it on your store. Without indexing, Magento would have to calculate the price of every product on the fly—taking into account shopping cart price rules, bundle pricing, discounts, tier pricing, and so on. Loading the price for a product would take a long time, possibly resulting in cart abandonment.
To access Index Management:

1. On the Admin menu, select System > Index Management.
2. Any indexer with a checkbox next to its name can be managed manually. The other indexers update automatically according to your Magento cron job. The default mode for each indexer is set in the system configuration.

Column Descriptions

<table>
<thead>
<tr>
<th>COLUMN</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Index</td>
<td>The name of the indexer.</td>
</tr>
<tr>
<td>Description</td>
<td>A description of the indexer.</td>
</tr>
<tr>
<td>Mode</td>
<td>Applies only to the indicated indexers. Most of the indicated indexers are set to Update on Save, which means a reindex is required when a change is saved. See: Manual Reindexing.</td>
</tr>
<tr>
<td>Status</td>
<td>Displays one of the following:</td>
</tr>
<tr>
<td></td>
<td>Reindex Required A change has been made that requires reindexing. If a checkbox and Reindex Required link appears, can be reindexed manually.</td>
</tr>
<tr>
<td></td>
<td>Ready The index is up-to-date.</td>
</tr>
<tr>
<td></td>
<td>Scheduled * Reindexing is required but hasn’t run yet according to your Magento cron job.</td>
</tr>
<tr>
<td></td>
<td>Running * Reindexing is required and is either running or in the queue.</td>
</tr>
<tr>
<td></td>
<td>Outdated * Indicates reindexing is required but there is an issue preventing it from running. If this state persists, submit a bug report.</td>
</tr>
</tbody>
</table>

* Applies to automatic indexers only.

<table>
<thead>
<tr>
<th>Update Required</th>
<th>Applies only to the indicated indexers. Indicates whether or not you must manually reindex. (The value in the Mode column indicates whether the indexer must be manually updated.)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Updated At</td>
<td>Displays the date and time an index was last manually updated, or Never if the index has never been manually updated.</td>
</tr>
<tr>
<td>Action</td>
<td>Indexers that require manual updating display a Reindex Data link. Click the link to reindex that option only.</td>
</tr>
</tbody>
</table>
Manual Reindexing

Indexers that require manual updates have a checkbox in the first column next to their name (Product Attributes, Tag Aggregation Data, and optionally, Catalog Search Index). The example below shows one index that requires a full reindex (Product Attributes), an index that requires a partial reindex (Catalog Search Index), and an index that is up-to-date (Tag Aggregation Data).

- If the Status column indicates “Reindex Required,” and the Update Required column indicates “No,” only a partial index is produced when you index manually.
- If the Status column indicates “Reindex Required,” and the Update Required column indicates “Yes,” a full index is produced when you index manually.

![Index States table]

**To reindex manually:**

1. On the Admin menu, select **System > Index Management**.
2. Select the checkbox of each item to be reindexed.
3. Set **Actions** to “Reindex Data.”
4. Click the **Submit** button.
Automatic Indexing

Magento indexes automatically whenever one or more items are changed (for example, price changes, catalog or shopping cart price rules are created, new categories added, and so on). Reindexing is performed as a background process; your store is accessible during all reindexing processes.

To avoid problems when multiple Admin users update objects that trigger automatic reindexing, set all indexers to run as cron jobs. Otherwise, every time an object is saved, any affected objects with dependencies might cause a deadlock. Symptoms of a deadlock include high CPU usage and MySQL errors. As a best practice, schedule indexing as a cron job to prevent deadlocks from occurring.

Index Modes

The default mode for each indexer is specified in the system configuration. By default, indexers that require manual updating are set to “Update on Save,” which means reindexing occurs after a change is made from the Admin. The other option is to manually reindex every time a change is made. (For example, if you change product attributes in the Admin, you must manually update the Product Attributes index.) If you ever need to override the default index mode, you can use the Action control.

Examples: Index Actions and Controls

Index Actions

<table>
<thead>
<tr>
<th>ACTION</th>
<th>RESULT</th>
<th>TO CONTROL</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating a new store, new customer group, or any action listed in &quot;Actions that Cause a Full Reindex.&quot;</td>
<td>Full reindex</td>
<td>Full reindexing is performed on the schedule determined by your Magento cron job. In a few cases, full reindexing must be performed manually.</td>
</tr>
</tbody>
</table>

Bulk loading of items in the following ways:
- Magento import/export
- Direct SQL query
- Any other method that directly adds, changes, or deletes data.

Partial reindex (only changed items are reindexed) | At the frequency determined by your Magento cron job. |

Changing scope (for example, from global to website) | Partial reindex (only changed items are reindexed) | At the frequency determined by your Magento cron job. |
To change the index mode:

1. On the Admin menu, select **System > Index Management**.
2. Select the checkbox of each indexer you want to change.
3. Set **Actions** to “Change Index Mode.” Then, set **Index Mode** to one of the following:
   - Update on Save
   - Manual Update
4. Click the **Submit** button to apply the change to each selected indexer.
# Events that Trigger Reindexing

## Reindex Triggers

<table>
<thead>
<tr>
<th>INDEX TYPE</th>
<th>REINDEXING EVENT</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product Prices</td>
<td>Add customer group.</td>
</tr>
<tr>
<td>Flat catalog product data</td>
<td>Add store.</td>
</tr>
<tr>
<td>Flat catalog category data</td>
<td>Add store.</td>
</tr>
<tr>
<td>Catalog category/product index</td>
<td>Add, edit, or delete products (single, mass, and import).</td>
</tr>
<tr>
<td>Catalog search index</td>
<td>Add, edit, or delete products (single, mass, and import).</td>
</tr>
<tr>
<td>Stock status index</td>
<td>Change inventory configuration settings.</td>
</tr>
<tr>
<td>Category permissions index</td>
<td>Add store, add store group, add or delete or update attribute (for searching and filtering),</td>
</tr>
</tbody>
</table>

---

1 The flat product and category indexers also influence how catalog and shopping cart price rules are indexed. If you have a large number of SKUs (about 500,000 or more), you will notice a dramatic improvement in indexing time for price rules. To take advantage of this improvement, you must enable Use Flat Catalog Product.
Events that Trigger a Full Reindex

Full Reindex Triggers

<table>
<thead>
<tr>
<th>INDEXER</th>
<th>EVENT</th>
</tr>
</thead>
<tbody>
<tr>
<td>Catalog Category Flat Indexer</td>
<td>Create a new store.</td>
</tr>
<tr>
<td></td>
<td>Create a new store view.</td>
</tr>
<tr>
<td></td>
<td>Create, or delete an attribute that is any of the following:</td>
</tr>
<tr>
<td></td>
<td>• Searchable or visible in advanced search</td>
</tr>
<tr>
<td></td>
<td>• Filterable</td>
</tr>
<tr>
<td></td>
<td>• Filterable in search</td>
</tr>
<tr>
<td></td>
<td>• Used for sorting</td>
</tr>
<tr>
<td></td>
<td>Change an existing attribute to be any of the preceding.</td>
</tr>
<tr>
<td></td>
<td>Enable flat category frontend options.</td>
</tr>
<tr>
<td>Catalog Product Flat Indexer</td>
<td>Create a new store.</td>
</tr>
<tr>
<td></td>
<td>Create a new store view.</td>
</tr>
<tr>
<td></td>
<td>Create, or delete an attribute that is any of the following:</td>
</tr>
<tr>
<td></td>
<td>• Searchable or visible in advanced search</td>
</tr>
<tr>
<td></td>
<td>• Filterable</td>
</tr>
<tr>
<td></td>
<td>• Filterable in search</td>
</tr>
<tr>
<td></td>
<td>• Used for sorting</td>
</tr>
<tr>
<td></td>
<td>Change an existing attribute to be any of the preceding.</td>
</tr>
<tr>
<td></td>
<td>Enable flat category frontend options.</td>
</tr>
<tr>
<td>Stock status indexer</td>
<td>When the following Inventory configuration options change:</td>
</tr>
<tr>
<td></td>
<td>Stock Options: Display Out of Stock Products</td>
</tr>
<tr>
<td></td>
<td>Product Stock Options: Manage Stock</td>
</tr>
<tr>
<td>Price Indexer</td>
<td>Adding a new customer group.</td>
</tr>
<tr>
<td></td>
<td>When any of the following Inventory configuration options change:</td>
</tr>
<tr>
<td></td>
<td>Stock Options: Display Out of Stock Products</td>
</tr>
<tr>
<td></td>
<td>Product Stock Options: Manage Stock</td>
</tr>
<tr>
<td></td>
<td>Price: Catalog Price Scope</td>
</tr>
<tr>
<td>Category or Product Indexer</td>
<td>Create or delete a store view.</td>
</tr>
<tr>
<td></td>
<td>Delete a store.</td>
</tr>
<tr>
<td></td>
<td>Delete a website.</td>
</tr>
</tbody>
</table>
CHAPTER 65:

Cache Storage

Using Magento’s cache management system is an easy way to improve the performance of your site. The Cache Storage Management page shows the status of each primary cache and its associated tag. Whenever one of the caches needs to be refreshed, a notice appears at the top of the workspace to guide you through the process. There are separate buttons to flush the Magento-specific cache, and the all-inclusive cache storage. At the bottom of the page there are additional buttons to flush the catalog product images cache and JavaScript/CSS cache.

On the server, the default location for the primary Magento cache is var/cache. As an alternative to using the Cache Management tool, the contents of each cache can be manually deleted from the server.
Clearing Caches

After clearing a cache, always refresh your browser to make sure that it uses the most recent files.

To refresh specific caches:

1. Do one of the following:
   - Click the **Cache Management** link in the message above the workspace.
   - On the Admin menu, select **System > Cache Management**.

   The status of each cache that needs to be refreshed appears in yellow and marked, “Invalidated.”

2. Do one of the following:
   - For each cache that needs to be refreshed, click the checkbox at the beginning of the row.
   - To select a group, click one of the selection options above the list.

3. Set **Actions** to “Refresh,” and click the **Submit** button.

To flush the product image cache:

1. From the Cache Storage Management page, under Additional Cache Management, click the **Flush Catalog Images Cache** button.

   The message, “Image cache was cleaned” appears at the top of the workspace.

2. Make sure to also clear the cache of your browser.
To flush the JavaScript/CSS cache:

1. From the Cache Storage Management page, under Additional Cache Management, click the **Flush JavaScript/CSS Cache** button.
   The message, “The JavaScript/CSS cache has been cleaned” appears at the top of the workspace.

2. Make sure to also clear the cache of your browser.

**Button Descriptions**

<table>
<thead>
<tr>
<th>BUTTONS</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flush Magento Cache</td>
<td>Removes all items in the default Magento cache (var/cache), according to their associated Magento tags.</td>
</tr>
<tr>
<td>Flush Cache Storage</td>
<td>Removes all items from the cache, regardless of Magento tag. If your system uses an alternate cache location, any cached files used by other applications are removed in the process.</td>
</tr>
<tr>
<td>Flush Catalog Images Cache</td>
<td>Removes all automatically resized and watermarked catalog images that are stored at: media/catalog/product/cache. If recently uploaded images aren't reflected in the catalog, try flushing the catalog and refreshing your browser.</td>
</tr>
<tr>
<td>Flush JavaScript/CSS Cache</td>
<td>Removes the merged copy of JavaScript and CSS files from the cache. If recent changes to the style sheet or JavaScript aren't reflected in the store, try flushing the JavaScript/CSS cache and refreshing your browser.</td>
</tr>
</tbody>
</table>
### Cache Types

<table>
<thead>
<tr>
<th>TYPE</th>
<th>DESCRIPTION</th>
<th>SYSTEM</th>
<th>MODULE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuration</td>
<td>System and module configuration files.</td>
<td>config.xml</td>
<td>config.xml</td>
</tr>
<tr>
<td></td>
<td>Associated tag: CONFIG</td>
<td>local.xml</td>
<td></td>
</tr>
<tr>
<td>Layouts</td>
<td>Page layout building instructions.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Associated tag: LAYOUT_GENERAL_CACHE_TAG</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Blocks HTML Output</td>
<td>The HTML that is associated with page blocks.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Associated tag: BLOCK_HTML</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Translations</td>
<td>Language translation files.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Associated tag: TRANSLATE</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Collections Data</td>
<td>Files that contain data that is the result of a query.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Associated tag: COLLECTION_DATA</td>
<td></td>
<td></td>
</tr>
<tr>
<td>EAV Types and Attributes</td>
<td>Attribute entities, types, and values.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Associated tag: EAV</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Web Services Configuration</td>
<td>Web Services definition files (api.xml)</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Associated tag: CONFIG_API</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Web Services Configuration</td>
<td>Web Services definition files (api2.xml)</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Associated tag: CONFIG_API2</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
External Full-Page Cache

Full-page caching can improve response time and reduce the load on the server. Magento Community Edition supports the external Send Full Page Cache. To learn more, see Content Caching (Dynamic) on the Zend website.

To enable external caching:

1. On the Admin menu, select System > Configuration.
2. In the panel on the left, under Advanced, select System.
3. Click to expand the External Full Page Cache Settings section. Then, do the following:
   a. Set Enable External Cache to “Yes.”
   b. Set External Cache Control to “Zend Full Page Cache.”
4. When complete, click the Save Config button.
CHAPTER 66:

Alternate Media Storage

Magento Community Edition gives you the option to store media files in a database on a database server, or on a Content Delivery Network (CDN), as opposed to storing them on the file system of the web server. The advantage of using alternate storage is that it minimizes the effort required to synchronize media when multiple instances of the system that are deployed on different servers that need access to the same images, CSS files, and other media files.

Using CDN as alternate media storage is implemented as a self-support option only, and not as a full integration with a specific CDN. You must choose and configure the CDN on your own. Topics in this chapter include:

- Media Storage Database Setup
- Media Storage CDN Setup
Media Storage Database Setup

By default, all images, compiled CSS files, and compiled JavaScript files of the Magento instance are stored in the file system on the web server. You can choose to store these files in a database on a database server. One advantage of this approach is the option of automatic synchronization and reverse synchronization between the web server file system and the database. You can use the default database to store media or create a new one. To be able to use a newly created database as media storage, you must add information about it and its access credentials to the local.xml file.

Database Workflow

When the customer opens the store page, its browser requests the HTML code and the media specified in the HTML code from the Magento system. The system searches the requested media in the file system and passes it to the browser, if it is found. If the system does not find the media in the file system, it requests the media from the database specified in the settings, places the media to the file system, and sends it to the customer’s web browser.

To get the files from the database to the file system on the web server a PHP script is used. When the browser requests media from the web server, there are two alternatives for when a PHP script is run:

- If web server rewrites are enabled in the Magento system and supported by the server, the PHP script is run only when the requested media is not found in the web server file system.
- If web server rewrites are disabled in the Magento system or not supported by the server, the PHP script is run in any case, even when the required media exists in the file system of the web server.
To use a database for media storage:

1. On the Admin menu, select **System > Configuration**.
2. In the panel on the left, under Advanced, select **System**.
3. This configuration takes place at the global level, so set **Current Configuration Scope** to “Default Config.”
4. Click to expand the **Storage Configuration for Media** section. Then, do the following:

   ![Storage Configuration for Media](image)

   **Storage Configuration for Media**

   a. Set **Media Storage** to “Database.”
   b. Set **Select Media Database** to the database you want to use.
   c. Click the **Synchronize** button to transfer the existing media to the newly selected database.
   d. Enter the **Environment Update Time** in seconds.
5. When complete, click the **Save Config** button.
Media Storage CDN Setup

Storing media files in a CDN is another alternative supported in Magento. There is no full integration with a specific CDN, and you are responsible for choosing and configuring a CDN on your own. After configuring the CDN, you must complete the configuration from the Admin. The changes can be made at either the global or website level.

CDN Workflow

When a CDN is selected as media storage, all paths to media on the web store pages are changed to paths to the CDN. Retrieving media that is stored in a CDN works as follows:

- When a customer opens a page in the store, the browser addresses the CDN with the request to acquire some media files, such as images.
- If the CDN does not yet have these images in its storage, it requests them from the server, and provides images to the customer's browser.
- If the CDN already has the required images in storage, it simply serves the requested images to the customer's browser.

**Important!** When a CDN is used as media storage, JavaScript may not function properly if the CDN is not in your subdomain. This is a browser security feature.
To configure a content delivery network:

1. On the Admin menu, select **System > Configuration**.
2. In the panel on the left, under General, select **Web**.
3. Set the **Current Configuration Scope** as needed.
4. Click to expand the **Unsecure** section. Then, do the following:

   a. Change the value of the **Base Media URL**.
   b. Change the value of the **Base JavaScript URL**.

5. Click to expand the **Secure** section.

   a. Change the value of the **Base Media URL**.
   b. Change the value of the **Base JavaScript URL**.

6. When complete, click the **Save Config** button.
CHAPTER 67:

Magento Connect

Magento Connect is Magento's original marketplace for extensions. There are hundreds of extensions available from all over the world. Magento out-of-the-box supports a few of the most popular ones. However, community members are developing and publishing new extensions in order to extend Magento with various new features.
Upgrading Magento

Magento Community Edition is constantly evolving. New features are added and problems resolved on an ongoing basis. From time to time you will be notified that a new Magento CE version is available. This notice will be published in the Magento blog, and in your Admin InBox.

Consider the following before upgrading your store:

- If the update is critical, contains mandatory updates, or resolves issues that you have encountered, you should update your store.
- Upgrading between major versions, such as between version 1.1 and 1.2, might require minor configuration changes. See the update release notes for more information.
- If your store has a custom theme, you will benefit from the bug fixes in the update, but new functionality might not be implemented in your theme.
- We strongly recommend that you test all updates in a staging environment before upgrading a live store.

To update your store to a new version:

1. On the Admin menu, select System > Magento Connect > Magento Connect Manager.
2. Enter your Admin username and password, and click the Log In button.
3. Click the Check for Upgrades button. Any upgrades available for Magento CE modules are marked in yellow.
4. In the Actions column, select the upgrades to be installed. Then, click the Commit Changes button.
5. When the installation is complete, click the Return to Admin link in the header.

Congratulations! You have upgraded Magento Community Edition. Now check your site to make sure everything works as expected.
Installing Extensions

Many extensions and themes are available on Magento Connect, and the installation process varies for each. Some extensions require additional configuration after the installation. For complete installation and configuration instructions, see the documentation provided by the extension developer. The following instructions outline the general process. Before installing any extension, always back up your store.

To back up your store:

1. On the Admin menu, select System > Magento Connect > Magento Connect Manager.
2. Select the Create Backup checkbox and select the backup type.

   The backup is created automatically, and listed under System > Tools > Backups.
To install an extension:

1. Go to Magento Connect.
2. Use the filters to browse through the available extensions.
3. On the page of the extension you want to install, do the following:
   a. If the extension is available for sale, click the Get Extension button. Then, follow the prompts to purchase the extension.
   b. Click the Get Extension Key button.
   c. Click the link to read the license agreement, and if you agree to the terms, select the checkbox.
      An extension key similar to this appears: magento-core/Mage_xxxx. The key is a special link that Magento needs to install the extension to your store.
   d. Click Select to select the key, and press Ctrl + C to copy it to the clipboard.
4. Log in to your store Admin, and do the following:
   a. On the Admin menu, select System > Magento Connect > Magento Connect Manager.
   b. When prompted, enter your Admin User Name and Password. Then, click the Log In button.
   c. In the Install New Extensions section, paste the Extension Key.
   d. Click the Install button and wait for the installation to complete.
5. You can now return to your store Admin and use the extension.
   Look for new options in the related section of the Admin. For example, payment extensions appear in System > Configuration > Sales > Payment Methods.
CHAPTER 68:

Web Services

Web services share information across networks using standards-based technologies. Information from your store can be shared with other Web-based services to help create a more integrated set of tools for your business.

Web services retrieve information from your store using an application programming interface, the Magento Core API. The Magento Core API includes all the parameters for data requests that other web services need to access information from your store. Topics in this chapter include:

- Magento Core API Settings
- Activating Web Services
Magento Core API Settings

The Magento Core API supports both SOAP and XML RPC protocols. The API is permission-based, and allows access to the Customer, Catalog, and Order modules of your store.

The WSDL (Web Services Description Language) definition that you create for your Magento Community Edition API solution is WS-I compliant by default. This makes it possible to use tools that require a WS-I complaint WSDL definition for API integration. No additional settings are required. By default, the API default character set is UTF-8, and the timeout for client sessions is 3600 seconds. You can change the default settings through the system configuration of the store. Use the following endpoint URL for all WSI-I APIs, and replace {site_url} with the store domain:

**WS-I Endpoint URL**

```
http://{site_url}/api/wsi_soap/?wsdl
```

To change the general settings:

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left under Services, select **Magento Core API**.
2. Click to expand the **General Settings** section. Then, do the following:

   **General Settings**

   a. Enter the name of the **Default Response Charset** that you want to use.
   b. Enter the length of the **Client Session Timeout** in seconds.
   c. To enable **WS-I Compliance**, select “Yes.”
   d. To enable the **WSDL Cache**, select “Yes.”
3. When complete, click the **Save Config** button.
Activating Web Services

Web Services give you the ability to grant permission to third-party applications to access your store data for the purpose of integration. Magento Community Edition supports both SOAP and REST services.

**Process Overview:**

Step 1: Create a Web Service Role

Step 2: Create a Web Service User

Step 3: Add Custom Scripts to Your Store

**Step 1: Create a Web Service Role**

1. On the Admin menu, select **System > Web Services > SOAP/XML-RPC Roles**.
2. Click the **Add New Role** button.
3. In the Role Information section, enter a **Role Name** such as “API.”
4. In the panel on the left, select **Role Resources**. Then do one of the following:
   - To enable full access, set **Resource Access** to “All.”
   - To provide limited access to data, set **Resource Access** to “Custom.” Then, select the checkbox of each resource that is available to this role.
   - By default, when a area is selected, full access is granted. However, you can specify the actions that a person is allowed to take. Specific types of access are listed under many of the resource links, so it is easy to determine exactly what a user is allowed to do with the resource.
5. When complete, click the **Save Role** button.

**Step 2: Create a Web Service User**

1. On the Admin menu, select **System > Web Services > SOAP/XML-RPC-Users**.
2. Click the **Add New User** button.
3. Complete the following fields:
   - User Name
   - First Name
   - Last Name
   - Email
4. In the **API Key** field, type in a verification key, or password. This is the access credentials that third-party web services will use to access your Magento store.

![Web Service User](image)

5. To confirm, re-enter the key in the **API Key Confirmation** field.

6. In the panel on the left, select **User Role**. Then, select a role for the user.

7. When complete, click the **Save User** button.

### Step 3: Add Custom Scripts to Your Store

Some third-party web services rely on snippets of JavaScript code to gather data. Some web services require you to insert code in the HTML `<head>` section, while others require the code to be in the HTML footer, below the closing `</body>` tag.
CHAPTER 69:  

**System Tools**

The system tools give developers, system administrators, and support engineers easy access to routine system processes and reports. Topics in this chapter include:

- Backups
- Patches
- Compilation
- System Log
- Cron
- Magento Test Framework
- Database Repair
Server Backups & Rollback

Magento Community Edition gives you the ability to back up different parts of the system—such as the database, file system, or both—and to rollback automatically. Files are compressed using the .gz and .tgz formats.

Best Practices

- **Restrict access to backup tools.** Access to the backup and rollback tools can be restricted by configuring user permissions for backup and rollback resources. To restrict access, leave the corresponding checkbox unselected. If you need to grant access to the rollback resources, you must grant access to backup resources as well.

- **Backup before installing extensions and updates.** Always perform a backup before installing an extension or updating Magento. Magento Connect Manager (MCM) includes a backup option that you can use before installing an extension or upgrading to a new release.
Creating a Backup

Database backup files are compressed using the .gz format. The .tgz format is used for system, database, and media backups. Backup files are stored in the var/backups directory in your Magento file system. The files that are stored in the /var/cache, /var/log, /var/session and /var/report folders are excluded from the backup.

To create a single backup:

1. On the Admin menu, select **System > Tools > Backups**.
2. Click one of the following buttons, depending on the type of backup you need to create:
   - **System Backup**: Creates a complete backup of the database and the file system. In the next step you can choose whether to include the media folder to the backup.
   - **Database and Media Backup**: Creates a backup of the database and the media folder.
   - **Database Backup**: Creates a backup of the database.
3. When prompted that the backup will take time, click **OK** to continue.
4. To put the store into maintenance mode during the backup, select the checkbox. After the backup is created, maintenance mode is turned off automatically.
5. If you are creating a system backup, select the **Include Media folder to System Backup** checkbox if you want to include the media folder. When prompted, confirm the action.

All backups are listed on the Backups page. Deleting a record from the list deletes the archive file as well.
To configure regularly scheduled backups:

1. On the Admin menu, select System > Configuration.
2. In the panel on the left, under Advanced, select System.
3. Click to expand the Scheduled Backup Settings section. Then, do the following:
   a. Set Backup Type to one of the following:
      - Database
      - Database and Media
      - System
      - System (excluding Media)
   b. Set the Start Time of the backup to the hour, minute, and second.
   c. Set the Frequency of the backup to one of the following:
      - Daily
      - Weekly
      - Monthly
4. To take the store offline during the backup process, set Maintenance Mode to “Yes.”

To backup from Magento Connect Manager

1. On the Admin menu, select System > Magento Connect > Magento Connect Manager.
2. Select the Create Backup checkbox and select the backup type.
3. Proceed with an extension installation or Magento update. The backup is created automatically and available at System > Tools > Backups.
Rolling Back Changes

At times it might become necessary to roll back changes to a previous backup.

**Important!** Use Rollback with caution. Customers who are in the process of checking out when you start the rollback may not be able to complete the process.

To roll back the whole system or the database:

1. On the Admin menu, select **System > Tools > Backups**.

2. On the Backups page, find the backup you want. Then in the Action column, click the **Rollback** link.

   All changes made since the backup was created will be lost after the rollback.

3. Confirm the rollback. When prompted, enter your Admin **Password**. Then, choose whether you want to put your store into the maintenance mode during the rollback. When restoring file system or database and media files you can choose to use the FTP connection.

   After the rollback, you are redirected to the Admin login page.

4. Refresh all cache types and rebuild required indexes.
Installing Magento Patches

Magento recently launched several patches to correct vulnerabilities in the system. It is recommended that you upgrade your store to the latest version of Magento, and install any security-related patches as soon as they become available.

Make sure to stop by our Magento Security Center, and sign up for the Security Alert Registry to receive direct notification from our security team of any emerging issues and solutions.

Because of the variation in hosting environments and access to the server, there is no “one size fits all” way to install a patch. This article describes three methods to install a patch, and also how to revert a patch.

- **Use SSH**
- **Run a Script**
- **Upload Pre-Patched Files**
- **Revert an Installed Patch**

If your hosting provider doesn’t provide SSH access to the server, try one of the other methods. Although the focus of this article is on security patches, the same methods can be used to install any Magento patch.

**Step 1: Back Up Your Magento Installation**

Always back up your Magento installation before installing a patch. To learn more, see: Creating a Backup

**Step 2: Download the Patch**

To download the recommended patches for your version of Magento Community Edition, visit the Magento download page.

**Step 3: Disable the Compiler**

If your store is compiled, make sure to disable compilation before installing a patch. After installing a patch, test the store thoroughly. Then, run the compiler again. Your store must be recompiled for the patch to take effect.
Step 4: Install the Patch

Method 1: Use SSH

Secure Shell (SSH) is the recommended way to install a patch. If you don’t know how to set up SSH, contact your hosting provider. For detailed instructions, see: Installing Patches with SSH.

1. Upload the patch files to the root of your [magento] installation folder.
2. If the store is compiled, make sure the compiler is disabled.
3. In the SSH console, run the following commands according to the patch extension:

```
.sh extension
sh patch_file_name.sh

.patch extension
patch --p0<patch_file_name.patch
```

4. Use either of the following methods to verify that the patch was installed:
   - Download or view the file: app/etc/applied.patches.list.
   - From the command line, run the patch file with the --list argument for a report of all patch installations.
Method 2: Run a Script

The following example shows how to install the SUPEE_5344.sh patch. Make sure to replace the patch name in the example with the name of the patch file to be installed.

1. Upload the patch files to the root of your [magento] installation folder.
2. If the store is compiled, make sure the compiler is disabled.
3. From your desktop, do the following:
   a. Use a text editor to create a file named patch.php that contains the following script.

```php
<?php
print("<PRE>");
passthru("/bin/bash PATCH_SUPEE-5344.sh");
print("</PRE>");
echo "Done";
?>
```

b. Upload the patch.php file to the root of your [magento] installation folder.

4. Run the script from your browser.

```
http://www.[yourstore.com]/patch.php
```

Then, look for the following message:

```
Checking if patch can be applied/reverted successfully...
Patch was applied/reverted successfully.
Done
```

5. After the patch is successfully installed, delete the patch.php file from your server.

If you receive the following error, either ask your hosting provider to install the missing tools, or try one of the other methods.

```
"Error! Some required system tools, that are utilized in this sh script, are not installed; Tool (s) "patch" is (are) missed, please install it(them).
```

6. Refresh your cache from the Magento Admin, Don’t forget to refresh your OPcode or APC cache as well.

7. If your store is compiled, rerun the compiler.
**Method 3: Upload Pre-Patched Files**

1. Download your Magento installation to your local machine.
2. Apply the patch locally.
3. Upload the updated files to your server.

**Reverting an Installed Patch**

Occasionally it is necessary to uninstall a patch. The command to revert a patch is essentially the same as the command that is used to install a patch, but with the addition of the `-R` flag.

1. Before you begin, make sure that you have appropriate permissions to the Magento installation directory on the server. If the directory is owned by a web server user such as `apache` or `root`, change to the appropriate user to ensure that you have the necessary permissions. For example:

   ```bash
   su - apache
   ```

   Then when prompted, enter the password.

2. Change to your `magento` installation folder.

3. On the command line, enter the following command to revert the patch:

   ```bash
   sh patch_file_name.sh -R
   ```
Installing Patches with SSH

Whenever a patch is released to fix an issue in the code, a notice is sent directly to your Admin Inbox. If the update is security related, the incoming message is color-coded red, and marked as a “Critical Update.”

Make sure to stop by our Magento Security Center, and sign up for the Security Alert Registry to receive direct notification from our security team of any emerging issues and solutions.

The following instructions explain how to download and install a patch, starting with a notice that appears in your Admin Inbox. The example takes place on a Windows system, and uses the WinSCP utility to upload patch files to the server, and Putty to access the server from the command line. You can download both utilities at no charge. If you are a Mac user, you can access the command line with Terminal.

If this is the first time you have installed a patch, we recommend that you complete the optional steps to create a backup copy of your store and install a patch as a test run. If you have experience installing patches, you can take the fast track and skip the optional steps. For advanced instructions, see the following articles in the Magento developer documentation:

How to Apply and Revert Magento Patches

Recommended File System Ownership and Privileges

Before you begin...

To install a patch, you must have a user name and password to access the server. In addition to your own login credentials, you might also need the apache password. If you don’t have these credentials, contact the person who set up your server.

Incoming Message of Critical Importance
Process Overview:
Step 1: Download the Patch
Step 2: Set the Necessary Permissions
Step 3: Create a Backup of the Magento Folder (Optional)
Step 4: Upload the Patch
Step 5: Install the Patch on the Backup (Optional)
Step 6: Install the Patch to Your Store
Step 7: A Little Housekeeping (Optional)
Step 8: Look for Signs of Unauthorized Access (For security-related issues)
Step 9: Clear the Magento Cache
Step 10: Recompile the Store (Only if compiled)
Step 11: Restart the Server

Step 1: Download the Patch

1. When you receive the message in your Inbox, click the Read details link to open the Magento Community Edition Download page. (The link in the Inbox is for convenience, and you can access the Download page at any time.)

2. Scroll down to the Download tab, under the Magento Community Edition Patches section. Then, find the patches that need to be installed. For this example, we'll download the following patches:

   SUPEE-5344  Addresses a potential remote code execution exploit  
   (Added Feb 9, 2015)

   SUPEE-1533  Addresses two potential remote code execution exploits  
   (Added Oct 3, 2014)
3. For each patch to be downloaded, do the following:
   
   a. In the Select your format box, select the version of Magento Community Edition that is installed on your server. If you don’t know the version number, you can find it in the footer of the Admin.

   b. Click the Download button. Look for the downloaded file in the lower-left corner of your browser.

   If prompted, log in to your account. If you don’t have an account, click the Create an Account Now! button, and follow the instructions. Then, return to the Download page and continue.

   c. Click the down arrow next to the download file name to display the menu. Then, select Show in folder. The patches are in the Download folder of your desktop computer.
Step 2: Set the Necessary Permissions

For a live store, permissions are locked down to prevent unauthorized access. However, you must change the permissions of the contents of the Magento installation folder before you can install the patch. In the following instructions, Putty is used to access the command line and change the permissions.

1. Click the **Start** button in the lower-left corner of your desktop, and launch **Putty**. When prompted, enter the **Host Name** or **IP Address** of your store, and click the **Open** button.

2. Servers have different directory structures, and the path to your Magento installation folder is most likely different from the one shown in the examples. Depending on your server, the path to your Magento installation folder might be one of the following:

<table>
<thead>
<tr>
<th>SERVER</th>
<th>PATH</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ubuntu</td>
<td>/var/www/magento</td>
</tr>
<tr>
<td>CentOS</td>
<td>/var/www/html/magento</td>
</tr>
</tbody>
</table>

From the command line, use the **Change Directory** command to navigate to your Magento installation folder. In this example, Magento is installed on a CentOS server, and the Magento installation folder is located three levels below the **html** folder.

```
cd /var/www/html/stores/ce/magento
```

3. List the directory to check the permission status of the **magento** folder. To install a patch, you must temporarily change the folder permissions. After the patch is installed, you can restore the appropriate permissions to your live store.

```
lst -l
```

If you get a “Permission denied” message, add **sudo** to the beginning of the List Directory command.
The second column shows the current permission settings for the contents of the `magento` folder. It includes a combination of read only, read/write, and execute permissions, depending on the type of folder or file. Take note of the owner and group in the next two columns. You probably won’t need this information, but it’s good to know. In this example, each folder and file is owned by the `apache` user and belongs to the `root` group.

### Recommended Permissions for a Live Store

**4.** To install a patch, you must change the permissions to allow the necessary files to be copied and overwritten, and to make it possible for the script to execute. Enter the following commands to change the permissions of the directories and files in the folder. Then, list the directory.

```bash
find . -type d -exec chmod 700 {} \;
find . -type f -exec chmod 600 {} \;
ls -l
```

To save time, copy each command from the example, and press the mouse button to paste it into the command line.
If your Magento installation is on a shared virtual server, you might need to begin each command as a `sudo` super administrator:

```
sudo find . -type d -exec chmod 700 {} \;
```

```
sudo find . -type f -exec chmod 600 {} \;
```

```
sudo ls -l
```

The first column in the directory shows the updated permission settings. After the patch is installed, you will restore the recommended permissions to your store.

![Updated Permissions]
Step 3: Create a Backup of the Magento Folder (Optional)

1. Use the Change Directory command, followed by two dot to move one level up in the directory tree. Then, list the directory so you can see the magento folder.
   
   ```
   cd..
   ls -l
   ```

2. Enter the following command to create a new folder, called backup.
   
   ```
   mkdir backup
   ls -l
   ```

   a. If you get a “Permission denied” message, add sudo to the beginning of the Make Directory command. Then, list the directory to see the folder that you created.
      
      ```
      sudo mkdir backup
      sudo ls -l
      ```

   b. The backup folder must have the same owner and group as the magento folder. If not, enter the following command to change the ownership of the backup folder and its contents.

   In this command, the backup folder is assigned to the apache user and root group, and followed by a single dot. (Don’t forget to use sudo if you need super administrator access.)

   ```
   chown -hR apache:root backup .
   ls -l
   ```

   c. Enter the “who am I” command to see if you are logged in as the correct owner.

   ```
   whoami
   ```

   d. If you are not logged in as the web server or apache user, enter the following command. When prompted, enter the password for the web server or apache user account.

   ```
   su - apache
   ```

   Notice that the prompt has changed. You are now in the bash folder of the apache user. While you’re logged in as the apache user, you won’t need to use sudo for super administrator access.
3. Use the Change Directory command to return to the location of your `magento` and `backup` folders. List the directory to see where you are. Then, check to see who you are.

```bash
cd /var/www/html/stores/ce
ls -l
whoami
```

![Backup Folder with Correct Owner and Group](image)

4. Copy the contents of the `magento` folder to the `backup` folder.

```bash
cp -r magento/* backup
```

5. Wait for the process to complete and for the system prompt to return. Then, take a look at the contents of the `backup` folder to make sure the files were copied.

```bash
cd backup
ls -l
cd ..
```

6. Because you’ll be working with the `backup` folder for awhile, it’s a good idea to restore the original permissions to your `magento` folder before continuing.

Enter the following commands to restore the recommended permissions to the `magento` folder. Then, list the directory to verify that the permissions are restored.

To save time, copy each command from the example, and press the mouse button to paste it into the command line.
Lock Down Permissions

```
ls -l

cd magento

find . -type d -exec chmod 500 {} \;
find . -type f -exec chmod 400 {} \;
find var/ -type f -exec chmod 600 {} \;
find media/ -type f -exec chmod 600 {} \;
find var/ -type d -exec chmod 700 {} \;
find media/ -type d -exec chmod 700 {} \;
ls -l
```
Step 4: Upload the Patch

1. To avoid permission problems when you upload the patch from your desktop, create a folder for the patch without any restrictive permissions. From Putty, navigate back to the level of the magento and backup folders. Then, make a new folder called patch, and change the permissions of the folder to 777.

```bash
cd ..
lsof -l
mkdir patch
chmod 777 patch
ls -l
```

You now have three folders with different permissions. The patch folder is wide open with read, write and execute permissions. For this limited purpose, it’s OK.

2. Return to your desktop, and launch WinSCP, or a similar tool. Then, log in to the server.

3. In the right pane, navigate on the server to the location of the patch folder.

4. In the left pane, go to your Downloads folder, and find the patch files that you downloaded. Drag the files over to the right pane, and drop them on the patch folder.
Step 5: **Install the Patch to the Backup** (Optional)

1. Return to Putty in the directory where the `patch`, `backup`, and `magento` folders are located. Change directories to the `patch` folder, and list a directory to verify that the patch files are there. Then, copy each patch file up one level. (Just remember—two dots up, one dot down.)

   ```
   cd patch
   ls -l
   cp PATCH_SUPEE-1533_EE_1.13.x_v1-2015-02-10-08-18-32.sh ..
   cp PATCH_SUPEE-5344_CE_1.8.0.0_v1-2015-02-10-08-10-38.sh ..
   cd ..
   ls -l
   ```

   Now the patch files are at the same level as the `backup` and `magento` folders, where they can be easily accessed.

2. Because the temporary `patch` folder has served its purpose, enter the following command to remove it from the server:

   ```
   rm -rf patch
   ls -l
   ```

3. Copy each patch file to the `backup` folder. Then, change directories to the `backup` folder, and list the directory. You should see the patch files in the directory.

   ```
   cp PATCH_SUPEE-1533_EE_1.13.x_v1-2015-02-10-08-18-32.sh backup
   cp PATCH_SUPEE-5344_CE_1.8.0.0_v1-2015-02-10-08-10-38.sh backup
   cd backup
   ls -l
   ```

4. To install the patch, use the appropriate syntax for the type of patch, and substitute the file name of the patch to be installed. There are two command formats, depending on the patch file
name extension. To avoid typos, copy the patch file name from Putty, and paste it into Notepad. Then, add the required command syntax, paste it into the command line, and press Enter.

<table>
<thead>
<tr>
<th>EXTENSION</th>
<th>COMMAND SYNTAX</th>
</tr>
</thead>
<tbody>
<tr>
<td>.sh</td>
<td>sh [patch_filename.sh]</td>
</tr>
<tr>
<td>.patch</td>
<td>patch -p0 &lt; [patch_filename.patch]</td>
</tr>
</tbody>
</table>

```
sh PATCH_SUPEE-1533_EE_1.13.x_v1-2015-02-10-08-18-32.sh  
sh PATCH_SUPEE-5344_CE_1.8.0.0_v1-2015-02-10-08-10-38.sh
```

The following message appears if the installation succeeds:

Patch was applied/reverted successfully.

If the patch is already installed on your computer, an error message appears. You don’t need to install it again.

So that’s really all there is to it. It might seem rather anticlimactic after so much preparation, but it’s important to understand the process before you apply the patch to your store.

5. The next step is to change directories to the `magento` folder, and reset the permissions so the patch can be copied and installed to your live store. Then, you will copy the patch file to the `magento` folder.

```
cd ..  
ls -l  
cd magento  
find . -type d -exec chmod 700 {} \;  
find . -type f -exec chmod 600 {} \;  
cd ..  
cp PATCH_SUPEE-1533_EE_1.13.x_v1-2015-02-10-08-18-32.sh magento  
cp PATCH_SUPEE-5344_CE_1.8.0.0_v1-2015-02-10-08-10-38.sh magento  
cd magento  
ls -l
```
Step 6: Install the Patch to Your Store

1. From your `magento` folder, enter the appropriate command to install the patch, and press Enter.

<table>
<thead>
<tr>
<th>EXTENSION</th>
<th>COMMAND SYNTAX</th>
</tr>
</thead>
<tbody>
<tr>
<td>.sh</td>
<td><code>sh [patch_filename.sh]</code></td>
</tr>
<tr>
<td>.patch</td>
<td><code>patch -p0 &lt; [patch_filename.patch]</code></td>
</tr>
</tbody>
</table>

To avoid typos, copy the name of the patch file from your Downloads folder and paste it into Notepad. Complete the required command syntax, and copy it to the clipboard. Then, press the mouse button to paste it into the command line.

```
sh PATCH_SUPEE-1533_EE_1.13.x_v1-2015-02-10-08-18-32.sh
sh PATCH_SUPEE-5344_CE_1.8.0.0_v1-2015-02-10-08-10-38.sh
```

2. When the process is complete, remove the patch files from the `magento` folder.

```
rm PATCH_SUPEE-1533_EE_1.13.x_v1-2015-02-10-08-18-32.sh
rm PATCH_SUPEE-5344_CE_1.8.0.0_v1-2015-02-10-08-10-38.sh
```

3. Enter the following commands to lock down permissions to the `magento` folder.

```
find . -type d -exec chmod 500 {} \
find . -type f -exec chmod 400 {} \
find var/ -type f -exec chmod 600 {} \
find media/ -type f -exec chmod 600 {} \
find var/ -type d -exec chmod 700 {} \
find media/ -type d -exec chmod 700 {} \
ls -l
```

Lock Down Permissions
Step 7: A Little Housekeeping (Optional)

To remove the backup folder and patch files from your server, enter the following commands:

```
cd ..
ls -l
rm -rf backup
rm PATCH_SUPEE-1533_EE_1.13.x_v1-2015-02-10-08-18-32.sh
rm PATCH_SUPEE-5344_CE_1.8.0.0_v1-2015-02-10-08-10-38.sh
ls -l
```

Step 8: Look for Signs of Unauthorized Access (For security-related issues)

1. Log in to the Admin of your store.
2. On the Admin menu, select System > Users. Then, do the following:
   a. Verify that there are no unauthorized user accounts in the list.
   b. If you find an unknown user account in the list, click to open the account. Then, click the Delete User button.

To learn more about detecting signs of unauthorized access, see: Critical Security Advisory. If you suspect that your site is compromised, contact the security department of your hosting company and request an audit.
Step 9: Clear the Magento Cache

1. On the Admin menu, select System > Cache Management.
2. Click the Flush Cache Storage button.

Step 10: Recompile the Store (Only if compiled)

If your store is compiled, you must recompile to incorporate the patch. If your store isn’t compiled, you can skip this step.

1. On the Admin menu, select System > Tools > Compilation.
2. Click the Run Compilation Process button.

Step 11: Gracefully Restart the Server

The final step is to restart the server to flush any remaining caches, such as the APC and/or Zend OpCache. The following steps show how to gracefully restart the server without disrupting pages from being served, or causing loss of data.

1. If your server has a control panel such as cPanel, look for the option to gracefully reboot the server. On cPanel, select Home > System Reboot > Graceful Server Reboot.
2. To gracefully restart from the command line, do the following:
   a. The syntax to restart the server from the command line varies by operating system. To find the version that is running on your server, enter the following:

```
cat /etc/issue
```

   b. Use the appropriate command to gracefully restart the server. If necessary, begin the command with sudo.

   **CentOS / Fedora / Redhat**

```
apachectl -k graceful
```

   **Debian / Ubuntu**

```
apache2ctl graceful
```

3. To end the session, close both the Putty and WinSCP windows.

If you have more than one server, make sure to install the patch on all Magento servers.
Compilation

The compiler is disabled by default. The first time you run the compiler, the status changes to “Enabled.” A summary of the compilation state appears at the top, and includes the status of the compiler and state of the compilation, the number of files compiled, and the number of compiled scopes.

**To run the compiler:**

1. On the Admin menu, select **System > Tools > Compilation**.
2. Click the **Run Compilation Process** button.

**To disable the compiler:**

Click the **Disable** button.

![Compilation Complete](image-url)
System Log

The System Log activates system logs, and determines the name of the system and exception log files.

To configure system logs:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Advanced, select Developer.
2. Click to expand the Log Settings section. Then, do the following:

   - Set Enabled to “Yes.”
   - In the System Log File Name field, enter the name you want to use for the system log file, in lowercase characters. The default file name is: system.log
   - In the Exceptions Log File Name field, enter the name you want to use for the exceptions log file, in lowercase characters. The default file name is: exceptions.log
3. When complete, click the Save Config button.

System Log Cleaning

System logs can be scheduled to be cleaned automatically as a Cron job. The configuration determines the number of days that system logs are kept on the server, how frequently the logs are cleaned, and who is notified if an error occurs.

To schedule system log cleaning:

1. On the Admin menu, select System > Configuration. Then in the panel on the left under Advanced, select System.
2. Click to expand the Log Cleaning section. Then, do the following:
3. Set **Save Log Days** to the number of days that system log files are kept on the server.

4. To automatically clean the system log on schedule, set **Enable Log Cleaning** to “Yes.” Then, do the following:
   
   a. Set **Start Time** to the hour, minute, and second that the system log is to be cleaned.
   
   b. To determine how often the system log is cleaned, set **Frequency** to one of the following:
      
      - Daily
      - Weekly
      - Monthly
   
   c. In the **Enter Email Recipient** field, enter the email address of the person to receive notification if an error occurs during log cleaning. Separate multiple addresses with a comma.
   
   d. In the **Error Email Sender** field, select the store contact that appears as the sender of the error notification.
   
   e. Select the **Error Email Template** to be used for the notification

5. When complete, click the **Save Config** button.
Cron (Scheduled Tasks)

Magento performs some operations on schedule by periodically running a script. You can control the execution and scheduling of Magento cron jobs from the Admin of your store. Store operations that run according to a cron schedule include:

- Email (Transactional and any other email sent from the store.)
- Catalog Price Rules
- Newsletters
- Google Sitemap Generation
- Customer Alerts and Notifications
- Currency Rate Updates
- Log Cleanup

Make sure that the secure and unsecure base URLs for the store are set correctly, so the generated URLs are correct. To learn more, see: Setting Up Cron Jobs.
To configure cron:

1. On the Admin menu, select **System > Configuration**. Then in the panel on the left under Advanced, select **System**.
2. Click to expand the **Cron** section.

![Cron (Scheduled Tasks)](image)

3. Enter the number of minutes for each of the following:
   - Generate Schedules Every
   - Schedule Ahead for
   - Missed if not Run Within
   - History Cleanup Every
   - Success History Lifetime
   - Failure History Lifetime

4. When complete, click the **Save Config** button.
Magento Test Framework

The Magento Test Framework (MTF) is a tool that can run nearly 170 automated functional tests, which are included in Magento and designed to improve the quality of implementations and to make it easier to perform basic acceptance testing when adding extensions, making customizations, or upgrading Magento. For more technical information, see: Introduction to Magento Testing Framework.
Requirements

**SYSTEM REQUIREMENTS**

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Windows, Mac OS, Ubuntu, or CentOS</th>
</tr>
</thead>
<tbody>
<tr>
<td>PHP</td>
<td>The OpenSSL extension must be enabled for downloading files with HTTPS.</td>
</tr>
<tr>
<td>Java, version 1.6 or later</td>
<td>To determine your current version of Java, enter the following at the command line: <code>java -version</code></td>
</tr>
<tr>
<td></td>
<td>If Java isn’t recognized, make sure the java and jar executables are in your system PATH. To learn more, see: Installing Java, Using Java</td>
</tr>
<tr>
<td>Magento</td>
<td>Magento URLs must not include a secret URL key. To verify the configuration, do the following:</td>
</tr>
<tr>
<td></td>
<td>1. Log in to the Magento Admin with administrator privileges.</td>
</tr>
<tr>
<td></td>
<td>2. On the Admin menu, select System &gt; Configuration.</td>
</tr>
<tr>
<td></td>
<td>3. In the panel on the left under Advanced, select Admin. Then, click to expand the Security section.</td>
</tr>
<tr>
<td></td>
<td>4. Set Add Secret Key to URLs to “No.”</td>
</tr>
<tr>
<td></td>
<td>5. Click Save Config.</td>
</tr>
<tr>
<td>Git</td>
<td>Git must be installed.</td>
</tr>
<tr>
<td></td>
<td>(Windows Only) Add Git to your system PATH variable, or run Composer from the Git bash shell.</td>
</tr>
<tr>
<td>Browser</td>
<td>If using a browser other than Firefox, download drivers that are compatible with Selenium. To learn more, see the Selenium Documentation.</td>
</tr>
<tr>
<td></td>
<td>The browser must also be declared in the config.xml file. For an example, see: Non-Firefox Browsers.</td>
</tr>
</tbody>
</table>
Installation

1. Download Composer for **UNIX** or **Windows**. Then, follow the instructions to install Composer.

2. Run Composer from the `[Magento install]/dev/tests/functional` directory as follows:

   ```bash
   composer install
   ```

   If you cannot run composer from the command line, do the following:

   a. Copy `composer.phar` to the same directory where `composer.json` is located. The typical location is:

      `[Magento install dir]/dev/tests/functional`

      The `composer.json` file contains dependency information and settings for PHPUnit, Selenium server, libraries, and so on, and is required to start MTF. It checks out MTF from a separate repository.

   b. Run Composer as follows:

      ```bash
      php composer.phar install
      ```

      A new directory named `vendor` is created with the checked-out MTF. The `vendor` directory contains:

      - An MTF framework directory (magento/mtf)
      - bin
      - composer
      - netwing
      - phpunit
      - symfony
      - autoload.php (file)

3. To run the generator, do one of the following:

   - Use your browser to navigate to the following location:

     `[Magento install dir]/dev/tests/functional/utils/generate.php`

   - Execute the following from the command line:

     ```bash
     php utils/generate/factory.php
     ```
The generator tool creates generated directories with factories for pages, blocks, handlers, fixtures and repositories. After MTF is initialized, the factories are pre-generated to facilitate creating and running tests.

Configuration

Non-Firefox Browsers

If using a browser other than Firefox, you must first download drivers that are compatible with Selenium. Then, add the following declaration to the config.xml file. The file is located at:

```
[Magento install]/dev/tests/functional/etc/config.xml
```

```xml
<server>
  <item name="selenium" type="default" browser="Google Chrome"
        browserName="chrome" host="localhost" port="4444"
        seleniumServerRequestsTimeout="90" sessionStrategy="shared">
    <desiredCapabilities>
      <platform>ANY</platform>
    </desiredCapabilities>
  </item>
</server>
```

To learn more, see the Selenium Documentation.

Magento URLs

Update the `phpunit.xml` file with the URLs of your storefront and Magento Admin as follows:

```xml
<env name="app_frontend_url"
     value="http://localhost/magento2/index.php"/>

<env name="app_backend_url"
     value="http://localhost/magento2/index.php/backend"/>
```
Configuration Reference

This reference provides information about each MTF configuration section located at:

[Magento install dir]/dev/tests/functional/etc/config.xml

application

Provides the login credentials for the Magento Admin.

Sample

```xml
<application>
  <reopenBrowser>testCase</reopenBrowser>
  <backendLogin>admin</backendLogin>
  <backendPassword>123123q</backendPassword>
  <backendLoginUrl>admin/auth/login</backendLoginUrl>
</application>
```

<table>
<thead>
<tr>
<th>ELEMENT</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>reopenBrowser</td>
<td>Determines if the browser is opened either before every test, or before every test case. The default behavior is for the browser to open before every test case.</td>
</tr>
<tr>
<td>backendLogin</td>
<td>The user name of the Magento Admin administrator.</td>
</tr>
<tr>
<td>backendPassword</td>
<td>The password of the Magento Admin administrator.</td>
</tr>
<tr>
<td>backendLoginUrl</td>
<td>The URL of the Magento Admin Login page.</td>
</tr>
</tbody>
</table>

isolation

Specifies the isolation strategies for tests, cases, and suites.

Sample

```xml
<isolation>
  <resetUrlPath>dev/tests/mtf/isolation.php</resetUrlPath>
  <testSuite>before</testSuite>
  <testCase>none</testCase>
  <test>none</test>
</isolation>
```
Your isolation strategy determines when the system returns to its initial state. An isolation strategy can apply to any scope, such as a test, case, or suite. The following four isolation strategies are available:

### Isolation Strategies

<table>
<thead>
<tr>
<th>STRATEGY</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>none</td>
<td>(Default) Specifies that the isolation script is not to be run before or after any test, case, or suite.</td>
</tr>
<tr>
<td>before</td>
<td>Specifies that the isolation script is to be run before a test, case, or suite.</td>
</tr>
<tr>
<td>after</td>
<td>Specifies that the isolation script is to be run after a test, case, or suite.</td>
</tr>
<tr>
<td>both</td>
<td>Specifies that the isolation script is to be run both before and after a test, case, or suite.</td>
</tr>
</tbody>
</table>

### server

Specifies the Selenium web browser (if not Firefox) and other options. For a list of valid browserName values, see:

- [Selenium source code](#)
- [List of Selenium RC Browser Launchers](#)

### Sample

```xml
<server>
  <item name="selenium" type="default" browser="Mozilla Firefox" browserName="firefox" host="localhost" port="4444" seleniumServerRequestsTimeout="90" sessionStrategy="shared">
    <desiredCapabilities>
      <platform>ANY</platform>
    </desiredCapabilities>
  </item>
</server>
```
Running MTF

1. Make sure your Magento code is up to date.

2. Change to the `dev/tests/functional` directory, and run `composer update` to update any dependencies that might prevent tests from running successfully.

   ```bash
   composer update
   ```

3. Start Selenium. Selenium was downloaded by Composer, and can be found in the following directory:

   ```bash
   dev/tests/functional/vendor/netwing/selenium-server-standalone
   ```

   **Example**

   ```java
   java -jar vendor/netwing/selenium-server-standalone/selenium-server-standalone-2.39.0.jar
   ```

4. Start your tests using PHPUnit, using your integrated development environment (IDE), or from the command line.

   **Example**

   ```bash
   cd dev/tests/functional
   phpunit
   ```
Frequently Asked Questions

Q: We want to run tests on a custom website. The tests assume that the main website is called “Main Website,” and do not work. Is there a way to provide a custom name without changing the tests?

A: This is an error in the tests. Instead of “Main Website,” it should be set to main_website, which will select the default website. The website_selection_patch will be included in next MTF release.

Q: I get errors in Mage\Adminhtml\Test\TestCase\CreateWebsiteEntityTest. How can I fix it?

A: This is a misconfiguration in the test, which was designed for an internal workflow. The website patch addresses this issue.

You might also try this as an alternate solution. In the following file:

dev\tests\functional\tests\app\Mage\Adminhtml\Test\Constraint\AssertProductIsPresentOnCustomWebsite.php

Change line 115 to:

```php
$this->magentoRoot = realpath(MTF_BP . '/../../../');
```

Q: I get errors in Mage\Adminhtml\Test\TestCase\CreateStoreEntityTest. How can I fix it?

A: This test fails due to lack of translations. Install translations into Magento.

Q: I get errors while testing a custom website.

A: One possible reason is that translations enabled. The tests expect to find English text on the page. Change the default language to English on the website that is being tested.
Q: Why are some of tests so slow, especially when comparing the default address with the data sets?

A: This is caused by the way the Selenium server processes the SELECT statement. The next version should address this issue.

Q: Some of the tests are very slow, especially when choosing a category for a newly added product. This process slows down when there are a lot of categories.

A: This is caused by the algorithm that prepares the tree:

\Magento\Mtf\Client\Element\TreeElement

The next version should address this issue.

Q: How can I create tests that extend an existing module? For example, how do we add new attributes and assertions to customer tests?

A: See this customer attribute example and instructions.

Q: How can I create tests for a responsive theme or for any other custom theme?

A: See this custom theme example and instructions.
Database Repair

The Database Repair tool compares a corrupt database with a target database, and updates the target so it has the same structure as the corrupt database. During the process, Database Repair does the following:

- Adds missing tables, or repairs them so they have the same engine type and charset
- Adds missing fields or repairs them
- Removes inconsistent data from tables with broken foreign key references
- Adds missing foreign keys and indexes

A typical use case for this tool is to fix the database of an existing Magento installation that has some of the errors mentioned above. To learn more, see: Magento 1.x Database Repair Tool.

---

Important! Do not use DB Repair on a production site without testing it first in a development environment. Always back up the original database before using DB Repair.

---

Step 1: Restrict Access to Website

It is highly recommended that you restrict access to your website while repairing the database. The following example restricts your Magento instance to your IP address exclusively. Other visitors, including search spiders, will get the HTTP “503 Service Unavailable” error.
Step 2: Create a Rewrite Rule

1. Create a file called 503.php in your Magento installation root that contains the following code:

```php
<?php
header('HTTP/1.1 503 Service Unavailable');
header('Content-Type: text/plain; charset=UTF-8');
echo "503 Service Unavailable";
```

2. In .htaccess or in Apache server configuration, add the following rewrite rule. Replace the IP address xxx\.x\.x\.x (xxx.x.x.x) with your own IP address. (Be careful to preserve the backslash and dot between the numbers.

If running in a cluster environment, uncomment the FileETag line. To learn more, see: Configure ETags.

```plaintext
#FileETag none
RewriteEngine On
RewriteCond %{REMOTE_ADDR} !^xxx\.x\.x\.x$
RewriteRule !503.php /503.php L
```

3. Save the .htaccess file or reload the Apache configuration. Your site will be down until the end of the process when you restore its original state.

Step 3. Install the DB Repair Tool

1. Download the archived Magento Database Repair tool from the Magento Community Edition download page.
2. Do either of the following:
   - Upload the archived file to your server, and extract it to any folder.
   - Extract the archive. Then, upload the file, `magento-db-repair-tool-1.2.php` to any folder on your server.

**Step 4: Back Up and Clone Your Database**

1. Back up your existing database that has the problem, so it can be restored in the event of a problem. We'll call it “database1.”
2. Clone “database1” as the new “database2” on the same server.
3. Create a new empty database, “database3.”
4. Do one of the following:
   - Copy the entire Magento folder (without the cache and sessions) to a new location, and install “database3.” Then, update the `local.xml` file with the database credentials.
   - Since access to the site is restricted, you can update the database credentials to “database3” for the current Magento instance. Then, clean the cache and launch Magento. The new database will be installed automatically.

You now have “database2,” which is a clone of your original database, and a Magento installation with the empty “database3.”

**Step 5: Run DB Repair**

1. Enter the following in the address bar of your browser to launch the DB Repair tool:
   ```
   http://[your-domain]/
   [path-to-folder]/magento-db-repair-tool-1.2.php
   ```

2. Under Corrupted Database Connection, complete the following information for “database2:” This information is the same as what is entered during the Configuration step of the Magento Setup.
   a. In the **Host** field, enter the server's fully qualified host name or IP address. If your database server is on the same host as your web server, enter “localhost.”
   b. Enter the following credentials for the MySQL database that has the problem:
      - Database Name
      - User Name
      - User Password
c. If there are multiple instances of Magento that share the same database, enter the Table Prefix.

3. Under Reference Database Connection, enter the database credentials for the empty “database3.”

   If using a Table Prefix, make sure that it is the same as the prefix used for Database1.

4. Click Continue to diagnose the database and display the results.

**Step 6: Examine the Results**

Examine the results to see the changes that were made. If nothing was changed, there is no need to fix the database.

- **Minor Changes**
  - If only the table charset changed, there is usually nothing to do—especially if the table contains no text data.

- **Major Issues**
  - If the table engine changed from MyIsam to InnoDB, you will need the help of a developer to investigate and resolve the problem.
  - If a missing foreign key, field, or table was added, you will need the help of a developer to investigate and resolve the problem.

**Step 7: Perform the Repair**

If you are satisfied with database repair report and need to fix your live database, you can either switch your installation to “database2” (because it was repaired), or perform the repair directly on the live database.

**Step 8: A Little Housekeeping**

1. Remove the Database Repair file, magento-db-repair-tool-1.2.php from your server.
2. Restore access to your website.
CHAPTER 70:

Configuration

This reference has field descriptions for each section of the configuration. Drill down through any section, and click a link to jump to the corresponding topic in the online user guide. From the “how to” instructions, click the caption below a screenshot to jump to the corresponding field descriptions. To learn more, see: Configuration Scope.

General

Includes basic configuration settings for the store, URLs, theme, currency, email addresses, store contacts, editor settings, and dashboard reports.

Catalog

Determines product and inventory settings, sitemap and RSS feed generation, and specifies the email template that is used to share products with friends.

Customers

Establishes basic customer account and login options, newsletter settings, wish list, and the format of auto-generated coupon codes.
Sales

Determines checkout and tax settings, payment and shipping options, sales email and PDF print-outs, and Google API settings.

Services

Configures Magento API settings, including SOAP and OAuth.

Advanced

Determines default Admin settings, various system configuration settings, advanced module controls, and developer tools.
Appendices

The appendix includes information about each release, and additional reference material.

- Release Notes
- Change Log
- Glossary
- Documentation Archive
- Configuration Reference
  - General
  - Catalog
  - Customers
  - Sales
  - Services
  - Advanced
APPENDIX A:

Release Notes

Release notes provide a detailed description of each product release, with links to additional technical information, installation instructions, and support resources.

The current release is represented by the first decimal position in the version number. In addition, there might be interim patch releases to resolve security issues, and make necessary updates to the software. Patch releases are represented by the second decimal position in the version number. This user guide reflects the most current version of the product, which appears in the upper-right corner of each page. See the Reference section of the online user guide for an archive of past release notes.

As a best practice, we recommend that you keep your Magento Community installation up to date, so you can benefit from the latest enhancements. You can find the release notes for the following previous versions of Magento Community Edition in the online user guide:

- Magento Community Edition 1.9.2.4
- Magento Community Edition 1.9.2.3
- Magento Community Edition 1.9.2.2
- Magento Community Edition 1.9.2.1
- Magento Community Edition 1.9.2
- Magento Community Edition 1.9.1.1
- Magento Community Edition 1.9.1
APPENDIX B:  

Change Log

Our documentation is continually updated with new topics, and corrections or clarifications made to existing content. The change log in the online user guide lists the major updates, organized by month. If you can’t see the most recent changes, try refreshing your browser or clearing the cache. Check back every now and then, to see what’s new!

![Change Log](image-url)
APPENDIX C:

Documentation Archive

To open the PDF in your browser, simply click the version link. Right-click the link to save the PDF to your computer.

User Guide Downloads

<table>
<thead>
<tr>
<th>TITLE</th>
<th>VERSION</th>
<th>DATE</th>
<th>SIZE</th>
<th>PAGES</th>
</tr>
</thead>
<tbody>
<tr>
<td>Magento Community Edition User Guide</td>
<td>1.9.2.1</td>
<td>Aug 2015</td>
<td>12.6 MB</td>
<td>1024</td>
</tr>
<tr>
<td>Magento Community Edition User Guide</td>
<td>1.9</td>
<td>Nov 2014</td>
<td>10.2 MB</td>
<td>746</td>
</tr>
<tr>
<td>Magento Community Edition User Guide</td>
<td>1.8</td>
<td>Dec 2013</td>
<td>11.7 MB</td>
<td>768</td>
</tr>
</tbody>
</table>
APPENDIX D:

Glossary

A

above the fold
The web page content that is immediately visible in the browser window; section of a page that is displayed without the need to scroll.

Admin
The password-protected back office of your store where orders, catalog, content, and configurations are managed.

alt text
The text that is displayed in place of an image when the user is unable to view the image.

anchor text
The visible text that is anchored to another page or page section; the literal text of a hyperlink.

API
Application Program Interface: A software interface that lets third-party applications read and write to a system using programming language constructs or statements.

aspect ratio
The proportional relationship between the width and height of an image.

attribute
A characteristic or property of a product; anything that describes a product. Examples of product attributes include color, size, weight, and price.

authorization
To give a service permission to perform certain actions or to access resources.

average inventory cost
Product price, less coupons or discounts, plus freight and applicable taxes. The average is determined by adding the beginning cost of inventory each month, plus the ending cost of inventory for the last month of the period.
B

B2B
Business to Business: A type of business transaction between two business entities that are not the final consumers of the goods or services.

B2C
Business to Consumer: Business transactions between a business entity and a consumer.

Banner
Promotional graphics displayed either horizontally on the top of a web page or vertically on the left or right margins. Website advertisements are often displayed as banners.

Base currency
The primary form of currency used in store transactions.

Base currency rate
The base currency rate is the default for your store.

Batch processing
To perform a task or make a change to multiple items all at once, without manual repetition.

Batch target
A special target that lets you build and/or publish multiple other targets in a single group (or "batch"). You can schedule batches to run at any time.

Block snippet
A snippet that is created out of one or more paragraphs.

Bounce rate
The percentage of visitors to your site that leave without viewing any other pages.

Brand
A unique identity that defines a particular product or group of products.

Breadcrumb
A navigation aid that helps the user to keep track of their location within your store.

Brick and mortar
A retail business with a permanent physical location, as opposed to being entirely virtual.

Broken link
A hyperlink that fails to send the user to its intended web page.

C

Callout
Sometimes used to describe an XML block of page layout code.
canonical URL
The canonical meta tag redirects search engines to the correct URL, when seemingly duplicate content is encountered on the server.

capture
The process of converting the authorized amount into a billable transaction. Transactions cannot be captured until authorized, and authorizations cannot be captured until the goods or services have been shipped.

cardholder
A person who opens a credit card account and is authorized to make purchases.

cascading style sheet
The markup standard used to apply styles to HTML elements on the page.

category
A set of products that share particular characteristics or attributes.

CCV
Credit Card Verification code. (See CVV)

checkout process
The process of gathering the payment and shipping information that is necessary to complete the purchase of items in the shopping cart. In the final step, the customer reviews and places the order.

CMS
Content Management System: A software system that is used to create, edit, and maintain content on a website.

composite product
Any product type that offers customers a choice of options.

Condition tag
A marker that you can apply to different areas of your content so that some sections show up in some of your outputs but not in others.

Content Delivery Network
A large distributed network of servers that specializes in the high performance delivery of multimedia content.

content marketing
The art of promoting products or services by providing valuable information at no charge.

conversion
A marketing term that indicates a goal has been reached. If the goal is to sell a product, conversion is reached when a visitor to your site becomes a buyer.

conversion rate
The percentage of visitors who are converted into buyers.
credit memo
A document issued by the merchant to a customer to write off an outstanding balance because of overcharge, rebate, or return of goods.

Cross-reference
A navigation link that lets you connect text in one topic to another topic (or a bookmark within a topic). Cross-references let you create "automated" links that are based on commands you provide. This allows you to keep links consistent and change them in just one place by using the "xref" style.

CSS
Cascading Style Sheets: A style sheet language that controls the appearance of HTML documents; a way to control the appearance of text, graphics, lists, links, and all other elements on a web page.

CSV
Comma Separated Values: A type of file used to store data values which are separated from each other by commas.

CVM
Card Verification Method: A way to verify the identity of the customer by confirming a 3-digit or 4-digit credit card security code with the payment processor.

CVV
The Card Verification Value, also known as the Card Security Code, provides an additional level of security for online transactions.

D

domain
The address of a website on the web; what the customer types in their browser address bar to access the store.

domestic shipment
A shipment where the sender and recipient are in the same country, and no international borders are crossed.

double opt-in
The process for subscribing email recipients by requiring them to take a secondary step to confirm that they want to receive emails.

Drop-down text
A feature that lets you "scrunch up" content in your topic. The content is expanded (and therefore displayed) when the end user clicks a link.

dynamic content
A web page that displays different content depending on the user request.
Dynamic Media URL
   A link to an image that contains a relative reference to the file location in media storage.

E

EAV
   Entity Attribute Value

evergreen content
   Content with a long shelf life.

F

FAQ
   Frequently Asked Questions.

favicon
   Short for favorites icon; a 16x16 or 32x32 pixel icon associated with a website; is displayed in the browser address bar and next to the site name in a bookmark list.

feed reader
   Software that is used to read syndicated content from RSS feeds.

FOB
   Freight On Board: A shipping term indicating who is responsible for paying transportation charges.

Footnote
   A comment that is used to explain a specific area of the text. Both the area in the text and the comment contain a number or symbol that ties the two together. A footnote (or endnote) comment can be placed at the end of a page, document, chapter, section, or book.

frontend properties
   Properties that determine the presentation and behavior of an attribute from the standpoint of the customer in your store.

fulfillment
   The process of managing customer shipments.

G

gateway
   A transaction bridge between a customer and a payment processing service that is used to transfer money between the customer and the merchant.

gross margin
   The difference between the cost and price of a product.
**H**

**handle**
In programming, a name used to reference an object.

**hierarchy**
The organization of websites, stores, and views in a Magento installation.

**home page**
The first home page a visitor sees when they access your website URL. Considered the most important page on your website according to search engine indexing.

**HTML**
HyperText Markup Language: A standard for tagging and structuring text, images, videos, and other media on a web page.

**I**

**international shipment**
A shipment where the sender and recipient are in different countries, and international borders are crossed.

**invoice**
A document that provides a detailed description of a purchase, including products purchased, quantity, price, shipping cost, sales tax, and total.

**J**

**JavaScript**
A scripting language used with HTML to produce dynamic effects and interactions on web pages.

**JQuery**
A popular JavaScript library that is often used to create dynamic and responsive effects.

**K**

**keyword**
A term or phrase used in a search to filter for content that is of significant importance to that term or phrase.

**L**

**LAMP**
Linux / Apache / MySQL / PHP

**landing page**
A page on your site where a visitor arrives after clicking a link or advertisement.
layout
The visual and structural composition of a page.

layout update
A specific set of XML instructions that determines how the page is constructed.

link juice
The value and authority transferred from one web page to another via hyperlinks (or links). Link juice affects a website’s page rank, a factor used to rank a search engine results page.

liquid layout
A flexible approach to web design that specifies the size and position of elements as percentages rather than as exact measurements in pixels.

load sequence
The order scripts are loaded into memory. To work correctly, some scripts must be loaded before others.

locale
A set of configurations that defines the user’s language, country, tax rate, and other settings.

login
The process of signing into an online account.

markdown
The amount subtracted from the original price of a product.

markup
A percentage added to the cost of an item to determine the retail price.

media storage
A dedicated space on the content delivery network for your store’s assets.

merchant account
An account with a bank or financial institution that makes it possible to accept credit card transactions.

meta tags
Information in a web page that is not displayed on the page itself, but is used by search engines to determine the page title, description, and page keywords.

navigation
The primary group of web page links that a customer uses to navigate around the website; the navigation links to the most important categories or pages on an online store.
**O**

**opt-in**
The process by which a user consents to receiving emails from an online store.

**P**

**packing slip**
A document that is usually included in a shipped package that describes the contents. Packing slips do not include financial or account information.

**path to purchase**
The path a prospect follows that leads to a sale.

**payment bridge**
An application that helps merchants meet PCI-DSS requirements.

**payment gateway**
A service that charges your customers’ credit cards and sends the funds to your merchant account, for deposit into your business bank account.

**PCI**
Payment Card Industry: Refers to debit and credit cards and their associated businesses.

**privacy policy**
A document that explains the merchant’s policies for handling customer information.

**purchase order (PO)**
A written sales contract between a buyer and seller that describes the merchandise or service to be purchased from a vendor.

**R**

**redirect**
A method used to alert browsers and search engines that a page has been moved. 301 Redirect: Permanent change 302 Redirect: Temporary change.

**relative link**
A hyperlink that includes only the address of the linked page that is relative to the linking page, rather than the full URL.

**return policy**
A document that explains the merchant’s rules regarding the return of products by customers.

**robots.txt**
A file placed on a website that tells search engine crawlers which pages not to index.
RSS feed
Really Simple Syndication: A technology that creates web content syndication and allows web users to subscribe to product feeds, websites, and blogs.

S

SaaS
Software as a Service: A software delivery model where the vendor provides the software and hosting environment, and customers pay for the service by subscription or per use.

Sass/Compass
A CSS pre-compiler that provides organizable, reusable CSS.

security certificate
Information that is used by the SSL protocol to establish a secure connection.

SEO
Search Engine Optimization: The process of improving a website’s search engine rankings in order to increase valued visitors.

SERP
Search Engine Results Page

settlement
Settlement occurs when the acquiring bank and the issuer exchange funds and the proceeds are deposited into the merchant account.

shipping carrier
A company that transports packages. Common carriers include UPS, FedEx, DHL, and USPS.

shopping cart
A grouping of products that the customer wishes to purchase at the end of their shopping session.

sidebar
The right or left column of a two-column page layout.

Single-Sourcing
"Single-Sourcing" is a fancy term that means something very simple—to produce multiple outputs from one source.

sitemap
A page that provides search engines with an efficient, alternate route through your site.

SKU
Stock Keeping Unit: A number or code assigned to a product to identify the product, options, price, and manufacturer.
Snippet
A pre-set chunk of content that you can use in your project over and over. Snippets are similar to variables, but snippets are used for longer chunks of content that you can format just as you would any other content in your topic. In snippets, you can also insert tables, pictures, and whatever else can be included in a normal topic.

Span
A tag that is used to group inline elements to format them with styles. A span tag doesn't perform any specific action; it simply holds the attributes (e.g., font size, color, font family) that you apply to inline content.

splash page
A promotional page with a product or advertisement; normally displayed before the home page.

SSL certificate
A validation and security mechanism that identifies the merchant and encrypts credit card and other sensitive information.

static block
A fixed content block that can be displayed on various content pages in a store.

static content
Content that does not change frequently. See also dynamic content.

Style
An element that contain pre-set formatting properties. You can apply style classes to your content to change the way it looks. Using style classes instead of direct (or "inline") formatting helps you work faster, more efficiently, and with more consistency in your topics. If you need to make changes to the formatting in the future, you do not need to change the formatting in each topic (as you would with direct formatting). Instead, you only need to change the formatting properties for that style in the appropriate stylesheet.

Table
A group of intersecting columns and rows that you can add to a topic for various purposes, such as comparing one thing with another or giving field descriptions for a software dialog.

Target
One "instance" of an output type. When you build your final output, you are essentially building one or more of the targets in your project.

Text snippet
A snippet that is created out of a portion of one paragraph.

theme
A package that contains graphics and appearance information, and customizes the look and feel of the store.
Topic
A chunk of information about a particular subject. Topics are the most important part of a project. Everything else is contained within topics (e.g., hyperlinks, text, pictures) or points toward topics (e.g., table of contents, index, browse sequences). The very reason end users open a Help system is to find information, a little direction. They find that help within individual topics.

transactional email
An automated email message that is sent in response to a specific event or transaction.

URL
Uniform Resource Locator: The unique address of a page on the internet.

usability
Refers to the degree to which a product or service is easy to use by its customers.

Variable
A pre-set term or content that you can use in your project over and over. Variables are similar to snippets, but variables are used for brief, non-formatted pieces of content (such as the name of your company’s product or your company’s phone number). There are different kinds of variables: (1) those you create, (2) system variables, (3) Heading variables, or (4) Running HF variables for page headers and footers in printed output.

Visual merchandising
A term used in retail to describe the art and science of floorplan development and the multi-dimensional presentation of products.

W

widget
A prepared snippet of code that adds functionality and/or dynamic effects to your store.

WYSIWYG
What You See Is What You Get: An editor that displays formatted text as it will appear in its final published form.

X

XML
Extensible Markup Language: A markup format derived from SGML that is used to format information for publication and distribution.

XML Editor
The window in the Flare interface where you can add content and formatting to elements such as topics and snippets.
APPENDIX E:

**Configuration Reference**

This reference has field descriptions for each section of the configuration. Drill down through any section, and click a link to jump to the corresponding topic in the user guide. To learn more, see: Configuration Scope.
Notes
Index

1

1 Column Layout 151, 500, 502

2

2 Columns
   with Left Bar 152, 500, 503
   with Right Bar 152, 500

3

3 Column Layout 501, 504
3D Secure Credit Card Validation 706

4

404 Page Not Found 449-450

A

Abandoned carts 566
   report 820
About Us page 448
Account
   customer information 543
   Magento 29
   share 32

Actions
   control 60, 64
Add
   Exception, theme 534
   New User 881
   Root Category 143
   to Wishlist 360
Address
   Book, customer 543
Address format 549
Address templates 549
Admin 49, 64
   CAPTCHA 896
   login 50
   menu 58
   Notifications 57
   permissions 877
   role 878
   role, create 879
   role, custom 880
   security 887, 895
   Startup Page 813
   user 878
   user, create 878
Adobe Reader 625
Advanced Search 165, 403
Advocacy Tools 44
Allow
  cookies 566
  Countries 73
  Gift Message 298
  HTML tags 166, 171
  HTML Tags on Frontend 171
  Printed Card 361
Allowed Currencies 826
Amazon Simple Pay 692
Analytics 38, 44
Anchor category 124, 143-144
Android, email 832
Antivirus software 112
Any, checkbox 65
AOV 41
Apache 10
API 45, 929
  Core 930
  Key 932
Append Complex Data 864
Apple Mail 832
Approve product review 367, 369
As Low As, bundle product 201
Assisted Shopping 573, 576
Associated Product 187, 192
attribute
  dropdown 223
  swatch values 229
Attribute 155
  advanced search 165
  code 167
create 159
  delete 162
  entities 866
  filterable 132
  group 164
  information 161
  input types 156
  layered navigation 165
  predefined 485
  price 258
  product 165
  properties 159
  quick search 165
  system 164
Attribute set 155, 163, 189-190, 285
Australia, PayPal solutions 688
Authorize.Net 692, 696, 698-699
  capture 696
  Direct Post Method 703
Auto Bill, recurring payment 291
Autogenerate
  Site Map 415
  Autogenerate Coupon Code 330
Automatic
  redirect 429
Average Order Value 41

B

Backend  See also
  Admin 50
Backorders 261, 267
  PayPal Express Checkout 676
Backup
  create 927
  delete 935
  permissions 934
Bank Transfer 639
Base
  currency 828
  image 217-218, 220
  JavaScript URL 923
  media URL 923
Base URL 106
Base URL Home page 450
Best practice
  industry 111
  SEO 413
Bestsellers 812
Bill Me Later, PayPal 652, 655
Billing
  agreement 543, 678
  recurring payment 292-293
Block 463, 485
  category 149, 151
  create 464
  ID, markup tag 491
Block reference 506-508
  category 466
CMS pages 466
  product page 467
Blocks HTML Output, cache 916
Blog, as Home Page 450
Blog, Magento 4-5, 7
Breadcrumb trail 125
Breadcrumb Trail 450
Browser Capabilities Detection 901
Bundle Product 179, 199
  group price 256, 258
  Items 201
Business location 73
Buy X, Get Y Free 338

C

Cache 913
  CSS files 915
  JavaScript 915
  module 916
  Storage Management 913
    system 916
    types 916
Cache Management 242
Callout 506
Canada, PayPal solutions 688
Canadian tax 791
Cancel
  order 584
Canceled, order status 612
Canonical meta tag 418, 424
CAPTCHA 896
  configuration, Admin 897
  configuration, store 898
Capture
  Offline 620, 697
  Online 618, 697
Cardholder data 112
Cardinal Centinel 706
Cart contents, retrieve 566
Cash On Delivery 641
Catalog 45
  Category Link 470
  flat 173
  images 216
  indexing 173
  Input Type for Store Owner 160
  menu 58
  New Products List 470
  Price Rules 309-310
  Product Link 470
  Search 288
Catalog Prices, tax 790
Category 123, 300
  create 137, 139
  Description 147
  Display Settings 149
  General Information 146
  grayed out 137, 139
  ID 141
  image 147
  landing page 141, 151
  levels 124
  Levels 138
  modify 142
  name 147
  page 149
  path, in URL 418, 424
  Products 153
  rewrite 437
  root 143
  tree 137, 139
  URL key 141
  Category hidden 145
  Category List
    Home Page 495
CDN 919, 922
  JavaScript use 922
  Certification 6
  Change Log 981
Channels 377
Check / Money Order 643
Checkbox 60
  states 65
  Terms and Conditions 598
  Checkout process 42, 541
  Terms and Conditions 596
  Checkout with PayPal 663
  Child authorizations, PayPal Express
    Checkout 677
  Chrome, email 833
  ChronoPay 692
  Clear cache 914
  Closed, order status 612
  CMS 39, 445
    Block, category 150
Index

menu 59
Page Link 470
page redirect 440
page rewrite 441
page, breadcrumbs 125
Pages 447, 451
Static Block 470
Widget 471
CMS Menu 446
COD 641
Collections Data, cache 916
Color
message importance 56
Column 499
layout 151, 506
sort 62
Comma-separated values 859
Command line
server 942
Community 44
Poll 347
Compare Products 166, 170, 346, 363
Comparison operator 312
Comparison properties 166
Compilation 957
Complete, order status 612, 623
Compliance, industry 111
Composite product 180
Compound tax 777
examples 777
Conditions, price rule 320
config.xml 916
configurable
swatch 223
configurable product
swatch 223
Configurable Product 178
create 189
image 195
inventory 284
Manage Stock 284
configurable products 226
Configuration
cache 916
email addresses 77
search, default 408
security 887, 895
Consent, cookies 114
Consistent prices 771
Consulting 6
Contact Us 79
form 491
Contacts 79
Content 445, 447
Delivery Network 919, 922
management system 39
page 451
Convert to Plain Text 851
Cookie
domain 116
law 114
lifetime 116
Options 180, 304
redirect 440
rewrite 441
scripts 932
Theme 152, 296
URL 38
variable 485
Custom Order Status 613
Customer account 44, 541, 585
dashboard 543
VAT Validation 785
address template 549
billing address, PayPal Express
Checkout 675
CSV structure 861
engagement 39
group 585
create 553-554
edit 554
VAT 785
journey 36-37
Order Status, RSS feed 379
retention 43
Reviews, report 822
segment 41
Service page 448
Support 76
Tags, report 821
VAT 785
Customer Account
Update 590
Customers 812
by Number of Orders, report 821
by Orders Total, report 821
Customers online 574
CyberMut Payment 693
CyberSource 692

D
Dashboard 44, 811
charts 814
configuration 811, 813
customer 543
menu 58
Database
and Media Backup 935
backup 935
compression, backup 935
media storage 920
Database Repair Tool 971
Dataflow 870
Date, input type 156
Day of Week 71
Default
Config 95
Country 73
Display Currency 828
e-mail template 837, 841
Robots 519
Title, page 519
Value 165
Default Pages 450
Default theme 530
Delete Entries, Import 864
Demo
  login 50
Design 39, 45, 523
  custom, category 151
  product 296
Desktop Environment, security 890
Developer Client Restrictions 535
Development environment 174
DHL 727
  shipping labels 737
  shipping packages 731
Digital Goods, EU tax 770
Dimensional weight 725
Direct Post Method, Authorize.Net 703
Disaster Recovery Plan 893
Discount 310, 647
  quantity 247
Display
  Actual Price 245
  in Suggested Terms 410
  Mode, category 150
  not required State 72
Settings
  Category 149
  Store Demo Notice 88, 519
Distributing newsletters 374
Documentation 4
Double opt-in 372
Download
  links 208
  samples 209
Downloadable Product 179, 770
  configure 210
  create 205
Downloader 13
Downloads, report 821
Drill-down, price 134
Drop shipments, PayPal Express
  Checkout 676
Dropdown
  attribute 190
  input type 156
Duplicate
  content 424
Dynamic
  media URL 422
  URL 417
  values, bundle product 199
dynamic image swap 234

E
EAV 173
  Types and Attributes, cache 916
eBook download 205
ECG 6
Eco tax 772
Ecosystem, Magento 7
Editor, WYSIWYG 455-456
electronic check 698

Email
  a Friend 347-348
  a Friend, configure 349
  addresses, configuration 77
  addresses, domain 76
  addresses, store 76
  campaign 43
  CSS file 856
  footer 847, 857
  header 856
  header template 842
  logo 856
  message templates 850
  Options 79
  template 834, 837, 841
  template, configure 831
  template, default 837, 841
  Email clients 832
  Email template 79, 858
    variables 485
  email, browsers 833
  email, upgrades 836
  Empty, page layout 152, 501
  Enable
    Cookies 449
    Qty Increments 284
    WYSIWYG Editor 166
  Encryption 112
  Encryption key 23
  Entity Attributes 868

Equalize
  Price Ranges, layered navigation 135
  Product Counts, layered navigation 135
  EU Member Countries 788
  EU Place of Supply 770
  European Union
    Example Tax Configuration 801
  Evergreen content 445
  eWAY Direct 694
  Excel
    XML 817
  Exception
    Package 524
  Export 868
    Dataflow 870
    product data 868
    product types 868
    Settings 868
    to, report 817
  Expressed consent, cookies 114
  Extension
    install 25, 927
    social media 380
    external cache 917

F
  Facebook 7, 381
    extensions 380
  Favicon 85, 519
  FedEx 727-729
    shipping labels 737
Fee failure, recurring payment 293
Feed reader 378
File
  compression, backup 934
File permissions 14
Filter
  by Attribute 142
  controls 63
Filterable
  attribute 132, 170
Filters 60
Firefox, email 833
Firewall 112
First Data Global Gateway 692
Fixed Product Tax 772
  input type 156
Flat
  catalog 173
    setup 174
  Rate Shipping 714
Flo2Cash Payment Web Service 694
Flush
  Cache Storage 915
  Catalog Cache 915
  JavaScript cache 915
  JavaScript/CSS Cache 915
  Magento Cache 915
    product image cache 914
Flush Swatch Image Cache 228
Flush Swatch Images Cache 242
Footer 89, 517, 521
Footer, email 847
Forum, Magento 4, 7
FPT 772
  attribute 773
    configuration 773
    in attribute set 775
    in product 775
France, PayPal solutions 688
Fraud Management Filters, PayPal 687
Free
  shipping 716
    shipping, price rule 335
Frontend Properties 160
FTP calculations 772
Fulfillment 617, 624
Full
  reindex 911
Full Page Cache, external 917

G

[GLOBAL] 95
Gateway, payment 691
General
  Contact 76-77
    Product Information 286
Get Extension Key 928
Gift Options
  configure 361
    product 298, 361
Global
  attribute scope 190
Index

search 60-61

Gmail 832

Goods & Services Tax 796

Google 385
  Analytics 385
  Analytics, cookies 119
  Merchant Center 385-386
  Product Listing Ads 386

Reader 378

Shopping 386

Sitemap 385, 391

Webmaster Tools 392

Grid
  filter 63
  sort 62
  View As 405

Grid, Product 126

Group price 256, 258

group_price attribute 256, 258

Grouped Product 178
  create 185

GST 796

Guest
  retrieve cart contents 566

H

Handle 516

Header 517, 520
  welcome message 87

Header template, email 842

Help 4

Hidden category 137, 139, 145

Hold, order 584

Home page 448
  New Products list 476

Home Page, create 454

Home Page, default 450

Hong Kong, PayPal solutions 689

HTML
  editor 455
  email 837, 841
  head 393
  Head 517-518
  in product description 171
  product descriptions 156
  suffix 417

I

iDEAL 693

Image
  cache, flush 914
  catalog, add 218
  import 864
  placeholder 183, 209, 220
  size 216
  sort order 219
  URL 458
  watermarks 221
  zoom 215

Implementation 45

Implied consent, cookies 114
### Import
- Behavior 867
- Currency Rates 829
- Dataflow 870
- guidelines 866
- images 864
- Product Images 870
- table rates, shipping 723
- Tax Rates 763
- in-line styles 834

### In Anchor, category
- 150

### In Stock
- 271

### Inbox, Admin
- 54

### Include / Exclude Tax
- 806

### Include in
- Advanced Search 403
- Navigation Menu 145, 147-148

### Incoming Messages
- 54

### Index
- 905
  - actions 908
  - modes 908

### Indexing speed
- 173

### Initial Fees, recurring payment
- 294

### Input type
- Bundle product 201
- Date 156
- Dropdown 156
- Fixed Product Tax 156
- Media Image 156
- Multiple Select 156
- Price 156

### Text Area
- 156

### Text Field
- 156

### Yes/No
- 156

### Input Validation
- 165

### Insert image
- 457

### Install
- extension 927
- Magento 11, 50
- patch 942
- Update 926

### Installation
- 11
  - Part I 12
  - Part II 20

### Security
- 891

### Integration
- 929

### Interface text, change
- 535

### Internet Explorer
- email 833

### Inventory
- 261, 263
  - configurable product 284
  - Configuration 262-263
  - Manage Stock 271

### Invoice
- 66, 610-611, 618, 622
  - Comments 623
  - Print 621

### Invoiced order, download product 210

### IP Address, Limit Sending By
- 349

### IP Anonymization, Google Analytics
- 398

### IP address
- 106

### iPhone, email
- 832
Magento
account 29
Connect 46, 523, 532, 925
Connect Manager, backup 934
Connect, install extension 927
Connect, Manager 928
cookies 119
Core API 929
Design Guide 523
reinstall 25
Solutions Partners 45
upgrades, email 836
Magento Connect, Install Extension 97
Magento Secure Payment Bridge 706
Magento Test Framework 962
Magento updates 25
Magnify image 215
Main menu 124
Main Menu
Categories 138
Major, message 56
Manage
Attribute Sets 163
Customers 67, 579
Products 66
Stock 263, 271, 284
Stores 92
Manufacturer's suggested retail price 251
Manufacturer, product 288
MAP (Minimum Advertised Price) 244, 251
Mark as Read 56
markup tag 460
Markup tag 485, 489, 493
Markup Tag
Home Page 495
Match Period To, report 818
Matched Expression 534
Maximal Depth 124
Maximal Depth, Top Navigation 138
Media
Image 217, 219
image, input type 156
Storage 457, 921
Storage, alternate 919
Storage, database 920
URL 422, 457
URL, markup tag 491
Media Storage 462
swatch 231
Memcached 10
Merchandising tools 41
Merchant
Location 638
Merchant solutions, PayPal 42
Message
importance 56
InBox 54
Messages, Admin 54
Meta
Description, product 289
Information 38, 414
   category 146
   Description 414
   Keywords 146, 414
   page 451
   product 184
   Title 414
   Information, product 210
   Information, Title 289
   Keywords, product 289
   tag, canonical 424
Meta Information
   product 289
Mini Shopping Cart 481
Mini Shopping Cart Widget 470
Minimum Advertised Price 251, 254
Minimum Order Amount 560
Miscellaneous
   HTML 521
   Scripts 393, 519
Misspelled words
   redirect 409
Mobile
   devices, matched expression 534
   menu 58
   theme, install 533
Moderate, product reviews 367, 369
Money Order 643
Most Viewed
   Products 812
   report 821
MSRP (Manufacturer's Suggested Retail Price)
   245, 251
MTF 962
Multi-Address Minimum Order 560
Multiple
   Select, input type 156
Music download 205
My
   Account 29
   Applications, customer 544
   Orders 543
   Product Reviews, customer 543
MySQL 10
   Fulltext Search 408
N
Navigation 123, 145
   menu 140, 148
   properties 165
   top 124
New
   Accounts, report 821
   Customers 812
   order state 612
   Products list 378, 470, 478
   Store 93
New Zealand, PayPal solutions 689
Newsletter 43, 371
   configuration 372
   problems 375
   Queue 374
Index

reports 375
subscribers 67
templates 373
Next page link 128
Nginx 10
No
  checkbox 65
  layout updates 152
Non-inline CSS 492, 834
non_inline_styles 834
Not
  Visible Individually 288
Not Capture 620, 697
Notice, message 56
Notifications, Admin 57

O
Offline, refund 632
Ogone 693
On Gesture, display price 245
On Hold, order status 583, 612
Onepage Checkout 596
Online customers 574
Online rates 724
Online refund 632
Opt-in 372
Oracle 10
Order 609-610, 612, 618, 622
cancel 584, 611
create 578
credit memo 611
fulfillment 46
invoice 611
review 596
shipment 611
stages 610
status 612-613
submit 610
Transactions 611
update 583
workflow 615
Order processing 42
Order Taxes, report 820
Orders
  report 816
Out of Stock 266, 268, 271, 273, 279
Outlook 832-833

P
Package
  pricing 250
  type, by carrier 728
Package, design 524
Packing slip 622, 624
Page 447
  configuration 517
  create 451
  Translate 103
Page Footer 521
Page Layout 152, 296, 499, 502
  examples 502
  product 296
Page Not Found 449
Pages
  Default 450
Pagination 128
  controls 60, 62, 405
  links 405
Parent
  category 152
Partial
  reindex 908
Partial authorization 699
Partial invoices 696
partners, Magento 6
Password 112, 542
Patch
  install 942
Patch, revert 941
Pay Now button, PayPal 662
Paybox Direct 693
payment
  gateways 653
Payment
  Action, Order 676
  actions 620
  gateways 45, 691
  methods 45
  multiple cards 699
  options 42
  partial 699
  received 610
  Review, order status 612
  services 45
Payment actions 696
Payment Card Industry (PCI) 112
Payment Methods 637
  Authorize.Net 703
  BankTransfer Payment 639
  Cash on Delivery 641
  Check / Money Order 643
  Purchase Order 645
  Zero Subtotal Checkout 647
Payment Services 705
PayPal 651, 693
  Bill Me Later 652, 655
  business account 654
  Express Checkout 651-652, 663
    Billing Agreements 678
  Express Checkout, Order Transactions 676
  Express Checkout, save billing address 675
  Fraud Management Filters 687
  merchant solutions 42
  Payflow Link 686
  Payflow Pro 685
  Payments Advanced 658
  Payments Pro 660
  Payments Standard 662
  Settlement Report 682, 820
  solutions 688
  Website Payments Standard 662
PayPal Access 653
PayPal Credit 652, 655
PCI Compliance 112
Index

PDF  
  credit memo 629
  invoice 618

PDF Printouts 606

Pending  
  order status 610, 612, 623
  order, download product 210
  Payment, order status 612
  PayPal, order status 612
  Reviews 367, 369

Tags  
  moderate 357

Percona 10

Permanent  
  (301) 436
  Redirect 429, 441

Permissions  
  admin 877
  backup 934
  custom 880
  rollback 934
  server 14
  Server, recommended 954

Persistent  
  cookie 566
  shopping cart 566

PHP 10

Place Order 610

Placeholder image 220

PO 645

Poll 346-347
  Manager 351
  pop-ups, allow 535

Popular Search Terms 406

Popular Tags 347, 354
  report 821

Postal code, optional 73

Previous page link 128

Price 243-244
  adjustment 194
  attributes 258
  display 828
  display on gesture 245
  drill-down 134
  input type 156
  Minimum Advertised Price (MAP) 251
  navigation 130, 134
  package 250
  product group 258
  Range, bundle product 199
  Special 246
  Tier 247
  View, bundle product 199

Price consistency 771

Price Group, Product 257

Price Rule  
  Catalog 310, 315
  condition, attributes 170
  coupon 329
  promotions 338, 340
  Shopping Cart 317
Price Type
  Fixed 305
  Percentage 305

Print
  credit memo 629
  shipping labels 734

Privacy
  policy 113, 118, 448

Processing, order status 610, 612

Product
  Bundle 199
catalog 45
Configurable 189
create 177
data, export 868
Description
  HTML 171
Downloadable 179
file structure 860
Group Price 256, 258
Grouped 185
image cache 914
image, zoom 215
images 183, 209, 213, 218
Information 285
  Custom Options 304
Design 296
Inventory 263
Prices 243-244
list 142, 171
  by category 491
  markup tag 491
  new 491
  name 287
Price Group 257
ratings 44
relationships 301-303
return workflow 628
reviews 44, 367
  moderate 367, 369
  report 822
Rewrite 433, 437
Simple 180
suggestions 41
Tax class 758
type
  export 868
  Virtual 196

Product Alerts
  configuration 280
  run settings 283
Product Bestsellers, report 821
  product images 214
Product Images
  Import 870
  product list
  swatch 226
Product List 126
  product page
  swatch 226
Product Stock Options 262-263
Product tag
   by Admin 356
Product View Page, visible on 171
Products
   in Carts, report 820
   Ordered, report 821
   Tags, report 821
Profiles, Dataflow 870
Promotions 309
   Price Rules 338
Protx Standard 693
Provincial Sales Tax 796
PST 796
Publish
   page 453
Purchase Order 645

Q
QR code 329
Qty, update 576
Quantity
   Discount 247
   Increments 250, 267, 284
Quick Search 402
   attributes 170
Quick Simple Product Creation 192
Quick Tour 35

R
Rating, product 370
Recently Compared Products 470
Recently Viewed Products 365, 470
Record selection 60
Recurring Profile 290
   customer account 543
Redirect 433, 437, 441
   custom 440
   misspelled words 409
   type 435-436
URL 427
Redis 10
Refresh
   cache 914
   report data 819
   statistics 819
Refund 627
   offline 632
   online 632
Reindex 907
   events 910
   full 911
   manual 907
   partial 908
   required 907
Reindex Required 174
Related
   Products 301, 362
Remember Me, shopping cart 566, 568
Replace
   Complex Data 864
Report 815, 820
   Coupon Usage 334
export 817
newsletter 375
statistics, refresh 819
wishlist 360
Reports, menu 59
Request Path, redirect 431
Reset, password 542
Resource Access, Custom 931
Responsive Web Design (RWD) 529-530
REST roles 882
Return HTML Version 851
Return to Stock 630
Revert Patch 941
Reviews 346
delete 66
Reviews and Ratings 367, 369
Reward Points
product review 367
Rewrite
category 437
custom 441
product 433, 437
type 435-436, 441
Rewrites 22
RMA 43
robots.txt 391, 394, 519
Role
custom 880
Resources 881
Rollback 937
resources 934
Root
category 93, 137, 139, 143
RSS feed 44, 378
Run settings, product alerts 283
S

[STORE] 95
Sales
channels 377
email 77
email templates 854
menu 58
order 578, 611
Representative 76
Sample
page 448
Sample data 13
Samples
download 209
Saved CC 649
Schedule
recurring payment 293
Scheduled Jobs, cron 960
Scope 95, 167
global attribute 190
settings 96
Scripts
custom 932
Search
Admin 61
configure 408
default 408

global 61
quick 402
results 405
tools, storefront 401

Search engine
friendly URLs 417
optimization 38, 289, 413

Search Terms 66, 409
add 410
report 822

Security 112, 887, 895
systems 112
Security certificate 106
Security, best practices 887
Select
All 64
Visible 64
Selection, records 60
Sender Email 77
SEO 38, 413
SERP 289
Server
backup 934
rollback 934
Server Environment, security 888
Server Permissions, recommended 954
Service Unavailable 449
503 Service Unavailable 449
Session
cookie 116, 566

Session Validation 899
Set Product as New from/to Date 287
Settlement Report, PayPal Express
Checkout 682

SFTP
credentials, PayPal 683
user account, PayPal 682
Share account, Magento 32
Ship
Bundle Items 203
order 610
Shipment 611, 622

Shipping
bundle product 201
carriers 727
Dimensional weight 725
labels 738
options 42
packages 728
packing slip 624
rates
import 718
online 724
refund 629
Shipping Labels 42, 733
configure 735
create 734
Shipping Methods 46, 711, 714, 716, 718
Shipping Prices, tax 791
Shipping Settings 75, 712
Shop By 130
Index

Shopping
  cart
    thumbnails 187
  history 43
  tools 345
Shopping Cart
  Edit 576
  Mini 481
  persistent 566, 569
  price rule 317, 329, 338, 340
  thumbnails 195, 562
Shopping, Assisted 576
Show Actual Values, report 817-818
Sidebar, block reference 506
Simple Product 178
  create 180
Sitemap 38, 391, 415
SKU 286-287
  dynamic, bundle product 200
  in price rules 315
  multiple 315
  use of 189
Small Image 216-217, 219
Social
  marketing 380
  shopping 360
Software download 205
Solutions Partners, Magento 45
Sort 60
  attributes 170
  controls 62
product list 150
Sort By 405
Spain, PayPal solutions 688
Spam 372
Special Price 244, 246
Special Products, RSS feed 379
Split orders, PayPal Express Checkout 676
SSL 10, 22, 106
Staging environment 25
Startup Page
  Admin 813
State is required for 72
States Options 72
Static Block 474
  category page 141
Static URL 417
Status
  change 64
  product 286-287
Stock Availability 266, 268, 271
  catalog page 277
  Configurable Product 284
  product page 275
  scenarios 274
Stock, Manage 263
Storage
  configuration, media 921
Store
  code, in URL 417
  URL 50
Store Contact Information, variables 846
Index
class 758
  customer group 554
  VAT 785

Class, customer 760
class, price 245
class, product 758
Classes, configure 754
configuration 754
Discount Settings 806, 808
Display Settings, configure 756
permissions 880
rates
  VAT 785
  Rounding 790
  rules 767
  VAT 785
  Warning Messages 806

Tax as line item 791
Tax Calculation Methods 790
Tax Class, VAT 801
Tax Rate
  Point of Origin 712
Tax Rates
  Import 763
Tax Zones and Rates 761
Tax, Quick Reference 789
Template
  layout update, widget 471
tag 491
  variables 485
Templates, transactional email 850

Temporary (302) redirect 436, 441
Terms and Conditions 596
Test, payment gateway 695
Text
  Area, input type 156
  editor 455
  Field, input type 156
Theme 39, 529
  change 523, 532
  Package 524
Theme, default 530
Third-party
  applications 45, 931
Thumbnail 217-218, 562
  Image 214
    category 147
Tier Price 244, 247
Timezone 71
Top Level Category, RSS feed 379
Top Navigation
  Depth 138
Total
  Invoiced vs. Paid, report 820
  Ordered, report 820
  Refunded, report 820
  Shipped, report 820
Tracking
  number, shipping 619
Training 6
Transactional emails 348, 834
  templates 850
Transactional Emails
configuration 856
Transactions 611, 626
Translate
Field Labels 102
Page 103
Product Fields 101
Translate Store 97
Translations, cache 916
Trial period, recurring payment 292, 294
TVQ 796
Twitter 7, 380

U
UI Text 535
Under construction 88
Unique Value, attribute property 165
United Kingdom, PayPal solutions 688
United States, PayPal solutions 688
Unselect
All 64
Visible 64
Up-sell products 302, 362
Update Attributes 65
Update Magento 25, 926
UPS 727
shipping labels 737
shipping packages 730
URL
category path 418
custom 38
dynamic 417
Key 288, 417
category 146
page 451
Key, category 147
options 417
redirect 427
rewrite 427
static 417
store code 417
suffix 288, 417
Use
Default checkbox 96
for Promo Rule Conditions 166, 171
Parent Category Settings 151
to Create Configurable Product 190
Use in Layered Navigation
swatch 228
Use Secure URLs (SSL) 106
User
guides 4
User guides 4
User Role, Admin 879
USPS 727
shipping labels 737
shipping packages 731

V
Value Added Tax 753, 779
Values Required 165
var/backups 934
var/cache 913
Variables 485-486, 488
    email 837, 841
    Store Contact Information 846
VAT 779
    ID location 787
VAT Tax Class 801
VAT Validation 784
    configure 785
Verified by VISA 706
View
    product 183, 207
View As 405
Virtual
    Product 178, 196
VISA, Verified by 706
Visibility
    product 288
Visible on Product View Page 166
Void transaction 697

W

[WEBSITE] 95
Watermark 221
Web server
    synchronization 920
Web Services 882, 929-930
    Configuration, cache 916
Webinars 4, 7
Websites
    multiple 91
    product 299
WEEE tax 772
Weight
    Bundle Product 203
    dynamic, bundle product 200
    product 286-287
Weight, dimensional 725
Welcome 3
    message 87, 520
    message, block 513
White list 374
Whitelist, Developer 535
Widget 459, 469, 471, 481, 492
    add to page 459
    CMS Static Block 474
    code 492
    email 837, 841
    New Products 478
Wiki 4
Wishlist 346, 360, 544
    in RSS feed 379
    Reports 360
Workflow
    order 612, 615
    Product Return 628
WS-I 930
WYSIWYG Editor 455
    enable 156
    enable for input 171
X

XML 505, 507

Y

Yes, checkbox 65
Yes/No, input type 156
YouTube 7

Z

Zend Full Page Cache 917
Zero Subtotal Checkout 647
Zones, tax 761
Zoom, product image 215